/[gentoo-x86]/eclass/haskell-cabal.eclass
Gentoo

Diff of /eclass/haskell-cabal.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.27 Revision 1.30
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/haskell-cabal.eclass,v 1.27 2012/02/07 12:47:54 slyfox Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/haskell-cabal.eclass,v 1.30 2012/04/14 19:30:53 slyfox Exp $
4 4
5# @ECLASS: haskell-cabal.eclass 5# @ECLASS: haskell-cabal.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Haskell herd <haskell@gentoo.org> 7# Haskell herd <haskell@gentoo.org>
8# @AUTHOR: 8# @AUTHOR:
28# bin -- the package installs binaries 28# bin -- the package installs binaries
29# lib -- the package installs libraries 29# lib -- the package installs libraries
30# nocabaldep -- don't add dependency on cabal. 30# nocabaldep -- don't add dependency on cabal.
31# only used for packages that _must_ not pull the dependency 31# only used for packages that _must_ not pull the dependency
32# on cabal, but still use this eclass (e.g. haskell-updater). 32# on cabal, but still use this eclass (e.g. haskell-updater).
33#
34# Dependencies on other cabal packages have to be specified
35# correctly.
36#
37# Cabal libraries should usually be SLOTted with "${PV}".
38#
39# Many Cabal packages require S to be manually set.
40#
41# Conforming Cabal packages don't require any function definitions
42# in the ebuild.
43#
44# Special flags to Cabal Configure can now be set by using
45# CABAL_CONFIGURE_FLAGS
46 33
47inherit ghc-package multilib 34inherit ghc-package multilib
48 35
49# @ECLASS-VARIABLE: CABAL_EXTRA_CONFIGURE_FLAGS 36# @ECLASS-VARIABLE: CABAL_EXTRA_CONFIGURE_FLAGS
50# @DESCRIPTION: 37# @DESCRIPTION:
93 esac 80 esac
94done 81done
95 82
96if [[ -n "${CABAL_USE_HADDOCK}" ]]; then 83if [[ -n "${CABAL_USE_HADDOCK}" ]]; then
97 IUSE="${IUSE} doc" 84 IUSE="${IUSE} doc"
98 DEPEND="${DEPEND} doc? ( dev-haskell/haddock )" 85 # don't require depend on itself to build docs.
86 # ebuild bootstraps docs from just built binary
87 [[ ${CATEGORY}/${PN} = "dev-haskell/haddock" ]] || DEPEND="${DEPEND} doc? ( dev-haskell/haddock )"
99fi 88fi
100 89
101if [[ -n "${CABAL_USE_HSCOLOUR}" ]]; then 90if [[ -n "${CABAL_USE_HSCOLOUR}" ]]; then
102 IUSE="${IUSE} hscolour" 91 IUSE="${IUSE} hscolour"
103 DEPEND="${DEPEND} hscolour? ( dev-haskell/hscolour )" 92 DEPEND="${DEPEND} hscolour? ( dev-haskell/hscolour )"
161cabal-bootstrap() { 150cabal-bootstrap() {
162 local setupmodule 151 local setupmodule
163 local cabalpackage 152 local cabalpackage
164 if [[ -f "${S}/Setup.lhs" ]]; then 153 if [[ -f "${S}/Setup.lhs" ]]; then
165 setupmodule="${S}/Setup.lhs" 154 setupmodule="${S}/Setup.lhs"
166 else
167 if [[ -f "${S}/Setup.hs" ]]; then 155 elif [[ -f "${S}/Setup.hs" ]]; then
168 setupmodule="${S}/Setup.hs" 156 setupmodule="${S}/Setup.hs"
169 else 157 else
170 die "No Setup.lhs or Setup.hs found" 158 die "No Setup.lhs or Setup.hs found"
171 fi
172 fi 159 fi
173 160
174 # We build the setup program using the latest version of 161 # We build the setup program using the latest version of
175 # cabal that we have installed 162 # cabal that we have installed
176 if version_is_at_least "6.4" "$(ghc-version)"; then
177 cabalpackage=Cabal-$(cabal-version) 163 cabalpackage=Cabal-$(cabal-version)
178 else
179 # older ghc's don't support package versioning
180 cabalpackage=Cabal
181 fi
182 einfo "Using cabal-$(cabal-version)." 164 einfo "Using cabal-$(cabal-version)."
183 165
184 make_setup() { 166 make_setup() {
185 set -- -package "${cabalpackage}" --make "${setupmodule}" \ 167 set -- -package "${cabalpackage}" --make "${setupmodule}" \
186 ${GHC_BOOTSTRAP_FLAGS} \ 168 ${GHC_BOOTSTRAP_FLAGS} \
188 -o setup 170 -o setup
189 echo $(ghc-getghc) ${HCFLAGS} "$@" 171 echo $(ghc-getghc) ${HCFLAGS} "$@"
190 $(ghc-getghc) "$@" 172 $(ghc-getghc) "$@"
191 } 173 }
192 if $(ghc-supports-shared-libraries); then 174 if $(ghc-supports-shared-libraries); then
193 # some custom build systems might use external libraries, 175 # # some custom build systems might use external libraries,
194 # for which we don't have shared libs, so keep static fallback 176 # # for which we don't have shared libs, so keep static fallback
177 # Disabled '-dynamic' as ghc does not embed RPATH to used extra-libraries:
178 # bug #411789, http://hackage.haskell.org/trac/ghc/ticket/5743#comment:3
179 # make_setup -dynamic "$@" ||
195 make_setup -dynamic "$@" || make_setup "$@" || die "compiling ${setupmodule} failed" 180 make_setup "$@" || die "compiling ${setupmodule} failed"
196 else 181 else
197 make_setup "$@" || die "compiling ${setupmodule} failed" 182 make_setup "$@" || die "compiling ${setupmodule} failed"
198 fi 183 fi
199} 184}
200 185
208 fi 193 fi
209 194
210 rm -f "${setupdir}"/Setup.{lhs,hs} 195 rm -f "${setupdir}"/Setup.{lhs,hs}
211 196
212 echo 'import Distribution.Simple; main = defaultMainWithHooks defaultUserHooks' \ 197 echo 'import Distribution.Simple; main = defaultMainWithHooks defaultUserHooks' \
213 > $setupdir/Setup.hs 198 > $setupdir/Setup.hs || die "failed to create default Setup.hs"
214} 199}
215 200
216cabal-hscolour() { 201cabal-hscolour() {
217 set -- hscolour "$@" 202 set -- hscolour "$@"
218 echo ./setup "$@" 203 echo ./setup "$@"
270 # currently cabal does not respect CFLAGS and LDFLAGS on it's own (bug #333217) 255 # currently cabal does not respect CFLAGS and LDFLAGS on it's own (bug #333217)
271 # so translate LDFLAGS to ghc parameters (without filtering) 256 # so translate LDFLAGS to ghc parameters (without filtering)
272 local flag 257 local flag
273 for flag in $LDFLAGS; do cabalconf="${cabalconf} --ghc-option=-optl$flag"; done 258 for flag in $LDFLAGS; do cabalconf="${cabalconf} --ghc-option=-optl$flag"; done
274 259
275 if version_is_at_least "1.4" "$(cabal-version)"; then
276 # disable executable stripping for the executables, as portage will 260 # disable executable stripping for the executables, as portage will
277 # strip by itself, and pre-stripping gives a QA warning. 261 # strip by itself, and pre-stripping gives a QA warning.
278 # cabal versions previous to 1.4 does not strip executables, and does 262 # cabal versions previous to 1.4 does not strip executables, and does
279 # not accept the flag. 263 # not accept the flag.
280 # this fixes numerous bugs, amongst them; 264 # this fixes numerous bugs, amongst them;
281 # bug #251881, bug #251882, bug #251884, bug #251886, bug #299494 265 # bug #251881, bug #251882, bug #251884, bug #251886, bug #299494
282 cabalconf="${cabalconf} --disable-executable-stripping" 266 cabalconf="${cabalconf} --disable-executable-stripping"
283 fi
284 267
285 if version_is_at_least "1.2.0" "$(cabal-version)"; then
286 cabalconf="${cabalconf} --docdir=${EPREFIX}/usr/share/doc/${PF}" 268 cabalconf="${cabalconf} --docdir=${EPREFIX}/usr/share/doc/${PF}"
287 # As of Cabal 1.2, configure is quite quiet. For diagnostic purposes 269 # As of Cabal 1.2, configure is quite quiet. For diagnostic purposes
288 # it's better if the configure chatter is in the build logs: 270 # it's better if the configure chatter is in the build logs:
289 cabalconf="${cabalconf} --verbose" 271 cabalconf="${cabalconf} --verbose"
290 fi
291 # Note: with Cabal-1.1.6.x we do not have enough control
292 # to put the docs into the right place. They're currently going
293 # into /usr/share/${P}/ghc-x.y/doc/
294 # rather than /usr/share/doc/${PF}/
295 # Because we can only set the datadir, not the docdir.
296 272
297 # We build shared version of our Cabal where ghc ships it's shared 273 # We build shared version of our Cabal where ghc ships it's shared
298 # version of it. We will link ./setup as dynamic binary againt Cabal later. 274 # version of it. We will link ./setup as dynamic binary againt Cabal later.
299 [[ ${CATEGORY}/${PN} == "dev-haskell/cabal" ]] && \ 275 [[ ${CATEGORY}/${PN} == "dev-haskell/cabal" ]] && \
300 $(ghc-supports-shared-libraries) && \ 276 $(ghc-supports-shared-libraries) && \
333 ./setup "$@" || die "setup copy failed" 309 ./setup "$@" || die "setup copy failed"
334 310
335 # cabal is a bit eager about creating dirs, 311 # cabal is a bit eager about creating dirs,
336 # so remove them if they are empty 312 # so remove them if they are empty
337 rmdir "${ED}/usr/bin" 2> /dev/null 313 rmdir "${ED}/usr/bin" 2> /dev/null
338
339 # GHC 6.4 has a bug in get/setPermission and Cabal 1.1.1 has
340 # no workaround.
341 # set the +x permission on executables
342 if [[ -d "${ED}/usr/bin" ]] ; then
343 chmod +x "${ED}/usr/bin/"*
344 fi
345 # TODO: do we still need this?
346} 314}
347 315
348cabal-pkg() { 316cabal-pkg() {
349 # This does not actually register since we're using true instead 317 # This does not actually register since we're using true instead
350 # of ghc-pkg. So it just leaves the .installed-pkg-config and we can 318 # of ghc-pkg. So it just leaves the .conf file and we can
351 # register that ourselves (if it exists). 319 # register that ourselves (if it exists).
352 local result
353 local err
354 320
355 if [[ -n ${CABAL_HAS_LIBRARIES} ]]; then 321 if [[ -n ${CABAL_HAS_LIBRARIES} ]]; then
356 if version_is_at_least "1.2.0" "$(cabal-version)"; then
357 # Newer cabal can generate a package conf for us: 322 # Newer cabal can generate a package conf for us:
358 ./setup register --gen-pkg-config="${T}/${P}.conf" 323 ./setup register --gen-pkg-config="${T}/${P}.conf"
359 ghc-setup-pkg "${T}/${P}.conf" 324 ghc-setup-pkg "${T}/${P}.conf"
360 ghc-install-pkg 325 ghc-install-pkg
361 else
362 # With older cabal we have to hack it by replacing its ghc-pkg
363 # with true and then just picking up the .installed-pkg-config
364 # file and registering that ourselves (if it exists).
365 sed -i "s|$(ghc-getghcpkg)|$(type -P true)|" .setup-config
366 ./setup register || die "setup register failed"
367 if [[ -f .installed-pkg-config ]]; then
368 ghc-setup-pkg .installed-pkg-config
369 ghc-install-pkg
370 else
371 die "setup register has not generated a package configuration file"
372 fi
373 fi
374 fi 326 fi
375} 327}
376 328
377# Some cabal libs are bundled along with some versions of ghc 329# Some cabal libs are bundled along with some versions of ghc
378# eg filepath-1.0 comes with ghc-6.6.1 330# eg filepath-1.0 comes with ghc-6.6.1
390} 342}
391 343
392# exported function: check if cabal is correctly installed for 344# exported function: check if cabal is correctly installed for
393# the currently active ghc (we cannot guarantee this with portage) 345# the currently active ghc (we cannot guarantee this with portage)
394haskell-cabal_pkg_setup() { 346haskell-cabal_pkg_setup() {
395 ghc-package_pkg_setup
396 if [[ -z "${CABAL_BOOTSTRAP}" && -z "${CABAL_FROM_GHC}" ]] && ! ghc-sanecabal "${CABAL_MIN_VERSION}"; then 347 if [[ -z "${CABAL_BOOTSTRAP}" && -z "${CABAL_FROM_GHC}" ]] && ! ghc-sanecabal "${CABAL_MIN_VERSION}"; then
397 eerror "The package dev-haskell/cabal is not correctly installed for" 348 eerror "The package dev-haskell/cabal is not correctly installed for"
398 eerror "the currently active version of ghc ($(ghc-version)). Please" 349 eerror "the currently active version of ghc ($(ghc-version)). Please"
399 eerror "run ghc-updater or haskell-updater or re-build dev-haskell/cabal." 350 eerror "run haskell-updater or re-build dev-haskell/cabal."
400 die "cabal is not correctly installed" 351 die "cabal is not correctly installed"
401 fi 352 fi
402 if [[ -z "${CABAL_HAS_BINARIES}" ]] && [[ -z "${CABAL_HAS_LIBRARIES}" ]]; then 353 if [[ -z "${CABAL_HAS_BINARIES}" ]] && [[ -z "${CABAL_HAS_LIBRARIES}" ]]; then
403 eerror "QA: Neither bin nor lib are in CABAL_FEATURES." 354 eqawarn "QA Notice: Neither bin nor lib are in CABAL_FEATURES."
404 fi 355 fi
405 if [[ -n "${CABAL_UNKNOWN}" ]]; then 356 if [[ -n "${CABAL_UNKNOWN}" ]]; then
406 ewarn "Unknown entry in CABAL_FEATURES: ${CABAL_UNKNOWN}" 357 eqawarn "QA Notice: Unknown entry in CABAL_FEATURES: ${CABAL_UNKNOWN}"
407 fi 358 fi
408 if cabal-is-dummy-lib; then 359 if cabal-is-dummy-lib; then
409 einfo "${P} is included in ghc-${CABAL_CORE_LIB_GHC_PV}, nothing to install." 360 einfo "${P} is included in ghc-${CABAL_CORE_LIB_GHC_PV}, nothing to install."
410 fi 361 fi
411} 362}
412 363
413haskell-cabal_src_configure() { 364haskell-cabal_src_configure() {
414 if ! cabal-is-dummy-lib; then 365 cabal-is-dummy-lib && return
366
415 pushd "${S}" > /dev/null 367 pushd "${S}" > /dev/null
416 368
417 cabal-bootstrap 369 cabal-bootstrap
418 370
419 cabal-configure "$@" 371 cabal-configure "$@"
420 372
421 popd > /dev/null 373 popd > /dev/null
422 fi
423} 374}
424 375
425# exported function: nice alias 376# exported function: nice alias
426cabal_src_configure() { 377cabal_src_configure() {
427 haskell-cabal_src_configure "$@" 378 haskell-cabal_src_configure "$@"
434 # Such error leads to default src_configure and we lose all passed flags. 385 # Such error leads to default src_configure and we lose all passed flags.
435 if ! has "${EAPI:-0}" 0 1; then 386 if ! has "${EAPI:-0}" 0 1; then
436 local passed_flag 387 local passed_flag
437 for passed_flag in "$@"; do 388 for passed_flag in "$@"; do
438 [[ ${passed_flag} == --flags=* ]] && \ 389 [[ ${passed_flag} == --flags=* ]] && \
439 eqawarn "Cabal option '${passed_flag}' has effect only in src_configure()" 390 eqawarn "QA Notice: Cabal option '${passed_flag}' has effect only in src_configure()"
440 done 391 done
441 fi 392 fi
442 393
443 if ! cabal-is-dummy-lib; then 394 cabal-is-dummy-lib && return
395
444 has src_configure ${HASKELL_CABAL_EXPF} || haskell-cabal_src_configure "$@" 396 has src_configure ${HASKELL_CABAL_EXPF} || haskell-cabal_src_configure "$@"
445 cabal-build 397 cabal-build
446 398
447 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then 399 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
448 if [[ -n "${CABAL_USE_HSCOLOUR}" ]] && use hscolour; then 400 if [[ -n "${CABAL_USE_HSCOLOUR}" ]] && use hscolour; then
449 # hscolour and haddock 401 # hscolour and haddock
450 cabal-hscolour-haddock 402 cabal-hscolour-haddock
451 else
452 # just haddock
453 cabal-haddock
454 fi
455 else 403 else
404 # just haddock
405 cabal-haddock
406 fi
407 else
456 if [[ -n "${CABAL_USE_HSCOLOUR}" ]] && use hscolour; then 408 if [[ -n "${CABAL_USE_HSCOLOUR}" ]] && use hscolour; then
457 # just hscolour 409 # just hscolour
458 cabal-hscolour 410 cabal-hscolour
459 fi
460 fi 411 fi
461 fi 412 fi
462} 413}
463 414
464haskell-cabal_src_compile() { 415haskell-cabal_src_compile() {
486 437
487# exported function: cabal-style copy and register 438# exported function: cabal-style copy and register
488cabal_src_install() { 439cabal_src_install() {
489 has "${EAPI:-0}" 0 1 2 && ! use prefix && EPREFIX= 440 has "${EAPI:-0}" 0 1 2 && ! use prefix && EPREFIX=
490 441
491 if cabal-is-dummy-lib; then 442 if ! cabal-is-dummy-lib; then
492 # create a dummy local package conf file for the sake of ghc-updater
493 local ghc_confdir_with_prefix="$(ghc-confdir)"
494 # remove EPREFIX
495 dodir ${ghc_confdir_with_prefix#${EPREFIX}}
496 echo '[]' > "${D}/$(ghc-confdir)/$(ghc-localpkgconf)"
497 else
498 cabal-copy 443 cabal-copy
499 cabal-pkg 444 cabal-pkg
500
501 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
502 if ! version_is_at_least "1.1.6" "$(cabal-version)"; then
503 dohtml -r dist/doc/html/*
504 fi
505 fi 445 fi
506 fi 446
447 # create a dummy local package conf file for haskell-updater
448 # if it does not exist (dummy libraries and binaries w/o libraries)
449 local ghc_confdir_with_prefix="$(ghc-confdir)"
450 # remove EPREFIX
451 dodir ${ghc_confdir_with_prefix#${EPREFIX}}
452 local conf_file="${D}/$(ghc-confdir)/$(ghc-localpkgconf)"
453 [[ -e $conf_file ]] || echo '[]' > "$conf_file" || die
507} 454}
508 455
509haskell-cabal_src_install() { 456haskell-cabal_src_install() {
510 pushd "${S}" > /dev/null 457 pushd "${S}" > /dev/null
511 458

Legend:
Removed from v.1.27  
changed lines
  Added in v.1.30

  ViewVC Help
Powered by ViewVC 1.1.20