/[gentoo-x86]/eclass/java-vm-2.eclass
Gentoo

Diff of /eclass/java-vm-2.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.11 Revision 1.33
1# Copyright 1999-2004 Gentoo Foundation 1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/java-vm-2.eclass,v 1.11 2006/09/10 20:59:11 betelgeuse Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/java-vm-2.eclass,v 1.33 2011/09/01 14:15:57 caster Exp $
4 4
5# ----------------------------------------------------------------------------- 5# -----------------------------------------------------------------------------
6# @eclass-begin 6# @eclass-begin
7# @eclass-shortdesc Java Virtual Machine eclass 7# @eclass-shortdesc Java Virtual Machine eclass
8# @eclass-maintainer java@gentoo.org 8# @eclass-maintainer java@gentoo.org
10# This eclass provides functionality which assists with installing 10# This eclass provides functionality which assists with installing
11# virtual machines, and ensures that they are recognized by java-config. 11# virtual machines, and ensures that they are recognized by java-config.
12# 12#
13# ----------------------------------------------------------------------------- 13# -----------------------------------------------------------------------------
14 14
15inherit eutils 15inherit eutils fdo-mime multilib prefix
16 16
17DEPEND="
18 =dev-java/java-config-2.0* 17DEPEND="=dev-java/java-config-2*"
19 >=sys-apps/portage-2.1" 18has "${EAPI}" 0 1 && DEPEND="${DEPEND} >=sys-apps/portage-2.1"
19
20RDEPEND=" 20RDEPEND="
21 =dev-java/java-config-2.0*" 21 =dev-java/java-config-2*"
22
23# If the VM supports generation-1, we need to depend on java-config-1
24if [[ ${JAVA_SUPPORTS_GENERATION_1} == 'true' ]]; then
25 DEPEND="${DEPEND} =dev-java/java-config-1.3*"
26 RDEPEND="${RDEPEND} =dev-java/java-config-1.3*"
27fi
28 22
29export WANT_JAVA_CONFIG=2 23export WANT_JAVA_CONFIG=2
30
31if [[ "${SLOT}" != "0" ]]; then
32 VMHANDLE=${PN}-${SLOT}
33else
34 VMHANDLE=${PN}
35fi
36 24
37JAVA_VM_CONFIG_DIR="/usr/share/java-config-2/vm" 25JAVA_VM_CONFIG_DIR="/usr/share/java-config-2/vm"
38JAVA_VM_DIR="/usr/lib/jvm" 26JAVA_VM_DIR="/usr/lib/jvm"
27JAVA_VM_BUILD_ONLY="${JAVA_VM_BUILD_ONLY:-FALSE}"
39 28
40EXPORT_FUNCTIONS pkg_postinst pkg_prerm 29EXPORT_FUNCTIONS pkg_setup pkg_postinst pkg_prerm pkg_postrm
30
31java-vm-2_pkg_setup() {
32 if [[ "${SLOT}" != "0" ]]; then
33 VMHANDLE=${PN}-${SLOT}
34 else
35 VMHANDLE=${PN}
36 fi
37}
41 38
42java-vm-2_pkg_postinst() { 39java-vm-2_pkg_postinst() {
43 # Set the generation-2 system VM, if it isn't set 40 # Set the generation-2 system VM, if it isn't set
44 if [[ -z "$(java-config-2 -f)" ]]; then 41 if [[ -z "$(java-config-2 -f)" ]]; then
45 java_set_default_vm_ 42 java_set_default_vm_
46 fi 43 fi
47 44
48 # support both variables for now 45 java-vm_check-nsplugin
49 if [[ ${JAVA_SUPPORTS_GENERATION_1} == 'true' && ${JAVA_VM_NO_GENERATION1} != 'true' ]]; then 46 java_mozilla_clean_
50 local systemvm1="$(java-config-1 -f 2>/dev/null)" 47 fdo-mime_desktop_database_update
51 # no generation-1 system-vm was previously set 48}
52 if [[ -z "${systemvm1}" ]]; then 49
53 # if 20java exists, must be using old VM 50java-vm_check-nsplugin() {
54 if [[ -f /etc/env.d/20java ]]; then 51 local libdir
55 ewarn "The current generation-1 system-vm is using an out-of-date VM," 52 if [[ ${VMHANDLE} =~ emul-linux-x86 ]]; then
56 ewarn "as in, it hasn't been updated for use with the new Java sytem." 53 libdir=lib32
57 # othewise, it must not have been set before
58 else 54 else
59 ewarn "No generation-1 system-vm previously set." 55 libdir=lib
60 fi
61 ewarn "Setting generation-1 system-vm to ${VMHANDLE}"
62 java-config-1 --set-system-vm=${P} 2>/dev/null
63 # dirty check to see if we are upgrading current generation-1 system vm
64 elif [[ "${systemvm1}" = ${VMHANDLE}* ]]; then
65 einfo "Emerging the current generation-1 system-vm..."
66 einfo "Updating its config files."
67 java-config-1 --set-system-vm=${P} 2>/dev/null
68 # dirty check to see if current system vm is a jre - replace it with
69 elif [[ "${systemvm1}" = *jre* ]]; then
70 ewarn "Current generation-1 system-vm is a JRE"
71 ewarn "For the new and old Java systems to coexist,"
72 ewarn "the generation-1 system-vm must be a JDK."
73 ewarn "Setting generation-1 system-vm to ${VMHANDLE}"
74 java-config-1 --set-system-vm=${P} 2>/dev/null
75 fi 56 fi
76 # else... some other VM is being updated, so we don't have to worry 57
77 else 58 has ${EAPI:-0} 0 1 2 && ! use prefix && EPREFIX=
78 einfo "JREs and 1.5+ JDKs are not supported for use with generation-1."
79 einfo "This is because generation-1 is only for use for building packages."
80 einfo "Only generation-2 should be used by end-users,"
81 einfo "where all JREs and JDKs will be available"
82 fi
83 59
84 # Install a default nsplugin if we don't already have one 60 # Install a default nsplugin if we don't already have one
85 if has nsplugin ${IUSE} && use nsplugin; then 61 if has nsplugin ${IUSE} && use nsplugin; then
86 if [[ ! -f /usr/lib/nsbrowser/plugins/javaplugin.so ]]; then 62 if [[ ! -f "${EPREFIX}"/usr/${libdir}/nsbrowser/plugins/javaplugin.so ]]; then
87 eselect java-nsplugin set ${VMHANDLE} 63 einfo "No system nsplugin currently set."
64 java-vm_set-nsplugin
65 else
66 einfo "System nsplugin is already set, not changing it."
88 fi 67 fi
68 einfo "You can change nsplugin with eselect java-nsplugin."
69 fi
70}
71
72java-vm_set-nsplugin() {
73 local extra_args
74 if use amd64; then
75 if [[ ${VMHANDLE} =~ emul-linux-x86 ]]; then
76 extra_args="32bit"
77 else
78 extra_args="64bit"
89 fi 79 fi
90 80 einfo "Setting ${extra_args} nsplugin to ${VMHANDLE}"
91 java_mozilla_clean_ 81 else
82 einfo "Setting nsplugin to ${VMHANDLE}..."
83 fi
84 eselect java-nsplugin set ${extra_args} ${VMHANDLE}
92} 85}
93 86
94java-vm-2_pkg_prerm() { 87java-vm-2_pkg_prerm() {
95 if [[ "$(java-config -f 2>/dev/null)" == "${VMHANDLE}" ]]; then 88 if [[ "$(java-config -f 2>/dev/null)" == "${VMHANDLE}" ]]; then
96 ewarn "It appears you are removing your system-vm!" 89 ewarn "It appears you are removing your system-vm!"
97 ewarn "Please run java-config -L to list available VMs," 90 ewarn "Please run java-config -L to list available VMs,"
98 ewarn "then use java-config -S to set a new system-vm!" 91 ewarn "then use java-config -S to set a new system-vm!"
99 fi 92 fi
100} 93}
101 94
95java-vm-2_pkg_postrm() {
96 fdo-mime_desktop_database_update
97}
98
102java_set_default_vm_() { 99java_set_default_vm_() {
103 java-config-2 --set-system-vm="${VMHANDLE}" 100 java-config-2 --set-system-vm="${VMHANDLE}"
104 101
105 einfo " ${P} set as the default system-vm." 102 einfo " ${P} set as the default system-vm."
106} 103}
114 echo ${sarch} 111 echo ${sarch}
115} 112}
116 113
117# TODO rename to something more evident, like install_env_file 114# TODO rename to something more evident, like install_env_file
118set_java_env() { 115set_java_env() {
116 debug-print-function ${FUNCNAME} $*
117
118 has ${EAPI:-0} 0 1 2 && ! use prefix && ED="${D}"
119
119 local platform="$(get_system_arch)" 120 local platform="$(get_system_arch)"
120 local env_file="${D}${JAVA_VM_CONFIG_DIR}/${VMHANDLE}" 121 local env_file="${ED}${JAVA_VM_CONFIG_DIR}/${VMHANDLE}"
121 local old_env_file="${D}/etc/env.d/java/20${P}" 122 local old_env_file="${ED}/etc/env.d/java/20${P}"
123 if [[ ${1} ]]; then
124 local source_env_file="${1}"
125 else
122 local source_env_file="${FILESDIR}/${VMHANDLE}.env" 126 local source_env_file="${FILESDIR}/${VMHANDLE}.env"
127 fi
123 128
124 if [[ ! -f ${source_env_file} ]]; then 129 if [[ ! -f ${source_env_file} ]]; then
125 die "Unable to find the env file: ${source_env_file}" 130 die "Unable to find the env file: ${source_env_file}"
126 fi 131 fi
127 132
130 -e "s/@P@/${P}/g" \ 135 -e "s/@P@/${P}/g" \
131 -e "s/@PN@/${PN}/g" \ 136 -e "s/@PN@/${PN}/g" \
132 -e "s/@PV@/${PV}/g" \ 137 -e "s/@PV@/${PV}/g" \
133 -e "s/@PF@/${PF}/g" \ 138 -e "s/@PF@/${PF}/g" \
134 -e "s/@PLATFORM@/${platform}/g" \ 139 -e "s/@PLATFORM@/${platform}/g" \
140 -e "s/@LIBDIR@/$(get_libdir)/g" \
135 -e "/^LDPATH=.*lib\\/\\\"/s|\"\\(.*\\)\"|\"\\1${platform}/:\\1${platform}/server/\"|" \ 141 -e "/^LDPATH=.*lib\\/\\\"/s|\"\\(.*\\)\"|\"\\1${platform}/:\\1${platform}/server/\"|" \
136 < ${source_env_file} \ 142 < "${source_env_file}" \
137 > ${env_file} || die "sed failed" 143 > "${env_file}" || die "sed failed"
138 144
145 (
139 echo "VMHANDLE=\"${VMHANDLE}\"" >> ${env_file} 146 echo "VMHANDLE=\"${VMHANDLE}\""
140 147 echo "BUILD_ONLY=\"${JAVA_VM_BUILD_ONLY}\""
141 # generation-1 compatibility 148 ) >> "${env_file}"
142 # respect both variables for now... 149
143 if [[ ${JAVA_SUPPORTS_GENERATION_1} == 'true' && ${JAVA_VM_NO_GENERATION1} != 'true' ]]; then 150 eprefixify ${env_file}
144 einfo "Enabling generation-1 compatibility..."
145 dodir /etc/env.d/java # generation-1 compatibility
146 # We need to strip some things out of the new style env,
147 # because these end up going in the env
148 sed -e 's/.*CLASSPATH.*//' \
149 -e 's/.*PROVIDES.*//' \
150 ${env_file} \
151 > ${old_env_file} || die "failed to create generation-1 env file"
152 else
153 ewarn "Disabling generation-1 compatibility..."
154 fi
155 151
156 [[ -n ${JAVA_PROVIDE} ]] && echo "PROVIDES=\"${JAVA_PROVIDE}\"" >> ${env_file} 152 [[ -n ${JAVA_PROVIDE} ]] && echo "PROVIDES=\"${JAVA_PROVIDE}\"" >> ${env_file}
157 153
158 local java_home=$(source ${env_file}; echo ${JAVA_HOME}) 154 local java_home=$(source "${env_file}"; echo ${JAVA_HOME})
159 [[ -z ${java_home} ]] && die "No JAVA_HOME defined in ${env_file}" 155 [[ -z ${java_home} ]] && die "No JAVA_HOME defined in ${env_file}"
160 156
161 # Make the symlink 157 # Make the symlink
158 dodir "${JAVA_VM_DIR}"
162 dosym ${java_home} ${JAVA_VM_DIR}/${VMHANDLE} \ 159 dosym ${java_home} ${JAVA_VM_DIR}/${VMHANDLE} \
163 || die "Failed to make VM symlink at ${JAVA_VM_DIR}/${VMHANDLE}" 160 || die "Failed to make VM symlink at ${JAVA_VM_DIR}/${VMHANDLE}"
164} 161}
165 162
163# -----------------------------------------------------------------------------
164# @ebuild-function java-vm_revdep-mask
165#
166# Installs a revdep-rebuild control file which SEARCH_DIR_MASK set to the path
167# where the VM is installed. Prevents pointless rebuilds - see bug #177925.
168# Also gives a notice to the user.
169#
170# @example
171# java-vm_revdep-mask
172# java-vm_revdep-mask /path/to/jdk/
173#
174# @param $1 - Path of the VM (defaults to /opt/${P} if not set)
175# ------------------------------------------------------------------------------
176java-vm_revdep-mask() {
177 if has ${EAPI:-0} 0 1 2 && ! use prefix; then
178 ED="${D}"
179 EPREFIX=
180 fi
181
182 local VMROOT="${1-"${EPREFIX}"/opt/${P}}"
183
184 dodir /etc/revdep-rebuild/
185 echo "SEARCH_DIRS_MASK=\"${VMROOT}\""> "${ED}/etc/revdep-rebuild/61-${VMHANDLE}"
186
187 elog "A revdep-rebuild control file was installed to prevent reinstalls due to"
188 elog "missing dependencies (see bug #177925 for more info). Note that some parts"
189 elog "of the JVM may require dependencies that are pulled only through respective"
190 elog "USE flags (typically X, alsa, odbc) and some Java code may fail without them."
191}
166 192
167java_get_plugin_dir_() { 193java_get_plugin_dir_() {
194 has ${EAPI:-0} 0 1 2 && ! use prefix && EPREFIX=
168 echo /usr/$(get_libdir)/nsbrowser/plugins 195 echo "${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins
169} 196}
170 197
171install_mozilla_plugin() { 198install_mozilla_plugin() {
172 local plugin=${1} 199 local plugin="${1}"
200 local variant="${2}"
173 201
202 has ${EAPI:-0} 0 1 2 && ! use prefix && ED="${D}"
174 if [ ! -f "${D}/${plugin}" ] ; then 203 if [[ ! -f "${ED}/${plugin}" ]]; then
175 die "Cannot find mozilla plugin at ${D}/${plugin}" 204 die "Cannot find mozilla plugin at ${ED}/${plugin}"
176 fi 205 fi
177 206
207 if [[ -n "${variant}" ]]; then
208 variant="-${variant}"
209 fi
210
178 local plugin_dir=/usr/share/java-config-2/nsplugin 211 local plugin_dir="/usr/share/java-config-2/nsplugin"
179 dodir ${plugin_dir} 212 dodir "${plugin_dir}"
180 dosym ${plugin} ${plugin_dir}/${VMHANDLE}-javaplugin.so 213 dosym "${plugin}" "${plugin_dir}/${VMHANDLE}${variant}-javaplugin.so"
181} 214}
182 215
183java_mozilla_clean_() { 216java_mozilla_clean_() {
184 # Because previously some ebuilds installed symlinks outside of pkg_install 217 # Because previously some ebuilds installed symlinks outside of pkg_install
185 # and are left behind, which forces you to manualy remove them to select the 218 # and are left behind, which forces you to manualy remove them to select the

Legend:
Removed from v.1.11  
changed lines
  Added in v.1.33

  ViewVC Help
Powered by ViewVC 1.1.20