/[gentoo-x86]/eclass/java-vm-2.eclass
Gentoo

Contents of /eclass/java-vm-2.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.16 - (show annotations) (download)
Sat Nov 11 00:13:22 2006 UTC (7 years, 8 months ago) by betelgeuse
Branch: MAIN
Changes since 1.15: +8 -3 lines
Some of the jdks/jres install .desktop files so let's run update-desktop-database code in postinst and postrm.

1 # Copyright 1999-2004 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/java-vm-2.eclass,v 1.15 2006/10/20 03:52:24 nichoj Exp $
4
5 # -----------------------------------------------------------------------------
6 # @eclass-begin
7 # @eclass-shortdesc Java Virtual Machine eclass
8 # @eclass-maintainer java@gentoo.org
9 #
10 # This eclass provides functionality which assists with installing
11 # virtual machines, and ensures that they are recognized by java-config.
12 #
13 # -----------------------------------------------------------------------------
14
15 inherit eutils fdo-mime
16
17 DEPEND="
18 =dev-java/java-config-2.0*
19 >=sys-apps/portage-2.1"
20 RDEPEND="
21 =dev-java/java-config-2.0*
22 =dev-java/java-config-1.3*"
23
24 export WANT_JAVA_CONFIG=2
25
26 if [[ "${SLOT}" != "0" ]]; then
27 VMHANDLE=${PN}-${SLOT}
28 else
29 VMHANDLE=${PN}
30 fi
31
32 JAVA_VM_CONFIG_DIR="/usr/share/java-config-2/vm"
33 JAVA_VM_DIR="/usr/lib/jvm"
34
35 EXPORT_FUNCTIONS pkg_postinst pkg_prerm pkg_postrm
36
37 java-vm-2_pkg_postinst() {
38 # Set the generation-2 system VM, if it isn't set
39 if [[ -z "$(java-config-2 -f)" ]]; then
40 java_set_default_vm_
41 fi
42
43 # support both variables for now
44 if [[ ${JAVA_SUPPORTS_GENERATION_1} == 'true' && ${JAVA_VM_NO_GENERATION1} != 'true' ]]; then
45 local systemvm1="$(java-config-1 -f 2>/dev/null)"
46 # no generation-1 system-vm was previously set
47 if [[ -z "${systemvm1}" ]]; then
48 # if 20java exists, must be using old VM
49 if [[ -f /etc/env.d/20java ]]; then
50 ewarn "The current generation-1 system-vm is using an out-of-date VM,"
51 ewarn "as in, it hasn't been updated for use with the new Java sytem."
52 # othewise, it must not have been set before
53 else
54 ewarn "No generation-1 system-vm previously set."
55 fi
56 ewarn "Setting generation-1 system-vm to ${VMHANDLE}"
57 java-config-1 --set-system-vm=${P} 2>/dev/null
58 # dirty check to see if we are upgrading current generation-1 system vm
59 elif [[ "${systemvm1}" = ${VMHANDLE}* ]]; then
60 einfo "Emerging the current generation-1 system-vm..."
61 einfo "Updating its config files."
62 java-config-1 --set-system-vm=${P} 2>/dev/null
63 # dirty check to see if current system vm is a jre - replace it with
64 elif [[ "${systemvm1}" = *jre* ]]; then
65 ewarn "Current generation-1 system-vm is a JRE"
66 ewarn "For the new and old Java systems to coexist,"
67 ewarn "the generation-1 system-vm must be a JDK."
68 ewarn "Setting generation-1 system-vm to ${VMHANDLE}"
69 java-config-1 --set-system-vm=${P} 2>/dev/null
70 fi
71 # else... some other VM is being updated, so we don't have to worry
72 else
73 einfo "JREs and 1.5+ JDKs are not supported for use with generation-1."
74 einfo "This is because generation-1 is only for use for building packages."
75 einfo "Only generation-2 should be used by end-users,"
76 einfo "where all JREs and JDKs will be available"
77 fi
78
79 echo
80
81 java-vm_check-nsplugin
82 java_mozilla_clean_
83 fdo-mime_desktop_database_update
84 }
85
86 java-vm_check-nsplugin() {
87 local libdir
88 if [[ ${VMHANDLE} =~ emul-linux-x86 ]]; then
89 libdir=lib32
90 else
91 libdir=lib
92 fi
93 # Install a default nsplugin if we don't already have one
94 if has nsplugin ${IUSE} && use nsplugin; then
95 if [[ ! -f /usr/${libdir}/nsbrowser/plugins/javaplugin.so ]]; then
96 einfo "No system nsplugin currently set."
97 java-vm_set-nsplugin
98 else
99 einfo "System nsplugin is already set, not changing it."
100 fi
101 einfo "You can change nsplugin with eselect java-nsplugin."
102 fi
103 }
104
105 java-vm_set-nsplugin() {
106 local extra_args
107 if use amd64; then
108 if [[ ${VMHANDLE} =~ emul-linux-x86 ]]; then
109 extra_args="32bit"
110 else
111 extra_args="64bit"
112 fi
113 einfo "Setting ${extra_args} nsplugin to ${VMHANDLE}"
114 else
115 einfo "Setting nsplugin to ${VMHANDLE}..."
116 fi
117 eselect java-nsplugin set ${extra_args} ${VMHANDLE}
118 }
119
120 java-vm-2_pkg_prerm() {
121 if [[ "$(java-config -f 2>/dev/null)" == "${VMHANDLE}" ]]; then
122 ewarn "It appears you are removing your system-vm!"
123 ewarn "Please run java-config -L to list available VMs,"
124 ewarn "then use java-config -S to set a new system-vm!"
125 fi
126 }
127
128 java-vm-2_pkg_postrm() {
129 fdo-mime_desktop_database_update
130 }
131
132 java_set_default_vm_() {
133 java-config-2 --set-system-vm="${VMHANDLE}"
134
135 einfo " ${P} set as the default system-vm."
136 }
137
138 get_system_arch() {
139 local sarch
140 sarch=$(echo ${ARCH} | sed -e s/[i]*.86/i386/ -e s/x86_64/amd64/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/)
141 if [ -z "${sarch}" ]; then
142 sarch=$(uname -m | sed -e s/[i]*.86/i386/ -e s/x86_64/amd64/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/)
143 fi
144 echo ${sarch}
145 }
146
147 # TODO rename to something more evident, like install_env_file
148 set_java_env() {
149 local platform="$(get_system_arch)"
150 local env_file="${D}${JAVA_VM_CONFIG_DIR}/${VMHANDLE}"
151 local old_env_file="${D}/etc/env.d/java/20${P}"
152 local source_env_file="${FILESDIR}/${VMHANDLE}.env"
153
154 if [[ ! -f ${source_env_file} ]]; then
155 die "Unable to find the env file: ${source_env_file}"
156 fi
157
158 dodir ${JAVA_VM_CONFIG_DIR}
159 sed \
160 -e "s/@P@/${P}/g" \
161 -e "s/@PN@/${PN}/g" \
162 -e "s/@PV@/${PV}/g" \
163 -e "s/@PF@/${PF}/g" \
164 -e "s/@PLATFORM@/${platform}/g" \
165 -e "/^LDPATH=.*lib\\/\\\"/s|\"\\(.*\\)\"|\"\\1${platform}/:\\1${platform}/server/\"|" \
166 < ${source_env_file} \
167 > ${env_file} || die "sed failed"
168
169 echo "VMHANDLE=\"${VMHANDLE}\"" >> ${env_file}
170
171 # generation-1 compatibility
172 # respect both variables for now...
173 if [[ ${JAVA_SUPPORTS_GENERATION_1} == 'true' && ${JAVA_VM_NO_GENERATION1} != 'true' ]]; then
174 einfo "Enabling generation-1 compatibility..."
175 dodir /etc/env.d/java # generation-1 compatibility
176 # We need to strip some things out of the new style env,
177 # because these end up going in the env
178 sed -e 's/.*CLASSPATH.*//' \
179 -e 's/.*PROVIDES.*//' \
180 ${env_file} \
181 > ${old_env_file} || die "failed to create generation-1 env file"
182 else
183 ewarn "Disabling generation-1 compatibility..."
184 fi
185
186 [[ -n ${JAVA_PROVIDE} ]] && echo "PROVIDES=\"${JAVA_PROVIDE}\"" >> ${env_file}
187
188 local java_home=$(source ${env_file}; echo ${JAVA_HOME})
189 [[ -z ${java_home} ]] && die "No JAVA_HOME defined in ${env_file}"
190
191 # Make the symlink
192 dosym ${java_home} ${JAVA_VM_DIR}/${VMHANDLE} \
193 || die "Failed to make VM symlink at ${JAVA_VM_DIR}/${VMHANDLE}"
194 }
195
196
197 java_get_plugin_dir_() {
198 echo /usr/$(get_libdir)/nsbrowser/plugins
199 }
200
201 install_mozilla_plugin() {
202 local plugin=${1}
203
204 if [ ! -f "${D}/${plugin}" ] ; then
205 die "Cannot find mozilla plugin at ${D}/${plugin}"
206 fi
207
208 local plugin_dir=/usr/share/java-config-2/nsplugin
209 dodir ${plugin_dir}
210 dosym ${plugin} ${plugin_dir}/${VMHANDLE}-javaplugin.so
211 }
212
213 java_mozilla_clean_() {
214 # Because previously some ebuilds installed symlinks outside of pkg_install
215 # and are left behind, which forces you to manualy remove them to select the
216 # jdk/jre you want to use for java
217 local plugin_dir=$(java_get_plugin_dir_)
218 for file in ${plugin_dir}/javaplugin_*; do
219 rm -f ${file}
220 done
221 for file in ${plugin_dir}/libjavaplugin*; do
222 rm -f ${file}
223 done
224 }
225
226 # ------------------------------------------------------------------------------
227 # @eclass-end
228 # ------------------------------------------------------------------------------

  ViewVC Help
Powered by ViewVC 1.1.20