/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.85 Revision 1.122
1# Copyright 1999-2010 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.85 2011/03/16 22:45:30 dilfridge Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.122 2013/02/02 16:58:00 dilfridge Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 based ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but 13# NOTE: KDE 4 ebuilds currently support EAPI "3". This will be reviewed
14# eclass will fail with version older than 2. 14# over time as new EAPI versions are approved.
15
16# @ECLASS-VARIABLE: KDE_SELINUX_MODULE
17# @DESCRIPTION:
18# If set to "none", do nothing.
19# For any other value, add selinux to IUSE, and depending on that useflag
20# add a dependency on sec-policy/selinux-${KDE_SELINUX_MODULE} to (R)DEPEND
21: ${KDE_SELINUX_MODULE:=none}
22
23# @ECLASS-VARIABLE: VIRTUALDBUS_TEST
24# @DESCRIPTION:
25# If defined, launch and use a private dbus session during src_test.
15 26
16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED 27# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION: 28# @DESCRIPTION:
18# For proper description see virtualx.eclass manpage. 29# For proper description see virtualx.eclass manpage.
19# Here we redefine default value to be manual, if your package needs virtualx 30# Here we redefine default value to be manual, if your package needs virtualx
20# for tests you should proceed with setting VIRTUALX_REQUIRED=test. 31# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
21: ${VIRTUALX_REQUIRED:=manual} 32: ${VIRTUALX_REQUIRED:=manual}
22 33
23inherit kde4-functions base virtualx eutils 34inherit kde4-functions toolchain-funcs fdo-mime flag-o-matic gnome2-utils base virtualx versionator eutils multilib
24 35
25get_build_type
26if [[ ${BUILD_TYPE} = live ]]; then 36if [[ ${KDE_BUILD_TYPE} = live ]]; then
27 if [[ ${KDEBASE} = kdevelop ]]; then 37 case ${KDE_SCM} in
28 inherit git
29 else
30 inherit subversion 38 svn) inherit subversion ;;
31 fi 39 git) inherit git-2 ;;
40 esac
32fi 41fi
33 42
34# @ECLASS-VARIABLE: CMAKE_REQUIRED 43# @ECLASS-VARIABLE: CMAKE_REQUIRED
35# @DESCRIPTION: 44# @DESCRIPTION:
36# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'. 45# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
41if [[ ${CMAKE_REQUIRED} = always ]]; then 50if [[ ${CMAKE_REQUIRED} = always ]]; then
42 buildsystem_eclass="cmake-utils" 51 buildsystem_eclass="cmake-utils"
43 export_fns="src_configure src_compile src_test src_install" 52 export_fns="src_configure src_compile src_test src_install"
44fi 53fi
45 54
46# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
47if [[ -n ${KDE_MINIMAL} ]]; then
48 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
49 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
50 done
51 unset slot
52 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
53else
54 KDE_MINIMAL_VALID=1
55fi
56
57# @ECLASS-VARIABLE: KDE_MINIMAL 55# @ECLASS-VARIABLE: KDE_MINIMAL
58# @DESCRIPTION: 56# @DESCRIPTION:
59# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal 57# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
60# version for apps to work. Currently defaults to 4.4 58# version for apps to work. Currently defaults to 4.4
61# One may override this variable to raise version requirements. 59# One may override this variable to raise version requirements.
62# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
63# Note that it is fixed to ${SLOT} for kde-base packages. 60# Note that it is fixed to ${PV} for kde-base packages.
64KDE_MINIMAL="${KDE_MINIMAL:-4.4}" 61KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
65 62
66# Set slot for packages in kde-base, koffice and kdevelop 63# Set slot for KDEBASE known packages
67case ${KDEBASE} in 64case ${KDEBASE} in
68 kde-base) 65 kde-base)
69 # Determine SLOT from PVs 66 SLOT=4
70 case ${PV} in
71 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
72 4.6* | 4.5.[6-9][0-9]*) SLOT="4.6" ;;
73 4.5* | 4.4.[6-9][0-9]*) SLOT="4.5" ;;
74 4.4* | 4.3.[6-9][0-9]*) SLOT="4.4" ;;
75 9999*) SLOT="live" ;; # regular live
76 *) die "Unsupported ${PV}" ;;
77 esac
78 KDE_MINIMAL="${SLOT}" 67 KDE_MINIMAL="${PV}"
79 ;;
80 koffice)
81 SLOT="2"
82 ;; 68 ;;
83 kdevelop) 69 kdevelop)
84 if [[ ${BUILD_TYPE} = live ]]; then 70 if [[ ${KDE_BUILD_TYPE} = live ]]; then
85 # @ECLASS-VARIABLE: KDEVELOP_VERSION 71 # @ECLASS-VARIABLE: KDEVELOP_VERSION
86 # @DESCRIPTION: 72 # @DESCRIPTION:
87 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages. 73 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
88 # Applies to KDEBASE=kdevelop only. 74 # Applies to KDEBASE=kdevelop only.
89 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}" 75 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
96 case ${PN} in 82 case ${PN} in
97 kdevelop|quanta) 83 kdevelop|quanta)
98 KDEVELOP_VERSION=${PV} 84 KDEVELOP_VERSION=${PV}
99 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)" 85 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
100 ;; 86 ;;
101 kdevplatform) 87 kdevplatform|kdevelop-php*)
102 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)" 88 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
103 KDEVPLATFORM_VERSION=${PV} 89 KDEVPLATFORM_VERSION=${PV}
104 ;; 90 ;;
105 *) 91 *)
106 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}" 92 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
109 fi 95 fi
110 SLOT="4" 96 SLOT="4"
111 ;; 97 ;;
112esac 98esac
113 99
114slot_is_at_least 4.5 ${KDE_MINIMAL} && CMAKE_MIN_VERSION="2.8.1"
115
116inherit ${buildsystem_eclass} 100inherit ${buildsystem_eclass}
117 101
118EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm 102EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_preinst pkg_postinst pkg_postrm
119 103
120unset buildsystem_eclass 104unset buildsystem_eclass
121unset export_fns 105unset export_fns
122 106
123# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED 107# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
141# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED 125# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
142# @DESCRIPTION: 126# @DESCRIPTION:
143# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'. 127# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
144# This variable must be set before inheriting any eclasses. Defaults to 'never'. 128# This variable must be set before inheriting any eclasses. Defaults to 'never'.
145MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}" 129MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
146
147# @ECLASS-VARIABLE: WEBKIT_REQUIRED
148# @DESCRIPTION:
149# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
150# This variable must be set before inheriting any eclasses. Defaults to 'never'.
151WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
152 130
153# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 131# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
154# @DESCRIPTION: 132# @DESCRIPTION:
155# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 133# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
156# This variable must be set before inheriting any eclasses. Defaults to 'never'. 134# This variable must be set before inheriting any eclasses. Defaults to 'never'.
171# This variable must be set before inheriting any eclasses. Defaults to 'never'. 149# This variable must be set before inheriting any eclasses. Defaults to 'never'.
172# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it 150# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
173# ensures buildtime and runtime dependencies. 151# ensures buildtime and runtime dependencies.
174KDE_HANDBOOK="${KDE_HANDBOOK:-never}" 152KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
175 153
154# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
155# @DESCRIPTION:
156# Set this varible if you want your live package to manage its
157# translations. (Mostly all kde ebuilds does not ship documentation
158# and translations in live ebuilds)
159if [[ ${KDE_BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
160 # Kdebase actualy provides the handbooks even for live stuff
161 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
162 KDE_LINGUAS=""
163fi
164
176# Setup packages inheriting this eclass 165# Setup packages inheriting this eclass
177case ${KDEBASE} in 166case ${KDEBASE} in
178 kde-base) 167 kde-base)
179 HOMEPAGE="http://www.kde.org/" 168 HOMEPAGE="http://www.kde.org/"
180 LICENSE="GPL-2" 169 LICENSE="GPL-2"
181 if [[ $BUILD_TYPE = live ]]; then 170 if [[ ${KDE_BUILD_TYPE} = live && -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
182 # Disable tests for live ebuilds 171 # Disable tests for live ebuilds by default
183 RESTRICT+=" test" 172 RESTRICT+=" test"
184 # Live ebuilds in kde-base default to kdeprefix by default
185 IUSE+=" +kdeprefix"
186 else
187 # All other ebuild types default to -kdeprefix as before
188 IUSE+=" kdeprefix"
189 fi 173 fi
174
190 # This code is to prevent portage from searching GENTOO_MIRRORS for 175 # This code is to prevent portage from searching GENTOO_MIRRORS for
191 # packages that will never be mirrored. (As they only will ever be in 176 # packages that will never be mirrored. (As they only will ever be in
192 # the overlay). 177 # the overlay).
193 case ${PV} in 178 case ${PV} in
194 *9999* | 4.?.[6-9]?) 179 *9999* | 4.?.[6-9]?)
195 RESTRICT+=" mirror" 180 RESTRICT+=" mirror"
196 ;; 181 ;;
197 esac 182 esac
198 # Block installation of other SLOTS unless kdeprefix
199 RDEPEND+=" $(block_other_slots)"
200 ;;
201 koffice)
202 HOMEPAGE="http://www.koffice.org/"
203 LICENSE="GPL-2"
204 ;; 183 ;;
205 kdevelop) 184 kdevelop)
206 HOMEPAGE="http://www.kdevelop.org/" 185 HOMEPAGE="http://www.kdevelop.org/"
207 LICENSE="GPL-2" 186 LICENSE="GPL-2"
208 ;; 187 ;;
209esac 188esac
210 189
211# @ECLASS-VARIABLE: QT_MINIMAL 190# @ECLASS-VARIABLE: QT_MINIMAL
212# @DESCRIPTION: 191# @DESCRIPTION:
213# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1... 192# Determine version of qt we enforce as minimal for the package.
214# 4.6.0 for 4.4, 4.6.3 for 4.5, and 4.7.0 for 4.6 and later
215if slot_is_at_least 4.6 "${KDE_MINIMAL}"; then 193if version_is_at_least 4.8.50 "${KDE_MINIMAL}"; then
194 # Upstream has added an *undeclared* dependency on Qt 4.8...
216 QT_MINIMAL="${QT_MINIMAL:-4.7.0}" 195 QT_MINIMAL="${QT_MINIMAL:-4.8.0}"
217elif slot_is_at_least 4.5 "${KDE_MINIMAL}"; then
218 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
219else 196else
220 QT_MINIMAL="${QT_MINIMAL:-4.6.0}" 197 QT_MINIMAL="${QT_MINIMAL:-4.7.4}"
221fi 198fi
222 199
223# Declarative dependencies 200# Declarative dependencies
224qtdeclarativedepend=" 201qtdeclarativedepend="
225 >=x11-libs/qt-declarative-${QT_MINIMAL}:4 202 >=x11-libs/qt-declarative-${QT_MINIMAL}:4
281 ;; 258 ;;
282 *) ;; 259 *) ;;
283esac 260esac
284unset qtmultimediadepend 261unset qtmultimediadepend
285 262
286# WebKit dependencies
287case ${KDE_REQUIRED} in
288 always)
289 qtwebkitusedeps="[kde]"
290 ;;
291 optional)
292 qtwebkitusedeps="[kde?]"
293 ;;
294 *) ;;
295esac
296qtwebkitdepend="
297 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
298"
299unset qtwebkitusedeps
300case ${WEBKIT_REQUIRED} in
301 always)
302 COMMONDEPEND+=" ${qtwebkitdepend}"
303 ;;
304 optional)
305 IUSE+=" webkit"
306 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
307 ;;
308 *) ;;
309esac
310unset qtwebkitdepend
311
312# CppUnit dependencies 263# CppUnit dependencies
313cppuintdepend=" 264cppuintdepend="
314 dev-util/cppunit 265 dev-util/cppunit
315" 266"
316case ${CPPUNIT_REQUIRED} in 267case ${CPPUNIT_REQUIRED} in
328# KDE dependencies 279# KDE dependencies
329# Qt accessibility classes are needed in various places, bug 325461 280# Qt accessibility classes are needed in various places, bug 325461
330kdecommondepend=" 281kdecommondepend="
331 dev-lang/perl 282 dev-lang/perl
332 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl] 283 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
284 >=x11-libs/qt-dbus-${QT_MINIMAL}:4
333 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus] 285 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
334 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde] 286 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility]
335 >=x11-libs/qt-script-${QT_MINIMAL}:4 287 >=x11-libs/qt-script-${QT_MINIMAL}:4
336 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support] 288 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
337 >=x11-libs/qt-svg-${QT_MINIMAL}:4 289 >=x11-libs/qt-svg-${QT_MINIMAL}:4
338 >=x11-libs/qt-test-${QT_MINIMAL}:4 290 >=x11-libs/qt-test-${QT_MINIMAL}:4
291 >=x11-libs/qt-webkit-${QT_MINIMAL}:4
339 !aqua? ( 292 !aqua? (
340 x11-libs/libXext 293 x11-libs/libXext
341 x11-libs/libXt 294 x11-libs/libXt
342 x11-libs/libXxf86vm 295 x11-libs/libXxf86vm
296 x11-libs/libXcomposite
297 x11-libs/libxkbfile
343 ) 298 )
344" 299"
345 300
346if [[ ${PN} != kdelibs ]]; then 301if [[ ${PN} != kdelibs ]]; then
347 kdecommondepend+=" $(add_kdebase_dep kdelibs)" 302 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
361 *) ;; 316 *) ;;
362 esac 317 esac
363 fi 318 fi
364 fi 319 fi
365fi 320fi
321
366kdedepend=" 322kdedepend="
367 dev-util/automoc 323 dev-util/automoc
368 dev-util/pkgconfig 324 virtual/pkgconfig
369 !aqua? ( 325 !aqua? (
370 >=x11-libs/libXtst-1.1.0 326 >=x11-libs/libXtst-1.1.0
371 x11-proto/xf86vidmodeproto 327 x11-proto/xf86vidmodeproto
372 ) 328 )
373" 329"
330
374kderdepend="" 331kderdepend=""
375 332
333# all packages needs oxygen icons for basic iconset
376if [[ ${PN} != oxygen-icons ]]; then 334if [[ ${PN} != oxygen-icons ]]; then
377 kderdepend+=" $(add_kdebase_dep oxygen-icons)" 335 kderdepend+=" $(add_kdebase_dep oxygen-icons)"
336fi
337
338# add a dependency over kde-l10n if EAPI4 or better is around
339if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} && ${EAPI:-0} != 3 ]]; then
340 for _lingua in ${KDE_LINGUAS}; do
341 # if our package has lignuas, pull in kde-l10n with selected lingua enabled,
342 # but only for selected ones.
343 # this can't be done on one line because if user doesn't use any localisation
344 # then he is probably not interested in kde-l10n at all.
345 kderdepend+="
346 linguas_${_lingua}? ( $(add_kdebase_dep kde-l10n "linguas_${_lingua}(+)") )
347 "
348 done
349 unset _lingua
378fi 350fi
379 351
380kdehandbookdepend=" 352kdehandbookdepend="
381 app-text/docbook-xml-dtd:4.2 353 app-text/docbook-xml-dtd:4.2
382 app-text/docbook-xsl-stylesheets 354 app-text/docbook-xsl-stylesheets
396 ;; 368 ;;
397 *) ;; 369 *) ;;
398esac 370esac
399unset kdehandbookdepend kdehandbookrdepend 371unset kdehandbookdepend kdehandbookrdepend
400 372
373case ${KDE_SELINUX_MODULE} in
374 none) ;;
375 *)
376 IUSE+=" selinux"
377 kdecommondepend+=" selinux? ( sec-policy/selinux-${KDE_SELINUX_MODULE} )"
378 ;;
379esac
380
401case ${KDE_REQUIRED} in 381case ${KDE_REQUIRED} in
402 always) 382 always)
403 IUSE+=" aqua" 383 IUSE+=" aqua"
404 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}" 384 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
405 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}" 385 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
423# Accumulate dependencies set by this eclass 403# Accumulate dependencies set by this eclass
424DEPEND+=" ${COMMONDEPEND}" 404DEPEND+=" ${COMMONDEPEND}"
425RDEPEND+=" ${COMMONDEPEND}" 405RDEPEND+=" ${COMMONDEPEND}"
426unset COMMONDEPEND 406unset COMMONDEPEND
427 407
428# Add experimental kdeenablefinal, disabled by default
429IUSE+=" kdeenablefinal"
430
431# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 408# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
432# koffice ebuild, the URI should be set in the ebuild itself 409# kdevelop ebuild, the URI should be set in the ebuild itself
433case ${BUILD_TYPE} in 410_calculate_src_uri() {
434 live) 411 debug-print-function ${FUNCNAME} "$@"
412
413 local _kmname _kmname_pv
414
415 # we calculate URI only for known KDEBASE modules
416 [[ -n ${KDEBASE} ]] || return
417
418 # calculate tarball module name
419 if [[ -n ${KMNAME} ]]; then
420 # fixup kdebase-apps name
421 case ${KMNAME} in
422 kdebase-apps)
423 _kmname="kdebase" ;;
424 *)
425 _kmname="${KMNAME}" ;;
426 esac
427 else
428 _kmname=${PN}
429 fi
430 _kmname_pv="${_kmname}-${PV}"
431 case ${KDEBASE} in
432 kde-base)
433 case ${PV} in
434 4.4.11.1)
435 # KDEPIM 4.4, special case
436 # TODO: Remove this part when KDEPIM 4.4 gets out of the tree
437 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2" ;;
438 4.[89].8[05] | 4.[89].9[0235678])
439 # Unstable KDE SC releases
440 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.xz" ;;
441 4.[1234567].[12345])
442 # Stable KDE SC with old .bz2 support
443 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
444 *)
445 # Stable KDE SC releases
446 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.xz" ;;
447 esac
448 ;;
449 kdevelop|kdevelop-php*|kdevplatform)
450 case ${KDEVELOP_VERSION} in
451 4.[12].[6-9]*) SRC_URI="mirror://kde/unstable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2" ;;
452 *) SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2" ;;
453 esac
454 ;;
455 esac
456}
457
458_calculate_live_repo() {
459 debug-print-function ${FUNCNAME} "$@"
460
435 SRC_URI="" 461 SRC_URI=""
436 if has subversion ${INHERITED}; then 462 case ${KDE_SCM} in
463 svn)
437 # Determine branch URL based on live type 464 # Determine branch URL based on live type
438 local branch_prefix 465 local branch_prefix
439 case ${PV} in 466 case ${PV} in
440 9999*) 467 9999*)
441 # trunk 468 # trunk
442 branch_prefix="trunk/KDE" 469 branch_prefix="trunk/KDE"
443 ;; 470 ;;
444 *) 471 *)
445 # branch 472 # branch
446 branch_prefix="branches/KDE/${SLOT}" 473 branch_prefix="branches/KDE/$(get_kde_version)"
447 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX 474 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
448 # @DESCRIPTION 475 # @DESCRIPTION
449 # Suffix appended to ESVN_PROJECT depending on fetched branch. 476 # Suffix appended to ESVN_PROJECT depending on fetched branch.
450 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise. 477 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
451 ESVN_PROJECT_SUFFIX="-${PV}" 478 ESVN_PROJECT_SUFFIX="-${PV}"
484 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta 511 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
485 # build packages from same svn location. 512 # build packages from same svn location.
486 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 513 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
487 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}" 514 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
488 ;; 515 ;;
489 koffice)
490 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
491 ;;
492 *) 516 *)
493 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 517 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
494 ;; 518 ;;
495 esac 519 esac
496 else 520 else
499 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}" 523 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
500 fi 524 fi
501 # @ECLASS-VARIABLE: ESVN_UP_FREQ 525 # @ECLASS-VARIABLE: ESVN_UP_FREQ
502 # @DESCRIPTION: 526 # @DESCRIPTION:
503 # This variable is used for specifying the timeout between svn synces 527 # This variable is used for specifying the timeout between svn synces
504 # for kde-base and koffice modules. Does not affect misc apps. 528 # for kde-base modules. Does not affect misc apps.
505 # Default value is 1 hour. 529 # Default value is 1 hour.
506 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1} 530 [[ ${KDEBASE} = kde-base ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
507 elif has git ${INHERITED}; then
508 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
509 KMMODULE="${PN}"
510 fi
511 case ${KDEBASE} in
512 kdevelop)
513 EGIT_REPO_URI="git://git.kde.org/${KMMODULE}"
514 ;;
515 esac
516 fi
517 ;; 531 ;;
518 *) 532 git)
533 local _kmname
534 # @ECLASS-VARIABLE: EGIT_MIRROR
535 # @DESCRIPTION:
536 # This variable allows easy overriding of default kde mirror service
537 # (anongit) with anything else you might want to use.
538 EGIT_MIRROR=${EGIT_MIRROR:=git://anongit.kde.org}
539
540 # @ECLASS-VARIABLE: EGIT_REPONAME
541 # @DESCRIPTION:
542 # This variable allows overriding of default repository
543 # name. Specify only if this differ from PN and KMNAME.
519 if [[ -n ${KDEBASE} ]]; then 544 if [[ -n ${EGIT_REPONAME} ]]; then
545 # the repository and kmname different
546 _kmname=${EGIT_REPONAME}
520 if [[ -n ${KMNAME} ]]; then 547 elif [[ -n ${KMNAME} ]]; then
521 case ${KMNAME} in
522 kdebase-apps)
523 _kmname="kdebase" ;;
524 *)
525 _kmname="${KMNAME}" ;; 548 _kmname=${KMNAME}
526 esac
527 else 549 else
528 _kmname=${PN} 550 _kmname=${PN}
529 fi 551 fi
530 _kmname_pv="${_kmname}-${PV}" 552
531 case ${KDEBASE} in 553 # default branching
532 kde-base) 554 [[ ${PV} != 9999* && ${KDEBASE} == kde-base ]] && \
533 case ${PV} in 555 EGIT_BRANCH="KDE/$(get_kde_version)"
534 4.5.93) 556
535 # Only kdepim and kdepim-runtime 4.6beta here 557 # default repo uri
536 SRC_URI="mirror://kde/unstable/kdepim/${PV}/${_kmname}-4.6beta3.tar.bz2" 558 EGIT_REPO_URI="${EGIT_MIRROR}/${_kmname}"
537 ;; 559
538 4.[456].8[05] | 4.[456].9[023568]) 560 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
539 # Unstable KDE SC releases 561 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
540 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
541 ;;
542 4.4.6 | 4.4.7 | 4.4.8 | 4.4.9 | 4.4.10)
543 # Only kdepim here
544 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
545 ;;
546 *)
547 # Stable KDE SC releases
548 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
549 ;;
550 esac
551 ;;
552 koffice)
553 case ${PV} in
554 2.1.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
555 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
556 esac
557 ;;
558 kdevelop)
559 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
560 ;;
561 esac
562 unset _kmname _kmname_pv
563 fi
564 ;; 562 ;;
563 esac
564}
565
566case ${KDE_BUILD_TYPE} in
567 live) _calculate_live_repo ;;
568 *) _calculate_src_uri ;;
565esac 569esac
566 570
567debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}" 571debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
568 572
569# @ECLASS-VARIABLE: PREFIX 573# @ECLASS-VARIABLE: PREFIX
570# @DESCRIPTION: 574# @DESCRIPTION:
571# Set the installation PREFIX for non kde-base applications. It defaults to /usr. 575# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
572# kde-base packages go into KDE4 installation directory (KDEDIR) by default. 576# kde-base packages go into KDE4 installation directory (/usr).
573# No matter the PREFIX, package will be built against KDE installed in KDEDIR. 577# No matter the PREFIX, package will be built against KDE installed in /usr.
574 578
575# @FUNCTION: kde4-base_pkg_setup 579# @FUNCTION: kde4-base_pkg_setup
576# @DESCRIPTION: 580# @DESCRIPTION:
577# Do the basic kdeprefix KDEDIR settings and determine with which kde should 581# Do some basic settings
578# optional applications link
579kde4-base_pkg_setup() { 582kde4-base_pkg_setup() {
580 debug-print-function ${FUNCNAME} "$@" 583 debug-print-function ${FUNCNAME} "$@"
581 584
582 # Prefix compat: 585 if has handbook ${IUSE} || has "+handbook" ${IUSE} && [ "${KDE_HANDBOOK}" != optional ] ; then
583 if [[ ${EAPI} == 2 ]] && ! use prefix; then 586 eqawarn "Handbook support is enabled via KDE_HANDBOOK=optional in the ebuild."
584 EPREFIX= 587 eqawarn "Please do not just set IUSE=handbook, as this leads to dependency errors."
585 EROOT=${ROOT}
586 fi 588 fi
587
588 # Append missing trailing slash character
589 [[ ${EROOT} = */ ]] || EROOT+="/"
590
591 # QA ebuilds
592 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
593 589
594 # Don't set KDEHOME during compilation, it will cause access violations 590 # Don't set KDEHOME during compilation, it will cause access violations
595 unset KDEHOME 591 unset KDEHOME
596 592
597 if [[ ${KDEBASE} = kde-base ]]; then 593 # Check if gcc compiler is fresh enough.
598 if use kdeprefix; then 594 # In theory should be in pkg_pretend but we check it only for kdelibs there
599 KDEDIR=/usr/kde/${SLOT} 595 # and for others we do just quick scan in pkg_setup because pkg_pretend
600 else 596 # executions consume quite some time.
601 KDEDIR=/usr 597 # We can only do this for EAPI 4 or later because the MERGE_TYPE variable
598 # is otherwise undefined.
599 if [[ ${EAPI:-0} != 3 ]]; then
600 if [[ ${MERGE_TYPE} != binary ]]; then
601 [[ $(gcc-major-version) -lt 4 ]] || \
602 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 3 ]] ) \
603 && die "Sorry, but gcc-4.3 and earlier wont work for KDE (see bug 354837)."
602 fi 604 fi
603 : ${PREFIX:=${KDEDIR}}
604 else
605 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
606 KDEDIR=
607 local kde_minimal_met
608 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
609 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
610 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
611 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
612 KDEDIR=/usr/kde/${slot}
613 else
614 KDEDIR=/usr
615 fi
616 break;
617 fi
618 done
619 unset slot
620
621 # Bail out if kdelibs required but not found
622 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
623 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
624 else
625 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
626 fi 605 fi
627 606
607 KDEDIR=/usr
628 : ${PREFIX:=/usr} 608 : ${PREFIX:=/usr}
629 fi 609 EKDEDIR=${EPREFIX}/usr
630 EKDEDIR=${EPREFIX}${KDEDIR}
631 610
632 # Point pkg-config path to KDE *.pc files
633 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
634 # Point to correct QT plugins path 611 # Point to correct QT plugins path
635 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/" 612 QT_PLUGIN_PATH="${EPREFIX}/usr/$(get_libdir)/kde4/plugins/"
636 613
637 # Fix XDG collision with sandbox 614 # Fix XDG collision with sandbox
638 export XDG_CONFIG_HOME="${T}" 615 export XDG_CONFIG_HOME="${T}"
639} 616}
640 617
642# @DESCRIPTION: 619# @DESCRIPTION:
643# This function unpacks the source tarballs for KDE4 applications. 620# This function unpacks the source tarballs for KDE4 applications.
644kde4-base_src_unpack() { 621kde4-base_src_unpack() {
645 debug-print-function ${FUNCNAME} "$@" 622 debug-print-function ${FUNCNAME} "$@"
646 623
647 if [[ ${BUILD_TYPE} = live ]]; then 624 if [[ ${KDE_BUILD_TYPE} = live ]]; then
648 if has subversion ${INHERITED}; then 625 case ${KDE_SCM} in
626 svn)
649 migrate_store_dir 627 migrate_store_dir
650 subversion_src_unpack 628 subversion_src_unpack
651 elif has git ${INHERITED}; then
652 git_src_unpack
653 fi
654 elif [[ ${EAPI} == 2 ]]; then
655 local file
656 for file in ${A}; do
657 # This setup is because EAPI <= 2 cannot unpack *.tar.xz files
658 # directly, so we do it ourselves (using the exact same code as portage)
659 case ${file} in
660 *.tar.xz)
661 echo ">>> Unpacking ${file} to ${PWD}"
662 xz -dc "${DISTDIR}"/${file} | tar xof -
663 assert "failed unpacking ${file}"
664 ;; 629 ;;
665 *) 630 git)
666 unpack ${file} 631 git-2_src_unpack
667 ;; 632 ;;
668 esac 633 esac
669 done
670 else 634 else
671 # For EAPI >= 3, we can just use unpack() directly
672 unpack ${A} 635 unpack ${A}
673 fi 636 fi
674} 637}
675 638
676# @FUNCTION: kde4-base_src_prepare 639# @FUNCTION: kde4-base_src_prepare
680# enable_selected_linguas() and enable_selected_doc_linguas() 643# enable_selected_linguas() and enable_selected_doc_linguas()
681# in kde4-functions.eclass(5) for further details. 644# in kde4-functions.eclass(5) for further details.
682kde4-base_src_prepare() { 645kde4-base_src_prepare() {
683 debug-print-function ${FUNCNAME} "$@" 646 debug-print-function ${FUNCNAME} "$@"
684 647
648 # enable handbook and linguas only when not using live ebuild
649
685 # Only enable selected languages, used for KDE extragear apps. 650 # Only enable selected languages, used for KDE extragear apps.
686 if [[ -n ${KDE_LINGUAS} ]]; then 651 if [[ -n ${KDE_LINGUAS} ]]; then
687 enable_selected_linguas 652 enable_selected_linguas
688 fi 653 fi
689 654
690 # Enable/disable handbooks for kde4-base packages 655 # Enable/disable handbooks for kde4-base packages
691 # kde-l10n inherits kde4-base but is metpackage, so no check for doc 656 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
692 # kdelibs inherits kde4-base but handle installing the handbook itself 657 # kdelibs inherits kde4-base but handle installing the handbook itself
693 if ! has kde4-meta ${INHERITED}; then 658 if ! has kde4-meta ${INHERITED} && in_iuse handbook; then
694 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas 659 if [[ ${KDEBASE} == kde-base ]]; then
660 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
661 # documentation in kde4-functions
662 : ${KDE_DOC_DIRS:=doc}
663 local dir
664 for dir in ${KDE_DOC_DIRS}; do
665 sed -e "\!^[[:space:]]*add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
666 -e "\!^[[:space:]]*ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
667 -e "\!^[[:space:]]*macro_optional_add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
668 -e "\!^[[:space:]]*MACRO_OPTIONAL_ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
669 -i CMakeLists.txt || die "failed to comment out handbook"
670 done
671 fi
672 else
673 enable_selected_doc_linguas
674 fi
695 fi 675 fi
696 676
697 # SCM bootstrap 677 # SCM bootstrap
698 if [[ ${BUILD_TYPE} = live ]]; then 678 if [[ ${KDE_BUILD_TYPE} = live ]]; then
699 if has subversion ${INHERITED}; then 679 case ${KDE_SCM} in
700 subversion_src_prepare 680 svn) subversion_src_prepare ;;
701 elif has git ${INHERITED}; then 681 esac
702 git_src_prepare
703 fi
704 fi 682 fi
705 683
706 # Apply patches 684 # Apply patches
707 base_src_prepare 685 base_src_prepare
708 686
714 # Inject library dependencies 692 # Inject library dependencies
715 if [[ -n ${KMLOADLIBS} ]] ; then 693 if [[ -n ${KMLOADLIBS} ]] ; then
716 load_library_dependencies 694 load_library_dependencies
717 fi 695 fi
718 696
719 # Replace KDE4Workspace library targets
720 find "${S}" -name CMakeLists.txt \
721 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
722 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
723 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
724 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
725 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
726 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
727 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
728 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
729 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
730 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
731 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
732 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
733 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
734 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
735 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
736 || die 'failed to replace KDE4Workspace library targets'
737
738 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/... 697 # Hack for manuals relying on outdated DTD, only outside kde-base/...
739 if [[ -z ${KDEBASE} ]]; then 698 if [[ -z ${KDEBASE} ]]; then
740 find "${S}" -name "*.docbook" \ 699 find "${S}" -name "*.docbook" \
741 -exec sed -i -r \ 700 -exec sed -i -r \
742 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \ 701 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
743 || die 'failed to fix DocBook variant version' 702 || die 'failed to fix DocBook variant version'
751 debug-print-function ${FUNCNAME} "$@" 710 debug-print-function ${FUNCNAME} "$@"
752 711
753 # Build tests in src_test only, where we override this value 712 # Build tests in src_test only, where we override this value
754 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF) 713 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
755 714
756 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then 715 if use_if_iuse debug; then
757 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
758 fi
759
760 if has debug ${IUSE//+} && use debug; then
761 # Set "real" debug mode 716 # Set "real" debug mode
762 CMAKE_BUILD_TYPE="Debugfull" 717 CMAKE_KDE_BUILD_TYPE="Debugfull"
763 else 718 else
764 # Handle common release builds 719 # Handle common release builds
765 append-cppflags -DQT_NO_DEBUG 720 append-cppflags -DQT_NO_DEBUG
766 fi 721 fi
767 722
772 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}") 727 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
773 728
774 # Use colors 729 # Use colors
775 QTEST_COLORED=1 730 QTEST_COLORED=1
776 731
777 # Shadow existing /usr installations 732 # Shadow existing installations
778 unset KDEDIRS 733 unset KDEDIRS
779 734
780 # Handle kdeprefix-ed KDE
781 if [[ ${KDEDIR} != /usr ]]; then
782 # Override some environment variables - only when kdeprefix is different,
783 # to not break ccache/distcc
784 PATH="${EKDEDIR}/bin:${PATH}"
785
786 # Append library search path
787 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
788
789 # Append full RPATH
790 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
791
792 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
793 # when more are present
794 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
795 fi
796
797 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling 735 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
798 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4) 736 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/$(get_libdir)/qt4)
799 #kde-config -path data unavailable when cross-compiling 737 #kde-config -path data unavailable when cross-compiling
800 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/) 738 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
801 739
802 # Handle kdeprefix in application itself
803 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
804 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc 740 # sysconf needs to be /etc, not /usr/etc
805 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc) 741 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
806 fi
807 742
808 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then 743 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
744 if [[ ${mycmakeargs} ]]; then
745 eqawarn "mycmakeargs should always be declared as an array, not a string"
746 fi
809 mycmakeargs=(${mycmakeargs}) 747 mycmakeargs=(${mycmakeargs})
810 fi 748 fi
811 749
812 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}") 750 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
813 751
826# @FUNCTION: kde4-base_src_test 764# @FUNCTION: kde4-base_src_test
827# @DESCRIPTION: 765# @DESCRIPTION:
828# Function for testing KDE4 applications. 766# Function for testing KDE4 applications.
829kde4-base_src_test() { 767kde4-base_src_test() {
830 debug-print-function ${FUNCNAME} "$@" 768 debug-print-function ${FUNCNAME} "$@"
769
770 local kded4_pid
771
772 _test_runner() {
773 if [[ -n "${VIRTUALDBUS_TEST}" ]]; then
774 export $(dbus-launch)
775 kded4 2>&1 > /dev/null &
776 kded4_pid=$!
777 fi
778
779 cmake-utils_src_test
780 }
781
782 # When run as normal user during ebuild development with the ebuild command, the
783 # kde tests tend to access the session DBUS. This however is not possible in a real
784 # emerge or on the tinderbox.
785 # > make sure it does not happen, so bad tests can be recognized and disabled
786 unset DBUS_SESSION_BUS_ADDRESS DBUS_SESSION_BUS_PID
831 787
832 # Override this value, set in kde4-base_src_configure() 788 # Override this value, set in kde4-base_src_configure()
833 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON) 789 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
834 cmake-utils_src_configure 790 cmake-utils_src_configure
835 kde4-base_src_compile 791 kde4-base_src_compile
836 792
837 # When run as normal user during ebuild development with the ebuild command, the
838 # kde tests tend to access the session DBUS. This however is not possible in a real
839 # emerge or on the tinderbox.
840 # > make sure it does not happen, so bad tests can be recognized and disabled
841 unset DBUS_SESSION_BUS_ADDRESS
842
843 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then 793 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
844 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default 794 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
845 if [[ ${VIRTUALX_COMMAND} != "emake" ]]; then 795 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
846 # surprise- we are already INSIDE virtualmake!!! 796 # surprise- we are already INSIDE virtualmake!!!
847 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality." 797 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
848 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild." 798 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
849 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the" 799 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
850 debug-print " kde4-base.eclass docs for details... Applying workaround." 800 debug-print " kde4-base.eclass docs for details... Applying workaround."
851 cmake-utils_src_test 801 _test_runner
852 else 802 else
853 VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake 803 VIRTUALX_COMMAND="_test_runner" virtualmake
854 fi 804 fi
855 else 805 else
856 cmake-utils_src_test 806 _test_runner
807 fi
808
809 if [ -n "${kded4_pid}" ] ; then
810 kill ${kded4_pid}
811 fi
812
813 if [ -n "${DBUS_SESSION_BUS_PID}" ] ; then
814 kill ${DBUS_SESSION_BUS_PID}
857 fi 815 fi
858} 816}
859 817
860# @FUNCTION: kde4-base_src_install 818# @FUNCTION: kde4-base_src_install
861# @DESCRIPTION: 819# @DESCRIPTION:
862# Function for installing KDE4 applications. 820# Function for installing KDE4 applications.
863kde4-base_src_install() { 821kde4-base_src_install() {
864 debug-print-function ${FUNCNAME} "$@" 822 debug-print-function ${FUNCNAME} "$@"
865
866 # Prefix support, for usage in ebuilds
867 if [[ ${EAPI} == 2 ]] && ! use prefix; then
868 ED=${D}
869 fi
870 823
871 if [[ -n ${KMSAVELIBS} ]] ; then 824 if [[ -n ${KMSAVELIBS} ]] ; then
872 install_library_dependencies 825 install_library_dependencies
873 fi 826 fi
874 827
875 # Install common documentation of KDE4 applications 828 # Install common documentation of KDE4 applications
876 local doc 829 local doc
877 if ! has kde4-meta ${INHERITED}; then 830 if ! has kde4-meta ${INHERITED}; then
878 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do 831 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
879 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && dodoc "${doc}" 832 [[ -f ${doc} && -s ${doc} ]] && dodoc "${doc}"
880 done 833 done
881 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do 834 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
882 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})" 835 [[ -f ${doc} && -s ${doc} ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
883 done 836 done
884 fi 837 fi
885 838
886 cmake-utils_src_install 839 cmake-utils_src_install
840
841 # In EAPI 4+, we don't want ${PREFIX}/share/doc/HTML to be compressed,
842 # because then khelpcenter can't find the docs
843 [[ ${EAPI:-0} != 3 && -d ${ED}/${PREFIX}/share/doc/HTML ]] &&
844 docompress -x ${PREFIX}/share/doc/HTML
845}
846
847# @FUNCTION: kde4-base_pkg_preinst
848# @DESCRIPTION:
849# Function storing icon caches
850kde4-base_pkg_preinst() {
851 debug-print-function ${FUNCNAME} "$@"
852
853 gnome2_icon_savelist
854 if [[ ${KDE_BUILD_TYPE} == live && ${KDE_SCM} == svn ]]; then
855 subversion_pkg_preinst
856 fi
887} 857}
888 858
889# @FUNCTION: kde4-base_pkg_postinst 859# @FUNCTION: kde4-base_pkg_postinst
890# @DESCRIPTION: 860# @DESCRIPTION:
891# Function to rebuild the KDE System Configuration Cache after an application has been installed. 861# Function to rebuild the KDE System Configuration Cache after an application has been installed.
892kde4-base_pkg_postinst() { 862kde4-base_pkg_postinst() {
893 debug-print-function ${FUNCNAME} "$@" 863 debug-print-function ${FUNCNAME} "$@"
894 864
865 gnome2_icon_cache_update
866 fdo-mime_desktop_database_update
867 fdo-mime_mime_database_update
895 buildsycoca 868 buildsycoca
896 869
897 if [[ ${BUILD_TYPE} = live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then 870 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
898 echo 871 if [[ ${KDE_BUILD_TYPE} = live ]]; then
899 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
900 einfo "Use it at your own risk."
901 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
902 echo
903 elif [[ ${BUILD_TYPE} != live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && has kdeprefix ${IUSE//+} && use kdeprefix; then
904 # warning about kdeprefix for non-live users
905 echo
906 ewarn "WARNING! You have the kdeprefix useflag enabled."
907 ewarn "This setting is strongly discouraged and might lead to potential trouble"
908 ewarn "with KDE update strategies."
909 ewarn "You are using this setup at your own risk and the kde team does not"
910 ewarn "take responsibilities for dead kittens."
911 echo
912 fi
913 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && ! has_version 'kde-base/kdebase-runtime-meta' && ! has_version 'kde-base/kdebase-startkde'; then
914 # warn about not supported approach
915 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
916 echo 872 echo
873 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
874 einfo "Use it at your own risk."
875 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
876 echo
877 fi
878 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta
879 if [[ ${KDEBASE} != kde-base ]] && \
880 ! has_version 'kde-base/kdebase-runtime-meta' && \
881 ! has_version 'kde-base/kdebase-startkde'; then
882 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
883 echo
917 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\"" 884 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
918 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above." 885 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
919 ewarn "With this setting you are unsupported by KDE team." 886 ewarn "With this setting you are unsupported by KDE team."
920 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID." 887 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
888 fi
921 fi 889 fi
922 fi 890 fi
923} 891}
924 892
925# @FUNCTION: kde4-base_pkg_postrm 893# @FUNCTION: kde4-base_pkg_postrm
926# @DESCRIPTION: 894# @DESCRIPTION:
927# Function to rebuild the KDE System Configuration Cache after an application has been removed. 895# Function to rebuild the KDE System Configuration Cache after an application has been removed.
928kde4-base_pkg_postrm() { 896kde4-base_pkg_postrm() {
929 debug-print-function ${FUNCNAME} "$@" 897 debug-print-function ${FUNCNAME} "$@"
930 898
899 gnome2_icon_cache_update
900 fdo-mime_desktop_database_update
901 fdo-mime_mime_database_update
931 buildsycoca 902 buildsycoca
932} 903}

Legend:
Removed from v.1.85  
changed lines
  Added in v.1.122

  ViewVC Help
Powered by ViewVC 1.1.20