/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.127 Revision 1.128
1# Copyright 1999-2013 Gentoo Foundation 1# Copyright 1999-2013 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.127 2013/07/23 19:55:30 johu Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.128 2013/08/15 14:52:58 kensington Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 based ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds currently support EAPIs 3, 4, and 5. This will be 13# NOTE: KDE 4 ebuilds currently support EAPIs 4 and 5. This will be
14# reviewed over time as new EAPI versions are approved. 14# reviewed over time as new EAPI versions are approved.
15 15
16if [[ ${___ECLASS_ONCE_KDE4_BASE} != "recur -_+^+_- spank" ]] ; then 16if [[ ${___ECLASS_ONCE_KDE4_BASE} != "recur -_+^+_- spank" ]] ; then
17___ECLASS_ONCE_KDE4_BASE="recur -_+^+_- spank" 17___ECLASS_ONCE_KDE4_BASE="recur -_+^+_- spank"
18 18
334# all packages needs oxygen icons for basic iconset 334# all packages needs oxygen icons for basic iconset
335if [[ ${PN} != oxygen-icons ]]; then 335if [[ ${PN} != oxygen-icons ]]; then
336 kderdepend+=" $(add_kdebase_dep oxygen-icons)" 336 kderdepend+=" $(add_kdebase_dep oxygen-icons)"
337fi 337fi
338 338
339# add a dependency over kde-l10n if EAPI4 or better is around
340if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} && ${EAPI:-0} != 3 ]]; then 339if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} ]]; then
341 for _lingua in ${KDE_LINGUAS}; do 340 for _lingua in ${KDE_LINGUAS}; do
342 # if our package has lignuas, pull in kde-l10n with selected lingua enabled, 341 # if our package has lignuas, pull in kde-l10n with selected lingua enabled,
343 # but only for selected ones. 342 # but only for selected ones.
344 # this can't be done on one line because if user doesn't use any localisation 343 # this can't be done on one line because if user doesn't use any localisation
345 # then he is probably not interested in kde-l10n at all. 344 # then he is probably not interested in kde-l10n at all.
620 619
621 # Check if gcc compiler is fresh enough. 620 # Check if gcc compiler is fresh enough.
622 # In theory should be in pkg_pretend but we check it only for kdelibs there 621 # In theory should be in pkg_pretend but we check it only for kdelibs there
623 # and for others we do just quick scan in pkg_setup because pkg_pretend 622 # and for others we do just quick scan in pkg_setup because pkg_pretend
624 # executions consume quite some time. 623 # executions consume quite some time.
625 # We can only do this for EAPI 4 or later because the MERGE_TYPE variable
626 # is otherwise undefined.
627 if [[ ${EAPI:-0} != 3 ]]; then
628 if [[ ${MERGE_TYPE} != binary ]]; then 624 if [[ ${MERGE_TYPE} != binary ]]; then
629 [[ $(gcc-major-version) -lt 4 ]] || \ 625 [[ $(gcc-major-version) -lt 4 ]] || \
630 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 3 ]] ) \ 626 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 3 ]] ) \
631 && die "Sorry, but gcc-4.3 and earlier wont work for KDE (see bug 354837)." 627 && die "Sorry, but gcc-4.3 and earlier wont work for KDE (see bug 354837)."
632 fi
633 fi 628 fi
634 629
635 KDEDIR=/usr 630 KDEDIR=/usr
636 : ${PREFIX:=/usr} 631 : ${PREFIX:=/usr}
637 EKDEDIR=${EPREFIX}/usr 632 EKDEDIR=${EPREFIX}/usr
864 done 859 done
865 fi 860 fi
866 861
867 cmake-utils_src_install 862 cmake-utils_src_install
868 863
869 # In EAPI 4+, we don't want ${PREFIX}/share/doc/HTML to be compressed, 864 # We don't want ${PREFIX}/share/doc/HTML to be compressed,
870 # because then khelpcenter can't find the docs 865 # because then khelpcenter can't find the docs
871 [[ ${EAPI:-0} != 3 && -d ${ED}/${PREFIX}/share/doc/HTML ]] && 866 [[ -d ${ED}/${PREFIX}/share/doc/HTML ]] &&
872 docompress -x ${PREFIX}/share/doc/HTML 867 docompress -x ${PREFIX}/share/doc/HTML
873} 868}
874 869
875# @FUNCTION: kde4-base_pkg_preinst 870# @FUNCTION: kde4-base_pkg_preinst
876# @DESCRIPTION: 871# @DESCRIPTION:

Legend:
Removed from v.1.127  
changed lines
  Added in v.1.128

  ViewVC Help
Powered by ViewVC 1.1.20