/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.3 Revision 1.96
1# Copyright 2007-2008 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.3 2008/02/18 17:00:32 ingmar Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.96 2011/06/06 21:38:18 abcd Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.0 ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 monolithic ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: This eclass uses the SLOT dependencies from EAPI="1" or compatible, 13# NOTE: KDE 4 ebuilds currently support EAPI "3". This will be reviewed
14# hence you must define EAPI="1" in the ebuild, before inheriting any eclasses. 14# over time as new EAPI versions are approved.
15 15
16inherit base eutils multilib cmake-utils kde4-functions 16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION:
18# For proper description see virtualx.eclass manpage.
19# Here we redefine default value to be manual, if your package needs virtualx
20# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
21: ${VIRTUALX_REQUIRED:=manual}
17 22
23inherit kde4-functions toolchain-funcs fdo-mime gnome2-utils base virtualx versionator eutils
24
25if [[ ${BUILD_TYPE} = live ]]; then
26 case ${KDE_SCM} in
27 svn) inherit subversion ;;
28 git) inherit git-2 ;;
29 esac
30fi
31
32# @ECLASS-VARIABLE: CMAKE_REQUIRED
33# @DESCRIPTION:
34# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
35# Please note that if it's set to 'never' you need to explicitly override following phases:
36# src_configure, src_compile, src_test and src_install.
37# Defaults to 'always'.
38: ${CMAKE_REQUIRED:=always}
39if [[ ${CMAKE_REQUIRED} = always ]]; then
40 buildsystem_eclass="cmake-utils"
41 export_fns="src_configure src_compile src_test src_install"
42fi
43
44# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
45if [[ -n ${KDE_MINIMAL} ]]; then
46 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
47 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
48 done
49 unset slot
50 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
51else
52 KDE_MINIMAL_VALID=1
53fi
54
55# @ECLASS-VARIABLE: KDE_MINIMAL
56# @DESCRIPTION:
57# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
58# version for apps to work. Currently defaults to 4.4
59# One may override this variable to raise version requirements.
60# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
61# Note that it is fixed to ${SLOT} for kde-base packages.
62KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
63
64# Set slot for KDEBASE known packages
65case ${KDEBASE} in
66 kde-base)
67 SLOT=$(_calculate_kde_slot)
68 [[ -z ${SLOT} ]] && die "Unsupported ${PV}"
69 KDE_MINIMAL="${SLOT}"
70 ;;
71 koffice)
72 SLOT="2"
73 ;;
74 kdevelop)
75 if [[ ${BUILD_TYPE} = live ]]; then
76 # @ECLASS-VARIABLE: KDEVELOP_VERSION
77 # @DESCRIPTION:
78 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
79 # Applies to KDEBASE=kdevelop only.
80 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
81 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
82 # @DESCRIPTION:
83 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
84 # Applies to KDEBASE=kdevelop only.
85 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
86 else
87 case ${PN} in
88 kdevelop|quanta)
89 KDEVELOP_VERSION=${PV}
90 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
91 ;;
92 kdevplatform)
93 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
94 KDEVPLATFORM_VERSION=${PV}
95 ;;
96 *)
97 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
98 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
99 esac
100 fi
101 SLOT="4"
102 ;;
103esac
104
105inherit ${buildsystem_eclass}
106
18EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_test src_install pkg_postinst pkg_postrm 107EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_preinst pkg_postinst pkg_postrm
19 108
20COMMONDEPEND=">=x11-libs/qt-4.3.3:4" 109unset buildsystem_eclass
21DEPEND="${DEPEND} ${COMMONDEPEND} 110unset export_fns
22 >=dev-util/cmake-2.4.7-r1 111
112# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
113# @DESCRIPTION:
114# Is qt-declarative required? Possible values are 'always', 'optional' and 'never'.
115# This variable must be set before inheriting any eclasses. Defaults to 'never'.
116DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
117
118# @ECLASS-VARIABLE: QTHELP_REQUIRED
119# @DESCRIPTION:
120# Is qt-assistant required? Possible values are 'always', 'optional' and 'never'.
121# This variable must be set before inheriting any eclasses. Defaults to 'never'.
122QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
123
124# @ECLASS-VARIABLE: OPENGL_REQUIRED
125# @DESCRIPTION:
126# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
127# This variable must be set before inheriting any eclasses. Defaults to 'never'.
128OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
129
130# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
131# @DESCRIPTION:
132# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
133# This variable must be set before inheriting any eclasses. Defaults to 'never'.
134MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
135
136# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
137# @DESCRIPTION:
138# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
139# This variable must be set before inheriting any eclasses. Defaults to 'never'.
140CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
141
142# @ECLASS-VARIABLE: KDE_REQUIRED
143# @DESCRIPTION:
144# Is kde required? Possible values are 'always', 'optional' and 'never'.
145# This variable must be set before inheriting any eclasses. Defaults to 'always'
146# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
147# Note that for kde-base packages this variable is fixed to 'always'.
148KDE_REQUIRED="${KDE_REQUIRED:-always}"
149
150# @ECLASS-VARIABLE: KDE_HANDBOOK
151# @DESCRIPTION:
152# Set to enable handbook in application. Possible values are 'always', 'optional'
153# (handbook USE flag) and 'never'.
154# This variable must be set before inheriting any eclasses. Defaults to 'never'.
155# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
156# ensures buildtime and runtime dependencies.
157KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
158
159# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
160# @DESCRIPTION:
161# Set this varible if you want your live package to manage its
162# translations. (Mostly all kde ebuilds does not ship documentation
163# and translations in live ebuilds)
164if [[ ${BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
165 # Kdebase actualy provides the handbooks even for live stuff
166 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
167 KDE_LINGUAS=""
168fi
169
170# Setup packages inheriting this eclass
171case ${KDEBASE} in
172 kde-base)
173 HOMEPAGE="http://www.kde.org/"
174 LICENSE="GPL-2"
175 if [[ $BUILD_TYPE = live ]]; then
176 # Disable tests for live ebuilds
177 RESTRICT+=" test"
178 fi
179
180 # Only add the kdeprefix USE flag for older versions, to help
181 # non-portage package managers handle the upgrade
182 if [[ ${PV} < 4.6.4 ]]; then
183 IUSE+=" kdeprefix"
184 fi
185
186 # This code is to prevent portage from searching GENTOO_MIRRORS for
187 # packages that will never be mirrored. (As they only will ever be in
188 # the overlay).
189 case ${PV} in
190 *9999* | 4.?.[6-9]?)
191 RESTRICT+=" mirror"
192 ;;
193 esac
194 # Block installation of other SLOTS unless kdeprefix
195 RDEPEND+=" $(block_other_slots)"
196 ;;
197 koffice)
198 HOMEPAGE="http://www.koffice.org/"
199 LICENSE="GPL-2"
200 ;;
201 kdevelop)
202 HOMEPAGE="http://www.kdevelop.org/"
203 LICENSE="GPL-2"
204 ;;
205esac
206
207# @ECLASS-VARIABLE: QT_MINIMAL
208# @DESCRIPTION:
209# Determine version of qt we enforce as minimal for the package.
210if slot_is_at_least 4.6 "${KDE_MINIMAL}"; then
211 QT_MINIMAL="${QT_MINIMAL:-4.7.0}"
212else
213 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
214fi
215
216# Declarative dependencies
217qtdeclarativedepend="
218 >=x11-libs/qt-declarative-${QT_MINIMAL}:4
219"
220case ${DECLARATIVE_REQUIRED} in
221 always)
222 COMMONDEPEND+=" ${qtdeclarativedepend}"
223 ;;
224 optional)
225 IUSE+=" declarative"
226 COMMONDEPEND+=" declarative? ( ${qtdeclarativedepend} )"
227 ;;
228 *) ;;
229esac
230unset qtdeclarativedepend
231
232# QtHelp dependencies
233qthelpdepend="
234 >=x11-libs/qt-assistant-${QT_MINIMAL}:4
235"
236case ${QTHELP_REQUIRED} in
237 always)
238 COMMONDEPEND+=" ${qthelpdepend}"
239 ;;
240 optional)
241 IUSE+=" qthelp"
242 COMMONDEPEND+=" qthelp? ( ${qthelpdepend} )"
243 ;;
244esac
245unset qthelpdepend
246
247# OpenGL dependencies
248qtopengldepend="
249 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
250"
251case ${OPENGL_REQUIRED} in
252 always)
253 COMMONDEPEND+=" ${qtopengldepend}"
254 ;;
255 optional)
256 IUSE+=" opengl"
257 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
258 ;;
259 *) ;;
260esac
261unset qtopengldepend
262
263# MultiMedia dependencies
264qtmultimediadepend="
265 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
266"
267case ${MULTIMEDIA_REQUIRED} in
268 always)
269 COMMONDEPEND+=" ${qtmultimediadepend}"
270 ;;
271 optional)
272 IUSE+=" multimedia"
273 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
274 ;;
275 *) ;;
276esac
277unset qtmultimediadepend
278
279# CppUnit dependencies
280cppuintdepend="
281 dev-util/cppunit
282"
283case ${CPPUNIT_REQUIRED} in
284 always)
285 DEPEND+=" ${cppuintdepend}"
286 ;;
287 optional)
288 IUSE+=" test"
289 DEPEND+=" test? ( ${cppuintdepend} )"
290 ;;
291 *) ;;
292esac
293unset cppuintdepend
294
295
296# WebKit use dependencies
297case ${KDE_REQUIRED} in
298 always)
299 qtwebkitusedeps="[kde]"
300 ;;
301 optional)
302 qtwebkitusedeps="[kde?]"
303 ;;
304 *) ;;
305esac
306# KDE dependencies
307# Qt accessibility classes are needed in various places, bug 325461
308kdecommondepend="
309 dev-lang/perl
310 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
311 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
312 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
313 >=x11-libs/qt-script-${QT_MINIMAL}:4
314 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
315 >=x11-libs/qt-svg-${QT_MINIMAL}:4
316 >=x11-libs/qt-test-${QT_MINIMAL}:4
317 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
318 !aqua? (
319 x11-libs/libXext
320 x11-libs/libXt
321 x11-libs/libXxf86vm
322 x11-libs/libXcomposite
323 )
324"
325
326if [[ ${PN} != kdelibs ]]; then
327 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
328 if [[ ${KDEBASE} = kdevelop ]]; then
329 if [[ ${PN} != kdevplatform ]]; then
330 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
331 # @DESCRIPTION:
332 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
333 # Applies to KDEBASE=kdevelop only.
334 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
335 case ${KDEVPLATFORM_REQUIRED} in
336 always)
337 kdecommondepend+="
338 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
339 "
340 ;;
341 *) ;;
342 esac
343 fi
344 fi
345fi
346
347kdedepend="
348 dev-util/automoc
23 dev-util/pkgconfig 349 dev-util/pkgconfig
24 x11-libs/libXt 350 !aqua? (
351 >=x11-libs/libXtst-1.1.0
25 x11-proto/xf86vidmodeproto" 352 x11-proto/xf86vidmodeproto
26RDEPEND="${RDEPEND} ${COMMONDEPEND}" 353 )
354"
27 355
28if has test ${IUSE//+}; then 356kderdepend=""
29 DEPEND="${DEPEND} 357
30 test? ( dev-util/cppunit )" 358# all packages needs oxygen icons for basic iconset
359if [[ ${PN} != oxygen-icons ]]; then
360 kderdepend+=" $(add_kdebase_dep oxygen-icons)"
31fi 361fi
32 362
33# @ECLASS-VARIABLE: NEED_KDE 363# add a dependency over kde-l10n if EAPI4 or better is around
34# @DESCRIPTION: 364if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} && ${EAPI:-0} != 3 ]]; then
35# This variable sets the version of KDE4 which will be used by the eclass. 365 for _lingua in ${KDE_LINGUAS}; do
36# This variable must be set by the ebuild, for all categories except for "kde-base". 366 # if our package has lignuas, pull in kde-l10n with selected lingua enabled,
37# For kde-base packages, if it is not set by the ebuild, 367 # but only for selected ones.
38# it's assumed that the required KDE4 version is the latest, non-live, available. 368 # this can't be done on one line because if user doesn't use any localisation
39# 369 # then he is probably not interested in kde-l10n at all.
40# @CODE 370 kderdepend+="
41# Acceptable values are: 371 linguas_${_lingua}? ( $(add_kdebase_dep kde-l10n "linguas_${_lingua}(+)") )
42# - latest - Use latest version in the portage tree 372 "
43# Default for kde-base ebuilds. Banned for ebuilds not part of kde or koffice. 373 done
44# - svn - Use svn release (live ebuilds) 374 unset _lingua
45# - :SLOT - Use any version in the SLOT specified in the NEED_KDE value.
46# - VERSION_NUMBER - Use the minimum KDE4 version specified in the NEED_KDE value.
47# - VERSION_NUMBER:SLOT - Use the minimum KDE4 version and the SLOT specified in the NEED_KDE value.
48# - none - Let the ebuild handle SLOT, kde dependencies, KDEDIR, ...
49# @CODE
50#
51# Note: There is no default NEED_KDE for ebuilds not in kde-base or part of
52# koffice, so you must set it explicitly in the ebuild, in all other cases.
53if [[ -z ${NEED_KDE} ]]; then
54 if [[ -n ${KDEBASE} ]]; then
55 NEED_KDE="latest"
56 else
57 die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild"
58 fi
59fi 375fi
60export NEED_KDE
61 376
62case ${NEED_KDE} in 377kdehandbookdepend="
63 latest) 378 app-text/docbook-xml-dtd:4.2
64 # Should only be used by 'kde-base'-ebuilds 379 app-text/docbook-xsl-stylesheets
65 if [[ "${KDEBASE}" == "kde-base" ]]; then 380"
66 case ${PV} in 381kdehandbookrdepend="
67 3.9*) _kdedir="3.9" ;; 382 $(add_kdebase_dep kdelibs 'handbook')
68 4*) _kdedir="4.0" ;; 383"
69 *) die "NEED_KDE=latest not supported for PV=${PV}" ;; 384case ${KDE_HANDBOOK} in
70 esac 385 always)
71 _operator=">=" 386 kdedepend+=" ${kdehandbookdepend}"
72 _pv="-${PV}:kde-4" 387 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
73 else
74 _kdedir="4.0"
75 _pv=":kde-4"
76 fi
77 ;; 388 ;;
78 svn|9999*|:kde-svn) 389 optional)
79 _kdedir="svn" 390 IUSE+=" +handbook"
80 _pv=":kde-svn" 391 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
81 export NEED_KDE="svn" 392 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
82 ;; 393 ;;
83 *:kde-svn) 394 *) ;;
84 _kdedir="svn"
85 _operator=">="
86 _pv="-${NEED_KDE}"
87 export NEED_KDE="svn"
88 ;;
89 # The ebuild handles dependencies, KDEDIR, SLOT.
90 none)
91 :
92 ;;
93 # NEED_KDE=":${SLOT}"
94 :kde-4)
95 _kdedir="4.0"
96 _pv="${NEED_KDE}"
97 ;;
98 # NEED_KDE="${PV}:${SLOT}"
99 *:kde-4)
100 _kdedir="4.0"
101 _operator=">="
102 _pv="-${NEED_KDE}"
103 ;;
104 3.9*)
105 _kdedir="3.9"
106 _operator=">="
107 _pv="-${NEED_KDE}:kde-4"
108 ;;
109 4*)
110 _kdedir="4.0"
111 _operator=">="
112 _pv="-${NEED_KDE}:kde-4"
113 ;;
114 *) die "NEED_KDE=${NEED_KDE} currently not supported."
115 ;;
116esac 395esac
396unset kdehandbookdepend kdehandbookrdepend
117 397
118if [[ ${NEED_KDE} != none ]]; then 398case ${KDE_REQUIRED} in
119 KDEDIR="/usr/kde/${_kdedir}" 399 always)
120 KDEDIRS="/usr:/usr/local:${KDEDIR}" 400 IUSE+=" aqua"
401 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
402 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
403 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
404 ;;
405 optional)
406 IUSE+=" aqua kde"
407 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
408 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
409 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
410 ;;
411 *) ;;
412esac
121 413
122 if [[ -n ${KDEBASE} ]]; then 414unset kdecommondepend kdedepend kderdepend
123 if [[ ${NEED_KDE} = svn ]]; then
124 SLOT="kde-svn"
125 else
126 SLOT="kde-4"
127 fi
128 fi
129 415
130 # We only need to add the dependencies if ${PN} is not "kdelibs" or "kdepimlibs" 416debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
131 if [[ ${PN} != "kdelibs" ]]; then 417debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
418debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
419
420# Accumulate dependencies set by this eclass
132 DEPEND="${DEPEND} 421DEPEND+=" ${COMMONDEPEND}"
133 ${_operator}kde-base/kdelibs${_pv}"
134 RDEPEND="${RDEPEND} 422RDEPEND+=" ${COMMONDEPEND}"
135 ${_operator}kde-base/kdelibs${_pv}" 423unset COMMONDEPEND
136 if [[ ${PN} != "kdepimlibs" ]]; then
137 DEPEND="${DEPEND}
138 ${_operator}kde-base/kdepimlibs${_pv}"
139 RDEPEND="${RDEPEND}
140 ${_operator}kde-base/kdepimlibs${_pv}"
141 fi
142 fi
143 424
144 unset _operator _pv _kdedir 425# Add experimental kdeenablefinal, masked by default
145fi 426IUSE+=" kdeenablefinal"
146 427
147# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 428# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
148# koffice ebuild, the URI should be set in the ebuild itself 429# koffice ebuild, the URI should be set in the ebuild itself
149if [[ -n ${KDEBASE} ]]; then 430_calculate_src_uri() {
431 debug-print-function ${FUNCNAME} "$@"
432
433 local _kmname _kmname_pv
434
435 # we calculate URI only for known KDEBASE modules
436 [[ -n ${KDEBASE} ]] || return
437
438 # calculate tarball module name
150 if [[ -n ${KMNAME} ]]; then 439 if [[ -n ${KMNAME} ]]; then
440 # fixup kdebase-apps name
441 case ${KMNAME} in
442 kdebase-apps)
443 _kmname="kdebase" ;;
444 *)
151 _kmname=${KMNAME} 445 _kmname="${KMNAME}" ;;
446 esac
152 else 447 else
153 _kmname=${PN} 448 _kmname=${PN}
154 fi 449 fi
155 _kmname_pv="${_kmname}-${PV}" 450 _kmname_pv="${_kmname}-${PV}"
156 if [[ ${NEED_KDE} != "svn" ]]; then
157 case ${KDEBASE} in 451 case ${KDEBASE} in
158 kde-base) 452 kde-base)
159 case ${PV} in 453 case ${PV} in
454 4.[456].8[05] | 4.[456].9[023568])
455 # Unstable KDE SC releases
456 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
457 # KDEPIM IS SPECIAL
458 [[ ${KMNAME} == "kdepim" || ${KMNAME} == "kdepim-runtime" ]] && SRC_URI="mirror://kde/unstable/kdepim/${PV}/${_kmname_pv}.tar.bz2"
459 ;;
460 4.4.[6789] | 4.4.1?*)
461 # Stable kdepim releases
462 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
463 ;;
464 *)
465 # Stable KDE SC releases
160 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2";; 466 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
467 ;;
161 esac 468 esac
162 ;; 469 ;;
163 koffice) 470 koffice)
471 case ${PV} in
472 2.[1234].[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
164 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" 473 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
474 esac
165 ;; 475 ;;
476 kdevelop)
477 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
478 ;;
479 esac
480}
481
482_calculate_live_repo() {
483 debug-print-function ${FUNCNAME} "$@"
484
485 SRC_URI=""
486 case ${KDE_SCM} in
487 svn)
488 # Determine branch URL based on live type
489 local branch_prefix
490 case ${PV} in
491 9999*)
492 # trunk
493 branch_prefix="trunk/KDE"
494 ;;
495 *)
496 # branch
497 branch_prefix="branches/KDE/${SLOT}"
498 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
499 # @DESCRIPTION
500 # Suffix appended to ESVN_PROJECT depending on fetched branch.
501 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
502 ESVN_PROJECT_SUFFIX="-${PV}"
503 ;;
504 esac
505 # @ECLASS-VARIABLE: ESVN_MIRROR
506 # @DESCRIPTION:
507 # This variable allows easy overriding of default kde mirror service
508 # (anonsvn) with anything else you might want to use.
509 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
510 # Split ebuild, or extragear stuff
511 if [[ -n ${KMNAME} ]]; then
512 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
513 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
514 KMMODULE="${PN}"
515 fi
516 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
517 case ${KMNAME} in
518 kdebase-*)
519 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
520 ;;
521 kdelibs-*)
522 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
523 ;;
524 kdereview*)
525 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
526 ;;
527 kdesupport)
528 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
529 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
530 ;;
531 kde*)
532 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
533 ;;
534 extragear*|playground*)
535 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
536 # build packages from same svn location.
537 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
538 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
539 ;;
540 koffice)
541 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
542 ;;
543 *)
544 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
545 ;;
546 esac
547 else
548 # kdelibs, kdepimlibs
549 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
550 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
551 fi
552 # @ECLASS-VARIABLE: ESVN_UP_FREQ
553 # @DESCRIPTION:
554 # This variable is used for specifying the timeout between svn synces
555 # for kde-base and koffice modules. Does not affect misc apps.
556 # Default value is 1 hour.
557 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
558 ;;
559 git)
560 local _kmname
561 # @ECLASS-VARIABLE: EGIT_MIRROR
562 # @DESCRIPTION:
563 # This variable allows easy overriding of default kde mirror service
564 # (anongit) with anything else you might want to use.
565 EGIT_MIRROR=${EGIT_MIRROR:=git://anongit.kde.org}
566
567 # @ECLASS-VARIABLE: EGIT_REPONAME
568 # @DESCRIPTION:
569 # This variable allows overriding of default repository
570 # name. Specify only if this differ from PN and KMNAME.
571 if [[ -n ${EGIT_REPONAME} ]]; then
572 # the repository and kmname different
573 _kmname=${EGIT_REPONAME}
574 elif [[ -n ${KMNAME} ]]; then
575 _kmname=${KMNAME}
576 else
577 _kmname=${PN}
578 fi
579
580 # default branching
581 case ${PV} in
582 9999*) ;;
583 *)
584 # set EGIT_BRANCH and EGIT_COMMIT to ${SLOT}
585 case ${_kmname} in
586 kdeplasma-addons | kdepim | kdepim-runtime | kdepimlibs | okular)
587 EGIT_BRANCH="${SLOT}"
588 ;;
589 marble)
590 EGIT_BRANCH="kde-${SLOT}"
591 ;;
592 *) EGIT_BRANCH="KDE/${SLOT}" ;;
593 esac
594 ;;
595 esac
596
597 EGIT_REPO_URI="${EGIT_MIRROR}/${_kmname}"
598
599 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
600 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
601 ;;
602 esac
603}
604
605case ${BUILD_TYPE} in
606 live) _calculate_live_repo ;;
607 *) _calculate_src_uri ;;
608esac
609
610debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
611
612# @ECLASS-VARIABLE: PREFIX
613# @DESCRIPTION:
614# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
615# kde-base packages go into KDE4 installation directory (KDEDIR) by default.
616# No matter the PREFIX, package will be built against KDE installed in KDEDIR.
617
618# @FUNCTION: kde4-base_pkg_setup
619# @DESCRIPTION:
620# Do the basic KDEDIR settings and determine with which kde should
621# optional applications link
622kde4-base_pkg_setup() {
623 debug-print-function ${FUNCNAME} "$@"
624
625 if has kdeprefix ${IUSE//+} && use kdeprefix; then
626 eerror "Sorry, kdeprefix support has been removed."
627 eerror "Please remove kdeprefix from your USE variable."
628 die "kdeprefix support has been removed"
629 fi
630
631 if [[ ${CATEGORY}/${PN} != kde-base/kdelibs && ${CATEGORY}/${PN} != kde-base/kde-env ]] && \
632 { [[ ${KDE_REQUIRED} == always ]] || { [[ ${KDE_REQUIRED} == optional ]] && use kde; }; } && \
633 has_version kde-base/kdelibs[kdeprefix]; then
634 eerror "Sorry, kdeprefix support has been removed."
635 eerror "Please rebuild kdelibs without kdeprefix support."
636 die "kdeprefix support has been removed"
637 fi
638
639 # QA ebuilds
640 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
641
642 # Don't set KDEHOME during compilation, it will cause access violations
643 unset KDEHOME
644
645 # Check if gcc compiler is fresh enough.
646 # In theory should be in pkg_pretend but we check it only for kdelibs there
647 # and for others we do just quick scan in pkg_setup because pkg_pretend
648 # executions consume quite some time.
649 [[ $(gcc-major-version) -lt 4 ]] || \
650 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 3 ]] ) \
651 && die "Sorry, but gcc-4.3 and earlier wont work for KDE (see bug 354837)."
652
653 KDEDIR=/usr
654 : ${PREFIX:=/usr}
655 EKDEDIR=${EPREFIX}/usr
656
657 # Point pkg-config path to KDE *.pc files
658 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
659 # Point to correct QT plugins path
660 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
661
662 # Fix XDG collision with sandbox
663 export XDG_CONFIG_HOME="${T}"
664}
665
666# @FUNCTION: kde4-base_src_unpack
667# @DESCRIPTION:
668# This function unpacks the source tarballs for KDE4 applications.
669kde4-base_src_unpack() {
670 debug-print-function ${FUNCNAME} "$@"
671
672 if [[ ${BUILD_TYPE} = live ]]; then
673 case ${KDE_SCM} in
674 svn)
675 migrate_store_dir
676 subversion_src_unpack
677 ;;
678 git)
679 git-2_src_unpack
680 ;;
166 esac 681 esac
167 fi
168 unset _kmname _kmname_pv
169fi
170
171debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
172debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - before blockers"
173
174# Monolithic ebuilds should add blockers for split ebuilds in the same slot.
175# If KMNAME is not set then this is not a split package
176if [[ -n ${KDEBASE} && -z ${KMNAME} ]]; then
177 for _x in $(get-child-packages ${CATEGORY}/${PN}); do
178 DEPEND="${DEPEND} !${_x}:${SLOT}"
179 RDEPEND="${RDEPEND} !${_x}:${SLOT}"
180 done
181 unset _x
182fi
183
184debug-print "${BASH_SOURCE} ${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - after blockers"
185
186# @ECLASS-VARIABLE: PREFIX
187# @DESCRIPTION:
188# Set the installation PREFIX. All kde-base ebuilds go into the KDE4 installation directory.
189# Applications installed by the other ebuilds go into /usr/ by default, this value
190# can be superseded by defining PREFIX before inheriting kde4-base.
191if [[ -n ${KDEBASE} ]]; then
192 PREFIX=${KDEDIR}
193else 682 else
194 # if PREFIX is not defined we set it to the default value of /usr 683 unpack ${A}
195 PREFIX="${PREFIX:-/usr}"
196fi 684 fi
685}
197 686
198debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SLOT ${SLOT} - KDEDIR ${KDEDIR} - KDEDIRS ${KDEDIRS}- PREFIX ${PREFIX} - NEED_KDE ${NEED_KDE}"
199
200# @FUNCTION: kde4-base_pkg_setup 687# @FUNCTION: kde4-base_src_prepare
201# @DESCRIPTION: 688# @DESCRIPTION:
202# Adds flags needed by all of KDE 4 to $QT4_BUILT_WITH_USE_CHECK. Uses 689# General pre-configure and pre-compile function for KDE4 applications.
203# kde4-functions_check_use from kde4-functions.eclass to print appropriate 690# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
204# errors and die if any required flags listed in $QT4_BUILT_WITH_USE_CHECK or 691# enable_selected_linguas() and enable_selected_doc_linguas()
205# $KDE4_BUILT_WITH_USE_CHECK are missing. 692# in kde4-functions.eclass(5) for further details.
206kde4-base_pkg_setup() { 693kde4-base_src_prepare() {
207 debug-print-function $FUNCNAME "$@" 694 debug-print-function ${FUNCNAME} "$@"
208 695
209 # KDE4 applications require qt4 compiled with USE="accessibility dbus gif jpeg png qt3support ssl zlib". 696 # enable handbook and linguas only when not using live ebuild
210 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} accessibility dbus gif jpeg png qt3support ssl zlib" 697
698 # Only enable selected languages, used for KDE extragear apps.
699 if [[ -n ${KDE_LINGUAS} ]]; then
700 enable_selected_linguas
701 fi
702
703 # Enable/disable handbooks for kde4-base packages
704 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
705 # kdelibs inherits kde4-base but handle installing the handbook itself
706 if ! has kde4-meta ${INHERITED} && has handbook ${IUSE//+}; then
707 if [[ ${KDEBASE} == kde-base ]]; then
708 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
709 # documentation in kde4-functions
710 : ${KDE_DOC_DIRS:=doc}
711 local dir
712 for dir in ${KDE_DOC_DIRS}; do
713 sed -e "\!^[[:space:]]*add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
714 -e "\!^[[:space:]]*ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
715 -e "\!^[[:space:]]*macro_optional_add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
716 -e "\!^[[:space:]]*MACRO_OPTIONAL_ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
717 -i CMakeLists.txt || die "failed to comment out handbook"
718 done
719 fi
720 else
721 enable_selected_doc_linguas
722 fi
723 fi
724
725 # SCM bootstrap
726 if [[ ${BUILD_TYPE} = live ]]; then
727 case ${KDE_SCM} in
728 svn) subversion_src_prepare ;;
729 esac
730 fi
731
732 # Apply patches
733 base_src_prepare
734
735 # Save library dependencies
736 if [[ -n ${KMSAVELIBS} ]] ; then
737 save_library_dependencies
738 fi
739
740 # Inject library dependencies
741 if [[ -n ${KMLOADLIBS} ]] ; then
742 load_library_dependencies
743 fi
744
745 # Replace KDE4Workspace library targets
746 find "${S}" -name CMakeLists.txt \
747 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
748 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
749 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
750 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
751 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
752 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
753 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
754 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
755 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
756 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
757 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
758 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
759 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
760 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
761 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
762 || die 'failed to replace KDE4Workspace library targets'
763
764 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/...
765 if [[ -z ${KDEBASE} ]]; then
766 find "${S}" -name "*.docbook" \
767 -exec sed -i -r \
768 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
769 || die 'failed to fix DocBook variant version'
770 fi
771}
772
773# @FUNCTION: kde4-base_src_configure
774# @DESCRIPTION:
775# Function for configuring the build of KDE4 applications.
776kde4-base_src_configure() {
777 debug-print-function ${FUNCNAME} "$@"
778
779 # Build tests in src_test only, where we override this value
780 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
781
782 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
783 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
784 fi
211 785
212 if has debug ${IUSE//+} && use debug; then 786 if has debug ${IUSE//+} && use debug; then
213 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} debug" 787 # Set "real" debug mode
214 fi 788 CMAKE_BUILD_TYPE="Debugfull"
215
216 if has opengl ${IUSE//+} && use opengl; then
217 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
218 fi
219
220 kde4-functions_check_use
221}
222
223# @FUNCTION: kde4-base_src_unpack
224# @DESCRIPTION:
225# This function unpacks the source tarballs for KDE4 applications.
226#
227# If no argument is passed to this function, then standard src_unpack is
228# executed. Otherwise options are passed to base_src_unpack.
229#
230# If the directory ${WORKDIR}/patches/ exists, we apply all patches in that
231# directory, provided they follow this format:
232# @CODE
233# - Monolithic ebuilds, (from kde-base)
234# - $CATEGORY=kde-base:
235# Apply ${CHILD_EBUILD_NAME}-${SLOT}-*{diff,patch}
236# - $CATEGORY=!kde-base:
237# Apply ${CHILD_EBUILD_NAME}-${PV}-*{diff,patch}
238# - Split ebuilds:
239# - $CATEGORY=kde-base:
240# Apply ${PN}-${SLOT}-*{diff,patch}
241# - $CATEGORY!=kde-base:
242# Apply ${PN}-${PV}-*{diff,patch}
243# @CODE
244#
245# If ${PATCHES} is non-zero all patches in it gets applied.
246kde4-base_src_unpack() {
247 debug-print-function $FUNCNAME "$@"
248
249 [[ -z "${KDE_S}" ]] && KDE_S="${S}"
250
251 local _patchdir _packages _p
252 _patchdir="${WORKDIR}/patches/"
253 if [[ -z $* ]]; then
254 # Unpack first and deal with KDE patches after examing possible patch sets.
255 # To be picked up, patches need to conform to the guidelines stated before.
256 # Monolithic ebuilds will use the split ebuild patches.
257 [[ -d "${KDE_S}" ]] || unpack ${A}
258 if [[ -d "${_patchdir}" ]]; then
259 if is-parent-package ${CATEGORY}/${PN} ; then
260 _packages="$(get-child-packages ${CATEGORY}/${PN})"
261 _packages="${_packages//${CATEGORY}\//} ${PN}"
262 else
263 _packages="${PN}"
264 fi
265 for _p in ${_packages}; do
266 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null)"
267 if [[ -n "${KDEBASE}" ]]; then
268 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null)"
269 fi
270 done
271 fi
272 [[ -n ${PATCHES} ]] && base_src_unpack autopatch
273 else 789 else
274 # Call base_src_unpack, which unpacks and patches 790 # Handle common release builds
275 # step by step transparently as defined in the ebuild. 791 append-cppflags -DQT_NO_DEBUG
276 base_src_unpack $*
277 fi 792 fi
278 793
279 # Updated cmake dir 794 # Set distribution name
280 if [[ -d "${WORKDIR}/cmake" ]] && [[ -d "${KDE_S}/cmake" ]]; then 795 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
281 ebegin "Updating cmake/ directory..." 796
282 rm -rf "${KDE_S}/cmake" || die "Unable to remove old cmake/ directory" 797 # Here we set the install prefix
283 ln -s "${WORKDIR}/cmake" "${KDE_S}/cmake" || die "Unable to symlink the new cmake/ directory" 798 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
284 eend 0 799
800 # Use colors
801 QTEST_COLORED=1
802
803 # Shadow existing /usr installations
804 unset KDEDIRS
805
806 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
807 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/$(get_libdir)/qt4)
808 #kde-config -path data unavailable when cross-compiling
809 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
810
811 # sysconf needs to be /etc, not /usr/etc
812 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
813
814 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
815 mycmakeargs=(${mycmakeargs})
285 fi 816 fi
817
818 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
819
820 cmake-utils_src_configure
286} 821}
287 822
288# @FUNCTION: kde4-base_src_compile 823# @FUNCTION: kde4-base_src_compile
289# @DESCRIPTION: 824# @DESCRIPTION:
290# General function for compiling KDE4 applications. 825# General function for compiling KDE4 applications.
291kde4-base_src_compile() { 826kde4-base_src_compile() {
292 debug-print-function ${FUNCNAME} "$@" 827 debug-print-function ${FUNCNAME} "$@"
293 828
294 kde4-base_src_configure
295 kde4-base_src_make
296}
297
298# @FUNCTION: kde4-base_src_configure
299# @DESCRIPTION:
300# Function for configuring the build of KDE4 applications.
301kde4-base_src_configure() {
302 debug-print-function ${FUNCNAME} "$@"
303
304 # Final flag handling
305 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
306 einfo "Activating enable-final flag"
307 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_FINAL=ON"
308 fi
309
310 # Enable generation of HTML handbook
311 if has htmlhandbook ${IUSE//+} && use htmlhandbook; then
312 einfo "Enabling building of HTML handbook"
313 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_HTMLHANDBOOK=ON"
314 fi
315
316 # Build tests in src_test only, where we override this value
317 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=OFF"
318
319 # Set distribution name
320 [[ ${PN} == "kdelibs" ]] && mycmakeargs="${mycmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo"
321
322 # runpath linking
323 mycmakeargs="${mycmakeargs} -DKDE4_USE_ALWAYS_FULL_RPATH=ON"
324
325 # Here we set the install prefix
326 mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}"
327
328 # Set environment
329 QTEST_COLORED=1
330 QT_PLUGIN_PATH=${KDEDIR}/$(get_libdir)/kde4/plugins/
331
332 cmake-utils_src_configureout
333}
334
335# @FUNCTION: kde4-base_src_make
336# @DESCRIPTION:
337# Function for building KDE4 applications.
338# Options are passed to cmake-utils_src_make.
339kde4-base_src_make() {
340 debug-print-function ${FUNCNAME} "$@"
341
342 cmake-utils_src_make "$@" 829 cmake-utils_src_compile "$@"
343} 830}
344 831
345# @FUNCTION: kde4-base_src_test 832# @FUNCTION: kde4-base_src_test
346# @DESCRIPTION: 833# @DESCRIPTION:
347# Function for testing KDE4 applications. 834# Function for testing KDE4 applications.
348kde4-base_src_test() { 835kde4-base_src_test() {
349 debug-print-function ${FUNCNAME} "$@" 836 debug-print-function ${FUNCNAME} "$@"
350 837
351 # Override this value, set in kde4-base_src_configure() 838 # Override this value, set in kde4-base_src_configure()
352 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON" 839 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
353 cmake-utils_src_compile 840 cmake-utils_src_configure
841 kde4-base_src_compile
354 842
843 # When run as normal user during ebuild development with the ebuild command, the
844 # kde tests tend to access the session DBUS. This however is not possible in a real
845 # emerge or on the tinderbox.
846 # > make sure it does not happen, so bad tests can be recognized and disabled
847 unset DBUS_SESSION_BUS_ADDRESS
848
849 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
850 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
851 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
852 # surprise- we are already INSIDE virtualmake!!!
853 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
854 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
855 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
856 debug-print " kde4-base.eclass docs for details... Applying workaround."
857 cmake-utils_src_test
858 else
859 VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake
860 fi
861 else
355 cmake-utils_src_test 862 cmake-utils_src_test
863 fi
356} 864}
357 865
358# @FUNCTION: kde4-base_src_install 866# @FUNCTION: kde4-base_src_install
359# @DESCRIPTION: 867# @DESCRIPTION:
360# Function for installing KDE4 applications. 868# Function for installing KDE4 applications.
361kde4-base_src_install() { 869kde4-base_src_install() {
362 debug-print-function ${FUNCNAME} "$@" 870 debug-print-function ${FUNCNAME} "$@"
363 871
364 kde4-base_src_make_doc 872 if [[ -n ${KMSAVELIBS} ]] ; then
873 install_library_dependencies
874 fi
875
876 # Install common documentation of KDE4 applications
877 local doc
878 if ! has kde4-meta ${INHERITED}; then
879 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
880 [[ -f ${doc} && -s ${doc} ]] && dodoc "${doc}"
881 done
882 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
883 [[ -f ${doc} && -s ${doc} ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
884 done
885 fi
886
365 cmake-utils_src_install 887 cmake-utils_src_install
366}
367 888
368# @FUNCTION: kde4-base_src_make_doc 889 # In EAPI 4+, we don't want ${PREFIX}/share/doc/HTML to be compressed,
369# @DESCRIPTION: 890 # because then khelpcenter can't find the docs
370# Function for installing the documentation of KDE4 applications. 891 [[ ${EAPI:-0} != 3 && -d ${ED}/${PREFIX}/share/doc/HTML ]] &&
371kde4-base_src_make_doc() { 892 docompress -x ${PREFIX}/share/doc/HTML
372 debug-print-function ${FUNCNAME} "$@" 893}
373 894
374 local doc 895# @FUNCTION: kde4-base_pkg_preinst
375 for doc in AUTHORS ChangeLog* README* NEWS TODO; do 896# @DESCRIPTION:
376 [[ -s $doc ]] && dodoc ${doc} 897# Function storing icon caches
377 done 898kde4-base_pkg_preinst() {
899 debug-print-function ${FUNCNAME} "$@"
378 900
379 if [[ -z ${KMNAME} ]]; then 901 gnome2_icon_savelist
380 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
381 if [[ -s $doc ]]; then
382 local doc_complete=${doc}
383 doc="${doc#*/}"
384 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
385 fi
386 done
387 fi
388
389 if [[ -n ${KDEBASE} && -d "${D}"/usr/share/doc/${PF} ]]; then
390 # work around bug #97196
391 dodir /usr/share/doc/kde && \
392 mv "${D}"/usr/share/doc/${PF} "${D}"/usr/share/doc/kde/ || \
393 die "Failed to move docs to kde/ failed."
394 fi
395} 902}
396 903
397# @FUNCTION: kde4-base_pkg_postinst 904# @FUNCTION: kde4-base_pkg_postinst
398# @DESCRIPTION: 905# @DESCRIPTION:
399# Function to rebuild the KDE System Configuration Cache after an application has been installed. 906# Function to rebuild the KDE System Configuration Cache after an application has been installed.
400kde4-base_pkg_postinst() { 907kde4-base_pkg_postinst() {
908 debug-print-function ${FUNCNAME} "$@"
909
910 gnome2_icon_cache_update
911 fdo-mime_desktop_database_update
912 fdo-mime_mime_database_update
401 buildsycoca 913 buildsycoca
914
915 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
916 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
917 echo
918 ewarn "WARNING! you have kdeenable final useflag enabled."
919 ewarn "This useflag needs to be enabled on ALL kde using packages and"
920 ewarn "is known to cause issues."
921 ewarn "You are using this setup at your own risk and the kde team does not"
922 ewarn "take responsibilities for dead kittens."
923 echo
924 fi
925 if [[ ${BUILD_TYPE} = live ]]; then
926 echo
927 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
928 einfo "Use it at your own risk."
929 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
930 echo
931 fi
932 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta
933 if [[ ${KDEBASE} != kde-base ]] && \
934 ! has_version 'kde-base/kdebase-runtime-meta' && \
935 ! has_version 'kde-base/kdebase-startkde'; then
936 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
937 echo
938 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
939 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
940 ewarn "With this setting you are unsupported by KDE team."
941 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
942 fi
943 fi
944 fi
402} 945}
403 946
404# @FUNCTION: kde4-base_pkg_postrm 947# @FUNCTION: kde4-base_pkg_postrm
405# @DESCRIPTION: 948# @DESCRIPTION:
406# Function to rebuild the KDE System Configuration Cache after an application has been removed. 949# Function to rebuild the KDE System Configuration Cache after an application has been removed.
407kde4-base_pkg_postrm() { 950kde4-base_pkg_postrm() {
951 debug-print-function ${FUNCNAME} "$@"
952
953 gnome2_icon_cache_update
954 fdo-mime_desktop_database_update
955 fdo-mime_mime_database_update
408 buildsycoca 956 buildsycoca
409} 957}

Legend:
Removed from v.1.3  
changed lines
  Added in v.1.96

  ViewVC Help
Powered by ViewVC 1.1.20