/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.3 Revision 1.98
1# Copyright 2007-2008 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.3 2008/02/18 17:00:32 ingmar Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.98 2011/06/09 21:05:45 tampakrap Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.0 ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 monolithic ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: This eclass uses the SLOT dependencies from EAPI="1" or compatible, 13# NOTE: KDE 4 ebuilds currently support EAPI "3". This will be reviewed
14# hence you must define EAPI="1" in the ebuild, before inheriting any eclasses. 14# over time as new EAPI versions are approved.
15 15
16inherit base eutils multilib cmake-utils kde4-functions 16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION:
18# For proper description see virtualx.eclass manpage.
19# Here we redefine default value to be manual, if your package needs virtualx
20# for tests you should proceed with setting VIRTUALX_REQUIRED=test.
21: ${VIRTUALX_REQUIRED:=manual}
17 22
23inherit kde4-functions toolchain-funcs fdo-mime gnome2-utils base virtualx versionator eutils
24
25if [[ ${BUILD_TYPE} = live ]]; then
26 case ${KDE_SCM} in
27 svn) inherit subversion ;;
28 git) inherit git-2 ;;
29 esac
30fi
31
32# @ECLASS-VARIABLE: CMAKE_REQUIRED
33# @DESCRIPTION:
34# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
35# Please note that if it's set to 'never' you need to explicitly override following phases:
36# src_configure, src_compile, src_test and src_install.
37# Defaults to 'always'.
38: ${CMAKE_REQUIRED:=always}
39if [[ ${CMAKE_REQUIRED} = always ]]; then
40 buildsystem_eclass="cmake-utils"
41 export_fns="src_configure src_compile src_test src_install"
42fi
43
44# @ECLASS-VARIABLE: KDE_MINIMAL
45# @DESCRIPTION:
46# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
47# version for apps to work. Currently defaults to 4.4
48# One may override this variable to raise version requirements.
49# Note that it is fixed to ${PV} for kde-base packages.
50KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
51
52# Set slot for KDEBASE known packages
53case ${KDEBASE} in
54 kde-base)
55 SLOT=$(get_kde_version)
56 [[ -z ${SLOT} ]] && die "Unsupported PV ${PV}"
57 KDE_MINIMAL="${PV}"
58 ;;
59 koffice)
60 SLOT="2"
61 ;;
62 kdevelop)
63 if [[ ${BUILD_TYPE} = live ]]; then
64 # @ECLASS-VARIABLE: KDEVELOP_VERSION
65 # @DESCRIPTION:
66 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
67 # Applies to KDEBASE=kdevelop only.
68 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
69 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
70 # @DESCRIPTION:
71 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
72 # Applies to KDEBASE=kdevelop only.
73 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
74 else
75 case ${PN} in
76 kdevelop|quanta)
77 KDEVELOP_VERSION=${PV}
78 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
79 ;;
80 kdevplatform)
81 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
82 KDEVPLATFORM_VERSION=${PV}
83 ;;
84 *)
85 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
86 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
87 esac
88 fi
89 SLOT="4"
90 ;;
91esac
92
93inherit ${buildsystem_eclass}
94
18EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_test src_install pkg_postinst pkg_postrm 95EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_preinst pkg_postinst pkg_postrm
19 96
20COMMONDEPEND=">=x11-libs/qt-4.3.3:4" 97unset buildsystem_eclass
21DEPEND="${DEPEND} ${COMMONDEPEND} 98unset export_fns
22 >=dev-util/cmake-2.4.7-r1 99
100# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
101# @DESCRIPTION:
102# Is qt-declarative required? Possible values are 'always', 'optional' and 'never'.
103# This variable must be set before inheriting any eclasses. Defaults to 'never'.
104DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
105
106# @ECLASS-VARIABLE: QTHELP_REQUIRED
107# @DESCRIPTION:
108# Is qt-assistant required? Possible values are 'always', 'optional' and 'never'.
109# This variable must be set before inheriting any eclasses. Defaults to 'never'.
110QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
111
112# @ECLASS-VARIABLE: OPENGL_REQUIRED
113# @DESCRIPTION:
114# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
115# This variable must be set before inheriting any eclasses. Defaults to 'never'.
116OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
117
118# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
119# @DESCRIPTION:
120# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
121# This variable must be set before inheriting any eclasses. Defaults to 'never'.
122MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
123
124# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
125# @DESCRIPTION:
126# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
127# This variable must be set before inheriting any eclasses. Defaults to 'never'.
128CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
129
130# @ECLASS-VARIABLE: KDE_REQUIRED
131# @DESCRIPTION:
132# Is kde required? Possible values are 'always', 'optional' and 'never'.
133# This variable must be set before inheriting any eclasses. Defaults to 'always'
134# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
135# Note that for kde-base packages this variable is fixed to 'always'.
136KDE_REQUIRED="${KDE_REQUIRED:-always}"
137
138# @ECLASS-VARIABLE: KDE_HANDBOOK
139# @DESCRIPTION:
140# Set to enable handbook in application. Possible values are 'always', 'optional'
141# (handbook USE flag) and 'never'.
142# This variable must be set before inheriting any eclasses. Defaults to 'never'.
143# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
144# ensures buildtime and runtime dependencies.
145KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
146
147# @ECLASS-VARIABLE: KDE_LINGUAS_LIVE_OVERRIDE
148# @DESCRIPTION:
149# Set this varible if you want your live package to manage its
150# translations. (Mostly all kde ebuilds does not ship documentation
151# and translations in live ebuilds)
152if [[ ${BUILD_TYPE} == live && -z ${KDE_LINGUAS_LIVE_OVERRIDE} ]]; then
153 # Kdebase actualy provides the handbooks even for live stuff
154 [[ ${KDEBASE} == kde-base ]] || KDE_HANDBOOK=never
155 KDE_LINGUAS=""
156fi
157
158# Setup packages inheriting this eclass
159case ${KDEBASE} in
160 kde-base)
161 HOMEPAGE="http://www.kde.org/"
162 LICENSE="GPL-2"
163 if [[ $BUILD_TYPE = live ]]; then
164 # Disable tests for live ebuilds
165 RESTRICT+=" test"
166 fi
167
168 # Only add the kdeprefix USE flag for older versions, to help
169 # non-portage package managers handle the upgrade
170 if [[ ${PV} < 4.6.4 && ( ( ${KMNAME} != kdepim && ${PN} != kdepim-runtime ) || ${PV} < 4.6 ) ]]; then
171 IUSE+=" kdeprefix"
172 fi
173
174 # This code is to prevent portage from searching GENTOO_MIRRORS for
175 # packages that will never be mirrored. (As they only will ever be in
176 # the overlay).
177 case ${PV} in
178 *9999* | 4.?.[6-9]?)
179 RESTRICT+=" mirror"
180 ;;
181 esac
182 # Block installation of other SLOTS unless kdeprefix
183 RDEPEND+=" $(block_other_slots)"
184 ;;
185 koffice)
186 HOMEPAGE="http://www.koffice.org/"
187 LICENSE="GPL-2"
188 ;;
189 kdevelop)
190 HOMEPAGE="http://www.kdevelop.org/"
191 LICENSE="GPL-2"
192 ;;
193esac
194
195# @ECLASS-VARIABLE: QT_MINIMAL
196# @DESCRIPTION:
197# Determine version of qt we enforce as minimal for the package.
198if version_is_at_least 4.5.50 "${KDE_MINIMAL}"; then
199 QT_MINIMAL="${QT_MINIMAL:-4.7.0}"
200else
201 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
202fi
203
204# Declarative dependencies
205qtdeclarativedepend="
206 >=x11-libs/qt-declarative-${QT_MINIMAL}:4
207"
208case ${DECLARATIVE_REQUIRED} in
209 always)
210 COMMONDEPEND+=" ${qtdeclarativedepend}"
211 ;;
212 optional)
213 IUSE+=" declarative"
214 COMMONDEPEND+=" declarative? ( ${qtdeclarativedepend} )"
215 ;;
216 *) ;;
217esac
218unset qtdeclarativedepend
219
220# QtHelp dependencies
221qthelpdepend="
222 >=x11-libs/qt-assistant-${QT_MINIMAL}:4
223"
224case ${QTHELP_REQUIRED} in
225 always)
226 COMMONDEPEND+=" ${qthelpdepend}"
227 ;;
228 optional)
229 IUSE+=" qthelp"
230 COMMONDEPEND+=" qthelp? ( ${qthelpdepend} )"
231 ;;
232esac
233unset qthelpdepend
234
235# OpenGL dependencies
236qtopengldepend="
237 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
238"
239case ${OPENGL_REQUIRED} in
240 always)
241 COMMONDEPEND+=" ${qtopengldepend}"
242 ;;
243 optional)
244 IUSE+=" opengl"
245 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
246 ;;
247 *) ;;
248esac
249unset qtopengldepend
250
251# MultiMedia dependencies
252qtmultimediadepend="
253 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
254"
255case ${MULTIMEDIA_REQUIRED} in
256 always)
257 COMMONDEPEND+=" ${qtmultimediadepend}"
258 ;;
259 optional)
260 IUSE+=" multimedia"
261 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
262 ;;
263 *) ;;
264esac
265unset qtmultimediadepend
266
267# CppUnit dependencies
268cppuintdepend="
269 dev-util/cppunit
270"
271case ${CPPUNIT_REQUIRED} in
272 always)
273 DEPEND+=" ${cppuintdepend}"
274 ;;
275 optional)
276 IUSE+=" test"
277 DEPEND+=" test? ( ${cppuintdepend} )"
278 ;;
279 *) ;;
280esac
281unset cppuintdepend
282
283
284# WebKit use dependencies
285case ${KDE_REQUIRED} in
286 always)
287 qtwebkitusedeps="[kde]"
288 ;;
289 optional)
290 qtwebkitusedeps="[kde?]"
291 ;;
292 *) ;;
293esac
294# KDE dependencies
295# Qt accessibility classes are needed in various places, bug 325461
296kdecommondepend="
297 dev-lang/perl
298 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
299 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
300 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
301 >=x11-libs/qt-script-${QT_MINIMAL}:4
302 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
303 >=x11-libs/qt-svg-${QT_MINIMAL}:4
304 >=x11-libs/qt-test-${QT_MINIMAL}:4
305 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
306 !aqua? (
307 x11-libs/libXext
308 x11-libs/libXt
309 x11-libs/libXxf86vm
310 x11-libs/libXcomposite
311 )
312"
313
314if [[ ${PN} != kdelibs ]]; then
315 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
316 if [[ ${KDEBASE} = kdevelop ]]; then
317 if [[ ${PN} != kdevplatform ]]; then
318 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
319 # @DESCRIPTION:
320 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
321 # Applies to KDEBASE=kdevelop only.
322 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
323 case ${KDEVPLATFORM_REQUIRED} in
324 always)
325 kdecommondepend+="
326 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
327 "
328 ;;
329 *) ;;
330 esac
331 fi
332 fi
333fi
334
335kdedepend="
336 dev-util/automoc
23 dev-util/pkgconfig 337 dev-util/pkgconfig
24 x11-libs/libXt 338 !aqua? (
339 >=x11-libs/libXtst-1.1.0
25 x11-proto/xf86vidmodeproto" 340 x11-proto/xf86vidmodeproto
26RDEPEND="${RDEPEND} ${COMMONDEPEND}" 341 )
342"
27 343
28if has test ${IUSE//+}; then 344kderdepend=""
29 DEPEND="${DEPEND} 345
30 test? ( dev-util/cppunit )" 346# all packages needs oxygen icons for basic iconset
347if [[ ${PN} != oxygen-icons ]]; then
348 kderdepend+=" $(add_kdebase_dep oxygen-icons)"
31fi 349fi
32 350
33# @ECLASS-VARIABLE: NEED_KDE 351# add a dependency over kde-l10n if EAPI4 or better is around
34# @DESCRIPTION: 352if [[ ${KDEBASE} != "kde-base" && -n ${KDE_LINGUAS} && ${EAPI:-0} != 3 ]]; then
35# This variable sets the version of KDE4 which will be used by the eclass. 353 for _lingua in ${KDE_LINGUAS}; do
36# This variable must be set by the ebuild, for all categories except for "kde-base". 354 # if our package has lignuas, pull in kde-l10n with selected lingua enabled,
37# For kde-base packages, if it is not set by the ebuild, 355 # but only for selected ones.
38# it's assumed that the required KDE4 version is the latest, non-live, available. 356 # this can't be done on one line because if user doesn't use any localisation
39# 357 # then he is probably not interested in kde-l10n at all.
40# @CODE 358 kderdepend+="
41# Acceptable values are: 359 linguas_${_lingua}? ( $(add_kdebase_dep kde-l10n "linguas_${_lingua}(+)") )
42# - latest - Use latest version in the portage tree 360 "
43# Default for kde-base ebuilds. Banned for ebuilds not part of kde or koffice. 361 done
44# - svn - Use svn release (live ebuilds) 362 unset _lingua
45# - :SLOT - Use any version in the SLOT specified in the NEED_KDE value.
46# - VERSION_NUMBER - Use the minimum KDE4 version specified in the NEED_KDE value.
47# - VERSION_NUMBER:SLOT - Use the minimum KDE4 version and the SLOT specified in the NEED_KDE value.
48# - none - Let the ebuild handle SLOT, kde dependencies, KDEDIR, ...
49# @CODE
50#
51# Note: There is no default NEED_KDE for ebuilds not in kde-base or part of
52# koffice, so you must set it explicitly in the ebuild, in all other cases.
53if [[ -z ${NEED_KDE} ]]; then
54 if [[ -n ${KDEBASE} ]]; then
55 NEED_KDE="latest"
56 else
57 die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild"
58 fi
59fi 363fi
60export NEED_KDE
61 364
62case ${NEED_KDE} in 365kdehandbookdepend="
63 latest) 366 app-text/docbook-xml-dtd:4.2
64 # Should only be used by 'kde-base'-ebuilds 367 app-text/docbook-xsl-stylesheets
65 if [[ "${KDEBASE}" == "kde-base" ]]; then 368"
66 case ${PV} in 369kdehandbookrdepend="
67 3.9*) _kdedir="3.9" ;; 370 $(add_kdebase_dep kdelibs 'handbook')
68 4*) _kdedir="4.0" ;; 371"
69 *) die "NEED_KDE=latest not supported for PV=${PV}" ;; 372case ${KDE_HANDBOOK} in
70 esac 373 always)
71 _operator=">=" 374 kdedepend+=" ${kdehandbookdepend}"
72 _pv="-${PV}:kde-4" 375 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
73 else
74 _kdedir="4.0"
75 _pv=":kde-4"
76 fi
77 ;; 376 ;;
78 svn|9999*|:kde-svn) 377 optional)
79 _kdedir="svn" 378 IUSE+=" +handbook"
80 _pv=":kde-svn" 379 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
81 export NEED_KDE="svn" 380 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
82 ;; 381 ;;
83 *:kde-svn) 382 *) ;;
84 _kdedir="svn"
85 _operator=">="
86 _pv="-${NEED_KDE}"
87 export NEED_KDE="svn"
88 ;;
89 # The ebuild handles dependencies, KDEDIR, SLOT.
90 none)
91 :
92 ;;
93 # NEED_KDE=":${SLOT}"
94 :kde-4)
95 _kdedir="4.0"
96 _pv="${NEED_KDE}"
97 ;;
98 # NEED_KDE="${PV}:${SLOT}"
99 *:kde-4)
100 _kdedir="4.0"
101 _operator=">="
102 _pv="-${NEED_KDE}"
103 ;;
104 3.9*)
105 _kdedir="3.9"
106 _operator=">="
107 _pv="-${NEED_KDE}:kde-4"
108 ;;
109 4*)
110 _kdedir="4.0"
111 _operator=">="
112 _pv="-${NEED_KDE}:kde-4"
113 ;;
114 *) die "NEED_KDE=${NEED_KDE} currently not supported."
115 ;;
116esac 383esac
384unset kdehandbookdepend kdehandbookrdepend
117 385
118if [[ ${NEED_KDE} != none ]]; then 386case ${KDE_REQUIRED} in
119 KDEDIR="/usr/kde/${_kdedir}" 387 always)
120 KDEDIRS="/usr:/usr/local:${KDEDIR}" 388 IUSE+=" aqua"
389 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
390 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
391 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
392 ;;
393 optional)
394 IUSE+=" aqua kde"
395 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
396 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
397 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
398 ;;
399 *) ;;
400esac
121 401
122 if [[ -n ${KDEBASE} ]]; then 402unset kdecommondepend kdedepend kderdepend
123 if [[ ${NEED_KDE} = svn ]]; then
124 SLOT="kde-svn"
125 else
126 SLOT="kde-4"
127 fi
128 fi
129 403
130 # We only need to add the dependencies if ${PN} is not "kdelibs" or "kdepimlibs" 404debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
131 if [[ ${PN} != "kdelibs" ]]; then 405debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
406debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
407
408# Accumulate dependencies set by this eclass
132 DEPEND="${DEPEND} 409DEPEND+=" ${COMMONDEPEND}"
133 ${_operator}kde-base/kdelibs${_pv}"
134 RDEPEND="${RDEPEND} 410RDEPEND+=" ${COMMONDEPEND}"
135 ${_operator}kde-base/kdelibs${_pv}" 411unset COMMONDEPEND
136 if [[ ${PN} != "kdepimlibs" ]]; then
137 DEPEND="${DEPEND}
138 ${_operator}kde-base/kdepimlibs${_pv}"
139 RDEPEND="${RDEPEND}
140 ${_operator}kde-base/kdepimlibs${_pv}"
141 fi
142 fi
143 412
144 unset _operator _pv _kdedir 413# Add experimental kdeenablefinal, masked by default
145fi 414IUSE+=" kdeenablefinal"
146 415
147# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 416# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
148# koffice ebuild, the URI should be set in the ebuild itself 417# koffice ebuild, the URI should be set in the ebuild itself
149if [[ -n ${KDEBASE} ]]; then 418_calculate_src_uri() {
419 debug-print-function ${FUNCNAME} "$@"
420
421 local _kmname _kmname_pv
422
423 # we calculate URI only for known KDEBASE modules
424 [[ -n ${KDEBASE} ]] || return
425
426 # calculate tarball module name
150 if [[ -n ${KMNAME} ]]; then 427 if [[ -n ${KMNAME} ]]; then
428 # fixup kdebase-apps name
429 case ${KMNAME} in
430 kdebase-apps)
431 _kmname="kdebase" ;;
432 *)
151 _kmname=${KMNAME} 433 _kmname="${KMNAME}" ;;
434 esac
152 else 435 else
153 _kmname=${PN} 436 _kmname=${PN}
154 fi 437 fi
155 _kmname_pv="${_kmname}-${PV}" 438 _kmname_pv="${_kmname}-${PV}"
156 if [[ ${NEED_KDE} != "svn" ]]; then
157 case ${KDEBASE} in 439 case ${KDEBASE} in
158 kde-base) 440 kde-base)
159 case ${PV} in 441 case ${PV} in
442 4.[456].8[05] | 4.[456].9[023568])
443 # Unstable KDE SC releases
444 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
445 # KDEPIM IS SPECIAL
446 [[ ${KMNAME} == "kdepim" || ${KMNAME} == "kdepim-runtime" ]] && SRC_URI="mirror://kde/unstable/kdepim/${PV}/${_kmname_pv}.tar.bz2"
447 ;;
448 *)
449 # Stable KDE SC releases
160 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2";; 450 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
451 # KDEPIM IS SPECIAL
452 [[ ${KMNAME} == "kdepim" || ${KMNAME} == "kdepim-runtime" ]] && SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
453 ;;
161 esac 454 esac
162 ;; 455 ;;
163 koffice) 456 koffice)
457 case ${PV} in
458 2.[1234].[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
164 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" 459 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
460 esac
165 ;; 461 ;;
462 kdevelop)
463 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
464 ;;
465 esac
466}
467
468_calculate_live_repo() {
469 debug-print-function ${FUNCNAME} "$@"
470
471 SRC_URI=""
472 case ${KDE_SCM} in
473 svn)
474 # Determine branch URL based on live type
475 local branch_prefix
476 case ${PV} in
477 9999*)
478 # trunk
479 branch_prefix="trunk/KDE"
480 ;;
481 *)
482 # branch
483 branch_prefix="branches/KDE/$(get_kde_version)"
484 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
485 # @DESCRIPTION
486 # Suffix appended to ESVN_PROJECT depending on fetched branch.
487 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
488 ESVN_PROJECT_SUFFIX="-${PV}"
489 ;;
490 esac
491 # @ECLASS-VARIABLE: ESVN_MIRROR
492 # @DESCRIPTION:
493 # This variable allows easy overriding of default kde mirror service
494 # (anonsvn) with anything else you might want to use.
495 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
496 # Split ebuild, or extragear stuff
497 if [[ -n ${KMNAME} ]]; then
498 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
499 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
500 KMMODULE="${PN}"
501 fi
502 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
503 case ${KMNAME} in
504 kdebase-*)
505 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
506 ;;
507 kdelibs-*)
508 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
509 ;;
510 kdereview*)
511 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
512 ;;
513 kdesupport)
514 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
515 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
516 ;;
517 kde*)
518 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
519 ;;
520 extragear*|playground*)
521 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
522 # build packages from same svn location.
523 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
524 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
525 ;;
526 koffice)
527 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
528 ;;
529 *)
530 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
531 ;;
532 esac
533 else
534 # kdelibs, kdepimlibs
535 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
536 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
537 fi
538 # @ECLASS-VARIABLE: ESVN_UP_FREQ
539 # @DESCRIPTION:
540 # This variable is used for specifying the timeout between svn synces
541 # for kde-base and koffice modules. Does not affect misc apps.
542 # Default value is 1 hour.
543 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
544 ;;
545 git)
546 local _kmname
547 # @ECLASS-VARIABLE: EGIT_MIRROR
548 # @DESCRIPTION:
549 # This variable allows easy overriding of default kde mirror service
550 # (anongit) with anything else you might want to use.
551 EGIT_MIRROR=${EGIT_MIRROR:=git://anongit.kde.org}
552
553 # @ECLASS-VARIABLE: EGIT_REPONAME
554 # @DESCRIPTION:
555 # This variable allows overriding of default repository
556 # name. Specify only if this differ from PN and KMNAME.
557 if [[ -n ${EGIT_REPONAME} ]]; then
558 # the repository and kmname different
559 _kmname=${EGIT_REPONAME}
560 elif [[ -n ${KMNAME} ]]; then
561 _kmname=${KMNAME}
562 else
563 _kmname=${PN}
564 fi
565
566 # default branching
567 case ${PV} in
568 9999*) ;;
569 *)
570 # set EGIT_BRANCH and EGIT_COMMIT to $(get_kde_version)
571 case ${_kmname} in
572 kdeplasma-addons | kdepim | kdepim-runtime | kdepimlibs | okular)
573 EGIT_BRANCH="$(get_kde_version)"
574 ;;
575 marble)
576 EGIT_BRANCH="kde-$(get_kde_version)"
577 ;;
578 *) EGIT_BRANCH="KDE/$(get_kde_version)" ;;
579 esac
580 ;;
581 esac
582
583 EGIT_REPO_URI="${EGIT_MIRROR}/${_kmname}"
584
585 debug-print "${FUNCNAME}: Repository: ${EGIT_REPO_URI}"
586 debug-print "${FUNCNAME}: Branch: ${EGIT_BRANCH}"
587 ;;
588 esac
589}
590
591case ${BUILD_TYPE} in
592 live) _calculate_live_repo ;;
593 *) _calculate_src_uri ;;
594esac
595
596debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
597
598# @ECLASS-VARIABLE: PREFIX
599# @DESCRIPTION:
600# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
601# kde-base packages go into KDE4 installation directory (KDEDIR) by default.
602# No matter the PREFIX, package will be built against KDE installed in KDEDIR.
603
604# @FUNCTION: kde4-base_pkg_setup
605# @DESCRIPTION:
606# Do the basic KDEDIR settings and determine with which kde should
607# optional applications link
608kde4-base_pkg_setup() {
609 debug-print-function ${FUNCNAME} "$@"
610
611 if has kdeprefix ${IUSE//+} && use kdeprefix; then
612 eerror "Sorry, kdeprefix support has been removed."
613 eerror "Please remove kdeprefix from your USE variable."
614 die "kdeprefix support has been removed"
615 fi
616
617 if [[ ${CATEGORY}/${PN} != kde-base/kdelibs && ${CATEGORY}/${PN} != kde-base/kde-env ]] && \
618 { [[ ${KDE_REQUIRED} == always ]] || { [[ ${KDE_REQUIRED} == optional ]] && use kde; }; } && \
619 has_version kde-base/kdelibs[kdeprefix]; then
620 eerror "Sorry, kdeprefix support has been removed."
621 eerror "Please rebuild kdelibs without kdeprefix support."
622 die "kdeprefix support has been removed"
623 fi
624
625 # Don't set KDEHOME during compilation, it will cause access violations
626 unset KDEHOME
627
628 # Check if gcc compiler is fresh enough.
629 # In theory should be in pkg_pretend but we check it only for kdelibs there
630 # and for others we do just quick scan in pkg_setup because pkg_pretend
631 # executions consume quite some time.
632 [[ $(gcc-major-version) -lt 4 ]] || \
633 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 3 ]] ) \
634 && die "Sorry, but gcc-4.3 and earlier wont work for KDE (see bug 354837)."
635
636 KDEDIR=/usr
637 : ${PREFIX:=/usr}
638 EKDEDIR=${EPREFIX}/usr
639
640 # Point pkg-config path to KDE *.pc files
641 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
642 # Point to correct QT plugins path
643 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
644
645 # Fix XDG collision with sandbox
646 export XDG_CONFIG_HOME="${T}"
647}
648
649# @FUNCTION: kde4-base_src_unpack
650# @DESCRIPTION:
651# This function unpacks the source tarballs for KDE4 applications.
652kde4-base_src_unpack() {
653 debug-print-function ${FUNCNAME} "$@"
654
655 if [[ ${BUILD_TYPE} = live ]]; then
656 case ${KDE_SCM} in
657 svn)
658 migrate_store_dir
659 subversion_src_unpack
660 ;;
661 git)
662 git-2_src_unpack
663 ;;
166 esac 664 esac
167 fi
168 unset _kmname _kmname_pv
169fi
170
171debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
172debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - before blockers"
173
174# Monolithic ebuilds should add blockers for split ebuilds in the same slot.
175# If KMNAME is not set then this is not a split package
176if [[ -n ${KDEBASE} && -z ${KMNAME} ]]; then
177 for _x in $(get-child-packages ${CATEGORY}/${PN}); do
178 DEPEND="${DEPEND} !${_x}:${SLOT}"
179 RDEPEND="${RDEPEND} !${_x}:${SLOT}"
180 done
181 unset _x
182fi
183
184debug-print "${BASH_SOURCE} ${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - after blockers"
185
186# @ECLASS-VARIABLE: PREFIX
187# @DESCRIPTION:
188# Set the installation PREFIX. All kde-base ebuilds go into the KDE4 installation directory.
189# Applications installed by the other ebuilds go into /usr/ by default, this value
190# can be superseded by defining PREFIX before inheriting kde4-base.
191if [[ -n ${KDEBASE} ]]; then
192 PREFIX=${KDEDIR}
193else 665 else
194 # if PREFIX is not defined we set it to the default value of /usr 666 unpack ${A}
195 PREFIX="${PREFIX:-/usr}"
196fi 667 fi
668}
197 669
198debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SLOT ${SLOT} - KDEDIR ${KDEDIR} - KDEDIRS ${KDEDIRS}- PREFIX ${PREFIX} - NEED_KDE ${NEED_KDE}"
199
200# @FUNCTION: kde4-base_pkg_setup 670# @FUNCTION: kde4-base_src_prepare
201# @DESCRIPTION: 671# @DESCRIPTION:
202# Adds flags needed by all of KDE 4 to $QT4_BUILT_WITH_USE_CHECK. Uses 672# General pre-configure and pre-compile function for KDE4 applications.
203# kde4-functions_check_use from kde4-functions.eclass to print appropriate 673# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
204# errors and die if any required flags listed in $QT4_BUILT_WITH_USE_CHECK or 674# enable_selected_linguas() and enable_selected_doc_linguas()
205# $KDE4_BUILT_WITH_USE_CHECK are missing. 675# in kde4-functions.eclass(5) for further details.
206kde4-base_pkg_setup() { 676kde4-base_src_prepare() {
207 debug-print-function $FUNCNAME "$@" 677 debug-print-function ${FUNCNAME} "$@"
208 678
209 # KDE4 applications require qt4 compiled with USE="accessibility dbus gif jpeg png qt3support ssl zlib". 679 # enable handbook and linguas only when not using live ebuild
210 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} accessibility dbus gif jpeg png qt3support ssl zlib" 680
681 # Only enable selected languages, used for KDE extragear apps.
682 if [[ -n ${KDE_LINGUAS} ]]; then
683 enable_selected_linguas
684 fi
685
686 # Enable/disable handbooks for kde4-base packages
687 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
688 # kdelibs inherits kde4-base but handle installing the handbook itself
689 if ! has kde4-meta ${INHERITED} && has handbook ${IUSE//+}; then
690 if [[ ${KDEBASE} == kde-base ]]; then
691 if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
692 # documentation in kde4-functions
693 : ${KDE_DOC_DIRS:=doc}
694 local dir
695 for dir in ${KDE_DOC_DIRS}; do
696 sed -e "\!^[[:space:]]*add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
697 -e "\!^[[:space:]]*ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
698 -e "\!^[[:space:]]*macro_optional_add_subdirectory[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
699 -e "\!^[[:space:]]*MACRO_OPTIONAL_ADD_SUBDIRECTORY[[:space:]]*([[:space:]]*${dir}[[:space:]]*)!s/^/#DONOTCOMPILE /" \
700 -i CMakeLists.txt || die "failed to comment out handbook"
701 done
702 fi
703 else
704 enable_selected_doc_linguas
705 fi
706 fi
707
708 # SCM bootstrap
709 if [[ ${BUILD_TYPE} = live ]]; then
710 case ${KDE_SCM} in
711 svn) subversion_src_prepare ;;
712 esac
713 fi
714
715 # Apply patches
716 base_src_prepare
717
718 # Save library dependencies
719 if [[ -n ${KMSAVELIBS} ]] ; then
720 save_library_dependencies
721 fi
722
723 # Inject library dependencies
724 if [[ -n ${KMLOADLIBS} ]] ; then
725 load_library_dependencies
726 fi
727
728 # Replace KDE4Workspace library targets
729 find "${S}" -name CMakeLists.txt \
730 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
731 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
732 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
733 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
734 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
735 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
736 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
737 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
738 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
739 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
740 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
741 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
742 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
743 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
744 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
745 || die 'failed to replace KDE4Workspace library targets'
746
747 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/...
748 if [[ -z ${KDEBASE} ]]; then
749 find "${S}" -name "*.docbook" \
750 -exec sed -i -r \
751 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
752 || die 'failed to fix DocBook variant version'
753 fi
754}
755
756# @FUNCTION: kde4-base_src_configure
757# @DESCRIPTION:
758# Function for configuring the build of KDE4 applications.
759kde4-base_src_configure() {
760 debug-print-function ${FUNCNAME} "$@"
761
762 # Build tests in src_test only, where we override this value
763 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
764
765 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
766 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
767 fi
211 768
212 if has debug ${IUSE//+} && use debug; then 769 if has debug ${IUSE//+} && use debug; then
213 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} debug" 770 # Set "real" debug mode
214 fi 771 CMAKE_BUILD_TYPE="Debugfull"
215
216 if has opengl ${IUSE//+} && use opengl; then
217 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
218 fi
219
220 kde4-functions_check_use
221}
222
223# @FUNCTION: kde4-base_src_unpack
224# @DESCRIPTION:
225# This function unpacks the source tarballs for KDE4 applications.
226#
227# If no argument is passed to this function, then standard src_unpack is
228# executed. Otherwise options are passed to base_src_unpack.
229#
230# If the directory ${WORKDIR}/patches/ exists, we apply all patches in that
231# directory, provided they follow this format:
232# @CODE
233# - Monolithic ebuilds, (from kde-base)
234# - $CATEGORY=kde-base:
235# Apply ${CHILD_EBUILD_NAME}-${SLOT}-*{diff,patch}
236# - $CATEGORY=!kde-base:
237# Apply ${CHILD_EBUILD_NAME}-${PV}-*{diff,patch}
238# - Split ebuilds:
239# - $CATEGORY=kde-base:
240# Apply ${PN}-${SLOT}-*{diff,patch}
241# - $CATEGORY!=kde-base:
242# Apply ${PN}-${PV}-*{diff,patch}
243# @CODE
244#
245# If ${PATCHES} is non-zero all patches in it gets applied.
246kde4-base_src_unpack() {
247 debug-print-function $FUNCNAME "$@"
248
249 [[ -z "${KDE_S}" ]] && KDE_S="${S}"
250
251 local _patchdir _packages _p
252 _patchdir="${WORKDIR}/patches/"
253 if [[ -z $* ]]; then
254 # Unpack first and deal with KDE patches after examing possible patch sets.
255 # To be picked up, patches need to conform to the guidelines stated before.
256 # Monolithic ebuilds will use the split ebuild patches.
257 [[ -d "${KDE_S}" ]] || unpack ${A}
258 if [[ -d "${_patchdir}" ]]; then
259 if is-parent-package ${CATEGORY}/${PN} ; then
260 _packages="$(get-child-packages ${CATEGORY}/${PN})"
261 _packages="${_packages//${CATEGORY}\//} ${PN}"
262 else
263 _packages="${PN}"
264 fi
265 for _p in ${_packages}; do
266 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null)"
267 if [[ -n "${KDEBASE}" ]]; then
268 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null)"
269 fi
270 done
271 fi
272 [[ -n ${PATCHES} ]] && base_src_unpack autopatch
273 else 772 else
274 # Call base_src_unpack, which unpacks and patches 773 # Handle common release builds
275 # step by step transparently as defined in the ebuild. 774 append-cppflags -DQT_NO_DEBUG
276 base_src_unpack $*
277 fi 775 fi
278 776
279 # Updated cmake dir 777 # Set distribution name
280 if [[ -d "${WORKDIR}/cmake" ]] && [[ -d "${KDE_S}/cmake" ]]; then 778 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
281 ebegin "Updating cmake/ directory..." 779
282 rm -rf "${KDE_S}/cmake" || die "Unable to remove old cmake/ directory" 780 # Here we set the install prefix
283 ln -s "${WORKDIR}/cmake" "${KDE_S}/cmake" || die "Unable to symlink the new cmake/ directory" 781 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
284 eend 0 782
783 # Use colors
784 QTEST_COLORED=1
785
786 # Shadow existing /usr installations
787 unset KDEDIRS
788
789 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
790 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/$(get_libdir)/qt4)
791 #kde-config -path data unavailable when cross-compiling
792 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
793
794 # sysconf needs to be /etc, not /usr/etc
795 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
796
797 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
798 mycmakeargs=(${mycmakeargs})
285 fi 799 fi
800
801 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
802
803 cmake-utils_src_configure
286} 804}
287 805
288# @FUNCTION: kde4-base_src_compile 806# @FUNCTION: kde4-base_src_compile
289# @DESCRIPTION: 807# @DESCRIPTION:
290# General function for compiling KDE4 applications. 808# General function for compiling KDE4 applications.
291kde4-base_src_compile() { 809kde4-base_src_compile() {
292 debug-print-function ${FUNCNAME} "$@" 810 debug-print-function ${FUNCNAME} "$@"
293 811
294 kde4-base_src_configure
295 kde4-base_src_make
296}
297
298# @FUNCTION: kde4-base_src_configure
299# @DESCRIPTION:
300# Function for configuring the build of KDE4 applications.
301kde4-base_src_configure() {
302 debug-print-function ${FUNCNAME} "$@"
303
304 # Final flag handling
305 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
306 einfo "Activating enable-final flag"
307 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_FINAL=ON"
308 fi
309
310 # Enable generation of HTML handbook
311 if has htmlhandbook ${IUSE//+} && use htmlhandbook; then
312 einfo "Enabling building of HTML handbook"
313 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_HTMLHANDBOOK=ON"
314 fi
315
316 # Build tests in src_test only, where we override this value
317 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=OFF"
318
319 # Set distribution name
320 [[ ${PN} == "kdelibs" ]] && mycmakeargs="${mycmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo"
321
322 # runpath linking
323 mycmakeargs="${mycmakeargs} -DKDE4_USE_ALWAYS_FULL_RPATH=ON"
324
325 # Here we set the install prefix
326 mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}"
327
328 # Set environment
329 QTEST_COLORED=1
330 QT_PLUGIN_PATH=${KDEDIR}/$(get_libdir)/kde4/plugins/
331
332 cmake-utils_src_configureout
333}
334
335# @FUNCTION: kde4-base_src_make
336# @DESCRIPTION:
337# Function for building KDE4 applications.
338# Options are passed to cmake-utils_src_make.
339kde4-base_src_make() {
340 debug-print-function ${FUNCNAME} "$@"
341
342 cmake-utils_src_make "$@" 812 cmake-utils_src_compile "$@"
343} 813}
344 814
345# @FUNCTION: kde4-base_src_test 815# @FUNCTION: kde4-base_src_test
346# @DESCRIPTION: 816# @DESCRIPTION:
347# Function for testing KDE4 applications. 817# Function for testing KDE4 applications.
348kde4-base_src_test() { 818kde4-base_src_test() {
349 debug-print-function ${FUNCNAME} "$@" 819 debug-print-function ${FUNCNAME} "$@"
350 820
351 # Override this value, set in kde4-base_src_configure() 821 # Override this value, set in kde4-base_src_configure()
352 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON" 822 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
353 cmake-utils_src_compile 823 cmake-utils_src_configure
824 kde4-base_src_compile
354 825
826 # When run as normal user during ebuild development with the ebuild command, the
827 # kde tests tend to access the session DBUS. This however is not possible in a real
828 # emerge or on the tinderbox.
829 # > make sure it does not happen, so bad tests can be recognized and disabled
830 unset DBUS_SESSION_BUS_ADDRESS
831
832 if [[ ${VIRTUALX_REQUIRED} == always || ${VIRTUALX_REQUIRED} == test ]]; then
833 # check for sanity if anyone already redefined VIRTUALX_COMMAND from the default
834 if [[ ${VIRTUALX_COMMAND} != emake ]]; then
835 # surprise- we are already INSIDE virtualmake!!!
836 debug-print "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
837 debug-print " You may NOT set VIRTUALX_COMMAND or call virtualmake from the ebuild."
838 debug-print " Setting VIRTUALX_REQUIRED is completely sufficient. See the"
839 debug-print " kde4-base.eclass docs for details... Applying workaround."
840 cmake-utils_src_test
841 else
842 VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake
843 fi
844 else
355 cmake-utils_src_test 845 cmake-utils_src_test
846 fi
356} 847}
357 848
358# @FUNCTION: kde4-base_src_install 849# @FUNCTION: kde4-base_src_install
359# @DESCRIPTION: 850# @DESCRIPTION:
360# Function for installing KDE4 applications. 851# Function for installing KDE4 applications.
361kde4-base_src_install() { 852kde4-base_src_install() {
362 debug-print-function ${FUNCNAME} "$@" 853 debug-print-function ${FUNCNAME} "$@"
363 854
364 kde4-base_src_make_doc 855 if [[ -n ${KMSAVELIBS} ]] ; then
856 install_library_dependencies
857 fi
858
859 # Install common documentation of KDE4 applications
860 local doc
861 if ! has kde4-meta ${INHERITED}; then
862 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
863 [[ -f ${doc} && -s ${doc} ]] && dodoc "${doc}"
864 done
865 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
866 [[ -f ${doc} && -s ${doc} ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
867 done
868 fi
869
365 cmake-utils_src_install 870 cmake-utils_src_install
366}
367 871
368# @FUNCTION: kde4-base_src_make_doc 872 # In EAPI 4+, we don't want ${PREFIX}/share/doc/HTML to be compressed,
369# @DESCRIPTION: 873 # because then khelpcenter can't find the docs
370# Function for installing the documentation of KDE4 applications. 874 [[ ${EAPI:-0} != 3 && -d ${ED}/${PREFIX}/share/doc/HTML ]] &&
371kde4-base_src_make_doc() { 875 docompress -x ${PREFIX}/share/doc/HTML
372 debug-print-function ${FUNCNAME} "$@" 876}
373 877
374 local doc 878# @FUNCTION: kde4-base_pkg_preinst
375 for doc in AUTHORS ChangeLog* README* NEWS TODO; do 879# @DESCRIPTION:
376 [[ -s $doc ]] && dodoc ${doc} 880# Function storing icon caches
377 done 881kde4-base_pkg_preinst() {
882 debug-print-function ${FUNCNAME} "$@"
378 883
379 if [[ -z ${KMNAME} ]]; then 884 gnome2_icon_savelist
380 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
381 if [[ -s $doc ]]; then
382 local doc_complete=${doc}
383 doc="${doc#*/}"
384 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
385 fi
386 done
387 fi
388
389 if [[ -n ${KDEBASE} && -d "${D}"/usr/share/doc/${PF} ]]; then
390 # work around bug #97196
391 dodir /usr/share/doc/kde && \
392 mv "${D}"/usr/share/doc/${PF} "${D}"/usr/share/doc/kde/ || \
393 die "Failed to move docs to kde/ failed."
394 fi
395} 885}
396 886
397# @FUNCTION: kde4-base_pkg_postinst 887# @FUNCTION: kde4-base_pkg_postinst
398# @DESCRIPTION: 888# @DESCRIPTION:
399# Function to rebuild the KDE System Configuration Cache after an application has been installed. 889# Function to rebuild the KDE System Configuration Cache after an application has been installed.
400kde4-base_pkg_postinst() { 890kde4-base_pkg_postinst() {
891 debug-print-function ${FUNCNAME} "$@"
892
893 gnome2_icon_cache_update
894 fdo-mime_desktop_database_update
895 fdo-mime_mime_database_update
401 buildsycoca 896 buildsycoca
897
898 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
899 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
900 echo
901 ewarn "WARNING! you have kdeenable final useflag enabled."
902 ewarn "This useflag needs to be enabled on ALL kde using packages and"
903 ewarn "is known to cause issues."
904 ewarn "You are using this setup at your own risk and the kde team does not"
905 ewarn "take responsibilities for dead kittens."
906 echo
907 fi
908 if [[ ${BUILD_TYPE} = live ]]; then
909 echo
910 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
911 einfo "Use it at your own risk."
912 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
913 echo
914 fi
915 # for all 3rd party soft tell user that he SHOULD install kdebase-startkde or kdebase-runtime-meta
916 if [[ ${KDEBASE} != kde-base ]] && \
917 ! has_version 'kde-base/kdebase-runtime-meta' && \
918 ! has_version 'kde-base/kdebase-startkde'; then
919 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
920 echo
921 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
922 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
923 ewarn "With this setting you are unsupported by KDE team."
924 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
925 fi
926 fi
927 fi
402} 928}
403 929
404# @FUNCTION: kde4-base_pkg_postrm 930# @FUNCTION: kde4-base_pkg_postrm
405# @DESCRIPTION: 931# @DESCRIPTION:
406# Function to rebuild the KDE System Configuration Cache after an application has been removed. 932# Function to rebuild the KDE System Configuration Cache after an application has been removed.
407kde4-base_pkg_postrm() { 933kde4-base_pkg_postrm() {
934 debug-print-function ${FUNCNAME} "$@"
935
936 gnome2_icon_cache_update
937 fdo-mime_desktop_database_update
938 fdo-mime_mime_database_update
408 buildsycoca 939 buildsycoca
409} 940}

Legend:
Removed from v.1.3  
changed lines
  Added in v.1.98

  ViewVC Help
Powered by ViewVC 1.1.20