/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.39 Revision 1.53
1# Copyright 2007-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.39 2009/06/04 09:29:54 scarabeus Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.53 2009/11/25 19:51:11 tampakrap Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but 13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but
14# eclass will fail with version older than 2. 14# eclass will fail with version older than 2.
15 15
16inherit base cmake-utils eutils kde4-functions 16# @ECLASS-VARIABLE: CMAKE_REQUIRED
17# @DESCRIPTION:
18# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
19# Please note that if it's set to 'never' you need to explicitly override following phases:
20# src_configure, src_compile, src_test and src_install.
21# Defaults to 'always'.
22CMAKE_REQUIRED="${CMAKE_REQUIRED:-${CMAKE_REQUIRED:-always}}"
23if [[ ${CMAKE_REQUIRED} = false || ${CMAKE_REQUIRED} = never ]]; then
24 buildsystem_eclass=""
25 export_fns=""
26else
27 buildsystem_eclass="cmake-utils"
28 export_fns="src_configure src_compile src_test src_install"
29fi
30
31inherit kde4-functions
17 32
18get_build_type 33get_build_type
19if [[ ${BUILD_TYPE} = live ]]; then 34if [[ ${BUILD_TYPE} = live ]]; then
20 inherit subversion 35 subversion_eclass="subversion"
21fi 36fi
22 37
38inherit base ${buildsystem_eclass} eutils ${subversion_eclass}
39
23EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare src_configure src_compile src_test src_install pkg_postinst pkg_postrm 40EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm
41
42unset buildsystem_eclass
43unset export_fns
44unset subversion_eclass
45
46case ${KDEBASE} in
47 kde-base)
48 HOMEPAGE="http://www.kde.org/"
49 LICENSE="GPL-2"
50 ;;
51 koffice)
52 HOMEPAGE="http://www.koffice.org/"
53 LICENSE="GPL-2"
54 ;;
55esac
24 56
25# @ECLASS-VARIABLE: OPENGL_REQUIRED 57# @ECLASS-VARIABLE: OPENGL_REQUIRED
26# @DESCRIPTION: 58# @DESCRIPTION:
27# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 59# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
28# This variable must be set before inheriting any eclasses. Defaults to 'never'. 60# This variable must be set before inheriting any eclasses. Defaults to 'never'.
59 KDE_MINIMAL_VALID=1 91 KDE_MINIMAL_VALID=1
60fi 92fi
61 93
62# @ECLASS-VARIABLE: KDE_MINIMAL 94# @ECLASS-VARIABLE: KDE_MINIMAL
63# @DESCRIPTION: 95# @DESCRIPTION:
64# This wariable is used when KDE_REQUIRED is set, to specify required KDE minimal 96# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
65# version for apps to work. Currently defaults to 4.2 97# version for apps to work. Currently defaults to 4.3
66# One may override this variable to raise version requirements. 98# One may override this variable to raise version requirements.
67# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables. 99# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
68# Note that for kde-base packages is fixed to ${SLOT}. 100# Note that it is fixed to ${SLOT} for kde-base packages.
69KDE_MINIMAL="${KDE_MINIMAL:-4.2}" 101KDE_MINIMAL="${KDE_MINIMAL:-4.3}"
70 102
71# Fallback behaviour (for now) 103# Setup packages inheriting this eclass
72# TODO Remove when tree is clean 104case ${KDEBASE} in
73if [[ -n ${NEED_KDE} ]]; then 105 kde-base)
74 case ${NEED_KDE} in 106 if [[ $BUILD_TYPE = live ]]; then
75 none) 107 # Disable tests for live ebuilds
76 KDE_REQUIRED="never" 108 RESTRICT+=" test"
77 ;; 109 # Live ebuilds in kde-base default to kdeprefix by default
78 *) 110 IUSE+=" +kdeprefix"
79 KDE_REQUIRED="always" 111 else
80 KDE_MINIMAL="${NEED_KDE}" 112 # All other ebuild types default to -kdeprefix as before
81 ;; 113 IUSE+=" kdeprefix"
114 fi
115 # Determine SLOT from PVs
116 case ${PV} in
117 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
118 4.4* | 4.3.[6-9]*) SLOT="4.4" ;;
119 4.3*) SLOT="4.3" ;;
120 4.2*) SLOT="4.2" ;;
121 9999*) SLOT="live" ;; # regular live
122 *) die "Unsupported ${PV}" ;;
82 esac 123 esac
124 # This code is to prevent portage from searching GENTOO_MIRRORS for
125 # packages that will never be mirrored. (As they only will ever be in
126 # the overlay).
127 case ${PV} in
128 *9999* | 4.?.[6-9]?)
129 RESTRICT+=" mirror"
130 ;;
131 esac
132 KDE_MINIMAL="${SLOT}"
133 _kdedir="${SLOT}"
134
135 # Block installation of other SLOTS unless kdeprefix
136 RDEPEND+=" $(block_other_slots)"
137 ;;
138 koffice)
139 SLOT="2"
140 ;;
141esac
142
143# @ECLASS-VARIABLE: QT_MINIMAL
144# @DESCRIPTION:
145# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1..
146# Currently defaults to 4.5.1 for KDE 4.3 and earlier
147# or 4.6.0_beta for KDE 4.4 and later
148if slot_is_at_least 4.4 "${KDE_MINIMAL}"; then
149 QT_MINIMAL="${QT_MINIMAL:-4.6.0_beta}"
83fi 150fi
84 151
85# @ECLASS-VARIABLE: QT_DEPEND 152QT_MINIMAL="${QT_MINIMAL:-4.5.1}"
86# @DESCRIPTION:
87# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1..
88# Currently defaults to 4.5.1
89QT_DEPEND="${QT_DEPEND:-4.5.1}"
90 153
91# OpenGL dependencies 154# OpenGL dependencies
92qtopengldepend=" 155qtopengldepend="
93 >=x11-libs/qt-opengl-${QT_DEPEND}:4 156 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
94" 157"
95case ${OPENGL_REQUIRED} in 158case ${OPENGL_REQUIRED} in
96 always) 159 always)
97 COMMONDEPEND="${COMMONDEPEND} ${qtopengldepend}" 160 COMMONDEPEND+=" ${qtopengldepend}"
98 ;; 161 ;;
99 optional) 162 optional)
100 IUSE="${IUSE} opengl" 163 IUSE+=" opengl"
101 COMMONDEPEND="${COMMONDEPEND}
102 opengl? ( ${qtopengldepend} ) 164 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
103 "
104 ;; 165 ;;
105 *) ;; 166 *) ;;
106esac 167esac
107unset qtopengldepend 168unset qtopengldepend
108 169
109# WebKit dependencies 170# WebKit dependencies
171case ${KDE_REQUIRED} in
172 always)
173 qtwebkitusedeps="[kde]"
174 ;;
175 optional)
176 qtwebkitusedeps="[kde?]"
177 ;;
178 *) ;;
179esac
110qtwebkitdepend=" 180qtwebkitdepend="
111 >=x11-libs/qt-webkit-${QT_DEPEND}:4 181 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
112" 182"
183unset qtwebkitusedeps
113case ${WEBKIT_REQUIRED} in 184case ${WEBKIT_REQUIRED} in
114 always) 185 always)
115 COMMONDEPEND="${COMMONDEPEND} ${qtwebkitdepend}" 186 COMMONDEPEND+=" ${qtwebkitdepend}"
116 ;; 187 ;;
117 optional) 188 optional)
118 IUSE="${IUSE} webkit" 189 IUSE+=" webkit"
119 COMMONDEPEND="${COMMONDEPEND}
120 webkit? ( ${qtwebkitdepend} ) 190 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
121 "
122 ;; 191 ;;
123 *) ;; 192 *) ;;
124esac 193esac
125unset qtwebkitdepend 194unset qtwebkitdepend
126 195
128cppuintdepend=" 197cppuintdepend="
129 dev-util/cppunit 198 dev-util/cppunit
130" 199"
131case ${CPPUNIT_REQUIRED} in 200case ${CPPUNIT_REQUIRED} in
132 always) 201 always)
133 DEPEND="${DEPEND} ${cppuintdepend}" 202 DEPEND+=" ${cppuintdepend}"
134 ;; 203 ;;
135 optional) 204 optional)
136 IUSE="${IUSE} test" 205 IUSE+=" test"
137 DEPEND="${DEPEND}
138 test? ( ${cppuintdepend} ) 206 DEPEND+=" test? ( ${cppuintdepend} )"
139 "
140 ;; 207 ;;
141 *) ;; 208 *) ;;
142esac 209esac
143unset cppuintdepend 210unset cppuintdepend
144
145# DEPRECATED block
146if [[ ${NEED_KDE} != "none" ]]; then
147 # localization deps
148 # DISABLED UNTIL PMS decide correct approach :(
149 if [[ -n ${KDE_LINGUAS} ]]; then
150 LNG_DEP=""
151 for _lng in ${KDE_LINGUAS}; do
152 # there must be or due to issue if lingua is not present in kde-l10n so
153 # it wont die but pick kde-l10n as-is.
154 LNG_DEP="${LNG_DEP}
155 || (
156 kde-base/kde-l10n[linguas_${_lng},kdeprefix=]
157 kde-base/kde-l10n[kdeprefix=]
158 )
159 "
160 done
161 fi
162fi # NEED_KDE != NONE block
163
164# Setup packages inheriting this eclass
165case ${KDEBASE} in
166 kde-base)
167 if [[ $BUILD_TYPE = live ]]; then
168 # Disable tests for live ebuilds
169 RESTRICT="${RESTRICT} test"
170 # Live ebuilds in kde-base default to kdeprefix by default
171 IUSE="${IUSE} +kdeprefix"
172 else
173 # All other ebuild types default to -kdeprefix as before
174 IUSE="${IUSE} kdeprefix"
175 fi
176 # Determine SLOT from PVs
177 case ${PV} in
178 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
179 4.3* | 4.2.9* | 4.2.8* | 4.2.7* | 4.2.6*) SLOT="4.3" ;;
180 4.2* | 4.1.9* | 4.1.8* | 4.1.7* | 4.1.6*) SLOT="4.2" ;;
181 9999*) SLOT="live" ;; # regular live
182 *) die "Unsupported ${PV}" ;;
183 esac
184 _kdedir="${SLOT}"
185 _pv="-${PV}:${SLOT}"
186 _pvn="-${PV}"
187
188 # Block installation of other SLOTS unless kdeprefix
189 for slot in ${KDE_SLOTS[@]}; do
190 # Block non kdeprefix ${PN} on other slots
191 if [[ ${SLOT} != ${slot} ]]; then
192 RDEPEND="${RDEPEND}
193 !kdeprefix? ( !kde-base/${PN}:${slot}[-kdeprefix] )
194 "
195 fi
196 done
197 unset slot
198 ;;
199 koffice)
200 SLOT="2"
201 _pv="-${KDE_MINIMAL}"
202 _pvn="${_pv}"
203 ;;
204 *)
205 _pv="-${KDE_MINIMAL}"
206 _pvn="${_pv}"
207 ;;
208
209esac
210 211
211# KDE dependencies 212# KDE dependencies
212kdecommondepend=" 213kdecommondepend="
213 dev-lang/perl 214 dev-lang/perl
215 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
216 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
217 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
218 >=x11-libs/qt-script-${QT_MINIMAL}:4
219 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
220 >=x11-libs/qt-svg-${QT_MINIMAL}:4
221 >=x11-libs/qt-test-${QT_MINIMAL}:4
222 !aqua? (
214 x11-libs/libXext 223 x11-libs/libXext
215 x11-libs/libXt 224 x11-libs/libXt
216 x11-libs/libXxf86vm 225 x11-libs/libXxf86vm
217 >=x11-libs/qt-core-${QT_DEPEND}:4[qt3support,ssl] 226 )
218 >=x11-libs/qt-gui-${QT_DEPEND}:4[accessibility,dbus]
219 >=x11-libs/qt-qt3support-${QT_DEPEND}:4[accessibility]
220 >=x11-libs/qt-script-${QT_DEPEND}:4
221 >=x11-libs/qt-sql-${QT_DEPEND}:4[qt3support]
222 >=x11-libs/qt-svg-${QT_DEPEND}:4
223 >=x11-libs/qt-test-${QT_DEPEND}:4
224" 227"
225if [[ ${PN} != kdelibs ]]; then 228if [[ ${PN} != kdelibs ]]; then
226 if [[ ${KDEBASE} = kde-base ]]; then 229 if [[ ${KDEBASE} = kde-base ]]; then
227 kdecommondepend="${kdecommondepend} 230 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
228 kdeprefix? ( >=kde-base/kdelibs${_pv}[kdeprefix] ) 231 # libknotificationitem only when SLOT is 4.3
229 !kdeprefix? ( >=kde-base/kdelibs${_pvn}[-kdeprefix] ) 232 [[ ${PN} != libknotificationitem ]] && [[ ${SLOT} = 4.3 ]] && \
233 kdecommondepend+=" $(add_kdebase_dep libknotificationitem)"
234 else
235 kdecommondepend+="
236 >=kde-base/kdelibs-${KDE_MINIMAL}
230 " 237 "
231 else
232 kdecommondepend="${kdecommondepend}
233 >=kde-base/kdelibs${_pv}
234 "
235 fi 238 fi
236fi 239fi
237unset _pv _pvn
238kdedepend=" 240kdedepend="
239 dev-util/pkgconfig 241 dev-util/pkgconfig
240 >=sys-apps/sandbox-1.3.2
241" 242"
242case ${KDE_REQUIRED} in 243case ${KDE_REQUIRED} in
243 always) 244 always)
245 IUSE+=" aqua"
244 COMMONDEPEND="${COMMONDEPEND} ${kdecommondepend}" 246 COMMONDEPEND+=" ${kdecommondepend}"
245 DEPEND="${DEPEND} ${kdedepend}" 247 DEPEND+=" ${kdedepend}"
246 ;; 248 ;;
247 optional) 249 optional)
248 IUSE="${IUSE} kde" 250 IUSE+=" aqua kde"
249 COMMONDEPEND="${COMMONDEPEND}
250 kde? ( ${kdecommondepend} )" 251 COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
251 DEPEND="${DEPEND}
252 kde? ( ${kdedepend} )" 252 DEPEND+=" kde? ( ${kdedepend} )"
253 ;; 253 ;;
254 *) ;; 254 *) ;;
255esac 255esac
256unset kdecommondepend kdedepend 256unset kdecommondepend kdedepend
257 257
258debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}" 258debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
259debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}" 259debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
260debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}" 260debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
261 261
262# Accumulate dependencies set by this eclass 262# Accumulate dependencies set by this eclass
263DEPEND="${DEPEND} ${COMMONDEPEND}" 263DEPEND+=" ${COMMONDEPEND}"
264RDEPEND="${RDEPEND} ${COMMONDEPEND}" 264RDEPEND+=" ${COMMONDEPEND}"
265unset COMMONDEPEND
265 266
266# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 267# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
267# koffice ebuild, the URI should be set in the ebuild itself 268# koffice ebuild, the URI should be set in the ebuild itself
268case ${BUILD_TYPE} in 269case ${BUILD_TYPE} in
269 live) 270 live)
299 # Split kde-base/ ebuilds: (they reside in trunk/KDE) 300 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
300 case ${KMNAME} in 301 case ${KMNAME} in
301 kdebase-*) 302 kdebase-*)
302 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}" 303 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
303 ;; 304 ;;
305 kdelibs-*)
306 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
307 ;;
304 kdereview) 308 kdereview)
305 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 309 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
306 ;; 310 ;;
307 kdesupport) 311 kdesupport)
308 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}" 312 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
347 esac 351 esac
348 else 352 else
349 _kmname=${PN} 353 _kmname=${PN}
350 fi 354 fi
351 _kmname_pv="${_kmname}-${PV}" 355 _kmname_pv="${_kmname}-${PV}"
352 if [[ $NEED_KDE != live ]]; then
353 case ${KDEBASE} in 356 case ${KDEBASE} in
354 kde-base) 357 kde-base)
355 case ${PV} in 358 case ${PV} in
356 4.2.85|4.2.90) 359 4.3.85 | 4.3.9[0568])
357 # block for normally packed unstable releases 360 # block for normally packed unstable releases
358 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" ;; 361 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
359 4.2.9* | 4.2.8* | 4.2.7* | 4.2.6*) 362 4.3.[6-9]*)
360 SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${PV}/${_kmname_pv}.tar.lzma" ;; 363 SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${PV}/${_kmname_pv}.tar.lzma" ;;
361 4.1.9* | 4.1.8* | 4.1.7* | 4.1.6* | 4.0.9* | 4.0.8*)
362 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
363 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;; 364 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
364 esac 365 esac
365 ;; 366 ;;
366 koffice) 367 koffice)
367 case ${PV} in 368 case ${PV} in
368 1.9*)
369 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" 369 2.0.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" ;;
370 ;;
371 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" ;; 370 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
372 esac 371 esac
373 ;;
374 esac 372 esac
375 fi
376 unset _kmname _kmname_pv 373 unset _kmname _kmname_pv
377 fi 374 fi
378 ;; 375 ;;
379esac 376esac
380 377
382 379
383# @ECLASS-VARIABLE: PREFIX 380# @ECLASS-VARIABLE: PREFIX
384# @DESCRIPTION: 381# @DESCRIPTION:
385# Set the installation PREFIX for non kde-base applications. It defaults to /usr. 382# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
386# kde-base packages go into KDE4 installation directory (KDEDIR) by default. 383# kde-base packages go into KDE4 installation directory (KDEDIR) by default.
387# No matter the PREFIX, package will be built agains KDE installed in KDEDIR. 384# No matter the PREFIX, package will be built against KDE installed in KDEDIR.
388 385
389# @FUNCTION: kde4-base_pkg_setup 386# @FUNCTION: kde4-base_pkg_setup
390# @DESCRIPTION: 387# @DESCRIPTION:
391# Do the basic kdeprefix KDEDIR settings and determine with which kde should 388# Do the basic kdeprefix KDEDIR settings and determine with which kde should
392# optional applications link 389# optional applications link
393kde4-base_pkg_setup() { 390kde4-base_pkg_setup() {
394 debug-print-function ${FUNCNAME} "$@" 391 debug-print-function ${FUNCNAME} "$@"
395 392
393 # Prefix compat:
394 use prefix || EROOT=${ROOT}
395 # Append missing trailing slash character
396 [[ ${EROOT} = */ ]] || EROOT+="/"
397
396 # QA ebuilds 398 # QA ebuilds
397 case ${NEED_KDE} in
398 none) ewarn "QA Notice: using deprecated NEED_KDE variable, use KDE_REQUIRED=\"never\" or KDE_REQUIRED=\"optional\" instead. You may want to override KDE_MINIMAL as well (default is KDE_MINIMAL=\"${KDE_MINIMAL}\")." ;;
399 *) [[ -n ${NEED_KDE} ]] && ewarn "QA Notice: using deprecated NEED_KDE variable, use KDE_MINIMAL instead (default is KDE_MINIMAL=\"${KDE_MINIMAL}\")." ;;
400 esac
401 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})." 399 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
402 400
403 # Don't set KDEHOME during compilation, it will cause access violations 401 # Don't set KDEHOME during compilation, it will cause access violations
404 unset KDEHOME 402 unset KDEHOME
405 403
406 if [[ ${KDEBASE} = kde-base ]]; then 404 if [[ ${KDEBASE} = kde-base ]]; then
407 if use kdeprefix; then 405 if use kdeprefix; then
408 KDEDIR="${ROOT}usr/kde/${_kdedir}" 406 KDEDIR="${EROOT}usr/kde/${_kdedir}"
409 else 407 else
410 KDEDIR="${ROOT}usr" 408 KDEDIR="${EROOT}usr"
411 fi 409 fi
412 PREFIX="${PREFIX:-${KDEDIR}}" 410 PREFIX="${PREFIX:-${KDEDIR}}"
413 else 411 else
414 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL 412 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
415 KDEDIR= 413 KDEDIR=
416 local kde_minimal_met 414 local kde_minimal_met
417 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do 415 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
418 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1 416 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
419 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then 417 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
420 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then 418 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
421 KDEDIR="${ROOT}usr/kde/${slot}" 419 KDEDIR="${EROOT}usr/kde/${slot}"
422 else 420 else
423 KDEDIR="${ROOT}usr" 421 KDEDIR="${EROOT}usr"
424 fi 422 fi
425 break; 423 break;
426 fi 424 fi
427 done 425 done
428 unset slot 426 unset slot
427
428 # Bail out if kdelibs required but not found
429 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
429 [[ -z KDEDIR ]] && die "Failed to determine KDEDIR!" 430 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
431 else
432 [[ -z ${KDEDIR} ]] && KDEDIR="${EROOT}usr"
433 fi
434
430 PREFIX="${PREFIX:-${ROOT}usr}" 435 PREFIX="${PREFIX:-${EROOT}usr}"
431 fi 436 fi
437 # Point pkg-config path to KDE *.pc files
438 export PKG_CONFIG_PATH="${KDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
439 # Point to correct QT plugins path
440 QT_PLUGIN_PATH="${KDEDIR}/$(get_libdir)/kde4/plugins/"
432 441
442 # Fix XDG collision with sandbox
443 export XDG_CONFIG_HOME="${T}"
433 # Not needed anymore 444 # Not needed anymore
434 unset _kdedir 445 unset _kdedir
435} 446}
436 447
437# @FUNCTION: kde4-base_src_unpack 448# @FUNCTION: kde4-base_src_unpack
446 else 457 else
447 base_src_unpack 458 base_src_unpack
448 fi 459 fi
449} 460}
450 461
451# @FUNCTION: kde4-base_src_compile 462# @FUNCTION: kde4-base_src_prepare
452# @DESCRIPTION: 463# @DESCRIPTION:
453# General pre-configure and pre-compile function for KDE4 applications. 464# General pre-configure and pre-compile function for KDE4 applications.
454# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and 465# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
466# enable_selected_linguas() and enable_selected_doc_linguas()
455# enable_selected_linguas() in kde4-functions.eclass(5) for further details. 467# in kde4-functions.eclass(5) for further details.
456kde4-base_src_prepare() { 468kde4-base_src_prepare() {
457 debug-print-function ${FUNCNAME} "$@" 469 debug-print-function ${FUNCNAME} "$@"
458 470
459 # Only enable selected languages, used for KDE extragear apps. 471 # Only enable selected languages, used for KDE extragear apps.
460 if [[ -n ${KDE_LINGUAS} ]]; then 472 if [[ -n ${KDE_LINGUAS} ]]; then
461 enable_selected_linguas 473 enable_selected_linguas
462 fi 474 fi
463 475
476 # Enable/disable handbooks for kde4-base packages
477 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
478 # kdelibs inherits kde4-base but handle installing the handbook itself
479 if ! has kde4-meta ${INHERITED}; then
480 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas
481 fi
482
464 [[ ${BUILD_TYPE} = live ]] && subversion_src_prepare 483 [[ ${BUILD_TYPE} = live ]] && subversion_src_prepare
465 base_src_prepare 484 base_src_prepare
466 485
467 # Save library dependencies 486 # Save library dependencies
468 if [[ -n ${KMSAVELIBS} ]] ; then 487 if [[ -n ${KMSAVELIBS} ]] ; then
493 if has debug ${IUSE//+} && use debug; then 512 if has debug ${IUSE//+} && use debug; then
494 CMAKE_BUILD_TYPE="Debugfull" 513 CMAKE_BUILD_TYPE="Debugfull"
495 fi 514 fi
496 515
497 # Set distribution name 516 # Set distribution name
498 [[ ${PN} = kdelibs ]] && cmakeargs="${cmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo" 517 [[ ${PN} = kdelibs ]] && cmakeargs+=" -DKDE_DISTRIBUTION_TEXT=Gentoo"
499 518
500 # Here we set the install prefix 519 # Here we set the install prefix
501 cmakeargs="${cmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}" 520 cmakeargs+=" -DCMAKE_INSTALL_PREFIX=${PREFIX}"
502 521
503 # Set environment 522 # Use colors
504 QTEST_COLORED=1 523 QTEST_COLORED=1
505 QT_PLUGIN_PATH="${KDEDIR}/$(get_libdir)/kde4/plugins/"
506
507 # Point pkg-config path to KDE *.pc files
508 export PKG_CONFIG_PATH="${KDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
509 524
510 # Shadow existing /usr installations 525 # Shadow existing /usr installations
511 unset KDEDIRS 526 unset KDEDIRS
512 527
528 # Handle kdeprefix-ed KDE
513 if [[ ${KDEDIR} != "${ROOT}usr" ]]; then 529 if [[ ${KDEDIR} != "${EROOT}usr" ]]; then
514 # Override some environment variables - only when kdeprefix is different, 530 # Override some environment variables - only when kdeprefix is different,
515 # to not break ccache/distcc 531 # to not break ccache/distcc
516 PATH="${KDEDIR}/bin:${PATH}" 532 PATH="${KDEDIR}/bin:${PATH}"
517 LDPATH="${KDEDIR}/$(get_libdir):${LDPATH}" 533 LDPATH="${KDEDIR}/$(get_libdir):${LDPATH}"
518 534
519 # Append full RPATH 535 # Append full RPATH
520 cmakeargs="${cmakeargs} -DCMAKE_SKIP_RPATH=OFF" 536 cmakeargs+=" -DCMAKE_SKIP_RPATH=OFF"
521 fi
522 537
523 if has kdeprefix ${IUSE//+} && use kdeprefix; then
524 # Set cmake prefixes to allow buildsystem to localize valid KDE installation 538 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
525 # when more are present 539 # when more are present
526 cmakeargs="${cmakeargs} -DCMAKE_SYSTEM_PREFIX_PATH=${KDEDIR}" 540 cmakeargs+=" -DCMAKE_SYSTEM_PREFIX_PATH=${KDEDIR}"
527 else 541 fi
542
543 # Handle kdeprefix in application itself
544 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
528 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc 545 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
529 cmakeargs="${cmakeargs} -DSYSCONF_INSTALL_DIR=${ROOT}etc" 546 cmakeargs+=" -DSYSCONF_INSTALL_DIR=${EROOT}etc"
530 fi 547 fi
531 548
532 mycmakeargs="${cmakeargs} ${mycmakeargs}" 549 mycmakeargs="${cmakeargs} ${mycmakeargs}"
533 550
534 cmake-utils_src_configure 551 cmake-utils_src_configure
538# @DESCRIPTION: 555# @DESCRIPTION:
539# General function for compiling KDE4 applications. 556# General function for compiling KDE4 applications.
540kde4-base_src_compile() { 557kde4-base_src_compile() {
541 debug-print-function ${FUNCNAME} "$@" 558 debug-print-function ${FUNCNAME} "$@"
542 559
543 cmake-utils_src_compile 560 cmake-utils_src_compile "$@"
544} 561}
545 562
546# @FUNCTION: kde4-base_src_test 563# @FUNCTION: kde4-base_src_test
547# @DESCRIPTION: 564# @DESCRIPTION:
548# Function for testing KDE4 applications. 565# Function for testing KDE4 applications.
549kde4-base_src_test() { 566kde4-base_src_test() {
550 debug-print-function ${FUNCNAME} "$@" 567 debug-print-function ${FUNCNAME} "$@"
551 568
552 # Override this value, set in kde4-base_src_configure() 569 # Override this value, set in kde4-base_src_configure()
553 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON" 570 mycmakeargs+=" -DKDE4_BUILD_TESTS=ON"
554 cmake-utils_src_configure 571 cmake-utils_src_configure
555 kde4-base_src_compile 572 kde4-base_src_compile
556 573
557 cmake-utils_src_test 574 cmake-utils_src_test
558} 575}
590 newdoc "$doc_complete" "${doc%/*}.${doc##*/}" 607 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
591 fi 608 fi
592 done 609 done
593 fi 610 fi
594 611
595 if [[ -n ${KDEBASE} ]] && [[ -d "${D}${ROOT}usr/share/doc/${PF}" ]]; then 612 if [[ -n ${KDEBASE} ]] && [[ -d "${D}${EROOT}usr/share/doc/${PF}" ]]; then
596 # work around bug #97196 613 # work around bug #97196
597 dodir /usr/share/doc/KDE4 && \ 614 dodir /usr/share/doc/KDE4 && \
598 mv "${D}${ROOT}usr/share/doc/${PF}" "${D}${ROOT}usr/share/doc/KDE4/" || \ 615 cp -r "${D}${EROOT}usr/share/doc/${PF}" "${D}${EROOT}usr/share/doc/KDE4/" || \
599 die "Failed to move docs to KDE4/." 616 die "Failed to move docs to KDE4/."
617 rm -rf "${D}${EROOT}usr/share/doc/${PF}"
600 fi 618 fi
601} 619}
602 620
603# @FUNCTION: kde4-base_pkg_postinst 621# @FUNCTION: kde4-base_pkg_postinst
604# @DESCRIPTION: 622# @DESCRIPTION:
608 626
609 buildsycoca 627 buildsycoca
610 628
611 if [[ ${BUILD_TYPE} = live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then 629 if [[ ${BUILD_TYPE} = live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
612 echo 630 echo
613 einfo "WARNING! This is an experimental live ebuild of ${KMNAME:-${PN}}" 631 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
614 einfo "Use it at your own risk." 632 einfo "Use it at your own risk."
615 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!" 633 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
616 echo 634 echo
617 elif [[ ${BUILD_TYPE} != live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && has kdeprefix ${IUSE//+} && use kdeprefix; then 635 elif [[ ${BUILD_TYPE} != live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && has kdeprefix ${IUSE//+} && use kdeprefix; then
618 # warning about kdeprefix for non-live users 636 # warning about kdeprefix for non-live users
619 echo 637 echo
620 ewarn "WARNING! You have kdeprefix useflag enabled." 638 ewarn "WARNING! You have the kdeprefix useflag enabled."
621 ewarn "This setting is strongly discouraged and might lead to potential troubles" 639 ewarn "This setting is strongly discouraged and might lead to potential trouble"
622 ewarn "with KDE update strategies." 640 ewarn "with KDE update strategies."
623 ewarn "You are using this setup at your own risk and kde team does not" 641 ewarn "You are using this setup at your own risk and the kde team does not"
624 ewarn "take responsibilities for dead kittens." 642 ewarn "take responsibilities for dead kittens."
625 echo 643 echo
626 fi 644 fi
627} 645}
628 646

Legend:
Removed from v.1.39  
changed lines
  Added in v.1.53

  ViewVC Help
Powered by ViewVC 1.1.20