/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.46 Revision 1.69
1# Copyright 2007-2009 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.46 2009/10/06 18:02:12 alexxy Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.69 2010/09/09 17:02:30 reavertm Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but 13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but
14# eclass will fail with version older than 2. 14# eclass will fail with version older than 2.
15 15
16# @ECLASS-VARIABLE: WANT_CMAKE 16inherit kde4-functions base eutils
17# @DESCRIPTION:
18# Specify if cmake-utils eclass is required. Defaults to true. Please note that
19# if the variable is set otherwise src_configure/compile/install calls in ebuild
20# must be overrided (can't use the eclass ones).
21WANT_CMAKE="${WANT_CMAKE:-true}"
22if [[ ${WANT_CMAKE} = true ]]; then
23 exports="src_configure src_compile src_test src_install"
24 cmake_eclass="cmake-utils"
25else
26 exports=""
27 cmake_eclass=""
28fi
29
30inherit base ${cmake_eclass} eutils kde4-functions
31 17
32get_build_type 18get_build_type
33if [[ ${BUILD_TYPE} = live ]]; then 19if [[ ${BUILD_TYPE} = live ]]; then
20 if [[ ${KDEBASE} = kdevelop ]]; then
21 inherit git
22 else
34 inherit subversion 23 inherit subversion
24 fi
35fi 25fi
36 26
37
38EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${exports} pkg_postinst pkg_postrm
39
40case ${KDEBASE} in
41 kde-base)
42 HOMEPAGE="http://www.kde.org/"
43 LICENSE="GPL-2"
44 ;;
45 koffice)
46 HOMEPAGE="http://www.koffice.org/"
47 LICENSE="GPL-2"
48 ;;
49esac
50
51# @ECLASS-VARIABLE: OPENGL_REQUIRED
52# @DESCRIPTION:
53# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
54# This variable must be set before inheriting any eclasses. Defaults to 'never'.
55OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
56
57# @ECLASS-VARIABLE: WEBKIT_REQUIRED
58# @DESCRIPTION:
59# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
60# This variable must be set before inheriting any eclasses. Defaults to 'never'.
61WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
62
63# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
64# @DESCRIPTION:
65# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
66# This variable must be set before inheriting any eclasses. Defaults to 'never'.
67CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
68
69# @ECLASS-VARIABLE: KDE_REQUIRED 27# @ECLASS-VARIABLE: CMAKE_REQUIRED
70# @DESCRIPTION: 28# @DESCRIPTION:
71# Is kde required? Possible values are 'always', 'optional' and 'never'. 29# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
72# This variable must be set before inheriting any eclasses. Defaults to 'always' 30# Please note that if it's set to 'never' you need to explicitly override following phases:
73# If set to always or optional, KDE_MINIMAL may be overriden as well. 31# src_configure, src_compile, src_test and src_install.
74# Note that for kde-base packages this variable is fixed to 'always'. 32# Defaults to 'always'.
75KDE_REQUIRED="${KDE_REQUIRED:-always}" 33: ${CMAKE_REQUIRED:=always}
34if [[ ${CMAKE_REQUIRED} = always ]]; then
35 buildsystem_eclass="cmake-utils"
36 export_fns="src_configure src_compile src_test src_install"
37fi
76 38
77# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here) 39# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
78if [[ -n ${KDE_MINIMAL} ]]; then 40if [[ -n ${KDE_MINIMAL} ]]; then
79 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do 41 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
80 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break 42 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
86fi 48fi
87 49
88# @ECLASS-VARIABLE: KDE_MINIMAL 50# @ECLASS-VARIABLE: KDE_MINIMAL
89# @DESCRIPTION: 51# @DESCRIPTION:
90# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal 52# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
91# version for apps to work. Currently defaults to 4.3 53# version for apps to work. Currently defaults to 4.4
92# One may override this variable to raise version requirements. 54# One may override this variable to raise version requirements.
93# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables. 55# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
94# Note that it is fixed to ${SLOT} for kde-base packages. 56# Note that it is fixed to ${SLOT} for kde-base packages.
95KDE_MINIMAL="${KDE_MINIMAL:-4.3}" 57KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
96 58
97# Fallback behaviour (for now) 59# Set slot for packages in kde-base, koffice and kdevelop
98# TODO Remove when tree is clean 60case ${KDEBASE} in
99if [[ -n ${NEED_KDE} ]]; then 61 kde-base)
100 case ${NEED_KDE} in 62 # Determine SLOT from PVs
101 none) 63 case ${PV} in
102 KDE_REQUIRED="never" 64 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
103 ;; 65 4.6* | 4.5.[6-9]*) SLOT="4.6" ;;
104 *) 66 4.5* | 4.4.[6-9]*) SLOT="4.5" ;;
105 KDE_REQUIRED="always" 67 4.4* | 4.3.[6-9]*) SLOT="4.4" ;;
106 KDE_MINIMAL="${NEED_KDE}" 68 9999*) SLOT="live" ;; # regular live
107 ;; 69 *) die "Unsupported ${PV}" ;;
108 esac 70 esac
109fi 71 KDE_MINIMAL="${SLOT}"
110 72 ;;
111# @ECLASS-VARIABLE: QT_DEPEND 73 koffice)
74 SLOT="2"
75 ;;
76 kdevelop)
77 if [[ ${BUILD_TYPE} = live ]]; then
78 # @ECLASS-VARIABLE: KDEVELOP_VERSION
112# @DESCRIPTION: 79 # @DESCRIPTION:
113# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1.. 80 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
114# Currently defaults to 4.5.1 81 # Applies to KDEBASE=kdevelop only.
115QT_DEPEND="${QT_DEPEND:-4.5.1}" 82 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
116 83 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
117# OpenGL dependencies 84 # @DESCRIPTION:
118qtopengldepend=" 85 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
119 >=x11-libs/qt-opengl-${QT_DEPEND}:4 86 # Applies to KDEBASE=kdevelop only.
120" 87 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
121case ${OPENGL_REQUIRED} in 88 else
122 always) 89 case ${PN} in
123 COMMONDEPEND+=" ${qtopengldepend}" 90 kdevelop|quanta)
91 KDEVELOP_VERSION=${PV}
92 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
93 ;;
94 kdevplatform)
95 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
96 KDEVPLATFORM_VERSION=${PV}
97 ;;
98 *)
99 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
100 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
101 esac
102 fi
103 SLOT="4"
124 ;; 104 ;;
125 optional)
126 IUSE+=" opengl"
127 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
128 ;;
129 *) ;;
130esac 105esac
131unset qtopengldepend
132 106
133# WebKit dependencies 107slot_is_at_least 4.5 ${KDE_MINIMAL} && CMAKE_MIN_VERSION="2.8.1"
134case ${KDE_REQUIRED} in
135 always)
136 qtwebkitusedeps="[kde]"
137 ;;
138 optional)
139 qtwebkitusedeps="[kde?]"
140 ;;
141 *) ;;
142esac
143qtwebkitdepend="
144 >=x11-libs/qt-webkit-${QT_DEPEND}:4${qtwebkitusedeps}
145"
146unset qtwebkitusedeps
147case ${WEBKIT_REQUIRED} in
148 always)
149 COMMONDEPEND+=" ${qtwebkitdepend}"
150 ;;
151 optional)
152 IUSE+=" webkit"
153 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
154 ;;
155 *) ;;
156esac
157unset qtwebkitdepend
158 108
159# CppUnit dependencies 109inherit ${buildsystem_eclass}
160cppuintdepend=" 110
161 dev-util/cppunit 111EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm
162" 112
163case ${CPPUNIT_REQUIRED} in 113unset buildsystem_eclass
164 always) 114unset export_fns
165 DEPEND+=" ${cppuintdepend}" 115
166 ;; 116# @ECLASS-VARIABLE: OPENGL_REQUIRED
167 optional) 117# @DESCRIPTION:
168 IUSE+=" test" 118# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
169 DEPEND+=" test? ( ${cppuintdepend} )" 119# This variable must be set before inheriting any eclasses. Defaults to 'never'.
170 ;; 120OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
171 *) ;; 121
172esac 122# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
173unset cppuintdepend 123# @DESCRIPTION:
124# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
125# This variable must be set before inheriting any eclasses. Defaults to 'never'.
126MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
127
128# @ECLASS-VARIABLE: WEBKIT_REQUIRED
129# @DESCRIPTION:
130# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
131# This variable must be set before inheriting any eclasses. Defaults to 'never'.
132WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
133
134# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
135# @DESCRIPTION:
136# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
137# This variable must be set before inheriting any eclasses. Defaults to 'never'.
138CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
139
140# @ECLASS-VARIABLE: KDE_REQUIRED
141# @DESCRIPTION:
142# Is kde required? Possible values are 'always', 'optional' and 'never'.
143# This variable must be set before inheriting any eclasses. Defaults to 'always'
144# If set to always or optional, KDE_MINIMAL may be overriden as well.
145# Note that for kde-base packages this variable is fixed to 'always'.
146KDE_REQUIRED="${KDE_REQUIRED:-always}"
147
148# @ECLASS-VARIABLE: KDE_HANDBOOK
149# @DESCRIPTION:
150# Set to enable handbook in application. It adds +handbook to IUSE, handbook dirs
151# to KMEXTRA and ensures buildtime and runtime dependencies.
152[[ -n ${KDE_HANDBOOK} ]] && IUSE+=" +handbook"
174 153
175# Setup packages inheriting this eclass 154# Setup packages inheriting this eclass
176case ${KDEBASE} in 155case ${KDEBASE} in
177 kde-base) 156 kde-base)
157 HOMEPAGE="http://www.kde.org/"
158 LICENSE="GPL-2"
178 if [[ $BUILD_TYPE = live ]]; then 159 if [[ $BUILD_TYPE = live ]]; then
179 # Disable tests for live ebuilds 160 # Disable tests for live ebuilds
180 RESTRICT+=" test" 161 RESTRICT+=" test"
181 # Live ebuilds in kde-base default to kdeprefix by default 162 # Live ebuilds in kde-base default to kdeprefix by default
182 IUSE+=" +kdeprefix" 163 IUSE+=" +kdeprefix"
183 else 164 else
184 # All other ebuild types default to -kdeprefix as before 165 # All other ebuild types default to -kdeprefix as before
185 IUSE+=" kdeprefix" 166 IUSE+=" kdeprefix"
186 fi 167 fi
187 # Determine SLOT from PVs
188 case ${PV} in
189 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
190 4.4* | 4.3.[6-9]*) SLOT="4.4" ;;
191 4.3*) SLOT="4.3" ;;
192 4.2*) SLOT="4.2" ;;
193 9999*) SLOT="live" ;; # regular live
194 *) die "Unsupported ${PV}" ;;
195 esac
196 # This code is to prevent portage from searching GENTOO_MIRRORS for 168 # This code is to prevent portage from searching GENTOO_MIRRORS for
197 # packages that will never be mirrored. (As they only will ever be in 169 # packages that will never be mirrored. (As they only will ever be in
198 # the overlay). 170 # the overlay).
199 case ${PV} in 171 case ${PV} in
200 *9999* | 4.?.[6-9]?) 172 *9999* | 4.?.[6-9]?)
201 RESTRICT+=" mirror" 173 RESTRICT+=" mirror"
202 ;; 174 ;;
203 esac 175 esac
204 KDE_MINIMAL="${SLOT}"
205 _kdedir="${SLOT}"
206 _pv="-${PV}:${SLOT}"
207 _pvn="-${PV}"
208
209 # Block installation of other SLOTS unless kdeprefix 176 # Block installation of other SLOTS unless kdeprefix
210 RDEPEND+=" $(block_other_slots)" 177 RDEPEND+=" $(block_other_slots)"
211 ;; 178 ;;
212 koffice) 179 koffice)
213 SLOT="2" 180 HOMEPAGE="http://www.koffice.org/"
214 _pv="-${KDE_MINIMAL}" 181 LICENSE="GPL-2"
215 _pvn="${_pv}"
216 ;; 182 ;;
217 *) 183 kdevelop)
218 _pv="-${KDE_MINIMAL}" 184 HOMEPAGE="http://www.kdevelop.org/"
219 _pvn="${_pv}" 185 LICENSE="GPL-2"
220 ;; 186 ;;
221
222esac 187esac
223 188
189# @ECLASS-VARIABLE: QT_MINIMAL
190# @DESCRIPTION:
191# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1...
192# 4.6.0 for 4.4 and 4.6.3 for 4.5 and later
193if slot_is_at_least 4.5 "${KDE_MINIMAL}"; then
194 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
195else
196 QT_MINIMAL="${QT_MINIMAL:-4.6.0}"
197fi
198
199# OpenGL dependencies
200qtopengldepend="
201 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
202"
203case ${OPENGL_REQUIRED} in
204 always)
205 COMMONDEPEND+=" ${qtopengldepend}"
206 ;;
207 optional)
208 IUSE+=" opengl"
209 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
210 ;;
211 *) ;;
212esac
213unset qtopengldepend
214
215# MultiMedia dependencies
216qtmultimediadepend="
217 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
218"
219case ${MULTIMEDIA_REQUIRED} in
220 always)
221 COMMONDEPEND+=" ${qtmultimediadepend}"
222 ;;
223 optional)
224 IUSE+=" multimedia"
225 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
226 ;;
227 *) ;;
228esac
229unset qtmultimediadepend
230
231# WebKit dependencies
232case ${KDE_REQUIRED} in
233 always)
234 qtwebkitusedeps="[kde]"
235 ;;
236 optional)
237 qtwebkitusedeps="[kde?]"
238 ;;
239 *) ;;
240esac
241qtwebkitdepend="
242 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
243"
244unset qtwebkitusedeps
245case ${WEBKIT_REQUIRED} in
246 always)
247 COMMONDEPEND+=" ${qtwebkitdepend}"
248 ;;
249 optional)
250 IUSE+=" webkit"
251 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
252 ;;
253 *) ;;
254esac
255unset qtwebkitdepend
256
257# CppUnit dependencies
258cppuintdepend="
259 dev-util/cppunit
260"
261case ${CPPUNIT_REQUIRED} in
262 always)
263 DEPEND+=" ${cppuintdepend}"
264 ;;
265 optional)
266 IUSE+=" test"
267 DEPEND+=" test? ( ${cppuintdepend} )"
268 ;;
269 *) ;;
270esac
271unset cppuintdepend
272
224# KDE dependencies 273# KDE dependencies
274# Qt accessibility classes are needed in various places, bug 325461
225kdecommondepend=" 275kdecommondepend="
226 dev-lang/perl
227 >=x11-libs/qt-core-${QT_DEPEND}:4[qt3support,ssl] 276 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
228 >=x11-libs/qt-gui-${QT_DEPEND}:4[accessibility,dbus] 277 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
229 >=x11-libs/qt-qt3support-${QT_DEPEND}:4[accessibility,kde] 278 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
230 >=x11-libs/qt-script-${QT_DEPEND}:4 279 >=x11-libs/qt-script-${QT_MINIMAL}:4
231 >=x11-libs/qt-sql-${QT_DEPEND}:4[qt3support] 280 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
232 >=x11-libs/qt-svg-${QT_DEPEND}:4 281 >=x11-libs/qt-svg-${QT_MINIMAL}:4
233 >=x11-libs/qt-test-${QT_DEPEND}:4 282 >=x11-libs/qt-test-${QT_MINIMAL}:4
234 !aqua? ( 283 !aqua? (
235 x11-libs/libXext 284 x11-libs/libXext
236 x11-libs/libXt 285 x11-libs/libXt
237 x11-libs/libXxf86vm 286 x11-libs/libXxf86vm
238 ) 287 )
239" 288"
289#perl is not needed on host (+ difficult crosscompilation)
290tc-is-cross-compiler || kdecommondepend+=" dev-lang/perl"
291
240if [[ ${PN} != kdelibs ]]; then 292if [[ ${PN} != kdelibs ]]; then
241 if [[ ${KDEBASE} = kde-base ]]; then 293 if [[ ${KDEBASE} = kde-base ]]; then
242 # libknotificationitem only when SLOT is 4.3 294 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
243 [[ ${PN} != libknotificationitem ]] && [[ ${SLOT} = 4.3 ]] && local libknotificationitem_required=1
244 kdecommondepend+="
245 kdeprefix? ( >=kde-base/kdelibs${_pv}[kdeprefix] )
246 !kdeprefix? ( >=kde-base/kdelibs${_pvn}[-kdeprefix] )
247 "
248 [[ -n ${libknotificationitem_required} ]] && \
249 kdecommondepend+="
250 kdeprefix? ( >=kde-base/libknotificationitem${_pv}[kdeprefix] )
251 !kdeprefix? ( >=kde-base/libknotificationitem${_pvn}[-kdeprefix] )
252 "
253 else 295 else
254 kdecommondepend+=" 296 kdecommondepend+="
255 >=kde-base/kdelibs${_pv} 297 >=kde-base/kdelibs-${KDE_MINIMAL}
256 " 298 "
299 if [[ ${KDEBASE} = kdevelop ]]; then
300 if [[ ${PN} != kdevplatform ]]; then
301 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
302 # @DESCRIPTION:
303 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
304 # Applies to KDEBASE=kdevelop only.
305 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
306 case ${KDEVPLATFORM_REQUIRED} in
307 always)
308 kdecommondepend+="
309 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
310 "
311 ;;
312 *) ;;
313 esac
314 fi
315 fi
257 fi 316 fi
258fi 317fi
259unset _pv _pvn
260kdedepend=" 318kdedepend="
319 dev-util/automoc
261 dev-util/pkgconfig 320 dev-util/pkgconfig
321 !aqua? (
322 || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1.0 )
323 x11-proto/xf86vidmodeproto
324 )
262" 325"
326
327# Handbook handling - dependencies
328if [[ -n ${KDE_HANDBOOK} ]]; then
329 kdedepend+="
330 handbook? (
331 app-text/docbook-xml-dtd:4.2
332 app-text/docbook-xsl-stylesheets
333 )
334 "
335 if [[ ${PN} != kdelibs ]]; then
336 if [[ ${KDEBASE} = kde-base ]]; then
337 PDEPEND+=" handbook? ( $(add_kdebase_dep kdelibs 'handbook') )"
338 else
339 PDEPEND+=" handbook? ( >=kde-base/kdelibs-${KDE_MINIMAL}[handbook] )"
340 fi
341 elif [[ ${PN} != khelpcenter ]]; then
342 if [[ ${KDEBASE} = kde-base ]]; then
343 PDEPEND+=" handbook? ( $(add_kdebase_dep khelpcenter 'handbook') )"
344 else
345 PDEPEND+=" handbook? ( >=kde-base/khelpcenter-${KDE_MINIMAL}[handbook] )"
346 fi
347 fi
348fi
349
263case ${KDE_REQUIRED} in 350case ${KDE_REQUIRED} in
264 always) 351 always)
265 IUSE+=" aqua" 352 IUSE+=" aqua"
266 COMMONDEPEND+=" ${kdecommondepend}" 353 COMMONDEPEND+=" ${kdecommondepend}"
267 DEPEND+=" ${kdedepend}" 354 DEPEND+=" ${kdedepend}"
271 COMMONDEPEND+=" kde? ( ${kdecommondepend} )" 358 COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
272 DEPEND+=" kde? ( ${kdedepend} )" 359 DEPEND+=" kde? ( ${kdedepend} )"
273 ;; 360 ;;
274 *) ;; 361 *) ;;
275esac 362esac
363
276unset kdecommondepend kdedepend 364unset kdecommondepend kdedepend
277 365
278debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}" 366debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
279debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}" 367debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
280debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}" 368debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
369debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: PDEPEND is ${PDEPEND}"
281 370
282# Accumulate dependencies set by this eclass 371# Accumulate dependencies set by this eclass
283DEPEND+=" ${COMMONDEPEND}" 372DEPEND+=" ${COMMONDEPEND}"
284RDEPEND+=" ${COMMONDEPEND}" 373RDEPEND+=" ${COMMONDEPEND}"
285unset COMMONDEPEND 374unset COMMONDEPEND
286 375
376# Add experimental kdeenablefinal, disabled by default
377IUSE+=" kdeenablefinal"
378
287# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 379# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
288# koffice ebuild, the URI should be set in the ebuild itself 380# koffice ebuild, the URI should be set in the ebuild itself
289case ${BUILD_TYPE} in 381case ${BUILD_TYPE} in
290 live) 382 live)
291 # Determine branch URL based on live type
292 local branch_prefix
293 case ${PV} in
294 9999*)
295 # trunk
296 branch_prefix="trunk/KDE"
297 ;;
298 *)
299 # branch
300 branch_prefix="branches/KDE/${SLOT}"
301 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
302 # @DESCRIPTION
303 # Suffix appended to ESVN_PROJECT depending on fetched branch.
304 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
305 ESVN_PROJECT_SUFFIX="-${PV}"
306 ;;
307 esac
308 SRC_URI="" 383 SRC_URI=""
384 if has subversion ${INHERITED}; then
385 # Determine branch URL based on live type
386 local branch_prefix
387 case ${PV} in
388 9999*)
389 # trunk
390 branch_prefix="trunk/KDE"
391 ;;
392 *)
393 # branch
394 branch_prefix="branches/KDE/${SLOT}"
395 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
396 # @DESCRIPTION
397 # Suffix appended to ESVN_PROJECT depending on fetched branch.
398 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
399 ESVN_PROJECT_SUFFIX="-${PV}"
400 ;;
401 esac
309 # @ECLASS-VARIABLE: ESVN_MIRROR 402 # @ECLASS-VARIABLE: ESVN_MIRROR
310 # @DESCRIPTION: 403 # @DESCRIPTION:
311 # This variable allows easy overriding of default kde mirror service 404 # This variable allows easy overriding of default kde mirror service
312 # (anonsvn) with anything else you might want to use. 405 # (anonsvn) with anything else you might want to use.
313 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde} 406 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
314 # Split ebuild, or extragear stuff 407 # Split ebuild, or extragear stuff
315 if [[ -n ${KMNAME} ]]; then 408 if [[ -n ${KMNAME} ]]; then
316 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}" 409 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
410 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
411 KMMODULE="${PN}"
412 fi
413 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
414 case ${KMNAME} in
415 kdebase-*)
416 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
417 ;;
418 kdelibs-*)
419 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
420 ;;
421 kdereview*)
422 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
423 ;;
424 kdesupport)
425 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
426 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
427 ;;
428 kde*)
429 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
430 ;;
431 extragear*|playground*)
432 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
433 # build packages from same svn location.
434 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
435 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
436 ;;
437 koffice)
438 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
439 ;;
440 *)
441 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
442 ;;
443 esac
444 else
445 # kdelibs, kdepimlibs
446 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
447 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
448 fi
449 # @ECLASS-VARIABLE: ESVN_UP_FREQ
450 # @DESCRIPTION:
451 # This variable is used for specifying the timeout between svn synces
452 # for kde-base and koffice modules. Does not affect misc apps.
453 # Default value is 1 hour.
454 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
455 elif has git ${INHERITED}; then
317 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then 456 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
318 KMMODULE="${PN}" 457 KMMODULE="${PN}"
319 fi 458 fi
320 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
321 case ${KMNAME} in 459 case ${KDEBASE} in
322 kdebase-*) 460 kdevelop)
323 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}" 461 EGIT_REPO_URI="git://gitorious.org/${KMNAME}/${KMMODULE}.git"
324 ;;
325 kdelibs-*)
326 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
327 ;;
328 kdereview)
329 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
330 ;;
331 kdesupport)
332 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
333 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
334 ;;
335 kde*)
336 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
337 ;;
338 extragear*|playground*)
339 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
340 # build packages from same svn location.
341 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
342 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
343 ;;
344 koffice)
345 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
346 ;;
347 *)
348 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
349 ;; 462 ;;
350 esac 463 esac
351 else
352 # kdelibs, kdepimlibs
353 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
354 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
355 fi 464 fi
356 # @ECLASS-VARIABLE: ESVN_UP_FREQ
357 # @DESCRIPTION:
358 # This variable is used for specifying the timeout between svn synces
359 # for kde-base and koffice modules. Does not affect misc apps.
360 # Default value is 1 hour.
361 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
362 ;; 465 ;;
363 *) 466 *)
364 if [[ -n ${KDEBASE} ]]; then 467 if [[ -n ${KDEBASE} ]]; then
365 if [[ -n ${KMNAME} ]]; then 468 if [[ -n ${KMNAME} ]]; then
366 case ${KMNAME} in 469 case ${KMNAME} in
371 esac 474 esac
372 else 475 else
373 _kmname=${PN} 476 _kmname=${PN}
374 fi 477 fi
375 _kmname_pv="${_kmname}-${PV}" 478 _kmname_pv="${_kmname}-${PV}"
376 if [[ $NEED_KDE != live ]]; then
377 case ${KDEBASE} in 479 case ${KDEBASE} in
378 kde-base) 480 kde-base)
379 case ${PV} in 481 case ${PV} in
380 4.3.85 | 4.3.9[0568]) 482 4.[45].8[05] | 4.[45].9[02568])
381 # block for normally packed unstable releases 483 # Normally packed unstable releases
382 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" ;; 484 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
383 4.3.[6-9]*) 485 4.[45].[6-9]*)
486 # Repacked tarballs: need to depend on xz-utils to ensure that they can be unpacked
384 SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${PV}/${_kmname_pv}.tar.lzma" ;; 487 SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${PV}/src/${_kmname_pv}.tar.xz"
488 DEPEND+=" app-arch/xz-utils"
489 ;;
385 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;; 490 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
386 esac 491 esac
387 ;; 492 ;;
388 koffice) 493 koffice)
389 case ${PV} in 494 case ${PV} in
390 2.0.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" ;; 495 2.1.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
391 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" ;; 496 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
392 esac 497 esac
498 ;;
499 kdevelop)
500 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
501 ;;
393 esac 502 esac
394 fi
395 unset _kmname _kmname_pv 503 unset _kmname _kmname_pv
396 fi 504 fi
397 ;; 505 ;;
398esac 506esac
399 507
410# Do the basic kdeprefix KDEDIR settings and determine with which kde should 518# Do the basic kdeprefix KDEDIR settings and determine with which kde should
411# optional applications link 519# optional applications link
412kde4-base_pkg_setup() { 520kde4-base_pkg_setup() {
413 debug-print-function ${FUNCNAME} "$@" 521 debug-print-function ${FUNCNAME} "$@"
414 522
523 # Prefix compat:
524 if [[ ${EAPI} == 2 ]] && ! use prefix; then
525 EPREFIX=
526 EROOT=${ROOT}
527 fi
528
529 # Append missing trailing slash character
530 [[ ${EROOT} = */ ]] || EROOT+="/"
531
415 # QA ebuilds 532 # QA ebuilds
416 case ${NEED_KDE} in
417 none) ewarn "QA Notice: using deprecated NEED_KDE variable, use KDE_REQUIRED=\"never\" or KDE_REQUIRED=\"optional\" instead. You may want to override KDE_MINIMAL as well (default is KDE_MINIMAL=\"${KDE_MINIMAL}\")." ;;
418 *) [[ -n ${NEED_KDE} ]] && ewarn "QA Notice: using deprecated NEED_KDE variable, use KDE_MINIMAL instead (default is KDE_MINIMAL=\"${KDE_MINIMAL}\")." ;;
419 esac
420 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})." 533 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
421 534
422 # Don't set KDEHOME during compilation, it will cause access violations 535 # Don't set KDEHOME during compilation, it will cause access violations
423 unset KDEHOME 536 unset KDEHOME
424 537
425 if [[ ${KDEBASE} = kde-base ]]; then 538 if [[ ${KDEBASE} = kde-base ]]; then
426 if use kdeprefix; then 539 if use kdeprefix; then
427 KDEDIR="${EROOT}usr/kde/${_kdedir}" 540 KDEDIR=/usr/kde/${SLOT}
428 else 541 else
429 KDEDIR="${EROOT}usr" 542 KDEDIR=/usr
430 fi 543 fi
431 PREFIX="${PREFIX:-${KDEDIR}}" 544 : ${PREFIX:=${KDEDIR}}
432 else 545 else
433 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL 546 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
434 KDEDIR= 547 KDEDIR=
435 local kde_minimal_met 548 local kde_minimal_met
436 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do 549 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
437 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1 550 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
438 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then 551 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
439 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then 552 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
440 KDEDIR="${EROOT}usr/kde/${slot}" 553 KDEDIR=/usr/kde/${slot}
441 else 554 else
442 KDEDIR="${EROOT}usr" 555 KDEDIR=/usr
443 fi 556 fi
444 break; 557 break;
445 fi 558 fi
446 done 559 done
447 unset slot 560 unset slot
448 561
449 # Bail out if kdelibs required but not found 562 # Bail out if kdelibs required but not found
450 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then 563 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
451 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!" 564 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
452 else 565 else
453 [[ -z ${KDEDIR} ]] && KDEDIR="${EROOT}usr" 566 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
454 fi
455
456 PREFIX="${PREFIX:-${EROOT}usr}"
457 fi 567 fi
568
569 : ${PREFIX:=/usr}
570 fi
571 EKDEDIR=${EPREFIX}${KDEDIR}
572
458 # Point pkg-config path to KDE *.pc files 573 # Point pkg-config path to KDE *.pc files
459 export PKG_CONFIG_PATH="${KDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}" 574 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
460 # Point to correct QT plugins path 575 # Point to correct QT plugins path
461 QT_PLUGIN_PATH="${KDEDIR}/$(get_libdir)/kde4/plugins/" 576 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
462 577
463 # Not needed anymore 578 # Fix XDG collision with sandbox
464 unset _kdedir 579 export XDG_CONFIG_HOME="${T}"
465} 580}
466 581
467# @FUNCTION: kde4-base_src_unpack 582# @FUNCTION: kde4-base_src_unpack
468# @DESCRIPTION: 583# @DESCRIPTION:
469# This function unpacks the source tarballs for KDE4 applications. 584# This function unpacks the source tarballs for KDE4 applications.
470kde4-base_src_unpack() { 585kde4-base_src_unpack() {
471 debug-print-function ${FUNCNAME} "$@" 586 debug-print-function ${FUNCNAME} "$@"
472 587
473 if [[ ${BUILD_TYPE} = live ]]; then 588 if [[ ${BUILD_TYPE} = live ]]; then
589 if has subversion ${INHERITED}; then
474 migrate_store_dir 590 migrate_store_dir
475 subversion_src_unpack 591 subversion_src_unpack
592 elif has git ${INHERITED}; then
593 git_src_unpack
594 fi
595 elif [[ ${EAPI} == 2 ]]; then
596 local file
597 for file in ${A}; do
598 # This setup is because EAPI <= 2 cannot unpack *.tar.xz files
599 # directly, so we do it ourselves (using the exact same code as portage)
600 case ${file} in
601 *.tar.xz)
602 echo ">>> Unpacking ${file} to ${PWD}"
603 xz -dc "${DISTDIR}"/${file} | tar xof -
604 assert "failed unpacking ${file}"
605 ;;
606 *)
607 unpack ${file}
608 ;;
609 esac
610 done
476 else 611 else
477 base_src_unpack 612 # For EAPI >= 3, we can just use unpack() directly
613 unpack ${A}
478 fi 614 fi
479} 615}
480 616
481# @FUNCTION: kde4-base_src_prepare 617# @FUNCTION: kde4-base_src_prepare
482# @DESCRIPTION: 618# @DESCRIPTION:
497 # kdelibs inherits kde4-base but handle installing the handbook itself 633 # kdelibs inherits kde4-base but handle installing the handbook itself
498 if ! has kde4-meta ${INHERITED}; then 634 if ! has kde4-meta ${INHERITED}; then
499 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas 635 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas
500 fi 636 fi
501 637
502 [[ ${BUILD_TYPE} = live ]] && subversion_src_prepare 638 # SCM bootstrap
639 if [[ ${BUILD_TYPE} = live ]]; then
640 if has subversion ${INHERITED}; then
641 subversion_src_prepare
642 elif has git ${INHERITED}; then
643 git_src_prepare
644 fi
645 fi
646
647 # Apply patches
503 base_src_prepare 648 base_src_prepare
504 649
505 # Save library dependencies 650 # Save library dependencies
506 if [[ -n ${KMSAVELIBS} ]] ; then 651 if [[ -n ${KMSAVELIBS} ]] ; then
507 save_library_dependencies 652 save_library_dependencies
517# @DESCRIPTION: 662# @DESCRIPTION:
518# Function for configuring the build of KDE4 applications. 663# Function for configuring the build of KDE4 applications.
519kde4-base_src_configure() { 664kde4-base_src_configure() {
520 debug-print-function ${FUNCNAME} "$@" 665 debug-print-function ${FUNCNAME} "$@"
521 666
667 # Build tests in src_test only, where we override this value
668 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
669
670 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
671 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
672 fi
673
674 if has debug ${IUSE//+} && use debug; then
675 # Set "real" debug mode
676 CMAKE_BUILD_TYPE="Debugfull"
677 else
522 # Handle common release builds 678 # Handle common release builds
523 if ! has debug ${IUSE//+} || ! use debug; then
524 append-cppflags -DQT_NO_DEBUG 679 append-cppflags -DQT_NO_DEBUG
525 fi 680 fi
526 681
527 # Build tests in src_test only, where we override this value
528 local cmakeargs="-DKDE4_BUILD_TESTS=OFF"
529
530 # set "real" debug mode
531 if has debug ${IUSE//+} && use debug; then
532 CMAKE_BUILD_TYPE="Debugfull"
533 fi
534
535 # Set distribution name 682 # Set distribution name
536 [[ ${PN} = kdelibs ]] && cmakeargs+=" -DKDE_DISTRIBUTION_TEXT=Gentoo" 683 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
537 684
538 # Here we set the install prefix 685 # Here we set the install prefix
539 cmakeargs+=" -DCMAKE_INSTALL_PREFIX=${PREFIX}" 686 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
540 687
541 # Use colors 688 # Use colors
542 QTEST_COLORED=1 689 QTEST_COLORED=1
543 690
544 # Shadow existing /usr installations 691 # Shadow existing /usr installations
545 unset KDEDIRS 692 unset KDEDIRS
546 693
547 # Handle kdeprefix-ed KDE 694 # Handle kdeprefix-ed KDE
548 if [[ ${KDEDIR} != "${EROOT}usr" ]]; then 695 if [[ ${KDEDIR} != /usr ]]; then
549 # Override some environment variables - only when kdeprefix is different, 696 # Override some environment variables - only when kdeprefix is different,
550 # to not break ccache/distcc 697 # to not break ccache/distcc
551 PATH="${KDEDIR}/bin:${PATH}" 698 PATH="${EKDEDIR}/bin:${PATH}"
552 LDPATH="${KDEDIR}/$(get_libdir):${LDPATH}" 699
700 # Append library search path
701 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
553 702
554 # Append full RPATH 703 # Append full RPATH
555 cmakeargs+=" -DCMAKE_SKIP_RPATH=OFF" 704 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
556 705
557 # Set cmake prefixes to allow buildsystem to locate valid KDE installation 706 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
558 # when more are present 707 # when more are present
559 cmakeargs+=" -DCMAKE_SYSTEM_PREFIX_PATH=${KDEDIR}" 708 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
560 fi 709 fi
710
711 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
712 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4)
713 #kde-config -path data unavailable when cross-compiling
714 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
561 715
562 # Handle kdeprefix in application itself 716 # Handle kdeprefix in application itself
563 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then 717 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
564 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc 718 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
565 cmakeargs+=" -DSYSCONF_INSTALL_DIR=${EROOT}etc" 719 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
566 fi 720 fi
567 721
722 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
723 mycmakeargs=(${mycmakeargs})
724 fi
725
568 mycmakeargs="${cmakeargs} ${mycmakeargs}" 726 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
569 727
570 cmake-utils_src_configure 728 cmake-utils_src_configure
571} 729}
572 730
573# @FUNCTION: kde4-base_src_compile 731# @FUNCTION: kde4-base_src_compile
584# Function for testing KDE4 applications. 742# Function for testing KDE4 applications.
585kde4-base_src_test() { 743kde4-base_src_test() {
586 debug-print-function ${FUNCNAME} "$@" 744 debug-print-function ${FUNCNAME} "$@"
587 745
588 # Override this value, set in kde4-base_src_configure() 746 # Override this value, set in kde4-base_src_configure()
589 mycmakeargs+=" -DKDE4_BUILD_TESTS=ON" 747 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
590 cmake-utils_src_configure 748 cmake-utils_src_configure
591 kde4-base_src_compile 749 kde4-base_src_compile
592 750
593 cmake-utils_src_test 751 cmake-utils_src_test
594} 752}
597# @DESCRIPTION: 755# @DESCRIPTION:
598# Function for installing KDE4 applications. 756# Function for installing KDE4 applications.
599kde4-base_src_install() { 757kde4-base_src_install() {
600 debug-print-function ${FUNCNAME} "$@" 758 debug-print-function ${FUNCNAME} "$@"
601 759
760 # Prefix support, for usage in ebuilds
761 if [[ ${EAPI} == 2 ]] && ! use prefix; then
762 ED=${D}
763 fi
764
602 if [[ -n ${KMSAVELIBS} ]] ; then 765 if [[ -n ${KMSAVELIBS} ]] ; then
603 install_library_dependencies 766 install_library_dependencies
604 fi 767 fi
605 768
606 kde4-base_src_make_doc 769 # Install common documentation of KDE4 applications
770 local doc
771 if ! has kde4-meta ${INHERITED}; then
772 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
773 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && dodoc "${doc}"
774 done
775 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
776 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
777 done
778 fi
779
607 cmake-utils_src_install 780 cmake-utils_src_install
608}
609
610# @FUNCTION: kde4-base_src_make_doc
611# @DESCRIPTION:
612# Function for installing the documentation of KDE4 applications.
613kde4-base_src_make_doc() {
614 debug-print-function ${FUNCNAME} "$@"
615
616 local doc
617 for doc in AUTHORS ChangeLog* README* NEWS TODO; do
618 [[ -s ${doc} ]] && dodoc ${doc}
619 done
620
621 if [[ -z ${KMNAME} ]]; then
622 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
623 if [[ -s ${doc} ]]; then
624 local doc_complete=${doc}
625 doc="${doc#*/}"
626 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
627 fi
628 done
629 fi
630
631 if [[ -n ${KDEBASE} ]] && [[ -d "${D}${EROOT}usr/share/doc/${PF}" ]]; then
632 # work around bug #97196
633 dodir /usr/share/doc/KDE4 && \
634 cp -r "${D}${EROOT}usr/share/doc/${PF}" "${D}${EROOT}usr/share/doc/KDE4/" || \
635 die "Failed to move docs to KDE4/."
636 rm -rf "${D}${EROOT}usr/share/doc/${PF}"
637 fi
638} 781}
639 782
640# @FUNCTION: kde4-base_pkg_postinst 783# @FUNCTION: kde4-base_pkg_postinst
641# @DESCRIPTION: 784# @DESCRIPTION:
642# Function to rebuild the KDE System Configuration Cache after an application has been installed. 785# Function to rebuild the KDE System Configuration Cache after an application has been installed.
659 ewarn "with KDE update strategies." 802 ewarn "with KDE update strategies."
660 ewarn "You are using this setup at your own risk and the kde team does not" 803 ewarn "You are using this setup at your own risk and the kde team does not"
661 ewarn "take responsibilities for dead kittens." 804 ewarn "take responsibilities for dead kittens."
662 echo 805 echo
663 fi 806 fi
807 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && ! has_version 'kde-base/kdebase-runtime-meta' && ! has_version 'kde-base/kdebase-startkde'; then
808 # warn about not supported approach
809 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
810 echo
811 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
812 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
813 ewarn "With this setting you are unsupported by KDE team."
814 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
815 fi
816 fi
664} 817}
665 818
666# @FUNCTION: kde4-base_pkg_postrm 819# @FUNCTION: kde4-base_pkg_postrm
667# @DESCRIPTION: 820# @DESCRIPTION:
668# Function to rebuild the KDE System Configuration Cache after an application has been removed. 821# Function to rebuild the KDE System Configuration Cache after an application has been removed.

Legend:
Removed from v.1.46  
changed lines
  Added in v.1.69

  ViewVC Help
Powered by ViewVC 1.1.20