/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.46 Revision 1.76
1# Copyright 2007-2009 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.46 2009/10/06 18:02:12 alexxy Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.76 2010/10/27 21:24:22 dilfridge Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but 13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but
14# eclass will fail with version older than 2. 14# eclass will fail with version older than 2.
15 15
16# @ECLASS-VARIABLE: WANT_CMAKE 16inherit kde4-functions base eutils
17# @DESCRIPTION:
18# Specify if cmake-utils eclass is required. Defaults to true. Please note that
19# if the variable is set otherwise src_configure/compile/install calls in ebuild
20# must be overrided (can't use the eclass ones).
21WANT_CMAKE="${WANT_CMAKE:-true}"
22if [[ ${WANT_CMAKE} = true ]]; then
23 exports="src_configure src_compile src_test src_install"
24 cmake_eclass="cmake-utils"
25else
26 exports=""
27 cmake_eclass=""
28fi
29
30inherit base ${cmake_eclass} eutils kde4-functions
31 17
32get_build_type 18get_build_type
33if [[ ${BUILD_TYPE} = live ]]; then 19if [[ ${BUILD_TYPE} = live ]]; then
20 if [[ ${KDEBASE} = kdevelop ]]; then
21 inherit git
22 else
34 inherit subversion 23 inherit subversion
24 fi
35fi 25fi
36 26
37
38EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${exports} pkg_postinst pkg_postrm
39
40case ${KDEBASE} in
41 kde-base)
42 HOMEPAGE="http://www.kde.org/"
43 LICENSE="GPL-2"
44 ;;
45 koffice)
46 HOMEPAGE="http://www.koffice.org/"
47 LICENSE="GPL-2"
48 ;;
49esac
50
51# @ECLASS-VARIABLE: OPENGL_REQUIRED
52# @DESCRIPTION:
53# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
54# This variable must be set before inheriting any eclasses. Defaults to 'never'.
55OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
56
57# @ECLASS-VARIABLE: WEBKIT_REQUIRED
58# @DESCRIPTION:
59# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
60# This variable must be set before inheriting any eclasses. Defaults to 'never'.
61WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
62
63# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
64# @DESCRIPTION:
65# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
66# This variable must be set before inheriting any eclasses. Defaults to 'never'.
67CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
68
69# @ECLASS-VARIABLE: KDE_REQUIRED 27# @ECLASS-VARIABLE: CMAKE_REQUIRED
70# @DESCRIPTION: 28# @DESCRIPTION:
71# Is kde required? Possible values are 'always', 'optional' and 'never'. 29# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
72# This variable must be set before inheriting any eclasses. Defaults to 'always' 30# Please note that if it's set to 'never' you need to explicitly override following phases:
73# If set to always or optional, KDE_MINIMAL may be overriden as well. 31# src_configure, src_compile, src_test and src_install.
74# Note that for kde-base packages this variable is fixed to 'always'. 32# Defaults to 'always'.
75KDE_REQUIRED="${KDE_REQUIRED:-always}" 33: ${CMAKE_REQUIRED:=always}
34if [[ ${CMAKE_REQUIRED} = always ]]; then
35 buildsystem_eclass="cmake-utils"
36 export_fns="src_configure src_compile src_test src_install"
37fi
76 38
77# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here) 39# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
78if [[ -n ${KDE_MINIMAL} ]]; then 40if [[ -n ${KDE_MINIMAL} ]]; then
79 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do 41 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
80 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break 42 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
86fi 48fi
87 49
88# @ECLASS-VARIABLE: KDE_MINIMAL 50# @ECLASS-VARIABLE: KDE_MINIMAL
89# @DESCRIPTION: 51# @DESCRIPTION:
90# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal 52# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
91# version for apps to work. Currently defaults to 4.3 53# version for apps to work. Currently defaults to 4.4
92# One may override this variable to raise version requirements. 54# One may override this variable to raise version requirements.
93# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables. 55# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
94# Note that it is fixed to ${SLOT} for kde-base packages. 56# Note that it is fixed to ${SLOT} for kde-base packages.
95KDE_MINIMAL="${KDE_MINIMAL:-4.3}" 57KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
96 58
97# Fallback behaviour (for now) 59# Set slot for packages in kde-base, koffice and kdevelop
98# TODO Remove when tree is clean 60case ${KDEBASE} in
99if [[ -n ${NEED_KDE} ]]; then 61 kde-base)
100 case ${NEED_KDE} in 62 # Determine SLOT from PVs
101 none) 63 case ${PV} in
102 KDE_REQUIRED="never" 64 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
103 ;; 65 4.6* | 4.5.[6-9][0-9]*) SLOT="4.6" ;;
104 *) 66 4.5* | 4.4.[6-9][0-9]*) SLOT="4.5" ;;
105 KDE_REQUIRED="always" 67 4.4* | 4.3.[6-9][0-9]*) SLOT="4.4" ;;
106 KDE_MINIMAL="${NEED_KDE}" 68 9999*) SLOT="live" ;; # regular live
107 ;; 69 *) die "Unsupported ${PV}" ;;
108 esac 70 esac
109fi 71 KDE_MINIMAL="${SLOT}"
110 72 ;;
111# @ECLASS-VARIABLE: QT_DEPEND 73 koffice)
74 SLOT="2"
75 ;;
76 kdevelop)
77 if [[ ${BUILD_TYPE} = live ]]; then
78 # @ECLASS-VARIABLE: KDEVELOP_VERSION
112# @DESCRIPTION: 79 # @DESCRIPTION:
113# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1.. 80 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
114# Currently defaults to 4.5.1 81 # Applies to KDEBASE=kdevelop only.
115QT_DEPEND="${QT_DEPEND:-4.5.1}" 82 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
116 83 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
117# OpenGL dependencies 84 # @DESCRIPTION:
118qtopengldepend=" 85 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
119 >=x11-libs/qt-opengl-${QT_DEPEND}:4 86 # Applies to KDEBASE=kdevelop only.
120" 87 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
121case ${OPENGL_REQUIRED} in 88 else
122 always) 89 case ${PN} in
123 COMMONDEPEND+=" ${qtopengldepend}" 90 kdevelop|quanta)
91 KDEVELOP_VERSION=${PV}
92 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
93 ;;
94 kdevplatform)
95 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
96 KDEVPLATFORM_VERSION=${PV}
97 ;;
98 *)
99 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
100 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
101 esac
102 fi
103 SLOT="4"
124 ;; 104 ;;
125 optional)
126 IUSE+=" opengl"
127 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
128 ;;
129 *) ;;
130esac 105esac
131unset qtopengldepend
132 106
133# WebKit dependencies 107slot_is_at_least 4.5 ${KDE_MINIMAL} && CMAKE_MIN_VERSION="2.8.1"
134case ${KDE_REQUIRED} in
135 always)
136 qtwebkitusedeps="[kde]"
137 ;;
138 optional)
139 qtwebkitusedeps="[kde?]"
140 ;;
141 *) ;;
142esac
143qtwebkitdepend="
144 >=x11-libs/qt-webkit-${QT_DEPEND}:4${qtwebkitusedeps}
145"
146unset qtwebkitusedeps
147case ${WEBKIT_REQUIRED} in
148 always)
149 COMMONDEPEND+=" ${qtwebkitdepend}"
150 ;;
151 optional)
152 IUSE+=" webkit"
153 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
154 ;;
155 *) ;;
156esac
157unset qtwebkitdepend
158 108
159# CppUnit dependencies 109inherit ${buildsystem_eclass}
160cppuintdepend=" 110
161 dev-util/cppunit 111EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm
162" 112
163case ${CPPUNIT_REQUIRED} in 113unset buildsystem_eclass
164 always) 114unset export_fns
165 DEPEND+=" ${cppuintdepend}" 115
166 ;; 116# @ECLASS-VARIABLE: OPENGL_REQUIRED
167 optional) 117# @DESCRIPTION:
168 IUSE+=" test" 118# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
169 DEPEND+=" test? ( ${cppuintdepend} )" 119# This variable must be set before inheriting any eclasses. Defaults to 'never'.
170 ;; 120OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
171 *) ;; 121
172esac 122# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
173unset cppuintdepend 123# @DESCRIPTION:
124# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
125# This variable must be set before inheriting any eclasses. Defaults to 'never'.
126MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
127
128# @ECLASS-VARIABLE: WEBKIT_REQUIRED
129# @DESCRIPTION:
130# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
131# This variable must be set before inheriting any eclasses. Defaults to 'never'.
132WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
133
134# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
135# @DESCRIPTION:
136# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
137# This variable must be set before inheriting any eclasses. Defaults to 'never'.
138CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
139
140# @ECLASS-VARIABLE: KDE_REQUIRED
141# @DESCRIPTION:
142# Is kde required? Possible values are 'always', 'optional' and 'never'.
143# This variable must be set before inheriting any eclasses. Defaults to 'always'
144# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
145# Note that for kde-base packages this variable is fixed to 'always'.
146KDE_REQUIRED="${KDE_REQUIRED:-always}"
147
148# @ECLASS-VARIABLE: KDE_HANDBOOK
149# @DESCRIPTION:
150# Set to enable handbook in application. Possible values are 'always', 'optional'
151# (handbook USE flag) and 'never'.
152# This variable must be set before inheriting any eclasses. Defaults to 'never'.
153# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
154# ensures buildtime and runtime dependencies.
155KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
174 156
175# Setup packages inheriting this eclass 157# Setup packages inheriting this eclass
176case ${KDEBASE} in 158case ${KDEBASE} in
177 kde-base) 159 kde-base)
160 HOMEPAGE="http://www.kde.org/"
161 LICENSE="GPL-2"
178 if [[ $BUILD_TYPE = live ]]; then 162 if [[ $BUILD_TYPE = live ]]; then
179 # Disable tests for live ebuilds 163 # Disable tests for live ebuilds
180 RESTRICT+=" test" 164 RESTRICT+=" test"
181 # Live ebuilds in kde-base default to kdeprefix by default 165 # Live ebuilds in kde-base default to kdeprefix by default
182 IUSE+=" +kdeprefix" 166 IUSE+=" +kdeprefix"
183 else 167 else
184 # All other ebuild types default to -kdeprefix as before 168 # All other ebuild types default to -kdeprefix as before
185 IUSE+=" kdeprefix" 169 IUSE+=" kdeprefix"
186 fi 170 fi
187 # Determine SLOT from PVs
188 case ${PV} in
189 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
190 4.4* | 4.3.[6-9]*) SLOT="4.4" ;;
191 4.3*) SLOT="4.3" ;;
192 4.2*) SLOT="4.2" ;;
193 9999*) SLOT="live" ;; # regular live
194 *) die "Unsupported ${PV}" ;;
195 esac
196 # This code is to prevent portage from searching GENTOO_MIRRORS for 171 # This code is to prevent portage from searching GENTOO_MIRRORS for
197 # packages that will never be mirrored. (As they only will ever be in 172 # packages that will never be mirrored. (As they only will ever be in
198 # the overlay). 173 # the overlay).
199 case ${PV} in 174 case ${PV} in
200 *9999* | 4.?.[6-9]?) 175 *9999* | 4.?.[6-9]?)
201 RESTRICT+=" mirror" 176 RESTRICT+=" mirror"
202 ;; 177 ;;
203 esac 178 esac
204 KDE_MINIMAL="${SLOT}"
205 _kdedir="${SLOT}"
206 _pv="-${PV}:${SLOT}"
207 _pvn="-${PV}"
208
209 # Block installation of other SLOTS unless kdeprefix 179 # Block installation of other SLOTS unless kdeprefix
210 RDEPEND+=" $(block_other_slots)" 180 RDEPEND+=" $(block_other_slots)"
211 ;; 181 ;;
212 koffice) 182 koffice)
213 SLOT="2" 183 HOMEPAGE="http://www.koffice.org/"
214 _pv="-${KDE_MINIMAL}" 184 LICENSE="GPL-2"
215 _pvn="${_pv}"
216 ;; 185 ;;
217 *) 186 kdevelop)
218 _pv="-${KDE_MINIMAL}" 187 HOMEPAGE="http://www.kdevelop.org/"
219 _pvn="${_pv}" 188 LICENSE="GPL-2"
220 ;; 189 ;;
221
222esac 190esac
191
192# @ECLASS-VARIABLE: QT_MINIMAL
193# @DESCRIPTION:
194# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1...
195# 4.6.0 for 4.4 and 4.6.3 for 4.5 and later
196if slot_is_at_least 4.5 "${KDE_MINIMAL}"; then
197 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
198else
199 QT_MINIMAL="${QT_MINIMAL:-4.6.0}"
200fi
201
202# OpenGL dependencies
203qtopengldepend="
204 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
205"
206case ${OPENGL_REQUIRED} in
207 always)
208 COMMONDEPEND+=" ${qtopengldepend}"
209 ;;
210 optional)
211 IUSE+=" opengl"
212 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
213 ;;
214 *) ;;
215esac
216unset qtopengldepend
217
218# MultiMedia dependencies
219qtmultimediadepend="
220 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
221"
222case ${MULTIMEDIA_REQUIRED} in
223 always)
224 COMMONDEPEND+=" ${qtmultimediadepend}"
225 ;;
226 optional)
227 IUSE+=" multimedia"
228 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
229 ;;
230 *) ;;
231esac
232unset qtmultimediadepend
233
234# WebKit dependencies
235case ${KDE_REQUIRED} in
236 always)
237 qtwebkitusedeps="[kde]"
238 ;;
239 optional)
240 qtwebkitusedeps="[kde?]"
241 ;;
242 *) ;;
243esac
244qtwebkitdepend="
245 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
246"
247unset qtwebkitusedeps
248case ${WEBKIT_REQUIRED} in
249 always)
250 COMMONDEPEND+=" ${qtwebkitdepend}"
251 ;;
252 optional)
253 IUSE+=" webkit"
254 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
255 ;;
256 *) ;;
257esac
258unset qtwebkitdepend
259
260# CppUnit dependencies
261cppuintdepend="
262 dev-util/cppunit
263"
264case ${CPPUNIT_REQUIRED} in
265 always)
266 DEPEND+=" ${cppuintdepend}"
267 ;;
268 optional)
269 IUSE+=" test"
270 DEPEND+=" test? ( ${cppuintdepend} )"
271 ;;
272 *) ;;
273esac
274unset cppuintdepend
223 275
224# KDE dependencies 276# KDE dependencies
277# Qt accessibility classes are needed in various places, bug 325461
225kdecommondepend=" 278kdecommondepend="
226 dev-lang/perl 279 dev-lang/perl
227 >=x11-libs/qt-core-${QT_DEPEND}:4[qt3support,ssl] 280 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
228 >=x11-libs/qt-gui-${QT_DEPEND}:4[accessibility,dbus] 281 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
229 >=x11-libs/qt-qt3support-${QT_DEPEND}:4[accessibility,kde] 282 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
230 >=x11-libs/qt-script-${QT_DEPEND}:4 283 >=x11-libs/qt-script-${QT_MINIMAL}:4
231 >=x11-libs/qt-sql-${QT_DEPEND}:4[qt3support] 284 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
232 >=x11-libs/qt-svg-${QT_DEPEND}:4 285 >=x11-libs/qt-svg-${QT_MINIMAL}:4
233 >=x11-libs/qt-test-${QT_DEPEND}:4 286 >=x11-libs/qt-test-${QT_MINIMAL}:4
234 !aqua? ( 287 !aqua? (
235 x11-libs/libXext 288 x11-libs/libXext
236 x11-libs/libXt 289 x11-libs/libXt
237 x11-libs/libXxf86vm 290 x11-libs/libXxf86vm
238 ) 291 )
239" 292"
293
240if [[ ${PN} != kdelibs ]]; then 294if [[ ${PN} != kdelibs ]]; then
295 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
241 if [[ ${KDEBASE} = kde-base ]]; then 296 if [[ ${KDEBASE} = kdevelop ]]; then
242 # libknotificationitem only when SLOT is 4.3 297 if [[ ${PN} != kdevplatform ]]; then
243 [[ ${PN} != libknotificationitem ]] && [[ ${SLOT} = 4.3 ]] && local libknotificationitem_required=1 298 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
244 kdecommondepend+=" 299 # @DESCRIPTION:
245 kdeprefix? ( >=kde-base/kdelibs${_pv}[kdeprefix] ) 300 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
246 !kdeprefix? ( >=kde-base/kdelibs${_pvn}[-kdeprefix] ) 301 # Applies to KDEBASE=kdevelop only.
247 " 302 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
248 [[ -n ${libknotificationitem_required} ]] && \ 303 case ${KDEVPLATFORM_REQUIRED} in
304 always)
249 kdecommondepend+=" 305 kdecommondepend+="
250 kdeprefix? ( >=kde-base/libknotificationitem${_pv}[kdeprefix] ) 306 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
251 !kdeprefix? ( >=kde-base/libknotificationitem${_pvn}[-kdeprefix] )
252 " 307 "
253 else 308 ;;
254 kdecommondepend+=" 309 *) ;;
255 >=kde-base/kdelibs${_pv} 310 esac
256 " 311 fi
257 fi 312 fi
258fi 313fi
259unset _pv _pvn
260kdedepend=" 314kdedepend="
315 dev-util/automoc
261 dev-util/pkgconfig 316 dev-util/pkgconfig
317 !aqua? (
318 || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1.0 )
319 x11-proto/xf86vidmodeproto
320 )
262" 321"
322kderdepend=""
323
324kdehandbookdepend="
325 app-text/docbook-xml-dtd:4.2
326 app-text/docbook-xsl-stylesheets
327"
328kdehandbookrdepend="
329 $(add_kdebase_dep kdelibs 'handbook')
330"
331case ${KDE_HANDBOOK} in
332 always)
333 kdedepend+=" ${kdehandbookdepend}"
334 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
335 ;;
336 optional)
337 IUSE+=" +handbook"
338 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
339 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
340 ;;
341 *) ;;
342esac
343unset kdehandbookdepend kdehandbookrdepend
344
263case ${KDE_REQUIRED} in 345case ${KDE_REQUIRED} in
264 always) 346 always)
265 IUSE+=" aqua" 347 IUSE+=" aqua"
266 COMMONDEPEND+=" ${kdecommondepend}" 348 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
267 DEPEND+=" ${kdedepend}" 349 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
350 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
268 ;; 351 ;;
269 optional) 352 optional)
270 IUSE+=" aqua kde" 353 IUSE+=" aqua kde"
271 COMMONDEPEND+=" kde? ( ${kdecommondepend} )" 354 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
272 DEPEND+=" kde? ( ${kdedepend} )" 355 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
356 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
273 ;; 357 ;;
274 *) ;; 358 *) ;;
275esac 359esac
360
276unset kdecommondepend kdedepend 361unset kdecommondepend kdedepend kderdepend
277 362
278debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}" 363debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
279debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}" 364debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
280debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}" 365debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
281 366
282# Accumulate dependencies set by this eclass 367# Accumulate dependencies set by this eclass
283DEPEND+=" ${COMMONDEPEND}" 368DEPEND+=" ${COMMONDEPEND}"
284RDEPEND+=" ${COMMONDEPEND}" 369RDEPEND+=" ${COMMONDEPEND}"
285unset COMMONDEPEND 370unset COMMONDEPEND
286 371
372# Add experimental kdeenablefinal, disabled by default
373IUSE+=" kdeenablefinal"
374
287# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 375# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
288# koffice ebuild, the URI should be set in the ebuild itself 376# koffice ebuild, the URI should be set in the ebuild itself
289case ${BUILD_TYPE} in 377case ${BUILD_TYPE} in
290 live) 378 live)
291 # Determine branch URL based on live type
292 local branch_prefix
293 case ${PV} in
294 9999*)
295 # trunk
296 branch_prefix="trunk/KDE"
297 ;;
298 *)
299 # branch
300 branch_prefix="branches/KDE/${SLOT}"
301 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
302 # @DESCRIPTION
303 # Suffix appended to ESVN_PROJECT depending on fetched branch.
304 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
305 ESVN_PROJECT_SUFFIX="-${PV}"
306 ;;
307 esac
308 SRC_URI="" 379 SRC_URI=""
380 if has subversion ${INHERITED}; then
381 # Determine branch URL based on live type
382 local branch_prefix
383 case ${PV} in
384 9999*)
385 # trunk
386 branch_prefix="trunk/KDE"
387 ;;
388 *)
389 # branch
390 branch_prefix="branches/KDE/${SLOT}"
391 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
392 # @DESCRIPTION
393 # Suffix appended to ESVN_PROJECT depending on fetched branch.
394 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
395 ESVN_PROJECT_SUFFIX="-${PV}"
396 ;;
397 esac
309 # @ECLASS-VARIABLE: ESVN_MIRROR 398 # @ECLASS-VARIABLE: ESVN_MIRROR
310 # @DESCRIPTION: 399 # @DESCRIPTION:
311 # This variable allows easy overriding of default kde mirror service 400 # This variable allows easy overriding of default kde mirror service
312 # (anonsvn) with anything else you might want to use. 401 # (anonsvn) with anything else you might want to use.
313 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde} 402 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
314 # Split ebuild, or extragear stuff 403 # Split ebuild, or extragear stuff
315 if [[ -n ${KMNAME} ]]; then 404 if [[ -n ${KMNAME} ]]; then
316 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}" 405 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
406 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
407 KMMODULE="${PN}"
408 fi
409 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
410 case ${KMNAME} in
411 kdebase-*)
412 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
413 ;;
414 kdelibs-*)
415 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
416 ;;
417 kdereview*)
418 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
419 ;;
420 kdesupport)
421 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
422 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
423 ;;
424 kde*)
425 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
426 ;;
427 extragear*|playground*)
428 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
429 # build packages from same svn location.
430 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
431 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
432 ;;
433 koffice)
434 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
435 ;;
436 *)
437 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
438 ;;
439 esac
440 else
441 # kdelibs, kdepimlibs
442 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
443 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
444 fi
445 # @ECLASS-VARIABLE: ESVN_UP_FREQ
446 # @DESCRIPTION:
447 # This variable is used for specifying the timeout between svn synces
448 # for kde-base and koffice modules. Does not affect misc apps.
449 # Default value is 1 hour.
450 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
451 elif has git ${INHERITED}; then
317 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then 452 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
318 KMMODULE="${PN}" 453 KMMODULE="${PN}"
319 fi 454 fi
320 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
321 case ${KMNAME} in 455 case ${KDEBASE} in
322 kdebase-*) 456 kdevelop)
323 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}" 457 EGIT_REPO_URI="git://gitorious.org/${KMNAME}/${KMMODULE}.git"
324 ;;
325 kdelibs-*)
326 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
327 ;;
328 kdereview)
329 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
330 ;;
331 kdesupport)
332 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
333 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
334 ;;
335 kde*)
336 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
337 ;;
338 extragear*|playground*)
339 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
340 # build packages from same svn location.
341 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
342 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
343 ;;
344 koffice)
345 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
346 ;;
347 *)
348 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
349 ;; 458 ;;
350 esac 459 esac
351 else
352 # kdelibs, kdepimlibs
353 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
354 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
355 fi 460 fi
356 # @ECLASS-VARIABLE: ESVN_UP_FREQ
357 # @DESCRIPTION:
358 # This variable is used for specifying the timeout between svn synces
359 # for kde-base and koffice modules. Does not affect misc apps.
360 # Default value is 1 hour.
361 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
362 ;; 461 ;;
363 *) 462 *)
364 if [[ -n ${KDEBASE} ]]; then 463 if [[ -n ${KDEBASE} ]]; then
365 if [[ -n ${KMNAME} ]]; then 464 if [[ -n ${KMNAME} ]]; then
366 case ${KMNAME} in 465 case ${KMNAME} in
371 esac 470 esac
372 else 471 else
373 _kmname=${PN} 472 _kmname=${PN}
374 fi 473 fi
375 _kmname_pv="${_kmname}-${PV}" 474 _kmname_pv="${_kmname}-${PV}"
376 if [[ $NEED_KDE != live ]]; then
377 case ${KDEBASE} in 475 case ${KDEBASE} in
378 kde-base) 476 kde-base)
379 case ${PV} in 477 case ${PV} in
380 4.3.85 | 4.3.9[0568]) 478 4.[456].8[05] | 4.[456].9[023568])
381 # block for normally packed unstable releases 479 # Unstable KDE SC releases
382 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" ;; 480 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
383 4.3.[6-9]*) 481 ;;
384 SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${PV}/${_kmname_pv}.tar.lzma" ;; 482 4.4.6 | 4.4.7)
483 # Only kdepim here
484 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
485 ;;
486 *)
487 # Stable KDE SC releases
385 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;; 488 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
489 ;;
386 esac 490 esac
387 ;; 491 ;;
388 koffice) 492 koffice)
389 case ${PV} in 493 case ${PV} in
390 2.0.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" ;; 494 2.1.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
391 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" ;; 495 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
392 esac 496 esac
497 ;;
498 kdevelop)
499 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
500 ;;
393 esac 501 esac
394 fi
395 unset _kmname _kmname_pv 502 unset _kmname _kmname_pv
396 fi 503 fi
397 ;; 504 ;;
398esac 505esac
399 506
410# Do the basic kdeprefix KDEDIR settings and determine with which kde should 517# Do the basic kdeprefix KDEDIR settings and determine with which kde should
411# optional applications link 518# optional applications link
412kde4-base_pkg_setup() { 519kde4-base_pkg_setup() {
413 debug-print-function ${FUNCNAME} "$@" 520 debug-print-function ${FUNCNAME} "$@"
414 521
522 # Prefix compat:
523 if [[ ${EAPI} == 2 ]] && ! use prefix; then
524 EPREFIX=
525 EROOT=${ROOT}
526 fi
527
528 # Append missing trailing slash character
529 [[ ${EROOT} = */ ]] || EROOT+="/"
530
415 # QA ebuilds 531 # QA ebuilds
416 case ${NEED_KDE} in
417 none) ewarn "QA Notice: using deprecated NEED_KDE variable, use KDE_REQUIRED=\"never\" or KDE_REQUIRED=\"optional\" instead. You may want to override KDE_MINIMAL as well (default is KDE_MINIMAL=\"${KDE_MINIMAL}\")." ;;
418 *) [[ -n ${NEED_KDE} ]] && ewarn "QA Notice: using deprecated NEED_KDE variable, use KDE_MINIMAL instead (default is KDE_MINIMAL=\"${KDE_MINIMAL}\")." ;;
419 esac
420 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})." 532 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
421 533
422 # Don't set KDEHOME during compilation, it will cause access violations 534 # Don't set KDEHOME during compilation, it will cause access violations
423 unset KDEHOME 535 unset KDEHOME
424 536
425 if [[ ${KDEBASE} = kde-base ]]; then 537 if [[ ${KDEBASE} = kde-base ]]; then
426 if use kdeprefix; then 538 if use kdeprefix; then
427 KDEDIR="${EROOT}usr/kde/${_kdedir}" 539 KDEDIR=/usr/kde/${SLOT}
428 else 540 else
429 KDEDIR="${EROOT}usr" 541 KDEDIR=/usr
430 fi 542 fi
431 PREFIX="${PREFIX:-${KDEDIR}}" 543 : ${PREFIX:=${KDEDIR}}
432 else 544 else
433 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL 545 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
434 KDEDIR= 546 KDEDIR=
435 local kde_minimal_met 547 local kde_minimal_met
436 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do 548 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
437 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1 549 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
438 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then 550 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
439 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then 551 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
440 KDEDIR="${EROOT}usr/kde/${slot}" 552 KDEDIR=/usr/kde/${slot}
441 else 553 else
442 KDEDIR="${EROOT}usr" 554 KDEDIR=/usr
443 fi 555 fi
444 break; 556 break;
445 fi 557 fi
446 done 558 done
447 unset slot 559 unset slot
448 560
449 # Bail out if kdelibs required but not found 561 # Bail out if kdelibs required but not found
450 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then 562 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
451 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!" 563 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
452 else 564 else
453 [[ -z ${KDEDIR} ]] && KDEDIR="${EROOT}usr" 565 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
454 fi
455
456 PREFIX="${PREFIX:-${EROOT}usr}"
457 fi 566 fi
567
568 : ${PREFIX:=/usr}
569 fi
570 EKDEDIR=${EPREFIX}${KDEDIR}
571
458 # Point pkg-config path to KDE *.pc files 572 # Point pkg-config path to KDE *.pc files
459 export PKG_CONFIG_PATH="${KDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}" 573 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
460 # Point to correct QT plugins path 574 # Point to correct QT plugins path
461 QT_PLUGIN_PATH="${KDEDIR}/$(get_libdir)/kde4/plugins/" 575 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
462 576
463 # Not needed anymore 577 # Fix XDG collision with sandbox
464 unset _kdedir 578 export XDG_CONFIG_HOME="${T}"
465} 579}
466 580
467# @FUNCTION: kde4-base_src_unpack 581# @FUNCTION: kde4-base_src_unpack
468# @DESCRIPTION: 582# @DESCRIPTION:
469# This function unpacks the source tarballs for KDE4 applications. 583# This function unpacks the source tarballs for KDE4 applications.
470kde4-base_src_unpack() { 584kde4-base_src_unpack() {
471 debug-print-function ${FUNCNAME} "$@" 585 debug-print-function ${FUNCNAME} "$@"
472 586
473 if [[ ${BUILD_TYPE} = live ]]; then 587 if [[ ${BUILD_TYPE} = live ]]; then
588 if has subversion ${INHERITED}; then
474 migrate_store_dir 589 migrate_store_dir
475 subversion_src_unpack 590 subversion_src_unpack
591 elif has git ${INHERITED}; then
592 git_src_unpack
593 fi
594 elif [[ ${EAPI} == 2 ]]; then
595 local file
596 for file in ${A}; do
597 # This setup is because EAPI <= 2 cannot unpack *.tar.xz files
598 # directly, so we do it ourselves (using the exact same code as portage)
599 case ${file} in
600 *.tar.xz)
601 echo ">>> Unpacking ${file} to ${PWD}"
602 xz -dc "${DISTDIR}"/${file} | tar xof -
603 assert "failed unpacking ${file}"
604 ;;
605 *)
606 unpack ${file}
607 ;;
608 esac
609 done
476 else 610 else
477 base_src_unpack 611 # For EAPI >= 3, we can just use unpack() directly
612 unpack ${A}
478 fi 613 fi
479} 614}
480 615
481# @FUNCTION: kde4-base_src_prepare 616# @FUNCTION: kde4-base_src_prepare
482# @DESCRIPTION: 617# @DESCRIPTION:
497 # kdelibs inherits kde4-base but handle installing the handbook itself 632 # kdelibs inherits kde4-base but handle installing the handbook itself
498 if ! has kde4-meta ${INHERITED}; then 633 if ! has kde4-meta ${INHERITED}; then
499 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas 634 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas
500 fi 635 fi
501 636
502 [[ ${BUILD_TYPE} = live ]] && subversion_src_prepare 637 # SCM bootstrap
638 if [[ ${BUILD_TYPE} = live ]]; then
639 if has subversion ${INHERITED}; then
640 subversion_src_prepare
641 elif has git ${INHERITED}; then
642 git_src_prepare
643 fi
644 fi
645
646 # Apply patches
503 base_src_prepare 647 base_src_prepare
504 648
505 # Save library dependencies 649 # Save library dependencies
506 if [[ -n ${KMSAVELIBS} ]] ; then 650 if [[ -n ${KMSAVELIBS} ]] ; then
507 save_library_dependencies 651 save_library_dependencies
509 653
510 # Inject library dependencies 654 # Inject library dependencies
511 if [[ -n ${KMLOADLIBS} ]] ; then 655 if [[ -n ${KMLOADLIBS} ]] ; then
512 load_library_dependencies 656 load_library_dependencies
513 fi 657 fi
658
659 # Hack for manuals relying on outdated DTD
660 find "${S}" -name "*.docbook" \
661 -exec sed -i -r \
662 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
663 || die 'failed to fix DocBook variant version'
514} 664}
515 665
516# @FUNCTION: kde4-base_src_configure 666# @FUNCTION: kde4-base_src_configure
517# @DESCRIPTION: 667# @DESCRIPTION:
518# Function for configuring the build of KDE4 applications. 668# Function for configuring the build of KDE4 applications.
519kde4-base_src_configure() { 669kde4-base_src_configure() {
520 debug-print-function ${FUNCNAME} "$@" 670 debug-print-function ${FUNCNAME} "$@"
521 671
672 # Build tests in src_test only, where we override this value
673 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
674
675 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
676 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
677 fi
678
679 if has debug ${IUSE//+} && use debug; then
680 # Set "real" debug mode
681 CMAKE_BUILD_TYPE="Debugfull"
682 else
522 # Handle common release builds 683 # Handle common release builds
523 if ! has debug ${IUSE//+} || ! use debug; then
524 append-cppflags -DQT_NO_DEBUG 684 append-cppflags -DQT_NO_DEBUG
525 fi 685 fi
526 686
527 # Build tests in src_test only, where we override this value
528 local cmakeargs="-DKDE4_BUILD_TESTS=OFF"
529
530 # set "real" debug mode
531 if has debug ${IUSE//+} && use debug; then
532 CMAKE_BUILD_TYPE="Debugfull"
533 fi
534
535 # Set distribution name 687 # Set distribution name
536 [[ ${PN} = kdelibs ]] && cmakeargs+=" -DKDE_DISTRIBUTION_TEXT=Gentoo" 688 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
537 689
538 # Here we set the install prefix 690 # Here we set the install prefix
539 cmakeargs+=" -DCMAKE_INSTALL_PREFIX=${PREFIX}" 691 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
540 692
541 # Use colors 693 # Use colors
542 QTEST_COLORED=1 694 QTEST_COLORED=1
543 695
544 # Shadow existing /usr installations 696 # Shadow existing /usr installations
545 unset KDEDIRS 697 unset KDEDIRS
546 698
547 # Handle kdeprefix-ed KDE 699 # Handle kdeprefix-ed KDE
548 if [[ ${KDEDIR} != "${EROOT}usr" ]]; then 700 if [[ ${KDEDIR} != /usr ]]; then
549 # Override some environment variables - only when kdeprefix is different, 701 # Override some environment variables - only when kdeprefix is different,
550 # to not break ccache/distcc 702 # to not break ccache/distcc
551 PATH="${KDEDIR}/bin:${PATH}" 703 PATH="${EKDEDIR}/bin:${PATH}"
552 LDPATH="${KDEDIR}/$(get_libdir):${LDPATH}" 704
705 # Append library search path
706 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
553 707
554 # Append full RPATH 708 # Append full RPATH
555 cmakeargs+=" -DCMAKE_SKIP_RPATH=OFF" 709 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
556 710
557 # Set cmake prefixes to allow buildsystem to locate valid KDE installation 711 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
558 # when more are present 712 # when more are present
559 cmakeargs+=" -DCMAKE_SYSTEM_PREFIX_PATH=${KDEDIR}" 713 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
560 fi 714 fi
715
716 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
717 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4)
718 #kde-config -path data unavailable when cross-compiling
719 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
561 720
562 # Handle kdeprefix in application itself 721 # Handle kdeprefix in application itself
563 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then 722 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
564 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc 723 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
565 cmakeargs+=" -DSYSCONF_INSTALL_DIR=${EROOT}etc" 724 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
566 fi 725 fi
567 726
727 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
728 mycmakeargs=(${mycmakeargs})
729 fi
730
568 mycmakeargs="${cmakeargs} ${mycmakeargs}" 731 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
569 732
570 cmake-utils_src_configure 733 cmake-utils_src_configure
571} 734}
572 735
573# @FUNCTION: kde4-base_src_compile 736# @FUNCTION: kde4-base_src_compile
584# Function for testing KDE4 applications. 747# Function for testing KDE4 applications.
585kde4-base_src_test() { 748kde4-base_src_test() {
586 debug-print-function ${FUNCNAME} "$@" 749 debug-print-function ${FUNCNAME} "$@"
587 750
588 # Override this value, set in kde4-base_src_configure() 751 # Override this value, set in kde4-base_src_configure()
589 mycmakeargs+=" -DKDE4_BUILD_TESTS=ON" 752 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
590 cmake-utils_src_configure 753 cmake-utils_src_configure
591 kde4-base_src_compile 754 kde4-base_src_compile
592 755
593 cmake-utils_src_test 756 cmake-utils_src_test
594} 757}
597# @DESCRIPTION: 760# @DESCRIPTION:
598# Function for installing KDE4 applications. 761# Function for installing KDE4 applications.
599kde4-base_src_install() { 762kde4-base_src_install() {
600 debug-print-function ${FUNCNAME} "$@" 763 debug-print-function ${FUNCNAME} "$@"
601 764
765 # Prefix support, for usage in ebuilds
766 if [[ ${EAPI} == 2 ]] && ! use prefix; then
767 ED=${D}
768 fi
769
602 if [[ -n ${KMSAVELIBS} ]] ; then 770 if [[ -n ${KMSAVELIBS} ]] ; then
603 install_library_dependencies 771 install_library_dependencies
604 fi 772 fi
605 773
606 kde4-base_src_make_doc 774 # Install common documentation of KDE4 applications
775 local doc
776 if ! has kde4-meta ${INHERITED}; then
777 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
778 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && dodoc "${doc}"
779 done
780 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
781 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
782 done
783 fi
784
607 cmake-utils_src_install 785 cmake-utils_src_install
608}
609
610# @FUNCTION: kde4-base_src_make_doc
611# @DESCRIPTION:
612# Function for installing the documentation of KDE4 applications.
613kde4-base_src_make_doc() {
614 debug-print-function ${FUNCNAME} "$@"
615
616 local doc
617 for doc in AUTHORS ChangeLog* README* NEWS TODO; do
618 [[ -s ${doc} ]] && dodoc ${doc}
619 done
620
621 if [[ -z ${KMNAME} ]]; then
622 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
623 if [[ -s ${doc} ]]; then
624 local doc_complete=${doc}
625 doc="${doc#*/}"
626 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
627 fi
628 done
629 fi
630
631 if [[ -n ${KDEBASE} ]] && [[ -d "${D}${EROOT}usr/share/doc/${PF}" ]]; then
632 # work around bug #97196
633 dodir /usr/share/doc/KDE4 && \
634 cp -r "${D}${EROOT}usr/share/doc/${PF}" "${D}${EROOT}usr/share/doc/KDE4/" || \
635 die "Failed to move docs to KDE4/."
636 rm -rf "${D}${EROOT}usr/share/doc/${PF}"
637 fi
638} 786}
639 787
640# @FUNCTION: kde4-base_pkg_postinst 788# @FUNCTION: kde4-base_pkg_postinst
641# @DESCRIPTION: 789# @DESCRIPTION:
642# Function to rebuild the KDE System Configuration Cache after an application has been installed. 790# Function to rebuild the KDE System Configuration Cache after an application has been installed.
659 ewarn "with KDE update strategies." 807 ewarn "with KDE update strategies."
660 ewarn "You are using this setup at your own risk and the kde team does not" 808 ewarn "You are using this setup at your own risk and the kde team does not"
661 ewarn "take responsibilities for dead kittens." 809 ewarn "take responsibilities for dead kittens."
662 echo 810 echo
663 fi 811 fi
812 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && ! has_version 'kde-base/kdebase-runtime-meta' && ! has_version 'kde-base/kdebase-startkde'; then
813 # warn about not supported approach
814 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
815 echo
816 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
817 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
818 ewarn "With this setting you are unsupported by KDE team."
819 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
820 fi
821 fi
664} 822}
665 823
666# @FUNCTION: kde4-base_pkg_postrm 824# @FUNCTION: kde4-base_pkg_postrm
667# @DESCRIPTION: 825# @DESCRIPTION:
668# Function to rebuild the KDE System Configuration Cache after an application has been removed. 826# Function to rebuild the KDE System Configuration Cache after an application has been removed.

Legend:
Removed from v.1.46  
changed lines
  Added in v.1.76

  ViewVC Help
Powered by ViewVC 1.1.20