/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.9 Revision 1.76
1# Copyright 2007-2008 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.9 2008/04/06 21:36:53 zlin Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.76 2010/10/27 21:24:22 dilfridge Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.0 ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 monolithic ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: This eclass uses the SLOT dependencies from EAPI="1" or compatible, 13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but
14# hence you must define EAPI="1" in the ebuild, before inheriting any eclasses. 14# eclass will fail with version older than 2.
15 15
16inherit base eutils multilib cmake-utils kde4-functions 16inherit kde4-functions base eutils
17 17
18EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_test src_install pkg_postinst pkg_postrm 18get_build_type
19if [[ ${BUILD_TYPE} = live ]]; then
20 if [[ ${KDEBASE} = kdevelop ]]; then
21 inherit git
22 else
23 inherit subversion
24 fi
25fi
19 26
20kde4-base_set_qt_dependencies() { 27# @ECLASS-VARIABLE: CMAKE_REQUIRED
21 local qt qtcore qtgui qt3support qtsvg qttest qtopengl qtdepend qtopengldepend 28# @DESCRIPTION:
29# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
30# Please note that if it's set to 'never' you need to explicitly override following phases:
31# src_configure, src_compile, src_test and src_install.
32# Defaults to 'always'.
33: ${CMAKE_REQUIRED:=always}
34if [[ ${CMAKE_REQUIRED} = always ]]; then
35 buildsystem_eclass="cmake-utils"
36 export_fns="src_configure src_compile src_test src_install"
37fi
22 38
23 # use dependencies 39# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
40if [[ -n ${KDE_MINIMAL} ]]; then
41 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
42 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
43 done
44 unset slot
45 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
46else
47 KDE_MINIMAL_VALID=1
48fi
49
50# @ECLASS-VARIABLE: KDE_MINIMAL
51# @DESCRIPTION:
52# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
53# version for apps to work. Currently defaults to 4.4
54# One may override this variable to raise version requirements.
55# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
56# Note that it is fixed to ${SLOT} for kde-base packages.
57KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
58
59# Set slot for packages in kde-base, koffice and kdevelop
60case ${KDEBASE} in
61 kde-base)
62 # Determine SLOT from PVs
24 case "${EAPI}" in 63 case ${PV} in
25 kdebuild-1) 64 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
26 qt="[accessibility][dbus][debug?][gif][jpeg][png][qt3support][ssl][zlib]" 65 4.6* | 4.5.[6-9][0-9]*) SLOT="4.6" ;;
27 qtcore="[debug?][qt3support][ssl]" 66 4.5* | 4.4.[6-9][0-9]*) SLOT="4.5" ;;
28 qtgui="[accessibility][dbus][debug?]" 67 4.4* | 4.3.[6-9][0-9]*) SLOT="4.4" ;;
29 qt3support="[accessibility][debug?]" 68 9999*) SLOT="live" ;; # regular live
30 qtsvg="[debug?]" 69 *) die "Unsupported ${PV}" ;;
31 qttest="[debug?]"
32 qtopengl="[debug?]"
33 case "${OPENGL_REQUIRED}" in
34 always)
35 qt="${qt}[opengl]"
36 ;;
37 optional)
38 qt="${qt}[opengl?]"
39 ;;
40 esac 70 esac
71 KDE_MINIMAL="${SLOT}"
41 ;; 72 ;;
73 koffice)
74 SLOT="2"
75 ;;
76 kdevelop)
77 if [[ ${BUILD_TYPE} = live ]]; then
78 # @ECLASS-VARIABLE: KDEVELOP_VERSION
79 # @DESCRIPTION:
80 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
81 # Applies to KDEBASE=kdevelop only.
82 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
83 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
84 # @DESCRIPTION:
85 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
86 # Applies to KDEBASE=kdevelop only.
87 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
88 else
89 case ${PN} in
90 kdevelop|quanta)
91 KDEVELOP_VERSION=${PV}
92 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
93 ;;
94 kdevplatform)
95 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
96 KDEVPLATFORM_VERSION=${PV}
97 ;;
98 *)
99 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
100 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
101 esac
102 fi
103 SLOT="4"
104 ;;
42 esac 105esac
43 106
44 # split qt 107slot_is_at_least 4.5 ${KDE_MINIMAL} && CMAKE_MIN_VERSION="2.8.1"
45 qtdepend="
46 x11-libs/qt-core:4${qtcore}
47 x11-libs/qt-gui:4${qtgui}
48 x11-libs/qt-qt3support:4${qt3support}
49 x11-libs/qt-svg:4${qtsvg}
50 x11-libs/qt-test:4${qttest}"
51 qtopengldepend="x11-libs/qt-opengl:4${qtopengl}"
52 108
53 # allow monolithic qt for PV < 4.1 109inherit ${buildsystem_eclass}
54 case "${PV}" in
55 scm|9999.4|4.1*) : ;;
56 *)
57 qtdepend="|| ( ( ${qtdepend} ) >=x11-libs/qt-4.3.3:4${qt} )"
58 qtopengldepend="|| ( ${qtopengldepend} >=x11-libs/qt-4.3.3:4 )"
59 ;;
60 esac
61 110
62 # opengl dependencies 111EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm
63 case "${OPENGL_REQUIRED}" in
64 always)
65 qtdepend="${qtdepend}
66 ${qtopengldepend}"
67 ;;
68 optional)
69 IUSE="${IUSE} opengl"
70 qtdepend="${qtdepend}
71 opengl? ( ${qtopengldepend} )"
72 ;;
73 *)
74 OPENGL_REQUIRED="never"
75 ;;
76 esac
77 112
78 COMMONDEPEND="${COMMONDEPEND} ${qtdepend}" 113unset buildsystem_eclass
79} 114unset export_fns
80kde4-base_set_qt_dependencies
81
82DEPEND="${DEPEND} ${COMMONDEPEND}
83 >=dev-util/cmake-2.4.7-r1
84 dev-util/pkgconfig
85 x11-libs/libXt
86 x11-proto/xf86vidmodeproto"
87RDEPEND="${RDEPEND} ${COMMONDEPEND}"
88 115
89# @ECLASS-VARIABLE: OPENGL_REQUIRED 116# @ECLASS-VARIABLE: OPENGL_REQUIRED
90# @DESCRIPTION: 117# @DESCRIPTION:
91# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 118# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
92# This variable must be set before inheriting any eclasses. Defaults to 'never'. 119# This variable must be set before inheriting any eclasses. Defaults to 'never'.
93OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 120OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
94 121
122# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
123# @DESCRIPTION:
124# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
125# This variable must be set before inheriting any eclasses. Defaults to 'never'.
126MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
127
128# @ECLASS-VARIABLE: WEBKIT_REQUIRED
129# @DESCRIPTION:
130# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
131# This variable must be set before inheriting any eclasses. Defaults to 'never'.
132WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
133
95# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 134# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
96# @DESCRIPTION: 135# @DESCRIPTION:
97# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 136# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
98# This variable must be set before inheriting any eclasses. Defaults to 'never'. 137# This variable must be set before inheriting any eclasses. Defaults to 'never'.
99CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}" 138CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
100 139
140# @ECLASS-VARIABLE: KDE_REQUIRED
141# @DESCRIPTION:
142# Is kde required? Possible values are 'always', 'optional' and 'never'.
143# This variable must be set before inheriting any eclasses. Defaults to 'always'
144# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
145# Note that for kde-base packages this variable is fixed to 'always'.
146KDE_REQUIRED="${KDE_REQUIRED:-always}"
147
148# @ECLASS-VARIABLE: KDE_HANDBOOK
149# @DESCRIPTION:
150# Set to enable handbook in application. Possible values are 'always', 'optional'
151# (handbook USE flag) and 'never'.
152# This variable must be set before inheriting any eclasses. Defaults to 'never'.
153# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
154# ensures buildtime and runtime dependencies.
155KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
156
157# Setup packages inheriting this eclass
158case ${KDEBASE} in
159 kde-base)
160 HOMEPAGE="http://www.kde.org/"
161 LICENSE="GPL-2"
162 if [[ $BUILD_TYPE = live ]]; then
163 # Disable tests for live ebuilds
164 RESTRICT+=" test"
165 # Live ebuilds in kde-base default to kdeprefix by default
166 IUSE+=" +kdeprefix"
167 else
168 # All other ebuild types default to -kdeprefix as before
169 IUSE+=" kdeprefix"
170 fi
171 # This code is to prevent portage from searching GENTOO_MIRRORS for
172 # packages that will never be mirrored. (As they only will ever be in
173 # the overlay).
174 case ${PV} in
175 *9999* | 4.?.[6-9]?)
176 RESTRICT+=" mirror"
177 ;;
178 esac
179 # Block installation of other SLOTS unless kdeprefix
180 RDEPEND+=" $(block_other_slots)"
181 ;;
182 koffice)
183 HOMEPAGE="http://www.koffice.org/"
184 LICENSE="GPL-2"
185 ;;
186 kdevelop)
187 HOMEPAGE="http://www.kdevelop.org/"
188 LICENSE="GPL-2"
189 ;;
190esac
191
192# @ECLASS-VARIABLE: QT_MINIMAL
193# @DESCRIPTION:
194# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1...
195# 4.6.0 for 4.4 and 4.6.3 for 4.5 and later
196if slot_is_at_least 4.5 "${KDE_MINIMAL}"; then
197 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
198else
199 QT_MINIMAL="${QT_MINIMAL:-4.6.0}"
200fi
201
202# OpenGL dependencies
203qtopengldepend="
204 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
205"
101case "${CPPUNIT_REQUIRED}" in 206case ${OPENGL_REQUIRED} in
102 always) 207 always)
103 DEPEND="${DEPEND} dev-util/cppunit" 208 COMMONDEPEND+=" ${qtopengldepend}"
104 ;; 209 ;;
105 optional) 210 optional)
106 IUSE="${IUSE} test" 211 IUSE+=" opengl"
107 DEPEND="${DEPEND} 212 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
108 test? ( dev-util/cppunit )"
109 ;; 213 ;;
110 *) 214 *) ;;
111 CPPUNIT_REQUIRED="never" 215esac
216unset qtopengldepend
217
218# MultiMedia dependencies
219qtmultimediadepend="
220 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
221"
222case ${MULTIMEDIA_REQUIRED} in
223 always)
224 COMMONDEPEND+=" ${qtmultimediadepend}"
112 ;; 225 ;;
226 optional)
227 IUSE+=" multimedia"
228 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
229 ;;
230 *) ;;
113esac 231esac
232unset qtmultimediadepend
114 233
115# @ECLASS-VARIABLE: NEED_KDE 234# WebKit dependencies
235case ${KDE_REQUIRED} in
236 always)
237 qtwebkitusedeps="[kde]"
238 ;;
239 optional)
240 qtwebkitusedeps="[kde?]"
241 ;;
242 *) ;;
243esac
244qtwebkitdepend="
245 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
246"
247unset qtwebkitusedeps
248case ${WEBKIT_REQUIRED} in
249 always)
250 COMMONDEPEND+=" ${qtwebkitdepend}"
251 ;;
252 optional)
253 IUSE+=" webkit"
254 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
255 ;;
256 *) ;;
257esac
258unset qtwebkitdepend
259
260# CppUnit dependencies
261cppuintdepend="
262 dev-util/cppunit
263"
264case ${CPPUNIT_REQUIRED} in
265 always)
266 DEPEND+=" ${cppuintdepend}"
267 ;;
268 optional)
269 IUSE+=" test"
270 DEPEND+=" test? ( ${cppuintdepend} )"
271 ;;
272 *) ;;
273esac
274unset cppuintdepend
275
276# KDE dependencies
277# Qt accessibility classes are needed in various places, bug 325461
278kdecommondepend="
279 dev-lang/perl
280 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
281 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
282 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
283 >=x11-libs/qt-script-${QT_MINIMAL}:4
284 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
285 >=x11-libs/qt-svg-${QT_MINIMAL}:4
286 >=x11-libs/qt-test-${QT_MINIMAL}:4
287 !aqua? (
288 x11-libs/libXext
289 x11-libs/libXt
290 x11-libs/libXxf86vm
291 )
292"
293
294if [[ ${PN} != kdelibs ]]; then
295 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
296 if [[ ${KDEBASE} = kdevelop ]]; then
297 if [[ ${PN} != kdevplatform ]]; then
298 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
116# @DESCRIPTION: 299 # @DESCRIPTION:
117# This variable sets the version of KDE4 which will be used by the eclass. 300 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
118# This variable must be set by the ebuild, for all categories except for "kde-base". 301 # Applies to KDEBASE=kdevelop only.
119# For kde-base packages, if it is not set by the ebuild, 302 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
120# it's assumed that the required KDE4 version is the latest, non-live, available. 303 case ${KDEVPLATFORM_REQUIRED} in
121# 304 always)
122# @CODE 305 kdecommondepend+="
123# Acceptable values are: 306 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
124# - latest - Use latest version in the portage tree 307 "
125# Default for kde-base ebuilds. Banned for ebuilds not part of kde or koffice. 308 ;;
126# - svn - Use svn release (live ebuilds) 309 *) ;;
127# - :SLOT - Use any version in the SLOT specified in the NEED_KDE value. 310 esac
128# - VERSION_NUMBER - Use the minimum KDE4 version specified in the NEED_KDE value. 311 fi
129# - VERSION_NUMBER:SLOT - Use the minimum KDE4 version and the SLOT specified in the NEED_KDE value.
130# - none - Let the ebuild handle SLOT, kde dependencies, KDEDIR, ...
131# @CODE
132#
133# Note: There is no default NEED_KDE for ebuilds not in kde-base or part of
134# koffice, so you must set it explicitly in the ebuild, in all other cases.
135if [[ -z ${NEED_KDE} ]]; then
136 if [[ -n ${KDEBASE} ]]; then
137 NEED_KDE="latest"
138 else
139 die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild"
140 fi 312 fi
141fi 313fi
142export NEED_KDE 314kdedepend="
315 dev-util/automoc
316 dev-util/pkgconfig
317 !aqua? (
318 || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1.0 )
319 x11-proto/xf86vidmodeproto
320 )
321"
322kderdepend=""
143 323
144case ${NEED_KDE} in 324kdehandbookdepend="
145 latest) 325 app-text/docbook-xml-dtd:4.2
146 # Should only be used by 'kde-base'-ebuilds 326 app-text/docbook-xsl-stylesheets
147 if [[ "${KDEBASE}" == "kde-base" ]]; then 327"
148 case ${PV} in 328kdehandbookrdepend="
149 3.9*) _kdedir="3.9" ;; 329 $(add_kdebase_dep kdelibs 'handbook')
150 4*) _kdedir="4.0" ;; 330"
151 *) die "NEED_KDE=latest not supported for PV=${PV}" ;; 331case ${KDE_HANDBOOK} in
152 esac 332 always)
153 _operator=">=" 333 kdedepend+=" ${kdehandbookdepend}"
154 _pv="-${PV}:kde-4" 334 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
155 else
156 _kdedir="4.0"
157 _pv=":kde-4"
158 fi
159 ;; 335 ;;
160 scm|svn|9999*|:kde-svn) 336 optional)
161 _kdedir="svn" 337 IUSE+=" +handbook"
162 _pv=":kde-svn" 338 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
163 export NEED_KDE="svn" 339 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
164 ;; 340 ;;
165 *:kde-svn) 341 *) ;;
166 _kdedir="svn"
167 _operator=">="
168 _pv="-${NEED_KDE}"
169 export NEED_KDE="svn"
170 ;;
171 # The ebuild handles dependencies, KDEDIR, SLOT.
172 none)
173 :
174 ;;
175 # NEED_KDE=":${SLOT}"
176 :kde-4)
177 _kdedir="4.0"
178 _pv="${NEED_KDE}"
179 ;;
180 # NEED_KDE="${PV}:${SLOT}"
181 *:kde-4)
182 _kdedir="4.0"
183 _operator=">="
184 _pv="-${NEED_KDE}"
185 ;;
186 3.9*)
187 _kdedir="3.9"
188 _operator=">="
189 _pv="-${NEED_KDE}:kde-4"
190 ;;
191 4*)
192 _kdedir="4.0"
193 _operator=">="
194 _pv="-${NEED_KDE}:kde-4"
195 ;;
196 *) die "NEED_KDE=${NEED_KDE} currently not supported."
197 ;;
198esac 342esac
343unset kdehandbookdepend kdehandbookrdepend
199 344
200if [[ ${NEED_KDE} != none ]]; then 345case ${KDE_REQUIRED} in
201 KDEDIR="/usr/kde/${_kdedir}" 346 always)
202 KDEDIRS="/usr:/usr/local:${KDEDIR}" 347 IUSE+=" aqua"
348 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
349 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
350 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
351 ;;
352 optional)
353 IUSE+=" aqua kde"
354 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
355 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
356 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
357 ;;
358 *) ;;
359esac
203 360
204 if [[ -n ${KDEBASE} ]]; then 361unset kdecommondepend kdedepend kderdepend
205 if [[ ${NEED_KDE} = svn ]]; then
206 SLOT="kde-svn"
207 else
208 SLOT="kde-4"
209 fi
210 fi
211 362
212 # We only need to add the dependencies if ${PN} is not "kdelibs" or "kdepimlibs" 363debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
213 if [[ ${PN} != "kdelibs" ]]; then 364debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
365debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
366
367# Accumulate dependencies set by this eclass
214 DEPEND="${DEPEND} 368DEPEND+=" ${COMMONDEPEND}"
215 ${_operator}kde-base/kdelibs${_pv}"
216 RDEPEND="${RDEPEND} 369RDEPEND+=" ${COMMONDEPEND}"
217 ${_operator}kde-base/kdelibs${_pv}" 370unset COMMONDEPEND
218 if [[ ${PN} != "kdepimlibs" ]]; then
219 DEPEND="${DEPEND}
220 ${_operator}kde-base/kdepimlibs${_pv}"
221 RDEPEND="${RDEPEND}
222 ${_operator}kde-base/kdepimlibs${_pv}"
223 fi
224 fi
225 371
226 unset _operator _pv _kdedir 372# Add experimental kdeenablefinal, disabled by default
227fi 373IUSE+=" kdeenablefinal"
228 374
229# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 375# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
230# koffice ebuild, the URI should be set in the ebuild itself 376# koffice ebuild, the URI should be set in the ebuild itself
231if [[ -n ${KDEBASE} ]]; then 377case ${BUILD_TYPE} in
378 live)
379 SRC_URI=""
380 if has subversion ${INHERITED}; then
381 # Determine branch URL based on live type
382 local branch_prefix
383 case ${PV} in
384 9999*)
385 # trunk
386 branch_prefix="trunk/KDE"
387 ;;
388 *)
389 # branch
390 branch_prefix="branches/KDE/${SLOT}"
391 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
392 # @DESCRIPTION
393 # Suffix appended to ESVN_PROJECT depending on fetched branch.
394 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
395 ESVN_PROJECT_SUFFIX="-${PV}"
396 ;;
397 esac
398 # @ECLASS-VARIABLE: ESVN_MIRROR
399 # @DESCRIPTION:
400 # This variable allows easy overriding of default kde mirror service
401 # (anonsvn) with anything else you might want to use.
402 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
403 # Split ebuild, or extragear stuff
232 if [[ -n ${KMNAME} ]]; then 404 if [[ -n ${KMNAME} ]]; then
405 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
406 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
407 KMMODULE="${PN}"
408 fi
409 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
410 case ${KMNAME} in
411 kdebase-*)
412 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
413 ;;
414 kdelibs-*)
415 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
416 ;;
417 kdereview*)
418 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
419 ;;
420 kdesupport)
421 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
422 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
423 ;;
424 kde*)
425 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
426 ;;
427 extragear*|playground*)
428 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
429 # build packages from same svn location.
430 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
431 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
432 ;;
433 koffice)
434 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
435 ;;
436 *)
437 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
438 ;;
439 esac
440 else
441 # kdelibs, kdepimlibs
442 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
443 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
444 fi
445 # @ECLASS-VARIABLE: ESVN_UP_FREQ
446 # @DESCRIPTION:
447 # This variable is used for specifying the timeout between svn synces
448 # for kde-base and koffice modules. Does not affect misc apps.
449 # Default value is 1 hour.
450 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
451 elif has git ${INHERITED}; then
452 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
453 KMMODULE="${PN}"
454 fi
455 case ${KDEBASE} in
456 kdevelop)
457 EGIT_REPO_URI="git://gitorious.org/${KMNAME}/${KMMODULE}.git"
458 ;;
459 esac
460 fi
461 ;;
462 *)
463 if [[ -n ${KDEBASE} ]]; then
464 if [[ -n ${KMNAME} ]]; then
465 case ${KMNAME} in
466 kdebase-apps)
467 _kmname="kdebase" ;;
468 *)
233 _kmname=${KMNAME} 469 _kmname="${KMNAME}" ;;
470 esac
471 else
472 _kmname=${PN}
473 fi
474 _kmname_pv="${_kmname}-${PV}"
475 case ${KDEBASE} in
476 kde-base)
477 case ${PV} in
478 4.[456].8[05] | 4.[456].9[023568])
479 # Unstable KDE SC releases
480 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
481 ;;
482 4.4.6 | 4.4.7)
483 # Only kdepim here
484 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
485 ;;
486 *)
487 # Stable KDE SC releases
488 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
489 ;;
490 esac
491 ;;
492 koffice)
493 case ${PV} in
494 2.1.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
495 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
496 esac
497 ;;
498 kdevelop)
499 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
500 ;;
501 esac
502 unset _kmname _kmname_pv
503 fi
504 ;;
505esac
506
507debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
508
509# @ECLASS-VARIABLE: PREFIX
510# @DESCRIPTION:
511# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
512# kde-base packages go into KDE4 installation directory (KDEDIR) by default.
513# No matter the PREFIX, package will be built against KDE installed in KDEDIR.
514
515# @FUNCTION: kde4-base_pkg_setup
516# @DESCRIPTION:
517# Do the basic kdeprefix KDEDIR settings and determine with which kde should
518# optional applications link
519kde4-base_pkg_setup() {
520 debug-print-function ${FUNCNAME} "$@"
521
522 # Prefix compat:
523 if [[ ${EAPI} == 2 ]] && ! use prefix; then
524 EPREFIX=
525 EROOT=${ROOT}
526 fi
527
528 # Append missing trailing slash character
529 [[ ${EROOT} = */ ]] || EROOT+="/"
530
531 # QA ebuilds
532 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
533
534 # Don't set KDEHOME during compilation, it will cause access violations
535 unset KDEHOME
536
537 if [[ ${KDEBASE} = kde-base ]]; then
538 if use kdeprefix; then
539 KDEDIR=/usr/kde/${SLOT}
540 else
541 KDEDIR=/usr
542 fi
543 : ${PREFIX:=${KDEDIR}}
234 else 544 else
235 _kmname=${PN} 545 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
546 KDEDIR=
547 local kde_minimal_met
548 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
549 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
550 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
551 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
552 KDEDIR=/usr/kde/${slot}
553 else
554 KDEDIR=/usr
555 fi
556 break;
557 fi
558 done
559 unset slot
560
561 # Bail out if kdelibs required but not found
562 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
563 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
564 else
565 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
236 fi 566 fi
237 _kmname_pv="${_kmname}-${PV}" 567
238 if [[ ${NEED_KDE} != "svn" ]]; then 568 : ${PREFIX:=/usr}
239 case ${KDEBASE} in 569 fi
240 kde-base) 570 EKDEDIR=${EPREFIX}${KDEDIR}
571
572 # Point pkg-config path to KDE *.pc files
573 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
574 # Point to correct QT plugins path
575 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
576
577 # Fix XDG collision with sandbox
578 export XDG_CONFIG_HOME="${T}"
579}
580
581# @FUNCTION: kde4-base_src_unpack
582# @DESCRIPTION:
583# This function unpacks the source tarballs for KDE4 applications.
584kde4-base_src_unpack() {
585 debug-print-function ${FUNCNAME} "$@"
586
587 if [[ ${BUILD_TYPE} = live ]]; then
588 if has subversion ${INHERITED}; then
589 migrate_store_dir
590 subversion_src_unpack
591 elif has git ${INHERITED}; then
592 git_src_unpack
593 fi
594 elif [[ ${EAPI} == 2 ]]; then
595 local file
596 for file in ${A}; do
597 # This setup is because EAPI <= 2 cannot unpack *.tar.xz files
598 # directly, so we do it ourselves (using the exact same code as portage)
241 case ${PV} in 599 case ${file} in
242 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2";; 600 *.tar.xz)
601 echo ">>> Unpacking ${file} to ${PWD}"
602 xz -dc "${DISTDIR}"/${file} | tar xof -
603 assert "failed unpacking ${file}"
604 ;;
605 *)
606 unpack ${file}
607 ;;
243 esac 608 esac
244 ;;
245 koffice)
246 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2"
247 ;;
248 esac
249 fi
250 unset _kmname _kmname_pv
251fi
252
253debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
254debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - before blockers"
255
256# Monolithic ebuilds should add blockers for split ebuilds in the same slot.
257# If KMNAME is not set then this is not a split package
258if [[ -n ${KDEBASE} && -z ${KMNAME} ]]; then
259 for _x in $(get-child-packages ${CATEGORY}/${PN}); do
260 DEPEND="${DEPEND} !${_x}:${SLOT}"
261 RDEPEND="${RDEPEND} !${_x}:${SLOT}"
262 done 609 done
263 unset _x
264fi
265
266debug-print "${BASH_SOURCE} ${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - after blockers"
267
268# @ECLASS-VARIABLE: PREFIX
269# @DESCRIPTION:
270# Set the installation PREFIX. All kde-base ebuilds go into the KDE4 installation directory.
271# Applications installed by the other ebuilds go into /usr/ by default, this value
272# can be superseded by defining PREFIX before inheriting kde4-base.
273if [[ -n ${KDEBASE} ]]; then
274 PREFIX=${KDEDIR}
275else
276 # if PREFIX is not defined we set it to the default value of /usr
277 PREFIX="${PREFIX:-/usr}"
278fi
279
280debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SLOT ${SLOT} - KDEDIR ${KDEDIR} - KDEDIRS ${KDEDIRS}- PREFIX ${PREFIX} - NEED_KDE ${NEED_KDE}"
281
282# @FUNCTION: kde4-base_pkg_setup
283# @DESCRIPTION:
284# Adds flags needed by all of KDE 4 to $QT4_BUILT_WITH_USE_CHECK. Uses
285# kde4-functions_check_use from kde4-functions.eclass to print appropriate
286# errors and die if any required flags listed in $QT4_BUILT_WITH_USE_CHECK or
287# $KDE4_BUILT_WITH_USE_CHECK are missing.
288kde4-base_pkg_setup() {
289 debug-print-function $FUNCNAME "$@"
290
291 case "${EAPI}" in
292 kdebuild-1)
293 [[ -n ${QT4_BUILT_WITH_USE_CHECK} || -n ${KDE4_BUILT_WITH_USE_CHECK} ]] && \
294 die "built_with_use illegal in this EAPI!"
295 ;;
296 *)
297 # KDE4 applications require qt4 compiled with USE="accessibility dbus gif jpeg png qt3support ssl zlib".
298 if has_version '<x11-libs/qt-4.4_alpha:4'; then
299 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} accessibility dbus gif jpeg png qt3support ssl zlib"
300 else 610 else
301 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 611 # For EAPI >= 3, we can just use unpack() directly
302 x11-libs/qt-core qt3support ssl 612 unpack ${A}
303 x11-libs/qt-gui accessibility dbus
304 x11-libs/qt-qt3support accessibility"
305 fi 613 fi
306
307 if has debug ${IUSE//+} && use debug; then
308 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
309 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} debug"
310 else
311 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
312 x11-libs/qt-core:4 debug
313 x11-libs/qt-gui:4 debug
314 x11-libs/qt-qt3support:4 debug
315 x11-libs/qt-svg:4 debug
316 x11-libs/qt-test:4 debug"
317 if has opengl ${IUSE//+} && use opengl || [[ ${OPENGL_REQUIRED} == always ]]; then
318 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
319 x11-libs/qt-opengl:4 debug"
320 fi
321 fi
322 fi
323
324 if has opengl ${IUSE//+} && use opengl || [[ ${OPENGL_REQUIRED} == always ]]; then
325 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
326 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
327 fi
328 fi
329 kde4-functions_check_use
330 ;;
331 esac
332} 614}
333 615
334# @FUNCTION: kde4-base_apply_patches
335# @DESCRIPTION:
336# This function applies patches.
337#
338# If the directory ${WORKDIR}/patches/ exists, we apply all patches in that
339# directory, provided they follow this format:
340# @CODE
341# - Monolithic ebuilds, (from kde-base)
342# - $CATEGORY=kde-base:
343# Apply ${CHILD_EBUILD_NAME}-${SLOT}-*{diff,patch}
344# - $CATEGORY=!kde-base:
345# Apply ${CHILD_EBUILD_NAME}-${PV}-*{diff,patch}
346# - Split ebuilds:
347# - $CATEGORY=kde-base:
348# Apply ${PN}-${SLOT}-*{diff,patch}
349# - $CATEGORY!=kde-base:
350# Apply ${PN}-${PV}-*{diff,patch}
351# @CODE
352#
353# If ${PATCHES} is non-zero all patches in it get applied. If there is more
354# than one patch please make ${PATCHES} an array for proper quoting.
355kde4-base_apply_patches() {
356 local _patchdir _packages _p
357 _patchdir="${WORKDIR}/patches/"
358 if [[ -d "${_patchdir}" ]]; then
359 if is-parent-package ${CATEGORY}/${PN} ; then
360 _packages="$(get-child-packages ${CATEGORY}/${PN})"
361 _packages="${_packages//${CATEGORY}\//} ${PN}"
362 else
363 _packages="${PN}"
364 fi
365 if [[ ${#PATCHES[@]} -gt 1 ]]; then
366 for _p in ${_packages}; do
367 PATCHES=( "${PATCHES[@]}" $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null) )
368 if [[ -n "${KDEBASE}" ]]; then
369 PATCHES=( "${PATCHES[@]}" $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null) )
370 fi
371 done
372 else
373 for _p in ${_packages}; do
374 PATCHES=(${PATCHES} $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null))
375 if [[ -n "${KDEBASE}" ]]; then
376 PATCHES=(${PATCHES} $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null))
377 fi
378 done
379 fi
380 fi
381 [[ -n ${PATCHES[@]} ]] && base_src_unpack autopatch
382}
383
384# @FUNCTION: kde4-base_src_unpack 616# @FUNCTION: kde4-base_src_prepare
385# @DESCRIPTION: 617# @DESCRIPTION:
386# This function unpacks the source tarballs for KDE4 applications. 618# General pre-configure and pre-compile function for KDE4 applications.
387#
388# If no argument is passed to this function, then standard src_unpack is
389# executed. Otherwise options are passed to base_src_unpack.
390#
391# In addition it calls kde4-base_apply_patches when no arguments are passed to
392# this function.
393#
394# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and 619# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
620# enable_selected_linguas() and enable_selected_doc_linguas()
395# enable_selected_linguas() in kde4-functions.eclass(5) for further details. 621# in kde4-functions.eclass(5) for further details.
396kde4-base_src_unpack() { 622kde4-base_src_prepare() {
397 debug-print-function $FUNCNAME "$@" 623 debug-print-function ${FUNCNAME} "$@"
398
399 [[ -z "${KDE_S}" ]] && KDE_S="${S}"
400
401 if [[ -z $* ]]; then
402 # Unpack first and deal with KDE patches after examing possible patch sets.
403 # To be picked up, patches need to conform to the guidelines stated before.
404 # Monolithic ebuilds will use the split ebuild patches.
405 [[ -d "${KDE_S}" ]] || unpack ${A}
406 kde4-base_apply_patches
407 else
408 # Call base_src_unpack, which unpacks and patches
409 # step by step transparently as defined in the ebuild.
410 base_src_unpack $*
411 fi
412
413 # Updated cmake dir
414 if [[ -d "${WORKDIR}/cmake" ]] && [[ -d "${KDE_S}/cmake" ]]; then
415 ebegin "Updating cmake/ directory..."
416 rm -rf "${KDE_S}/cmake" || die "Unable to remove old cmake/ directory"
417 ln -s "${WORKDIR}/cmake" "${KDE_S}/cmake" || die "Unable to symlink the new cmake/ directory"
418 eend 0
419 fi
420 624
421 # Only enable selected languages, used for KDE extragear apps. 625 # Only enable selected languages, used for KDE extragear apps.
422 if [[ -n ${KDE_LINGUAS} ]]; then 626 if [[ -n ${KDE_LINGUAS} ]]; then
423 enable_selected_linguas 627 enable_selected_linguas
424 fi 628 fi
629
630 # Enable/disable handbooks for kde4-base packages
631 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
632 # kdelibs inherits kde4-base but handle installing the handbook itself
633 if ! has kde4-meta ${INHERITED}; then
634 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas
635 fi
636
637 # SCM bootstrap
638 if [[ ${BUILD_TYPE} = live ]]; then
639 if has subversion ${INHERITED}; then
640 subversion_src_prepare
641 elif has git ${INHERITED}; then
642 git_src_prepare
643 fi
644 fi
645
646 # Apply patches
647 base_src_prepare
648
649 # Save library dependencies
650 if [[ -n ${KMSAVELIBS} ]] ; then
651 save_library_dependencies
652 fi
653
654 # Inject library dependencies
655 if [[ -n ${KMLOADLIBS} ]] ; then
656 load_library_dependencies
657 fi
658
659 # Hack for manuals relying on outdated DTD
660 find "${S}" -name "*.docbook" \
661 -exec sed -i -r \
662 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
663 || die 'failed to fix DocBook variant version'
664}
665
666# @FUNCTION: kde4-base_src_configure
667# @DESCRIPTION:
668# Function for configuring the build of KDE4 applications.
669kde4-base_src_configure() {
670 debug-print-function ${FUNCNAME} "$@"
671
672 # Build tests in src_test only, where we override this value
673 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
674
675 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
676 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
677 fi
678
679 if has debug ${IUSE//+} && use debug; then
680 # Set "real" debug mode
681 CMAKE_BUILD_TYPE="Debugfull"
682 else
683 # Handle common release builds
684 append-cppflags -DQT_NO_DEBUG
685 fi
686
687 # Set distribution name
688 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
689
690 # Here we set the install prefix
691 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
692
693 # Use colors
694 QTEST_COLORED=1
695
696 # Shadow existing /usr installations
697 unset KDEDIRS
698
699 # Handle kdeprefix-ed KDE
700 if [[ ${KDEDIR} != /usr ]]; then
701 # Override some environment variables - only when kdeprefix is different,
702 # to not break ccache/distcc
703 PATH="${EKDEDIR}/bin:${PATH}"
704
705 # Append library search path
706 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
707
708 # Append full RPATH
709 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
710
711 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
712 # when more are present
713 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
714 fi
715
716 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
717 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4)
718 #kde-config -path data unavailable when cross-compiling
719 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
720
721 # Handle kdeprefix in application itself
722 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
723 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
724 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
725 fi
726
727 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
728 mycmakeargs=(${mycmakeargs})
729 fi
730
731 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
732
733 cmake-utils_src_configure
425} 734}
426 735
427# @FUNCTION: kde4-base_src_compile 736# @FUNCTION: kde4-base_src_compile
428# @DESCRIPTION: 737# @DESCRIPTION:
429# General function for compiling KDE4 applications. 738# General function for compiling KDE4 applications.
430kde4-base_src_compile() { 739kde4-base_src_compile() {
431 debug-print-function ${FUNCNAME} "$@" 740 debug-print-function ${FUNCNAME} "$@"
432 741
433 kde4-base_src_configure
434 kde4-base_src_make
435}
436
437# @FUNCTION: kde4-base_src_configure
438# @DESCRIPTION:
439# Function for configuring the build of KDE4 applications.
440kde4-base_src_configure() {
441 debug-print-function ${FUNCNAME} "$@"
442
443 # Final flag handling
444 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
445 echo "Activating enable-final flag"
446 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_FINAL=ON"
447 fi
448
449 # Enable generation of HTML handbook
450 if has htmlhandbook ${IUSE//+} && use htmlhandbook; then
451 echo "Enabling building of HTML handbook"
452 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_HTMLHANDBOOK=ON"
453 fi
454
455 # Build tests in src_test only, where we override this value
456 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=OFF"
457
458 # Set distribution name
459 [[ ${PN} == "kdelibs" ]] && mycmakeargs="${mycmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo"
460
461 # runpath linking
462 mycmakeargs="${mycmakeargs} -DKDE4_USE_ALWAYS_FULL_RPATH=ON"
463
464 # Here we set the install prefix
465 mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}"
466
467 # Set environment
468 QTEST_COLORED=1
469 QT_PLUGIN_PATH=${KDEDIR}/$(get_libdir)/kde4/plugins/
470
471 cmake-utils_src_configureout
472}
473
474# @FUNCTION: kde4-base_src_make
475# @DESCRIPTION:
476# Function for building KDE4 applications.
477# Options are passed to cmake-utils_src_make.
478kde4-base_src_make() {
479 debug-print-function ${FUNCNAME} "$@"
480
481 cmake-utils_src_make "$@" 742 cmake-utils_src_compile "$@"
482} 743}
483 744
484# @FUNCTION: kde4-base_src_test 745# @FUNCTION: kde4-base_src_test
485# @DESCRIPTION: 746# @DESCRIPTION:
486# Function for testing KDE4 applications. 747# Function for testing KDE4 applications.
487kde4-base_src_test() { 748kde4-base_src_test() {
488 debug-print-function ${FUNCNAME} "$@" 749 debug-print-function ${FUNCNAME} "$@"
489 750
490 # Override this value, set in kde4-base_src_configure() 751 # Override this value, set in kde4-base_src_configure()
491 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON" 752 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
492 cmake-utils_src_compile 753 cmake-utils_src_configure
754 kde4-base_src_compile
493 755
494 cmake-utils_src_test 756 cmake-utils_src_test
495} 757}
496 758
497# @FUNCTION: kde4-base_src_install 759# @FUNCTION: kde4-base_src_install
498# @DESCRIPTION: 760# @DESCRIPTION:
499# Function for installing KDE4 applications. 761# Function for installing KDE4 applications.
500kde4-base_src_install() { 762kde4-base_src_install() {
501 debug-print-function ${FUNCNAME} "$@" 763 debug-print-function ${FUNCNAME} "$@"
502 764
503 kde4-base_src_make_doc 765 # Prefix support, for usage in ebuilds
766 if [[ ${EAPI} == 2 ]] && ! use prefix; then
767 ED=${D}
768 fi
769
770 if [[ -n ${KMSAVELIBS} ]] ; then
771 install_library_dependencies
772 fi
773
774 # Install common documentation of KDE4 applications
775 local doc
776 if ! has kde4-meta ${INHERITED}; then
777 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
778 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && dodoc "${doc}"
779 done
780 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
781 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
782 done
783 fi
784
504 cmake-utils_src_install 785 cmake-utils_src_install
505} 786}
506 787
507# @FUNCTION: kde4-base_src_make_doc
508# @DESCRIPTION:
509# Function for installing the documentation of KDE4 applications.
510kde4-base_src_make_doc() {
511 debug-print-function ${FUNCNAME} "$@"
512
513 local doc
514 for doc in AUTHORS ChangeLog* README* NEWS TODO; do
515 [[ -s $doc ]] && dodoc ${doc}
516 done
517
518 if [[ -z ${KMNAME} ]]; then
519 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
520 if [[ -s $doc ]]; then
521 local doc_complete=${doc}
522 doc="${doc#*/}"
523 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
524 fi
525 done
526 fi
527
528 if [[ -n ${KDEBASE} && -d "${D}"/usr/share/doc/${PF} ]]; then
529 # work around bug #97196
530 dodir /usr/share/doc/kde && \
531 mv "${D}"/usr/share/doc/${PF} "${D}"/usr/share/doc/kde/ || \
532 die "Failed to move docs to kde/ failed."
533 fi
534}
535
536# @FUNCTION: kde4-base_pkg_postinst 788# @FUNCTION: kde4-base_pkg_postinst
537# @DESCRIPTION: 789# @DESCRIPTION:
538# Function to rebuild the KDE System Configuration Cache after an application has been installed. 790# Function to rebuild the KDE System Configuration Cache after an application has been installed.
539kde4-base_pkg_postinst() { 791kde4-base_pkg_postinst() {
792 debug-print-function ${FUNCNAME} "$@"
793
794 buildsycoca
795
796 if [[ ${BUILD_TYPE} = live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
797 echo
798 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
799 einfo "Use it at your own risk."
800 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
801 echo
802 elif [[ ${BUILD_TYPE} != live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && has kdeprefix ${IUSE//+} && use kdeprefix; then
803 # warning about kdeprefix for non-live users
804 echo
805 ewarn "WARNING! You have the kdeprefix useflag enabled."
806 ewarn "This setting is strongly discouraged and might lead to potential trouble"
807 ewarn "with KDE update strategies."
808 ewarn "You are using this setup at your own risk and the kde team does not"
809 ewarn "take responsibilities for dead kittens."
810 echo
811 fi
812 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && ! has_version 'kde-base/kdebase-runtime-meta' && ! has_version 'kde-base/kdebase-startkde'; then
813 # warn about not supported approach
814 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
815 echo
816 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
817 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
818 ewarn "With this setting you are unsupported by KDE team."
819 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
820 fi
821 fi
822}
823
824# @FUNCTION: kde4-base_pkg_postrm
825# @DESCRIPTION:
826# Function to rebuild the KDE System Configuration Cache after an application has been removed.
827kde4-base_pkg_postrm() {
828 debug-print-function ${FUNCNAME} "$@"
829
540 buildsycoca 830 buildsycoca
541} 831}
542
543# @FUNCTION: kde4-base_pkg_postrm
544# @DESCRIPTION:
545# Function to rebuild the KDE System Configuration Cache after an application has been removed.
546kde4-base_pkg_postrm() {
547 buildsycoca
548}

Legend:
Removed from v.1.9  
changed lines
  Added in v.1.76

  ViewVC Help
Powered by ViewVC 1.1.20