/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.5 Revision 1.79
1# Copyright 2007-2008 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.5 2008/03/14 15:51:50 ingmar Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.79 2010/12/06 10:17:04 tampakrap Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.0 ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The kde4-base.eclass provides support for building KDE4 monolithic ebuilds 10# The kde4-base.eclass provides support for building KDE4 based ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: This eclass uses the SLOT dependencies from EAPI="1" or compatible, 13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but
14# hence you must define EAPI="1" in the ebuild, before inheriting any eclasses. 14# eclass will fail with version older than 2.
15 15
16inherit base eutils multilib cmake-utils kde4-functions 16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION:
18# Do we need an X server? Valid values are "always", "optional", and "manual".
19# "tests" is a synonym for "optional". While virtualx.eclass supports in principle
20# also the use of an X server during other ebuild phases, we only use it in
21# src_test here. Most likely you'll want to set "optional", which introduces the
22# use-flag "test" (if not already present), adds dependencies conditional on that
23# use-flag, and automatically runs (only) the ebuild test phase with a virtual X server
24# present. This makes things a lot more comfortable than the bare virtualx eclass.
17 25
26# In case the variable is not set in the ebuild, let virtualx eclass not do anything
27: ${VIRTUALX_REQUIRED:=manual}
28
29inherit kde4-functions base virtualx eutils
30
31get_build_type
32if [[ ${BUILD_TYPE} = live ]]; then
33 if [[ ${KDEBASE} = kdevelop ]]; then
34 inherit git
35 else
36 inherit subversion
37 fi
38fi
39
40# @ECLASS-VARIABLE: CMAKE_REQUIRED
41# @DESCRIPTION:
42# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
43# Please note that if it's set to 'never' you need to explicitly override following phases:
44# src_configure, src_compile, src_test and src_install.
45# Defaults to 'always'.
46: ${CMAKE_REQUIRED:=always}
47if [[ ${CMAKE_REQUIRED} = always ]]; then
48 buildsystem_eclass="cmake-utils"
49 export_fns="src_configure src_compile src_test src_install"
50fi
51
52# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
53if [[ -n ${KDE_MINIMAL} ]]; then
54 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
55 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
56 done
57 unset slot
58 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
59else
60 KDE_MINIMAL_VALID=1
61fi
62
63# @ECLASS-VARIABLE: KDE_MINIMAL
64# @DESCRIPTION:
65# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
66# version for apps to work. Currently defaults to 4.4
67# One may override this variable to raise version requirements.
68# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
69# Note that it is fixed to ${SLOT} for kde-base packages.
70KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
71
72# Set slot for packages in kde-base, koffice and kdevelop
73case ${KDEBASE} in
74 kde-base)
75 # Determine SLOT from PVs
76 case ${PV} in
77 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
78 4.6* | 4.5.[6-9][0-9]*) SLOT="4.6" ;;
79 4.5* | 4.4.[6-9][0-9]*) SLOT="4.5" ;;
80 4.4* | 4.3.[6-9][0-9]*) SLOT="4.4" ;;
81 9999*) SLOT="live" ;; # regular live
82 *) die "Unsupported ${PV}" ;;
83 esac
84 KDE_MINIMAL="${SLOT}"
85 ;;
86 koffice)
87 SLOT="2"
88 ;;
89 kdevelop)
90 if [[ ${BUILD_TYPE} = live ]]; then
91 # @ECLASS-VARIABLE: KDEVELOP_VERSION
92 # @DESCRIPTION:
93 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
94 # Applies to KDEBASE=kdevelop only.
95 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
96 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
97 # @DESCRIPTION:
98 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
99 # Applies to KDEBASE=kdevelop only.
100 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
101 else
102 case ${PN} in
103 kdevelop|quanta)
104 KDEVELOP_VERSION=${PV}
105 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
106 ;;
107 kdevplatform)
108 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
109 KDEVPLATFORM_VERSION=${PV}
110 ;;
111 *)
112 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
113 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
114 esac
115 fi
116 SLOT="4"
117 ;;
118esac
119
120slot_is_at_least 4.5 ${KDE_MINIMAL} && CMAKE_MIN_VERSION="2.8.1"
121
122inherit ${buildsystem_eclass}
123
18EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_test src_install pkg_postinst pkg_postrm 124EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm
19 125
20COMMONDEPEND="|| ( ( 126unset buildsystem_eclass
21 x11-libs/qt-core:4 127unset export_fns
22 x11-libs/qt-gui:4 128
23 x11-libs/qt-qt3support:4 129# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
24 x11-libs/qt-svg:4 130# @DESCRIPTION:
25 x11-libs/qt-test:4 ) 131# Is qt-declarative required? Possible values are 'always', 'optional' and 'never'.
26 >=x11-libs/qt-4.3.3:4 )" 132# This variable must be set before inheriting any eclasses. Defaults to 'never'.
133DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
134
135# @ECLASS-VARIABLE: QTHELP_REQUIRED
136# @DESCRIPTION:
137# Is qt-assistant required? Possible values are 'always', 'optional' and 'never'.
138# This variable must be set before inheriting any eclasses. Defaults to 'never'.
139QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
27 140
28# @ECLASS-VARIABLE: OPENGL_REQUIRED 141# @ECLASS-VARIABLE: OPENGL_REQUIRED
29# @DESCRIPTION: 142# @DESCRIPTION:
30# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'. 143# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
31# This variable must be set before inheriting any eclasses. Defaults to 'never'. 144# This variable must be set before inheriting any eclasses. Defaults to 'never'.
32OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}" 145OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
33 146
34OPENGLDEPEND="|| ( x11-libs/qt-opengl:4 147# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
35 >=x11-libs/qt-4.3.3:4 )" 148# @DESCRIPTION:
36case "${OPENGL_REQUIRED}" in 149# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
37 always) 150# This variable must be set before inheriting any eclasses. Defaults to 'never'.
38 COMMONDEPEND="${COMMONDEPEND} 151MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
39 ${OPENGLDEPEND}"
40 ;;
41 optional)
42 IUSE="${IUSE} opengl"
43 COMMONDEPEND="${COMMONDEPEND}
44 opengl? ( ${OPENGLDEPEND} )"
45 ;;
46 *)
47 OPENGL_REQUIRED="never"
48 ;;
49esac
50 152
51DEPEND="${DEPEND} ${COMMONDEPEND} 153# @ECLASS-VARIABLE: WEBKIT_REQUIRED
52 >=dev-util/cmake-2.4.7-r1 154# @DESCRIPTION:
53 dev-util/pkgconfig 155# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
54 x11-libs/libXt 156# This variable must be set before inheriting any eclasses. Defaults to 'never'.
55 x11-proto/xf86vidmodeproto" 157WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
56RDEPEND="${RDEPEND} ${COMMONDEPEND}"
57 158
58# @ECLASS-VARIABLE: CPPUNIT_REQUIRED 159# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
59# @DESCRIPTION: 160# @DESCRIPTION:
60# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'. 161# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
61# This variable must be set before inheriting any eclasses. Defaults to 'never'. 162# This variable must be set before inheriting any eclasses. Defaults to 'never'.
62CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}" 163CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
63 164
64case "${CPPUNIT_REQUIRED}" in 165# @ECLASS-VARIABLE: KDE_REQUIRED
166# @DESCRIPTION:
167# Is kde required? Possible values are 'always', 'optional' and 'never'.
168# This variable must be set before inheriting any eclasses. Defaults to 'always'
169# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
170# Note that for kde-base packages this variable is fixed to 'always'.
171KDE_REQUIRED="${KDE_REQUIRED:-always}"
172
173# @ECLASS-VARIABLE: KDE_HANDBOOK
174# @DESCRIPTION:
175# Set to enable handbook in application. Possible values are 'always', 'optional'
176# (handbook USE flag) and 'never'.
177# This variable must be set before inheriting any eclasses. Defaults to 'never'.
178# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
179# ensures buildtime and runtime dependencies.
180KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
181
182# Setup packages inheriting this eclass
183case ${KDEBASE} in
184 kde-base)
185 HOMEPAGE="http://www.kde.org/"
186 LICENSE="GPL-2"
187 if [[ $BUILD_TYPE = live ]]; then
188 # Disable tests for live ebuilds
189 RESTRICT+=" test"
190 # Live ebuilds in kde-base default to kdeprefix by default
191 IUSE+=" +kdeprefix"
192 else
193 # All other ebuild types default to -kdeprefix as before
194 IUSE+=" kdeprefix"
195 fi
196 # This code is to prevent portage from searching GENTOO_MIRRORS for
197 # packages that will never be mirrored. (As they only will ever be in
198 # the overlay).
199 case ${PV} in
200 *9999* | 4.?.[6-9]?)
201 RESTRICT+=" mirror"
202 ;;
203 esac
204 # Block installation of other SLOTS unless kdeprefix
205 RDEPEND+=" $(block_other_slots)"
206 ;;
207 koffice)
208 HOMEPAGE="http://www.koffice.org/"
209 LICENSE="GPL-2"
210 ;;
211 kdevelop)
212 HOMEPAGE="http://www.kdevelop.org/"
213 LICENSE="GPL-2"
214 ;;
215esac
216
217# @ECLASS-VARIABLE: QT_MINIMAL
218# @DESCRIPTION:
219# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1...
220# 4.6.0 for 4.4, 4.6.3 for 4.5, and 4.7.0 for 4.6 and later
221if slot_is_at_least 4.6 "${KDE_MINIMAL}"; then
222 QT_MINIMAL="${QT_MINIMAL:-4.7.0}"
223elif slot_is_at_least 4.5 "${KDE_MINIMAL}"; then
224 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
225else
226 QT_MINIMAL="${QT_MINIMAL:-4.6.0}"
227fi
228
229# Declarative dependencies
230qtdeclarativedepend="
231 >=x11-libs/qt-declarative-${QT_MINIMAL}:4
232"
233case ${DECLARATIVE_REQUIRED} in
65 always) 234 always)
66 DEPEND="${DEPEND} dev-util/cppunit" 235 COMMONDEPEND+=" ${qtdeclarativedepend}"
67 ;; 236 ;;
68 optional) 237 optional)
69 IUSE="${IUSE} test" 238 IUSE+=" declarative"
70 DEPEND="${DEPEND} 239 COMMONDEPEND+=" declarative? ( ${qtdeclarativedepend} )"
71 test? ( dev-util/cppunit )"
72 ;; 240 ;;
73 *) 241 *) ;;
74 CPPUNIT_REQUIRED="never" 242esac
243unset qtdeclarativedepend
244
245# QtHelp dependencies
246qthelpdepend="
247 >=x11-libs/qt-assistant-${QT_MINIMAL}:4
248"
249case ${QTHELP_REQUIRED} in
250 always)
251 COMMONDEPEND+=" ${qthelpdepend}"
75 ;; 252 ;;
253 optional)
254 IUSE+=" qthelp"
255 COMMONDEPEND+=" qthelp? ( ${qthelpdepend} )"
256 ;;
76esac 257esac
258unset qthelpdepend
77 259
78# @ECLASS-VARIABLE: NEED_KDE 260# OpenGL dependencies
261qtopengldepend="
262 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
263"
264case ${OPENGL_REQUIRED} in
265 always)
266 COMMONDEPEND+=" ${qtopengldepend}"
267 ;;
268 optional)
269 IUSE+=" opengl"
270 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
271 ;;
272 *) ;;
273esac
274unset qtopengldepend
275
276# MultiMedia dependencies
277qtmultimediadepend="
278 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
279"
280case ${MULTIMEDIA_REQUIRED} in
281 always)
282 COMMONDEPEND+=" ${qtmultimediadepend}"
283 ;;
284 optional)
285 IUSE+=" multimedia"
286 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
287 ;;
288 *) ;;
289esac
290unset qtmultimediadepend
291
292# WebKit dependencies
293case ${KDE_REQUIRED} in
294 always)
295 qtwebkitusedeps="[kde]"
296 ;;
297 optional)
298 qtwebkitusedeps="[kde?]"
299 ;;
300 *) ;;
301esac
302qtwebkitdepend="
303 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
304"
305unset qtwebkitusedeps
306case ${WEBKIT_REQUIRED} in
307 always)
308 COMMONDEPEND+=" ${qtwebkitdepend}"
309 ;;
310 optional)
311 IUSE+=" webkit"
312 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
313 ;;
314 *) ;;
315esac
316unset qtwebkitdepend
317
318# CppUnit dependencies
319cppuintdepend="
320 dev-util/cppunit
321"
322case ${CPPUNIT_REQUIRED} in
323 always)
324 DEPEND+=" ${cppuintdepend}"
325 ;;
326 optional)
327 IUSE+=" test"
328 DEPEND+=" test? ( ${cppuintdepend} )"
329 ;;
330 *) ;;
331esac
332unset cppuintdepend
333
334# KDE dependencies
335# Qt accessibility classes are needed in various places, bug 325461
336kdecommondepend="
337 dev-lang/perl
338 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
339 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
340 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
341 >=x11-libs/qt-script-${QT_MINIMAL}:4
342 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
343 >=x11-libs/qt-svg-${QT_MINIMAL}:4
344 >=x11-libs/qt-test-${QT_MINIMAL}:4
345 !aqua? (
346 x11-libs/libXext
347 x11-libs/libXt
348 x11-libs/libXxf86vm
349 )
350"
351
352if [[ ${PN} != kdelibs ]]; then
353 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
354 if [[ ${KDEBASE} = kdevelop ]]; then
355 if [[ ${PN} != kdevplatform ]]; then
356 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
79# @DESCRIPTION: 357 # @DESCRIPTION:
80# This variable sets the version of KDE4 which will be used by the eclass. 358 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
81# This variable must be set by the ebuild, for all categories except for "kde-base". 359 # Applies to KDEBASE=kdevelop only.
82# For kde-base packages, if it is not set by the ebuild, 360 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
83# it's assumed that the required KDE4 version is the latest, non-live, available. 361 case ${KDEVPLATFORM_REQUIRED} in
84# 362 always)
85# @CODE 363 kdecommondepend+="
86# Acceptable values are: 364 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
87# - latest - Use latest version in the portage tree 365 "
88# Default for kde-base ebuilds. Banned for ebuilds not part of kde or koffice. 366 ;;
89# - svn - Use svn release (live ebuilds) 367 *) ;;
90# - :SLOT - Use any version in the SLOT specified in the NEED_KDE value. 368 esac
91# - VERSION_NUMBER - Use the minimum KDE4 version specified in the NEED_KDE value. 369 fi
92# - VERSION_NUMBER:SLOT - Use the minimum KDE4 version and the SLOT specified in the NEED_KDE value.
93# - none - Let the ebuild handle SLOT, kde dependencies, KDEDIR, ...
94# @CODE
95#
96# Note: There is no default NEED_KDE for ebuilds not in kde-base or part of
97# koffice, so you must set it explicitly in the ebuild, in all other cases.
98if [[ -z ${NEED_KDE} ]]; then
99 if [[ -n ${KDEBASE} ]]; then
100 NEED_KDE="latest"
101 else
102 die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild"
103 fi 370 fi
104fi 371fi
105export NEED_KDE 372kdedepend="
373 dev-util/automoc
374 dev-util/pkgconfig
375 !aqua? (
376 || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1.0 )
377 x11-proto/xf86vidmodeproto
378 )
379"
380kderdepend=""
106 381
107case ${NEED_KDE} in 382kdehandbookdepend="
108 latest) 383 app-text/docbook-xml-dtd:4.2
109 # Should only be used by 'kde-base'-ebuilds 384 app-text/docbook-xsl-stylesheets
110 if [[ "${KDEBASE}" == "kde-base" ]]; then 385"
111 case ${PV} in 386kdehandbookrdepend="
112 3.9*) _kdedir="3.9" ;; 387 $(add_kdebase_dep kdelibs 'handbook')
113 4*) _kdedir="4.0" ;; 388"
114 *) die "NEED_KDE=latest not supported for PV=${PV}" ;; 389case ${KDE_HANDBOOK} in
115 esac 390 always)
116 _operator=">=" 391 kdedepend+=" ${kdehandbookdepend}"
117 _pv="-${PV}:kde-4" 392 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
118 else
119 _kdedir="4.0"
120 _pv=":kde-4"
121 fi
122 ;; 393 ;;
123 svn|9999*|:kde-svn) 394 optional)
124 _kdedir="svn" 395 IUSE+=" +handbook"
125 _pv=":kde-svn" 396 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
126 export NEED_KDE="svn" 397 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
127 ;; 398 ;;
128 *:kde-svn) 399 *) ;;
129 _kdedir="svn"
130 _operator=">="
131 _pv="-${NEED_KDE}"
132 export NEED_KDE="svn"
133 ;;
134 # The ebuild handles dependencies, KDEDIR, SLOT.
135 none)
136 :
137 ;;
138 # NEED_KDE=":${SLOT}"
139 :kde-4)
140 _kdedir="4.0"
141 _pv="${NEED_KDE}"
142 ;;
143 # NEED_KDE="${PV}:${SLOT}"
144 *:kde-4)
145 _kdedir="4.0"
146 _operator=">="
147 _pv="-${NEED_KDE}"
148 ;;
149 3.9*)
150 _kdedir="3.9"
151 _operator=">="
152 _pv="-${NEED_KDE}:kde-4"
153 ;;
154 4*)
155 _kdedir="4.0"
156 _operator=">="
157 _pv="-${NEED_KDE}:kde-4"
158 ;;
159 *) die "NEED_KDE=${NEED_KDE} currently not supported."
160 ;;
161esac 400esac
401unset kdehandbookdepend kdehandbookrdepend
162 402
163if [[ ${NEED_KDE} != none ]]; then 403case ${KDE_REQUIRED} in
164 KDEDIR="/usr/kde/${_kdedir}" 404 always)
165 KDEDIRS="/usr:/usr/local:${KDEDIR}" 405 IUSE+=" aqua"
406 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
407 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
408 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
409 ;;
410 optional)
411 IUSE+=" aqua kde"
412 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
413 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
414 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
415 ;;
416 *) ;;
417esac
166 418
167 if [[ -n ${KDEBASE} ]]; then 419unset kdecommondepend kdedepend kderdepend
168 if [[ ${NEED_KDE} = svn ]]; then
169 SLOT="kde-svn"
170 else
171 SLOT="kde-4"
172 fi
173 fi
174 420
175 # We only need to add the dependencies if ${PN} is not "kdelibs" or "kdepimlibs" 421debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
176 if [[ ${PN} != "kdelibs" ]]; then 422debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
423debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
424
425# Accumulate dependencies set by this eclass
177 DEPEND="${DEPEND} 426DEPEND+=" ${COMMONDEPEND}"
178 ${_operator}kde-base/kdelibs${_pv}"
179 RDEPEND="${RDEPEND} 427RDEPEND+=" ${COMMONDEPEND}"
180 ${_operator}kde-base/kdelibs${_pv}" 428unset COMMONDEPEND
181 if [[ ${PN} != "kdepimlibs" ]]; then
182 DEPEND="${DEPEND}
183 ${_operator}kde-base/kdepimlibs${_pv}"
184 RDEPEND="${RDEPEND}
185 ${_operator}kde-base/kdepimlibs${_pv}"
186 fi
187 fi
188 429
189 unset _operator _pv _kdedir 430# Add experimental kdeenablefinal, disabled by default
190fi 431IUSE+=" kdeenablefinal"
191 432
192# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 433# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
193# koffice ebuild, the URI should be set in the ebuild itself 434# koffice ebuild, the URI should be set in the ebuild itself
194if [[ -n ${KDEBASE} ]]; then 435case ${BUILD_TYPE} in
436 live)
437 SRC_URI=""
438 if has subversion ${INHERITED}; then
439 # Determine branch URL based on live type
440 local branch_prefix
441 case ${PV} in
442 9999*)
443 # trunk
444 branch_prefix="trunk/KDE"
445 ;;
446 *)
447 # branch
448 branch_prefix="branches/KDE/${SLOT}"
449 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
450 # @DESCRIPTION
451 # Suffix appended to ESVN_PROJECT depending on fetched branch.
452 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
453 ESVN_PROJECT_SUFFIX="-${PV}"
454 ;;
455 esac
456 # @ECLASS-VARIABLE: ESVN_MIRROR
457 # @DESCRIPTION:
458 # This variable allows easy overriding of default kde mirror service
459 # (anonsvn) with anything else you might want to use.
460 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
461 # Split ebuild, or extragear stuff
195 if [[ -n ${KMNAME} ]]; then 462 if [[ -n ${KMNAME} ]]; then
463 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
464 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
465 KMMODULE="${PN}"
466 fi
467 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
468 case ${KMNAME} in
469 kdebase-*)
470 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
471 ;;
472 kdelibs-*)
473 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
474 ;;
475 kdereview*)
476 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
477 ;;
478 kdesupport)
479 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
480 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
481 ;;
482 kde*)
483 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
484 ;;
485 extragear*|playground*)
486 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
487 # build packages from same svn location.
488 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
489 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
490 ;;
491 koffice)
492 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
493 ;;
494 *)
495 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
496 ;;
497 esac
498 else
499 # kdelibs, kdepimlibs
500 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
501 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
502 fi
503 # @ECLASS-VARIABLE: ESVN_UP_FREQ
504 # @DESCRIPTION:
505 # This variable is used for specifying the timeout between svn synces
506 # for kde-base and koffice modules. Does not affect misc apps.
507 # Default value is 1 hour.
508 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
509 elif has git ${INHERITED}; then
510 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
511 KMMODULE="${PN}"
512 fi
513 case ${KDEBASE} in
514 kdevelop)
515 EGIT_REPO_URI="git://git.kde.org/${KMMODULE}"
516 ;;
517 esac
518 fi
519 ;;
520 *)
521 if [[ -n ${KDEBASE} ]]; then
522 if [[ -n ${KMNAME} ]]; then
523 case ${KMNAME} in
524 kdebase-apps)
525 _kmname="kdebase" ;;
526 *)
196 _kmname=${KMNAME} 527 _kmname="${KMNAME}" ;;
528 esac
529 else
530 _kmname=${PN}
531 fi
532 _kmname_pv="${_kmname}-${PV}"
533 case ${KDEBASE} in
534 kde-base)
535 case ${PV} in
536 4.[456].8[05] | 4.[456].9[023568])
537 # Unstable KDE SC releases
538 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
539 ;;
540 4.4.6 | 4.4.7 | 4.4.8)
541 # Only kdepim here
542 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
543 ;;
544 *)
545 # Stable KDE SC releases
546 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
547 ;;
548 esac
549 ;;
550 koffice)
551 case ${PV} in
552 2.1.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
553 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
554 esac
555 ;;
556 kdevelop)
557 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
558 ;;
559 esac
560 unset _kmname _kmname_pv
561 fi
562 ;;
563esac
564
565debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
566
567# @ECLASS-VARIABLE: PREFIX
568# @DESCRIPTION:
569# Set the installation PREFIX for non kde-base applications. It defaults to /usr.
570# kde-base packages go into KDE4 installation directory (KDEDIR) by default.
571# No matter the PREFIX, package will be built against KDE installed in KDEDIR.
572
573# @FUNCTION: kde4-base_pkg_setup
574# @DESCRIPTION:
575# Do the basic kdeprefix KDEDIR settings and determine with which kde should
576# optional applications link
577kde4-base_pkg_setup() {
578 debug-print-function ${FUNCNAME} "$@"
579
580 # Prefix compat:
581 if [[ ${EAPI} == 2 ]] && ! use prefix; then
582 EPREFIX=
583 EROOT=${ROOT}
584 fi
585
586 # Append missing trailing slash character
587 [[ ${EROOT} = */ ]] || EROOT+="/"
588
589 # QA ebuilds
590 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
591
592 # Don't set KDEHOME during compilation, it will cause access violations
593 unset KDEHOME
594
595 if [[ ${KDEBASE} = kde-base ]]; then
596 if use kdeprefix; then
597 KDEDIR=/usr/kde/${SLOT}
598 else
599 KDEDIR=/usr
600 fi
601 : ${PREFIX:=${KDEDIR}}
197 else 602 else
198 _kmname=${PN} 603 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
199 fi 604 KDEDIR=
200 _kmname_pv="${_kmname}-${PV}" 605 local kde_minimal_met
201 if [[ ${NEED_KDE} != "svn" ]]; then 606 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
202 case ${KDEBASE} in 607 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
203 kde-base) 608 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
204 case ${PV} in 609 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
205 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2";; 610 KDEDIR=/usr/kde/${slot}
206 esac
207 ;;
208 koffice)
209 SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2"
210 ;;
211 esac
212 fi
213 unset _kmname _kmname_pv
214fi
215
216debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
217debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - before blockers"
218
219# Monolithic ebuilds should add blockers for split ebuilds in the same slot.
220# If KMNAME is not set then this is not a split package
221if [[ -n ${KDEBASE} && -z ${KMNAME} ]]; then
222 for _x in $(get-child-packages ${CATEGORY}/${PN}); do
223 DEPEND="${DEPEND} !${_x}:${SLOT}"
224 RDEPEND="${RDEPEND} !${_x}:${SLOT}"
225 done
226 unset _x
227fi
228
229debug-print "${BASH_SOURCE} ${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND ${DEPEND} - after blockers"
230
231# @ECLASS-VARIABLE: PREFIX
232# @DESCRIPTION:
233# Set the installation PREFIX. All kde-base ebuilds go into the KDE4 installation directory.
234# Applications installed by the other ebuilds go into /usr/ by default, this value
235# can be superseded by defining PREFIX before inheriting kde4-base.
236if [[ -n ${KDEBASE} ]]; then
237 PREFIX=${KDEDIR}
238else
239 # if PREFIX is not defined we set it to the default value of /usr
240 PREFIX="${PREFIX:-/usr}"
241fi
242
243debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SLOT ${SLOT} - KDEDIR ${KDEDIR} - KDEDIRS ${KDEDIRS}- PREFIX ${PREFIX} - NEED_KDE ${NEED_KDE}"
244
245# @FUNCTION: kde4-base_pkg_setup
246# @DESCRIPTION:
247# Adds flags needed by all of KDE 4 to $QT4_BUILT_WITH_USE_CHECK. Uses
248# kde4-functions_check_use from kde4-functions.eclass to print appropriate
249# errors and die if any required flags listed in $QT4_BUILT_WITH_USE_CHECK or
250# $KDE4_BUILT_WITH_USE_CHECK are missing.
251kde4-base_pkg_setup() {
252 debug-print-function $FUNCNAME "$@"
253
254 # KDE4 applications require qt4 compiled with USE="accessibility dbus gif jpeg png qt3support ssl zlib".
255 if has_version '<x11-libs/qt-4.4_alpha:4'; then
256 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} accessibility dbus gif jpeg png qt3support ssl zlib"
257 else
258 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
259 x11-libs/qt-core qt3support ssl
260 x11-libs/qt-gui accessibility dbus
261 x11-libs/qt-qt3support accessibility"
262 fi
263
264 if has debug ${IUSE//+} && use debug; then
265 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
266 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} debug"
267 else 611 else
268 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK} 612 KDEDIR=/usr
269 x11-libs/qt-core:4 debug
270 x11-libs/qt-gui:4 debug
271 x11-libs/qt-qt3support:4 debug
272 x11-libs/qt-svg:4 debug
273 x11-libs/qt-test:4 debug"
274 if [[ ${OPENGL_REQUIRED} == always ]] || has opengl ${IUSE//+} && use opengl; then
275 KDE4_BUILT_WITH_USE_CHECK="${KDE4_BUILT_WITH_USE_CHECK}
276 x11-libs/qt-opengl:4 debug"
277 fi 613 fi
278 fi 614 break;
279 fi
280
281 if [[ ${OPENGL_REQUIRED} == always ]] || has opengl ${IUSE//+} && use opengl; then
282 if has_version '<x11-libs/qt-4.4.0_alpha:4'; then
283 QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
284 fi
285 fi
286
287 kde4-functions_check_use
288}
289
290# @FUNCTION: kde4-base_apply_patches
291# @DESCRIPTION:
292# This function applies patches.
293#
294# If the directory ${WORKDIR}/patches/ exists, we apply all patches in that
295# directory, provided they follow this format:
296# @CODE
297# - Monolithic ebuilds, (from kde-base)
298# - $CATEGORY=kde-base:
299# Apply ${CHILD_EBUILD_NAME}-${SLOT}-*{diff,patch}
300# - $CATEGORY=!kde-base:
301# Apply ${CHILD_EBUILD_NAME}-${PV}-*{diff,patch}
302# - Split ebuilds:
303# - $CATEGORY=kde-base:
304# Apply ${PN}-${SLOT}-*{diff,patch}
305# - $CATEGORY!=kde-base:
306# Apply ${PN}-${PV}-*{diff,patch}
307# @CODE
308#
309# If ${PATCHES} is non-zero all patches in it gets applied.
310kde4-base_apply_patches() {
311 local _patchdir _packages _p
312 _patchdir="${WORKDIR}/patches/"
313 if [[ -d "${_patchdir}" ]]; then
314 if is-parent-package ${CATEGORY}/${PN} ; then
315 _packages="$(get-child-packages ${CATEGORY}/${PN})"
316 _packages="${_packages//${CATEGORY}\//} ${PN}"
317 else
318 _packages="${PN}"
319 fi
320 for _p in ${_packages}; do
321 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${PV}-*{diff,patch} 2>/dev/null)"
322 if [[ -n "${KDEBASE}" ]]; then
323 PATCHES="${PATCHES} $(ls ${_patchdir}/${_p}-${SLOT}-*{diff,patch} 2>/dev/null)"
324 fi 615 fi
325 done 616 done
617 unset slot
618
619 # Bail out if kdelibs required but not found
620 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
621 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
622 else
623 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
326 fi 624 fi
327 [[ -n ${PATCHES} ]] && base_src_unpack autopatch 625
626 : ${PREFIX:=/usr}
627 fi
628 EKDEDIR=${EPREFIX}${KDEDIR}
629
630 # Point pkg-config path to KDE *.pc files
631 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
632 # Point to correct QT plugins path
633 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
634
635 # Fix XDG collision with sandbox
636 export XDG_CONFIG_HOME="${T}"
328} 637}
329 638
330# @FUNCTION: kde4-base_src_unpack 639# @FUNCTION: kde4-base_src_unpack
331# @DESCRIPTION: 640# @DESCRIPTION:
332# This function unpacks the source tarballs for KDE4 applications. 641# This function unpacks the source tarballs for KDE4 applications.
333#
334# If no argument is passed to this function, then standard src_unpack is
335# executed. Otherwise options are passed to base_src_unpack.
336#
337# In addition it calls kde4-base_apply_patches when no arguments are passed to
338# this function.
339kde4-base_src_unpack() { 642kde4-base_src_unpack() {
340 debug-print-function $FUNCNAME "$@" 643 debug-print-function ${FUNCNAME} "$@"
341 644
342 [[ -z "${KDE_S}" ]] && KDE_S="${S}" 645 if [[ ${BUILD_TYPE} = live ]]; then
343 646 if has subversion ${INHERITED}; then
344 if [[ -z $* ]]; then 647 migrate_store_dir
345 # Unpack first and deal with KDE patches after examing possible patch sets. 648 subversion_src_unpack
346 # To be picked up, patches need to conform to the guidelines stated before. 649 elif has git ${INHERITED}; then
347 # Monolithic ebuilds will use the split ebuild patches. 650 git_src_unpack
348 [[ -d "${KDE_S}" ]] || unpack ${A} 651 fi
349 kde4-base_apply_patches 652 elif [[ ${EAPI} == 2 ]]; then
653 local file
654 for file in ${A}; do
655 # This setup is because EAPI <= 2 cannot unpack *.tar.xz files
656 # directly, so we do it ourselves (using the exact same code as portage)
657 case ${file} in
658 *.tar.xz)
659 echo ">>> Unpacking ${file} to ${PWD}"
660 xz -dc "${DISTDIR}"/${file} | tar xof -
661 assert "failed unpacking ${file}"
662 ;;
663 *)
664 unpack ${file}
665 ;;
666 esac
667 done
350 else 668 else
351 # Call base_src_unpack, which unpacks and patches 669 # For EAPI >= 3, we can just use unpack() directly
352 # step by step transparently as defined in the ebuild. 670 unpack ${A}
353 base_src_unpack $* 671 fi
672}
673
674# @FUNCTION: kde4-base_src_prepare
675# @DESCRIPTION:
676# General pre-configure and pre-compile function for KDE4 applications.
677# It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
678# enable_selected_linguas() and enable_selected_doc_linguas()
679# in kde4-functions.eclass(5) for further details.
680kde4-base_src_prepare() {
681 debug-print-function ${FUNCNAME} "$@"
682
683 # Only enable selected languages, used for KDE extragear apps.
684 if [[ -n ${KDE_LINGUAS} ]]; then
685 enable_selected_linguas
686 fi
687
688 # Enable/disable handbooks for kde4-base packages
689 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
690 # kdelibs inherits kde4-base but handle installing the handbook itself
691 if ! has kde4-meta ${INHERITED}; then
692 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas
693 fi
694
695 # SCM bootstrap
696 if [[ ${BUILD_TYPE} = live ]]; then
697 if has subversion ${INHERITED}; then
698 subversion_src_prepare
699 elif has git ${INHERITED}; then
700 git_src_prepare
354 fi 701 fi
355
356 # Updated cmake dir
357 if [[ -d "${WORKDIR}/cmake" ]] && [[ -d "${KDE_S}/cmake" ]]; then
358 ebegin "Updating cmake/ directory..."
359 rm -rf "${KDE_S}/cmake" || die "Unable to remove old cmake/ directory"
360 ln -s "${WORKDIR}/cmake" "${KDE_S}/cmake" || die "Unable to symlink the new cmake/ directory"
361 eend 0
362 fi 702 fi
703
704 # Apply patches
705 base_src_prepare
706
707 # Save library dependencies
708 if [[ -n ${KMSAVELIBS} ]] ; then
709 save_library_dependencies
710 fi
711
712 # Inject library dependencies
713 if [[ -n ${KMLOADLIBS} ]] ; then
714 load_library_dependencies
715 fi
716
717 # Replace KDE4Workspace library targets
718 find "${S}" -name CMakeLists.txt \
719 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
720 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
721 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
722 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
723 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
724 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
725 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
726 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
727 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
728 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
729 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
730 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
731 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
732 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
733 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
734 || die 'failed to replace KDE4Workspace library targets'
735
736 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/...
737 if [[ -z ${KDEBASE} ]]; then
738 find "${S}" -name "*.docbook" \
739 -exec sed -i -r \
740 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
741 || die 'failed to fix DocBook variant version'
742 fi
743}
744
745# @FUNCTION: kde4-base_src_configure
746# @DESCRIPTION:
747# Function for configuring the build of KDE4 applications.
748kde4-base_src_configure() {
749 debug-print-function ${FUNCNAME} "$@"
750
751 # Build tests in src_test only, where we override this value
752 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
753
754 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
755 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
756 fi
757
758 if has debug ${IUSE//+} && use debug; then
759 # Set "real" debug mode
760 CMAKE_BUILD_TYPE="Debugfull"
761 else
762 # Handle common release builds
763 append-cppflags -DQT_NO_DEBUG
764 fi
765
766 # Set distribution name
767 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
768
769 # Here we set the install prefix
770 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
771
772 # Use colors
773 QTEST_COLORED=1
774
775 # Shadow existing /usr installations
776 unset KDEDIRS
777
778 # Handle kdeprefix-ed KDE
779 if [[ ${KDEDIR} != /usr ]]; then
780 # Override some environment variables - only when kdeprefix is different,
781 # to not break ccache/distcc
782 PATH="${EKDEDIR}/bin:${PATH}"
783
784 # Append library search path
785 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
786
787 # Append full RPATH
788 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
789
790 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
791 # when more are present
792 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
793 fi
794
795 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
796 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4)
797 #kde-config -path data unavailable when cross-compiling
798 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
799
800 # Handle kdeprefix in application itself
801 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
802 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
803 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
804 fi
805
806 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
807 mycmakeargs=(${mycmakeargs})
808 fi
809
810 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
811
812 cmake-utils_src_configure
363} 813}
364 814
365# @FUNCTION: kde4-base_src_compile 815# @FUNCTION: kde4-base_src_compile
366# @DESCRIPTION: 816# @DESCRIPTION:
367# General function for compiling KDE4 applications. 817# General function for compiling KDE4 applications.
368kde4-base_src_compile() { 818kde4-base_src_compile() {
369 debug-print-function ${FUNCNAME} "$@" 819 debug-print-function ${FUNCNAME} "$@"
370 820
371 kde4-base_src_configure
372 kde4-base_src_make
373}
374
375# @FUNCTION: kde4-base_src_configure
376# @DESCRIPTION:
377# Function for configuring the build of KDE4 applications.
378kde4-base_src_configure() {
379 debug-print-function ${FUNCNAME} "$@"
380
381 # Final flag handling
382 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
383 echo "Activating enable-final flag"
384 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_FINAL=ON"
385 fi
386
387 # Enable generation of HTML handbook
388 if has htmlhandbook ${IUSE//+} && use htmlhandbook; then
389 echo "Enabling building of HTML handbook"
390 mycmakeargs="${mycmakeargs} -DKDE4_ENABLE_HTMLHANDBOOK=ON"
391 fi
392
393 # Build tests in src_test only, where we override this value
394 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=OFF"
395
396 # Set distribution name
397 [[ ${PN} == "kdelibs" ]] && mycmakeargs="${mycmakeargs} -DKDE_DISTRIBUTION_TEXT=Gentoo"
398
399 # runpath linking
400 mycmakeargs="${mycmakeargs} -DKDE4_USE_ALWAYS_FULL_RPATH=ON"
401
402 # Here we set the install prefix
403 mycmakeargs="${mycmakeargs} -DCMAKE_INSTALL_PREFIX=${PREFIX}"
404
405 # Set environment
406 QTEST_COLORED=1
407 QT_PLUGIN_PATH=${KDEDIR}/$(get_libdir)/kde4/plugins/
408
409 cmake-utils_src_configureout
410}
411
412# @FUNCTION: kde4-base_src_make
413# @DESCRIPTION:
414# Function for building KDE4 applications.
415# Options are passed to cmake-utils_src_make.
416kde4-base_src_make() {
417 debug-print-function ${FUNCNAME} "$@"
418
419 cmake-utils_src_make "$@" 821 cmake-utils_src_compile "$@"
420} 822}
421 823
422# @FUNCTION: kde4-base_src_test 824# @FUNCTION: kde4-base_src_test
423# @DESCRIPTION: 825# @DESCRIPTION:
424# Function for testing KDE4 applications. 826# Function for testing KDE4 applications.
425kde4-base_src_test() { 827kde4-base_src_test() {
426 debug-print-function ${FUNCNAME} "$@" 828 debug-print-function ${FUNCNAME} "$@"
427 829
428 # Override this value, set in kde4-base_src_configure() 830 # Override this value, set in kde4-base_src_configure()
429 mycmakeargs="${mycmakeargs} -DKDE4_BUILD_TESTS=ON" 831 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
430 cmake-utils_src_compile 832 cmake-utils_src_configure
833 kde4-base_src_compile
431 834
835 if [[ ${VIRTUALX_REQUIRED} == always ]] ||
836 ( [[ ${VIRTUALX_REQUIRED} != manual ]] && use test ); then
837
838 if [[ ${maketype} ]]; then
839 # surprise- we are already INSIDE virtualmake!!!
840 ewarn "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
841 ewarn " You may NOT set maketype or call virtualmake from the ebuild. Applying workaround."
842 cmake-utils_src_test
843 else
844 export maketype="cmake-utils_src_test"
845 virtualmake
846 fi
847 else
432 cmake-utils_src_test 848 cmake-utils_src_test
849 fi
433} 850}
434 851
435# @FUNCTION: kde4-base_src_install 852# @FUNCTION: kde4-base_src_install
436# @DESCRIPTION: 853# @DESCRIPTION:
437# Function for installing KDE4 applications. 854# Function for installing KDE4 applications.
438kde4-base_src_install() { 855kde4-base_src_install() {
439 debug-print-function ${FUNCNAME} "$@" 856 debug-print-function ${FUNCNAME} "$@"
440 857
441 kde4-base_src_make_doc 858 # Prefix support, for usage in ebuilds
859 if [[ ${EAPI} == 2 ]] && ! use prefix; then
860 ED=${D}
861 fi
862
863 if [[ -n ${KMSAVELIBS} ]] ; then
864 install_library_dependencies
865 fi
866
867 # Install common documentation of KDE4 applications
868 local doc
869 if ! has kde4-meta ${INHERITED}; then
870 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
871 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && dodoc "${doc}"
872 done
873 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
874 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
875 done
876 fi
877
442 cmake-utils_src_install 878 cmake-utils_src_install
443} 879}
444 880
445# @FUNCTION: kde4-base_src_make_doc
446# @DESCRIPTION:
447# Function for installing the documentation of KDE4 applications.
448kde4-base_src_make_doc() {
449 debug-print-function ${FUNCNAME} "$@"
450
451 local doc
452 for doc in AUTHORS ChangeLog* README* NEWS TODO; do
453 [[ -s $doc ]] && dodoc ${doc}
454 done
455
456 if [[ -z ${KMNAME} ]]; then
457 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
458 if [[ -s $doc ]]; then
459 local doc_complete=${doc}
460 doc="${doc#*/}"
461 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
462 fi
463 done
464 fi
465
466 if [[ -n ${KDEBASE} && -d "${D}"/usr/share/doc/${PF} ]]; then
467 # work around bug #97196
468 dodir /usr/share/doc/kde && \
469 mv "${D}"/usr/share/doc/${PF} "${D}"/usr/share/doc/kde/ || \
470 die "Failed to move docs to kde/ failed."
471 fi
472}
473
474# @FUNCTION: kde4-base_pkg_postinst 881# @FUNCTION: kde4-base_pkg_postinst
475# @DESCRIPTION: 882# @DESCRIPTION:
476# Function to rebuild the KDE System Configuration Cache after an application has been installed. 883# Function to rebuild the KDE System Configuration Cache after an application has been installed.
477kde4-base_pkg_postinst() { 884kde4-base_pkg_postinst() {
885 debug-print-function ${FUNCNAME} "$@"
886
887 buildsycoca
888
889 if [[ ${BUILD_TYPE} = live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
890 echo
891 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
892 einfo "Use it at your own risk."
893 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
894 echo
895 elif [[ ${BUILD_TYPE} != live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && has kdeprefix ${IUSE//+} && use kdeprefix; then
896 # warning about kdeprefix for non-live users
897 echo
898 ewarn "WARNING! You have the kdeprefix useflag enabled."
899 ewarn "This setting is strongly discouraged and might lead to potential trouble"
900 ewarn "with KDE update strategies."
901 ewarn "You are using this setup at your own risk and the kde team does not"
902 ewarn "take responsibilities for dead kittens."
903 echo
904 fi
905 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && ! has_version 'kde-base/kdebase-runtime-meta' && ! has_version 'kde-base/kdebase-startkde'; then
906 # warn about not supported approach
907 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
908 echo
909 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
910 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
911 ewarn "With this setting you are unsupported by KDE team."
912 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
913 fi
914 fi
915}
916
917# @FUNCTION: kde4-base_pkg_postrm
918# @DESCRIPTION:
919# Function to rebuild the KDE System Configuration Cache after an application has been removed.
920kde4-base_pkg_postrm() {
921 debug-print-function ${FUNCNAME} "$@"
922
478 buildsycoca 923 buildsycoca
479} 924}
480
481# @FUNCTION: kde4-base_pkg_postrm
482# @DESCRIPTION:
483# Function to rebuild the KDE System Configuration Cache after an application has been removed.
484kde4-base_pkg_postrm() {
485 buildsycoca
486}

Legend:
Removed from v.1.5  
changed lines
  Added in v.1.79

  ViewVC Help
Powered by ViewVC 1.1.20