/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Diff of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.56 Revision 1.79
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.56 2009/12/10 17:35:52 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.79 2010/12/06 10:17:04 tampakrap Exp $
4 4
5# @ECLASS: kde4-base.eclass 5# @ECLASS: kde4-base.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: This eclass provides functions for kde 4.X ebuilds 8# @BLURB: This eclass provides functions for kde 4.X ebuilds
11# and KDE4 applications. 11# and KDE4 applications.
12# 12#
13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but 13# NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but
14# eclass will fail with version older than 2. 14# eclass will fail with version older than 2.
15 15
16# @ECLASS-VARIABLE: VIRTUALX_REQUIRED
17# @DESCRIPTION:
18# Do we need an X server? Valid values are "always", "optional", and "manual".
19# "tests" is a synonym for "optional". While virtualx.eclass supports in principle
20# also the use of an X server during other ebuild phases, we only use it in
21# src_test here. Most likely you'll want to set "optional", which introduces the
22# use-flag "test" (if not already present), adds dependencies conditional on that
23# use-flag, and automatically runs (only) the ebuild test phase with a virtual X server
24# present. This makes things a lot more comfortable than the bare virtualx eclass.
25
26# In case the variable is not set in the ebuild, let virtualx eclass not do anything
27: ${VIRTUALX_REQUIRED:=manual}
28
29inherit kde4-functions base virtualx eutils
30
31get_build_type
32if [[ ${BUILD_TYPE} = live ]]; then
33 if [[ ${KDEBASE} = kdevelop ]]; then
34 inherit git
35 else
36 inherit subversion
37 fi
38fi
39
16# @ECLASS-VARIABLE: CMAKE_REQUIRED 40# @ECLASS-VARIABLE: CMAKE_REQUIRED
17# @DESCRIPTION: 41# @DESCRIPTION:
18# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'. 42# Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
19# Please note that if it's set to 'never' you need to explicitly override following phases: 43# Please note that if it's set to 'never' you need to explicitly override following phases:
20# src_configure, src_compile, src_test and src_install. 44# src_configure, src_compile, src_test and src_install.
21# Defaults to 'always'. 45# Defaults to 'always'.
22: ${CMAKE_REQUIRED:=always} 46: ${CMAKE_REQUIRED:=always}
23if [[ ${CMAKE_REQUIRED} = false || ${CMAKE_REQUIRED} = never ]]; then 47if [[ ${CMAKE_REQUIRED} = always ]]; then
24 buildsystem_eclass=""
25 export_fns=""
26else
27 buildsystem_eclass="cmake-utils" 48 buildsystem_eclass="cmake-utils"
28 export_fns="src_configure src_compile src_test src_install" 49 export_fns="src_configure src_compile src_test src_install"
29fi 50fi
30
31inherit kde4-functions
32
33get_build_type
34if [[ ${BUILD_TYPE} = live ]]; then
35 subversion_eclass="subversion"
36fi
37
38inherit base ${buildsystem_eclass} eutils ${subversion_eclass}
39
40EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm
41
42unset buildsystem_eclass
43unset export_fns
44unset subversion_eclass
45
46case ${KDEBASE} in
47 kde-base)
48 HOMEPAGE="http://www.kde.org/"
49 LICENSE="GPL-2"
50 ;;
51 koffice)
52 HOMEPAGE="http://www.koffice.org/"
53 LICENSE="GPL-2"
54 ;;
55esac
56
57# @ECLASS-VARIABLE: OPENGL_REQUIRED
58# @DESCRIPTION:
59# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
60# This variable must be set before inheriting any eclasses. Defaults to 'never'.
61OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
62
63# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
64# @DESCRIPTION:
65# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
66# This variable must be set before inheriting any eclasses. Defaults to 'never'.
67MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
68
69# @ECLASS-VARIABLE: WEBKIT_REQUIRED
70# @DESCRIPTION:
71# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
72# This variable must be set before inheriting any eclasses. Defaults to 'never'.
73WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
74
75# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
76# @DESCRIPTION:
77# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
78# This variable must be set before inheriting any eclasses. Defaults to 'never'.
79CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
80
81# @ECLASS-VARIABLE: KDE_REQUIRED
82# @DESCRIPTION:
83# Is kde required? Possible values are 'always', 'optional' and 'never'.
84# This variable must be set before inheriting any eclasses. Defaults to 'always'
85# If set to always or optional, KDE_MINIMAL may be overriden as well.
86# Note that for kde-base packages this variable is fixed to 'always'.
87KDE_REQUIRED="${KDE_REQUIRED:-always}"
88 51
89# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here) 52# Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
90if [[ -n ${KDE_MINIMAL} ]]; then 53if [[ -n ${KDE_MINIMAL} ]]; then
91 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do 54 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
92 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break 55 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
98fi 61fi
99 62
100# @ECLASS-VARIABLE: KDE_MINIMAL 63# @ECLASS-VARIABLE: KDE_MINIMAL
101# @DESCRIPTION: 64# @DESCRIPTION:
102# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal 65# This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
103# version for apps to work. Currently defaults to 4.3 66# version for apps to work. Currently defaults to 4.4
104# One may override this variable to raise version requirements. 67# One may override this variable to raise version requirements.
105# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables. 68# For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
106# Note that it is fixed to ${SLOT} for kde-base packages. 69# Note that it is fixed to ${SLOT} for kde-base packages.
107KDE_MINIMAL="${KDE_MINIMAL:-4.3}" 70KDE_MINIMAL="${KDE_MINIMAL:-4.4}"
71
72# Set slot for packages in kde-base, koffice and kdevelop
73case ${KDEBASE} in
74 kde-base)
75 # Determine SLOT from PVs
76 case ${PV} in
77 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
78 4.6* | 4.5.[6-9][0-9]*) SLOT="4.6" ;;
79 4.5* | 4.4.[6-9][0-9]*) SLOT="4.5" ;;
80 4.4* | 4.3.[6-9][0-9]*) SLOT="4.4" ;;
81 9999*) SLOT="live" ;; # regular live
82 *) die "Unsupported ${PV}" ;;
83 esac
84 KDE_MINIMAL="${SLOT}"
85 ;;
86 koffice)
87 SLOT="2"
88 ;;
89 kdevelop)
90 if [[ ${BUILD_TYPE} = live ]]; then
91 # @ECLASS-VARIABLE: KDEVELOP_VERSION
92 # @DESCRIPTION:
93 # Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
94 # Applies to KDEBASE=kdevelop only.
95 KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
96 # @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
97 # @DESCRIPTION:
98 # Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
99 # Applies to KDEBASE=kdevelop only.
100 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
101 else
102 case ${PN} in
103 kdevelop|quanta)
104 KDEVELOP_VERSION=${PV}
105 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
106 ;;
107 kdevplatform)
108 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
109 KDEVPLATFORM_VERSION=${PV}
110 ;;
111 *)
112 KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.0.0}"
113 KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-1.0.0}"
114 esac
115 fi
116 SLOT="4"
117 ;;
118esac
119
120slot_is_at_least 4.5 ${KDE_MINIMAL} && CMAKE_MIN_VERSION="2.8.1"
121
122inherit ${buildsystem_eclass}
123
124EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm
125
126unset buildsystem_eclass
127unset export_fns
128
129# @ECLASS-VARIABLE: DECLARATIVE_REQUIRED
130# @DESCRIPTION:
131# Is qt-declarative required? Possible values are 'always', 'optional' and 'never'.
132# This variable must be set before inheriting any eclasses. Defaults to 'never'.
133DECLARATIVE_REQUIRED="${DECLARATIVE_REQUIRED:-never}"
134
135# @ECLASS-VARIABLE: QTHELP_REQUIRED
136# @DESCRIPTION:
137# Is qt-assistant required? Possible values are 'always', 'optional' and 'never'.
138# This variable must be set before inheriting any eclasses. Defaults to 'never'.
139QTHELP_REQUIRED="${QTHELP_REQUIRED:-never}"
140
141# @ECLASS-VARIABLE: OPENGL_REQUIRED
142# @DESCRIPTION:
143# Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
144# This variable must be set before inheriting any eclasses. Defaults to 'never'.
145OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
146
147# @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
148# @DESCRIPTION:
149# Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
150# This variable must be set before inheriting any eclasses. Defaults to 'never'.
151MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
152
153# @ECLASS-VARIABLE: WEBKIT_REQUIRED
154# @DESCRIPTION:
155# Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
156# This variable must be set before inheriting any eclasses. Defaults to 'never'.
157WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
158
159# @ECLASS-VARIABLE: CPPUNIT_REQUIRED
160# @DESCRIPTION:
161# Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
162# This variable must be set before inheriting any eclasses. Defaults to 'never'.
163CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
164
165# @ECLASS-VARIABLE: KDE_REQUIRED
166# @DESCRIPTION:
167# Is kde required? Possible values are 'always', 'optional' and 'never'.
168# This variable must be set before inheriting any eclasses. Defaults to 'always'
169# If set to 'always' or 'optional', KDE_MINIMAL may be overriden as well.
170# Note that for kde-base packages this variable is fixed to 'always'.
171KDE_REQUIRED="${KDE_REQUIRED:-always}"
172
173# @ECLASS-VARIABLE: KDE_HANDBOOK
174# @DESCRIPTION:
175# Set to enable handbook in application. Possible values are 'always', 'optional'
176# (handbook USE flag) and 'never'.
177# This variable must be set before inheriting any eclasses. Defaults to 'never'.
178# It adds default handbook dirs for kde-base packages to KMEXTRA and in any case it
179# ensures buildtime and runtime dependencies.
180KDE_HANDBOOK="${KDE_HANDBOOK:-never}"
108 181
109# Setup packages inheriting this eclass 182# Setup packages inheriting this eclass
110case ${KDEBASE} in 183case ${KDEBASE} in
111 kde-base) 184 kde-base)
185 HOMEPAGE="http://www.kde.org/"
186 LICENSE="GPL-2"
112 if [[ $BUILD_TYPE = live ]]; then 187 if [[ $BUILD_TYPE = live ]]; then
113 # Disable tests for live ebuilds 188 # Disable tests for live ebuilds
114 RESTRICT+=" test" 189 RESTRICT+=" test"
115 # Live ebuilds in kde-base default to kdeprefix by default 190 # Live ebuilds in kde-base default to kdeprefix by default
116 IUSE+=" +kdeprefix" 191 IUSE+=" +kdeprefix"
117 else 192 else
118 # All other ebuild types default to -kdeprefix as before 193 # All other ebuild types default to -kdeprefix as before
119 IUSE+=" kdeprefix" 194 IUSE+=" kdeprefix"
120 fi 195 fi
121 # Determine SLOT from PVs
122 case ${PV} in
123 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
124 4.4* | 4.3.[6-9]*) SLOT="4.4" ;;
125 4.3*) SLOT="4.3" ;;
126 4.2*) SLOT="4.2" ;;
127 9999*) SLOT="live" ;; # regular live
128 *) die "Unsupported ${PV}" ;;
129 esac
130 # This code is to prevent portage from searching GENTOO_MIRRORS for 196 # This code is to prevent portage from searching GENTOO_MIRRORS for
131 # packages that will never be mirrored. (As they only will ever be in 197 # packages that will never be mirrored. (As they only will ever be in
132 # the overlay). 198 # the overlay).
133 case ${PV} in 199 case ${PV} in
134 *9999* | 4.?.[6-9]?) 200 *9999* | 4.?.[6-9]?)
135 RESTRICT+=" mirror" 201 RESTRICT+=" mirror"
136 ;; 202 ;;
137 esac 203 esac
138 KDE_MINIMAL="${SLOT}"
139 _kdedir="${SLOT}"
140
141 # Block installation of other SLOTS unless kdeprefix 204 # Block installation of other SLOTS unless kdeprefix
142 RDEPEND+=" $(block_other_slots)" 205 RDEPEND+=" $(block_other_slots)"
143 ;; 206 ;;
144 koffice) 207 koffice)
145 SLOT="2" 208 HOMEPAGE="http://www.koffice.org/"
209 LICENSE="GPL-2"
210 ;;
211 kdevelop)
212 HOMEPAGE="http://www.kdevelop.org/"
213 LICENSE="GPL-2"
146 ;; 214 ;;
147esac 215esac
148 216
149# @ECLASS-VARIABLE: QT_MINIMAL 217# @ECLASS-VARIABLE: QT_MINIMAL
150# @DESCRIPTION: 218# @DESCRIPTION:
151# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1.. 219# Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1...
152# Currently defaults to 4.5.1 for KDE 4.3 and earlier 220# 4.6.0 for 4.4, 4.6.3 for 4.5, and 4.7.0 for 4.6 and later
153# or 4.6.0_rc1 for KDE 4.4 and later
154if slot_is_at_least 4.4 "${KDE_MINIMAL}"; then 221if slot_is_at_least 4.6 "${KDE_MINIMAL}"; then
222 QT_MINIMAL="${QT_MINIMAL:-4.7.0}"
223elif slot_is_at_least 4.5 "${KDE_MINIMAL}"; then
224 QT_MINIMAL="${QT_MINIMAL:-4.6.3}"
225else
155 QT_MINIMAL="${QT_MINIMAL:-4.6.0}" 226 QT_MINIMAL="${QT_MINIMAL:-4.6.0}"
156fi 227fi
157 228
158QT_MINIMAL="${QT_MINIMAL:-4.5.1}" 229# Declarative dependencies
230qtdeclarativedepend="
231 >=x11-libs/qt-declarative-${QT_MINIMAL}:4
232"
233case ${DECLARATIVE_REQUIRED} in
234 always)
235 COMMONDEPEND+=" ${qtdeclarativedepend}"
236 ;;
237 optional)
238 IUSE+=" declarative"
239 COMMONDEPEND+=" declarative? ( ${qtdeclarativedepend} )"
240 ;;
241 *) ;;
242esac
243unset qtdeclarativedepend
244
245# QtHelp dependencies
246qthelpdepend="
247 >=x11-libs/qt-assistant-${QT_MINIMAL}:4
248"
249case ${QTHELP_REQUIRED} in
250 always)
251 COMMONDEPEND+=" ${qthelpdepend}"
252 ;;
253 optional)
254 IUSE+=" qthelp"
255 COMMONDEPEND+=" qthelp? ( ${qthelpdepend} )"
256 ;;
257esac
258unset qthelpdepend
159 259
160# OpenGL dependencies 260# OpenGL dependencies
161qtopengldepend=" 261qtopengldepend="
162 >=x11-libs/qt-opengl-${QT_MINIMAL}:4 262 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
163" 263"
230 *) ;; 330 *) ;;
231esac 331esac
232unset cppuintdepend 332unset cppuintdepend
233 333
234# KDE dependencies 334# KDE dependencies
335# Qt accessibility classes are needed in various places, bug 325461
235kdecommondepend=" 336kdecommondepend="
236 dev-lang/perl 337 dev-lang/perl
237 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl] 338 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
238 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus] 339 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
239 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde] 340 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
245 x11-libs/libXext 346 x11-libs/libXext
246 x11-libs/libXt 347 x11-libs/libXt
247 x11-libs/libXxf86vm 348 x11-libs/libXxf86vm
248 ) 349 )
249" 350"
351
250if [[ ${PN} != kdelibs ]]; then 352if [[ ${PN} != kdelibs ]]; then
251 if [[ ${KDEBASE} = kde-base ]]; then
252 kdecommondepend+=" $(add_kdebase_dep kdelibs)" 353 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
253 # libknotificationitem only when SLOT is 4.3 354 if [[ ${KDEBASE} = kdevelop ]]; then
254 [[ ${PN} != libknotificationitem ]] && [[ ${SLOT} = 4.3 ]] && \ 355 if [[ ${PN} != kdevplatform ]]; then
255 kdecommondepend+=" $(add_kdebase_dep libknotificationitem)" 356 # @ECLASS-VARIABLE: KDEVPLATFORM_REQUIRED
256 else 357 # @DESCRIPTION:
358 # Specifies whether kdevplatform is required. Possible values are 'always' (default) and 'never'.
359 # Applies to KDEBASE=kdevelop only.
360 KDEVPLATFORM_REQUIRED="${KDEVPLATFORM_REQUIRED:-always}"
361 case ${KDEVPLATFORM_REQUIRED} in
362 always)
257 kdecommondepend+=" 363 kdecommondepend+="
258 >=kde-base/kdelibs-${KDE_MINIMAL} 364 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
259 " 365 "
366 ;;
367 *) ;;
368 esac
369 fi
260 fi 370 fi
261fi 371fi
262kdedepend=" 372kdedepend="
373 dev-util/automoc
263 dev-util/pkgconfig 374 dev-util/pkgconfig
264 !aqua? ( 375 !aqua? (
265 || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1.0 ) 376 || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1.0 )
266 x11-proto/xf86vidmodeproto 377 x11-proto/xf86vidmodeproto
267 ) 378 )
268" 379"
380kderdepend=""
381
382kdehandbookdepend="
383 app-text/docbook-xml-dtd:4.2
384 app-text/docbook-xsl-stylesheets
385"
386kdehandbookrdepend="
387 $(add_kdebase_dep kdelibs 'handbook')
388"
389case ${KDE_HANDBOOK} in
390 always)
391 kdedepend+=" ${kdehandbookdepend}"
392 [[ ${PN} != kdelibs ]] && kderdepend+=" ${kdehandbookrdepend}"
393 ;;
394 optional)
395 IUSE+=" +handbook"
396 kdedepend+=" handbook? ( ${kdehandbookdepend} )"
397 [[ ${PN} != kdelibs ]] && kderdepend+=" handbook? ( ${kdehandbookrdepend} )"
398 ;;
399 *) ;;
400esac
401unset kdehandbookdepend kdehandbookrdepend
402
269case ${KDE_REQUIRED} in 403case ${KDE_REQUIRED} in
270 always) 404 always)
271 IUSE+=" aqua" 405 IUSE+=" aqua"
272 COMMONDEPEND+=" ${kdecommondepend}" 406 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" ${kdecommondepend}"
273 DEPEND+=" ${kdedepend}" 407 [[ -n ${kdedepend} ]] && DEPEND+=" ${kdedepend}"
408 [[ -n ${kderdepend} ]] && RDEPEND+=" ${kderdepend}"
274 ;; 409 ;;
275 optional) 410 optional)
276 IUSE+=" aqua kde" 411 IUSE+=" aqua kde"
277 COMMONDEPEND+=" kde? ( ${kdecommondepend} )" 412 [[ -n ${kdecommondepend} ]] && COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
278 DEPEND+=" kde? ( ${kdedepend} )" 413 [[ -n ${kdedepend} ]] && DEPEND+=" kde? ( ${kdedepend} )"
414 [[ -n ${kderdepend} ]] && RDEPEND+=" kde? ( ${kderdepend} )"
279 ;; 415 ;;
280 *) ;; 416 *) ;;
281esac 417esac
282 418
283unset kdecommondepend kdedepend 419unset kdecommondepend kdedepend kderdepend
284 420
285debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}" 421debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
286debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}" 422debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
287debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}" 423debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
288 424
296 432
297# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a 433# Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
298# koffice ebuild, the URI should be set in the ebuild itself 434# koffice ebuild, the URI should be set in the ebuild itself
299case ${BUILD_TYPE} in 435case ${BUILD_TYPE} in
300 live) 436 live)
301 # Determine branch URL based on live type
302 local branch_prefix
303 case ${PV} in
304 9999*)
305 # trunk
306 branch_prefix="trunk/KDE"
307 ;;
308 *)
309 # branch
310 branch_prefix="branches/KDE/${SLOT}"
311 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
312 # @DESCRIPTION
313 # Suffix appended to ESVN_PROJECT depending on fetched branch.
314 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
315 ESVN_PROJECT_SUFFIX="-${PV}"
316 ;;
317 esac
318 SRC_URI="" 437 SRC_URI=""
438 if has subversion ${INHERITED}; then
439 # Determine branch URL based on live type
440 local branch_prefix
441 case ${PV} in
442 9999*)
443 # trunk
444 branch_prefix="trunk/KDE"
445 ;;
446 *)
447 # branch
448 branch_prefix="branches/KDE/${SLOT}"
449 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
450 # @DESCRIPTION
451 # Suffix appended to ESVN_PROJECT depending on fetched branch.
452 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
453 ESVN_PROJECT_SUFFIX="-${PV}"
454 ;;
455 esac
319 # @ECLASS-VARIABLE: ESVN_MIRROR 456 # @ECLASS-VARIABLE: ESVN_MIRROR
320 # @DESCRIPTION: 457 # @DESCRIPTION:
321 # This variable allows easy overriding of default kde mirror service 458 # This variable allows easy overriding of default kde mirror service
322 # (anonsvn) with anything else you might want to use. 459 # (anonsvn) with anything else you might want to use.
323 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde} 460 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
324 # Split ebuild, or extragear stuff 461 # Split ebuild, or extragear stuff
325 if [[ -n ${KMNAME} ]]; then 462 if [[ -n ${KMNAME} ]]; then
326 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}" 463 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
464 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
465 KMMODULE="${PN}"
466 fi
467 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
468 case ${KMNAME} in
469 kdebase-*)
470 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
471 ;;
472 kdelibs-*)
473 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
474 ;;
475 kdereview*)
476 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
477 ;;
478 kdesupport)
479 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
480 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
481 ;;
482 kde*)
483 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
484 ;;
485 extragear*|playground*)
486 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
487 # build packages from same svn location.
488 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
489 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
490 ;;
491 koffice)
492 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
493 ;;
494 *)
495 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
496 ;;
497 esac
498 else
499 # kdelibs, kdepimlibs
500 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
501 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
502 fi
503 # @ECLASS-VARIABLE: ESVN_UP_FREQ
504 # @DESCRIPTION:
505 # This variable is used for specifying the timeout between svn synces
506 # for kde-base and koffice modules. Does not affect misc apps.
507 # Default value is 1 hour.
508 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
509 elif has git ${INHERITED}; then
327 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then 510 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
328 KMMODULE="${PN}" 511 KMMODULE="${PN}"
329 fi 512 fi
330 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
331 case ${KMNAME} in 513 case ${KDEBASE} in
332 kdebase-*) 514 kdevelop)
333 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}" 515 EGIT_REPO_URI="git://git.kde.org/${KMMODULE}"
334 ;;
335 kdelibs-*)
336 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
337 ;;
338 kdereview*)
339 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
340 ;;
341 kdesupport)
342 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
343 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
344 ;;
345 kde*)
346 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
347 ;;
348 extragear*|playground*)
349 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
350 # build packages from same svn location.
351 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
352 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
353 ;;
354 koffice)
355 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
356 ;;
357 *)
358 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
359 ;; 516 ;;
360 esac 517 esac
361 else
362 # kdelibs, kdepimlibs
363 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
364 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
365 fi 518 fi
366 # @ECLASS-VARIABLE: ESVN_UP_FREQ
367 # @DESCRIPTION:
368 # This variable is used for specifying the timeout between svn synces
369 # for kde-base and koffice modules. Does not affect misc apps.
370 # Default value is 1 hour.
371 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
372 ;; 519 ;;
373 *) 520 *)
374 if [[ -n ${KDEBASE} ]]; then 521 if [[ -n ${KDEBASE} ]]; then
375 if [[ -n ${KMNAME} ]]; then 522 if [[ -n ${KMNAME} ]]; then
376 case ${KMNAME} in 523 case ${KMNAME} in
384 fi 531 fi
385 _kmname_pv="${_kmname}-${PV}" 532 _kmname_pv="${_kmname}-${PV}"
386 case ${KDEBASE} in 533 case ${KDEBASE} in
387 kde-base) 534 kde-base)
388 case ${PV} in 535 case ${PV} in
389 4.3.8[05] | 4.3.9[0568]) 536 4.[456].8[05] | 4.[456].9[023568])
390 # block for normally packed unstable releases 537 # Unstable KDE SC releases
391 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" ;; 538 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2"
392 4.3.[6-9]*)
393 # Repacked tarballs: need to depend on xz-utils to ensure that they can be unpacked
394 SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${PV}/${_kmname_pv}.tar.xz"
395 DEPEND+=" app-arch/xz-utils"
396 ;; 539 ;;
540 4.4.6 | 4.4.7 | 4.4.8)
541 # Only kdepim here
542 SRC_URI="mirror://kde/stable/kdepim-${PV}/src/${_kmname_pv}.tar.bz2"
543 ;;
544 *)
545 # Stable KDE SC releases
397 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;; 546 SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2"
547 ;;
398 esac 548 esac
399 ;; 549 ;;
400 koffice) 550 koffice)
401 case ${PV} in 551 case ${PV} in
402 2.0.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/src/${_kmname_pv}.tar.bz2" ;; 552 2.1.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
403 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;; 553 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
404 esac 554 esac
555 ;;
556 kdevelop)
557 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
558 ;;
405 esac 559 esac
406 unset _kmname _kmname_pv 560 unset _kmname _kmname_pv
407 fi 561 fi
408 ;; 562 ;;
409esac 563esac
438 # Don't set KDEHOME during compilation, it will cause access violations 592 # Don't set KDEHOME during compilation, it will cause access violations
439 unset KDEHOME 593 unset KDEHOME
440 594
441 if [[ ${KDEBASE} = kde-base ]]; then 595 if [[ ${KDEBASE} = kde-base ]]; then
442 if use kdeprefix; then 596 if use kdeprefix; then
443 KDEDIR=${EPREFIX}/usr/kde/${_kdedir} 597 KDEDIR=/usr/kde/${SLOT}
444 else 598 else
445 KDEDIR=${EPREFIX}/usr 599 KDEDIR=/usr
446 fi 600 fi
447 : ${PREFIX:=${KDEDIR}} 601 : ${PREFIX:=${KDEDIR}}
448 else 602 else
449 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL 603 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
450 KDEDIR= 604 KDEDIR=
451 local kde_minimal_met 605 local kde_minimal_met
452 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do 606 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
453 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1 607 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
454 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then 608 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
455 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then 609 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
456 KDEDIR=${EPREFIX}/usr/kde/${slot} 610 KDEDIR=/usr/kde/${slot}
457 else 611 else
458 KDEDIR=${EPREFIX}/usr 612 KDEDIR=/usr
459 fi 613 fi
460 break; 614 break;
461 fi 615 fi
462 done 616 done
463 unset slot 617 unset slot
464 618
465 # Bail out if kdelibs required but not found 619 # Bail out if kdelibs required but not found
466 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then 620 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
467 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!" 621 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
468 else 622 else
469 [[ -z ${KDEDIR} ]] && KDEDIR=${EPREFIX}/usr 623 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
470 fi
471
472 : ${PREFIX:=${EPREFIX}/usr}
473 fi 624 fi
625
626 : ${PREFIX:=/usr}
627 fi
628 EKDEDIR=${EPREFIX}${KDEDIR}
629
474 # Point pkg-config path to KDE *.pc files 630 # Point pkg-config path to KDE *.pc files
475 export PKG_CONFIG_PATH="${KDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}" 631 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
476 # Point to correct QT plugins path 632 # Point to correct QT plugins path
477 QT_PLUGIN_PATH="${KDEDIR}/$(get_libdir)/kde4/plugins/" 633 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
478 634
479 # Fix XDG collision with sandbox 635 # Fix XDG collision with sandbox
480 export XDG_CONFIG_HOME="${T}" 636 export XDG_CONFIG_HOME="${T}"
481 # Not needed anymore
482 unset _kdedir
483} 637}
484 638
485# @FUNCTION: kde4-base_src_unpack 639# @FUNCTION: kde4-base_src_unpack
486# @DESCRIPTION: 640# @DESCRIPTION:
487# This function unpacks the source tarballs for KDE4 applications. 641# This function unpacks the source tarballs for KDE4 applications.
488kde4-base_src_unpack() { 642kde4-base_src_unpack() {
489 debug-print-function ${FUNCNAME} "$@" 643 debug-print-function ${FUNCNAME} "$@"
490 644
491 if [[ ${BUILD_TYPE} = live ]]; then 645 if [[ ${BUILD_TYPE} = live ]]; then
646 if has subversion ${INHERITED}; then
492 migrate_store_dir 647 migrate_store_dir
493 subversion_src_unpack 648 subversion_src_unpack
649 elif has git ${INHERITED}; then
650 git_src_unpack
651 fi
494 elif [[ ${EAPI} == [23] ]]; then 652 elif [[ ${EAPI} == 2 ]]; then
495 local file 653 local file
496 for file in ${A}; do 654 for file in ${A}; do
497 # This setup is because EAPI <= 3 cannot unpack *.tar.xz files 655 # This setup is because EAPI <= 2 cannot unpack *.tar.xz files
498 # directly, so we do it ourselves (using the exact same code as portage) 656 # directly, so we do it ourselves (using the exact same code as portage)
499 case ${file} in 657 case ${file} in
500 *.tar.xz) 658 *.tar.xz)
501 echo ">>> Unpacking ${file} to ${PWD}" 659 echo ">>> Unpacking ${file} to ${PWD}"
502 xz -dc "${DISTDIR}"/${file} | tar xof - 660 xz -dc "${DISTDIR}"/${file} | tar xof -
506 unpack ${file} 664 unpack ${file}
507 ;; 665 ;;
508 esac 666 esac
509 done 667 done
510 else 668 else
511 # For EAPI >= 4, we can just use unpack() directly 669 # For EAPI >= 3, we can just use unpack() directly
512 unpack ${A} 670 unpack ${A}
513 fi 671 fi
514} 672}
515 673
516# @FUNCTION: kde4-base_src_prepare 674# @FUNCTION: kde4-base_src_prepare
532 # kdelibs inherits kde4-base but handle installing the handbook itself 690 # kdelibs inherits kde4-base but handle installing the handbook itself
533 if ! has kde4-meta ${INHERITED}; then 691 if ! has kde4-meta ${INHERITED}; then
534 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas 692 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas
535 fi 693 fi
536 694
537 [[ ${BUILD_TYPE} = live ]] && subversion_src_prepare 695 # SCM bootstrap
696 if [[ ${BUILD_TYPE} = live ]]; then
697 if has subversion ${INHERITED}; then
698 subversion_src_prepare
699 elif has git ${INHERITED}; then
700 git_src_prepare
701 fi
702 fi
703
704 # Apply patches
538 base_src_prepare 705 base_src_prepare
539 706
540 # Save library dependencies 707 # Save library dependencies
541 if [[ -n ${KMSAVELIBS} ]] ; then 708 if [[ -n ${KMSAVELIBS} ]] ; then
542 save_library_dependencies 709 save_library_dependencies
543 fi 710 fi
544 711
545 # Inject library dependencies 712 # Inject library dependencies
546 if [[ -n ${KMLOADLIBS} ]] ; then 713 if [[ -n ${KMLOADLIBS} ]] ; then
547 load_library_dependencies 714 load_library_dependencies
715 fi
716
717 # Replace KDE4Workspace library targets
718 find "${S}" -name CMakeLists.txt \
719 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_TASKMANAGER_(LIBRARY|LIBS)\}/taskmanager/g' {} + \
720 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWORKSPACE_(LIBRARY|LIBS)\}/kworkspace/g' {} + \
721 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROLIFACES_(LIBRARY|LIBS)\}/solidcontrolifaces/g' {} + \
722 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_SOLIDCONTROL_(LIBRARY|LIBS)\}/solidcontrol/g' {} + \
723 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PROCESSUI_(LIBRARY|LIBS)\}/processui/g' {} + \
724 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_LSOFUI_(LIBRARY|LIBS)\}/lsofui/g' {} + \
725 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_PLASMACLOCK_(LIBRARY|LIBS)\}/plasmaclock/g' {} + \
726 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERYCLIENT_(LIBRARY|LIBS)\}/nepomukqueryclient/g' {} + \
727 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_NEPOMUKQUERY_(LIBRARY|LIBS)\}/nepomukquery/g' {} + \
728 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSCREENSAVER_(LIBRARY|LIBS)\}/kscreensaver/g' {} + \
729 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_WEATHERION_(LIBRARY|LIBS)\}/weather_ion/g' {} + \
730 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KWINEFFECTS_(LIBRARY|LIBS)\}/kwineffects/g' {} + \
731 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KDECORATIONS_(LIBRARY|LIBS)\}/kdecorations/g' {} + \
732 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KSGRD_(LIBRARY|LIBS)\}/ksgrd/g' {} + \
733 -exec sed -i -r -e 's/\$\{KDE4WORKSPACE_KEPHAL_(LIBRARY|LIBS)\}/kephal/g' {} + \
734 || die 'failed to replace KDE4Workspace library targets'
735
736 # Hack for manuals relying on outdated DTD, only outside kde-base/koffice/...
737 if [[ -z ${KDEBASE} ]]; then
738 find "${S}" -name "*.docbook" \
739 -exec sed -i -r \
740 -e 's:-//KDE//DTD DocBook XML V4\.1(\..)?-Based Variant V1\.[01]//EN:-//KDE//DTD DocBook XML V4.2-Based Variant V1.1//EN:g' {} + \
741 || die 'failed to fix DocBook variant version'
548 fi 742 fi
549} 743}
550 744
551# @FUNCTION: kde4-base_src_configure 745# @FUNCTION: kde4-base_src_configure
552# @DESCRIPTION: 746# @DESCRIPTION:
571 765
572 # Set distribution name 766 # Set distribution name
573 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo) 767 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
574 768
575 # Here we set the install prefix 769 # Here we set the install prefix
576 cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${PREFIX}") 770 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
577 771
578 # Use colors 772 # Use colors
579 QTEST_COLORED=1 773 QTEST_COLORED=1
580 774
581 # Shadow existing /usr installations 775 # Shadow existing /usr installations
582 unset KDEDIRS 776 unset KDEDIRS
583 777
584 # Handle kdeprefix-ed KDE 778 # Handle kdeprefix-ed KDE
585 if [[ ${KDEDIR} != ${EPREFIX}/usr ]]; then 779 if [[ ${KDEDIR} != /usr ]]; then
586 # Override some environment variables - only when kdeprefix is different, 780 # Override some environment variables - only when kdeprefix is different,
587 # to not break ccache/distcc 781 # to not break ccache/distcc
588 PATH="${KDEDIR}/bin:${PATH}" 782 PATH="${EKDEDIR}/bin:${PATH}"
589 LDPATH="${KDEDIR}/$(get_libdir):${LDPATH}" 783
784 # Append library search path
785 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
590 786
591 # Append full RPATH 787 # Append full RPATH
592 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF) 788 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
593 789
594 # Set cmake prefixes to allow buildsystem to locate valid KDE installation 790 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
595 # when more are present 791 # when more are present
596 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${KDEDIR}") 792 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
597 fi 793 fi
794
795 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
796 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4)
797 #kde-config -path data unavailable when cross-compiling
798 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
598 799
599 # Handle kdeprefix in application itself 800 # Handle kdeprefix in application itself
600 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then 801 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
601 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc 802 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
602 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc) 803 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
603 fi 804 fi
604 805
605 if [[ $(declare -p mycmakeargs) != "declare -a mycmakeargs="* ]]; then 806 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
606 mycmakeargs=(${mycmakeargs}) 807 mycmakeargs=(${mycmakeargs})
607 fi 808 fi
608 809
609 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}") 810 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
610 811
629 # Override this value, set in kde4-base_src_configure() 830 # Override this value, set in kde4-base_src_configure()
630 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON) 831 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
631 cmake-utils_src_configure 832 cmake-utils_src_configure
632 kde4-base_src_compile 833 kde4-base_src_compile
633 834
835 if [[ ${VIRTUALX_REQUIRED} == always ]] ||
836 ( [[ ${VIRTUALX_REQUIRED} != manual ]] && use test ); then
837
838 if [[ ${maketype} ]]; then
839 # surprise- we are already INSIDE virtualmake!!!
840 ewarn "QA Notice: This version of kde4-base.eclass includes the virtualx functionality."
841 ewarn " You may NOT set maketype or call virtualmake from the ebuild. Applying workaround."
842 cmake-utils_src_test
843 else
844 export maketype="cmake-utils_src_test"
845 virtualmake
846 fi
847 else
634 cmake-utils_src_test 848 cmake-utils_src_test
849 fi
635} 850}
636 851
637# @FUNCTION: kde4-base_src_install 852# @FUNCTION: kde4-base_src_install
638# @DESCRIPTION: 853# @DESCRIPTION:
639# Function for installing KDE4 applications. 854# Function for installing KDE4 applications.
640kde4-base_src_install() { 855kde4-base_src_install() {
641 debug-print-function ${FUNCNAME} "$@" 856 debug-print-function ${FUNCNAME} "$@"
642 857
858 # Prefix support, for usage in ebuilds
859 if [[ ${EAPI} == 2 ]] && ! use prefix; then
860 ED=${D}
861 fi
862
643 if [[ -n ${KMSAVELIBS} ]] ; then 863 if [[ -n ${KMSAVELIBS} ]] ; then
644 install_library_dependencies 864 install_library_dependencies
645 fi 865 fi
646 866
647 kde4-base_src_make_doc 867 # Install common documentation of KDE4 applications
868 local doc
869 if ! has kde4-meta ${INHERITED}; then
870 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
871 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && dodoc "${doc}"
872 done
873 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
874 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
875 done
876 fi
877
648 cmake-utils_src_install 878 cmake-utils_src_install
649}
650
651# @FUNCTION: kde4-base_src_make_doc
652# @DESCRIPTION:
653# Function for installing the documentation of KDE4 applications.
654kde4-base_src_make_doc() {
655 debug-print-function ${FUNCNAME} "$@"
656
657 local doc
658 for doc in AUTHORS ChangeLog* README* NEWS TODO; do
659 [[ -s ${doc} ]] && dodoc ${doc}
660 done
661
662 if [[ -z ${KMNAME} ]]; then
663 for doc in {apps,runtime,workspace,.}/*/{AUTHORS,README*}; do
664 if [[ -s ${doc} ]]; then
665 local doc_complete=${doc}
666 doc="${doc#*/}"
667 newdoc "$doc_complete" "${doc%/*}.${doc##*/}"
668 fi
669 done
670 fi
671
672 [[ -z ${ED} ]] && ED=${D}${EPREFIX}
673
674 if [[ -n ${KDEBASE} ]] && [[ -d ${ED}usr/share/doc/${PF} ]]; then
675 # work around bug #97196
676 dodir /usr/share/doc/KDE4 && \
677 cp -r "${ED}usr/share/doc/${PF}" "${ED}usr/share/doc/KDE4/" || \
678 die "Failed to move docs to KDE4/."
679 rm -rf "${ED}usr/share/doc/${PF}"
680 fi
681} 879}
682 880
683# @FUNCTION: kde4-base_pkg_postinst 881# @FUNCTION: kde4-base_pkg_postinst
684# @DESCRIPTION: 882# @DESCRIPTION:
685# Function to rebuild the KDE System Configuration Cache after an application has been installed. 883# Function to rebuild the KDE System Configuration Cache after an application has been installed.
702 ewarn "with KDE update strategies." 900 ewarn "with KDE update strategies."
703 ewarn "You are using this setup at your own risk and the kde team does not" 901 ewarn "You are using this setup at your own risk and the kde team does not"
704 ewarn "take responsibilities for dead kittens." 902 ewarn "take responsibilities for dead kittens."
705 echo 903 echo
706 fi 904 fi
905 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && ! has_version 'kde-base/kdebase-runtime-meta' && ! has_version 'kde-base/kdebase-startkde'; then
906 # warn about not supported approach
907 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
908 echo
909 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
910 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
911 ewarn "With this setting you are unsupported by KDE team."
912 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
913 fi
914 fi
707} 915}
708 916
709# @FUNCTION: kde4-base_pkg_postrm 917# @FUNCTION: kde4-base_pkg_postrm
710# @DESCRIPTION: 918# @DESCRIPTION:
711# Function to rebuild the KDE System Configuration Cache after an application has been removed. 919# Function to rebuild the KDE System Configuration Cache after an application has been removed.

Legend:
Removed from v.1.56  
changed lines
  Added in v.1.79

  ViewVC Help
Powered by ViewVC 1.1.20