/[gentoo-x86]/eclass/kde4-base.eclass
Gentoo

Contents of /eclass/kde4-base.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.64 - (show annotations) (download)
Sat Jun 26 01:33:21 2010 UTC (4 years, 5 months ago) by reavertm
Branch: MAIN
Changes since 1.63: +3 -3 lines
Add USE dep on accessibility for Qt packages, see bug 325461

1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.63 2010/06/22 13:49:08 reavertm Exp $
4
5 # @ECLASS: kde4-base.eclass
6 # @MAINTAINER:
7 # kde@gentoo.org
8 # @BLURB: This eclass provides functions for kde 4.X ebuilds
9 # @DESCRIPTION:
10 # The kde4-base.eclass provides support for building KDE4 based ebuilds
11 # and KDE4 applications.
12 #
13 # NOTE: KDE 4 ebuilds by default define EAPI="2", this can be redefined but
14 # eclass will fail with version older than 2.
15
16 inherit kde4-functions base eutils
17
18 get_build_type
19 if [[ ${BUILD_TYPE} = live ]]; then
20 if [[ ${KDEBASE} = kdevelop ]]; then
21 inherit git
22 else
23 inherit subversion
24 fi
25 fi
26
27 # @ECLASS-VARIABLE: CMAKE_REQUIRED
28 # @DESCRIPTION:
29 # Specify if cmake buildsystem is being used. Possible values are 'always' and 'never'.
30 # Please note that if it's set to 'never' you need to explicitly override following phases:
31 # src_configure, src_compile, src_test and src_install.
32 # Defaults to 'always'.
33 : ${CMAKE_REQUIRED:=always}
34 if [[ ${CMAKE_REQUIRED} = always ]]; then
35 buildsystem_eclass="cmake-utils"
36 export_fns="src_configure src_compile src_test src_install"
37 fi
38
39 # Verify KDE_MINIMAL (display QA notice in pkg_setup, still we need to fix it here)
40 if [[ -n ${KDE_MINIMAL} ]]; then
41 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
42 [[ ${KDE_MINIMAL} = ${slot} ]] && KDE_MINIMAL_VALID=1 && break
43 done
44 unset slot
45 [[ -z ${KDE_MINIMAL_VALID} ]] && unset KDE_MINIMAL
46 else
47 KDE_MINIMAL_VALID=1
48 fi
49
50 # @ECLASS-VARIABLE: KDE_MINIMAL
51 # @DESCRIPTION:
52 # This variable is used when KDE_REQUIRED is set, to specify required KDE minimal
53 # version for apps to work. Currently defaults to 4.3
54 # One may override this variable to raise version requirements.
55 # For possible values look at KDE_SLOTS and KDE_LIVE_SLOTS variables.
56 # Note that it is fixed to ${SLOT} for kde-base packages.
57 KDE_MINIMAL="${KDE_MINIMAL:-4.3}"
58
59 # Set slot for packages in kde-base, koffice and kdevelop
60 case ${KDEBASE} in
61 kde-base)
62 # Determine SLOT from PVs
63 case ${PV} in
64 *.9999*) SLOT="${PV/.9999*/}" ;; # stable live
65 4.5* | 4.4.[6-9]*) SLOT="4.5" ;;
66 4.4* | 4.3.[6-9]*) SLOT="4.4" ;;
67 4.3*) SLOT="4.3" ;;
68 9999*) SLOT="live" ;; # regular live
69 *) die "Unsupported ${PV}" ;;
70 esac
71 KDE_MINIMAL="${SLOT}"
72 ;;
73 koffice)
74 SLOT="2"
75 ;;
76 kdevelop)
77 if [[ ${BUILD_TYPE} = live ]]; then
78 KDEVELOP_VERSION="9999"
79 KDEVPLATFORM_VERSION="9999"
80 else
81 case ${PN} in
82 kdevelop|quanta)
83 KDEVELOP_VERSION=${PV}
84 KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
85 ;;
86 *)
87 KDEVELOP_VERSION="$(($(get_major_version)+3)).$(get_after_major_version)"
88 KDEVPLATFORM_VERSION=${PV}
89 esac
90 fi
91 SLOT="4"
92 ;;
93 esac
94
95 slot_is_at_least 4.5 ${KDE_MINIMAL} && CMAKE_MIN_VERSION="2.6.4"
96
97 inherit ${buildsystem_eclass}
98
99 EXPORT_FUNCTIONS pkg_setup src_unpack src_prepare ${export_fns} pkg_postinst pkg_postrm
100
101 unset buildsystem_eclass
102 unset export_fns
103
104 case ${KDEBASE} in
105 kde-base)
106 HOMEPAGE="http://www.kde.org/"
107 LICENSE="GPL-2"
108 ;;
109 koffice)
110 HOMEPAGE="http://www.koffice.org/"
111 LICENSE="GPL-2"
112 ;;
113 kdevelop)
114 HOMEPAGE="http://www.kdevelop.org/"
115 LICENSE="GPL-2"
116 ;;
117 esac
118
119 # @ECLASS-VARIABLE: OPENGL_REQUIRED
120 # @DESCRIPTION:
121 # Is qt-opengl required? Possible values are 'always', 'optional' and 'never'.
122 # This variable must be set before inheriting any eclasses. Defaults to 'never'.
123 OPENGL_REQUIRED="${OPENGL_REQUIRED:-never}"
124
125 # @ECLASS-VARIABLE: MULTIMEDIA_REQUIRED
126 # @DESCRIPTION:
127 # Is qt-multimedia required? Possible values are 'always', 'optional' and 'never'.
128 # This variable must be set before inheriting any eclasses. Defaults to 'never'.
129 MULTIMEDIA_REQUIRED="${MULTIMEDIA_REQUIRED:-never}"
130
131 # @ECLASS-VARIABLE: WEBKIT_REQUIRED
132 # @DESCRIPTION:
133 # Is qt-webkit requred? Possible values are 'always', 'optional' and 'never'.
134 # This variable must be set before inheriting any eclasses. Defaults to 'never'.
135 WEBKIT_REQUIRED="${WEBKIT_REQUIRED:-never}"
136
137 # @ECLASS-VARIABLE: CPPUNIT_REQUIRED
138 # @DESCRIPTION:
139 # Is cppunit required for tests? Possible values are 'always', 'optional' and 'never'.
140 # This variable must be set before inheriting any eclasses. Defaults to 'never'.
141 CPPUNIT_REQUIRED="${CPPUNIT_REQUIRED:-never}"
142
143 # @ECLASS-VARIABLE: KDE_REQUIRED
144 # @DESCRIPTION:
145 # Is kde required? Possible values are 'always', 'optional' and 'never'.
146 # This variable must be set before inheriting any eclasses. Defaults to 'always'
147 # If set to always or optional, KDE_MINIMAL may be overriden as well.
148 # Note that for kde-base packages this variable is fixed to 'always'.
149 KDE_REQUIRED="${KDE_REQUIRED:-always}"
150
151 # Setup packages inheriting this eclass
152 case ${KDEBASE} in
153 kde-base)
154 if [[ $BUILD_TYPE = live ]]; then
155 # Disable tests for live ebuilds
156 RESTRICT+=" test"
157 # Live ebuilds in kde-base default to kdeprefix by default
158 IUSE+=" +kdeprefix"
159 else
160 # All other ebuild types default to -kdeprefix as before
161 IUSE+=" kdeprefix"
162 fi
163 # This code is to prevent portage from searching GENTOO_MIRRORS for
164 # packages that will never be mirrored. (As they only will ever be in
165 # the overlay).
166 case ${PV} in
167 *9999* | 4.?.[6-9]?)
168 RESTRICT+=" mirror"
169 ;;
170 esac
171 # Block installation of other SLOTS unless kdeprefix
172 RDEPEND+=" $(block_other_slots)"
173 ;;
174 esac
175
176 # @ECLASS-VARIABLE: QT_MINIMAL
177 # @DESCRIPTION:
178 # Determine version of qt we enforce as minimal for the package. 4.4.0 4.5.1..
179 # Currently defaults to 4.5.1 for KDE 4.3 and earlier
180 # or 4.6.0 for KDE 4.4 and later
181 if slot_is_at_least 4.4 "${KDE_MINIMAL}"; then
182 QT_MINIMAL="${QT_MINIMAL:-4.6.0}"
183 fi
184
185 QT_MINIMAL="${QT_MINIMAL:-4.5.1}"
186
187 # OpenGL dependencies
188 qtopengldepend="
189 >=x11-libs/qt-opengl-${QT_MINIMAL}:4
190 "
191 case ${OPENGL_REQUIRED} in
192 always)
193 COMMONDEPEND+=" ${qtopengldepend}"
194 ;;
195 optional)
196 IUSE+=" opengl"
197 COMMONDEPEND+=" opengl? ( ${qtopengldepend} )"
198 ;;
199 *) ;;
200 esac
201 unset qtopengldepend
202
203 # MultiMedia dependencies
204 qtmultimediadepend="
205 >=x11-libs/qt-multimedia-${QT_MINIMAL}:4
206 "
207 case ${MULTIMEDIA_REQUIRED} in
208 always)
209 COMMONDEPEND+=" ${qtmultimediadepend}"
210 ;;
211 optional)
212 IUSE+=" multimedia"
213 COMMONDEPEND+=" multimedia? ( ${qtmultimediadepend} )"
214 ;;
215 *) ;;
216 esac
217 unset qtmultimediadepend
218
219 # WebKit dependencies
220 case ${KDE_REQUIRED} in
221 always)
222 qtwebkitusedeps="[kde]"
223 ;;
224 optional)
225 qtwebkitusedeps="[kde?]"
226 ;;
227 *) ;;
228 esac
229 qtwebkitdepend="
230 >=x11-libs/qt-webkit-${QT_MINIMAL}:4${qtwebkitusedeps}
231 "
232 unset qtwebkitusedeps
233 case ${WEBKIT_REQUIRED} in
234 always)
235 COMMONDEPEND+=" ${qtwebkitdepend}"
236 ;;
237 optional)
238 IUSE+=" webkit"
239 COMMONDEPEND+=" webkit? ( ${qtwebkitdepend} )"
240 ;;
241 *) ;;
242 esac
243 unset qtwebkitdepend
244
245 # CppUnit dependencies
246 cppuintdepend="
247 dev-util/cppunit
248 "
249 case ${CPPUNIT_REQUIRED} in
250 always)
251 DEPEND+=" ${cppuintdepend}"
252 ;;
253 optional)
254 IUSE+=" test"
255 DEPEND+=" test? ( ${cppuintdepend} )"
256 ;;
257 *) ;;
258 esac
259 unset cppuintdepend
260
261 # KDE dependencies
262 kdecommondepend="
263 >=x11-libs/qt-core-${QT_MINIMAL}:4[qt3support,ssl]
264 >=x11-libs/qt-gui-${QT_MINIMAL}:4[accessibility,dbus]
265 >=x11-libs/qt-qt3support-${QT_MINIMAL}:4[accessibility,kde]
266 >=x11-libs/qt-script-${QT_MINIMAL}:4
267 >=x11-libs/qt-sql-${QT_MINIMAL}:4[qt3support]
268 >=x11-libs/qt-svg-${QT_MINIMAL}:4
269 >=x11-libs/qt-test-${QT_MINIMAL}:4
270 !aqua? (
271 x11-libs/libXext
272 x11-libs/libXt
273 x11-libs/libXxf86vm
274 )
275 "
276 #perl is not needed on host (+ difficult crosscompilation)
277 tc-is-cross-compiler || kdecommondepend="$kdecommondepend dev-lang/perl"
278
279 if [[ ${PN} != kdelibs ]]; then
280 if [[ ${KDEBASE} = kde-base ]]; then
281 kdecommondepend+=" $(add_kdebase_dep kdelibs)"
282 # libknotificationitem only when SLOT is 4.3
283 [[ ${PN} != libknotificationitem ]] && [[ ${SLOT} = 4.3 ]] && \
284 kdecommondepend+=" $(add_kdebase_dep libknotificationitem)"
285 else
286 kdecommondepend+="
287 >=kde-base/kdelibs-${KDE_MINIMAL}
288 "
289 if [[ ${KDEBASE} = kdevelop ]]; then
290 if [[ ${PN} != kdevplatform ]]; then
291 kdecommondepend+="
292 >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
293 "
294 fi
295 fi
296 fi
297 fi
298 kdedepend="
299 dev-util/automoc
300 dev-util/pkgconfig
301 !aqua? (
302 || ( >=x11-libs/libXtst-1.1.0 <x11-proto/xextproto-7.1.0 )
303 x11-proto/xf86vidmodeproto
304 )
305 "
306 case ${KDE_REQUIRED} in
307 always)
308 IUSE+=" aqua"
309 COMMONDEPEND+=" ${kdecommondepend}"
310 DEPEND+=" ${kdedepend}"
311 ;;
312 optional)
313 IUSE+=" aqua kde"
314 COMMONDEPEND+=" kde? ( ${kdecommondepend} )"
315 DEPEND+=" kde? ( ${kdedepend} )"
316 ;;
317 *) ;;
318 esac
319
320 unset kdecommondepend kdedepend
321
322 debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: COMMONDEPEND is ${COMMONDEPEND}"
323 debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: DEPEND (only) is ${DEPEND}"
324 debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: RDEPEND (only) is ${RDEPEND}"
325
326 # Accumulate dependencies set by this eclass
327 DEPEND+=" ${COMMONDEPEND}"
328 RDEPEND+=" ${COMMONDEPEND}"
329 unset COMMONDEPEND
330
331 # Add experimental kdeenablefinal, disabled by default
332 IUSE+=" kdeenablefinal"
333
334 # Fetch section - If the ebuild's category is not 'kde-base' and if it is not a
335 # koffice ebuild, the URI should be set in the ebuild itself
336 case ${BUILD_TYPE} in
337 live)
338 SRC_URI=""
339 if has subversion ${INHERITED}; then
340 # Determine branch URL based on live type
341 local branch_prefix
342 case ${PV} in
343 9999*)
344 # trunk
345 branch_prefix="trunk/KDE"
346 ;;
347 *)
348 # branch
349 branch_prefix="branches/KDE/${SLOT}"
350 # @ECLASS-VARIABLE: ESVN_PROJECT_SUFFIX
351 # @DESCRIPTION
352 # Suffix appended to ESVN_PROJECT depending on fetched branch.
353 # Defaults is empty (for -9999 = trunk), and "-${PV}" otherwise.
354 ESVN_PROJECT_SUFFIX="-${PV}"
355 ;;
356 esac
357 # @ECLASS-VARIABLE: ESVN_MIRROR
358 # @DESCRIPTION:
359 # This variable allows easy overriding of default kde mirror service
360 # (anonsvn) with anything else you might want to use.
361 ESVN_MIRROR=${ESVN_MIRROR:=svn://anonsvn.kde.org/home/kde}
362 # Split ebuild, or extragear stuff
363 if [[ -n ${KMNAME} ]]; then
364 ESVN_PROJECT="${KMNAME}${ESVN_PROJECT_SUFFIX}"
365 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
366 KMMODULE="${PN}"
367 fi
368 # Split kde-base/ ebuilds: (they reside in trunk/KDE)
369 case ${KMNAME} in
370 kdebase-*)
371 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdebase/${KMNAME#kdebase-}"
372 ;;
373 kdelibs-*)
374 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/kdelibs/${KMNAME#kdelibs-}"
375 ;;
376 kdereview*)
377 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
378 ;;
379 kdesupport)
380 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
381 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
382 ;;
383 kde*)
384 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${KMNAME}"
385 ;;
386 extragear*|playground*)
387 # Unpack them in toplevel dir, so that they won't conflict with kde4-meta
388 # build packages from same svn location.
389 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
390 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
391 ;;
392 koffice)
393 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}"
394 ;;
395 *)
396 ESVN_REPO_URI="${ESVN_MIRROR}/trunk/${KMNAME}/${KMMODULE}"
397 ;;
398 esac
399 else
400 # kdelibs, kdepimlibs
401 ESVN_REPO_URI="${ESVN_MIRROR}/${branch_prefix}/${PN}"
402 ESVN_PROJECT="${PN}${ESVN_PROJECT_SUFFIX}"
403 fi
404 # @ECLASS-VARIABLE: ESVN_UP_FREQ
405 # @DESCRIPTION:
406 # This variable is used for specifying the timeout between svn synces
407 # for kde-base and koffice modules. Does not affect misc apps.
408 # Default value is 1 hour.
409 [[ ${KDEBASE} = kde-base || ${KDEBASE} = koffice ]] && ESVN_UP_FREQ=${ESVN_UP_FREQ:-1}
410 elif has git ${INHERITED}; then
411 if [[ -z ${KMNOMODULE} ]] && [[ -z ${KMMODULE} ]]; then
412 KMMODULE="${PN}"
413 fi
414 case ${KDEBASE} in
415 kdevelop)
416 EGIT_REPO_URI="git://gitorious.org/${KMNAME}/${KMMODULE}.git"
417 ;;
418 esac
419 fi
420 ;;
421 *)
422 if [[ -n ${KDEBASE} ]]; then
423 if [[ -n ${KMNAME} ]]; then
424 case ${KMNAME} in
425 kdebase-apps)
426 _kmname="kdebase" ;;
427 *)
428 _kmname="${KMNAME}" ;;
429 esac
430 else
431 _kmname=${PN}
432 fi
433 _kmname_pv="${_kmname}-${PV}"
434 case ${KDEBASE} in
435 kde-base)
436 case ${PV} in
437 4.[34].8[05] | 4.[34].9[0568])
438 # block for normally packed unstable releases
439 SRC_URI="mirror://kde/unstable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
440 4.[34].[6-9]*)
441 # Repacked tarballs: need to depend on xz-utils to ensure that they can be unpacked
442 SRC_URI="http://dev.gentooexperimental.org/~alexxy/kde/${PV}/src/${_kmname_pv}.tar.xz"
443 DEPEND+=" app-arch/xz-utils"
444 ;;
445 *) SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.bz2" ;;
446 esac
447 ;;
448 koffice)
449 case ${PV} in
450 2.1.[6-9]*) SRC_URI="mirror://kde/unstable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
451 *) SRC_URI="mirror://kde/stable/${_kmname_pv}/${_kmname_pv}.tar.bz2" ;;
452 esac
453 ;;
454 kdevelop)
455 SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.bz2"
456 ;;
457 esac
458 unset _kmname _kmname_pv
459 fi
460 ;;
461 esac
462
463 debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
464
465 # @ECLASS-VARIABLE: PREFIX
466 # @DESCRIPTION:
467 # Set the installation PREFIX for non kde-base applications. It defaults to /usr.
468 # kde-base packages go into KDE4 installation directory (KDEDIR) by default.
469 # No matter the PREFIX, package will be built against KDE installed in KDEDIR.
470
471 # @FUNCTION: kde4-base_pkg_setup
472 # @DESCRIPTION:
473 # Do the basic kdeprefix KDEDIR settings and determine with which kde should
474 # optional applications link
475 kde4-base_pkg_setup() {
476 debug-print-function ${FUNCNAME} "$@"
477
478 # Prefix compat:
479 if [[ ${EAPI} == 2 ]] && ! use prefix; then
480 EPREFIX=
481 EROOT=${ROOT}
482 fi
483
484 # Append missing trailing slash character
485 [[ ${EROOT} = */ ]] || EROOT+="/"
486
487 # QA ebuilds
488 [[ -z ${KDE_MINIMAL_VALID} ]] && ewarn "QA Notice: ignoring invalid KDE_MINIMAL (defaulting to ${KDE_MINIMAL})."
489
490 # Don't set KDEHOME during compilation, it will cause access violations
491 unset KDEHOME
492
493 if [[ ${KDEBASE} = kde-base ]]; then
494 if use kdeprefix; then
495 KDEDIR=/usr/kde/${SLOT}
496 else
497 KDEDIR=/usr
498 fi
499 : ${PREFIX:=${KDEDIR}}
500 else
501 # Determine KDEDIR by loooking for the closest match with KDE_MINIMAL
502 KDEDIR=
503 local kde_minimal_met
504 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
505 [[ -z ${kde_minimal_met} ]] && [[ ${slot} = ${KDE_MINIMAL} ]] && kde_minimal_met=1
506 if [[ -n ${kde_minimal_met} ]] && has_version "kde-base/kdelibs:${slot}"; then
507 if has_version "kde-base/kdelibs:${slot}[kdeprefix]"; then
508 KDEDIR=/usr/kde/${slot}
509 else
510 KDEDIR=/usr
511 fi
512 break;
513 fi
514 done
515 unset slot
516
517 # Bail out if kdelibs required but not found
518 if [[ ${KDE_REQUIRED} = always ]] || { [[ ${KDE_REQUIRED} = optional ]] && use kde; }; then
519 [[ -z ${KDEDIR} ]] && die "Failed to determine KDEDIR!"
520 else
521 [[ -z ${KDEDIR} ]] && KDEDIR=/usr
522 fi
523
524 : ${PREFIX:=/usr}
525 fi
526 EKDEDIR=${EPREFIX}${KDEDIR}
527
528 # Point pkg-config path to KDE *.pc files
529 export PKG_CONFIG_PATH="${EKDEDIR}/$(get_libdir)/pkgconfig${PKG_CONFIG_PATH:+:${PKG_CONFIG_PATH}}"
530 # Point to correct QT plugins path
531 QT_PLUGIN_PATH="${EKDEDIR}/$(get_libdir)/kde4/plugins/"
532
533 # Fix XDG collision with sandbox
534 export XDG_CONFIG_HOME="${T}"
535 }
536
537 # @FUNCTION: kde4-base_src_unpack
538 # @DESCRIPTION:
539 # This function unpacks the source tarballs for KDE4 applications.
540 kde4-base_src_unpack() {
541 debug-print-function ${FUNCNAME} "$@"
542
543 if [[ ${BUILD_TYPE} = live ]]; then
544 if has subversion ${INHERITED}; then
545 migrate_store_dir
546 subversion_src_unpack
547 elif has git ${INHERITED}; then
548 git_src_unpack
549 fi
550 elif [[ ${EAPI} == 2 ]]; then
551 local file
552 for file in ${A}; do
553 # This setup is because EAPI <= 2 cannot unpack *.tar.xz files
554 # directly, so we do it ourselves (using the exact same code as portage)
555 case ${file} in
556 *.tar.xz)
557 echo ">>> Unpacking ${file} to ${PWD}"
558 xz -dc "${DISTDIR}"/${file} | tar xof -
559 assert "failed unpacking ${file}"
560 ;;
561 *)
562 unpack ${file}
563 ;;
564 esac
565 done
566 else
567 # For EAPI >= 3, we can just use unpack() directly
568 unpack ${A}
569 fi
570 }
571
572 # @FUNCTION: kde4-base_src_prepare
573 # @DESCRIPTION:
574 # General pre-configure and pre-compile function for KDE4 applications.
575 # It also handles translations if KDE_LINGUAS is defined. See KDE_LINGUAS and
576 # enable_selected_linguas() and enable_selected_doc_linguas()
577 # in kde4-functions.eclass(5) for further details.
578 kde4-base_src_prepare() {
579 debug-print-function ${FUNCNAME} "$@"
580
581 # Only enable selected languages, used for KDE extragear apps.
582 if [[ -n ${KDE_LINGUAS} ]]; then
583 enable_selected_linguas
584 fi
585
586 # Enable/disable handbooks for kde4-base packages
587 # kde-l10n inherits kde4-base but is metpackage, so no check for doc
588 # kdelibs inherits kde4-base but handle installing the handbook itself
589 if ! has kde4-meta ${INHERITED}; then
590 has handbook ${IUSE//+} && [[ ${PN} != kde-l10n ]] && [[ ${PN} != kdelibs ]] && enable_selected_doc_linguas
591 fi
592
593 # SCM bootstrap
594 if [[ ${BUILD_TYPE} = live ]]; then
595 if has subversion ${INHERITED}; then
596 subversion_src_prepare
597 elif has git ${INHERITED}; then
598 git_src_prepare
599 fi
600 fi
601
602 # Apply patches
603 base_src_prepare
604 epatch_user
605
606 # Save library dependencies
607 if [[ -n ${KMSAVELIBS} ]] ; then
608 save_library_dependencies
609 fi
610
611 # Inject library dependencies
612 if [[ -n ${KMLOADLIBS} ]] ; then
613 load_library_dependencies
614 fi
615 }
616
617 # @FUNCTION: kde4-base_src_configure
618 # @DESCRIPTION:
619 # Function for configuring the build of KDE4 applications.
620 kde4-base_src_configure() {
621 debug-print-function ${FUNCNAME} "$@"
622
623 # Build tests in src_test only, where we override this value
624 local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
625
626 if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
627 cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
628 fi
629
630 if has debug ${IUSE//+} && use debug; then
631 # Set "real" debug mode
632 CMAKE_BUILD_TYPE="Debugfull"
633 else
634 # Handle common release builds
635 append-cppflags -DQT_NO_DEBUG
636 fi
637
638 # Set distribution name
639 [[ ${PN} = kdelibs ]] && cmakeargs+=(-DKDE_DISTRIBUTION_TEXT=Gentoo)
640
641 # Here we set the install prefix
642 tc-is-cross-compiler || cmakeargs+=(-DCMAKE_INSTALL_PREFIX="${EPREFIX}${PREFIX}")
643
644 # Use colors
645 QTEST_COLORED=1
646
647 # Shadow existing /usr installations
648 unset KDEDIRS
649
650 # Handle kdeprefix-ed KDE
651 if [[ ${KDEDIR} != /usr ]]; then
652 # Override some environment variables - only when kdeprefix is different,
653 # to not break ccache/distcc
654 PATH="${EKDEDIR}/bin:${PATH}"
655
656 # Append library search path
657 append-ldflags -L"${EKDEDIR}/$(get_libdir)"
658
659 # Append full RPATH
660 cmakeargs+=(-DCMAKE_SKIP_RPATH=OFF)
661
662 # Set cmake prefixes to allow buildsystem to locate valid KDE installation
663 # when more are present
664 cmakeargs+=(-DCMAKE_SYSTEM_PREFIX_PATH="${EKDEDIR}")
665 fi
666
667 #qmake -query QT_INSTALL_LIBS unavailable when cross-compiling
668 tc-is-cross-compiler && cmakeargs+=(-DQT_LIBRARY_DIR=${ROOT}/usr/lib/qt4)
669 #kde-config -path data unavailable when cross-compiling
670 tc-is-cross-compiler && cmakeargs+=(-DKDE4_DATA_DIR=${ROOT}/usr/share/apps/)
671
672 # Handle kdeprefix in application itself
673 if ! has kdeprefix ${IUSE//+} || ! use kdeprefix; then
674 # If prefix is /usr, sysconf needs to be /etc, not /usr/etc
675 cmakeargs+=(-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc)
676 fi
677
678 if [[ $(declare -p mycmakeargs 2>&-) != "declare -a mycmakeargs="* ]]; then
679 mycmakeargs=(${mycmakeargs})
680 fi
681
682 mycmakeargs=("${cmakeargs[@]}" "${mycmakeargs[@]}")
683
684 cmake-utils_src_configure
685 }
686
687 # @FUNCTION: kde4-base_src_compile
688 # @DESCRIPTION:
689 # General function for compiling KDE4 applications.
690 kde4-base_src_compile() {
691 debug-print-function ${FUNCNAME} "$@"
692
693 cmake-utils_src_compile "$@"
694 }
695
696 # @FUNCTION: kde4-base_src_test
697 # @DESCRIPTION:
698 # Function for testing KDE4 applications.
699 kde4-base_src_test() {
700 debug-print-function ${FUNCNAME} "$@"
701
702 # Override this value, set in kde4-base_src_configure()
703 mycmakeargs+=(-DKDE4_BUILD_TESTS=ON)
704 cmake-utils_src_configure
705 kde4-base_src_compile
706
707 cmake-utils_src_test
708 }
709
710 # @FUNCTION: kde4-base_src_install
711 # @DESCRIPTION:
712 # Function for installing KDE4 applications.
713 kde4-base_src_install() {
714 debug-print-function ${FUNCNAME} "$@"
715
716 # Prefix support, for usage in ebuilds
717 if [[ ${EAPI} == 2 ]] && ! use prefix; then
718 ED=${D}
719 fi
720
721 if [[ -n ${KMSAVELIBS} ]] ; then
722 install_library_dependencies
723 fi
724
725 # Install common documentation of KDE4 applications
726 local doc
727 if ! has kde4-meta ${INHERITED}; then
728 for doc in "${S}"/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
729 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && dodoc "${doc}"
730 done
731 for doc in "${S}"/*/{AUTHORS,CHANGELOG,ChangeLog*,README*,NEWS,TODO,HACKING}; do
732 [[ -f "${doc}" ]] && [[ -s "${doc}" ]] && newdoc "${doc}" "$(basename $(dirname ${doc})).$(basename ${doc})"
733 done
734 fi
735
736 cmake-utils_src_install
737 }
738
739 # @FUNCTION: kde4-base_pkg_postinst
740 # @DESCRIPTION:
741 # Function to rebuild the KDE System Configuration Cache after an application has been installed.
742 kde4-base_pkg_postinst() {
743 debug-print-function ${FUNCNAME} "$@"
744
745 buildsycoca
746
747 if [[ ${BUILD_TYPE} = live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
748 echo
749 einfo "WARNING! This is an experimental live ebuild of ${CATEGORY}/${PN}"
750 einfo "Use it at your own risk."
751 einfo "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
752 echo
753 elif [[ ${BUILD_TYPE} != live ]] && [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && has kdeprefix ${IUSE//+} && use kdeprefix; then
754 # warning about kdeprefix for non-live users
755 echo
756 ewarn "WARNING! You have the kdeprefix useflag enabled."
757 ewarn "This setting is strongly discouraged and might lead to potential trouble"
758 ewarn "with KDE update strategies."
759 ewarn "You are using this setup at your own risk and the kde team does not"
760 ewarn "take responsibilities for dead kittens."
761 echo
762 fi
763 if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]] && ! has_version 'kde-base/kdebase-runtime-meta' && ! has_version 'kde-base/kdebase-startkde'; then
764 # warn about not supported approach
765 if [[ ${KDE_REQUIRED} == always ]] || ( [[ ${KDE_REQUIRED} == optional ]] && use kde ); then
766 echo
767 ewarn "WARNING! Your system configuration contains neither \"kde-base/kdebase-runtime-meta\""
768 ewarn "nor \"kde-base/kdebase-startkde\". You need one of above."
769 ewarn "With this setting you are unsupported by KDE team."
770 ewarn "All missing features you report for misc packages will be probably ignored or closed as INVALID."
771 fi
772 fi
773 }
774
775 # @FUNCTION: kde4-base_pkg_postrm
776 # @DESCRIPTION:
777 # Function to rebuild the KDE System Configuration Cache after an application has been removed.
778 kde4-base_pkg_postrm() {
779 debug-print-function ${FUNCNAME} "$@"
780
781 buildsycoca
782 }

  ViewVC Help
Powered by ViewVC 1.1.20