/[gentoo-x86]/eclass/kde4-functions.eclass
Gentoo

Diff of /eclass/kde4-functions.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.49 Revision 1.54
1# Copyright 1999-2011 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-functions.eclass,v 1.49 2011/06/06 17:51:26 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-functions.eclass,v 1.54 2011/06/15 22:03:13 abcd Exp $
4 4
5inherit versionator 5inherit versionator
6 6
7# @ECLASS: kde4-functions.eclass 7# @ECLASS: kde4-functions.eclass
8# @MAINTAINER: 8# @MAINTAINER:
42elif [[ ${KMNAME-${PN}} = kdevelop ]]; then 42elif [[ ${KMNAME-${PN}} = kdevelop ]]; then
43 debug-print "${ECLASS}: KDEVELOP ebuild recognized" 43 debug-print "${ECLASS}: KDEVELOP ebuild recognized"
44 KDEBASE=kdevelop 44 KDEBASE=kdevelop
45fi 45fi
46 46
47# @ECLASS-VARIABLE: KDE_SLOTS
48# @DESCRIPTION:
49# The slots used by all KDE versions later than 4.0. The live KDE releases use
50# KDE_LIVE_SLOTS instead. Values should be ordered.
51KDE_SLOTS=( "4.1" "4.2" "4.3" "4.4" "4.5" "4.6" "4.7" )
52
53# @ECLASS-VARIABLE: KDE_LIVE_SLOTS
54# @DESCRIPTION:
55# The slots used by KDE live versions. Values should be ordered.
56KDE_LIVE_SLOTS=( "live" )
57
58# determine the build type 47# determine the build type
59if [[ ${SLOT} = live || ${PV} = *9999* ]]; then 48if [[ ${PV} = *9999* ]]; then
60 BUILD_TYPE="live" 49 BUILD_TYPE="live"
61else 50else
62 BUILD_TYPE="release" 51 BUILD_TYPE="release"
63fi 52fi
64export BUILD_TYPE 53export BUILD_TYPE
108 for _lingua in ${KDE_LINGUAS}; do 97 for _lingua in ${KDE_LINGUAS}; do
109 IUSE="${IUSE} linguas_${_lingua}" 98 IUSE="${IUSE} linguas_${_lingua}"
110 done 99 done
111fi 100fi
112 101
113# @FUNCTION: slot_is_at_least
114# @USAGE: <want> <have>
115# @DESCRIPTION:
116# Version aware slot comparator.
117# Current implementation relies on the fact, that slots can be compared like
118# string literals (and let's keep it this way).
119slot_is_at_least() {
120 [[ "${2}" > "${1}" || "${2}" = "${1}" ]]
121}
122
123# @FUNCTION: buildsycoca 102# @FUNCTION: buildsycoca
124# @DESCRIPTION: 103# @DESCRIPTION:
125# Function to rebuild the KDE System Configuration Cache. 104# Function to rebuild the KDE System Configuration Cache.
126# All KDE ebuilds should run this in pkg_postinst and pkg_postrm. 105# All KDE ebuilds should run this in pkg_postinst and pkg_postrm.
127buildsycoca() { 106buildsycoca() {
128 debug-print-function ${FUNCNAME} "$@" 107 debug-print-function ${FUNCNAME} "$@"
129 108
130 # We no longer need to run kbuildsycoca4, as kded does that automatically, as needed 109 # We no longer need to run kbuildsycoca4, as kded does that automatically, as needed
131 110
132 # fix permission for some directories 111 # fix permission for some directories
133 for x in share/{config,kde4}; do 112 for x in usr/share/{config,kde4}; do
134 [[ ${KDEDIR} == /usr ]] && DIRS=${EROOT}usr || DIRS="${EROOT}usr ${EROOT}${KDEDIR}" 113 DIRS=${EROOT}usr
135 for y in ${DIRS}; do
136 [[ -d "${y}/${x}" ]] || break # nothing to do if directory does not exist 114 [[ -d "${EROOT}${x}" ]] || break # nothing to do if directory does not exist
137 # fixes Bug 318237 115 # fixes Bug 318237
138 if use userland_BSD ; then 116 if use userland_BSD ; then
139 [[ $(stat -f %p "${y}/${x}") != 40755 ]] 117 [[ $(stat -f %p "${EROOT}${x}") != 40755 ]]
140 local stat_rtn="$?" 118 local stat_rtn="$?"
141 else 119 else
142 [[ $(stat --format=%a "${y}/${x}") != 755 ]] 120 [[ $(stat --format=%a "${EROOT}${x}") != 755 ]]
143 local stat_rtn=$? 121 local stat_rtn=$?
144 fi 122 fi
145 if [[ $stat_rtn != 1 ]] ; then 123 if [[ $stat_rtn != 1 ]] ; then
146 ewarn "QA Notice:" 124 ewarn "QA Notice:"
147 ewarn "Package ${PN} is breaking ${y}/${x} permissions." 125 ewarn "Package ${PN} is breaking ${EROOT}${x} permissions."
148 ewarn "Please report this issue to gentoo bugzilla." 126 ewarn "Please report this issue to gentoo bugzilla."
149 einfo "Permissions will get adjusted automatically now." 127 einfo "Permissions will get adjusted automatically now."
150 find "${y}/${x}" -type d -print0 | xargs -0 chmod 755 128 find "${EROOT}${x}" -type d -print0 | xargs -0 chmod 755
151 fi 129 fi
152 done
153 done 130 done
154} 131}
155 132
156# @FUNCTION: comment_all_add_subdirectory 133# @FUNCTION: comment_all_add_subdirectory
157# @USAGE: [list of directory names] 134# @USAGE: [list of directory names]
308 285
309# @FUNCTION: save_library_dependencies 286# @FUNCTION: save_library_dependencies
310# @DESCRIPTION: 287# @DESCRIPTION:
311# Add exporting CMake dependencies for current package 288# Add exporting CMake dependencies for current package
312save_library_dependencies() { 289save_library_dependencies() {
313 local depsfile="${T}/${PN}:${SLOT}" 290 local depsfile="${T}/${PN}"
314 291
315 ebegin "Saving library dependencies in ${depsfile##*/}" 292 ebegin "Saving library dependencies in ${depsfile##*/}"
316 echo "EXPORT_LIBRARY_DEPENDENCIES(\"${depsfile}\")" >> "${S}/CMakeLists.txt" || \ 293 echo "EXPORT_LIBRARY_DEPENDENCIES(\"${depsfile}\")" >> "${S}/CMakeLists.txt" || \
317 die "Failed to save the library dependencies." 294 die "Failed to save the library dependencies."
318 eend $? 295 eend $?
320 297
321# @FUNCTION: install_library_dependencies 298# @FUNCTION: install_library_dependencies
322# @DESCRIPTION: 299# @DESCRIPTION:
323# Install generated CMake library dependencies to /var/lib/kde 300# Install generated CMake library dependencies to /var/lib/kde
324install_library_dependencies() { 301install_library_dependencies() {
325 local depsfile="${T}/${PN}:${SLOT}" 302 local depsfile="${T}/${PN}"
326 303
327 ebegin "Installing library dependencies as ${depsfile##*/}" 304 ebegin "Installing library dependencies as ${depsfile##*/}"
328 insinto /var/lib/kde 305 insinto /var/lib/kde
329 doins "${depsfile}" || die "Failed to install library dependencies." 306 doins "${depsfile}" || die "Failed to install library dependencies."
330 eend $? 307 eend $?
338 ebegin "Injecting library dependencies from '${KMLOADLIBS}'" 315 ebegin "Injecting library dependencies from '${KMLOADLIBS}'"
339 316
340 i=0 317 i=0
341 for pn in ${KMLOADLIBS} ; do 318 for pn in ${KMLOADLIBS} ; do
342 ((i++)) 319 ((i++))
343 depsfile="${EPREFIX}/var/lib/kde/${pn}:${SLOT}" 320 depsfile="${EPREFIX}/var/lib/kde/${pn}"
321 [[ -r ${depsfile} ]] || depsfile="${EPREFIX}/var/lib/kde/${pn}:$(get_kde_version)"
344 [[ -r ${depsfile} ]] || die "Depsfile '${depsfile}' not accessible. You probably need to reinstall ${pn}." 322 [[ -r ${depsfile} ]] || die "Depsfile '${depsfile}' not accessible. You probably need to reinstall ${pn}."
345 sed -i -e "${i}iINCLUDE(\"${depsfile}\")" "${S}/CMakeLists.txt" || \ 323 sed -i -e "${i}iINCLUDE(\"${depsfile}\")" "${S}/CMakeLists.txt" || \
346 die "Failed to include library dependencies for ${pn}" 324 die "Failed to include library dependencies for ${pn}"
347 done 325 done
348 eend $? 326 eend $?
349}
350
351# @FUNCTION: block_other_slots
352# @DESCRIPTION:
353# Create blocks for the current package in other slots when
354# installed with USE=-kdeprefix
355block_other_slots() {
356 debug-print-function ${FUNCNAME} "$@"
357
358 _do_blocker ${PN} 0:${SLOT}
359} 327}
360 328
361# @FUNCTION: add_blocker 329# @FUNCTION: add_blocker
362# @DESCRIPTION: 330# @DESCRIPTION:
363# Create correct RDEPEND value for blocking correct package. 331# Create correct RDEPEND value for blocking correct package.
364# Useful for file-collision blocks. 332# Useful for file-collision blocks.
365# Parameters are package and version(s) to block. 333# Parameters are package and version(s) to block.
366# add_blocker kdelibs 4.2.4 334# add_blocker kdelibs 4.2.4
367# If no version is specified, then all versions will be blocked 335# If no version is specified, then all versions will be blocked.
368# If any arguments (from 2 on) contain a ":", then different versions 336# If the version is 0, then no versions will be blocked.
369# are blocked in different slots. (Unlisted slots get the version without 337# If a second version ending in ":3.5" is passed, then the version listed for
370# a ":", if none, then all versions are blocked). The parameter is then of 338# that slot will be blocked as well.
371# the form VERSION:SLOT. Any VERSION of 0 means that no blocker will be
372# added for that slot (or, if no slot, then for any unlisted slot).
373# A parameter of the form :SLOT means to block all versions from that slot.
374# If VERSION begins with "<", then "!<foo" will be used instead of "!<=foo".
375# As a special case, if a parameter with slot "3.5" is passed, then that slot
376# may also be blocked.
377# 339#
378# Versions that match "4.x.50" are equivalent to all slots up to (and including) 340# Examples:
379# "4.x", but nothing following slot "4.x" 341# # Block all versions of kdelibs
342# add_blocker kdelibs
380# 343#
381# As an example, if SLOT=live, then 344# # Block all versions of kdelibs older than 4.3.50
382# add_blocker kdelibs 0 :4.3 '<4.3.96:4.4' 9999:live 345# add_blocker kdelibs 4.3.50
383# will add the following to RDEPEND: 346#
384# !kdeprefix? ( !kde-base/kdelibs:4.3[-kdeprefix] ) 347# # Block kdelibs 3.5.10 and older, but not any version of
385# !kdeprefix? ( !<kde-base/kdelibs-4.3.96:4.4[-kdeprefix] ) 348# # kdelibs from KDE 4
386# !<=kde-base/kdelibs-9999:live 349# add_blocker kdelibs 0 3.5.10:3.5
387add_blocker() { 350add_blocker() {
388 debug-print-function ${FUNCNAME} "$@" 351 debug-print-function ${FUNCNAME} "$@"
389 352
390 RDEPEND+=" $(_do_blocker "$@")" 353 [[ -z ${1} ]] && die "Missing parameter"
354 local pkg=kde-base/$1 atom old_ver="unset" use
355 if [[ $pkg == *\[*\] ]]; then
356 use=${pkg/#*\[/[}
357 pkg=${pkg%\[*\]}
358 fi
359
360 [[ "$3" == *:3.5 ]] && old_ver=${3%:3.5}
361
362 # If the version passed is "0", do nothing
363 if [[ ${2} != 0 ]]; then
364 # If no version was passed, block all versions in this slot
365 if [[ -z ${2} ]]; then
366 atom=${pkg}
367 # If the version passed begins with a "<", then use "<" instead of "<="
368 elif [[ ${2::1} == "<" ]]; then
369 # this also removes the first character of the version, which is a "<"
370 atom="<${pkg}-${2:1}"
371 else
372 atom="<=${pkg}-${2}"
373 fi
374 RDEPEND+=" !${atom}:4${use}"
375 fi
376
377 # Do the same thing as above for :3.5, except that we don't want any
378 # output if no parameter was passed.
379 if [[ ${old_ver} != "unset" ]]; then
380 if [[ -z ${old_ver} ]]; then
381 atom=${pkg}
382 elif [[ ${old_ver::1} == "<" ]]; then
383 atom="<${pkg}-${old_ver:1}"
384 else
385 atom="<=${pkg}-${old_ver}"
386 fi
387 RDEPEND+=" !${atom}:3.5${use}"
388 fi
391} 389}
392 390
393# @FUNCTION: add_kdebase_dep 391# @FUNCTION: add_kdebase_dep
394# @DESCRIPTION: 392# @DESCRIPTION:
395# Create proper dependency for kde-base/ dependencies, adding SLOT when needed 393# Create proper dependency for kde-base/ dependencies.
396# (and *only* when needed).
397# This takes 1 to 3 arguments. The first being the package name, the optional 394# This takes 1 to 3 arguments. The first being the package name, the optional
398# second is additional USE flags to append, and the optional third is the 395# second is additional USE flags to append, and the optional third is the
399# version to use instead of the automatic version (use sparingly). 396# version to use instead of the automatic version (use sparingly).
400# The output of this should be added directly to DEPEND/RDEPEND, and may be 397# The output of this should be added directly to DEPEND/RDEPEND, and may be
401# wrapped in a USE conditional (but not an || conditional without an extra set 398# wrapped in a USE conditional (but not an || conditional without an extra set
409 ver=${3} 406 ver=${3}
410 elif [[ -n ${KDE_OVERRIDE_MINIMAL} ]]; then 407 elif [[ -n ${KDE_OVERRIDE_MINIMAL} ]]; then
411 ver=${KDE_OVERRIDE_MINIMAL} 408 ver=${KDE_OVERRIDE_MINIMAL}
412 elif [[ ${KDEBASE} != kde-base ]]; then 409 elif [[ ${KDEBASE} != kde-base ]]; then
413 ver=${KDE_MINIMAL} 410 ver=${KDE_MINIMAL}
414 # FIXME remove hack when kdepim-4.4.* is gone
415 elif [[ ( ${KMNAME} == kdepim || ${PN} == kdepim-runtime ) && ${SLOT} == 4.4 && ${1} =~ ^(kde(pim)?libs|oxygen-icons)$ ]]; then
416 ver=4.4.5
417 # FIXME remove hack when kdepim-4.6beta is gone
418 elif [[ ( ${KMNAME} == kdepim || ${PN} == kdepim-runtime ) && ${PV} == 4.5.98 && ${1} =~ ^(kde(pim)?libs|oxygen-icons)$ ]]; then
419 ver=4.5.90
420 # if building stable-live version depend just on slot 411 # if building stable-live version depend just on the raw KDE version
421 # to allow merging packages against more stable basic stuff 412 # to allow merging packages against more stable basic stuff
422 elif [[ ${PV} == *.9999 ]]; then 413 elif [[ ${PV} == *.9999 ]]; then
423 ver=${SLOT} 414 ver=$(get_kde_version)
424 else 415 else
425 ver=${PV} 416 ver=${PV}
426 fi 417 fi
427 418
428 [[ -z ${1} ]] && die "Missing parameter" 419 [[ -z ${1} ]] && die "Missing parameter"
429 420
430 local use=${2:+,${2}}
431
432 if [[ ${KDEBASE} = kde-base ]]; then
433 echo " !kdeprefix? ( >=kde-base/${1}-${ver}[aqua=,-kdeprefix${use}] )"
434 # kdeprefix is no-go for kdepim 4.4
435 [[ ( ${KMNAME} == kdepim || ${PN} == kdepim-runtime ) && ${SLOT} == 4.4 ]] || \
436 echo " kdeprefix? ( >=kde-base/${1}-${ver}:${SLOT}[aqua=,kdeprefix${use}] )"
437 elif [[ ${ver} == live ]]; then
438 echo " kde-base/${1}:live[aqua=${use}]"
439 else
440 echo " >=kde-base/${1}-${ver}[aqua=${use}]" 421 echo " >=kde-base/${1}-${ver}:4[aqua=${2:+,${2}}]"
441 fi
442}
443
444# _greater_max_in_slot ver slot
445# slot must be 4.x or live
446# returns true if ver is >= the maximum possibile version in slot
447_greater_max_in_slot() {
448 local ver=$1
449 local slot=$2
450 # If slot is live, then return false
451 # (nothing is greater than the maximum live version)
452 [[ $slot == live ]] && return 1
453 # Otherwise, for slot X.Y, test against X.Y.50
454 local test=${slot}.50
455 version_compare $1 ${test}
456 # 1 = '<', 2 = '=', 3 = '>'
457 (( $? != 1 ))
458}
459
460# _less_min_in_slot ver slot
461# slot must be 4.x or live
462# returns true if ver is <= the minimum possibile version in slot
463_less_min_in_slot() {
464 local ver=$1
465 local slot=$2
466 # If slot == live, then test with "9999_pre", so that 9999 tests false
467 local test=9999_pre
468 # If slot == X.Y, then test with X.(Y-1).50
469 [[ $slot != live ]] && test=${slot%.*}.$((${slot#*.} - 1)).50
470 version_compare $1 ${test}
471 # 1 = '<', 2 = '=', 3 = '>'
472 (( $? != 3 ))
473}
474
475# Internal function used for add_blocker and block_other_slots
476# This takes the same parameters as add_blocker, but echos to
477# stdout instead of updating a variable.
478_do_blocker() {
479 debug-print-function ${FUNCNAME} "$@"
480
481 [[ -z ${1} ]] && die "Missing parameter"
482 local pkg=kde-base/$1 use
483 shift
484 if [[ $pkg == *\[*\] ]]; then
485 use=${pkg#*\[}
486 use=${use%\]}
487 pkg=${pkg%\[*\]}
488 fi
489
490 local param slot def="unset" var atom
491 # The following variables will hold parameters that contain ":"
492 # - block_3_5
493 # - block_4_1
494 # - block_4_2
495 # - block_4_3
496 # - block_4_4
497 # - block_live
498 for slot in 3.5 ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
499 local block_${slot//./_}="unset"
500 done
501
502 # This construct goes through each parameter passed, and sets
503 # either def or block_* to the version passed
504 for param; do
505 # If the parameter does not have a ":" in it...
506 if [[ ${param/:} == ${param} ]]; then
507 def=${param}
508 else # the parameter *does* have a ":" in it
509 # so everything after the : is the slot...
510 slot=${param#*:}
511 # ...and everything before the : is the version
512 local block_${slot//./_}=${param%:*}
513 fi
514 done
515
516 for slot in ${KDE_SLOTS[@]} ${KDE_LIVE_SLOTS[@]}; do
517 # ${var} contains the name of the variable we care about for this slot
518 # ${!var} is it's value
519 var=block_${slot//./_}
520 # if we didn't pass *:${slot}, then use the unsloted value
521 [[ ${!var} == "unset" ]] && var=def
522
523 # If no version was passed, or the version is greater than the maximum
524 # possible version in this slot, block all versions in this slot
525 if [[ ${!var} == "unset" ]] || [[ -z ${!var} ]] || _greater_max_in_slot ${!var#<} ${slot}; then
526 atom=${pkg}
527 # If the version is "0" or less than the minimum possible version in
528 # this slot, do nothing
529 elif [[ ${!var} == "0" ]] || _less_min_in_slot ${!var#<} ${slot}; then
530 continue
531 # If the version passed begins with a "<", then use "<" instead of "<="
532 elif [[ ${!var:0:1} == "<" ]]; then
533 # this also removes the first character of the version, which is a "<"
534 atom="<${pkg}-${!var:1}"
535 else
536 atom="<=${pkg}-${!var}"
537 fi
538 # we always block our own slot, ignoring kdeprefix
539 if [[ ${SLOT} == ${slot} ]]; then
540 echo " !${atom}:${slot}${use:+[${use}]}"
541 else
542 # we only block other slots on -kdeprefix
543 echo " !kdeprefix? ( !${atom}:${slot}[-kdeprefix${use:+,${use}}] )"
544 fi
545 done
546
547 # This is a special case block for :3.5; it does not use the
548 # default version passed, and no blocker is output *unless* a version
549 # is passed, or ":3.5" is passed to explicitly request a block on all
550 # 3.5 versions.
551 if [[ ${block_3_5} != "unset" && ${block_3_5} != "0" ]]; then
552 if [[ -z ${block_3_5} ]]; then
553 atom=${pkg}
554 elif [[ ${block_3_5:0:1} == "<" ]]; then
555 atom="<${pkg}-${block_3_5:1}"
556 else
557 atom="<=${pkg}-${block_3_5}"
558 fi
559 echo " !${atom}:3.5${use:+[${use}]}"
560 fi
561} 422}
562 423
563# local function to enable specified translations for specified directory 424# local function to enable specified translations for specified directory
564# used from kde4-functions_enable_selected_linguas function 425# used from kde4-functions_enable_selected_linguas function
565_enable_selected_linguas_dir() { 426_enable_selected_linguas_dir() {
608 [[ -n ${linguas} ]] && echo ">>> Enabling languages: ${linguas}" 469 [[ -n ${linguas} ]] && echo ">>> Enabling languages: ${linguas}"
609 470
610 popd > /dev/null 471 popd > /dev/null
611} 472}
612 473
613_calculate_kde_slot() { 474# @FUNCTION: get_kde_version
475# Translates an ebuild version into a major.minor KDE SC
476# release version. If no version is specified, ${PV} is used.
477get_kde_version() {
614 local ver=${1:-${PV}} 478 local ver=${1:-${PV}}
615 local major=$(get_major_version ${ver}) 479 local major=$(get_major_version ${ver})
616 local minor=$(get_version_component_range 2 ${ver}) 480 local minor=$(get_version_component_range 2 ${ver})
617 local micro=$(get_version_component_range 3 ${ver}) 481 local micro=$(get_version_component_range 3 ${ver})
618 [[ ${ver} == 9999 ]] && echo live 482 if [[ ${ver} == 9999 ]]; then
619 (( major == 4 && micro == 9999 )) && echo ${major}.${minor} 483 echo live
620 if (( major == 4 && micro != 9999 )); then 484 else
621 (( micro < 50 )) && echo ${major}.${minor} || echo ${major}.$((minor + 1)) 485 (( micro < 50 )) && echo ${major}.${minor} || echo ${major}.$((minor + 1))
622 fi 486 fi
623} 487}

Legend:
Removed from v.1.49  
changed lines
  Added in v.1.54

  ViewVC Help
Powered by ViewVC 1.1.20