/[gentoo-x86]/eclass/kde4-meta.eclass
Gentoo

Diff of /eclass/kde4-meta.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.53 Revision 1.54
1# Copyright 1999-2011 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.53 2011/06/06 17:51:26 abcd Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.54 2011/06/07 20:11:04 abcd Exp $
4# 4#
5# @ECLASS: kde4-meta.eclass 5# @ECLASS: kde4-meta.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# kde@gentoo.org 7# kde@gentoo.org
8# @BLURB: Eclass for writing "split" KDE packages. 8# @BLURB: Eclass for writing "split" KDE packages.
206 || die "${escm}: can't export subdirectory '${subdir}' to '${S}/${targetdir}'." 206 || die "${escm}: can't export subdirectory '${subdir}' to '${S}/${targetdir}'."
207 done 207 done
208 ;; 208 ;;
209 esac 209 esac
210 else 210 else
211 local abort tarball tarfile f extractlist moduleprefix postfix 211 local abort tarball tarfile f extractlist postfix
212 212
213 KMTARPARAMS+=" --bzip2" 213 KMTARPARAMS+=" --bzip2"
214 postfix="bz2" 214 postfix="bz2"
215 215
216 case ${KMNAME} in 216 case ${KMNAME} in
217 kdebase-apps) 217 kdebase-apps)
218 # kdebase/apps -> kdebase-apps 218 # kdebase/apps -> kdebase-apps
219 tarball="kdebase-${PV}.tar.${postfix}" 219 tarball="kdebase-${PV}.tar.${postfix}"
220 if ! slot_is_at_least 4.6 ${SLOT} || [[ ${PV} == "4.6.0" ]]; then
221 moduleprefix=apps/
222 KMTARPARAMS+=" --transform=s|apps/||"
223 fi
224 ;; 220 ;;
225 *) 221 *)
226 # Create tarball name from module name (this is the default) 222 # Create tarball name from module name (this is the default)
227 tarball="${KMNAME}-${PV}.tar.${postfix}" 223 tarball="${KMNAME}-${PV}.tar.${postfix}"
228 ;; 224 ;;
239 235
240 kde4-meta_create_extractlists 236 kde4-meta_create_extractlists
241 237
242 for f in cmake/ CMakeLists.txt ConfigureChecks.cmake config.h.cmake 238 for f in cmake/ CMakeLists.txt ConfigureChecks.cmake config.h.cmake
243 do 239 do
244 extractlist+=" ${topdir}${moduleprefix}${f}" 240 extractlist+=" ${topdir}${f}"
245 done 241 done
246 extractlist+=" $(__list_needed_subdirectories)" 242 extractlist+=" $(__list_needed_subdirectories)"
247 243
248 pushd "${WORKDIR}" > /dev/null 244 pushd "${WORKDIR}" > /dev/null
249 245
266 262
267 popd > /dev/null 263 popd > /dev/null
268 264
269 eend $? 265 eend $?
270 266
271 # We need to clear it here to make verification below work
272 unset moduleprefix
273
274 if [[ -n ${KDE4_STRICTER} ]]; then 267 if [[ -n ${KDE4_STRICTER} ]]; then
275 for f in $(__list_needed_subdirectories fatal); do 268 for f in $(__list_needed_subdirectories fatal); do
276 if [[ ! -e ${S}/${f#*/} ]]; then 269 if [[ ! -e ${S}/${f#*/} ]]; then
277 eerror "'${f#*/}' is missing" 270 eerror "'${f#*/}' is missing"
278 abort=true 271 abort=true
294kde4-meta_create_extractlists() { 287kde4-meta_create_extractlists() {
295 debug-print-function ${FUNCNAME} "$@" 288 debug-print-function ${FUNCNAME} "$@"
296 289
297 # Add default handbook locations 290 # Add default handbook locations
298 # FIXME - legacy code - remove when 4.4.5 is gone or preferrably port 4.4.5. 291 # FIXME - legacy code - remove when 4.4.5 is gone or preferrably port 4.4.5.
299 if ! slot_is_at_least 4.5 ${SLOT} && has handbook ${IUSE//+} && use handbook && [[ -z ${KMNOMODULE} ]]; then 292 if [[ $(get_kde_version) < 4.5 ]] && has handbook ${IUSE//+} && use handbook && [[ -z ${KMNOMODULE} ]]; then
300 # We use the basename of $KMMODULE because $KMMODULE can contain 293 # We use the basename of $KMMODULE because $KMMODULE can contain
301 # the path to the module subdirectory. 294 # the path to the module subdirectory.
302 KMEXTRA_NONFATAL+=" 295 KMEXTRA_NONFATAL+="
303 doc/${KMMODULE##*/}" 296 doc/${KMMODULE##*/}"
304 fi 297 fi
310 303
311 # Add some CMake-files to KMEXTRACTONLY. 304 # Add some CMake-files to KMEXTRACTONLY.
312 # Note that this actually doesn't include KMEXTRA handling. 305 # Note that this actually doesn't include KMEXTRA handling.
313 # In those cases you should care to add the relevant files to KMEXTRACTONLY 306 # In those cases you should care to add the relevant files to KMEXTRACTONLY
314 case ${KMNAME} in 307 case ${KMNAME} in
315 kdebase)
316 if ! slot_is_at_least 4.6 ${SLOT} || [[ ${PV} == "4.6.0" ]]; then
317 KMEXTRACTONLY+="
318 apps/config-apps.h.cmake
319 apps/ConfigureChecks.cmake"
320 else
321 KMEXTRACTONLY+="
322 config-apps.h.cmake
323 ConfigureChecks.cmake"
324 fi
325 ;;
326 kdebase-apps | kde-baseapps) 308 kdebase | kdebase-apps | kde-base-apps)
327 KMEXTRACTONLY+=" 309 KMEXTRACTONLY+="
328 config-apps.h.cmake 310 config-apps.h.cmake
329 ConfigureChecks.cmake" 311 ConfigureChecks.cmake"
330 ;; 312 ;;
331 kdebase-runtime | kde-runtime) 313 kdebase-runtime | kde-runtime)
354 libkdepim/" 336 libkdepim/"
355 fi 337 fi
356 KMEXTRACTONLY+=" 338 KMEXTRACTONLY+="
357 config-enterprise.h.cmake 339 config-enterprise.h.cmake
358 kleopatra/ConfigureChecks.cmake" 340 kleopatra/ConfigureChecks.cmake"
359 if slot_is_at_least 4.5 ${SLOT}; then 341 if ! [[ $(get_kde_version) < 4.5 ]]; then
360 KMEXTRACTONLY+=" 342 KMEXTRACTONLY+="
361 CTestCustom.cmake 343 CTestCustom.cmake
362 kdepim-version.h.cmake" 344 kdepim-version.h.cmake"
363 else 345 else
364 KMEXTRACTONLY+=" 346 KMEXTRACTONLY+="
389 ;; 371 ;;
390 esac 372 esac
391 # Don't install cmake modules for split ebuilds, to avoid collisions. 373 # Don't install cmake modules for split ebuilds, to avoid collisions.
392 # note: kdegraphics >= 4.6.2 does not even have code to do that, so we 374 # note: kdegraphics >= 4.6.2 does not even have code to do that, so we
393 # should not try in that case 375 # should not try in that case
394 if [[ ${KMNAME} != kdegraphics ]] || { [[ ${SLOT} != 4.6 || ${PV} < 4.6.2 ]] && ! slot_is_at_least 4.7 ${SLOT}; }; then 376 # note2: kdeedu 4.6.4 does not have a cmake/modules/ subdir anymore :(
377 # it may be possible to formulate this shorter, but it should also
378 # still be understandable...
379 if [[ ${KMNAME} != kdegraphics || ( ( $(get_kde_version) != 4.6 || ${PV} < 4.6.2 ) && $(get_kde_version) < 4.7 ) ]] \
380 && ! [[ ${KMNAME} == kdeedu && ${PV} == 4.6.4 ]]; then
395 case ${KMNAME} in 381 case ${KMNAME} in
396 kdebase-runtime|kde-runtime|kdebase-workspace|kde-workspace|kdeedu|kdegames|kdegraphics) 382 kdebase-runtime|kde-runtime|kdebase-workspace|kde-workspace|kdeedu|kdegames|kdegraphics)
397 case ${PN} in 383 case ${PN} in
398 libkdegames|libkdeedu|libkworkspace) 384 libkdegames|libkdeedu|libkworkspace)
399 KMEXTRA+=" 385 KMEXTRA+="
453 # Create final list of stuff to extract 439 # Create final list of stuff to extract
454 # We append topdir only when specified (usually for tarballs) 440 # We append topdir only when specified (usually for tarballs)
455 for i in ${kmmodule_expanded} ${kmextra_expanded} ${kmcompileonly_expanded} \ 441 for i in ${kmmodule_expanded} ${kmextra_expanded} ${kmcompileonly_expanded} \
456 ${KMEXTRACTONLY} 442 ${KMEXTRACTONLY}
457 do 443 do
458 extractlist+=" ${topdir}${moduleprefix}${i}" 444 extractlist+=" ${topdir}${i}"
459 done 445 done
460 446
461 echo ${extractlist} 447 echo ${extractlist}
462} 448}
463 449
601 if ( has kontact ${IUSE//+} && use kontact ) || [[ ${PN} = kontact ]]; then 587 if ( has kontact ${IUSE//+} && use kontact ) || [[ ${PN} = kontact ]]; then
602 sed -e '/if[[:space:]]*([[:space:]]*BUILD_.*)/s/^/#OVERRIDE /' \ 588 sed -e '/if[[:space:]]*([[:space:]]*BUILD_.*)/s/^/#OVERRIDE /' \
603 -e '/if[[:space:]]*([[:space:]]*[[:alnum:]]*_FOUND[[:space:]]*)/s/^/#OVERRIDE /' \ 589 -e '/if[[:space:]]*([[:space:]]*[[:alnum:]]*_FOUND[[:space:]]*)/s/^/#OVERRIDE /' \
604 -i kontact/plugins/CMakeLists.txt || die 'failed to override build logic' 590 -i kontact/plugins/CMakeLists.txt || die 'failed to override build logic'
605 fi 591 fi
606 if ! slot_is_at_least 4.5 ${SLOT}; then 592 if [[ $(get_kde_version) < 4.5 ]]; then
607 case ${PN} in 593 case ${PN} in
608 kalarm|kmailcvt|kontact|korganizer|korn) 594 kalarm|kmailcvt|kontact|korganizer|korn)
609 sed -n -e '/qt4_generate_dbus_interface(.*org\.kde\.kmail\.\(kmail\|mailcomposer\)\.xml/p' \ 595 sed -n -e '/qt4_generate_dbus_interface(.*org\.kde\.kmail\.\(kmail\|mailcomposer\)\.xml/p' \
610 -e '/add_custom_target(kmail_xml /,/)/p' \ 596 -e '/add_custom_target(kmail_xml /,/)/p' \
611 -i kmail/CMakeLists.txt || die "uncommenting xml failed" 597 -i kmail/CMakeLists.txt || die "uncommenting xml failed"

Legend:
Removed from v.1.53  
changed lines
  Added in v.1.54

  ViewVC Help
Powered by ViewVC 1.1.20