/[gentoo-x86]/eclass/leechcraft.eclass
Gentoo

Diff of /eclass/leechcraft.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.13 Revision 1.14
1# Copyright 1999-2014 Gentoo Foundation 1# Copyright 1999-2014 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/leechcraft.eclass,v 1.13 2014/04/14 15:45:16 maksbotan Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/leechcraft.eclass,v 1.14 2014/04/15 16:06:56 maksbotan Exp $
4# 4#
5# @ECLASS: leechcraft.eclass 5# @ECLASS: leechcraft.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# leechcraft@gentoo.org 7# leechcraft@gentoo.org
8# @AUTHOR: 8# @AUTHOR:
79 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \ 79 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
80 && die "Sorry, but gcc 4.6 or higher is required." 80 && die "Sorry, but gcc 4.6 or higher is required."
81 fi 81 fi
82 fi 82 fi
83 if version_is_at_least 0.6.66 || ( [[ ${PN} == lc-monocle ]] && version_is_at_least 0.6.65 ); then 83 if version_is_at_least 0.6.66 || ( [[ ${PN} == lc-monocle ]] && version_is_at_least 0.6.65 ); then
84 echo "lalalalala"
85 # 0.6.65 monocle and all later plugins require at least gcc 4.8 84 # 0.6.65 monocle and all later plugins require at least gcc 4.8
86 if [[ ${MERGE_TYPE} != binary ]]; then 85 if [[ ${MERGE_TYPE} != binary ]]; then
87 [[ $(gcc-major-version) -lt 4 ]] || \ 86 [[ $(gcc-major-version) -lt 4 ]] || \
88 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 8 ]] ) \ 87 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 8 ]] ) \
89 && die "Sorry, but gcc 4.8 or higher is required." 88 && die "Sorry, but gcc 4.8 or higher is required."

Legend:
Removed from v.1.13  
changed lines
  Added in v.1.14

  ViewVC Help
Powered by ViewVC 1.1.20