/[gentoo-x86]/eclass/leechcraft.eclass
Gentoo

Diff of /eclass/leechcraft.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.5 Revision 1.7
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/leechcraft.eclass,v 1.5 2012/07/17 04:29:05 vapier Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/leechcraft.eclass,v 1.7 2012/10/14 12:19:32 pinkbyte Exp $
4# 4#
5# @ECLASS: leechcraft.eclass 5# @ECLASS: leechcraft.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# leechcraft@gentoo.org 7# leechcraft@gentoo.org
8# @AUTHOR: 8# @AUTHOR:
20# Thanks for original eclass to Andrian Nord <NightNord@niifaq.ru>. 20# Thanks for original eclass to Andrian Nord <NightNord@niifaq.ru>.
21# 21#
22# Only EAPI >1 supported 22# Only EAPI >1 supported
23 23
24case ${EAPI:-0} in 24case ${EAPI:-0} in
25 4|3|2) ;; 25 2|3|4|5) ;;
26 0|1) die "EAPI not supported, bug ebuild mantainer" ;; 26 0|1) die "EAPI not supported, bug ebuild mantainer" ;;
27 *) die "Unknown EAPI, bug eclass maintainers" ;; 27 *) die "Unknown EAPI, bug eclass maintainers" ;;
28esac 28esac
29 29
30inherit cmake-utils versionator 30inherit cmake-utils toolchain-funcs versionator
31 31
32if [[ ${PV} == 9999 ]]; then 32if [[ ${PV} == 9999 ]]; then
33 EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git" 33 EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
34 EGIT_PROJECT="leechcraft" 34 EGIT_PROJECT="leechcraft"
35 35
60elif [[ ${PN} != leechcraft-core ]]; then 60elif [[ ${PN} != leechcraft-core ]]; then
61 CMAKE_USE_DIR="${S}"/src/plugins/${PN#leechcraft-} 61 CMAKE_USE_DIR="${S}"/src/plugins/${PN#leechcraft-}
62else 62else
63 CMAKE_USE_DIR="${S}"/src 63 CMAKE_USE_DIR="${S}"/src
64fi 64fi
65
66EXPORT_FUNCTIONS "pkg_pretend"
67
68# @FUNCTION: leechcraft_pkg_pretend
69# @DESCRIPTION:
70# Determine active compiler version and refuse to build
71# if it is not satisfied at least to minimal version,
72# supported by upstream developers
73leechcraft_pkg_pretend() {
74 debug-print-function ${FUNCNAME} "$@"
75
76 if version_is_at_least 0.5.85; then
77 # 0.5.85 and later requires at least gcc 4.6
78 if [[ ${MERGE_TYPE} != binary ]]; then
79 [[ $(gcc-major-version) -lt 4 ]] || \
80 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
81 && die "Sorry, but gcc 4.6 or higher is required."
82 fi
83 fi
84}

Legend:
Removed from v.1.5  
changed lines
  Added in v.1.7

  ViewVC Help
Powered by ViewVC 1.1.20