/[gentoo-x86]/eclass/libtool.eclass
Gentoo

Contents of /eclass/libtool.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.102 - (hide annotations) (download)
Sat Sep 15 16:16:53 2012 UTC (2 years, 3 months ago) by zmedico
Branch: MAIN
Changes since 1.101: +1 -3 lines
Remove redundant DESCRIPTION variable settings.

1 grobian 1.99 # Copyright 1999-2012 Gentoo Foundation
2 vapier 1.15 # Distributed under the terms of the GNU General Public License v2
3 zmedico 1.102 # $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.101 2012/07/26 16:14:47 grobian Exp $
4 vapier 1.90
5     # @ECLASS: libtool.eclass
6     # @MAINTAINER:
7     # base-system@gentoo.org
8     # @BLURB: quickly update bundled libtool code
9     # @DESCRIPTION:
10 azarah 1.1 # This eclass patches ltmain.sh distributed with libtoolized packages with the
11 azarah 1.24 # relink and portage patch among others
12 vapier 1.75 #
13     # Note, this eclass does not require libtool as it only applies patches to
14     # generated libtool files. We do not run the libtoolize program because that
15     # requires a regeneration of the main autotool files in order to work properly.
16 rac 1.34
17 vapier 1.97 if [[ ${___ECLASS_ONCE_LIBTOOL} != "recur -_+^+_- spank" ]] ; then
18     ___ECLASS_ONCE_LIBTOOL="recur -_+^+_- spank"
19    
20 vapier 1.96 # If an overlay has eclass overrides, but doesn't actually override the
21     # libtool.eclass, we'll have ECLASSDIR pointing to the active overlay's
22     # eclass/ dir, but libtool.eclass is still in the main Gentoo tree. So
23     # add a check to locate the ELT-patches/ regardless of what's going on.
24     ECLASSDIR_LOCAL=${BASH_SOURCE[0]%/*}
25     elt_patch_dir() {
26     local d="${ECLASSDIR}/ELT-patches"
27     if [[ ! -d ${d} ]] ; then
28     d="${ECLASSDIR_LOCAL}/ELT-patches"
29     fi
30     echo "${d}"
31     }
32    
33 vapier 1.94 inherit multilib toolchain-funcs
34 vapier 1.82
35 azarah 1.24 #
36     # See if we can apply $2 on $1, and if so, do it
37     #
38     ELT_try_and_apply_patch() {
39     local ret=0
40 azarah 1.57 local file=$1
41     local patch=$2
42 vapier 1.94 local src=$3
43     local disp="${src} patch"
44     local log="${T}/elibtool.log"
45    
46     if [[ -z ${__ELT_NOTED_TMP} ]] ; then
47     __ELT_NOTED_TMP=true
48     printf 'temp patch: %s\n' "${patch}" > "${log}"
49     fi
50     printf '\nTrying %s\n' "${disp}" >> "${log}"
51 flameeyes 1.91
52 azarah 1.24 # We only support patchlevel of 0 - why worry if its static patches?
53 vapier 1.94 if patch -p0 --dry-run "${file}" "${patch}" >> "${log}" 2>&1 ; then
54     einfo " Applying ${disp} ..."
55     patch -p0 -g0 --no-backup-if-mismatch "${file}" "${patch}" >> "${log}" 2>&1
56 azarah 1.24 ret=$?
57 vapier 1.94 export ELT_APPLIED_PATCHES="${ELT_APPLIED_PATCHES} ${src}"
58 azarah 1.24 else
59     ret=1
60     fi
61    
62 azarah 1.57 return "${ret}"
63 azarah 1.24 }
64    
65     #
66 azarah 1.59 # Get string version of ltmain.sh or ltconfig (passed as $1)
67     #
68     ELT_libtool_version() {
69 vapier 1.90 (
70     unset VERSION
71     eval $(grep -e '^[[:space:]]*VERSION=' "$1")
72     echo "${VERSION:-0}"
73     )
74 azarah 1.59 }
75    
76     #
77 azarah 1.24 # Run through the patches in $2 and see if any
78     # apply to $1 ...
79     #
80     ELT_walk_patches() {
81 vapier 1.94 local patch tmp
82 azarah 1.24 local ret=1
83 azarah 1.57 local file=$1
84     local patch_set=$2
85 vapier 1.96 local patch_dir="$(elt_patch_dir)/${patch_set}"
86 azarah 1.57 local rem_int_dep=$3
87 azarah 1.2
88 vapier 1.86 [[ -z ${patch_set} ]] && return 1
89     [[ ! -d ${patch_dir} ]] && return 1
90 mr_bones_ 1.27
91 vapier 1.94 # Allow patches to use @GENTOO_LIBDIR@ replacements
92     local sed_args=( -e "s:@GENTOO_LIBDIR@:$(get_libdir):g" )
93     if [[ -n ${rem_int_dep} ]] ; then
94     # replace @REM_INT_DEP@ with what was passed
95     # to --remove-internal-dep
96     sed_args+=( -e "s|@REM_INT_DEP@|${rem_int_dep}|g" )
97     fi
98    
99 vapier 1.96 pushd "$(elt_patch_dir)" >/dev/null || die
100 azarah 1.43
101 vapier 1.86 # Go through the patches in reverse order (newer version to older)
102     for patch in $(find "${patch_set}" -maxdepth 1 -type f | LC_ALL=C sort -r) ; do
103 vapier 1.94 tmp="${T}/libtool-elt.patch"
104     sed "${sed_args[@]}" "${patch}" > "${tmp}" || die
105     if ELT_try_and_apply_patch "${file}" "${tmp}" "${patch}" ; then
106 vapier 1.86 # Break to unwind w/popd rather than return directly
107     ret=0
108     break
109     fi
110     done
111 azarah 1.24
112 vapier 1.87 popd >/dev/null
113 vapier 1.86 return ${ret}
114 azarah 1.24 }
115    
116 vapier 1.90 # @FUNCTION: elibtoolize
117     # @USAGE: [dirs] [--portage] [--reverse-deps] [--patch-only] [--remove-internal-dep=xxx] [--shallow] [--no-uclibc]
118     # @DESCRIPTION:
119     # Apply a smorgasbord of patches to bundled libtool files. This function
120     # should always be safe to run. If no directories are specified, then
121     # ${S} will be searched for appropriate files.
122     #
123     # If the --shallow option is used, then only ${S}/ltmain.sh will be patched.
124     #
125     # The other options should be avoided in general unless you know what's going on.
126 azarah 1.24 elibtoolize() {
127 vapier 1.90 local x
128 azarah 1.24 local do_portage="no"
129     local do_reversedeps="no"
130     local do_only_patches="no"
131 azarah 1.56 local do_uclibc="yes"
132 azarah 1.24 local deptoremove=
133 vapier 1.90 local do_shallow="no"
134 vapier 1.95 local force="false"
135 loki_val 1.83 local elt_patches="install-sh ltmain portage relink max_cmd_len sed test tmp cross as-needed"
136 mr_bones_ 1.27
137 vapier 1.42 for x in "$@" ; do
138 vapier 1.90 case ${x} in
139     --portage)
140 azarah 1.24 # Only apply portage patch, and don't
141     # 'libtoolize --copy --force' if all patches fail.
142     do_portage="yes"
143     ;;
144 vapier 1.90 --reverse-deps)
145 azarah 1.24 # Apply the reverse-deps patch
146     # http://bugzilla.gnome.org/show_bug.cgi?id=75635
147     do_reversedeps="yes"
148 vapier 1.90 elt_patches+=" fix-relink"
149 azarah 1.24 ;;
150 vapier 1.90 --patch-only)
151 azarah 1.24 # Do not run libtoolize if none of the patches apply ..
152     do_only_patches="yes"
153     ;;
154 vapier 1.90 --remove-internal-dep=*)
155 azarah 1.24 # We will replace @REM_INT_DEP@ with what is needed
156     # in ELT_walk_patches() ...
157 vapier 1.90 deptoremove=${x#--remove-internal-dep=}
158 azarah 1.24
159     # Add the patch for this ...
160 vapier 1.90 [[ -n ${deptoremove} ]] && elt_patches+=" rem-int-dep"
161 azarah 1.24 ;;
162 vapier 1.90 --shallow)
163 azarah 1.24 # Only patch the ltmain.sh in ${S}
164 vapier 1.90 do_shallow="yes"
165 azarah 1.24 ;;
166 vapier 1.90 --no-uclibc)
167 azarah 1.56 do_uclibc="no"
168 vapier 1.40 ;;
169 vapier 1.95 --force)
170     force="true"
171     ;;
172 vapier 1.42 *)
173 azarah 1.57 eerror "Invalid elibtoolize option: ${x}"
174     die "elibtoolize called with ${x} ??"
175 azarah 1.24 esac
176 azarah 1.4 done
177 azarah 1.1
178 vapier 1.90 [[ ${do_uclibc} == "yes" ]] && elt_patches+=" uclibc-conf uclibc-ltconf"
179 azarah 1.56
180 vapier 1.90 case ${CHOST} in
181     *-aix*) elt_patches+=" hardcode aixrtl aix-noundef" ;; #213277
182     *-darwin*) elt_patches+=" darwin-ltconf darwin-ltmain darwin-conf" ;;
183 grobian 1.101 *-solaris*) elt_patches+=" sol2-conf sol2-ltmain" ;;
184 vapier 1.90 *-freebsd*) elt_patches+=" fbsd-conf fbsd-ltconf" ;;
185     *-hpux*) elt_patches+=" hpux-conf deplibs hc-flag-ld hardcode hardcode-relink relink-prog no-lc" ;;
186     *-irix*) elt_patches+=" irix-ltmain" ;;
187     *-mint*) elt_patches+=" mint-conf" ;;
188 grobian 1.84 esac
189 usata 1.36
190 flameeyes 1.91 if $(tc-getLD) --version 2>&1 | grep -qs 'GNU gold'; then
191     elt_patches+=" gold-conf"
192     fi
193    
194 vapier 1.90 # Reuse "$@" for dirs to patch
195     set --
196     if [[ ${do_shallow} == "yes" ]] ; then
197     [[ -f ${S}/ltmain.sh ]] && set -- "${S}"
198     else
199     set -- $(find "${S}" -name ltmain.sh -printf '%h ')
200     fi
201    
202     local d p
203     for d in "$@" ; do
204 azarah 1.24 export ELT_APPLIED_PATCHES=
205 mr_bones_ 1.27
206 vapier 1.95 if [[ -f ${d}/.elibtoolized ]] ; then
207     ${force} || continue
208     fi
209 azarah 1.52
210 vapier 1.98 local outfunc="einfo"
211     [[ -f ${d}/.elibtoolized ]] && outfunc="ewarn"
212     ${outfunc} "Running elibtoolize in: ${d#${WORKDIR}/}/"
213     if [[ ${outfunc} == "ewarn" ]] ; then
214 vapier 1.95 ewarn " We've already been run in this tree; you should"
215     ewarn " avoid this if possible (perhaps by filing a bug)"
216     fi
217 azarah 1.2
218 vapier 1.90 for p in ${elt_patches} ; do
219 azarah 1.24 local ret=0
220    
221 vapier 1.90 case ${p} in
222     portage)
223 azarah 1.64 # Stupid test to see if its already applied ...
224 vapier 1.90 if ! grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
225     ELT_walk_patches "${d}/ltmain.sh" "${p}"
226 azarah 1.64 ret=$?
227     fi
228     ;;
229 vapier 1.90 rem-int-dep)
230     ELT_walk_patches "${d}/ltmain.sh" "${p}" "${deptoremove}"
231 azarah 1.24 ret=$?
232     ;;
233 vapier 1.90 fix-relink)
234 azarah 1.24 # Do not apply if we do not have the relink patch applied ...
235 vapier 1.90 if grep -qs 'inst_prefix_dir' "${d}/ltmain.sh" ; then
236     ELT_walk_patches "${d}/ltmain.sh" "${p}"
237 azarah 1.24 ret=$?
238     fi
239     ;;
240 vapier 1.90 max_cmd_len)
241 azarah 1.25 # Do not apply if $max_cmd_len is not used ...
242 vapier 1.90 if grep -qs 'max_cmd_len' "${d}/ltmain.sh" ; then
243     ELT_walk_patches "${d}/ltmain.sh" "${p}"
244 azarah 1.25 ret=$?
245     fi
246     ;;
247 vapier 1.90 as-needed)
248     ELT_walk_patches "${d}/ltmain.sh" "${p}"
249 loki_val 1.83 ret=$?
250     ;;
251 vapier 1.90 uclibc-conf)
252     if grep -qs 'Transform linux' "${d}/configure" ; then
253     ELT_walk_patches "${d}/configure" "${p}"
254 azarah 1.53 ret=$?
255     # ltmain.sh and co might be in a subdirectory ...
256 vapier 1.90 elif [[ ! -e ${d}/configure ]] && \
257 flameeyes 1.91 grep -qs 'Transform linux' "${d}/../configure" ; then
258 vapier 1.90 ELT_walk_patches "${d}/../configure" "${p}"
259 azarah 1.53 ret=$?
260     fi
261     ;;
262 vapier 1.90 uclibc-ltconf)
263 azarah 1.60 # Newer libtoolize clears ltconfig, as not used anymore
264 vapier 1.90 if [[ -s ${d}/ltconfig ]] ; then
265     ELT_walk_patches "${d}/ltconfig" "${p}"
266 azarah 1.53 ret=$?
267     fi
268     ;;
269 vapier 1.90 fbsd-conf)
270     if grep -qs 'version_type=freebsd-' "${d}/configure" ; then
271     ELT_walk_patches "${d}/configure" "${p}"
272 flameeyes 1.55 ret=$?
273     # ltmain.sh and co might be in a subdirectory ...
274 vapier 1.90 elif [[ ! -e ${d}/configure ]] && \
275 flameeyes 1.91 grep -qs 'version_type=freebsd-' "${d}/../configure" ; then
276 vapier 1.90 ELT_walk_patches "${d}/../configure" "${p}"
277 flameeyes 1.55 ret=$?
278     fi
279     ;;
280 vapier 1.90 fbsd-ltconf)
281     if [[ -s ${d}/ltconfig ]] ; then
282     ELT_walk_patches "${d}/ltconfig" "${p}"
283 flameeyes 1.68 ret=$?
284     fi
285     ;;
286 vapier 1.90 darwin-conf)
287     if grep -qs '&& echo \.so ||' "${d}/configure" ; then
288     ELT_walk_patches "${d}/configure" "${p}"
289 grobian 1.84 ret=$?
290     # ltmain.sh and co might be in a subdirectory ...
291 vapier 1.90 elif [[ ! -e ${d}/configure ]] && \
292 flameeyes 1.91 grep -qs '&& echo \.so ||' "${d}/../configure" ; then
293 vapier 1.90 ELT_walk_patches "${d}/../configure" "${p}"
294 grobian 1.84 ret=$?
295     fi
296     ;;
297 vapier 1.90 darwin-ltconf)
298 azarah 1.60 # Newer libtoolize clears ltconfig, as not used anymore
299 vapier 1.90 if [[ -s ${d}/ltconfig ]] ; then
300     ELT_walk_patches "${d}/ltconfig" "${p}"
301 azarah 1.60 ret=$?
302     fi
303     ;;
304 vapier 1.90 darwin-ltmain)
305 grobian 1.84 # special case to avoid false positives (failing to apply
306     # ltmain.sh path message), newer libtools have this patch
307     # built in, so not much to patch around then
308 vapier 1.90 if [[ -e ${d}/ltmain.sh ]] && \
309     ! grep -qs 'verstring="-compatibility_version' "${d}/ltmain.sh" ; then
310     ELT_walk_patches "${d}/ltmain.sh" "${p}"
311 grobian 1.84 ret=$?
312     fi
313     ;;
314 vapier 1.90 aixrtl|hpux-conf)
315 haubi 1.85 ret=1
316     local subret=0
317     # apply multiple patches as often as they match
318     while [[ $subret -eq 0 ]]; do
319     subret=1
320 vapier 1.90 if [[ -e ${d}/configure ]]; then
321     ELT_walk_patches "${d}/configure" "${p}"
322 haubi 1.85 subret=$?
323     # ltmain.sh and co might be in a subdirectory ...
324 vapier 1.90 elif [[ ! -e ${d}/configure && -e ${d}/../configure ]] ; then
325     ELT_walk_patches "${d}/../configure" "${p}"
326 haubi 1.85 subret=$?
327     fi
328     if [[ $subret -eq 0 ]]; then
329     # have at least one patch succeeded.
330     ret=0
331     fi
332     done
333     ;;
334 grobian 1.100 mint-conf|gold-conf|sol2-conf)
335 grobian 1.84 ret=1
336     local subret=1
337 vapier 1.90 if [[ -e ${d}/configure ]]; then
338     ELT_walk_patches "${d}/configure" "${p}"
339 grobian 1.84 subret=$?
340     # ltmain.sh and co might be in a subdirectory ...
341 flameeyes 1.91 elif [[ -e ${d}/../configure ]] ; then
342 vapier 1.90 ELT_walk_patches "${d}/../configure" "${p}"
343 grobian 1.84 subret=$?
344 flameeyes 1.91 elif [[ -e ${d}/../../configure ]] ; then
345     ELT_walk_patches "${d}/../../configure" "${p}"
346     subret=$?
347 grobian 1.84 fi
348     if [[ $subret -eq 0 ]]; then
349     # have at least one patch succeeded.
350     ret=0
351     fi
352     ;;
353 vapier 1.90 install-sh)
354     ELT_walk_patches "${d}/install-sh" "${p}"
355 uberlord 1.78 ret=$?
356     ;;
357 vapier 1.90 cross)
358 vapier 1.82 if tc-is-cross-compiler ; then
359 vapier 1.90 ELT_walk_patches "${d}/ltmain.sh" "${p}"
360 vapier 1.82 ret=$?
361     fi
362     ;;
363 azarah 1.24 *)
364 vapier 1.90 ELT_walk_patches "${d}/ltmain.sh" "${p}"
365 azarah 1.24 ret=$?
366     ;;
367     esac
368 mr_bones_ 1.27
369 vapier 1.42 if [[ ${ret} -ne 0 ]] ; then
370 vapier 1.90 case ${p} in
371     relink)
372     local version=$(ELT_libtool_version "${d}/ltmain.sh")
373 azarah 1.24 # Critical patch, but could be applied ...
374 azarah 1.59 # FIXME: Still need a patch for ltmain.sh > 1.4.0
375 vapier 1.90 if ! grep -qs 'inst_prefix_dir' "${d}/ltmain.sh" && \
376     [[ $(VER_to_int "${version}") -ge $(VER_to_int "1.4.0") ]] ; then
377 azarah 1.24 ewarn " Could not apply relink.patch!"
378     fi
379     ;;
380 vapier 1.90 portage)
381 azarah 1.24 # Critical patch - for this one we abort, as it can really
382     # cause breakage without it applied!
383 vapier 1.42 if [[ ${do_portage} == "yes" ]] ; then
384 azarah 1.24 # Stupid test to see if its already applied ...
385 vapier 1.90 if ! grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
386 azarah 1.24 echo
387     eerror "Portage patch requested, but failed to apply!"
388 vapier 1.88 eerror "Please file a bug report to add a proper patch."
389 azarah 1.24 die "Portage patch requested, but failed to apply!"
390     fi
391     else
392 vapier 1.90 if grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
393 azarah 1.51 # ewarn " Portage patch seems to be already applied."
394     # ewarn " Please verify that it is not needed."
395     :
396 azarah 1.45 else
397 flameeyes 1.91 local version=$(ELT_libtool_version "${d}"/ltmain.sh)
398 azarah 1.45 echo
399 azarah 1.46 eerror "Portage patch failed to apply (ltmain.sh version ${version})!"
400 vapier 1.88 eerror "Please file a bug report to add a proper patch."
401 azarah 1.45 die "Portage patch failed to apply!"
402     fi
403     # We do not want to run libtoolize ...
404     ELT_APPLIED_PATCHES="portage"
405 azarah 1.3 fi
406     ;;
407 vapier 1.90 uclibc-*)
408     [[ ${CHOST} == *-uclibc ]] && ewarn " uClibc patch set '${p}' failed to apply!"
409 azarah 1.53 ;;
410 vapier 1.90 fbsd-*)
411     if [[ ${CHOST} == *-freebsd* ]] ; then
412 flameeyes 1.65 if [[ -z $(grep 'Handle Gentoo/FreeBSD as it was Linux' \
413 vapier 1.90 "${d}/configure" "${d}/../configure" 2>/dev/null) ]]; then
414     eerror " FreeBSD patch set '${p}' failed to apply!"
415     die "FreeBSD patch set '${p}' failed to apply!"
416 flameeyes 1.61 fi
417 azarah 1.60 fi
418     ;;
419 vapier 1.90 darwin-*)
420     [[ ${CHOST} == *"-darwin"* ]] && ewarn " Darwin patch set '${p}' failed to apply!"
421 flameeyes 1.55 ;;
422 azarah 1.3 esac
423 azarah 1.1 fi
424 azarah 1.52 done
425 azarah 1.11
426 azarah 1.52 if [[ -z ${ELT_APPLIED_PATCHES} ]] ; then
427     if [[ ${do_portage} == "no" && \
428     ${do_reversedeps} == "no" && \
429     ${do_only_patches} == "no" && \
430     ${deptoremove} == "" ]]
431     then
432     ewarn "Cannot apply any patches, please file a bug about this"
433 vapier 1.75 die
434 azarah 1.1 fi
435 azarah 1.52 fi
436    
437 vapier 1.90 rm -f "${d}/libtool"
438 azarah 1.52
439 vapier 1.90 > "${d}/.elibtoolized"
440 azarah 1.1 done
441 vapier 1.30 }
442    
443 vapier 1.90 uclibctoolize() { die "Use elibtoolize"; }
444     darwintoolize() { die "Use elibtoolize"; }
445 azarah 1.44
446     # char *VER_major(string)
447     #
448     # Return the Major (X of X.Y.Z) version
449     #
450     VER_major() {
451     [[ -z $1 ]] && return 1
452    
453     local VER=$@
454 azarah 1.57 echo "${VER%%[^[:digit:]]*}"
455 azarah 1.44 }
456    
457     # char *VER_minor(string)
458     #
459     # Return the Minor (Y of X.Y.Z) version
460     #
461     VER_minor() {
462     [[ -z $1 ]] && return 1
463    
464     local VER=$@
465     VER=${VER#*.}
466 azarah 1.57 echo "${VER%%[^[:digit:]]*}"
467 azarah 1.44 }
468    
469     # char *VER_micro(string)
470     #
471     # Return the Micro (Z of X.Y.Z) version.
472     #
473     VER_micro() {
474     [[ -z $1 ]] && return 1
475    
476     local VER=$@
477     VER=${VER#*.*.}
478 azarah 1.57 echo "${VER%%[^[:digit:]]*}"
479 azarah 1.44 }
480    
481     # int VER_to_int(string)
482     #
483     # Convert a string type version (2.4.0) to an int (132096)
484     # for easy compairing or versions ...
485     #
486     VER_to_int() {
487     [[ -z $1 ]] && return 1
488    
489     local VER_MAJOR=$(VER_major "$1")
490     local VER_MINOR=$(VER_minor "$1")
491     local VER_MICRO=$(VER_micro "$1")
492     local VER_int=$(( VER_MAJOR * 65536 + VER_MINOR * 256 + VER_MICRO ))
493    
494     # We make version 1.0.0 the minimum version we will handle as
495     # a sanity check ... if its less, we fail ...
496     if [[ ${VER_int} -ge 65536 ]] ; then
497     echo "${VER_int}"
498     return 0
499     fi
500    
501     echo 1
502     return 1
503     }
504 vapier 1.97
505     fi

  ViewVC Help
Powered by ViewVC 1.1.20