/[gentoo-x86]/eclass/libtool.eclass
Gentoo

Contents of /eclass/libtool.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.108 - (hide annotations) (download)
Thu Dec 5 16:52:35 2013 UTC (8 months, 2 weeks ago) by blueness
Branch: MAIN
Changes since 1.107: +1 -4 lines
Remove warning for uclibc if patching fails, bug #492640

1 aballier 1.106 # Copyright 1999-2013 Gentoo Foundation
2 vapier 1.15 # Distributed under the terms of the GNU General Public License v2
3 blueness 1.108 # $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.107 2013/11/22 09:05:55 haubi Exp $
4 vapier 1.90
5     # @ECLASS: libtool.eclass
6     # @MAINTAINER:
7     # base-system@gentoo.org
8     # @BLURB: quickly update bundled libtool code
9     # @DESCRIPTION:
10 azarah 1.1 # This eclass patches ltmain.sh distributed with libtoolized packages with the
11 azarah 1.24 # relink and portage patch among others
12 vapier 1.75 #
13     # Note, this eclass does not require libtool as it only applies patches to
14     # generated libtool files. We do not run the libtoolize program because that
15     # requires a regeneration of the main autotool files in order to work properly.
16 rac 1.34
17 vapier 1.97 if [[ ${___ECLASS_ONCE_LIBTOOL} != "recur -_+^+_- spank" ]] ; then
18     ___ECLASS_ONCE_LIBTOOL="recur -_+^+_- spank"
19    
20 vapier 1.96 # If an overlay has eclass overrides, but doesn't actually override the
21     # libtool.eclass, we'll have ECLASSDIR pointing to the active overlay's
22     # eclass/ dir, but libtool.eclass is still in the main Gentoo tree. So
23     # add a check to locate the ELT-patches/ regardless of what's going on.
24     ECLASSDIR_LOCAL=${BASH_SOURCE[0]%/*}
25     elt_patch_dir() {
26     local d="${ECLASSDIR}/ELT-patches"
27     if [[ ! -d ${d} ]] ; then
28     d="${ECLASSDIR_LOCAL}/ELT-patches"
29     fi
30     echo "${d}"
31     }
32    
33 vapier 1.94 inherit multilib toolchain-funcs
34 vapier 1.82
35 azarah 1.24 #
36     # See if we can apply $2 on $1, and if so, do it
37     #
38     ELT_try_and_apply_patch() {
39     local ret=0
40 azarah 1.57 local file=$1
41     local patch=$2
42 vapier 1.94 local src=$3
43     local disp="${src} patch"
44     local log="${T}/elibtool.log"
45    
46     if [[ -z ${__ELT_NOTED_TMP} ]] ; then
47     __ELT_NOTED_TMP=true
48     printf 'temp patch: %s\n' "${patch}" > "${log}"
49     fi
50     printf '\nTrying %s\n' "${disp}" >> "${log}"
51 flameeyes 1.91
52 vapier 1.105 if [[ ! -e ${file} ]] ; then
53     echo "File not found: ${file}" >> "${log}"
54     return 1
55     fi
56    
57 vapier 1.103 # Save file for permission restoration. `patch` sometimes resets things.
58 aballier 1.106 # Ideally we'd want 'stat -c %a', but stat is highly non portable and we are
59     # guaranted to have GNU find, so use that instead.
60     local perms="$(find ${file} -maxdepth 0 -printf '%m')"
61 azarah 1.24 # We only support patchlevel of 0 - why worry if its static patches?
62 vapier 1.94 if patch -p0 --dry-run "${file}" "${patch}" >> "${log}" 2>&1 ; then
63     einfo " Applying ${disp} ..."
64     patch -p0 -g0 --no-backup-if-mismatch "${file}" "${patch}" >> "${log}" 2>&1
65 azarah 1.24 ret=$?
66 vapier 1.94 export ELT_APPLIED_PATCHES="${ELT_APPLIED_PATCHES} ${src}"
67 azarah 1.24 else
68     ret=1
69     fi
70 aballier 1.106 chmod "${perms}" "${file}"
71 azarah 1.24
72 azarah 1.57 return "${ret}"
73 azarah 1.24 }
74    
75     #
76 azarah 1.59 # Get string version of ltmain.sh or ltconfig (passed as $1)
77     #
78     ELT_libtool_version() {
79 vapier 1.90 (
80     unset VERSION
81     eval $(grep -e '^[[:space:]]*VERSION=' "$1")
82     echo "${VERSION:-0}"
83     )
84 azarah 1.59 }
85    
86     #
87 azarah 1.24 # Run through the patches in $2 and see if any
88     # apply to $1 ...
89     #
90     ELT_walk_patches() {
91 vapier 1.94 local patch tmp
92 azarah 1.24 local ret=1
93 azarah 1.57 local file=$1
94     local patch_set=$2
95 vapier 1.96 local patch_dir="$(elt_patch_dir)/${patch_set}"
96 azarah 1.57 local rem_int_dep=$3
97 azarah 1.2
98 vapier 1.86 [[ -z ${patch_set} ]] && return 1
99     [[ ! -d ${patch_dir} ]] && return 1
100 mr_bones_ 1.27
101 vapier 1.94 # Allow patches to use @GENTOO_LIBDIR@ replacements
102     local sed_args=( -e "s:@GENTOO_LIBDIR@:$(get_libdir):g" )
103     if [[ -n ${rem_int_dep} ]] ; then
104     # replace @REM_INT_DEP@ with what was passed
105     # to --remove-internal-dep
106     sed_args+=( -e "s|@REM_INT_DEP@|${rem_int_dep}|g" )
107     fi
108    
109 vapier 1.96 pushd "$(elt_patch_dir)" >/dev/null || die
110 azarah 1.43
111 vapier 1.86 # Go through the patches in reverse order (newer version to older)
112     for patch in $(find "${patch_set}" -maxdepth 1 -type f | LC_ALL=C sort -r) ; do
113 vapier 1.94 tmp="${T}/libtool-elt.patch"
114     sed "${sed_args[@]}" "${patch}" > "${tmp}" || die
115     if ELT_try_and_apply_patch "${file}" "${tmp}" "${patch}" ; then
116 vapier 1.86 # Break to unwind w/popd rather than return directly
117     ret=0
118     break
119     fi
120     done
121 azarah 1.24
122 vapier 1.87 popd >/dev/null
123 vapier 1.86 return ${ret}
124 azarah 1.24 }
125    
126 vapier 1.90 # @FUNCTION: elibtoolize
127     # @USAGE: [dirs] [--portage] [--reverse-deps] [--patch-only] [--remove-internal-dep=xxx] [--shallow] [--no-uclibc]
128     # @DESCRIPTION:
129     # Apply a smorgasbord of patches to bundled libtool files. This function
130     # should always be safe to run. If no directories are specified, then
131     # ${S} will be searched for appropriate files.
132     #
133     # If the --shallow option is used, then only ${S}/ltmain.sh will be patched.
134     #
135     # The other options should be avoided in general unless you know what's going on.
136 azarah 1.24 elibtoolize() {
137 vapier 1.90 local x
138 azarah 1.24 local do_portage="no"
139     local do_reversedeps="no"
140     local do_only_patches="no"
141 azarah 1.56 local do_uclibc="yes"
142 azarah 1.24 local deptoremove=
143 vapier 1.90 local do_shallow="no"
144 vapier 1.95 local force="false"
145 vapier 1.104 local elt_patches="install-sh ltmain portage relink max_cmd_len sed test tmp cross as-needed target-nm"
146 mr_bones_ 1.27
147 vapier 1.42 for x in "$@" ; do
148 vapier 1.90 case ${x} in
149     --portage)
150 azarah 1.24 # Only apply portage patch, and don't
151     # 'libtoolize --copy --force' if all patches fail.
152     do_portage="yes"
153     ;;
154 vapier 1.90 --reverse-deps)
155 azarah 1.24 # Apply the reverse-deps patch
156     # http://bugzilla.gnome.org/show_bug.cgi?id=75635
157     do_reversedeps="yes"
158 vapier 1.90 elt_patches+=" fix-relink"
159 azarah 1.24 ;;
160 vapier 1.90 --patch-only)
161 azarah 1.24 # Do not run libtoolize if none of the patches apply ..
162     do_only_patches="yes"
163     ;;
164 vapier 1.90 --remove-internal-dep=*)
165 azarah 1.24 # We will replace @REM_INT_DEP@ with what is needed
166     # in ELT_walk_patches() ...
167 vapier 1.90 deptoremove=${x#--remove-internal-dep=}
168 azarah 1.24
169     # Add the patch for this ...
170 vapier 1.90 [[ -n ${deptoremove} ]] && elt_patches+=" rem-int-dep"
171 azarah 1.24 ;;
172 vapier 1.90 --shallow)
173 azarah 1.24 # Only patch the ltmain.sh in ${S}
174 vapier 1.90 do_shallow="yes"
175 azarah 1.24 ;;
176 vapier 1.90 --no-uclibc)
177 azarah 1.56 do_uclibc="no"
178 vapier 1.40 ;;
179 vapier 1.95 --force)
180     force="true"
181     ;;
182 vapier 1.42 *)
183 azarah 1.57 eerror "Invalid elibtoolize option: ${x}"
184     die "elibtoolize called with ${x} ??"
185 azarah 1.24 esac
186 azarah 1.4 done
187 azarah 1.1
188 vapier 1.90 [[ ${do_uclibc} == "yes" ]] && elt_patches+=" uclibc-conf uclibc-ltconf"
189 azarah 1.56
190 vapier 1.90 case ${CHOST} in
191     *-aix*) elt_patches+=" hardcode aixrtl aix-noundef" ;; #213277
192     *-darwin*) elt_patches+=" darwin-ltconf darwin-ltmain darwin-conf" ;;
193 grobian 1.101 *-solaris*) elt_patches+=" sol2-conf sol2-ltmain" ;;
194 vapier 1.90 *-freebsd*) elt_patches+=" fbsd-conf fbsd-ltconf" ;;
195     *-hpux*) elt_patches+=" hpux-conf deplibs hc-flag-ld hardcode hardcode-relink relink-prog no-lc" ;;
196     *-irix*) elt_patches+=" irix-ltmain" ;;
197     *-mint*) elt_patches+=" mint-conf" ;;
198 grobian 1.84 esac
199 usata 1.36
200 flameeyes 1.91 if $(tc-getLD) --version 2>&1 | grep -qs 'GNU gold'; then
201     elt_patches+=" gold-conf"
202     fi
203    
204 vapier 1.90 # Reuse "$@" for dirs to patch
205     set --
206     if [[ ${do_shallow} == "yes" ]] ; then
207 haubi 1.107 [[ -f ${S}/ltmain.sh || -f ${S}/configure ]] && set -- "${S}"
208 vapier 1.90 else
209 haubi 1.107 set -- $(find "${S}" '(' -name ltmain.sh -o -name configure ')' -printf '%h\n' | sort -u)
210 vapier 1.90 fi
211    
212     local d p
213     for d in "$@" ; do
214 azarah 1.24 export ELT_APPLIED_PATCHES=
215 mr_bones_ 1.27
216 vapier 1.95 if [[ -f ${d}/.elibtoolized ]] ; then
217     ${force} || continue
218     fi
219 azarah 1.52
220 vapier 1.98 local outfunc="einfo"
221     [[ -f ${d}/.elibtoolized ]] && outfunc="ewarn"
222     ${outfunc} "Running elibtoolize in: ${d#${WORKDIR}/}/"
223     if [[ ${outfunc} == "ewarn" ]] ; then
224 vapier 1.95 ewarn " We've already been run in this tree; you should"
225     ewarn " avoid this if possible (perhaps by filing a bug)"
226     fi
227 azarah 1.2
228 haubi 1.107 local ret
229    
230     # patching ltmain.sh
231     [[ -f ${d}/ltmain.sh ]] &&
232 vapier 1.90 for p in ${elt_patches} ; do
233 haubi 1.107 ret=0
234 azarah 1.24
235 vapier 1.90 case ${p} in
236     portage)
237 azarah 1.64 # Stupid test to see if its already applied ...
238 vapier 1.90 if ! grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
239     ELT_walk_patches "${d}/ltmain.sh" "${p}"
240 azarah 1.64 ret=$?
241     fi
242     ;;
243 vapier 1.90 rem-int-dep)
244     ELT_walk_patches "${d}/ltmain.sh" "${p}" "${deptoremove}"
245 azarah 1.24 ret=$?
246     ;;
247 vapier 1.90 fix-relink)
248 azarah 1.24 # Do not apply if we do not have the relink patch applied ...
249 vapier 1.90 if grep -qs 'inst_prefix_dir' "${d}/ltmain.sh" ; then
250     ELT_walk_patches "${d}/ltmain.sh" "${p}"
251 azarah 1.24 ret=$?
252     fi
253     ;;
254 vapier 1.90 max_cmd_len)
255 azarah 1.25 # Do not apply if $max_cmd_len is not used ...
256 vapier 1.90 if grep -qs 'max_cmd_len' "${d}/ltmain.sh" ; then
257     ELT_walk_patches "${d}/ltmain.sh" "${p}"
258 azarah 1.25 ret=$?
259     fi
260     ;;
261 vapier 1.90 as-needed)
262     ELT_walk_patches "${d}/ltmain.sh" "${p}"
263 loki_val 1.83 ret=$?
264     ;;
265 vapier 1.90 uclibc-ltconf)
266 azarah 1.60 # Newer libtoolize clears ltconfig, as not used anymore
267 vapier 1.90 if [[ -s ${d}/ltconfig ]] ; then
268     ELT_walk_patches "${d}/ltconfig" "${p}"
269 azarah 1.53 ret=$?
270     fi
271     ;;
272 vapier 1.90 fbsd-ltconf)
273     if [[ -s ${d}/ltconfig ]] ; then
274     ELT_walk_patches "${d}/ltconfig" "${p}"
275 flameeyes 1.68 ret=$?
276     fi
277     ;;
278 vapier 1.90 darwin-ltconf)
279 azarah 1.60 # Newer libtoolize clears ltconfig, as not used anymore
280 vapier 1.90 if [[ -s ${d}/ltconfig ]] ; then
281     ELT_walk_patches "${d}/ltconfig" "${p}"
282 azarah 1.60 ret=$?
283     fi
284     ;;
285 vapier 1.90 darwin-ltmain)
286 grobian 1.84 # special case to avoid false positives (failing to apply
287     # ltmain.sh path message), newer libtools have this patch
288     # built in, so not much to patch around then
289 vapier 1.90 if [[ -e ${d}/ltmain.sh ]] && \
290     ! grep -qs 'verstring="-compatibility_version' "${d}/ltmain.sh" ; then
291     ELT_walk_patches "${d}/ltmain.sh" "${p}"
292 grobian 1.84 ret=$?
293     fi
294     ;;
295 vapier 1.90 install-sh)
296     ELT_walk_patches "${d}/install-sh" "${p}"
297 uberlord 1.78 ret=$?
298     ;;
299 vapier 1.90 cross)
300 vapier 1.82 if tc-is-cross-compiler ; then
301 vapier 1.90 ELT_walk_patches "${d}/ltmain.sh" "${p}"
302 vapier 1.82 ret=$?
303     fi
304     ;;
305 azarah 1.24 *)
306 vapier 1.90 ELT_walk_patches "${d}/ltmain.sh" "${p}"
307 azarah 1.24 ret=$?
308     ;;
309     esac
310 mr_bones_ 1.27
311 vapier 1.42 if [[ ${ret} -ne 0 ]] ; then
312 vapier 1.90 case ${p} in
313     relink)
314     local version=$(ELT_libtool_version "${d}/ltmain.sh")
315 azarah 1.24 # Critical patch, but could be applied ...
316 azarah 1.59 # FIXME: Still need a patch for ltmain.sh > 1.4.0
317 vapier 1.90 if ! grep -qs 'inst_prefix_dir' "${d}/ltmain.sh" && \
318     [[ $(VER_to_int "${version}") -ge $(VER_to_int "1.4.0") ]] ; then
319 azarah 1.24 ewarn " Could not apply relink.patch!"
320     fi
321     ;;
322 vapier 1.90 portage)
323 azarah 1.24 # Critical patch - for this one we abort, as it can really
324     # cause breakage without it applied!
325 vapier 1.42 if [[ ${do_portage} == "yes" ]] ; then
326 azarah 1.24 # Stupid test to see if its already applied ...
327 vapier 1.90 if ! grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
328 azarah 1.24 echo
329     eerror "Portage patch requested, but failed to apply!"
330 vapier 1.88 eerror "Please file a bug report to add a proper patch."
331 azarah 1.24 die "Portage patch requested, but failed to apply!"
332     fi
333     else
334 vapier 1.90 if grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
335 azarah 1.51 # ewarn " Portage patch seems to be already applied."
336     # ewarn " Please verify that it is not needed."
337     :
338 azarah 1.45 else
339 flameeyes 1.91 local version=$(ELT_libtool_version "${d}"/ltmain.sh)
340 azarah 1.45 echo
341 azarah 1.46 eerror "Portage patch failed to apply (ltmain.sh version ${version})!"
342 vapier 1.88 eerror "Please file a bug report to add a proper patch."
343 azarah 1.45 die "Portage patch failed to apply!"
344     fi
345     # We do not want to run libtoolize ...
346     ELT_APPLIED_PATCHES="portage"
347 azarah 1.3 fi
348     ;;
349 vapier 1.90 darwin-*)
350     [[ ${CHOST} == *"-darwin"* ]] && ewarn " Darwin patch set '${p}' failed to apply!"
351 flameeyes 1.55 ;;
352 azarah 1.3 esac
353 azarah 1.1 fi
354 azarah 1.52 done
355 azarah 1.11
356 haubi 1.107 # makes sense for ltmain.sh patches only
357     [[ -f ${d}/ltmain.sh ]] &&
358 azarah 1.52 if [[ -z ${ELT_APPLIED_PATCHES} ]] ; then
359     if [[ ${do_portage} == "no" && \
360     ${do_reversedeps} == "no" && \
361     ${do_only_patches} == "no" && \
362     ${deptoremove} == "" ]]
363     then
364     ewarn "Cannot apply any patches, please file a bug about this"
365 vapier 1.75 die
366 azarah 1.1 fi
367 azarah 1.52 fi
368    
369 haubi 1.107 # patching configure
370     [[ -f ${d}/configure ]] &&
371     for p in ${elt_patches} ; do
372     ret=0
373    
374     case ${p} in
375     uclibc-conf)
376     if grep -qs 'Transform linux' "${d}/configure" ; then
377     ELT_walk_patches "${d}/configure" "${p}"
378     ret=$?
379     fi
380     ;;
381     fbsd-conf)
382     if grep -qs 'version_type=freebsd-' "${d}/configure" ; then
383     ELT_walk_patches "${d}/configure" "${p}"
384     ret=$?
385     fi
386     ;;
387     darwin-conf)
388     if grep -qs '&& echo \.so ||' "${d}/configure" ; then
389     ELT_walk_patches "${d}/configure" "${p}"
390     ret=$?
391     fi
392     ;;
393     aixrtl|hpux-conf)
394     ret=1
395     local subret=0
396     # apply multiple patches as often as they match
397     while [[ $subret -eq 0 ]]; do
398     subret=1
399     if [[ -e ${d}/configure ]]; then
400     ELT_walk_patches "${d}/configure" "${p}"
401     subret=$?
402     fi
403     if [[ $subret -eq 0 ]]; then
404     # have at least one patch succeeded.
405     ret=0
406     fi
407     done
408     ;;
409     mint-conf|gold-conf|sol2-conf)
410     ELT_walk_patches "${d}/configure" "${p}"
411     ret=$?
412     ;;
413     target-nm)
414     ELT_walk_patches "${d}/configure" "${p}"
415     ret=$?
416     ;;
417     *)
418     # ltmain.sh patches are applied above
419     ;;
420     esac
421    
422     if [[ ${ret} -ne 0 ]] ; then
423     case ${p} in
424     uclibc-*)
425     [[ ${CHOST} == *-uclibc ]] && ewarn " uClibc patch set '${p}' failed to apply!"
426     ;;
427     fbsd-*)
428     if [[ ${CHOST} == *-freebsd* ]] ; then
429     if [[ -z $(grep 'Handle Gentoo/FreeBSD as it was Linux' \
430     "${d}/configure" 2>/dev/null) ]]; then
431     eerror " FreeBSD patch set '${p}' failed to apply!"
432     die "FreeBSD patch set '${p}' failed to apply!"
433     fi
434     fi
435     ;;
436     darwin-*)
437     [[ ${CHOST} == *"-darwin"* ]] && ewarn " Darwin patch set '${p}' failed to apply!"
438     ;;
439     esac
440     fi
441     done
442    
443 vapier 1.90 rm -f "${d}/libtool"
444 azarah 1.52
445 vapier 1.90 > "${d}/.elibtoolized"
446 azarah 1.1 done
447 vapier 1.30 }
448    
449 vapier 1.90 uclibctoolize() { die "Use elibtoolize"; }
450     darwintoolize() { die "Use elibtoolize"; }
451 azarah 1.44
452     # char *VER_major(string)
453     #
454     # Return the Major (X of X.Y.Z) version
455     #
456     VER_major() {
457     [[ -z $1 ]] && return 1
458    
459     local VER=$@
460 azarah 1.57 echo "${VER%%[^[:digit:]]*}"
461 azarah 1.44 }
462    
463     # char *VER_minor(string)
464     #
465     # Return the Minor (Y of X.Y.Z) version
466     #
467     VER_minor() {
468     [[ -z $1 ]] && return 1
469    
470     local VER=$@
471     VER=${VER#*.}
472 azarah 1.57 echo "${VER%%[^[:digit:]]*}"
473 azarah 1.44 }
474    
475     # char *VER_micro(string)
476     #
477     # Return the Micro (Z of X.Y.Z) version.
478     #
479     VER_micro() {
480     [[ -z $1 ]] && return 1
481    
482     local VER=$@
483     VER=${VER#*.*.}
484 azarah 1.57 echo "${VER%%[^[:digit:]]*}"
485 azarah 1.44 }
486    
487     # int VER_to_int(string)
488     #
489     # Convert a string type version (2.4.0) to an int (132096)
490     # for easy compairing or versions ...
491     #
492     VER_to_int() {
493     [[ -z $1 ]] && return 1
494    
495     local VER_MAJOR=$(VER_major "$1")
496     local VER_MINOR=$(VER_minor "$1")
497     local VER_MICRO=$(VER_micro "$1")
498     local VER_int=$(( VER_MAJOR * 65536 + VER_MINOR * 256 + VER_MICRO ))
499    
500     # We make version 1.0.0 the minimum version we will handle as
501     # a sanity check ... if its less, we fail ...
502     if [[ ${VER_int} -ge 65536 ]] ; then
503     echo "${VER_int}"
504     return 0
505     fi
506    
507     echo 1
508     return 1
509     }
510 vapier 1.97
511     fi

  ViewVC Help
Powered by ViewVC 1.1.20