/[gentoo-x86]/eclass/libtool.eclass
Gentoo

Contents of /eclass/libtool.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.97 - (hide annotations) (download)
Tue Dec 13 21:28:15 2011 UTC (2 years, 9 months ago) by vapier
Branch: MAIN
Changes since 1.96: +6 -1 lines
avoid multiple inclusions when possible to speed caching up

1 vapier 1.94 # Copyright 1999-2011 Gentoo Foundation
2 vapier 1.15 # Distributed under the terms of the GNU General Public License v2
3 vapier 1.97 # $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.96 2011/11/18 17:32:14 vapier Exp $
4 vapier 1.90
5     # @ECLASS: libtool.eclass
6     # @MAINTAINER:
7     # base-system@gentoo.org
8     # @BLURB: quickly update bundled libtool code
9     # @DESCRIPTION:
10 azarah 1.1 # This eclass patches ltmain.sh distributed with libtoolized packages with the
11 azarah 1.24 # relink and portage patch among others
12 vapier 1.75 #
13     # Note, this eclass does not require libtool as it only applies patches to
14     # generated libtool files. We do not run the libtoolize program because that
15     # requires a regeneration of the main autotool files in order to work properly.
16 rac 1.34
17 vapier 1.97 if [[ ${___ECLASS_ONCE_LIBTOOL} != "recur -_+^+_- spank" ]] ; then
18     ___ECLASS_ONCE_LIBTOOL="recur -_+^+_- spank"
19    
20 vapier 1.96 # If an overlay has eclass overrides, but doesn't actually override the
21     # libtool.eclass, we'll have ECLASSDIR pointing to the active overlay's
22     # eclass/ dir, but libtool.eclass is still in the main Gentoo tree. So
23     # add a check to locate the ELT-patches/ regardless of what's going on.
24     ECLASSDIR_LOCAL=${BASH_SOURCE[0]%/*}
25     elt_patch_dir() {
26     local d="${ECLASSDIR}/ELT-patches"
27     if [[ ! -d ${d} ]] ; then
28     d="${ECLASSDIR_LOCAL}/ELT-patches"
29     fi
30     echo "${d}"
31     }
32    
33 vapier 1.22 DESCRIPTION="Based on the ${ECLASS} eclass"
34 azarah 1.1
35 vapier 1.94 inherit multilib toolchain-funcs
36 vapier 1.82
37 azarah 1.24 #
38     # See if we can apply $2 on $1, and if so, do it
39     #
40     ELT_try_and_apply_patch() {
41     local ret=0
42 azarah 1.57 local file=$1
43     local patch=$2
44 vapier 1.94 local src=$3
45     local disp="${src} patch"
46     local log="${T}/elibtool.log"
47    
48     if [[ -z ${__ELT_NOTED_TMP} ]] ; then
49     __ELT_NOTED_TMP=true
50     printf 'temp patch: %s\n' "${patch}" > "${log}"
51     fi
52     printf '\nTrying %s\n' "${disp}" >> "${log}"
53 flameeyes 1.91
54 azarah 1.24 # We only support patchlevel of 0 - why worry if its static patches?
55 vapier 1.94 if patch -p0 --dry-run "${file}" "${patch}" >> "${log}" 2>&1 ; then
56     einfo " Applying ${disp} ..."
57     patch -p0 -g0 --no-backup-if-mismatch "${file}" "${patch}" >> "${log}" 2>&1
58 azarah 1.24 ret=$?
59 vapier 1.94 export ELT_APPLIED_PATCHES="${ELT_APPLIED_PATCHES} ${src}"
60 azarah 1.24 else
61     ret=1
62     fi
63    
64 azarah 1.57 return "${ret}"
65 azarah 1.24 }
66    
67     #
68 azarah 1.59 # Get string version of ltmain.sh or ltconfig (passed as $1)
69     #
70     ELT_libtool_version() {
71 vapier 1.90 (
72     unset VERSION
73     eval $(grep -e '^[[:space:]]*VERSION=' "$1")
74     echo "${VERSION:-0}"
75     )
76 azarah 1.59 }
77    
78     #
79 azarah 1.24 # Run through the patches in $2 and see if any
80     # apply to $1 ...
81     #
82     ELT_walk_patches() {
83 vapier 1.94 local patch tmp
84 azarah 1.24 local ret=1
85 azarah 1.57 local file=$1
86     local patch_set=$2
87 vapier 1.96 local patch_dir="$(elt_patch_dir)/${patch_set}"
88 azarah 1.57 local rem_int_dep=$3
89 azarah 1.2
90 vapier 1.86 [[ -z ${patch_set} ]] && return 1
91     [[ ! -d ${patch_dir} ]] && return 1
92 mr_bones_ 1.27
93 vapier 1.94 # Allow patches to use @GENTOO_LIBDIR@ replacements
94     local sed_args=( -e "s:@GENTOO_LIBDIR@:$(get_libdir):g" )
95     if [[ -n ${rem_int_dep} ]] ; then
96     # replace @REM_INT_DEP@ with what was passed
97     # to --remove-internal-dep
98     sed_args+=( -e "s|@REM_INT_DEP@|${rem_int_dep}|g" )
99     fi
100    
101 vapier 1.96 pushd "$(elt_patch_dir)" >/dev/null || die
102 azarah 1.43
103 vapier 1.86 # Go through the patches in reverse order (newer version to older)
104     for patch in $(find "${patch_set}" -maxdepth 1 -type f | LC_ALL=C sort -r) ; do
105 vapier 1.94 tmp="${T}/libtool-elt.patch"
106     sed "${sed_args[@]}" "${patch}" > "${tmp}" || die
107     if ELT_try_and_apply_patch "${file}" "${tmp}" "${patch}" ; then
108 vapier 1.86 # Break to unwind w/popd rather than return directly
109     ret=0
110     break
111     fi
112     done
113 azarah 1.24
114 vapier 1.87 popd >/dev/null
115 vapier 1.86 return ${ret}
116 azarah 1.24 }
117    
118 vapier 1.90 # @FUNCTION: elibtoolize
119     # @USAGE: [dirs] [--portage] [--reverse-deps] [--patch-only] [--remove-internal-dep=xxx] [--shallow] [--no-uclibc]
120     # @DESCRIPTION:
121     # Apply a smorgasbord of patches to bundled libtool files. This function
122     # should always be safe to run. If no directories are specified, then
123     # ${S} will be searched for appropriate files.
124     #
125     # If the --shallow option is used, then only ${S}/ltmain.sh will be patched.
126     #
127     # The other options should be avoided in general unless you know what's going on.
128 azarah 1.24 elibtoolize() {
129 vapier 1.90 local x
130 azarah 1.24 local do_portage="no"
131     local do_reversedeps="no"
132     local do_only_patches="no"
133 azarah 1.56 local do_uclibc="yes"
134 azarah 1.24 local deptoremove=
135 vapier 1.90 local do_shallow="no"
136 vapier 1.95 local force="false"
137 loki_val 1.83 local elt_patches="install-sh ltmain portage relink max_cmd_len sed test tmp cross as-needed"
138 mr_bones_ 1.27
139 vapier 1.42 for x in "$@" ; do
140 vapier 1.90 case ${x} in
141     --portage)
142 azarah 1.24 # Only apply portage patch, and don't
143     # 'libtoolize --copy --force' if all patches fail.
144     do_portage="yes"
145     ;;
146 vapier 1.90 --reverse-deps)
147 azarah 1.24 # Apply the reverse-deps patch
148     # http://bugzilla.gnome.org/show_bug.cgi?id=75635
149     do_reversedeps="yes"
150 vapier 1.90 elt_patches+=" fix-relink"
151 azarah 1.24 ;;
152 vapier 1.90 --patch-only)
153 azarah 1.24 # Do not run libtoolize if none of the patches apply ..
154     do_only_patches="yes"
155     ;;
156 vapier 1.90 --remove-internal-dep=*)
157 azarah 1.24 # We will replace @REM_INT_DEP@ with what is needed
158     # in ELT_walk_patches() ...
159 vapier 1.90 deptoremove=${x#--remove-internal-dep=}
160 azarah 1.24
161     # Add the patch for this ...
162 vapier 1.90 [[ -n ${deptoremove} ]] && elt_patches+=" rem-int-dep"
163 azarah 1.24 ;;
164 vapier 1.90 --shallow)
165 azarah 1.24 # Only patch the ltmain.sh in ${S}
166 vapier 1.90 do_shallow="yes"
167 azarah 1.24 ;;
168 vapier 1.90 --no-uclibc)
169 azarah 1.56 do_uclibc="no"
170 vapier 1.40 ;;
171 vapier 1.95 --force)
172     force="true"
173     ;;
174 vapier 1.42 *)
175 azarah 1.57 eerror "Invalid elibtoolize option: ${x}"
176     die "elibtoolize called with ${x} ??"
177 azarah 1.24 esac
178 azarah 1.4 done
179 azarah 1.1
180 vapier 1.90 [[ ${do_uclibc} == "yes" ]] && elt_patches+=" uclibc-conf uclibc-ltconf"
181 azarah 1.56
182 vapier 1.90 case ${CHOST} in
183     *-aix*) elt_patches+=" hardcode aixrtl aix-noundef" ;; #213277
184     *-darwin*) elt_patches+=" darwin-ltconf darwin-ltmain darwin-conf" ;;
185     *-freebsd*) elt_patches+=" fbsd-conf fbsd-ltconf" ;;
186     *-hpux*) elt_patches+=" hpux-conf deplibs hc-flag-ld hardcode hardcode-relink relink-prog no-lc" ;;
187     *-irix*) elt_patches+=" irix-ltmain" ;;
188     *-mint*) elt_patches+=" mint-conf" ;;
189 grobian 1.84 esac
190 usata 1.36
191 flameeyes 1.91 if $(tc-getLD) --version 2>&1 | grep -qs 'GNU gold'; then
192     elt_patches+=" gold-conf"
193     fi
194    
195 vapier 1.90 # Reuse "$@" for dirs to patch
196     set --
197     if [[ ${do_shallow} == "yes" ]] ; then
198     [[ -f ${S}/ltmain.sh ]] && set -- "${S}"
199     else
200     set -- $(find "${S}" -name ltmain.sh -printf '%h ')
201     fi
202    
203     local d p
204     for d in "$@" ; do
205 azarah 1.24 export ELT_APPLIED_PATCHES=
206 mr_bones_ 1.27
207 vapier 1.95 if [[ -f ${d}/.elibtoolized ]] ; then
208     ${force} || continue
209     fi
210 azarah 1.52
211 vapier 1.90 einfo "Running elibtoolize in: ${d#${WORKDIR}/}/"
212 vapier 1.95 if [[ -f ${d}/.elibtoolized ]] ; then
213     ewarn " We've already been run in this tree; you should"
214     ewarn " avoid this if possible (perhaps by filing a bug)"
215     fi
216 azarah 1.2
217 vapier 1.90 for p in ${elt_patches} ; do
218 azarah 1.24 local ret=0
219    
220 vapier 1.90 case ${p} in
221     portage)
222 azarah 1.64 # Stupid test to see if its already applied ...
223 vapier 1.90 if ! grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
224     ELT_walk_patches "${d}/ltmain.sh" "${p}"
225 azarah 1.64 ret=$?
226     fi
227     ;;
228 vapier 1.90 rem-int-dep)
229     ELT_walk_patches "${d}/ltmain.sh" "${p}" "${deptoremove}"
230 azarah 1.24 ret=$?
231     ;;
232 vapier 1.90 fix-relink)
233 azarah 1.24 # Do not apply if we do not have the relink patch applied ...
234 vapier 1.90 if grep -qs 'inst_prefix_dir' "${d}/ltmain.sh" ; then
235     ELT_walk_patches "${d}/ltmain.sh" "${p}"
236 azarah 1.24 ret=$?
237     fi
238     ;;
239 vapier 1.90 max_cmd_len)
240 azarah 1.25 # Do not apply if $max_cmd_len is not used ...
241 vapier 1.90 if grep -qs 'max_cmd_len' "${d}/ltmain.sh" ; then
242     ELT_walk_patches "${d}/ltmain.sh" "${p}"
243 azarah 1.25 ret=$?
244     fi
245     ;;
246 vapier 1.90 as-needed)
247     ELT_walk_patches "${d}/ltmain.sh" "${p}"
248 loki_val 1.83 ret=$?
249     ;;
250 vapier 1.90 uclibc-conf)
251     if grep -qs 'Transform linux' "${d}/configure" ; then
252     ELT_walk_patches "${d}/configure" "${p}"
253 azarah 1.53 ret=$?
254     # ltmain.sh and co might be in a subdirectory ...
255 vapier 1.90 elif [[ ! -e ${d}/configure ]] && \
256 flameeyes 1.91 grep -qs 'Transform linux' "${d}/../configure" ; then
257 vapier 1.90 ELT_walk_patches "${d}/../configure" "${p}"
258 azarah 1.53 ret=$?
259     fi
260     ;;
261 vapier 1.90 uclibc-ltconf)
262 azarah 1.60 # Newer libtoolize clears ltconfig, as not used anymore
263 vapier 1.90 if [[ -s ${d}/ltconfig ]] ; then
264     ELT_walk_patches "${d}/ltconfig" "${p}"
265 azarah 1.53 ret=$?
266     fi
267     ;;
268 vapier 1.90 fbsd-conf)
269     if grep -qs 'version_type=freebsd-' "${d}/configure" ; then
270     ELT_walk_patches "${d}/configure" "${p}"
271 flameeyes 1.55 ret=$?
272     # ltmain.sh and co might be in a subdirectory ...
273 vapier 1.90 elif [[ ! -e ${d}/configure ]] && \
274 flameeyes 1.91 grep -qs 'version_type=freebsd-' "${d}/../configure" ; then
275 vapier 1.90 ELT_walk_patches "${d}/../configure" "${p}"
276 flameeyes 1.55 ret=$?
277     fi
278     ;;
279 vapier 1.90 fbsd-ltconf)
280     if [[ -s ${d}/ltconfig ]] ; then
281     ELT_walk_patches "${d}/ltconfig" "${p}"
282 flameeyes 1.68 ret=$?
283     fi
284     ;;
285 vapier 1.90 darwin-conf)
286     if grep -qs '&& echo \.so ||' "${d}/configure" ; then
287     ELT_walk_patches "${d}/configure" "${p}"
288 grobian 1.84 ret=$?
289     # ltmain.sh and co might be in a subdirectory ...
290 vapier 1.90 elif [[ ! -e ${d}/configure ]] && \
291 flameeyes 1.91 grep -qs '&& echo \.so ||' "${d}/../configure" ; then
292 vapier 1.90 ELT_walk_patches "${d}/../configure" "${p}"
293 grobian 1.84 ret=$?
294     fi
295     ;;
296 vapier 1.90 darwin-ltconf)
297 azarah 1.60 # Newer libtoolize clears ltconfig, as not used anymore
298 vapier 1.90 if [[ -s ${d}/ltconfig ]] ; then
299     ELT_walk_patches "${d}/ltconfig" "${p}"
300 azarah 1.60 ret=$?
301     fi
302     ;;
303 vapier 1.90 darwin-ltmain)
304 grobian 1.84 # special case to avoid false positives (failing to apply
305     # ltmain.sh path message), newer libtools have this patch
306     # built in, so not much to patch around then
307 vapier 1.90 if [[ -e ${d}/ltmain.sh ]] && \
308     ! grep -qs 'verstring="-compatibility_version' "${d}/ltmain.sh" ; then
309     ELT_walk_patches "${d}/ltmain.sh" "${p}"
310 grobian 1.84 ret=$?
311     fi
312     ;;
313 vapier 1.90 aixrtl|hpux-conf)
314 haubi 1.85 ret=1
315     local subret=0
316     # apply multiple patches as often as they match
317     while [[ $subret -eq 0 ]]; do
318     subret=1
319 vapier 1.90 if [[ -e ${d}/configure ]]; then
320     ELT_walk_patches "${d}/configure" "${p}"
321 haubi 1.85 subret=$?
322     # ltmain.sh and co might be in a subdirectory ...
323 vapier 1.90 elif [[ ! -e ${d}/configure && -e ${d}/../configure ]] ; then
324     ELT_walk_patches "${d}/../configure" "${p}"
325 haubi 1.85 subret=$?
326     fi
327     if [[ $subret -eq 0 ]]; then
328     # have at least one patch succeeded.
329     ret=0
330     fi
331     done
332     ;;
333 flameeyes 1.91 mint-conf|gold-conf)
334 grobian 1.84 ret=1
335     local subret=1
336 vapier 1.90 if [[ -e ${d}/configure ]]; then
337     ELT_walk_patches "${d}/configure" "${p}"
338 grobian 1.84 subret=$?
339     # ltmain.sh and co might be in a subdirectory ...
340 flameeyes 1.91 elif [[ -e ${d}/../configure ]] ; then
341 vapier 1.90 ELT_walk_patches "${d}/../configure" "${p}"
342 grobian 1.84 subret=$?
343 flameeyes 1.91 elif [[ -e ${d}/../../configure ]] ; then
344     ELT_walk_patches "${d}/../../configure" "${p}"
345     subret=$?
346 grobian 1.84 fi
347     if [[ $subret -eq 0 ]]; then
348     # have at least one patch succeeded.
349     ret=0
350     fi
351     ;;
352 vapier 1.90 install-sh)
353     ELT_walk_patches "${d}/install-sh" "${p}"
354 uberlord 1.78 ret=$?
355     ;;
356 vapier 1.90 cross)
357 vapier 1.82 if tc-is-cross-compiler ; then
358 vapier 1.90 ELT_walk_patches "${d}/ltmain.sh" "${p}"
359 vapier 1.82 ret=$?
360     fi
361     ;;
362 azarah 1.24 *)
363 vapier 1.90 ELT_walk_patches "${d}/ltmain.sh" "${p}"
364 azarah 1.24 ret=$?
365     ;;
366     esac
367 mr_bones_ 1.27
368 vapier 1.42 if [[ ${ret} -ne 0 ]] ; then
369 vapier 1.90 case ${p} in
370     relink)
371     local version=$(ELT_libtool_version "${d}/ltmain.sh")
372 azarah 1.24 # Critical patch, but could be applied ...
373 azarah 1.59 # FIXME: Still need a patch for ltmain.sh > 1.4.0
374 vapier 1.90 if ! grep -qs 'inst_prefix_dir' "${d}/ltmain.sh" && \
375     [[ $(VER_to_int "${version}") -ge $(VER_to_int "1.4.0") ]] ; then
376 azarah 1.24 ewarn " Could not apply relink.patch!"
377     fi
378     ;;
379 vapier 1.90 portage)
380 azarah 1.24 # Critical patch - for this one we abort, as it can really
381     # cause breakage without it applied!
382 vapier 1.42 if [[ ${do_portage} == "yes" ]] ; then
383 azarah 1.24 # Stupid test to see if its already applied ...
384 vapier 1.90 if ! grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
385 azarah 1.24 echo
386     eerror "Portage patch requested, but failed to apply!"
387 vapier 1.88 eerror "Please file a bug report to add a proper patch."
388 azarah 1.24 die "Portage patch requested, but failed to apply!"
389     fi
390     else
391 vapier 1.90 if grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
392 azarah 1.51 # ewarn " Portage patch seems to be already applied."
393     # ewarn " Please verify that it is not needed."
394     :
395 azarah 1.45 else
396 flameeyes 1.91 local version=$(ELT_libtool_version "${d}"/ltmain.sh)
397 azarah 1.45 echo
398 azarah 1.46 eerror "Portage patch failed to apply (ltmain.sh version ${version})!"
399 vapier 1.88 eerror "Please file a bug report to add a proper patch."
400 azarah 1.45 die "Portage patch failed to apply!"
401     fi
402     # We do not want to run libtoolize ...
403     ELT_APPLIED_PATCHES="portage"
404 azarah 1.3 fi
405     ;;
406 vapier 1.90 uclibc-*)
407     [[ ${CHOST} == *-uclibc ]] && ewarn " uClibc patch set '${p}' failed to apply!"
408 azarah 1.53 ;;
409 vapier 1.90 fbsd-*)
410     if [[ ${CHOST} == *-freebsd* ]] ; then
411 flameeyes 1.65 if [[ -z $(grep 'Handle Gentoo/FreeBSD as it was Linux' \
412 vapier 1.90 "${d}/configure" "${d}/../configure" 2>/dev/null) ]]; then
413     eerror " FreeBSD patch set '${p}' failed to apply!"
414     die "FreeBSD patch set '${p}' failed to apply!"
415 flameeyes 1.61 fi
416 azarah 1.60 fi
417     ;;
418 vapier 1.90 darwin-*)
419     [[ ${CHOST} == *"-darwin"* ]] && ewarn " Darwin patch set '${p}' failed to apply!"
420 flameeyes 1.55 ;;
421 azarah 1.3 esac
422 azarah 1.1 fi
423 azarah 1.52 done
424 azarah 1.11
425 azarah 1.52 if [[ -z ${ELT_APPLIED_PATCHES} ]] ; then
426     if [[ ${do_portage} == "no" && \
427     ${do_reversedeps} == "no" && \
428     ${do_only_patches} == "no" && \
429     ${deptoremove} == "" ]]
430     then
431     ewarn "Cannot apply any patches, please file a bug about this"
432 vapier 1.75 die
433 azarah 1.1 fi
434 azarah 1.52 fi
435    
436 vapier 1.90 rm -f "${d}/libtool"
437 azarah 1.52
438 vapier 1.90 > "${d}/.elibtoolized"
439 azarah 1.1 done
440 vapier 1.30 }
441    
442 vapier 1.90 uclibctoolize() { die "Use elibtoolize"; }
443     darwintoolize() { die "Use elibtoolize"; }
444 azarah 1.44
445     # char *VER_major(string)
446     #
447     # Return the Major (X of X.Y.Z) version
448     #
449     VER_major() {
450     [[ -z $1 ]] && return 1
451    
452     local VER=$@
453 azarah 1.57 echo "${VER%%[^[:digit:]]*}"
454 azarah 1.44 }
455    
456     # char *VER_minor(string)
457     #
458     # Return the Minor (Y of X.Y.Z) version
459     #
460     VER_minor() {
461     [[ -z $1 ]] && return 1
462    
463     local VER=$@
464     VER=${VER#*.}
465 azarah 1.57 echo "${VER%%[^[:digit:]]*}"
466 azarah 1.44 }
467    
468     # char *VER_micro(string)
469     #
470     # Return the Micro (Z of X.Y.Z) version.
471     #
472     VER_micro() {
473     [[ -z $1 ]] && return 1
474    
475     local VER=$@
476     VER=${VER#*.*.}
477 azarah 1.57 echo "${VER%%[^[:digit:]]*}"
478 azarah 1.44 }
479    
480     # int VER_to_int(string)
481     #
482     # Convert a string type version (2.4.0) to an int (132096)
483     # for easy compairing or versions ...
484     #
485     VER_to_int() {
486     [[ -z $1 ]] && return 1
487    
488     local VER_MAJOR=$(VER_major "$1")
489     local VER_MINOR=$(VER_minor "$1")
490     local VER_MICRO=$(VER_micro "$1")
491     local VER_int=$(( VER_MAJOR * 65536 + VER_MINOR * 256 + VER_MICRO ))
492    
493     # We make version 1.0.0 the minimum version we will handle as
494     # a sanity check ... if its less, we fail ...
495     if [[ ${VER_int} -ge 65536 ]] ; then
496     echo "${VER_int}"
497     return 0
498     fi
499    
500     echo 1
501     return 1
502     }
503 vapier 1.97
504     fi

  ViewVC Help
Powered by ViewVC 1.1.20