/[gentoo-x86]/eclass/libtool.eclass
Gentoo

Diff of /eclass/libtool.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.42 Revision 1.63
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.42 2005/01/31 03:02:13 vapier Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.63 2006/01/22 00:24:15 azarah Exp $
4# 4#
5# Author: Martin Schlemmer <azarah@gentoo.org> 5# Author: Martin Schlemmer <azarah@gentoo.org>
6# 6#
7# This eclass patches ltmain.sh distributed with libtoolized packages with the 7# This eclass patches ltmain.sh distributed with libtoolized packages with the
8# relink and portage patch among others 8# relink and portage patch among others
9 9
10ECLASS="libtool"
11INHERITED="${INHERITED} ${ECLASS}"
12 10
13# 2004.09.25 rac 11# 2004.09.25 rac
14# i have verified that at least one package can use this eclass and 12# i have verified that at least one package can use this eclass and
15# build properly even without libtool installed yet, probably using 13# build properly even without libtool installed yet, probably using
16# the files in the distribution. eliminating this dependency fixes 14# the files in the distribution. eliminating this dependency fixes
18# stageballs <3. if anybody decides to revert this, please attempt 16# stageballs <3. if anybody decides to revert this, please attempt
19# to find an alternate way of resolving that bug at the same time. 17# to find an alternate way of resolving that bug at the same time.
20 18
21DESCRIPTION="Based on the ${ECLASS} eclass" 19DESCRIPTION="Based on the ${ECLASS} eclass"
22 20
23ELIBTOOL_VERSION="2.0.1" 21ELIBTOOL_VERSION="2.0.2"
24 22
25ELT_PATCH_DIR="${PORTDIR}/eclass/ELT-patches" 23ELT_PATCH_DIR="${PORTDIR}/eclass/ELT-patches"
26ELT_APPLIED_PATCHES= 24ELT_APPLIED_PATCHES=
25ELT_LTMAIN_SH=
27 26
28# 27#
29# Returns all the directories containing ltmain.sh 28# Returns all the directories containing ltmain.sh
30# 29#
31ELT_find_ltmain_sh() { 30ELT_find_ltmain_sh() {
42# 41#
43# See if we can apply $2 on $1, and if so, do it 42# See if we can apply $2 on $1, and if so, do it
44# 43#
45ELT_try_and_apply_patch() { 44ELT_try_and_apply_patch() {
46 local ret=0 45 local ret=0
46 local file=$1
47 local patch="$2" 47 local patch=$2
48 48
49 # We only support patchlevel of 0 - why worry if its static patches? 49 # We only support patchlevel of 0 - why worry if its static patches?
50 if patch -p0 --dry-run $1 < ${patch} &> ${T}/elibtool.log ; then 50 if patch -p0 --dry-run "${file}" "${patch}" &> "${T}/elibtool.log" ; then
51 einfo " Applying $(basename "$(dirname "${patch}")")-${patch##*/}.patch ..." 51 einfo " Applying $(basename "$(dirname "${patch}")")-${patch##*/}.patch ..."
52 patch -p0 $1 < ${patch} &>${T}/elibtool.log 52 patch -p0 -g0 --no-backup-if-mismatch "${file}" "${patch}" \
53 &> "${T}/elibtool.log"
53 ret=$? 54 ret=$?
54 export ELT_APPLIED_PATCHES="${ELT_APPLIED_PATCHES} ${patch##*/}" 55 export ELT_APPLIED_PATCHES="${ELT_APPLIED_PATCHES} ${patch##*/}"
55 else 56 else
56 ret=1 57 ret=1
57 fi 58 fi
58 59
59 return ${ret} 60 return "${ret}"
61}
62
63#
64# Get string version of ltmain.sh or ltconfig (passed as $1)
65#
66ELT_libtool_version() {
67 local ltmain_sh=$1
68 local version=
69
70 version=$(eval $(grep -e '^[[:space:]]*VERSION=' "${ltmain_sh}"); \
71 echo "${VERSION}")
72 [[ -z ${version} ]] && version="0"
73
74 echo "${version}"
60} 75}
61 76
62# 77#
63# Run through the patches in $2 and see if any 78# Run through the patches in $2 and see if any
64# apply to $1 ... 79# apply to $1 ...
65# 80#
66ELT_walk_patches() { 81ELT_walk_patches() {
67 local x= 82 local x=
68 local y= 83 local y=
69 local ret=1 84 local ret=1
85 local file=$1
86 local patch_set=$2
70 local patch_dir= 87 local patch_dir=
88 local rem_int_dep=$3
89 local version=
90 local ltmain_sh=$1
71 91
92 [[ ${file} == *"/configure" ]] && ltmain_sh=${ELT_LTMAIN_SH}
93 version=$(ELT_libtool_version "${ltmain_sh}")
94
72 if [[ -n $2 ]] ; then 95 if [[ -n ${patch_set} ]] ; then
73 if [[ -d ${ELT_PATCH_DIR}/$2 ]] ; then 96 if [[ -d ${ELT_PATCH_DIR}/${patch_set} ]] ; then
74 patch_dir="${ELT_PATCH_DIR}/$2" 97 patch_dir="${ELT_PATCH_DIR}/${patch_set}"
75 else 98 else
76 return ${ret} 99 return "${ret}"
77 fi 100 fi
78 101
102 if [[ ${version} == "0" ]] ; then
103 eerror "Could not get VERSION for ${file##*/}!"
104 die "Could not get VERSION for ${file##*/}!"
105 fi
106
107 # Go through the patches in reverse order (large to small)
79 for x in $(ls -d "${patch_dir}"/* 2> /dev/null) ; do 108 for x in $(ls -d "${patch_dir}"/* 2> /dev/null | grep -v 'CVS' | sort -r) ; do
80 if [[ -n ${x} && -f ${x} ]] ; then 109 if [[ -n ${x} && -f ${x} ]] ; then
110 local ltver=$(VER_to_int "${version}")
111 local ptver=$(VER_to_int "${x##*/}")
112
113 # If libtool version smaller than patch version, skip patch.
114 [[ ${ltver} -lt ${ptver} ]] && continue
81 # For --remove-internal-dep ... 115 # For --remove-internal-dep ...
82 if [[ -n $3 ]] ; then 116 if [[ -n ${rem_int_dep} ]] ; then
83 # For replace @REM_INT_DEP@ with what was passed 117 # For replace @REM_INT_DEP@ with what was passed
84 # to --remove-internal-dep 118 # to --remove-internal-dep
85 sed -e "s|@REM_INT_DEP@|$3|g" ${x} > \ 119 sed -e "s|@REM_INT_DEP@|${rem_int_dep}|g" ${x} > \
86 ${T}/$$.rem_int_deps.patch 120 "${T}/$$.rem_int_deps.patch"
87 121
88 x="${T}/$$.rem_int_deps.patch" 122 x="${T}/$$.rem_int_deps.patch"
89 fi 123 fi
90 124
91 if ELT_try_and_apply_patch "$1" "${x}" ; then 125 if ELT_try_and_apply_patch "${file}" "${x}" ; then
92 ret=0 126 ret=0
93 break 127 break
94 fi 128 fi
95 fi 129 fi
96 done 130 done
97 fi 131 fi
98 132
99 return ${ret} 133 return "${ret}"
100} 134}
101 135
102elibtoolize() { 136elibtoolize() {
103 local x= 137 local x=
104 local y= 138 local y=
105 local do_portage="no" 139 local do_portage="no"
106 local do_reversedeps="no" 140 local do_reversedeps="no"
107 local do_only_patches="no" 141 local do_only_patches="no"
142 local do_uclibc="yes"
108 local deptoremove= 143 local deptoremove=
109 local my_dirlist= 144 local my_dirlist=
110 local elt_patches="portage relink max_cmd_len sed test tmp" 145 local elt_patches="portage relink max_cmd_len sed test tmp"
111 local start_dir="${PWD}" 146 local start_dir=${PWD}
112 147
113 my_dirlist="$(ELT_find_ltmain_sh)" 148 my_dirlist=$(ELT_find_ltmain_sh)
114 149
115 for x in "$@" ; do 150 for x in "$@" ; do
116 case "${x}" in 151 case "${x}" in
117 "--portage") 152 "--portage")
118 # Only apply portage patch, and don't 153 # Only apply portage patch, and don't
130 do_only_patches="yes" 165 do_only_patches="yes"
131 ;; 166 ;;
132 "^--remove-internal-dep="*) 167 "^--remove-internal-dep="*)
133 # We will replace @REM_INT_DEP@ with what is needed 168 # We will replace @REM_INT_DEP@ with what is needed
134 # in ELT_walk_patches() ... 169 # in ELT_walk_patches() ...
135 deptoremove="$(echo "${x}" | sed -e 's|--remove-internal-dep=||')" 170 deptoremove=$(echo "${x}" | sed -e 's|--remove-internal-dep=||')
136 171
137 # Add the patch for this ... 172 # Add the patch for this ...
138 [ -n "${deptoremove}" ] && elt_patches="${elt_patches} rem-int-dep" 173 [[ -n ${deptoremove} ]] && elt_patches="${elt_patches} rem-int-dep"
139 ;; 174 ;;
140 "--shallow") 175 "--shallow")
141 # Only patch the ltmain.sh in ${S} 176 # Only patch the ltmain.sh in ${S}
142 if [ -f "${S}/ltmain.sh" ] 177 if [[ -f ${S}/ltmain.sh ]] ; then
143 then
144 my_dirlist="${S}" 178 my_dirlist=${S}
145 else 179 else
146 my_dirlist= 180 my_dirlist=
147 fi 181 fi
148 ;; 182 ;;
149 "--no-uclibc") 183 "--no-uclibc")
150 NO_UCLIBCTOOLIZE=1 184 do_uclibc="no"
151 ;; 185 ;;
152 *) 186 *)
153 eerror "Invalid elibtoolize option: $x" 187 eerror "Invalid elibtoolize option: ${x}"
154 die "elibtoolize called with $x ??" 188 die "elibtoolize called with ${x} ??"
155 esac 189 esac
156 done 190 done
157 191
192 [[ ${do_uclibc} == "yes" ]] && \
193 elt_patches="${elt_patches} uclibc-conf uclibc-ltconf"
194
195 [[ ${CHOST} == *"-freebsd"* ]] && \
196 elt_patches="${elt_patches} fbsd-conf"
197
158 if use ppc-macos ; then 198 if useq ppc-macos ; then
199 local opts
200 [[ -f Makefile.am ]] && opts="--automake"
159 glibtoolize --copy --force 201 glibtoolize --copy --force ${opts}
160 darwintoolize 202
203 elt_patches="${elt_patches} darwin-ltconf darwin-ltmain"
161 fi 204 fi
162 205
163 for x in ${my_dirlist} ; do 206 for x in ${my_dirlist} ; do
164 local tmp=$(echo "${x}" | sed -e "s|${S}||") 207 local tmp=$(echo "${x}" | sed -e "s|${WORKDIR}||")
165 export ELT_APPLIED_PATCHES= 208 export ELT_APPLIED_PATCHES=
209 export ELT_LTMAIN_SH="${x}/ltmain.sh"
210
211 [[ -f ${x}/.elibtoolized ]] && continue
166 212
167 cd ${x} 213 cd ${x}
168 einfo "Patching \${S}$(echo "/${tmp}/ltmain.sh" | sed -e 's|//|/|g') ..." 214 einfo "Running elibtoolize in: $(echo "/${tmp}" | sed -e 's|//|/|g; s|^/||')"
169 215
170 for y in ${elt_patches} ; do 216 for y in ${elt_patches} ; do
171 local ret=0 217 local ret=0
172 218
173 case "${y}" in 219 case "${y}" in
187 if [[ -n $(grep 'max_cmd_len' "${x}/ltmain.sh") ]] ; then 233 if [[ -n $(grep 'max_cmd_len' "${x}/ltmain.sh") ]] ; then
188 ELT_walk_patches "${x}/ltmain.sh" "${y}" 234 ELT_walk_patches "${x}/ltmain.sh" "${y}"
189 ret=$? 235 ret=$?
190 fi 236 fi
191 ;; 237 ;;
238 "uclibc-conf")
239 if [[ -e ${x}/configure && \
240 -n $(grep 'Transform linux' "${x}/configure") ]] ; then
241 ELT_walk_patches "${x}/configure" "${y}"
242 ret=$?
243 # ltmain.sh and co might be in a subdirectory ...
244 elif [[ ! -e ${x}/configure && -e ${x}/../configure && \
245 -n $(grep 'Transform linux' "${x}/../configure") ]] ; then
246 ELT_walk_patches "${x}/../configure" "${y}"
247 ret=$?
248 fi
249 ;;
250 "uclibc-ltconf")
251 # Newer libtoolize clears ltconfig, as not used anymore
252 if [[ -s ${x}/ltconfig ]] ; then
253 ELT_walk_patches "${x}/ltconfig" "${y}"
254 ret=$?
255 fi
256 ;;
257 "fbsd-conf")
258 if [[ -e ${x}/configure && \
259 -n $(grep 'version_type=freebsd-' "${x}/configure") ]] ; then
260 ELT_walk_patches "${x}/configure" "${y}"
261 ret=$?
262 # ltmain.sh and co might be in a subdirectory ...
263 elif [[ ! -e ${x}/configure && -e ${x}/../configure && \
264 -n $(grep 'version_type=freebsd-' "${x}/../configure") ]] ; then
265 ELT_walk_patches "${x}/../configure" "${y}"
266 ret=$?
267 fi
268 ;;
269 "darwin-ltconf")
270 # Newer libtoolize clears ltconfig, as not used anymore
271 if [[ -s ${x}/ltconfig ]] ; then
272 ELT_walk_patches "${x}/ltconfig" "${y}"
273 ret=$?
274 fi
275 ;;
192 *) 276 *)
193 ELT_walk_patches "${x}/ltmain.sh" "${y}" 277 ELT_walk_patches "${x}/ltmain.sh" "${y}"
194 ret=$? 278 ret=$?
195 ;; 279 ;;
196 esac 280 esac
197 281
198 if [[ ${ret} -ne 0 ]] ; then 282 if [[ ${ret} -ne 0 ]] ; then
199 case ${y} in 283 case ${y} in
200 "relink") 284 "relink")
285 local version=$(ELT_libtool_version "${x}/ltmain.sh")
201 # Critical patch, but could be applied ... 286 # Critical patch, but could be applied ...
287 # FIXME: Still need a patch for ltmain.sh > 1.4.0
202 if [[ -z $(grep 'inst_prefix_dir' "${x}/ltmain.sh") ]] ; then 288 if [[ -z $(grep 'inst_prefix_dir' "${x}/ltmain.sh") && \
289 $(VER_to_int "${version}") -ge $(VER_to_int "1.4.0") ]] ; then
203 ewarn " Could not apply relink.patch!" 290 ewarn " Could not apply relink.patch!"
204 fi 291 fi
205 ;; 292 ;;
206 "portage") 293 "portage")
207 # Critical patch - for this one we abort, as it can really 294 # Critical patch - for this one we abort, as it can really
209 if [[ ${do_portage} == "yes" ]] ; then 296 if [[ ${do_portage} == "yes" ]] ; then
210 # Stupid test to see if its already applied ... 297 # Stupid test to see if its already applied ...
211 if [[ -z $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then 298 if [[ -z $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then
212 echo 299 echo
213 eerror "Portage patch requested, but failed to apply!" 300 eerror "Portage patch requested, but failed to apply!"
301 eerror "Please bug azarah or vapier to add proper patch."
214 die "Portage patch requested, but failed to apply!" 302 die "Portage patch requested, but failed to apply!"
215 fi 303 fi
216 else 304 else
217 ewarn " Could not apply portage.patch!" 305 if [[ -n $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then
306 # ewarn " Portage patch seems to be already applied."
218 ewarn " Please verify that it is not needed." 307 # ewarn " Please verify that it is not needed."
308 :
309 else
310 local version=$( \
311 eval $(grep -e '^[[:space:]]*VERSION=' "${x}/ltmain.sh"); \
312 echo "${VERSION}")
313
314 echo
315 eerror "Portage patch failed to apply (ltmain.sh version ${version})!"
316 eerror "Please bug azarah or vapier to add proper patch."
317 die "Portage patch failed to apply!"
318 fi
319 # We do not want to run libtoolize ...
320 ELT_APPLIED_PATCHES="portage"
219 fi 321 fi
322 ;;
323 "uclibc-"*)
324 [[ ${CHOST} == *"-uclibc" ]] && \
325 ewarn " uClibc patch set '${y}' failed to apply!"
326 ;;
327 "fbsd-"*)
328 if [[ ${CHOST} == *"-freebsd"* ]] ; then
329 if [[ -z $(grep 'Handle Gentoo/FreeBSD as it was Linux' "${x}/configure") ]]; then
330 eerror " FreeBSD patch set '${y}' failed to apply!"
331 die "FreeBSD patch set '${y}' failed to apply!"
332 fi
333 fi
334 ;;
335 "darwin-"*)
336 useq ppc-macos && \
337 ewarn " Darwin patch set '${y}' failed to apply!"
220 ;; 338 ;;
221 esac 339 esac
222 fi 340 fi
341 done
223 342
224 if [[ -z ${ELT_APPLIED_PATCHES} ]] ; then 343 if [[ -z ${ELT_APPLIED_PATCHES} ]] ; then
225 if [[ ${do_portage} == "no" && \ 344 if [[ ${do_portage} == "no" && \
226 ${do_reversedeps} == "no" && \ 345 ${do_reversedeps} == "no" && \
227 ${do_only_patches} == "no" && \ 346 ${do_only_patches} == "no" && \
228 ${deptoremove} == "" ]] 347 ${deptoremove} == "" ]]
229 then 348 then
349 ewarn "Cannot apply any patches, please file a bug about this"
350 break
351
230 # Sometimes ltmain.sh is in a subdirectory ... 352 # Sometimes ltmain.sh is in a subdirectory ...
231 if [[ ! -f ${x}/configure.in && ! -f ${x}/configure.ac ]] ; then 353 if [[ ! -f ${x}/configure.in && ! -f ${x}/configure.ac ]] ; then
232 if [[ -f ${x}/../configure.in || -f ${x}/../configure.ac ]] ; then 354 if [[ -f ${x}/../configure.in || -f ${x}/../configure.ac ]] ; then
233 cd "${x}"/../ 355 cd "${x}"/../
234 fi 356 fi
235 fi
236
237 if type -p libtoolize &> /dev/null ; then
238 ewarn "Cannot apply any patch, running libtoolize..."
239 libtoolize --copy --force
240 fi
241 cd "${x}"
242 break
243 fi 357 fi
358
359 if type -p libtoolize &> /dev/null ; then
360 ewarn "Cannot apply any patches, running libtoolize..."
361 libtoolize --copy --force
362 fi
363 cd "${x}"
364 break
244 fi 365 fi
245 done 366 fi
367
368 [[ -f ${x}/libtool ]] && rm -f "${x}/libtool"
369
370 touch "${x}/.elibtoolized"
246 done 371 done
247 372
248 if [[ -f libtool ]] ; then 373 cd "${start_dir}"
249 rm -f libtool 374}
375
376uclibctoolize() {
377 ewarn "uclibctoolize() is depreciated, please just use elibtoolize()!"
378 elibtoolize
379}
380
381darwintoolize() {
382 ewarn "darwintoolize() is depreciated, please just use elibtoolize()!"
383 elibtoolize
384}
385
386# char *VER_major(string)
387#
388# Return the Major (X of X.Y.Z) version
389#
390VER_major() {
391 [[ -z $1 ]] && return 1
392
393 local VER=$@
394 echo "${VER%%[^[:digit:]]*}"
395}
396
397# char *VER_minor(string)
398#
399# Return the Minor (Y of X.Y.Z) version
400#
401VER_minor() {
402 [[ -z $1 ]] && return 1
403
404 local VER=$@
405 VER=${VER#*.}
406 echo "${VER%%[^[:digit:]]*}"
407}
408
409# char *VER_micro(string)
410#
411# Return the Micro (Z of X.Y.Z) version.
412#
413VER_micro() {
414 [[ -z $1 ]] && return 1
415
416 local VER=$@
417 VER=${VER#*.*.}
418 echo "${VER%%[^[:digit:]]*}"
419}
420
421# int VER_to_int(string)
422#
423# Convert a string type version (2.4.0) to an int (132096)
424# for easy compairing or versions ...
425#
426VER_to_int() {
427 [[ -z $1 ]] && return 1
428
429 local VER_MAJOR=$(VER_major "$1")
430 local VER_MINOR=$(VER_minor "$1")
431 local VER_MICRO=$(VER_micro "$1")
432 local VER_int=$(( VER_MAJOR * 65536 + VER_MINOR * 256 + VER_MICRO ))
433
434 # We make version 1.0.0 the minimum version we will handle as
435 # a sanity check ... if its less, we fail ...
436 if [[ ${VER_int} -ge 65536 ]] ; then
437 echo "${VER_int}"
438 return 0
250 fi 439 fi
251 440
252 cd "${start_dir}" 441 echo 1
253 442 return 1
254 uclibctoolize
255} 443}
256
257uclibctoolize() {
258 [[ -n ${NO_UCLIBCTOOLIZE} ]] && return 0
259
260 local errmsg=""
261 [[ ${CTARGET:-${CHOST}} == *-uclibc ]] \
262 && errmsg="PLEASE CHECK" \
263 || errmsg="Already patched"
264 local targets=""
265 local x
266
267 if [[ -z $* ]] ; then
268 targets=$(find ${S} -name configure -o -name ltconfig)
269 fi
270
271 einfo "Applying uClibc/libtool patches ..."
272 for x in ${targets} ; do
273 [[ ! -s ${x} ]] && continue
274 case ${x##*/} in
275 configure)
276 if grep 'Transform linux' "${x}" > /dev/null ; then
277 ebegin " Fixing \${S}${x/${S}}"
278 patch -p0 "${x}" "${ELT_PATCH_DIR}/uclibc/configure.patch" > /dev/null
279 eend $? "${errmsg} ${x}"
280 fi
281 ;;
282
283 ltconfig)
284 local ver=$(grep '^VERSION=' ${x})
285 ver=${ver/VERSION=}
286 [[ ${ver:0:3} == "1.4" ]] && ver="1.3" # 1.4 and 1.3 are compat
287 ebegin " Fixing \${S}${x/${S}}"
288 patch -p0 "${x}" "${ELT_PATCH_DIR}/uclibc/ltconfig-${ver:0:3}.patch" > /dev/null
289 eend $? "${errmsg} ${x}"
290 ;;
291 esac
292 done
293}
294
295darwintoolize() {
296 local targets=""
297 local x
298
299 if [[ -z $* ]] ; then
300 targets=$(find ${S} -name ltmain.sh -o -name ltconfig)
301 fi
302
303 einfo "Applying Darwin/libtool patches ..."
304 for x in ${targets} ; do
305 [[ ! -s ${x} ]] && continue
306 case ${x##*/} in
307 ltmain.sh|ltconfig)
308 local ver=$(grep '^VERSION=' ${x})
309 ver=${ver/VERSION=}
310 if [[ ${ver:0:3} == "1.4" || ${ver:0:3} == "1.5" ]] ; then
311 ver="1.3" # 1.4, 1.5 and 1.3 are compat
312 fi
313
314 ebegin " Fixing \${S}${x/${S}}"
315 patch -p0 "${x}" "${ELT_PATCH_DIR}/darwin/${x##*/}-${ver:0:3}.patch" > /dev/null
316 eend $? "PLEASE CHECK ${x}"
317 ;;
318 esac
319 done
320}

Legend:
Removed from v.1.42  
changed lines
  Added in v.1.63

  ViewVC Help
Powered by ViewVC 1.1.20