/[gentoo-x86]/eclass/libtool.eclass
Gentoo

Diff of /eclass/libtool.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.62 Revision 1.63
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.62 2005/12/07 22:50:05 azarah Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.63 2006/01/22 00:24:15 azarah Exp $
4# 4#
5# Author: Martin Schlemmer <azarah@gentoo.org> 5# Author: Martin Schlemmer <azarah@gentoo.org>
6# 6#
7# This eclass patches ltmain.sh distributed with libtoolized packages with the 7# This eclass patches ltmain.sh distributed with libtoolized packages with the
8# relink and portage patch among others 8# relink and portage patch among others
296 if [[ ${do_portage} == "yes" ]] ; then 296 if [[ ${do_portage} == "yes" ]] ; then
297 # Stupid test to see if its already applied ... 297 # Stupid test to see if its already applied ...
298 if [[ -z $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then 298 if [[ -z $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then
299 echo 299 echo
300 eerror "Portage patch requested, but failed to apply!" 300 eerror "Portage patch requested, but failed to apply!"
301 eerror "Please bug azarah or vapier to add proper patch."
301 die "Portage patch requested, but failed to apply!" 302 die "Portage patch requested, but failed to apply!"
302 fi 303 fi
303 else 304 else
304 if [[ -n $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then 305 if [[ -n $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then
305 # ewarn " Portage patch seems to be already applied." 306 # ewarn " Portage patch seems to be already applied."
310 eval $(grep -e '^[[:space:]]*VERSION=' "${x}/ltmain.sh"); \ 311 eval $(grep -e '^[[:space:]]*VERSION=' "${x}/ltmain.sh"); \
311 echo "${VERSION}") 312 echo "${VERSION}")
312 313
313 echo 314 echo
314 eerror "Portage patch failed to apply (ltmain.sh version ${version})!" 315 eerror "Portage patch failed to apply (ltmain.sh version ${version})!"
316 eerror "Please bug azarah or vapier to add proper patch."
315 die "Portage patch failed to apply!" 317 die "Portage patch failed to apply!"
316 fi 318 fi
317 # We do not want to run libtoolize ... 319 # We do not want to run libtoolize ...
318 ELT_APPLIED_PATCHES="portage" 320 ELT_APPLIED_PATCHES="portage"
319 fi 321 fi

Legend:
Removed from v.1.62  
changed lines
  Added in v.1.63

  ViewVC Help
Powered by ViewVC 1.1.20