/[gentoo-x86]/eclass/libtool.eclass
Gentoo

Diff of /eclass/libtool.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.87 Revision 1.88
1# Copyright 1999-2007 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.87 2010/04/14 18:14:45 vapier Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.88 2010/05/11 04:45:48 vapier Exp $
4# 4#
5# Maintainer: base-system@gentoo.org 5# Maintainer: base-system@gentoo.org
6# 6#
7# This eclass patches ltmain.sh distributed with libtoolized packages with the 7# This eclass patches ltmain.sh distributed with libtoolized packages with the
8# relink and portage patch among others 8# relink and portage patch among others
368 if [[ ${do_portage} == "yes" ]] ; then 368 if [[ ${do_portage} == "yes" ]] ; then
369 # Stupid test to see if its already applied ... 369 # Stupid test to see if its already applied ...
370 if [[ -z $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then 370 if [[ -z $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then
371 echo 371 echo
372 eerror "Portage patch requested, but failed to apply!" 372 eerror "Portage patch requested, but failed to apply!"
373 eerror "Please bug azarah or vapier to add proper patch." 373 eerror "Please file a bug report to add a proper patch."
374 die "Portage patch requested, but failed to apply!" 374 die "Portage patch requested, but failed to apply!"
375 fi 375 fi
376 else 376 else
377 if [[ -n $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then 377 if [[ -n $(grep 'We do not want portage' "${x}/ltmain.sh") ]] ; then
378 # ewarn " Portage patch seems to be already applied." 378 # ewarn " Portage patch seems to be already applied."
383 eval $(grep -e '^[[:space:]]*VERSION=' "${x}/ltmain.sh"); \ 383 eval $(grep -e '^[[:space:]]*VERSION=' "${x}/ltmain.sh"); \
384 echo "${VERSION}") 384 echo "${VERSION}")
385 385
386 echo 386 echo
387 eerror "Portage patch failed to apply (ltmain.sh version ${version})!" 387 eerror "Portage patch failed to apply (ltmain.sh version ${version})!"
388 eerror "Please bug azarah or vapier to add proper patch." 388 eerror "Please file a bug report to add a proper patch."
389 die "Portage patch failed to apply!" 389 die "Portage patch failed to apply!"
390 fi 390 fi
391 # We do not want to run libtoolize ... 391 # We do not want to run libtoolize ...
392 ELT_APPLIED_PATCHES="portage" 392 ELT_APPLIED_PATCHES="portage"
393 fi 393 fi

Legend:
Removed from v.1.87  
changed lines
  Added in v.1.88

  ViewVC Help
Powered by ViewVC 1.1.20