/[gentoo-x86]/eclass/libtool.eclass
Gentoo

Contents of /eclass/libtool.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.92 - (show annotations) (download)
Fri Jun 10 10:14:21 2011 UTC (3 years, 6 months ago) by flameeyes
Branch: MAIN
Changes since 1.91: +3 -5 lines
Use a safer syntax for libtool.eclass (bug #370983).

1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.91 2011/06/09 15:53:04 flameeyes Exp $
4
5 # @ECLASS: libtool.eclass
6 # @MAINTAINER:
7 # base-system@gentoo.org
8 # @BLURB: quickly update bundled libtool code
9 # @DESCRIPTION:
10 # This eclass patches ltmain.sh distributed with libtoolized packages with the
11 # relink and portage patch among others
12 #
13 # Note, this eclass does not require libtool as it only applies patches to
14 # generated libtool files. We do not run the libtoolize program because that
15 # requires a regeneration of the main autotool files in order to work properly.
16
17 DESCRIPTION="Based on the ${ECLASS} eclass"
18
19 inherit toolchain-funcs
20
21 ELT_PATCH_DIR="${ECLASSDIR}/ELT-patches"
22
23 #
24 # See if we can apply $2 on $1, and if so, do it
25 #
26 ELT_try_and_apply_patch() {
27 local ret=0
28 local file=$1
29 local patch=$2
30
31 echo -e "\nTrying $(basename "$(dirname "${patch}")")-${patch##*/}.patch on ${file}" \
32 &>> "${T}/elibtool.log"
33
34 # We only support patchlevel of 0 - why worry if its static patches?
35 if patch -p0 --dry-run "${file}" "${patch}" &>> "${T}/elibtool.log" ; then
36 einfo " Applying $(basename "$(dirname "${patch}")")-${patch##*/}.patch ..."
37 patch -p0 -g0 --no-backup-if-mismatch "${file}" "${patch}" \
38 &>> "${T}/elibtool.log"
39 ret=$?
40 export ELT_APPLIED_PATCHES="${ELT_APPLIED_PATCHES} ${patch##*/}"
41 else
42 ret=1
43 fi
44
45 return "${ret}"
46 }
47
48 #
49 # Get string version of ltmain.sh or ltconfig (passed as $1)
50 #
51 ELT_libtool_version() {
52 (
53 unset VERSION
54 eval $(grep -e '^[[:space:]]*VERSION=' "$1")
55 echo "${VERSION:-0}"
56 )
57 }
58
59 #
60 # Run through the patches in $2 and see if any
61 # apply to $1 ...
62 #
63 ELT_walk_patches() {
64 local patch
65 local ret=1
66 local file=$1
67 local patch_set=$2
68 local patch_dir="${ELT_PATCH_DIR}/${patch_set}"
69 local rem_int_dep=$3
70
71 [[ -z ${patch_set} ]] && return 1
72 [[ ! -d ${patch_dir} ]] && return 1
73
74 pushd "${ELT_PATCH_DIR}" >/dev/null
75
76 # Go through the patches in reverse order (newer version to older)
77 for patch in $(find "${patch_set}" -maxdepth 1 -type f | LC_ALL=C sort -r) ; do
78 # For --remove-internal-dep ...
79 if [[ -n ${rem_int_dep} ]] ; then
80 # For replace @REM_INT_DEP@ with what was passed
81 # to --remove-internal-dep
82 local tmp="${T}/$$.rem_int_deps.patch"
83 sed -e "s|@REM_INT_DEP@|${rem_int_dep}|g" "${patch}" > "${tmp}"
84 patch=${tmp}
85 fi
86
87 if ELT_try_and_apply_patch "${file}" "${patch}" ; then
88 # Break to unwind w/popd rather than return directly
89 ret=0
90 break
91 fi
92 done
93
94 popd >/dev/null
95 return ${ret}
96 }
97
98 # @FUNCTION: elibtoolize
99 # @USAGE: [dirs] [--portage] [--reverse-deps] [--patch-only] [--remove-internal-dep=xxx] [--shallow] [--no-uclibc]
100 # @DESCRIPTION:
101 # Apply a smorgasbord of patches to bundled libtool files. This function
102 # should always be safe to run. If no directories are specified, then
103 # ${S} will be searched for appropriate files.
104 #
105 # If the --shallow option is used, then only ${S}/ltmain.sh will be patched.
106 #
107 # The other options should be avoided in general unless you know what's going on.
108 elibtoolize() {
109 local x
110 local do_portage="no"
111 local do_reversedeps="no"
112 local do_only_patches="no"
113 local do_uclibc="yes"
114 local deptoremove=
115 local do_shallow="no"
116 local elt_patches="install-sh ltmain portage relink max_cmd_len sed test tmp cross as-needed"
117
118 for x in "$@" ; do
119 case ${x} in
120 --portage)
121 # Only apply portage patch, and don't
122 # 'libtoolize --copy --force' if all patches fail.
123 do_portage="yes"
124 ;;
125 --reverse-deps)
126 # Apply the reverse-deps patch
127 # http://bugzilla.gnome.org/show_bug.cgi?id=75635
128 do_reversedeps="yes"
129 elt_patches+=" fix-relink"
130 ;;
131 --patch-only)
132 # Do not run libtoolize if none of the patches apply ..
133 do_only_patches="yes"
134 ;;
135 --remove-internal-dep=*)
136 # We will replace @REM_INT_DEP@ with what is needed
137 # in ELT_walk_patches() ...
138 deptoremove=${x#--remove-internal-dep=}
139
140 # Add the patch for this ...
141 [[ -n ${deptoremove} ]] && elt_patches+=" rem-int-dep"
142 ;;
143 --shallow)
144 # Only patch the ltmain.sh in ${S}
145 do_shallow="yes"
146 ;;
147 --no-uclibc)
148 do_uclibc="no"
149 ;;
150 *)
151 eerror "Invalid elibtoolize option: ${x}"
152 die "elibtoolize called with ${x} ??"
153 esac
154 done
155
156 [[ ${do_uclibc} == "yes" ]] && elt_patches+=" uclibc-conf uclibc-ltconf"
157
158 case ${CHOST} in
159 *-aix*) elt_patches+=" hardcode aixrtl aix-noundef" ;; #213277
160 *-darwin*) elt_patches+=" darwin-ltconf darwin-ltmain darwin-conf" ;;
161 *-freebsd*) elt_patches+=" fbsd-conf fbsd-ltconf" ;;
162 *-hpux*) elt_patches+=" hpux-conf deplibs hc-flag-ld hardcode hardcode-relink relink-prog no-lc" ;;
163 *-irix*) elt_patches+=" irix-ltmain" ;;
164 *-mint*) elt_patches+=" mint-conf" ;;
165 esac
166
167 if $(tc-getLD) --version 2>&1 | grep -qs 'GNU gold'; then
168 elt_patches+=" gold-conf"
169 fi
170
171 # Reuse "$@" for dirs to patch
172 set --
173 if [[ ${do_shallow} == "yes" ]] ; then
174 [[ -f ${S}/ltmain.sh ]] && set -- "${S}"
175 else
176 set -- $(find "${S}" -name ltmain.sh -printf '%h ')
177 fi
178
179 local d p
180 for d in "$@" ; do
181 export ELT_APPLIED_PATCHES=
182
183 [[ -f ${d}/.elibtoolized ]] && continue
184
185 einfo "Running elibtoolize in: ${d#${WORKDIR}/}/"
186
187 for p in ${elt_patches} ; do
188 local ret=0
189
190 case ${p} in
191 portage)
192 # Stupid test to see if its already applied ...
193 if ! grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
194 ELT_walk_patches "${d}/ltmain.sh" "${p}"
195 ret=$?
196 fi
197 ;;
198 rem-int-dep)
199 ELT_walk_patches "${d}/ltmain.sh" "${p}" "${deptoremove}"
200 ret=$?
201 ;;
202 fix-relink)
203 # Do not apply if we do not have the relink patch applied ...
204 if grep -qs 'inst_prefix_dir' "${d}/ltmain.sh" ; then
205 ELT_walk_patches "${d}/ltmain.sh" "${p}"
206 ret=$?
207 fi
208 ;;
209 max_cmd_len)
210 # Do not apply if $max_cmd_len is not used ...
211 if grep -qs 'max_cmd_len' "${d}/ltmain.sh" ; then
212 ELT_walk_patches "${d}/ltmain.sh" "${p}"
213 ret=$?
214 fi
215 ;;
216 as-needed)
217 ELT_walk_patches "${d}/ltmain.sh" "${p}"
218 ret=$?
219 ;;
220 uclibc-conf)
221 if grep -qs 'Transform linux' "${d}/configure" ; then
222 ELT_walk_patches "${d}/configure" "${p}"
223 ret=$?
224 # ltmain.sh and co might be in a subdirectory ...
225 elif [[ ! -e ${d}/configure ]] && \
226 grep -qs 'Transform linux' "${d}/../configure" ; then
227 ELT_walk_patches "${d}/../configure" "${p}"
228 ret=$?
229 fi
230 ;;
231 uclibc-ltconf)
232 # Newer libtoolize clears ltconfig, as not used anymore
233 if [[ -s ${d}/ltconfig ]] ; then
234 ELT_walk_patches "${d}/ltconfig" "${p}"
235 ret=$?
236 fi
237 ;;
238 fbsd-conf)
239 if grep -qs 'version_type=freebsd-' "${d}/configure" ; then
240 ELT_walk_patches "${d}/configure" "${p}"
241 ret=$?
242 # ltmain.sh and co might be in a subdirectory ...
243 elif [[ ! -e ${d}/configure ]] && \
244 grep -qs 'version_type=freebsd-' "${d}/../configure" ; then
245 ELT_walk_patches "${d}/../configure" "${p}"
246 ret=$?
247 fi
248 ;;
249 fbsd-ltconf)
250 if [[ -s ${d}/ltconfig ]] ; then
251 ELT_walk_patches "${d}/ltconfig" "${p}"
252 ret=$?
253 fi
254 ;;
255 darwin-conf)
256 if grep -qs '&& echo \.so ||' "${d}/configure" ; then
257 ELT_walk_patches "${d}/configure" "${p}"
258 ret=$?
259 # ltmain.sh and co might be in a subdirectory ...
260 elif [[ ! -e ${d}/configure ]] && \
261 grep -qs '&& echo \.so ||' "${d}/../configure" ; then
262 ELT_walk_patches "${d}/../configure" "${p}"
263 ret=$?
264 fi
265 ;;
266 darwin-ltconf)
267 # Newer libtoolize clears ltconfig, as not used anymore
268 if [[ -s ${d}/ltconfig ]] ; then
269 ELT_walk_patches "${d}/ltconfig" "${p}"
270 ret=$?
271 fi
272 ;;
273 darwin-ltmain)
274 # special case to avoid false positives (failing to apply
275 # ltmain.sh path message), newer libtools have this patch
276 # built in, so not much to patch around then
277 if [[ -e ${d}/ltmain.sh ]] && \
278 ! grep -qs 'verstring="-compatibility_version' "${d}/ltmain.sh" ; then
279 ELT_walk_patches "${d}/ltmain.sh" "${p}"
280 ret=$?
281 fi
282 ;;
283 aixrtl|hpux-conf)
284 ret=1
285 local subret=0
286 # apply multiple patches as often as they match
287 while [[ $subret -eq 0 ]]; do
288 subret=1
289 if [[ -e ${d}/configure ]]; then
290 ELT_walk_patches "${d}/configure" "${p}"
291 subret=$?
292 # ltmain.sh and co might be in a subdirectory ...
293 elif [[ ! -e ${d}/configure && -e ${d}/../configure ]] ; then
294 ELT_walk_patches "${d}/../configure" "${p}"
295 subret=$?
296 fi
297 if [[ $subret -eq 0 ]]; then
298 # have at least one patch succeeded.
299 ret=0
300 fi
301 done
302 ;;
303 mint-conf|gold-conf)
304 ret=1
305 local subret=1
306 if [[ -e ${d}/configure ]]; then
307 ELT_walk_patches "${d}/configure" "${p}"
308 subret=$?
309 # ltmain.sh and co might be in a subdirectory ...
310 elif [[ -e ${d}/../configure ]] ; then
311 ELT_walk_patches "${d}/../configure" "${p}"
312 subret=$?
313 elif [[ -e ${d}/../../configure ]] ; then
314 ELT_walk_patches "${d}/../../configure" "${p}"
315 subret=$?
316 fi
317 if [[ $subret -eq 0 ]]; then
318 # have at least one patch succeeded.
319 ret=0
320 fi
321 ;;
322 install-sh)
323 ELT_walk_patches "${d}/install-sh" "${p}"
324 ret=$?
325 ;;
326 cross)
327 if tc-is-cross-compiler ; then
328 ELT_walk_patches "${d}/ltmain.sh" "${p}"
329 ret=$?
330 fi
331 ;;
332 *)
333 ELT_walk_patches "${d}/ltmain.sh" "${p}"
334 ret=$?
335 ;;
336 esac
337
338 if [[ ${ret} -ne 0 ]] ; then
339 case ${p} in
340 relink)
341 local version=$(ELT_libtool_version "${d}/ltmain.sh")
342 # Critical patch, but could be applied ...
343 # FIXME: Still need a patch for ltmain.sh > 1.4.0
344 if ! grep -qs 'inst_prefix_dir' "${d}/ltmain.sh" && \
345 [[ $(VER_to_int "${version}") -ge $(VER_to_int "1.4.0") ]] ; then
346 ewarn " Could not apply relink.patch!"
347 fi
348 ;;
349 portage)
350 # Critical patch - for this one we abort, as it can really
351 # cause breakage without it applied!
352 if [[ ${do_portage} == "yes" ]] ; then
353 # Stupid test to see if its already applied ...
354 if ! grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
355 echo
356 eerror "Portage patch requested, but failed to apply!"
357 eerror "Please file a bug report to add a proper patch."
358 die "Portage patch requested, but failed to apply!"
359 fi
360 else
361 if grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
362 # ewarn " Portage patch seems to be already applied."
363 # ewarn " Please verify that it is not needed."
364 :
365 else
366 local version=$(ELT_libtool_version "${d}"/ltmain.sh)
367 echo
368 eerror "Portage patch failed to apply (ltmain.sh version ${version})!"
369 eerror "Please file a bug report to add a proper patch."
370 die "Portage patch failed to apply!"
371 fi
372 # We do not want to run libtoolize ...
373 ELT_APPLIED_PATCHES="portage"
374 fi
375 ;;
376 uclibc-*)
377 [[ ${CHOST} == *-uclibc ]] && ewarn " uClibc patch set '${p}' failed to apply!"
378 ;;
379 fbsd-*)
380 if [[ ${CHOST} == *-freebsd* ]] ; then
381 if [[ -z $(grep 'Handle Gentoo/FreeBSD as it was Linux' \
382 "${d}/configure" "${d}/../configure" 2>/dev/null) ]]; then
383 eerror " FreeBSD patch set '${p}' failed to apply!"
384 die "FreeBSD patch set '${p}' failed to apply!"
385 fi
386 fi
387 ;;
388 darwin-*)
389 [[ ${CHOST} == *"-darwin"* ]] && ewarn " Darwin patch set '${p}' failed to apply!"
390 ;;
391 esac
392 fi
393 done
394
395 if [[ -z ${ELT_APPLIED_PATCHES} ]] ; then
396 if [[ ${do_portage} == "no" && \
397 ${do_reversedeps} == "no" && \
398 ${do_only_patches} == "no" && \
399 ${deptoremove} == "" ]]
400 then
401 ewarn "Cannot apply any patches, please file a bug about this"
402 die
403 fi
404 fi
405
406 rm -f "${d}/libtool"
407
408 > "${d}/.elibtoolized"
409 done
410 }
411
412 uclibctoolize() { die "Use elibtoolize"; }
413 darwintoolize() { die "Use elibtoolize"; }
414
415 # char *VER_major(string)
416 #
417 # Return the Major (X of X.Y.Z) version
418 #
419 VER_major() {
420 [[ -z $1 ]] && return 1
421
422 local VER=$@
423 echo "${VER%%[^[:digit:]]*}"
424 }
425
426 # char *VER_minor(string)
427 #
428 # Return the Minor (Y of X.Y.Z) version
429 #
430 VER_minor() {
431 [[ -z $1 ]] && return 1
432
433 local VER=$@
434 VER=${VER#*.}
435 echo "${VER%%[^[:digit:]]*}"
436 }
437
438 # char *VER_micro(string)
439 #
440 # Return the Micro (Z of X.Y.Z) version.
441 #
442 VER_micro() {
443 [[ -z $1 ]] && return 1
444
445 local VER=$@
446 VER=${VER#*.*.}
447 echo "${VER%%[^[:digit:]]*}"
448 }
449
450 # int VER_to_int(string)
451 #
452 # Convert a string type version (2.4.0) to an int (132096)
453 # for easy compairing or versions ...
454 #
455 VER_to_int() {
456 [[ -z $1 ]] && return 1
457
458 local VER_MAJOR=$(VER_major "$1")
459 local VER_MINOR=$(VER_minor "$1")
460 local VER_MICRO=$(VER_micro "$1")
461 local VER_int=$(( VER_MAJOR * 65536 + VER_MINOR * 256 + VER_MICRO ))
462
463 # We make version 1.0.0 the minimum version we will handle as
464 # a sanity check ... if its less, we fail ...
465 if [[ ${VER_int} -ge 65536 ]] ; then
466 echo "${VER_int}"
467 return 0
468 fi
469
470 echo 1
471 return 1
472 }

  ViewVC Help
Powered by ViewVC 1.1.20