/[gentoo-x86]/eclass/libtool.eclass
Gentoo

Contents of /eclass/libtool.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.96 - (show annotations) (download)
Fri Nov 18 17:32:14 2011 UTC (2 years, 10 months ago) by vapier
Branch: MAIN
Changes since 1.95: +16 -5 lines
allow overlays to specify eclass overrides without breaking libtools lookup of local patches #389009

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.95 2011/11/14 17:08:49 vapier Exp $
4
5 # @ECLASS: libtool.eclass
6 # @MAINTAINER:
7 # base-system@gentoo.org
8 # @BLURB: quickly update bundled libtool code
9 # @DESCRIPTION:
10 # This eclass patches ltmain.sh distributed with libtoolized packages with the
11 # relink and portage patch among others
12 #
13 # Note, this eclass does not require libtool as it only applies patches to
14 # generated libtool files. We do not run the libtoolize program because that
15 # requires a regeneration of the main autotool files in order to work properly.
16
17 # If an overlay has eclass overrides, but doesn't actually override the
18 # libtool.eclass, we'll have ECLASSDIR pointing to the active overlay's
19 # eclass/ dir, but libtool.eclass is still in the main Gentoo tree. So
20 # add a check to locate the ELT-patches/ regardless of what's going on.
21 ECLASSDIR_LOCAL=${BASH_SOURCE[0]%/*}
22 elt_patch_dir() {
23 local d="${ECLASSDIR}/ELT-patches"
24 if [[ ! -d ${d} ]] ; then
25 d="${ECLASSDIR_LOCAL}/ELT-patches"
26 fi
27 echo "${d}"
28 }
29
30 DESCRIPTION="Based on the ${ECLASS} eclass"
31
32 inherit multilib toolchain-funcs
33
34 #
35 # See if we can apply $2 on $1, and if so, do it
36 #
37 ELT_try_and_apply_patch() {
38 local ret=0
39 local file=$1
40 local patch=$2
41 local src=$3
42 local disp="${src} patch"
43 local log="${T}/elibtool.log"
44
45 if [[ -z ${__ELT_NOTED_TMP} ]] ; then
46 __ELT_NOTED_TMP=true
47 printf 'temp patch: %s\n' "${patch}" > "${log}"
48 fi
49 printf '\nTrying %s\n' "${disp}" >> "${log}"
50
51 # We only support patchlevel of 0 - why worry if its static patches?
52 if patch -p0 --dry-run "${file}" "${patch}" >> "${log}" 2>&1 ; then
53 einfo " Applying ${disp} ..."
54 patch -p0 -g0 --no-backup-if-mismatch "${file}" "${patch}" >> "${log}" 2>&1
55 ret=$?
56 export ELT_APPLIED_PATCHES="${ELT_APPLIED_PATCHES} ${src}"
57 else
58 ret=1
59 fi
60
61 return "${ret}"
62 }
63
64 #
65 # Get string version of ltmain.sh or ltconfig (passed as $1)
66 #
67 ELT_libtool_version() {
68 (
69 unset VERSION
70 eval $(grep -e '^[[:space:]]*VERSION=' "$1")
71 echo "${VERSION:-0}"
72 )
73 }
74
75 #
76 # Run through the patches in $2 and see if any
77 # apply to $1 ...
78 #
79 ELT_walk_patches() {
80 local patch tmp
81 local ret=1
82 local file=$1
83 local patch_set=$2
84 local patch_dir="$(elt_patch_dir)/${patch_set}"
85 local rem_int_dep=$3
86
87 [[ -z ${patch_set} ]] && return 1
88 [[ ! -d ${patch_dir} ]] && return 1
89
90 # Allow patches to use @GENTOO_LIBDIR@ replacements
91 local sed_args=( -e "s:@GENTOO_LIBDIR@:$(get_libdir):g" )
92 if [[ -n ${rem_int_dep} ]] ; then
93 # replace @REM_INT_DEP@ with what was passed
94 # to --remove-internal-dep
95 sed_args+=( -e "s|@REM_INT_DEP@|${rem_int_dep}|g" )
96 fi
97
98 pushd "$(elt_patch_dir)" >/dev/null || die
99
100 # Go through the patches in reverse order (newer version to older)
101 for patch in $(find "${patch_set}" -maxdepth 1 -type f | LC_ALL=C sort -r) ; do
102 tmp="${T}/libtool-elt.patch"
103 sed "${sed_args[@]}" "${patch}" > "${tmp}" || die
104 if ELT_try_and_apply_patch "${file}" "${tmp}" "${patch}" ; then
105 # Break to unwind w/popd rather than return directly
106 ret=0
107 break
108 fi
109 done
110
111 popd >/dev/null
112 return ${ret}
113 }
114
115 # @FUNCTION: elibtoolize
116 # @USAGE: [dirs] [--portage] [--reverse-deps] [--patch-only] [--remove-internal-dep=xxx] [--shallow] [--no-uclibc]
117 # @DESCRIPTION:
118 # Apply a smorgasbord of patches to bundled libtool files. This function
119 # should always be safe to run. If no directories are specified, then
120 # ${S} will be searched for appropriate files.
121 #
122 # If the --shallow option is used, then only ${S}/ltmain.sh will be patched.
123 #
124 # The other options should be avoided in general unless you know what's going on.
125 elibtoolize() {
126 local x
127 local do_portage="no"
128 local do_reversedeps="no"
129 local do_only_patches="no"
130 local do_uclibc="yes"
131 local deptoremove=
132 local do_shallow="no"
133 local force="false"
134 local elt_patches="install-sh ltmain portage relink max_cmd_len sed test tmp cross as-needed"
135
136 for x in "$@" ; do
137 case ${x} in
138 --portage)
139 # Only apply portage patch, and don't
140 # 'libtoolize --copy --force' if all patches fail.
141 do_portage="yes"
142 ;;
143 --reverse-deps)
144 # Apply the reverse-deps patch
145 # http://bugzilla.gnome.org/show_bug.cgi?id=75635
146 do_reversedeps="yes"
147 elt_patches+=" fix-relink"
148 ;;
149 --patch-only)
150 # Do not run libtoolize if none of the patches apply ..
151 do_only_patches="yes"
152 ;;
153 --remove-internal-dep=*)
154 # We will replace @REM_INT_DEP@ with what is needed
155 # in ELT_walk_patches() ...
156 deptoremove=${x#--remove-internal-dep=}
157
158 # Add the patch for this ...
159 [[ -n ${deptoremove} ]] && elt_patches+=" rem-int-dep"
160 ;;
161 --shallow)
162 # Only patch the ltmain.sh in ${S}
163 do_shallow="yes"
164 ;;
165 --no-uclibc)
166 do_uclibc="no"
167 ;;
168 --force)
169 force="true"
170 ;;
171 *)
172 eerror "Invalid elibtoolize option: ${x}"
173 die "elibtoolize called with ${x} ??"
174 esac
175 done
176
177 [[ ${do_uclibc} == "yes" ]] && elt_patches+=" uclibc-conf uclibc-ltconf"
178
179 case ${CHOST} in
180 *-aix*) elt_patches+=" hardcode aixrtl aix-noundef" ;; #213277
181 *-darwin*) elt_patches+=" darwin-ltconf darwin-ltmain darwin-conf" ;;
182 *-freebsd*) elt_patches+=" fbsd-conf fbsd-ltconf" ;;
183 *-hpux*) elt_patches+=" hpux-conf deplibs hc-flag-ld hardcode hardcode-relink relink-prog no-lc" ;;
184 *-irix*) elt_patches+=" irix-ltmain" ;;
185 *-mint*) elt_patches+=" mint-conf" ;;
186 esac
187
188 if $(tc-getLD) --version 2>&1 | grep -qs 'GNU gold'; then
189 elt_patches+=" gold-conf"
190 fi
191
192 # Reuse "$@" for dirs to patch
193 set --
194 if [[ ${do_shallow} == "yes" ]] ; then
195 [[ -f ${S}/ltmain.sh ]] && set -- "${S}"
196 else
197 set -- $(find "${S}" -name ltmain.sh -printf '%h ')
198 fi
199
200 local d p
201 for d in "$@" ; do
202 export ELT_APPLIED_PATCHES=
203
204 if [[ -f ${d}/.elibtoolized ]] ; then
205 ${force} || continue
206 fi
207
208 einfo "Running elibtoolize in: ${d#${WORKDIR}/}/"
209 if [[ -f ${d}/.elibtoolized ]] ; then
210 ewarn " We've already been run in this tree; you should"
211 ewarn " avoid this if possible (perhaps by filing a bug)"
212 fi
213
214 for p in ${elt_patches} ; do
215 local ret=0
216
217 case ${p} in
218 portage)
219 # Stupid test to see if its already applied ...
220 if ! grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
221 ELT_walk_patches "${d}/ltmain.sh" "${p}"
222 ret=$?
223 fi
224 ;;
225 rem-int-dep)
226 ELT_walk_patches "${d}/ltmain.sh" "${p}" "${deptoremove}"
227 ret=$?
228 ;;
229 fix-relink)
230 # Do not apply if we do not have the relink patch applied ...
231 if grep -qs 'inst_prefix_dir' "${d}/ltmain.sh" ; then
232 ELT_walk_patches "${d}/ltmain.sh" "${p}"
233 ret=$?
234 fi
235 ;;
236 max_cmd_len)
237 # Do not apply if $max_cmd_len is not used ...
238 if grep -qs 'max_cmd_len' "${d}/ltmain.sh" ; then
239 ELT_walk_patches "${d}/ltmain.sh" "${p}"
240 ret=$?
241 fi
242 ;;
243 as-needed)
244 ELT_walk_patches "${d}/ltmain.sh" "${p}"
245 ret=$?
246 ;;
247 uclibc-conf)
248 if grep -qs 'Transform linux' "${d}/configure" ; then
249 ELT_walk_patches "${d}/configure" "${p}"
250 ret=$?
251 # ltmain.sh and co might be in a subdirectory ...
252 elif [[ ! -e ${d}/configure ]] && \
253 grep -qs 'Transform linux' "${d}/../configure" ; then
254 ELT_walk_patches "${d}/../configure" "${p}"
255 ret=$?
256 fi
257 ;;
258 uclibc-ltconf)
259 # Newer libtoolize clears ltconfig, as not used anymore
260 if [[ -s ${d}/ltconfig ]] ; then
261 ELT_walk_patches "${d}/ltconfig" "${p}"
262 ret=$?
263 fi
264 ;;
265 fbsd-conf)
266 if grep -qs 'version_type=freebsd-' "${d}/configure" ; then
267 ELT_walk_patches "${d}/configure" "${p}"
268 ret=$?
269 # ltmain.sh and co might be in a subdirectory ...
270 elif [[ ! -e ${d}/configure ]] && \
271 grep -qs 'version_type=freebsd-' "${d}/../configure" ; then
272 ELT_walk_patches "${d}/../configure" "${p}"
273 ret=$?
274 fi
275 ;;
276 fbsd-ltconf)
277 if [[ -s ${d}/ltconfig ]] ; then
278 ELT_walk_patches "${d}/ltconfig" "${p}"
279 ret=$?
280 fi
281 ;;
282 darwin-conf)
283 if grep -qs '&& echo \.so ||' "${d}/configure" ; then
284 ELT_walk_patches "${d}/configure" "${p}"
285 ret=$?
286 # ltmain.sh and co might be in a subdirectory ...
287 elif [[ ! -e ${d}/configure ]] && \
288 grep -qs '&& echo \.so ||' "${d}/../configure" ; then
289 ELT_walk_patches "${d}/../configure" "${p}"
290 ret=$?
291 fi
292 ;;
293 darwin-ltconf)
294 # Newer libtoolize clears ltconfig, as not used anymore
295 if [[ -s ${d}/ltconfig ]] ; then
296 ELT_walk_patches "${d}/ltconfig" "${p}"
297 ret=$?
298 fi
299 ;;
300 darwin-ltmain)
301 # special case to avoid false positives (failing to apply
302 # ltmain.sh path message), newer libtools have this patch
303 # built in, so not much to patch around then
304 if [[ -e ${d}/ltmain.sh ]] && \
305 ! grep -qs 'verstring="-compatibility_version' "${d}/ltmain.sh" ; then
306 ELT_walk_patches "${d}/ltmain.sh" "${p}"
307 ret=$?
308 fi
309 ;;
310 aixrtl|hpux-conf)
311 ret=1
312 local subret=0
313 # apply multiple patches as often as they match
314 while [[ $subret -eq 0 ]]; do
315 subret=1
316 if [[ -e ${d}/configure ]]; then
317 ELT_walk_patches "${d}/configure" "${p}"
318 subret=$?
319 # ltmain.sh and co might be in a subdirectory ...
320 elif [[ ! -e ${d}/configure && -e ${d}/../configure ]] ; then
321 ELT_walk_patches "${d}/../configure" "${p}"
322 subret=$?
323 fi
324 if [[ $subret -eq 0 ]]; then
325 # have at least one patch succeeded.
326 ret=0
327 fi
328 done
329 ;;
330 mint-conf|gold-conf)
331 ret=1
332 local subret=1
333 if [[ -e ${d}/configure ]]; then
334 ELT_walk_patches "${d}/configure" "${p}"
335 subret=$?
336 # ltmain.sh and co might be in a subdirectory ...
337 elif [[ -e ${d}/../configure ]] ; then
338 ELT_walk_patches "${d}/../configure" "${p}"
339 subret=$?
340 elif [[ -e ${d}/../../configure ]] ; then
341 ELT_walk_patches "${d}/../../configure" "${p}"
342 subret=$?
343 fi
344 if [[ $subret -eq 0 ]]; then
345 # have at least one patch succeeded.
346 ret=0
347 fi
348 ;;
349 install-sh)
350 ELT_walk_patches "${d}/install-sh" "${p}"
351 ret=$?
352 ;;
353 cross)
354 if tc-is-cross-compiler ; then
355 ELT_walk_patches "${d}/ltmain.sh" "${p}"
356 ret=$?
357 fi
358 ;;
359 *)
360 ELT_walk_patches "${d}/ltmain.sh" "${p}"
361 ret=$?
362 ;;
363 esac
364
365 if [[ ${ret} -ne 0 ]] ; then
366 case ${p} in
367 relink)
368 local version=$(ELT_libtool_version "${d}/ltmain.sh")
369 # Critical patch, but could be applied ...
370 # FIXME: Still need a patch for ltmain.sh > 1.4.0
371 if ! grep -qs 'inst_prefix_dir' "${d}/ltmain.sh" && \
372 [[ $(VER_to_int "${version}") -ge $(VER_to_int "1.4.0") ]] ; then
373 ewarn " Could not apply relink.patch!"
374 fi
375 ;;
376 portage)
377 # Critical patch - for this one we abort, as it can really
378 # cause breakage without it applied!
379 if [[ ${do_portage} == "yes" ]] ; then
380 # Stupid test to see if its already applied ...
381 if ! grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
382 echo
383 eerror "Portage patch requested, but failed to apply!"
384 eerror "Please file a bug report to add a proper patch."
385 die "Portage patch requested, but failed to apply!"
386 fi
387 else
388 if grep -qs 'We do not want portage' "${d}/ltmain.sh" ; then
389 # ewarn " Portage patch seems to be already applied."
390 # ewarn " Please verify that it is not needed."
391 :
392 else
393 local version=$(ELT_libtool_version "${d}"/ltmain.sh)
394 echo
395 eerror "Portage patch failed to apply (ltmain.sh version ${version})!"
396 eerror "Please file a bug report to add a proper patch."
397 die "Portage patch failed to apply!"
398 fi
399 # We do not want to run libtoolize ...
400 ELT_APPLIED_PATCHES="portage"
401 fi
402 ;;
403 uclibc-*)
404 [[ ${CHOST} == *-uclibc ]] && ewarn " uClibc patch set '${p}' failed to apply!"
405 ;;
406 fbsd-*)
407 if [[ ${CHOST} == *-freebsd* ]] ; then
408 if [[ -z $(grep 'Handle Gentoo/FreeBSD as it was Linux' \
409 "${d}/configure" "${d}/../configure" 2>/dev/null) ]]; then
410 eerror " FreeBSD patch set '${p}' failed to apply!"
411 die "FreeBSD patch set '${p}' failed to apply!"
412 fi
413 fi
414 ;;
415 darwin-*)
416 [[ ${CHOST} == *"-darwin"* ]] && ewarn " Darwin patch set '${p}' failed to apply!"
417 ;;
418 esac
419 fi
420 done
421
422 if [[ -z ${ELT_APPLIED_PATCHES} ]] ; then
423 if [[ ${do_portage} == "no" && \
424 ${do_reversedeps} == "no" && \
425 ${do_only_patches} == "no" && \
426 ${deptoremove} == "" ]]
427 then
428 ewarn "Cannot apply any patches, please file a bug about this"
429 die
430 fi
431 fi
432
433 rm -f "${d}/libtool"
434
435 > "${d}/.elibtoolized"
436 done
437 }
438
439 uclibctoolize() { die "Use elibtoolize"; }
440 darwintoolize() { die "Use elibtoolize"; }
441
442 # char *VER_major(string)
443 #
444 # Return the Major (X of X.Y.Z) version
445 #
446 VER_major() {
447 [[ -z $1 ]] && return 1
448
449 local VER=$@
450 echo "${VER%%[^[:digit:]]*}"
451 }
452
453 # char *VER_minor(string)
454 #
455 # Return the Minor (Y of X.Y.Z) version
456 #
457 VER_minor() {
458 [[ -z $1 ]] && return 1
459
460 local VER=$@
461 VER=${VER#*.}
462 echo "${VER%%[^[:digit:]]*}"
463 }
464
465 # char *VER_micro(string)
466 #
467 # Return the Micro (Z of X.Y.Z) version.
468 #
469 VER_micro() {
470 [[ -z $1 ]] && return 1
471
472 local VER=$@
473 VER=${VER#*.*.}
474 echo "${VER%%[^[:digit:]]*}"
475 }
476
477 # int VER_to_int(string)
478 #
479 # Convert a string type version (2.4.0) to an int (132096)
480 # for easy compairing or versions ...
481 #
482 VER_to_int() {
483 [[ -z $1 ]] && return 1
484
485 local VER_MAJOR=$(VER_major "$1")
486 local VER_MINOR=$(VER_minor "$1")
487 local VER_MICRO=$(VER_micro "$1")
488 local VER_int=$(( VER_MAJOR * 65536 + VER_MINOR * 256 + VER_MICRO ))
489
490 # We make version 1.0.0 the minimum version we will handle as
491 # a sanity check ... if its less, we fail ...
492 if [[ ${VER_int} -ge 65536 ]] ; then
493 echo "${VER_int}"
494 return 0
495 fi
496
497 echo 1
498 return 1
499 }

  ViewVC Help
Powered by ViewVC 1.1.20