/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.120 Revision 1.159
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.120 2009/12/09 18:46:53 robbat2 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.159 2011/04/21 12:15:19 robbat2 Exp $
4 4
5# @ECLASS: mysql.eclass 5# @ECLASS: mysql.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 7# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
8# Maintainers: MySQL Team <mysql-bugs@gentoo.org> 8# Maintainers: MySQL Team <mysql-bugs@gentoo.org>
16# phase hooks. 16# phase hooks.
17 17
18WANT_AUTOCONF="latest" 18WANT_AUTOCONF="latest"
19WANT_AUTOMAKE="latest" 19WANT_AUTOMAKE="latest"
20 20
21inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator 21inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator toolchain-funcs
22
23# Shorten the path because the socket path length must be shorter than 107 chars
24# and we will run a mysql server during test phase
25S="${WORKDIR}/mysql"
26
27[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z"
28if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
29 EGIT_PROJECT=mysql-extras
30 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
31 inherit git
32fi
22 33
23case "${EAPI:-0}" in 34case "${EAPI:-0}" in
24 2) 35 2)
25 EXPORT_FUNCTIONS pkg_setup \ 36 EXPORT_FUNCTIONS pkg_setup \
26 src_unpack src_prepare \ 37 src_unpack src_prepare \
40 ;; 51 ;;
41 *) 52 *)
42 die "Unsupported EAPI: ${EAPI}" ;; 53 die "Unsupported EAPI: ${EAPI}" ;;
43esac 54esac
44 55
45# Shorten the path because the socket path length must be shorter than 107 chars
46# and we will run a mysql server during test phase
47S="${WORKDIR}/mysql"
48 56
49[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z" 57# @ECLASS-VARIABLE: MYSQL_PV_MAJOR
50if [[ "${MY_EXTRAS_VER}" == "live" ]]; then 58# @DESCRIPTION:
51 EGIT_PROJECT=mysql-extras 59# Upstream MySQL considers the first two parts of the version number to be the
52 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git" 60# major version. Upgrades that change major version should always run
53 inherit git 61# mysql_upgrade.
62MYSQL_PV_MAJOR="$(get_version_component_range 1-2 ${PV})"
63
64# Cluster is a special case...
65if [[ "${PN}" == "mysql-cluster" ]]; then
66 case $PV in
67 6.1*|7.0*|7.1*) MYSQL_PV_MAJOR=5.1 ;;
68 esac
54fi 69fi
70
55 71
56# @ECLASS-VARIABLE: MYSQL_VERSION_ID 72# @ECLASS-VARIABLE: MYSQL_VERSION_ID
57# @DESCRIPTION: 73# @DESCRIPTION:
58# MYSQL_VERSION_ID will be: 74# MYSQL_VERSION_ID will be:
59# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 75# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
77# @DESCRIPTION: 93# @DESCRIPTION:
78# Specifiy if community features are available. Possible values are 1 (yes) 94# Specifiy if community features are available. Possible values are 1 (yes)
79# and 0 (no). 95# and 0 (no).
80# Community features are available in mysql-community 96# Community features are available in mysql-community
81# AND in the re-merged mysql-5.0.82 and newer 97# AND in the re-merged mysql-5.0.82 and newer
82if [ "${PN}" == "mysql-community" ]; then 98if [ "${PN}" == "mysql-community" -o "${PN}" == "mariadb" ]; then
83 MYSQL_COMMUNITY_FEATURES=1 99 MYSQL_COMMUNITY_FEATURES=1
84elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then 100elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
85 MYSQL_COMMUNITY_FEATURES=1 101 MYSQL_COMMUNITY_FEATURES=1
86elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then 102elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
87 MYSQL_COMMUNITY_FEATURES=1 103 MYSQL_COMMUNITY_FEATURES=1
88elif [ "${PV#5.4}" != "${PV}" ]; then 104elif [ "${PV#5.4}" != "${PV}" ] ; then
105 MYSQL_COMMUNITY_FEATURES=1
106elif [ "${PV#5.5}" != "${PV}" ] ; then
107 MYSQL_COMMUNITY_FEATURES=1
108elif [ "${PV#6}" != "${PV}" ] ; then
109 MYSQL_COMMUNITY_FEATURES=1
110elif [ "${PV#7}" != "${PV}" ] ; then
89 MYSQL_COMMUNITY_FEATURES=1 111 MYSQL_COMMUNITY_FEATURES=1
90else 112else
91 MYSQL_COMMUNITY_FEATURES=0 113 MYSQL_COMMUNITY_FEATURES=0
92fi 114fi
93 115
108 >=sys-apps/sed-4 130 >=sys-apps/sed-4
109 >=sys-apps/texinfo-4.7-r1 131 >=sys-apps/texinfo-4.7-r1
110 >=sys-libs/readline-4.1 132 >=sys-libs/readline-4.1
111 >=sys-libs/zlib-1.2.3" 133 >=sys-libs/zlib-1.2.3"
112 134
135[[ "${PN}" == "mariadb" ]] \
136&& DEPEND="${DEPEND} libevent? ( >=dev-libs/libevent-1.4 )"
137
113# Having different flavours at the same time is not a good idea 138# Having different flavours at the same time is not a good idea
114for i in "" "-community" ; do 139for i in "mysql" "mysql-community" "mysql-cluster" "mariadb" ; do
115 [[ "${i}" == ${PN#mysql} ]] || 140 [[ "${i}" == ${PN} ]] ||
116 DEPEND="${DEPEND} !dev-db/mysql${i}" 141 DEPEND="${DEPEND} !dev-db/${i}"
117done 142done
118 143
119RDEPEND="${DEPEND} 144RDEPEND="${DEPEND}
120 !minimal? ( dev-db/mysql-init-scripts ) 145 !minimal? ( dev-db/mysql-init-scripts )
121 selinux? ( sec-policy/selinux-mysql )" 146 selinux? ( sec-policy/selinux-mysql )"
122 147
148if [ "${EAPI:-0}" = "2" ]; then
149 DEPEND="${DEPEND} static? ( || ( sys-libs/ncurses[static-libs] <=sys-libs/ncurses-5.7-r3 ) )"
150fi
151
123# compile-time-only 152# compile-time-only
124mysql_version_is_at_least "5.1" \ 153mysql_version_is_at_least "5.1" \
125|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )" 154|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
126 155
127# compile-time-only 156# compile-time-only
128mysql_version_is_at_least "5.1.12" \ 157mysql_version_is_at_least "5.1.12" \
129&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3" 158&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
130 159
160[[ "${PN}" == "mariadb" ]] \
161&& mysql_version_is_at_least "5.2" \
162&& DEPEND="${DEPEND} oqgraph? ( >=dev-libs/boost-1.40.0 )"
163#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
164# sphinx? ( app-misc/sphinx )"
165
131# dev-perl/DBD-mysql is needed by some scripts installed by MySQL 166# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
132PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 167PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
133 168
134# For other stuff to bring us in 169# For other stuff to bring us in
135PDEPEND="${PDEPEND} =virtual/mysql-$(get_version_component_range 1-2 ${PV})" 170PDEPEND="${PDEPEND} =virtual/mysql-${MYSQL_PV_MAJOR}"
136 171
137# Work out the default SERVER_URI correctly 172# Work out the default SERVER_URI correctly
138if [ -z "${SERVER_URI}" ]; then 173if [ -z "${SERVER_URI}" ]; then
174 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
175 if [ "${PN}" == "mariadb" ]; then
176 MARIA_FULL_PV="$(replace_version_separator 3 '-' ${PV})"
177 MARIA_FULL_P="${PN}-${MARIA_FULL_PV}"
178 SERVER_URI="
179 http://ftp.osuosl.org/pub/mariadb/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
180 http://ftp.rediris.es/mirror/MariaDB/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
181 http://maria.llarian.net/download/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
182 http://launchpad.net/maria/${MYSQL_PV_MAJOR}/ongoing/+download/${MARIA_FULL_P}.tar.gz
183 http://mirrors.fe.up.pt/pub/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
184 http://ftp-stud.hs-esslingen.de/pub/Mirrors/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
185 "
139 # The community build is on the mirrors 186 # The community and cluster builds are on the mirrors
140 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then 187 elif [[ "${MYSQL_COMMUNITY_FEATURES}" == "1" || ${PN} == "mysql-cluster" ]] ; then
141 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz" 188 if [[ "${PN}" == "mysql-cluster" ]] ; then
189 URI_DIR="MySQL-Cluster"
190 URI_FILE="mysql-cluster-gpl"
191 else
192 URI_DIR="MySQL"
193 URI_FILE="mysql"
194 fi
195 URI_A="${URI_FILE}-${MY_PV}.tar.gz"
196 MIRROR_PV=$(get_version_component_range 1-2 ${PV})
197 # Recently upstream switched to an archive site, and not on mirrors
198 SERVER_URI="http://downloads.mysql.com/archives/${URI_FILE}-${MIRROR_PV}/${URI_A}
199 mirror://mysql/Downloads/${URI_DIR}-${PV%.*}/${URI_A}"
142 # The (old) enterprise source is on the primary site only 200 # The (old) enterprise source is on the primary site only
143 elif [ "${PN}" == "mysql" ]; then 201 elif [ "${PN}" == "mysql" ]; then
144 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz" 202 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
145 fi 203 fi
146fi 204fi
147 205
148# Define correct SRC_URIs 206# Define correct SRC_URIs
149SRC_URI="${SERVER_URI}" 207SRC_URI="${SERVER_URI}"
150 208
151[[ ${MY_EXTRAS_VER} != live ]] && SRC_URI="${SRC_URI} 209# Gentoo patches to MySQL
210[[ ${MY_EXTRAS_VER} != live ]] \
211&& SRC_URI="${SRC_URI}
152 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 212 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
153 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2" 213 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
154PBXT_SRC_URI="mirror://sourceforge/pbxt/pbxt-${PBXT_VERSION}.tar.gz" 214 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
155mysql_version_is_at_least "5.1.12" \
156&& [[ -n "${PBXT_VERSION}" ]] \
157&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URIPBXT_SRC_URI} )"
158
159# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
160XTRADB_SRC_URI="http://www.percona.com/${PN}/xtradb/${PERCONA_VER}/source/percona-xtradb-${XTRADB_VER}.tar.gz"
161mysql_version_is_at_least "5.1.26" \
162&& [[ -n ${XTRADB_VER} && -n ${PERCONA_VER} ]] \
163&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI} )"
164 215
165DESCRIPTION="A fast, multi-threaded, multi-user SQL database server." 216DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
166HOMEPAGE="http://www.mysql.com/" 217HOMEPAGE="http://www.mysql.com/"
218if [[ "${PN}" == "mariadb" ]]; then
219 HOMEPAGE="http://askmonty.org/"
220 DESCRIPTION="MariaDB is a MySQL fork with 3rd-party patches and additional storage engines merged."
221fi
222if [[ "${PN}" == "mysql-community" ]]; then
223 DESCRIPTION="${DESCRIPTION} (obsolete, move to dev-db/mysql)"
224fi
167LICENSE="GPL-2" 225LICENSE="GPL-2"
168SLOT="0" 226SLOT="0"
169IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static" 227IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
170 228
171mysql_version_is_at_least "4.1" \ 229mysql_version_is_at_least "4.1" \
172&& IUSE="${IUSE} latin1" 230&& IUSE="${IUSE} latin1"
173 231
174mysql_version_is_at_least "4.1.3" \ 232if mysql_version_is_at_least "4.1.3" ; then
175&& IUSE="${IUSE} cluster extraengine" 233 IUSE="${IUSE} extraengine"
234 if [[ "${PN}" != "mysql-cluster" ]] ; then
235 IUSE="${IUSE} cluster"
236 fi
237fi
176 238
177mysql_version_is_at_least "5.0" \ 239mysql_version_is_at_least "5.0" \
178|| IUSE="${IUSE} raid" 240|| IUSE="${IUSE} raid"
179 241
180mysql_version_is_at_least "5.0.18" \ 242mysql_version_is_at_least "5.0.18" \
181&& IUSE="${IUSE} max-idx-128" 243&& IUSE="${IUSE} max-idx-128"
182 244
183mysql_version_is_at_least "5.1" \ 245mysql_version_is_at_least "5.1" \
184|| IUSE="${IUSE} berkdb" 246|| IUSE="${IUSE} berkdb"
185 247
186mysql_version_is_at_least "5.1.12" \
187&& IUSE="${IUSE} pbxt"
188
189mysql_version_is_at_least "5.1.26" \
190&& IUSE="${IUSE} xtradb"
191
192[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \ 248[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
193&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling" 249&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
250
251[[ "${PN}" == "mariadb" ]] \
252&& IUSE="${IUSE} libevent"
253
254[[ "${PN}" == "mariadb" ]] \
255&& mysql_version_is_at_least "5.2" \
256&& IUSE="${IUSE} oqgraph"
257#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
258#&& IUSE="${IUSE} oqgraph sphinx"
259
260# MariaDB has integrated PBXT
261# PBXT_VERSION means that we have a PBXT patch for this PV
262# PBXT was only introduced after 5.1.12
263pbxt_patch_available() {
264 [[ "${PN}" != "mariadb" ]] \
265 && mysql_version_is_at_least "5.1.12" \
266 && [[ -n "${PBXT_VERSION}" ]]
267 return $?
268}
269
270pbxt_available() {
271 pbxt_patch_available || [[ "${PN}" == "mariadb" ]]
272 return $?
273}
274
275# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
276# MariaDB has integrated XtraDB
277# XTRADB_VERS means that we have a XTRADB patch for this PV
278# XTRADB was only introduced after 5.1.26
279xtradb_patch_available() {
280 [[ "${PN}" != "mariadb" ]] \
281 && mysql_version_is_at_least "5.1.26" \
282 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]]
283 return $?
284}
285
286
287pbxt_patch_available \
288&& PBXT_P="pbxt-${PBXT_VERSION}" \
289&& PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
290&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
291
292# PBXT_NEWSTYLE means pbxt is in storage/ and gets enabled as other plugins
293# vs. built outside the dir
294pbxt_available \
295&& IUSE="${IUSE} pbxt" \
296&& mysql_version_is_at_least "5.1.40" \
297&& PBXT_NEWSTYLE=1
298
299xtradb_patch_available \
300&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
301&& XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
302&& XTRADB_SRC_B1="http://www.percona.com/" \
303&& XTRADB_SRC_B2="${XTRADB_SRC_B1}/percona-builds/" \
304&& XTRADB_SRC_URI1="${XTRADB_SRC_B2}/Percona-Server/Percona-Server-${XTRADB_SRC_URI_COMMON}" \
305&& XTRADB_SRC_URI2="${XTRADB_SRC_B2}/xtradb/${XTRADB_SRC_URI_COMMON}" \
306&& XTRADB_SRC_URI3="${XTRADB_SRC_B1}/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
307&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} ${XTRADB_SRC_URI3} )" \
308&& IUSE="${IUSE} xtradb"
194 309
195# 310#
196# HELPER FUNCTIONS: 311# HELPER FUNCTIONS:
197# 312#
198 313
199# @FUNCTION: mysql_disable_test 314# @FUNCTION: mysql_disable_test
200# @DESCRIPTION: 315# @DESCRIPTION:
201# Helper function to disable specific tests. 316# Helper function to disable specific tests.
202mysql_disable_test() { 317mysql_disable_test() {
318 local rawtestname testname testsuite reason mysql_disable_file
203 local testname="${1}" ; shift 319 rawtestname="${1}" ; shift
204 local reason="${@}" 320 reason="${@}"
321 ewarn "test '${rawtestname}' disabled: '${reason}'"
322
323 testsuite="${rawtestname/.*}"
324 testname="${rawtestname/*.}"
205 local mysql_disable_file="${S}/mysql-test/t/disabled.def" 325 mysql_disable_file="${S}/mysql-test/t/disabled.def"
326 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
206 echo ${testname} : ${reason} >> "${mysql_disable_file}" 327 echo ${testname} : ${reason} >> "${mysql_disable_file}"
207 ewarn "test '${testname}' disabled: '${reason}'" 328
329 # ${S}/mysql-tests/t/disabled.def
330 #
331 # ${S}/mysql-tests/suite/federated/disabled.def
332 #
333 # ${S}/mysql-tests/suite/jp/t/disabled.def
334 # ${S}/mysql-tests/suite/ndb/t/disabled.def
335 # ${S}/mysql-tests/suite/rpl/t/disabled.def
336 # ${S}/mysql-tests/suite/parts/t/disabled.def
337 # ${S}/mysql-tests/suite/rpl_ndb/t/disabled.def
338 # ${S}/mysql-tests/suite/ndb_team/t/disabled.def
339 # ${S}/mysql-tests/suite/binlog/t/disabled.def
340 # ${S}/mysql-tests/suite/innodb/t/disabled.def
341 if [ -n "${testsuite}" ]; then
342 for mysql_disable_file in \
343 ${S}/mysql-test/suite/${testsuite}/disabled.def \
344 ${S}/mysql-test/suite/${testsuite}/t/disabled.def \
345 FAILED ; do
346 [ -f "${mysql_disable_file}" ] && break
347 done
348 if [ "${mysql_disabled_file}" != "FAILED" ]; then
349 echo "${testname} : ${reason}" >> "${mysql_disable_file}"
350 else
351 ewarn "Could not find testsuite disabled.def location for ${rawtestname}"
352 fi
353 fi
208} 354}
209 355
210# @FUNCTION: mysql_init_vars 356# @FUNCTION: mysql_init_vars
211# @DESCRIPTION: 357# @DESCRIPTION:
212# void mysql_init_vars() 358# void mysql_init_vars()
263 MY_DATADIR="${new_MY_DATADIR}" 409 MY_DATADIR="${new_MY_DATADIR}"
264 fi 410 fi
265 fi 411 fi
266 fi 412 fi
267 413
414 if [ "${MY_SOURCEDIR:-unset}" == "unset" ]; then
268 MY_SOURCEDIR=${SERVER_URI##*/} 415 MY_SOURCEDIR=${SERVER_URI##*/}
269 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*} 416 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
417 fi
270 418
271 export MY_SHAREDSTATEDIR MY_SYSCONFDIR 419 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
272 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR 420 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
273 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR 421 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
274} 422}
321 if use debug ; then 469 if use debug ; then
322 myconf="${myconf} --with-debug=full" 470 myconf="${myconf} --with-debug=full"
323 else 471 else
324 myconf="${myconf} --without-debug" 472 myconf="${myconf} --without-debug"
325 mysql_version_is_at_least "4.1.3" \ 473 mysql_version_is_at_least "4.1.3" \
326 && use cluster \ 474 && ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) \
327 && myconf="${myconf} --without-ndb-debug" 475 && myconf="${myconf} --without-ndb-debug"
328 fi 476 fi
329 477
330 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then 478 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
331 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}" 479 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
355 myconf="${myconf} $(use_with perl bench)" 503 myconf="${myconf} $(use_with perl bench)"
356 myconf="${myconf} --enable-assembler" 504 myconf="${myconf} --enable-assembler"
357 myconf="${myconf} --with-extra-tools" 505 myconf="${myconf} --with-extra-tools"
358 myconf="${myconf} --with-innodb" 506 myconf="${myconf} --with-innodb"
359 myconf="${myconf} --without-readline" 507 myconf="${myconf} --without-readline"
508 myconf="${myconf} $(use_with ssl openssl)"
360 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)" 509 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
361 510
362 # --with-vio is not needed anymore, it's on by default and 511 # --with-vio is not needed anymore, it's on by default and
363 # has been removed from configure 512 # has been removed from configure
513 # Apply to 4.x and 5.0.[0-3]
364 if use ssl ; then 514 if use ssl ; then
365 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio" 515 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
366 fi
367
368 if mysql_version_is_at_least "5.1.11" ; then
369 myconf="${myconf} $(use_with ssl)"
370 else
371 myconf="${myconf} $(use_with ssl openssl)"
372 fi 516 fi
373 517
374 if mysql_version_is_at_least "5.0.60" ; then 518 if mysql_version_is_at_least "5.0.60" ; then
375 if use berkdb ; then 519 if use berkdb ; then
376 elog "Berkeley DB support was disabled due to build failures" 520 elog "Berkeley DB support was disabled due to build failures"
392 myconf="${myconf} --without-berkeley-db" 536 myconf="${myconf} --without-berkeley-db"
393 fi 537 fi
394 538
395 if mysql_version_is_at_least "4.1.3" ; then 539 if mysql_version_is_at_least "4.1.3" ; then
396 myconf="${myconf} --with-geometry" 540 myconf="${myconf} --with-geometry"
541 if [[ "${PN}" != "mysql-cluster" ]] ; then
397 myconf="${myconf} $(use_with cluster ndbcluster)" 542 myconf="${myconf} $(use_with cluster ndbcluster)"
543 fi
398 fi 544 fi
399 545
400 if mysql_version_is_at_least "4.1.3" && use extraengine ; then 546 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
401 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html 547 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
402 myconf="${myconf} --with-archive-storage-engine" 548 myconf="${myconf} --with-archive-storage-engine"
433 579
434configure_51() { 580configure_51() {
435 # TODO: !!!! readd --without-readline 581 # TODO: !!!! readd --without-readline
436 # the failure depend upon config/ac-macros/readline.m4 checking into 582 # the failure depend upon config/ac-macros/readline.m4 checking into
437 # readline.h instead of history.h 583 # readline.h instead of history.h
438 myconf="${myconf} $(use_with ssl)" 584 myconf="${myconf} $(use_with ssl ssl /usr)"
439 myconf="${myconf} --enable-assembler" 585 myconf="${myconf} --enable-assembler"
440 myconf="${myconf} --with-geometry" 586 myconf="${myconf} --with-geometry"
441 myconf="${myconf} --with-readline" 587 myconf="${myconf} --with-readline"
442 myconf="${myconf} --with-row-based-replication"
443 myconf="${myconf} --with-zlib=/usr/$(get_libdir)" 588 myconf="${myconf} --with-zlib-dir=/usr/"
444 myconf="${myconf} --without-pstack" 589 myconf="${myconf} --without-pstack"
590 myconf="${myconf} --with-plugindir=/usr/$(get_libdir)/mysql/plugin"
591
592 # This is an explict die here, because if we just forcibly disable it, then the
593 # user's data is not accessible.
594 use max-idx-128 && die "Bug #336027: upstream has a corruption issue with max-idx-128 presently"
445 use max-idx-128 && myconf="${myconf} --with-max-indexes=128" 595 #use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
596 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
597 myconf="${myconf} $(use_enable community community-features)"
598 if use community; then
599 myconf="${myconf} $(use_enable profiling)"
600 else
601 myconf="${myconf} --disable-profiling"
602 fi
603 fi
604
605 # Scan for all available plugins
606 local plugins_avail="$(
607 LANG=C \
608 find "${S}" \
609 \( \
610 -name 'plug.in' \
611 -o -iname 'configure.in' \
612 -o -iname 'configure.ac' \
613 \) \
614 -print0 \
615 | xargs -0 sed -r -n \
616 -e '/^MYSQL_STORAGE_ENGINE/{
617 s~MYSQL_STORAGE_ENGINE\([[:space:]]*\[?([-_a-z0-9]+)\]?.*,~\1 ~g ;
618 s~^([^ ]+).*~\1~gp;
619 }' \
620 | tr -s '\n' ' '
621 )"
446 622
447 # 5.1 introduces a new way to manage storage engines (plugins) 623 # 5.1 introduces a new way to manage storage engines (plugins)
448 # like configuration=none 624 # like configuration=none
625 # This base set are required, and will always be statically built.
449 local plugins="csv,myisam,myisammrg,heap" 626 local plugins_sta="csv myisam myisammrg heap"
627 local plugins_dyn=""
628 local plugins_dis="example ibmdb2i"
629
630 # These aren't actually required by the base set, but are really useful:
631 plugins_sta="${plugins_sta} archive blackhole"
632
633 # default in 5.5.4
634 if mysql_version_is_at_least "5.5.4" ; then
635 plugins_sta="${plugins_sta} partition"
636 fi
637 # Now the extras
450 if use extraengine ; then 638 if use extraengine ; then
451 # like configuration=max-no-ndb, archive and example removed in 5.1.11 639 # like configuration=max-no-ndb, archive and example removed in 5.1.11
452 plugins="${plugins},archive,blackhole,example,federated,partition" 640 # not added yet: ibmdb2i
641 # Not supporting as examples: example,daemon_example,ftexample
642 plugins_sta="${plugins_sta} partition"
453 643
644 if [[ "${PN}" != "mariadb" ]] ; then
454 elog "Before using the Federated storage engine, please be sure to read" 645 elog "Before using the Federated storage engine, please be sure to read"
455 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 646 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
647 plugins_dyn="${plugins_sta} federated"
648 else
649 elog "MariaDB includes the FederatedX engine. Be sure to read"
650 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
651 plugins_dyn="${plugins_sta} federatedx"
456 fi 652 fi
653 else
654 plugins_dis="${plugins_dis} partition federated"
655 fi
457 656
458 # Upstream specifically requests that InnoDB always be built. 657 # Upstream specifically requests that InnoDB always be built:
459 plugins="${plugins},innobase" 658 # - innobase, innodb_plugin
659 # Build falcon if available for 6.x series.
660 for i in innobase falcon ; do
661 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
662 done
663 for i in innodb_plugin ; do
664 [ -e "${S}"/storage/${i} ] && plugins_dyn="${plugins_dyn} ${i}"
665 done
460 666
461 # like configuration=max-no-ndb 667 # like configuration=max-no-ndb
462 if use cluster ; then 668 if ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) ; then
463 plugins="${plugins},ndbcluster" 669 plugins_sta="${plugins_sta} ndbcluster partition"
670 plugins_dis="${plugins_dis//partition}"
464 myconf="${myconf} --with-ndb-binlog" 671 myconf="${myconf} --with-ndb-binlog"
672 else
673 plugins_dis="${plugins_dis} ndbcluster"
674 fi
675
676 if [[ "${PN}" == "mariadb" ]] ; then
677 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
678 # caught above.
679 # This is not optional, without it several upstream testcases fail.
680 # Also strongly recommended by upstream.
681 if [[ "${PV}" < "5.2.0" ]] ; then
682 myconf="${myconf} --with-maria-tmp-tables"
683 plugins_sta="${plugins_sta} maria"
684 else
685 myconf="${myconf} --with-aria-tmp-tables"
686 plugins_sta="${plugins_sta} aria"
465 fi 687 fi
466 688
689 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] ||
690 die "The ${P} package doesn't provide innobase nor xtradb"
691
692 for i in innobase xtradb ; do
693 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
694 done
695
696 myconf="${myconf} $(use_with libevent)"
697
467 if mysql_version_is_at_least "5.2" ; then 698 if mysql_version_is_at_least "5.2" ; then
468 plugins="${plugins},falcon" 699 #This should include sphinx, but the 5.2.4 archive forgot the plug.in file
700 #for i in oqgraph sphinx ; do
701 for i in oqgraph ; do
702 use ${i} \
703 && plugins_dyn="${plugins_dyn} ${i}" \
704 || plugins_dis="${plugins_dis} ${i}"
705 done
469 fi 706 fi
707 fi
470 708
709 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then
710 use pbxt \
711 && plugins_dyn="${plugins_dyn} pbxt" \
712 || plugins_dis="${plugins_dis} pbxt"
713 fi
714
715 use static && \
716 plugins_sta="${plugins_sta} ${plugins_dyn}" && \
717 plugins_dyn=""
718
719 einfo "Available plugins: ${plugins_avail}"
720 einfo "Dynamic plugins: ${plugins_dyn}"
721 einfo "Static plugins: ${plugins_sta}"
722 einfo "Disabled plugins: ${plugins_dis}"
723
724 # These are the static plugins
471 myconf="${myconf} --with-plugins=${plugins}" 725 myconf="${myconf} --with-plugins=${plugins_sta// /,}"
726 # And the disabled ones
727 for i in ${plugins_dis} ; do
728 myconf="${myconf} --without-plugin-${i}"
729 done
472} 730}
473 731
474pbxt_src_configure() { 732pbxt_src_configure() {
475 mysql_init_vars 733 mysql_init_vars
476 734
477 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 735 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
478 736
479 einfo "Reconfiguring dir '${PWD}'" 737 einfo "Reconfiguring dir '${PWD}'"
480 AT_GNUCONF_UPDATE="yes" eautoreconf 738 eautoreconf
481 739
482 local myconf="" 740 local myconf=""
483 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}" 741 myconf="${myconf} --with-mysql=${S} --libdir=/usr/$(get_libdir)"
484 use debug && myconf="${myconf} --with-debug=full" 742 use debug && myconf="${myconf} --with-debug=full"
485 # TODO: is it safe/needed to use econf here ?
486 ./configure ${myconf} || die "Problem configuring PBXT storage engine" 743 econf ${myconf} || die "Problem configuring PBXT storage engine"
487} 744}
488 745
489pbxt_src_compile() { 746pbxt_src_compile() {
747
490 # Be backwards compatible for now 748 # Be backwards compatible for now
491 if [[ $EAPI != 2 ]]; then 749 if [[ $EAPI != 2 ]]; then
492 pbxt_src_configure 750 pbxt_src_configure
493 fi 751 fi
494 # TODO: is it safe/needed to use emake here ? 752 # TODO: is it safe/needed to use emake here ?
498 # TODO: modify test suite for PBXT 756 # TODO: modify test suite for PBXT
499} 757}
500 758
501pbxt_src_install() { 759pbxt_src_install() {
502 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 760 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
503 make install || die "Failed to install PBXT" 761 emake install DESTDIR="${D}" || die "Failed to install PBXT"
504 popd 762 popd
505} 763}
506 764
507# 765#
508# EBUILD FUNCTIONS 766# EBUILD FUNCTIONS
521 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root." 779 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
522 fi 780 fi
523 fi 781 fi
524 fi 782 fi
525 783
784 # bug 350844
785 case "${EAPI:-0}" in
786 0 | 1)
787 if use static && !built_with_use sys-libs/ncurses static-libs; then
788 die "To build MySQL statically you need to enable static-libs for sys-libs/ncurses"
789 fi
790 ;;
791 esac
792
526 # Check for USE flag problems in pkg_setup 793 # Check for USE flag problems in pkg_setup
527 if use static && use ssl ; then 794 if use static && use ssl ; then
528 eerror "MySQL does not support being built statically with SSL support enabled!"
529 die "MySQL does not support being built statically with SSL support enabled!" 795 M="MySQL does not support being built statically with SSL support enabled!"
796 eerror "${M}"
797 die "${M}"
798 fi
799
800 if mysql_version_is_at_least "5.1.51" \
801 && ! mysql_version_is_at_least "5.2" \
802 && use debug ; then
803 # Also in package.use.mask
804 die "Bug #344885: Upstream has broken USE=debug for 5.1 series >=5.1.51"
530 fi 805 fi
531 806
532 if ! mysql_version_is_at_least "5.0" \ 807 if ! mysql_version_is_at_least "5.0" \
533 && use raid \ 808 && use raid \
534 && use static ; then 809 && use static ; then
536 eerror "with RAID support enabled." 811 eerror "with RAID support enabled."
537 die "USE flags 'raid' and 'static' conflict!" 812 die "USE flags 'raid' and 'static' conflict!"
538 fi 813 fi
539 814
540 if mysql_version_is_at_least "4.1.3" \ 815 if mysql_version_is_at_least "4.1.3" \
541 && ( use cluster || use extraengine ) \ 816 && ( use cluster || use extraengine || use embedded ) \
542 && use minimal ; then 817 && use minimal ; then
543 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
544 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 818 M="USE flags 'cluster', 'extraengine', 'embedded' conflict with 'minimal' USE flag!"
819 eerror "${M}"
820 die "${M}"
821 fi
822
823 if mysql_version_is_at_least "5.1" \
824 && xtradb_patch_available \
825 && use xtradb \
826 && use embedded ; then
827 M="USE flags 'xtradb' and 'embedded' conflict and cause build failures"
828 eerror "${M}"
829 die "${M}"
830 fi
831
832 # Bug #290570, 284946, 307251
833 # Upstream changes made us need a fairly new GCC4.
834 # But only for 5.0.8[3-6]!
835 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then
836 GCC_VER=$(gcc-version)
837 case ${GCC_VER} in
838 2*|3*|4.0|4.1|4.2)
839 eerror "Some releases of MySQL required a very new GCC, and then"
840 eerror "later release relaxed that requirement again. Either pick a"
841 eerror "MySQL >=5.0.87, or use a newer GCC."
842 die "Active GCC too old!" ;;
843 esac
545 fi 844 fi
546 845
547 # This should come after all of the die statements 846 # This should come after all of the die statements
548 enewgroup mysql 60 || die "problem adding 'mysql' group" 847 enewgroup mysql 60 || die "problem adding 'mysql' group"
549 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 848 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
550 849
551 mysql_check_version_range "4.0 to 5.0.99.99" \ 850 mysql_check_version_range "4.0 to 5.0.99.99" \
552 && use berkdb \ 851 && use berkdb \
553 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 852 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
853
854 if [ "${PN}" != "mysql-cluster" ] && use cluster; then
855 ewarn "Upstream has noted that the NDB cluster support in the 5.0 and"
856 ewarn "5.1 series should NOT be put into production. In the near"
857 ewarn "future, it will be disabled from building."
858 ewarn ""
859 ewarn "If you need NDB support, you should instead move to the new"
860 ewarn "mysql-cluster package that represents that upstream NDB"
861 ewarn "development."
862 fi
554} 863}
555 864
556# @FUNCTION: mysql_src_unpack 865# @FUNCTION: mysql_src_unpack
557# @DESCRIPTION: 866# @DESCRIPTION:
558# Unpack the source code and call mysql_src_prepare for EAPI < 2. 867# Unpack the source code and call mysql_src_prepare for EAPI < 2.
587 # Now link in right patches 896 # Now link in right patches
588 mysql_mv_patches 897 mysql_mv_patches
589 # And apply 898 # And apply
590 epatch 899 epatch
591 900
592 # Additional checks, remove bundled zlib 901 # last -fPIC fixup, per bug #305873
902 i="${S}"/storage/innodb_plugin/plug.in
903 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
904
905 # Additional checks, remove bundled zlib (Cluster needs this, for static
906 # memory management in zlib, leave available for Cluster)
907 if [[ "${PN}" != "mysql-cluster" ]] ; then
593 rm -f "${S}/zlib/"*.[ch] 908 rm -f "${S}/zlib/"*.[ch]
594 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 909 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
910 fi
595 rm -f "scripts/mysqlbug" 911 rm -f "scripts/mysqlbug"
596 912
597 # Make charsets install in the right place 913 # Make charsets install in the right place
598 find . -name 'Makefile.am' \ 914 find . -name 'Makefile.am' \
599 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \; 915 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
600 916
601 if mysql_version_is_at_least "4.1" ; then 917 if mysql_version_is_at_least "4.1" ; then
602 # Remove what needs to be recreated, so we're sure it's actually done 918 # Remove what needs to be recreated, so we're sure it's actually done
919 einfo "Cleaning up old buildscript files"
603 find . -name Makefile \ 920 find . -name Makefile \
604 -o -name Makefile.in \ 921 -o -name Makefile.in \
605 -o -name configure \ 922 -o -name configure \
606 -exec rm -f {} \; 923 -exec rm -f {} \;
607 rm -f "ltmain.sh" 924 rm -f "ltmain.sh"
608 rm -f "scripts/mysqlbug" 925 rm -f "scripts/mysqlbug"
609 fi 926 fi
610 927
611 local rebuilddirlist d 928 local rebuilddirlist d
612 929
930 if xtradb_patch_available && use xtradb ; then
931 einfo "Adding storage engine: Percona XtraDB (replacing InnoDB)"
932 pushd "${S}"/storage >/dev/null
933 i="innobase"
934 o="${WORKDIR}/storage-${i}.mysql-upstream"
935 # Have we been here already?
936 [ -d "${o}" ] && rm -f "${i}"
937 # Or maybe we haven't
938 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
939 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}"
940 popd >/dev/null
941 fi
942
943 if pbxt_patch_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then
944 einfo "Adding storage engine: PBXT"
945 pushd "${S}"/storage >/dev/null
946 i='pbxt'
947 [ -d "${i}" ] && rm -rf "${i}"
948 cp -ral "${WORKDIR}/${PBXT_P}" "${i}"
949 popd >/dev/null
950 fi
951
613 if mysql_version_is_at_least "5.1.12" ; then 952 if mysql_version_is_at_least "5.1.12" ; then
614 rebuilddirlist="." 953 rebuilddirlist="."
954 # This does not seem to be needed presently. robbat2 2010/02/23
955 #einfo "Updating innobase cmake"
615 # TODO: check this with a cmake expert 956 ## TODO: check this with a cmake expert
616 cmake \ 957 #cmake \
617 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \ 958 # -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
618 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \ 959 # -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
619 "storage/innobase" 960 # "storage/innobase"
620 else 961 else
621 rebuilddirlist=". innobase" 962 rebuilddirlist=". innobase"
622 fi 963 fi
623 964
624 for d in ${rebuilddirlist} ; do 965 for d in ${rebuilddirlist} ; do
625 einfo "Reconfiguring dir '${d}'" 966 einfo "Reconfiguring dir '${d}'"
626 pushd "${d}" &>/dev/null 967 pushd "${d}" &>/dev/null
627 AT_GNUCONF_UPDATE="yes" eautoreconf 968 eautoreconf
628 popd &>/dev/null 969 popd &>/dev/null
629 done 970 done
630 971
631 if mysql_check_version_range "4.1 to 5.0.99.99" \ 972 if mysql_check_version_range "4.1 to 5.0.99.99" \
632 && use berkdb ; then 973 && use berkdb ; then
974 einfo "Fixing up berkdb buildsystem"
633 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh" 975 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
634 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \ 976 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
635 || die "Could not copy libtool.m4 to bdb/dist/" 977 || die "Could not copy libtool.m4 to bdb/dist/"
636 #These files exist only with libtool-2*, and need to be included. 978 #These files exist only with libtool-2*, and need to be included.
637 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then 979 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then
686 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 1028 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
687 export CXXFLAGS 1029 export CXXFLAGS
688 1030
689 # bug #283926, with GCC4.4, this is required to get correct behavior. 1031 # bug #283926, with GCC4.4, this is required to get correct behavior.
690 append-flags -fno-strict-aliasing 1032 append-flags -fno-strict-aliasing
1033
1034 # bug #335185, #335995, with >= GCC4.3.3 on x86 only, omit-frame-pointer
1035 # causes a mis-compile.
1036 # Upstream bugs:
1037 # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38562
1038 # http://bugs.mysql.com/bug.php?id=45205
1039 use x86 && version_is_at_least "4.3.3" "$(gcc-fullversion)" && \
1040 append-flags -fno-omit-frame-pointer && \
1041 filter-flags -fomit-frame-pointer
691 1042
692 econf \ 1043 econf \
693 --libexecdir="/usr/sbin" \ 1044 --libexecdir="/usr/sbin" \
694 --sysconfdir="${MY_SYSCONFDIR}" \ 1045 --sysconfdir="${MY_SYSCONFDIR}" \
695 --localstatedir="${MY_LOCALSTATEDIR}" \ 1046 --localstatedir="${MY_LOCALSTATEDIR}" \
699 --with-low-memory \ 1050 --with-low-memory \
700 --with-client-ldflags=-lstdc++ \ 1051 --with-client-ldflags=-lstdc++ \
701 --enable-thread-safe-client \ 1052 --enable-thread-safe-client \
702 --with-comment="Gentoo Linux ${PF}" \ 1053 --with-comment="Gentoo Linux ${PF}" \
703 --without-docs \ 1054 --without-docs \
1055 --with-LIBDIR="$(get_libdir)" \
704 ${myconf} || die "econf failed" 1056 ${myconf} || die "econf failed"
705 1057
706 # TODO: Move this before autoreconf !!! 1058 # TODO: Move this before autoreconf !!!
707 find . -type f -name Makefile -print0 \ 1059 find . -type f -name Makefile -print0 \
708 | xargs -0 -n100 sed -i \ 1060 | xargs -0 -n100 sed -i \
709 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 1061 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
710 1062
711 if [[ $EAPI == 2 ]]; then 1063 if [[ $EAPI == 2 ]] && [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
712 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_configure 1064 pbxt_patch_available && use pbxt && pbxt_src_configure
713 fi 1065 fi
714} 1066}
715 1067
716# @FUNCTION: mysql_src_compile 1068# @FUNCTION: mysql_src_compile
717# @DESCRIPTION: 1069# @DESCRIPTION:
718# Compile the mysql code. 1070# Compile the mysql code.
719mysql_src_compile() { 1071mysql_src_compile() {
720 # Be backwards compatible for now 1072 # Be backwards compatible for now
721 case ${EAPI:-0} in 1073 case ${EAPI:-0} in
722 2) : ;; 1074 2) : ;;
723 0 | 1) mysql_src_configure ;; 1075 0 | 1) mysql_src_configure ;;
724 esac 1076 esac
725 1077
726 emake || die "emake failed" 1078 emake || die "emake failed"
727 1079
728 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile 1080 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1081 pbxt_patch_available && use pbxt && pbxt_src_compile
1082 fi
729} 1083}
730 1084
731# @FUNCTION: mysql_src_install 1085# @FUNCTION: mysql_src_install
732# @DESCRIPTION: 1086# @DESCRIPTION:
733# Install mysql. 1087# Install mysql.
734mysql_src_install() { 1088mysql_src_install() {
735 # Make sure the vars are correctly initialized 1089 # Make sure the vars are correctly initialized
736 mysql_init_vars 1090 mysql_init_vars
737 1091
738 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed" 1092 emake install \
1093 DESTDIR="${D}" \
1094 benchdir_root="${MY_SHAREDSTATEDIR}" \
1095 testroot="${MY_SHAREDSTATEDIR}" \
1096 || die "emake install failed"
739 1097
740 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_install 1098 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1099 pbxt_patch_available && use pbxt && pbxt_src_install
1100 fi
741 1101
742 # Convenience links 1102 # Convenience links
743 einfo "Making Convenience links for mysqlcheck multi-call binary" 1103 einfo "Making Convenience links for mysqlcheck multi-call binary"
744 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze" 1104 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
745 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair" 1105 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
749 einfo "Removing duplicate /usr/share/mysql files" 1109 einfo "Removing duplicate /usr/share/mysql files"
750 rm -Rf "${D}/usr/share/info" 1110 rm -Rf "${D}/usr/share/info"
751 for removeme in "mysql-log-rotate" mysql.server* \ 1111 for removeme in "mysql-log-rotate" mysql.server* \
752 binary-configure* my-*.cnf mi_test_all* 1112 binary-configure* my-*.cnf mi_test_all*
753 do 1113 do
754 rm -f "${D}"/usr/share/mysql/${removeme} 1114 rm -f "${D}"/${MY_SHAREDSTATEDIR}/${removeme}
755 done 1115 done
756 1116
757 # Clean up stuff for a minimal build 1117 # Clean up stuff for a minimal build
758 if use minimal ; then 1118 if use minimal ; then
759 einfo "Remove all extra content for minimal build" 1119 einfo "Remove all extra content for minimal build"
761 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 1121 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
762 rm -f "${D}/usr/sbin/mysqld" 1122 rm -f "${D}/usr/sbin/mysqld"
763 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 1123 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
764 fi 1124 fi
765 1125
1126 # Unless they explicitly specific USE=test, then do not install the
1127 # testsuite. It DOES have a use to be installed, esp. when you want to do a
1128 # validation of your database configuration after tuning it.
1129 if use !test ; then
1130 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
1131 fi
1132
766 # Configuration stuff 1133 # Configuration stuff
767 if mysql_version_is_at_least "4.1" ; then 1134 case ${MYSQL_PV_MAJOR} in
768 mysql_mycnf_version="4.1"
769 else
770 mysql_mycnf_version="4.0" 1135 3*|4.0) mysql_mycnf_version="4.0" ;;
771 fi 1136 4.[1-9]|5.0) mysql_mycnf_version="4.1" ;;
772 einfo "Building default my.cnf" 1137 5.[1-9]|6*|7*) mysql_mycnf_version="5.1" ;;
1138 esac
1139 einfo "Building default my.cnf (${mysql_mycnf_version})"
773 insinto "${MY_SYSCONFDIR}" 1140 insinto "${MY_SYSCONFDIR}"
774 doins scripts/mysqlaccess.conf 1141 doins scripts/mysqlaccess.conf
1142 mycnf_src="my.cnf-${mysql_mycnf_version}"
775 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \ 1143 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
776 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \ 1144 "${FILESDIR}/${mycnf_src}" \
777 > "${TMPDIR}/my.cnf.ok" 1145 > "${TMPDIR}/my.cnf.ok"
778 if mysql_version_is_at_least "4.1" && use latin1 ; then 1146 if use latin1 ; then
779 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok" 1147 sed -i \
1148 -e "/character-set/s|utf8|latin1|g" \
1149 "${TMPDIR}/my.cnf.ok"
780 fi 1150 fi
781 newins "${TMPDIR}/my.cnf.ok" my.cnf 1151 newins "${TMPDIR}/my.cnf.ok" my.cnf
782 1152
783 # Minimal builds don't have the MySQL server 1153 # Minimal builds don't have the MySQL server
784 if ! use minimal ; then 1154 if ! use minimal ; then
799 done 1169 done
800 fi 1170 fi
801 1171
802 # Docs 1172 # Docs
803 einfo "Installing docs" 1173 einfo "Installing docs"
804 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 1174 dodoc README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE
805 doinfo "${S}"/Docs/mysql.info 1175 doinfo "${S}"/Docs/mysql.info
806 1176
807 # Minimal builds don't have the MySQL server 1177 # Minimal builds don't have the MySQL server
808 if ! use minimal ; then 1178 if ! use minimal ; then
809 einfo "Including support files and sample configurations" 1179 einfo "Including support files and sample configurations"
811 for script in \ 1181 for script in \
812 "${S}"/support-files/my-*.cnf \ 1182 "${S}"/support-files/my-*.cnf \
813 "${S}"/support-files/magic \ 1183 "${S}"/support-files/magic \
814 "${S}"/support-files/ndb-config-2-node.ini 1184 "${S}"/support-files/ndb-config-2-node.ini
815 do 1185 do
816 dodoc "${script}" 1186 [[ -f "$script" ]] && dodoc "${script}"
817 done 1187 done
818 1188
819 docinto "scripts" 1189 docinto "scripts"
820 for script in "${S}"/scripts/mysql* ; do 1190 for script in "${S}"/scripts/mysql* ; do
821 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1191 [[ -f "$script" ]] && [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
822 done 1192 done
823 1193
824 fi 1194 fi
825 1195
826 mysql_lib_symlinks "${D}" 1196 mysql_lib_symlinks "${D}"
860 for script in \ 1230 for script in \
861 support-files/my-*.cnf \ 1231 support-files/my-*.cnf \
862 support-files/magic \ 1232 support-files/magic \
863 support-files/ndb-config-2-node.ini 1233 support-files/ndb-config-2-node.ini
864 do 1234 do
1235 [[ -f "${script}" ]] \
865 dodoc "${script}" 1236 && dodoc "${script}"
866 done 1237 done
867 1238
868 docinto "scripts" 1239 docinto "scripts"
869 for script in scripts/mysql* ; do 1240 for script in scripts/mysql* ; do
1241 [[ -f "${script}" ]] \
870 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1242 && [[ "${script%.sh}" == "${script}" ]] \
1243 && dodoc "${script}"
871 done 1244 done
872 1245
873 einfo 1246 einfo
874 elog "You might want to run:" 1247 elog "You might want to run:"
875 elog "\"emerge --config =${CATEGORY}/${PF}\"" 1248 elog "\"emerge --config =${CATEGORY}/${PF}\""
876 elog "if this is a new install." 1249 elog "if this is a new install."
877 einfo 1250 einfo
878 fi
879 1251
880 if mysql_version_is_at_least "5.1.12" && use pbxt ; then 1252 einfo
1253 elog "If you are upgrading major versions, you should run the"
1254 elog "mysql_upgrade tool."
1255 einfo
1256 fi
1257
1258 if pbxt_available && use pbxt ; then
881 # TODO: explain it better 1259 # TODO: explain it better
882 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';" 1260 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
883 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;" 1261 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
884 elog "if, after that, you cannot start the MySQL server," 1262 elog "if, after that, you cannot start the MySQL server,"
885 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then" 1263 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
936 fi 1314 fi
937 fi 1315 fi
938 1316
939 local pwd1="a" 1317 local pwd1="a"
940 local pwd2="b" 1318 local pwd2="b"
941 local maxtry=5 1319 local maxtry=15
1320
1321 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${ROOT}/root/.my.cnf" ]; then
1322 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${ROOT}/root/.my.cnf")"
1323 fi
942 1324
943 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then 1325 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
944 ewarn "You have already a MySQL database in place." 1326 ewarn "You have already a MySQL database in place."
945 ewarn "(${ROOT}/${MY_DATADIR}/*)" 1327 ewarn "(${ROOT}/${MY_DATADIR}/*)"
946 ewarn "Please rename or delete it if you wish to replace it." 1328 ewarn "Please rename or delete it if you wish to replace it."
949 1331
950 # Bug #213475 - MySQL _will_ object strenously if your machine is named 1332 # Bug #213475 - MySQL _will_ object strenously if your machine is named
951 # localhost. Also causes weird failures. 1333 # localhost. Also causes weird failures.
952 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost" 1334 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
953 1335
954 einfo "Creating the mysql database and setting proper" 1336 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
955 einfo "permissions on it ..."
956 1337
957 einfo "Insert a password for the mysql 'root' user" 1338 einfo "Please provide a password for the mysql 'root' user now, in the"
1339 einfo "MYSQL_ROOT_PASSWORD env var or through the /root/.my.cnf file."
958 ewarn "Avoid [\"'\\_%] characters in the password" 1340 ewarn "Avoid [\"'\\_%] characters in the password"
959 read -rsp " >" pwd1 ; echo 1341 read -rsp " >" pwd1 ; echo
960 1342
961 einfo "Retype the password" 1343 einfo "Retype the password"
962 read -rsp " >" pwd2 ; echo 1344 read -rsp " >" pwd2 ; echo
963 1345
964 if [[ "x$pwd1" != "x$pwd2" ]] ; then 1346 if [[ "x$pwd1" != "x$pwd2" ]] ; then
965 die "Passwords are not the same" 1347 die "Passwords are not the same"
1348 fi
1349 MYSQL_ROOT_PASSWORD="${pwd1}"
1350 unset pwd1 pwd2
966 fi 1351 fi
967 1352
968 local options="" 1353 local options=""
969 local sqltmp="$(emktemp)" 1354 local sqltmp="$(emktemp)"
970 1355
984 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \ 1369 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
985 || die "MySQL databases not installed" 1370 || die "MySQL databases not installed"
986 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null 1371 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
987 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null 1372 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
988 1373
1374 # Figure out which options we need to disable to do the setup
1375 helpfile="${TMPDIR}/mysqld-help"
1376 ${ROOT}/usr/sbin/mysqld --verbose --help >"${helpfile}" 2>/dev/null
1377 for opt in grant-tables host-cache name-resolve networking slave-start bdb \
1378 federated innodb ssl log-bin relay-log slow-query-log external-locking \
1379 ndbcluster \
1380 ; do
1381 optexp="--(skip-)?${opt}" optfull="--skip-${opt}"
1382 egrep -sq -- "${optexp}" "${helpfile}" && options="${options} ${optfull}"
1383 done
1384 # But some options changed names
1385 egrep -sq external-locking "${helpfile}" && \
1386 options="${options/skip-locking/skip-external-locking}"
1387
989 if mysql_version_is_at_least "4.1.3" ; then 1388 if mysql_version_is_at_least "4.1.3" ; then
990 options="--skip-ndbcluster"
991
992 # Filling timezones, see 1389 # Filling timezones, see
993 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html 1390 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
994 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null 1391 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
995 1392
996 if [[ -r "${help_tables}" ]] ; then 1393 if [[ -r "${help_tables}" ]] ; then
997 cat "${help_tables}" >> "${sqltmp}" 1394 cat "${help_tables}" >> "${sqltmp}"
998 fi 1395 fi
999 fi 1396 fi
1397
1398 einfo "Creating the mysql database and setting proper"
1399 einfo "permissions on it ..."
1000 1400
1001 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock" 1401 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock"
1002 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid" 1402 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid"
1003 local mysqld="${ROOT}/usr/sbin/mysqld \ 1403 local mysqld="${ROOT}/usr/sbin/mysqld \
1004 ${options} \ 1404 ${options} \
1005 --user=mysql \ 1405 --user=mysql \
1006 --skip-grant-tables \
1007 --basedir=${ROOT}/usr \ 1406 --basedir=${ROOT}/usr \
1008 --datadir=${ROOT}/${MY_DATADIR} \ 1407 --datadir=${ROOT}/${MY_DATADIR} \
1009 --skip-innodb \
1010 --skip-bdb \
1011 --skip-networking \
1012 --max_allowed_packet=8M \ 1408 --max_allowed_packet=8M \
1013 --net_buffer_length=16K \ 1409 --net_buffer_length=16K \
1410 --default-storage-engine=MyISAM \
1014 --socket=${socket} \ 1411 --socket=${socket} \
1015 --pid-file=${pidfile}" 1412 --pid-file=${pidfile}"
1413 #einfo "About to start mysqld: ${mysqld}"
1414 ebegin "Starting mysqld"
1016 ${mysqld} & 1415 ${mysqld} &
1416 rc=$?
1017 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do 1417 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
1018 maxtry=$((${maxtry}-1)) 1418 maxtry=$((${maxtry}-1))
1019 echo -n "." 1419 echo -n "."
1020 sleep 1 1420 sleep 1
1021 done 1421 done
1422 eend $rc
1022 1423
1424 if ! [[ -S "${socket}" ]]; then
1425 die "Completely failed to start up mysqld with: ${mysqld}"
1426 fi
1427
1428 ebegin "Setting root password"
1023 # Do this from memory, as we don't want clear text passwords in temp files 1429 # Do this from memory, as we don't want clear text passwords in temp files
1024 local sql="UPDATE mysql.user SET Password = PASSWORD('${pwd1}') WHERE USER='root'" 1430 local sql="UPDATE mysql.user SET Password = PASSWORD('${MYSQL_ROOT_PASSWORD}') WHERE USER='root'"
1025 "${ROOT}/usr/bin/mysql" \ 1431 "${ROOT}/usr/bin/mysql" \
1026 --socket=${socket} \ 1432 --socket=${socket} \
1027 -hlocalhost \ 1433 -hlocalhost \
1028 -e "${sql}" 1434 -e "${sql}"
1435 eend $?
1029 1436
1030 einfo "Loading \"zoneinfo\", this step may require a few seconds ..." 1437 ebegin "Loading \"zoneinfo\", this step may require a few seconds ..."
1031
1032 "${ROOT}/usr/bin/mysql" \ 1438 "${ROOT}/usr/bin/mysql" \
1033 --socket=${socket} \ 1439 --socket=${socket} \
1034 -hlocalhost \ 1440 -hlocalhost \
1035 -uroot \ 1441 -uroot \
1036 -p"${pwd1}" \ 1442 -p"${MYSQL_ROOT_PASSWORD}" \
1037 mysql < "${sqltmp}" 1443 mysql < "${sqltmp}"
1444 rc=$?
1445 eend $?
1446 [ $rc -ne 0 ] && ewarn "Failed to load zoneinfo!"
1038 1447
1039 # Stop the server and cleanup 1448 # Stop the server and cleanup
1449 einfo "Stopping the server ..."
1040 kill $(< "${pidfile}" ) 1450 kill $(< "${pidfile}" )
1041 rm -f "${sqltmp}" 1451 rm -f "${sqltmp}"
1042 einfo "Stopping the server ..."
1043 wait %1 1452 wait %1
1044 einfo "Done" 1453 einfo "Done"
1045} 1454}
1046 1455
1047# @FUNCTION: mysql_pkg_postrm 1456# @FUNCTION: mysql_pkg_postrm

Legend:
Removed from v.1.120  
changed lines
  Added in v.1.159

  ViewVC Help
Powered by ViewVC 1.1.20