/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.129 Revision 1.135
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.129 2010/02/02 02:46:52 robbat2 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.135 2010/03/03 23:57:13 robbat2 Exp $
4 4
5# @ECLASS: mysql.eclass 5# @ECLASS: mysql.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 7# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
8# Maintainers: MySQL Team <mysql-bugs@gentoo.org> 8# Maintainers: MySQL Team <mysql-bugs@gentoo.org>
83 MYSQL_COMMUNITY_FEATURES=1 83 MYSQL_COMMUNITY_FEATURES=1
84elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then 84elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
85 MYSQL_COMMUNITY_FEATURES=1 85 MYSQL_COMMUNITY_FEATURES=1
86elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then 86elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
87 MYSQL_COMMUNITY_FEATURES=1 87 MYSQL_COMMUNITY_FEATURES=1
88elif [ "${PV#5.4}" != "${PV}" ] || [ "${PV#5.4}" != "${PV}" ]; then 88elif [ "${PV#5.4}" != "${PV}" ] ; then
89 MYSQL_COMMUNITY_FEATURES=1
90elif [ "${PV#5.5}" != "${PV}" ] ; then
91 MYSQL_COMMUNITY_FEATURES=1
92elif [ "${PV#6.0}" != "${PV}" ] ; then
89 MYSQL_COMMUNITY_FEATURES=1 93 MYSQL_COMMUNITY_FEATURES=1
90else 94else
91 MYSQL_COMMUNITY_FEATURES=0 95 MYSQL_COMMUNITY_FEATURES=0
92fi 96fi
93 97
134# For other stuff to bring us in 138# For other stuff to bring us in
135PDEPEND="${PDEPEND} =virtual/mysql-$(get_version_component_range 1-2 ${PV})" 139PDEPEND="${PDEPEND} =virtual/mysql-$(get_version_component_range 1-2 ${PV})"
136 140
137# Work out the default SERVER_URI correctly 141# Work out the default SERVER_URI correctly
138if [ -z "${SERVER_URI}" ]; then 142if [ -z "${SERVER_URI}" ]; then
143 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
139 # The community build is on the mirrors 144 # The community build is on the mirrors
140 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then 145 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
141 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz" 146 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${MY_PV}.tar.gz"
142 # The (old) enterprise source is on the primary site only 147 # The (old) enterprise source is on the primary site only
143 elif [ "${PN}" == "mysql" ]; then 148 elif [ "${PN}" == "mysql" ]; then
144 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz" 149 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
145 fi 150 fi
146fi 151fi
147 152
148# Define correct SRC_URIs 153# Define correct SRC_URIs
149SRC_URI="${SERVER_URI}" 154SRC_URI="${SERVER_URI}"
153&& SRC_URI="${SRC_URI} 158&& SRC_URI="${SRC_URI}
154 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 159 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
155 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 160 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
156 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2" 161 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
157 162
163DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
164HOMEPAGE="http://www.mysql.com/"
165LICENSE="GPL-2"
166SLOT="0"
167IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
168
169mysql_version_is_at_least "4.1" \
170&& IUSE="${IUSE} latin1"
171
172mysql_version_is_at_least "4.1.3" \
173&& IUSE="${IUSE} cluster extraengine"
174
175mysql_version_is_at_least "5.0" \
176|| IUSE="${IUSE} raid"
177
178mysql_version_is_at_least "5.0.18" \
179&& IUSE="${IUSE} max-idx-128"
180
181mysql_version_is_at_least "5.1" \
182|| IUSE="${IUSE} berkdb"
183
184[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
185&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
186
158# PBXT engine 187# PBXT engine
159mysql_version_is_at_least "5.1.12" \ 188mysql_version_is_at_least "5.1.12" \
160&& [[ -n "${PBXT_VERSION}" ]] \ 189&& [[ -n "${PBXT_VERSION}" ]] \
161&& PBXT_P="pbxt-${PBXT_VERSION}" \ 190&& PBXT_P="pbxt-${PBXT_VERSION}" \
162&& PBXT_SRC_URI="mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \ 191&& PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
163&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" 192&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
193&& IUSE="${IUSE} pbxt"
164 194
165# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set 195# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
166mysql_version_is_at_least "5.1.26" \ 196mysql_version_is_at_least "5.1.26" \
167&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \ 197&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
168&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \ 198&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
199&& XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
200&& XTRADB_SRC_URI1="http://www.percona.com/percona-builds/xtradb/${XTRADB_SRC_URI_COMMON}" \
169&& XTRADB_SRC_URI="http://www.percona.com/${PN}/xtradb/${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \ 201&& XTRADB_SRC_URI2="http://www.percona.com/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
170&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI} )" 202&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} )" \
171
172DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
173HOMEPAGE="http://www.mysql.com/"
174LICENSE="GPL-2"
175SLOT="0"
176IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static"
177
178mysql_version_is_at_least "4.1" \
179&& IUSE="${IUSE} latin1"
180
181mysql_version_is_at_least "4.1.3" \
182&& IUSE="${IUSE} cluster extraengine"
183
184mysql_version_is_at_least "5.0" \
185|| IUSE="${IUSE} raid"
186
187mysql_version_is_at_least "5.0.18" \
188&& IUSE="${IUSE} max-idx-128"
189
190mysql_version_is_at_least "5.1" \
191|| IUSE="${IUSE} berkdb"
192
193mysql_version_is_at_least "5.1.12" \
194&& [[ -n "${PBXT_VERSION}" ]] \
195&& IUSE="${IUSE} pbxt"
196
197mysql_version_is_at_least "5.1.26" \
198&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
199&& IUSE="${IUSE} xtradb" 203&& IUSE="${IUSE} xtradb"
200
201[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
202&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
203 204
204# 205#
205# HELPER FUNCTIONS: 206# HELPER FUNCTIONS:
206# 207#
207 208
215 ewarn "test '${rawtestname}' disabled: '${reason}'" 216 ewarn "test '${rawtestname}' disabled: '${reason}'"
216 217
217 testsuite="${rawtestname/.*}" 218 testsuite="${rawtestname/.*}"
218 testname="${rawtestname/*.}" 219 testname="${rawtestname/*.}"
219 mysql_disable_file="${S}/mysql-test/t/disabled.def" 220 mysql_disable_file="${S}/mysql-test/t/disabled.def"
220 einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}" 221 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
221 echo ${testname} : ${reason} >> "${mysql_disable_file}" 222 echo ${testname} : ${reason} >> "${mysql_disable_file}"
222 223
223 # ${S}/mysql-tests/t/disabled.def 224 # ${S}/mysql-tests/t/disabled.def
224 # 225 #
225 # ${S}/mysql-tests/suite/federated/disabled.def 226 # ${S}/mysql-tests/suite/federated/disabled.def
404 if use ssl ; then 405 if use ssl ; then
405 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio" 406 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
406 fi 407 fi
407 408
408 if mysql_version_is_at_least "5.1.11" ; then 409 if mysql_version_is_at_least "5.1.11" ; then
409 myconf="${myconf} $(use_with ssl)" 410 myconf="${myconf} $(use_with ssl /usr)"
410 else 411 else
411 myconf="${myconf} $(use_with ssl openssl)" 412 myconf="${myconf} $(use_with ssl openssl)"
412 fi 413 fi
413 414
414 if mysql_version_is_at_least "5.0.60" ; then 415 if mysql_version_is_at_least "5.0.60" ; then
477 # readline.h instead of history.h 478 # readline.h instead of history.h
478 myconf="${myconf} $(use_with ssl)" 479 myconf="${myconf} $(use_with ssl)"
479 myconf="${myconf} --enable-assembler" 480 myconf="${myconf} --enable-assembler"
480 myconf="${myconf} --with-geometry" 481 myconf="${myconf} --with-geometry"
481 myconf="${myconf} --with-readline" 482 myconf="${myconf} --with-readline"
482 myconf="${myconf} --with-row-based-replication"
483 myconf="${myconf} --with-zlib=/usr/$(get_libdir)" 483 myconf="${myconf} --with-zlib-dir=/usr/"
484 myconf="${myconf} --without-pstack" 484 myconf="${myconf} --without-pstack"
485 use max-idx-128 && myconf="${myconf} --with-max-indexes=128" 485 use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
486 486
487 # 5.1 introduces a new way to manage storage engines (plugins) 487 # 5.1 introduces a new way to manage storage engines (plugins)
488 # like configuration=none 488 # like configuration=none
495 495
496 elog "Before using the Federated storage engine, please be sure to read" 496 elog "Before using the Federated storage engine, please be sure to read"
497 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 497 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
498 fi 498 fi
499 499
500 # Upstream specifically requests that InnoDB always be built. 500 # Upstream specifically requests that InnoDB always be built:
501 plugins="${plugins},innobase,innodb_plugin" 501 # - innobase, innodb_plugin
502 # Build falcon if available for 6.x series.
503 for i in innobase innodb_plugin falcon ; do
504 [ -e "${S}"/storage/${i} ] && plugins="${plugins},${i}"
505 done
502 506
503 # like configuration=max-no-ndb 507 # like configuration=max-no-ndb
504 if use cluster ; then 508 if use cluster ; then
505 plugins="${plugins},ndbcluster" 509 plugins="${plugins},ndbcluster"
506 myconf="${myconf} --with-ndb-binlog" 510 myconf="${myconf} --with-ndb-binlog"
507 fi 511 fi
508 512
509 if [ -e "${S}/storage/falcon" ] ; then
510 plugins="${plugins},falcon"
511 fi
512
513 myconf="${myconf} --with-plugins=${plugins}" 513 myconf="${myconf} --with-plugins=${plugins}"
514}
515
516xtradb_applicable() {
517 mysql_version_is_at_least "5.1.26" \
518 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
519 && use xtradb
520 return $?
521}
522
523pbxt_applicable() {
524 mysql_version_is_at_least "5.1.12" \
525 && [[ -n "${PBXT_VERSION}" ]] \
526 && use pbxt
527 return $?
514} 528}
515 529
516pbxt_src_configure() { 530pbxt_src_configure() {
517 mysql_init_vars 531 mysql_init_vars
518 532
520 534
521 einfo "Reconfiguring dir '${PWD}'" 535 einfo "Reconfiguring dir '${PWD}'"
522 AT_GNUCONF_UPDATE="yes" eautoreconf 536 AT_GNUCONF_UPDATE="yes" eautoreconf
523 537
524 local myconf="" 538 local myconf=""
525 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}" 539 myconf="${myconf} --with-mysql=${S} --libdir=${MY_LIBDIR}"
526 use debug && myconf="${myconf} --with-debug=full" 540 use debug && myconf="${myconf} --with-debug=full"
527 # TODO: is it safe/needed to use econf here ? 541 # TODO: is it safe/needed to use econf here ?
528 ./configure ${myconf} || die "Problem configuring PBXT storage engine" 542 ./configure ${myconf} || die "Problem configuring PBXT storage engine"
529} 543}
530 544
540 # TODO: modify test suite for PBXT 554 # TODO: modify test suite for PBXT
541} 555}
542 556
543pbxt_src_install() { 557pbxt_src_install() {
544 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 558 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
545 make install || die "Failed to install PBXT" 559 emake install DESTDIR="${D}" || die "Failed to install PBXT"
546 popd 560 popd
547} 561}
548 562
549# 563#
550# EBUILD FUNCTIONS 564# EBUILD FUNCTIONS
599 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 613 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
600 614
601 mysql_check_version_range "4.0 to 5.0.99.99" \ 615 mysql_check_version_range "4.0 to 5.0.99.99" \
602 && use berkdb \ 616 && use berkdb \
603 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 617 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
618
619 if [ "${PN}" != "mysql-cluster" ] && use cluster; then
620 ewarn "Upstream has noted that the NDB cluster support in the 5.0 and"
621 ewarn "5.1 series should NOT be put into production. In the near"
622 ewarn "future, it will be disabled from building."
623 ewarn ""
624 ewarn "If you need NDB support, you should instead move to the new"
625 ewarn "mysql-cluster package that represents that upstream NDB"
626 ewarn "development."
627 fi
604} 628}
605 629
606# @FUNCTION: mysql_src_unpack 630# @FUNCTION: mysql_src_unpack
607# @DESCRIPTION: 631# @DESCRIPTION:
608# Unpack the source code and call mysql_src_prepare for EAPI < 2. 632# Unpack the source code and call mysql_src_prepare for EAPI < 2.
637 # Now link in right patches 661 # Now link in right patches
638 mysql_mv_patches 662 mysql_mv_patches
639 # And apply 663 # And apply
640 epatch 664 epatch
641 665
666 # last -fPIC fixup, per bug #305873
667 i="${S}"/storage/innodb_plugin/plug.in
668 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
669
642 # Additional checks, remove bundled zlib 670 # Additional checks, remove bundled zlib
643 rm -f "${S}/zlib/"*.[ch] 671 rm -f "${S}/zlib/"*.[ch]
644 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 672 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
645 rm -f "scripts/mysqlbug" 673 rm -f "scripts/mysqlbug"
646 674
659 rm -f "scripts/mysqlbug" 687 rm -f "scripts/mysqlbug"
660 fi 688 fi
661 689
662 local rebuilddirlist d 690 local rebuilddirlist d
663 691
664 if mysql_version_is_at_least "5.1.26" && use xtradb ; then 692 if xtradb_applicable ; then
665 einfo "Replacing InnoDB with Percona XtraDB" 693 einfo "Replacing InnoDB with Percona XtraDB"
666 pushd "${S}"/storage 694 pushd "${S}"/storage
667 i="innobase" 695 i="innobase"
668 o="${WORKDIR}/storage-${i}.mysql-upstream" 696 o="${WORKDIR}/storage-${i}.mysql-upstream"
669 # Have we been here already? 697 # Have we been here already?
670 [ -h "${i}" ] && rm -f "${i}" 698 [ -d "${o}" ] && rm -f "${i}"
671 # Or maybe we haven't 699 # Or maybe we haven't
672 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}" 700 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
673 ln -s "${WORKDIR}/${XTRADB_P}" "${i}" 701 cp -ra "${WORKDIR}/${XTRADB_P}" "${i}"
674 popd 702 popd
675 fi 703 fi
676 704
677 if mysql_version_is_at_least "5.1.12" ; then 705 if mysql_version_is_at_least "5.1.12" ; then
678 einfo "Updating innobase cmake"
679 rebuilddirlist="." 706 rebuilddirlist="."
707 # This does not seem to be needed presently. robbat2 2010/02/23
708 #einfo "Updating innobase cmake"
680 # TODO: check this with a cmake expert 709 ## TODO: check this with a cmake expert
681 cmake \ 710 #cmake \
682 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \ 711 # -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
683 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \ 712 # -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
684 "storage/innobase" 713 # "storage/innobase"
685 else 714 else
686 rebuilddirlist=". innobase" 715 rebuilddirlist=". innobase"
687 fi 716 fi
688 717
689 for d in ${rebuilddirlist} ; do 718 for d in ${rebuilddirlist} ; do
773 find . -type f -name Makefile -print0 \ 802 find . -type f -name Makefile -print0 \
774 | xargs -0 -n100 sed -i \ 803 | xargs -0 -n100 sed -i \
775 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 804 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
776 805
777 if [[ $EAPI == 2 ]]; then 806 if [[ $EAPI == 2 ]]; then
778 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_configure 807 pbxt_applicable && pbxt_src_configure
779 fi 808 fi
780} 809}
781 810
782# @FUNCTION: mysql_src_compile 811# @FUNCTION: mysql_src_compile
783# @DESCRIPTION: 812# @DESCRIPTION:
789 0 | 1) mysql_src_configure ;; 818 0 | 1) mysql_src_configure ;;
790 esac 819 esac
791 820
792 emake || die "emake failed" 821 emake || die "emake failed"
793 822
794 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile 823 pbxt_applicable && pbxt_src_compile
795} 824}
796 825
797# @FUNCTION: mysql_src_install 826# @FUNCTION: mysql_src_install
798# @DESCRIPTION: 827# @DESCRIPTION:
799# Install mysql. 828# Install mysql.
800mysql_src_install() { 829mysql_src_install() {
801 # Make sure the vars are correctly initialized 830 # Make sure the vars are correctly initialized
802 mysql_init_vars 831 mysql_init_vars
803 832
804 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed" 833 emake install \
834 DESTDIR="${D}" \
835 benchdir_root="${MY_SHAREDSTATEDIR}" \
836 testroot="${MY_SHAREDSTATEDIR}" \
837 || die "emake install failed"
805 838
806 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_install 839 pbxt_applicable && pbxt_src_install
807 840
808 # Convenience links 841 # Convenience links
809 einfo "Making Convenience links for mysqlcheck multi-call binary" 842 einfo "Making Convenience links for mysqlcheck multi-call binary"
810 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze" 843 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
811 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair" 844 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
815 einfo "Removing duplicate /usr/share/mysql files" 848 einfo "Removing duplicate /usr/share/mysql files"
816 rm -Rf "${D}/usr/share/info" 849 rm -Rf "${D}/usr/share/info"
817 for removeme in "mysql-log-rotate" mysql.server* \ 850 for removeme in "mysql-log-rotate" mysql.server* \
818 binary-configure* my-*.cnf mi_test_all* 851 binary-configure* my-*.cnf mi_test_all*
819 do 852 do
820 rm -f "${D}"/usr/share/mysql/${removeme} 853 rm -f "${D}"/${MY_SHAREDSTATEDIR}/${removeme}
821 done 854 done
822 855
823 # Clean up stuff for a minimal build 856 # Clean up stuff for a minimal build
824 if use minimal ; then 857 if use minimal ; then
825 einfo "Remove all extra content for minimal build" 858 einfo "Remove all extra content for minimal build"
826 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench} 859 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench}
827 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 860 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
828 rm -f "${D}/usr/sbin/mysqld" 861 rm -f "${D}/usr/sbin/mysqld"
829 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 862 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
863 fi
864
865 # Unless they explicitly specific USE=test, then do not install the
866 # testsuite. It DOES have a use to be installed, esp. when you want to do a
867 # validation of your database configuration after tuning it.
868 if use !test ; then
869 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
830 fi 870 fi
831 871
832 # Configuration stuff 872 # Configuration stuff
833 if mysql_version_is_at_least "4.1" ; then 873 if mysql_version_is_at_least "4.1" ; then
834 mysql_mycnf_version="4.1" 874 mysql_mycnf_version="4.1"
865 done 905 done
866 fi 906 fi
867 907
868 # Docs 908 # Docs
869 einfo "Installing docs" 909 einfo "Installing docs"
870 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 910 dodoc README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE
871 doinfo "${S}"/Docs/mysql.info 911 doinfo "${S}"/Docs/mysql.info
872 912
873 # Minimal builds don't have the MySQL server 913 # Minimal builds don't have the MySQL server
874 if ! use minimal ; then 914 if ! use minimal ; then
875 einfo "Including support files and sample configurations" 915 einfo "Including support files and sample configurations"
877 for script in \ 917 for script in \
878 "${S}"/support-files/my-*.cnf \ 918 "${S}"/support-files/my-*.cnf \
879 "${S}"/support-files/magic \ 919 "${S}"/support-files/magic \
880 "${S}"/support-files/ndb-config-2-node.ini 920 "${S}"/support-files/ndb-config-2-node.ini
881 do 921 do
882 dodoc "${script}" 922 [[ -f "$script" ]] && dodoc "${script}"
883 done 923 done
884 924
885 docinto "scripts" 925 docinto "scripts"
886 for script in "${S}"/scripts/mysql* ; do 926 for script in "${S}"/scripts/mysql* ; do
887 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 927 [[ -f "$script" ]] && [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
888 done 928 done
889 929
890 fi 930 fi
891 931
892 mysql_lib_symlinks "${D}" 932 mysql_lib_symlinks "${D}"
941 elog "\"emerge --config =${CATEGORY}/${PF}\"" 981 elog "\"emerge --config =${CATEGORY}/${PF}\""
942 elog "if this is a new install." 982 elog "if this is a new install."
943 einfo 983 einfo
944 fi 984 fi
945 985
946 if mysql_version_is_at_least "5.1.12" && use pbxt ; then 986 if pbxt_applicable ; then
947 # TODO: explain it better 987 # TODO: explain it better
948 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';" 988 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
949 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;" 989 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
950 elog "if, after that, you cannot start the MySQL server," 990 elog "if, after that, you cannot start the MySQL server,"
951 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then" 991 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"

Legend:
Removed from v.1.129  
changed lines
  Added in v.1.135

  ViewVC Help
Powered by ViewVC 1.1.20