/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.135 Revision 1.156
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.135 2010/03/03 23:57:13 robbat2 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.156 2010/11/28 21:55:54 robbat2 Exp $
4 4
5# @ECLASS: mysql.eclass 5# @ECLASS: mysql.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 7# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
8# Maintainers: MySQL Team <mysql-bugs@gentoo.org> 8# Maintainers: MySQL Team <mysql-bugs@gentoo.org>
51 ;; 51 ;;
52 *) 52 *)
53 die "Unsupported EAPI: ${EAPI}" ;; 53 die "Unsupported EAPI: ${EAPI}" ;;
54esac 54esac
55 55
56
57# @ECLASS-VARIABLE: MYSQL_PV_MAJOR
58# @DESCRIPTION:
59# Upstream MySQL considers the first two parts of the version number to be the
60# major version. Upgrades that change major version should always run
61# mysql_upgrade.
62MYSQL_PV_MAJOR="$(get_version_component_range 1-2 ${PV})"
63
64# Cluster is a special case...
65if [[ "${PN}" == "mysql-cluster" ]]; then
66 case $PV in
67 6.1*|7.0*|7.1*) MYSQL_PV_MAJOR=5.1 ;;
68 esac
69fi
70
71
56# @ECLASS-VARIABLE: MYSQL_VERSION_ID 72# @ECLASS-VARIABLE: MYSQL_VERSION_ID
57# @DESCRIPTION: 73# @DESCRIPTION:
58# MYSQL_VERSION_ID will be: 74# MYSQL_VERSION_ID will be:
59# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 75# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
60# This is an important part, because many of the choices the MySQL ebuild will do 76# This is an important part, because many of the choices the MySQL ebuild will do
77# @DESCRIPTION: 93# @DESCRIPTION:
78# Specifiy if community features are available. Possible values are 1 (yes) 94# Specifiy if community features are available. Possible values are 1 (yes)
79# and 0 (no). 95# and 0 (no).
80# Community features are available in mysql-community 96# Community features are available in mysql-community
81# AND in the re-merged mysql-5.0.82 and newer 97# AND in the re-merged mysql-5.0.82 and newer
82if [ "${PN}" == "mysql-community" ]; then 98if [ "${PN}" == "mysql-community" -o "${PN}" == "mariadb" ]; then
83 MYSQL_COMMUNITY_FEATURES=1 99 MYSQL_COMMUNITY_FEATURES=1
84elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then 100elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
85 MYSQL_COMMUNITY_FEATURES=1 101 MYSQL_COMMUNITY_FEATURES=1
86elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then 102elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
87 MYSQL_COMMUNITY_FEATURES=1 103 MYSQL_COMMUNITY_FEATURES=1
88elif [ "${PV#5.4}" != "${PV}" ] ; then 104elif [ "${PV#5.4}" != "${PV}" ] ; then
89 MYSQL_COMMUNITY_FEATURES=1 105 MYSQL_COMMUNITY_FEATURES=1
90elif [ "${PV#5.5}" != "${PV}" ] ; then 106elif [ "${PV#5.5}" != "${PV}" ] ; then
91 MYSQL_COMMUNITY_FEATURES=1 107 MYSQL_COMMUNITY_FEATURES=1
92elif [ "${PV#6.0}" != "${PV}" ] ; then 108elif [ "${PV#6}" != "${PV}" ] ; then
109 MYSQL_COMMUNITY_FEATURES=1
110elif [ "${PV#7}" != "${PV}" ] ; then
93 MYSQL_COMMUNITY_FEATURES=1 111 MYSQL_COMMUNITY_FEATURES=1
94else 112else
95 MYSQL_COMMUNITY_FEATURES=0 113 MYSQL_COMMUNITY_FEATURES=0
96fi 114fi
97 115
112 >=sys-apps/sed-4 130 >=sys-apps/sed-4
113 >=sys-apps/texinfo-4.7-r1 131 >=sys-apps/texinfo-4.7-r1
114 >=sys-libs/readline-4.1 132 >=sys-libs/readline-4.1
115 >=sys-libs/zlib-1.2.3" 133 >=sys-libs/zlib-1.2.3"
116 134
135[[ "${PN}" == "mariadb" ]] \
136&& DEPEND="${DEPEND} libevent? ( >=dev-libs/libevent-1.4 )"
137
117# Having different flavours at the same time is not a good idea 138# Having different flavours at the same time is not a good idea
118for i in "" "-community" ; do 139for i in "mysql" "mysql-community" "mysql-cluster" "mariadb" ; do
119 [[ "${i}" == ${PN#mysql} ]] || 140 [[ "${i}" == ${PN} ]] ||
120 DEPEND="${DEPEND} !dev-db/mysql${i}" 141 DEPEND="${DEPEND} !dev-db/${i}"
121done 142done
122 143
123RDEPEND="${DEPEND} 144RDEPEND="${DEPEND}
124 !minimal? ( dev-db/mysql-init-scripts ) 145 !minimal? ( dev-db/mysql-init-scripts )
125 selinux? ( sec-policy/selinux-mysql )" 146 selinux? ( sec-policy/selinux-mysql )"
134 155
135# dev-perl/DBD-mysql is needed by some scripts installed by MySQL 156# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
136PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 157PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
137 158
138# For other stuff to bring us in 159# For other stuff to bring us in
139PDEPEND="${PDEPEND} =virtual/mysql-$(get_version_component_range 1-2 ${PV})" 160PDEPEND="${PDEPEND} =virtual/mysql-${MYSQL_PV_MAJOR}"
140 161
141# Work out the default SERVER_URI correctly 162# Work out the default SERVER_URI correctly
142if [ -z "${SERVER_URI}" ]; then 163if [ -z "${SERVER_URI}" ]; then
143 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}" 164 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
165 if [ "${PN}" == "mariadb" ]; then
166 MARIA_FULL_PV="$(replace_version_separator 3 '-' ${PV})"
167 MARIA_FULL_P="${PN}-${MARIA_FULL_PV}"
168 SERVER_URI="
169 http://ftp.osuosl.org/pub/mariadb/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
170 http://ftp.rediris.es/mirror/MariaDB/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
171 http://maria.llarian.net/download/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
172 http://launchpad.net/maria/${MYSQL_PV_MAJOR}/ongoing/+download/${MARIA_FULL_P}.tar.gz
173 http://mirrors.fe.up.pt/pub/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
174 http://ftp-stud.hs-esslingen.de/pub/Mirrors/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
175 "
144 # The community build is on the mirrors 176 # The community and cluster builds are on the mirrors
145 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then 177 elif [[ "${MYSQL_COMMUNITY_FEATURES}" == "1" || ${PN} == "mysql-cluster" ]] ; then
146 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${MY_PV}.tar.gz" 178 if [[ "${PN}" == "mysql-cluster" ]] ; then
179 URI_DIR="MySQL-Cluster"
180 URI_FILE="mysql-cluster-gpl"
181 else
182 URI_DIR="MySQL"
183 URI_FILE="mysql"
184 fi
185 URI_A="${URI_FILE}-${MY_PV}.tar.gz"
186 MIRROR_PV=$(get_version_component_range 1-2 ${PV})
187 # Recently upstream switched to an archive site, and not on mirrors
188 SERVER_URI="http://downloads.mysql.com/archives/${URI_FILE}-${MIRROR_PV}/${URI_A}
189 mirror://mysql/Downloads/${URI_DIR}-${PV%.*}/${URI_A}"
147 # The (old) enterprise source is on the primary site only 190 # The (old) enterprise source is on the primary site only
148 elif [ "${PN}" == "mysql" ]; then 191 elif [ "${PN}" == "mysql" ]; then
149 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz" 192 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
150 fi 193 fi
151fi 194fi
160 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 203 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
161 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2" 204 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
162 205
163DESCRIPTION="A fast, multi-threaded, multi-user SQL database server." 206DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
164HOMEPAGE="http://www.mysql.com/" 207HOMEPAGE="http://www.mysql.com/"
208if [[ "${PN}" == "mariadb" ]]; then
209 HOMEPAGE="http://askmonty.org/"
210 DESCRIPTION="MariaDB is a MySQL fork with 3rd-party patches and additional storage engines merged."
211fi
212if [[ "${PN}" == "mysql-community" ]]; then
213 DESCRIPTION="${DESCRIPTION} (obsolete, move to dev-db/mysql)"
214fi
165LICENSE="GPL-2" 215LICENSE="GPL-2"
166SLOT="0" 216SLOT="0"
167IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test" 217IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
168 218
169mysql_version_is_at_least "4.1" \ 219mysql_version_is_at_least "4.1" \
170&& IUSE="${IUSE} latin1" 220&& IUSE="${IUSE} latin1"
171 221
172mysql_version_is_at_least "4.1.3" \ 222if mysql_version_is_at_least "4.1.3" ; then
173&& IUSE="${IUSE} cluster extraengine" 223 IUSE="${IUSE} extraengine"
224 if [[ "${PN}" != "mysql-cluster" ]] ; then
225 IUSE="${IUSE} cluster"
226 fi
227fi
174 228
175mysql_version_is_at_least "5.0" \ 229mysql_version_is_at_least "5.0" \
176|| IUSE="${IUSE} raid" 230|| IUSE="${IUSE} raid"
177 231
178mysql_version_is_at_least "5.0.18" \ 232mysql_version_is_at_least "5.0.18" \
182|| IUSE="${IUSE} berkdb" 236|| IUSE="${IUSE} berkdb"
183 237
184[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \ 238[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
185&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling" 239&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
186 240
187# PBXT engine 241[[ "${PN}" == "mariadb" ]] \
242&& IUSE="${IUSE} libevent"
243
244# MariaDB has integrated PBXT
245# PBXT_VERSION means that we have a PBXT patch for this PV
246# PBXT was only introduced after 5.1.12
247pbxt_patch_available() {
248 [[ "${PN}" != "mariadb" ]] \
188mysql_version_is_at_least "5.1.12" \ 249 && mysql_version_is_at_least "5.1.12" \
189&& [[ -n "${PBXT_VERSION}" ]] \ 250 && [[ -n "${PBXT_VERSION}" ]]
251 return $?
252}
253
254pbxt_available() {
255 pbxt_patch_available || [[ "${PN}" == "mariadb" ]]
256 return $?
257}
258
259# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
260# MariaDB has integrated XtraDB
261# XTRADB_VERS means that we have a XTRADB patch for this PV
262# XTRADB was only introduced after 5.1.26
263xtradb_patch_available() {
264 [[ "${PN}" != "mariadb" ]] \
265 && mysql_version_is_at_least "5.1.26" \
266 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]]
267 return $?
268}
269
270
271pbxt_patch_available \
190&& PBXT_P="pbxt-${PBXT_VERSION}" \ 272&& PBXT_P="pbxt-${PBXT_VERSION}" \
191&& PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \ 273&& PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
192&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \ 274&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
275
276# PBXT_NEWSTYLE means pbxt is in storage/ and gets enabled as other plugins
277# vs. built outside the dir
278pbxt_available \
193&& IUSE="${IUSE} pbxt" 279&& IUSE="${IUSE} pbxt" \
194
195# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
196mysql_version_is_at_least "5.1.26" \ 280&& mysql_version_is_at_least "5.1.40" \
197&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \ 281&& PBXT_NEWSTYLE=1
282
283xtradb_patch_available \
198&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \ 284&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
199&& XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \ 285&& XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
200&& XTRADB_SRC_URI1="http://www.percona.com/percona-builds/xtradb/${XTRADB_SRC_URI_COMMON}" \ 286&& XTRADB_SRC_B1="http://www.percona.com/" \
287&& XTRADB_SRC_B2="${XTRADB_SRC_B1}/percona-builds/" \
288&& XTRADB_SRC_URI1="${XTRADB_SRC_B2}/Percona-Server/Percona-Server-${XTRADB_SRC_URI_COMMON}" \
201&& XTRADB_SRC_URI2="http://www.percona.com/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \ 289&& XTRADB_SRC_URI2="${XTRADB_SRC_B2}/xtradb/${XTRADB_SRC_URI_COMMON}" \
290&& XTRADB_SRC_URI3="${XTRADB_SRC_B1}/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
202&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} )" \ 291&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} ${XTRADB_SRC_URI3} )" \
203&& IUSE="${IUSE} xtradb" 292&& IUSE="${IUSE} xtradb"
204 293
205# 294#
206# HELPER FUNCTIONS: 295# HELPER FUNCTIONS:
207# 296#
212mysql_disable_test() { 301mysql_disable_test() {
213 local rawtestname testname testsuite reason mysql_disable_file 302 local rawtestname testname testsuite reason mysql_disable_file
214 rawtestname="${1}" ; shift 303 rawtestname="${1}" ; shift
215 reason="${@}" 304 reason="${@}"
216 ewarn "test '${rawtestname}' disabled: '${reason}'" 305 ewarn "test '${rawtestname}' disabled: '${reason}'"
217 306
218 testsuite="${rawtestname/.*}" 307 testsuite="${rawtestname/.*}"
219 testname="${rawtestname/*.}" 308 testname="${rawtestname/*.}"
220 mysql_disable_file="${S}/mysql-test/t/disabled.def" 309 mysql_disable_file="${S}/mysql-test/t/disabled.def"
221 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}" 310 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
222 echo ${testname} : ${reason} >> "${mysql_disable_file}" 311 echo ${testname} : ${reason} >> "${mysql_disable_file}"
304 MY_DATADIR="${new_MY_DATADIR}" 393 MY_DATADIR="${new_MY_DATADIR}"
305 fi 394 fi
306 fi 395 fi
307 fi 396 fi
308 397
398 if [ "${MY_SOURCEDIR:-unset}" == "unset" ]; then
309 MY_SOURCEDIR=${SERVER_URI##*/} 399 MY_SOURCEDIR=${SERVER_URI##*/}
310 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*} 400 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
401 fi
311 402
312 export MY_SHAREDSTATEDIR MY_SYSCONFDIR 403 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
313 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR 404 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
314 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR 405 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
315} 406}
362 if use debug ; then 453 if use debug ; then
363 myconf="${myconf} --with-debug=full" 454 myconf="${myconf} --with-debug=full"
364 else 455 else
365 myconf="${myconf} --without-debug" 456 myconf="${myconf} --without-debug"
366 mysql_version_is_at_least "4.1.3" \ 457 mysql_version_is_at_least "4.1.3" \
367 && use cluster \ 458 && ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) \
368 && myconf="${myconf} --without-ndb-debug" 459 && myconf="${myconf} --without-ndb-debug"
369 fi 460 fi
370 461
371 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then 462 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
372 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}" 463 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
396 myconf="${myconf} $(use_with perl bench)" 487 myconf="${myconf} $(use_with perl bench)"
397 myconf="${myconf} --enable-assembler" 488 myconf="${myconf} --enable-assembler"
398 myconf="${myconf} --with-extra-tools" 489 myconf="${myconf} --with-extra-tools"
399 myconf="${myconf} --with-innodb" 490 myconf="${myconf} --with-innodb"
400 myconf="${myconf} --without-readline" 491 myconf="${myconf} --without-readline"
492 myconf="${myconf} $(use_with ssl openssl)"
401 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)" 493 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
402 494
403 # --with-vio is not needed anymore, it's on by default and 495 # --with-vio is not needed anymore, it's on by default and
404 # has been removed from configure 496 # has been removed from configure
497 # Apply to 4.x and 5.0.[0-3]
405 if use ssl ; then 498 if use ssl ; then
406 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio" 499 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
407 fi
408
409 if mysql_version_is_at_least "5.1.11" ; then
410 myconf="${myconf} $(use_with ssl /usr)"
411 else
412 myconf="${myconf} $(use_with ssl openssl)"
413 fi 500 fi
414 501
415 if mysql_version_is_at_least "5.0.60" ; then 502 if mysql_version_is_at_least "5.0.60" ; then
416 if use berkdb ; then 503 if use berkdb ; then
417 elog "Berkeley DB support was disabled due to build failures" 504 elog "Berkeley DB support was disabled due to build failures"
433 myconf="${myconf} --without-berkeley-db" 520 myconf="${myconf} --without-berkeley-db"
434 fi 521 fi
435 522
436 if mysql_version_is_at_least "4.1.3" ; then 523 if mysql_version_is_at_least "4.1.3" ; then
437 myconf="${myconf} --with-geometry" 524 myconf="${myconf} --with-geometry"
525 if [[ "${PN}" != "mysql-cluster" ]] ; then
438 myconf="${myconf} $(use_with cluster ndbcluster)" 526 myconf="${myconf} $(use_with cluster ndbcluster)"
527 fi
439 fi 528 fi
440 529
441 if mysql_version_is_at_least "4.1.3" && use extraengine ; then 530 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
442 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html 531 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
443 myconf="${myconf} --with-archive-storage-engine" 532 myconf="${myconf} --with-archive-storage-engine"
474 563
475configure_51() { 564configure_51() {
476 # TODO: !!!! readd --without-readline 565 # TODO: !!!! readd --without-readline
477 # the failure depend upon config/ac-macros/readline.m4 checking into 566 # the failure depend upon config/ac-macros/readline.m4 checking into
478 # readline.h instead of history.h 567 # readline.h instead of history.h
479 myconf="${myconf} $(use_with ssl)" 568 myconf="${myconf} $(use_with ssl ssl /usr)"
480 myconf="${myconf} --enable-assembler" 569 myconf="${myconf} --enable-assembler"
481 myconf="${myconf} --with-geometry" 570 myconf="${myconf} --with-geometry"
482 myconf="${myconf} --with-readline" 571 myconf="${myconf} --with-readline"
483 myconf="${myconf} --with-zlib-dir=/usr/" 572 myconf="${myconf} --with-zlib-dir=/usr/"
484 myconf="${myconf} --without-pstack" 573 myconf="${myconf} --without-pstack"
574 myconf="${myconf} --with-plugindir=/usr/$(get_libdir)/mysql/plugin"
575
576 # This is an explict die here, because if we just forcibly disable it, then the
577 # user's data is not accessible.
578 use max-idx-128 && die "Bug #336027: upstream has a corruption issue with max-idx-128 presently"
485 use max-idx-128 && myconf="${myconf} --with-max-indexes=128" 579 #use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
580 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
581 myconf="${myconf} $(use_enable community community-features)"
582 if use community; then
583 myconf="${myconf} $(use_enable profiling)"
584 else
585 myconf="${myconf} --disable-profiling"
586 fi
587 fi
588
589 # Scan for all available plugins
590 local plugins_avail="$(
591 LANG=C \
592 find "${S}" \
593 \( \
594 -name 'plug.in' \
595 -o -iname 'configure.in' \
596 -o -iname 'configure.ac' \
597 \) \
598 -print0 \
599 | xargs -0 sed -r -n \
600 -e '/^MYSQL_STORAGE_ENGINE/{
601 s~MYSQL_STORAGE_ENGINE\([[:space:]]*\[?([-_a-z0-9]+)\]?.*,~\1 ~g ;
602 s~^([^ ]+).*~\1~gp;
603 }' \
604 | tr -s '\n' ' '
605 )"
486 606
487 # 5.1 introduces a new way to manage storage engines (plugins) 607 # 5.1 introduces a new way to manage storage engines (plugins)
488 # like configuration=none 608 # like configuration=none
609 # This base set are required, and will always be statically built.
489 local plugins="csv,myisam,myisammrg,heap" 610 local plugins_sta="csv myisam myisammrg heap"
611 local plugins_dyn=""
612 local plugins_dis="example ibmdb2i"
613
614 # These aren't actually required by the base set, but are really useful:
615 plugins_sta="${plugins_sta} archive blackhole"
616
617 # default in 5.5.4
618 if mysql_version_is_at_least "5.5.4" ; then
619 plugins_sta="${plugins_sta} partition"
620 fi
621 # Now the extras
490 if use extraengine ; then 622 if use extraengine ; then
491 # like configuration=max-no-ndb, archive and example removed in 5.1.11 623 # like configuration=max-no-ndb, archive and example removed in 5.1.11
492 # not added yet: ibmdb2i 624 # not added yet: ibmdb2i
493 # Not supporting as examples: example,daemon_example,ftexample 625 # Not supporting as examples: example,daemon_example,ftexample
494 plugins="${plugins},archive,blackhole,federated,partition" 626 plugins_sta="${plugins_sta} partition"
627 plugins_dyn="${plugins_sta} federated"
495 628
629 if [[ "${PN}" != "mariadb" ]] ; then
496 elog "Before using the Federated storage engine, please be sure to read" 630 elog "Before using the Federated storage engine, please be sure to read"
497 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 631 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
632 else
633 elog "MariaDB includes the FederatedX engine. Be sure to read"
634 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
635 fi
636 else
637 plugins_dis="${plugins_dis} partition federated"
498 fi 638 fi
499 639
500 # Upstream specifically requests that InnoDB always be built: 640 # Upstream specifically requests that InnoDB always be built:
501 # - innobase, innodb_plugin 641 # - innobase, innodb_plugin
502 # Build falcon if available for 6.x series. 642 # Build falcon if available for 6.x series.
503 for i in innobase innodb_plugin falcon ; do 643 for i in innobase falcon ; do
504 [ -e "${S}"/storage/${i} ] && plugins="${plugins},${i}" 644 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
505 done 645 done
646 for i in innodb_plugin ; do
647 [ -e "${S}"/storage/${i} ] && plugins_dyn="${plugins_dyn} ${i}"
648 done
506 649
507 # like configuration=max-no-ndb 650 # like configuration=max-no-ndb
508 if use cluster ; then 651 if ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) ; then
509 plugins="${plugins},ndbcluster" 652 plugins_sta="${plugins_sta} ndbcluster partition"
653 plugins_dis="${plugins_dis//partition}"
510 myconf="${myconf} --with-ndb-binlog" 654 myconf="${myconf} --with-ndb-binlog"
655 else
656 plugins_dis="${plugins_dis} ndbcluster"
511 fi 657 fi
512 658
659 if [[ "${PN}" == "mariadb" ]] ; then
660 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
661 # caught above.
662 plugins_sta="${plugins_sta} maria"
663
664 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] ||
665 die "The ${P} package doesn't provide innobase nor xtradb"
666
667 for i in innobase xtradb ; do
668 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
669 done
670
671 myconf="${myconf} $(use_with libevent)"
672 # This is not optional, without it several upstream testcases fail.
673 # Also strongly recommended by upstream.
674 myconf="${myconf} --with-maria-tmp-tables"
675 fi
676
677 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then
678 use pbxt \
679 && plugins_dyn="${plugins_dyn} pbxt" \
680 || plugins_dis="${plugins_dis} pbxt"
681 fi
682
683 use static && \
684 plugins_sta="${plugins_sta} ${plugins_dyn}" && \
685 plugins_dyn=""
686
687 einfo "Available plugins: ${plugins_avail}"
688 einfo "Dynamic plugins: ${plugins_dyn}"
689 einfo "Static plugins: ${plugins_sta}"
690 einfo "Disabled plugins: ${plugins_dis}"
691
692 # These are the static plugins
513 myconf="${myconf} --with-plugins=${plugins}" 693 myconf="${myconf} --with-plugins=${plugins_sta// /,}"
514} 694 # And the disabled ones
515 695 for i in ${plugins_dis} ; do
516xtradb_applicable() { 696 myconf="${myconf} --without-plugin-${i}"
517 mysql_version_is_at_least "5.1.26" \ 697 done
518 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
519 && use xtradb
520 return $?
521}
522
523pbxt_applicable() {
524 mysql_version_is_at_least "5.1.12" \
525 && [[ -n "${PBXT_VERSION}" ]] \
526 && use pbxt
527 return $?
528} 698}
529 699
530pbxt_src_configure() { 700pbxt_src_configure() {
531 mysql_init_vars 701 mysql_init_vars
532 702
533 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 703 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
534 704
535 einfo "Reconfiguring dir '${PWD}'" 705 einfo "Reconfiguring dir '${PWD}'"
536 AT_GNUCONF_UPDATE="yes" eautoreconf 706 eautoreconf
537 707
538 local myconf="" 708 local myconf=""
539 myconf="${myconf} --with-mysql=${S} --libdir=${MY_LIBDIR}" 709 myconf="${myconf} --with-mysql=${S} --libdir=/usr/$(get_libdir)"
540 use debug && myconf="${myconf} --with-debug=full" 710 use debug && myconf="${myconf} --with-debug=full"
541 # TODO: is it safe/needed to use econf here ?
542 ./configure ${myconf} || die "Problem configuring PBXT storage engine" 711 econf ${myconf} || die "Problem configuring PBXT storage engine"
543} 712}
544 713
545pbxt_src_compile() { 714pbxt_src_compile() {
715
546 # Be backwards compatible for now 716 # Be backwards compatible for now
547 if [[ $EAPI != 2 ]]; then 717 if [[ $EAPI != 2 ]]; then
548 pbxt_src_configure 718 pbxt_src_configure
549 fi 719 fi
550 # TODO: is it safe/needed to use emake here ? 720 # TODO: is it safe/needed to use emake here ?
579 fi 749 fi
580 fi 750 fi
581 751
582 # Check for USE flag problems in pkg_setup 752 # Check for USE flag problems in pkg_setup
583 if use static && use ssl ; then 753 if use static && use ssl ; then
584 eerror "MySQL does not support being built statically with SSL support enabled!"
585 die "MySQL does not support being built statically with SSL support enabled!" 754 M="MySQL does not support being built statically with SSL support enabled!"
755 eerror "${M}"
756 die "${M}"
757 fi
758
759 if mysql_version_is_at_least "5.1.51" \
760 && ! mysql_version_is_at_least "5.2" \
761 && use debug ; then
762 # Also in package.use.mask
763 die "Bug #344885: Upstream has broken USE=debug for 5.1 series >=5.1.51"
586 fi 764 fi
587 765
588 if ! mysql_version_is_at_least "5.0" \ 766 if ! mysql_version_is_at_least "5.0" \
589 && use raid \ 767 && use raid \
590 && use static ; then 768 && use static ; then
592 eerror "with RAID support enabled." 770 eerror "with RAID support enabled."
593 die "USE flags 'raid' and 'static' conflict!" 771 die "USE flags 'raid' and 'static' conflict!"
594 fi 772 fi
595 773
596 if mysql_version_is_at_least "4.1.3" \ 774 if mysql_version_is_at_least "4.1.3" \
597 && ( use cluster || use extraengine ) \ 775 && ( use cluster || use extraengine || use embedded ) \
598 && use minimal ; then 776 && use minimal ; then
599 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
600 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 777 M="USE flags 'cluster', 'extraengine', 'embedded' conflict with 'minimal' USE flag!"
778 eerror "${M}"
779 die "${M}"
601 fi 780 fi
602 781
603 # Bug #290570 fun. Upstream made us need a fairly new GCC4.
604 if mysql_version_is_at_least "5.0.83" ; then 782 if mysql_version_is_at_least "5.1" \
783 && xtradb_patch_available \
784 && use xtradb \
785 && use embedded ; then
786 M="USE flags 'xtradb' and 'embedded' conflict and cause build failures"
787 eerror "${M}"
788 die "${M}"
789 fi
790
791 # Bug #290570, 284946, 307251
792 # Upstream changes made us need a fairly new GCC4.
793 # But only for 5.0.8[3-6]!
794 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then
605 GCC_VER=$(gcc-version) 795 GCC_VER=$(gcc-version)
606 case ${GCC_VER} in 796 case ${GCC_VER} in
607 2*|3*|4.0|4.1|4.2) die "Active GCC too old! Must have at least GCC4.3" ;; 797 2*|3*|4.0|4.1|4.2)
798 eerror "Some releases of MySQL required a very new GCC, and then"
799 eerror "later release relaxed that requirement again. Either pick a"
800 eerror "MySQL >=5.0.87, or use a newer GCC."
801 die "Active GCC too old!" ;;
608 esac 802 esac
609 fi 803 fi
610 804
611 # This should come after all of the die statements 805 # This should come after all of the die statements
612 enewgroup mysql 60 || die "problem adding 'mysql' group" 806 enewgroup mysql 60 || die "problem adding 'mysql' group"
662 mysql_mv_patches 856 mysql_mv_patches
663 # And apply 857 # And apply
664 epatch 858 epatch
665 859
666 # last -fPIC fixup, per bug #305873 860 # last -fPIC fixup, per bug #305873
667 i="${S}"/storage/innodb_plugin/plug.in 861 i="${S}"/storage/innodb_plugin/plug.in
668 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}" 862 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
669 863
670 # Additional checks, remove bundled zlib 864 # Additional checks, remove bundled zlib (Cluster needs this, for static
865 # memory management in zlib, leave available for Cluster)
866 if [[ "${PN}" != "mysql-cluster" ]] ; then
671 rm -f "${S}/zlib/"*.[ch] 867 rm -f "${S}/zlib/"*.[ch]
672 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 868 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
869 fi
673 rm -f "scripts/mysqlbug" 870 rm -f "scripts/mysqlbug"
674 871
675 # Make charsets install in the right place 872 # Make charsets install in the right place
676 find . -name 'Makefile.am' \ 873 find . -name 'Makefile.am' \
677 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \; 874 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
687 rm -f "scripts/mysqlbug" 884 rm -f "scripts/mysqlbug"
688 fi 885 fi
689 886
690 local rebuilddirlist d 887 local rebuilddirlist d
691 888
692 if xtradb_applicable ; then 889 if xtradb_patch_available && use xtradb ; then
693 einfo "Replacing InnoDB with Percona XtraDB" 890 einfo "Adding storage engine: Percona XtraDB (replacing InnoDB)"
694 pushd "${S}"/storage 891 pushd "${S}"/storage >/dev/null
695 i="innobase" 892 i="innobase"
696 o="${WORKDIR}/storage-${i}.mysql-upstream" 893 o="${WORKDIR}/storage-${i}.mysql-upstream"
697 # Have we been here already? 894 # Have we been here already?
698 [ -d "${o}" ] && rm -f "${i}" 895 [ -d "${o}" ] && rm -f "${i}"
699 # Or maybe we haven't 896 # Or maybe we haven't
700 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}" 897 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
701 cp -ra "${WORKDIR}/${XTRADB_P}" "${i}" 898 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}"
702 popd 899 popd >/dev/null
900 fi
901
902 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then
903 einfo "Adding storage engine: PBXT"
904 pushd "${S}"/storage >/dev/null
905 i='pbxt'
906 [ -d "${i}" ] && rm -rf "${i}"
907 cp -ral "${WORKDIR}/${PBXT_P}" "${i}"
908 popd >/dev/null
703 fi 909 fi
704 910
705 if mysql_version_is_at_least "5.1.12" ; then 911 if mysql_version_is_at_least "5.1.12" ; then
706 rebuilddirlist="." 912 rebuilddirlist="."
707 # This does not seem to be needed presently. robbat2 2010/02/23 913 # This does not seem to be needed presently. robbat2 2010/02/23
716 fi 922 fi
717 923
718 for d in ${rebuilddirlist} ; do 924 for d in ${rebuilddirlist} ; do
719 einfo "Reconfiguring dir '${d}'" 925 einfo "Reconfiguring dir '${d}'"
720 pushd "${d}" &>/dev/null 926 pushd "${d}" &>/dev/null
721 AT_GNUCONF_UPDATE="yes" eautoreconf 927 eautoreconf
722 popd &>/dev/null 928 popd &>/dev/null
723 done 929 done
724 930
725 if mysql_check_version_range "4.1 to 5.0.99.99" \ 931 if mysql_check_version_range "4.1 to 5.0.99.99" \
726 && use berkdb ; then 932 && use berkdb ; then
781 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 987 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
782 export CXXFLAGS 988 export CXXFLAGS
783 989
784 # bug #283926, with GCC4.4, this is required to get correct behavior. 990 # bug #283926, with GCC4.4, this is required to get correct behavior.
785 append-flags -fno-strict-aliasing 991 append-flags -fno-strict-aliasing
992
993 # bug #335185, #335995, with >= GCC4.3.3 on x86 only, omit-frame-pointer
994 # causes a mis-compile.
995 # Upstream bugs:
996 # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38562
997 # http://bugs.mysql.com/bug.php?id=45205
998 use x86 && version_is_at_least "4.3.3" "$(gcc-fullversion)" && \
999 append-flags -fno-omit-frame-pointer && \
1000 filter-flags -fomit-frame-pointer
786 1001
787 econf \ 1002 econf \
788 --libexecdir="/usr/sbin" \ 1003 --libexecdir="/usr/sbin" \
789 --sysconfdir="${MY_SYSCONFDIR}" \ 1004 --sysconfdir="${MY_SYSCONFDIR}" \
790 --localstatedir="${MY_LOCALSTATEDIR}" \ 1005 --localstatedir="${MY_LOCALSTATEDIR}" \
801 # TODO: Move this before autoreconf !!! 1016 # TODO: Move this before autoreconf !!!
802 find . -type f -name Makefile -print0 \ 1017 find . -type f -name Makefile -print0 \
803 | xargs -0 -n100 sed -i \ 1018 | xargs -0 -n100 sed -i \
804 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 1019 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
805 1020
806 if [[ $EAPI == 2 ]]; then 1021 if [[ $EAPI == 2 ]] && [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
807 pbxt_applicable && pbxt_src_configure 1022 pbxt_patch_available && use pbxt && pbxt_src_configure
808 fi 1023 fi
809} 1024}
810 1025
811# @FUNCTION: mysql_src_compile 1026# @FUNCTION: mysql_src_compile
812# @DESCRIPTION: 1027# @DESCRIPTION:
813# Compile the mysql code. 1028# Compile the mysql code.
814mysql_src_compile() { 1029mysql_src_compile() {
815 # Be backwards compatible for now 1030 # Be backwards compatible for now
816 case ${EAPI:-0} in 1031 case ${EAPI:-0} in
817 2) : ;; 1032 2) : ;;
818 0 | 1) mysql_src_configure ;; 1033 0 | 1) mysql_src_configure ;;
819 esac 1034 esac
820 1035
821 emake || die "emake failed" 1036 emake || die "emake failed"
822 1037
823 pbxt_applicable && pbxt_src_compile 1038 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1039 pbxt_patch_available && use pbxt && pbxt_src_compile
1040 fi
824} 1041}
825 1042
826# @FUNCTION: mysql_src_install 1043# @FUNCTION: mysql_src_install
827# @DESCRIPTION: 1044# @DESCRIPTION:
828# Install mysql. 1045# Install mysql.
834 DESTDIR="${D}" \ 1051 DESTDIR="${D}" \
835 benchdir_root="${MY_SHAREDSTATEDIR}" \ 1052 benchdir_root="${MY_SHAREDSTATEDIR}" \
836 testroot="${MY_SHAREDSTATEDIR}" \ 1053 testroot="${MY_SHAREDSTATEDIR}" \
837 || die "emake install failed" 1054 || die "emake install failed"
838 1055
839 pbxt_applicable && pbxt_src_install 1056 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1057 pbxt_patch_available && use pbxt && pbxt_src_install
1058 fi
840 1059
841 # Convenience links 1060 # Convenience links
842 einfo "Making Convenience links for mysqlcheck multi-call binary" 1061 einfo "Making Convenience links for mysqlcheck multi-call binary"
843 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze" 1062 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
844 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair" 1063 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
868 if use !test ; then 1087 if use !test ; then
869 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test 1088 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
870 fi 1089 fi
871 1090
872 # Configuration stuff 1091 # Configuration stuff
873 if mysql_version_is_at_least "4.1" ; then 1092 case ${MYSQL_PV_MAJOR} in
874 mysql_mycnf_version="4.1"
875 else
876 mysql_mycnf_version="4.0" 1093 3*|4.0) mysql_mycnf_version="4.0" ;;
877 fi 1094 4.[1-9]|5.0) mysql_mycnf_version="4.1" ;;
878 einfo "Building default my.cnf" 1095 5.[1-9]|6*|7*) mysql_mycnf_version="5.1" ;;
1096 esac
1097 einfo "Building default my.cnf (${mysql_mycnf_version})"
879 insinto "${MY_SYSCONFDIR}" 1098 insinto "${MY_SYSCONFDIR}"
880 doins scripts/mysqlaccess.conf 1099 doins scripts/mysqlaccess.conf
1100 mycnf_src="my.cnf-${mysql_mycnf_version}"
881 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \ 1101 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
882 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \ 1102 "${FILESDIR}/${mycnf_src}" \
883 > "${TMPDIR}/my.cnf.ok" 1103 > "${TMPDIR}/my.cnf.ok"
884 if mysql_version_is_at_least "4.1" && use latin1 ; then 1104 if use latin1 ; then
885 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok" 1105 sed -i \
1106 -e "/character-set/s|utf8|latin1|g" \
1107 "${TMPDIR}/my.cnf.ok"
886 fi 1108 fi
887 newins "${TMPDIR}/my.cnf.ok" my.cnf 1109 newins "${TMPDIR}/my.cnf.ok" my.cnf
888 1110
889 # Minimal builds don't have the MySQL server 1111 # Minimal builds don't have the MySQL server
890 if ! use minimal ; then 1112 if ! use minimal ; then
966 for script in \ 1188 for script in \
967 support-files/my-*.cnf \ 1189 support-files/my-*.cnf \
968 support-files/magic \ 1190 support-files/magic \
969 support-files/ndb-config-2-node.ini 1191 support-files/ndb-config-2-node.ini
970 do 1192 do
1193 [[ -f "${script}" ]] \
971 dodoc "${script}" 1194 && dodoc "${script}"
972 done 1195 done
973 1196
974 docinto "scripts" 1197 docinto "scripts"
975 for script in scripts/mysql* ; do 1198 for script in scripts/mysql* ; do
1199 [[ -f "${script}" ]] \
976 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1200 && [[ "${script%.sh}" == "${script}" ]] \
1201 && dodoc "${script}"
977 done 1202 done
978 1203
979 einfo 1204 einfo
980 elog "You might want to run:" 1205 elog "You might want to run:"
981 elog "\"emerge --config =${CATEGORY}/${PF}\"" 1206 elog "\"emerge --config =${CATEGORY}/${PF}\""
982 elog "if this is a new install." 1207 elog "if this is a new install."
983 einfo 1208 einfo
984 fi
985 1209
986 if pbxt_applicable ; then 1210 einfo
1211 elog "If you are upgrading major versions, you should run the"
1212 elog "mysql_upgrade tool."
1213 einfo
1214 fi
1215
1216 if pbxt_available && use pbxt ; then
987 # TODO: explain it better 1217 # TODO: explain it better
988 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';" 1218 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
989 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;" 1219 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
990 elog "if, after that, you cannot start the MySQL server," 1220 elog "if, after that, you cannot start the MySQL server,"
991 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then" 1221 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
1042 fi 1272 fi
1043 fi 1273 fi
1044 1274
1045 local pwd1="a" 1275 local pwd1="a"
1046 local pwd2="b" 1276 local pwd2="b"
1277 local MYSQL_ROOT_PASSWORD=''
1047 local maxtry=5 1278 local maxtry=15
1279
1280 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${ROOT}/root/.my.cnf" ]; then
1281 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${ROOT}/root/.my.cnf")"
1282 fi
1048 1283
1049 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then 1284 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
1050 ewarn "You have already a MySQL database in place." 1285 ewarn "You have already a MySQL database in place."
1051 ewarn "(${ROOT}/${MY_DATADIR}/*)" 1286 ewarn "(${ROOT}/${MY_DATADIR}/*)"
1052 ewarn "Please rename or delete it if you wish to replace it." 1287 ewarn "Please rename or delete it if you wish to replace it."
1055 1290
1056 # Bug #213475 - MySQL _will_ object strenously if your machine is named 1291 # Bug #213475 - MySQL _will_ object strenously if your machine is named
1057 # localhost. Also causes weird failures. 1292 # localhost. Also causes weird failures.
1058 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost" 1293 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
1059 1294
1060 einfo "Creating the mysql database and setting proper" 1295 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
1061 einfo "permissions on it ..."
1062 1296
1063 einfo "Insert a password for the mysql 'root' user" 1297 einfo "Please provide a password for the mysql 'root' user now,"
1298 einfo "or in the MYSQL_ROOT_PASSWORD env var."
1064 ewarn "Avoid [\"'\\_%] characters in the password" 1299 ewarn "Avoid [\"'\\_%] characters in the password"
1065 read -rsp " >" pwd1 ; echo 1300 read -rsp " >" pwd1 ; echo
1066 1301
1067 einfo "Retype the password" 1302 einfo "Retype the password"
1068 read -rsp " >" pwd2 ; echo 1303 read -rsp " >" pwd2 ; echo
1069 1304
1070 if [[ "x$pwd1" != "x$pwd2" ]] ; then 1305 if [[ "x$pwd1" != "x$pwd2" ]] ; then
1071 die "Passwords are not the same" 1306 die "Passwords are not the same"
1307 fi
1308 MYSQL_ROOT_PASSWORD="${pwd1}"
1309 unset pwd1 pwd2
1072 fi 1310 fi
1073 1311
1074 local options="" 1312 local options=""
1075 local sqltmp="$(emktemp)" 1313 local sqltmp="$(emktemp)"
1076 1314
1090 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \ 1328 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
1091 || die "MySQL databases not installed" 1329 || die "MySQL databases not installed"
1092 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null 1330 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
1093 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null 1331 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
1094 1332
1333 # Figure out which options we need to disable to do the setup
1334 helpfile="${TMPDIR}/mysqld-help"
1335 ${ROOT}/usr/sbin/mysqld --verbose --help >"${helpfile}" 2>/dev/null
1336 for opt in grant-tables host-cache name-resolve networking slave-start bdb \
1337 federated innodb ssl log-bin relay-log slow-query-log external-locking \
1338 ndbcluster \
1339 ; do
1340 optexp="--(skip-)?${opt}" optfull="--skip-${opt}"
1341 egrep -sq -- "${optexp}" "${helpfile}" && options="${options} ${optfull}"
1342 done
1343 # But some options changed names
1344 egrep -sq external-locking "${helpfile}" && \
1345 options="${options/skip-locking/skip-external-locking}"
1346
1095 if mysql_version_is_at_least "4.1.3" ; then 1347 if mysql_version_is_at_least "4.1.3" ; then
1096 options="--skip-ndbcluster"
1097
1098 # Filling timezones, see 1348 # Filling timezones, see
1099 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html 1349 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
1100 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null 1350 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
1101 1351
1102 if [[ -r "${help_tables}" ]] ; then 1352 if [[ -r "${help_tables}" ]] ; then
1103 cat "${help_tables}" >> "${sqltmp}" 1353 cat "${help_tables}" >> "${sqltmp}"
1104 fi 1354 fi
1105 fi 1355 fi
1356
1357 einfo "Creating the mysql database and setting proper"
1358 einfo "permissions on it ..."
1106 1359
1107 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock" 1360 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock"
1108 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid" 1361 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid"
1109 local mysqld="${ROOT}/usr/sbin/mysqld \ 1362 local mysqld="${ROOT}/usr/sbin/mysqld \
1110 ${options} \ 1363 ${options} \
1111 --user=mysql \ 1364 --user=mysql \
1112 --skip-grant-tables \
1113 --basedir=${ROOT}/usr \ 1365 --basedir=${ROOT}/usr \
1114 --datadir=${ROOT}/${MY_DATADIR} \ 1366 --datadir=${ROOT}/${MY_DATADIR} \
1115 --skip-innodb \
1116 --skip-bdb \
1117 --skip-networking \
1118 --max_allowed_packet=8M \ 1367 --max_allowed_packet=8M \
1119 --net_buffer_length=16K \ 1368 --net_buffer_length=16K \
1369 --default-storage-engine=MyISAM \
1120 --socket=${socket} \ 1370 --socket=${socket} \
1121 --pid-file=${pidfile}" 1371 --pid-file=${pidfile}"
1372 #einfo "About to start mysqld: ${mysqld}"
1373 ebegin "Starting mysqld"
1122 ${mysqld} & 1374 ${mysqld} &
1375 rc=$?
1123 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do 1376 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
1124 maxtry=$((${maxtry}-1)) 1377 maxtry=$((${maxtry}-1))
1125 echo -n "." 1378 echo -n "."
1126 sleep 1 1379 sleep 1
1127 done 1380 done
1381 eend $rc
1128 1382
1383 if ! [[ -S "${socket}" ]]; then
1384 die "Completely failed to start up mysqld with: ${mysqld}"
1385 fi
1386
1387 ebegin "Setting root password"
1129 # Do this from memory, as we don't want clear text passwords in temp files 1388 # Do this from memory, as we don't want clear text passwords in temp files
1130 local sql="UPDATE mysql.user SET Password = PASSWORD('${pwd1}') WHERE USER='root'" 1389 local sql="UPDATE mysql.user SET Password = PASSWORD('${MYSQL_ROOT_PASSWORD}') WHERE USER='root'"
1131 "${ROOT}/usr/bin/mysql" \ 1390 "${ROOT}/usr/bin/mysql" \
1132 --socket=${socket} \ 1391 --socket=${socket} \
1133 -hlocalhost \ 1392 -hlocalhost \
1134 -e "${sql}" 1393 -e "${sql}"
1394 eend $?
1135 1395
1136 einfo "Loading \"zoneinfo\", this step may require a few seconds ..." 1396 ebegin "Loading \"zoneinfo\", this step may require a few seconds ..."
1137
1138 "${ROOT}/usr/bin/mysql" \ 1397 "${ROOT}/usr/bin/mysql" \
1139 --socket=${socket} \ 1398 --socket=${socket} \
1140 -hlocalhost \ 1399 -hlocalhost \
1141 -uroot \ 1400 -uroot \
1142 -p"${pwd1}" \ 1401 -p"${MYSQL_ROOT_PASSWORD}" \
1143 mysql < "${sqltmp}" 1402 mysql < "${sqltmp}"
1403 rc=$?
1404 eend $?
1405 [ $rc -ne 0 ] && ewarn "Failed to load zoneinfo!"
1144 1406
1145 # Stop the server and cleanup 1407 # Stop the server and cleanup
1408 einfo "Stopping the server ..."
1146 kill $(< "${pidfile}" ) 1409 kill $(< "${pidfile}" )
1147 rm -f "${sqltmp}" 1410 rm -f "${sqltmp}"
1148 einfo "Stopping the server ..."
1149 wait %1 1411 wait %1
1150 einfo "Done" 1412 einfo "Done"
1151} 1413}
1152 1414
1153# @FUNCTION: mysql_pkg_postrm 1415# @FUNCTION: mysql_pkg_postrm

Legend:
Removed from v.1.135  
changed lines
  Added in v.1.156

  ViewVC Help
Powered by ViewVC 1.1.20