/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.59 Revision 1.142
1# Copyright 1999-2006 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.59 2007/01/05 00:07:23 vivo Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.142 2010/03/24 20:37:54 robbat2 Exp $
4# kate: encoding utf-8; eol unix;
5# kate: indent-width 4; mixedindent off; remove-trailing-space on; space-indent off;
6# kate: word-wrap-column 80; word-wrap off;
7 4
5# @ECLASS: mysql.eclass
6# @MAINTAINER:
8# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 7# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
8# Maintainers: MySQL Team <mysql-bugs@gentoo.org>
9# Maintainer: Luca Longinotti <chtekk@gentoo.org> 9# - Luca Longinotti <chtekk@gentoo.org>
10# - Robin H. Johnson <robbat2@gentoo.org>
11# @BLURB: This eclass provides most of the functions for mysql ebuilds
12# @DESCRIPTION:
13# The mysql.eclass provides almost all the code to build the mysql ebuilds
14# including the src_unpack, src_prepare, src_configure, src_compile,
15# scr_install, pkg_preinst, pkg_postinst, pkg_config and pkg_postrm
16# phase hooks.
10 17
11# Note that MYSQL_VERSION_ID must be empty !!!
12
13ECLASS="mysql"
14INHERITED="$INHERITED $ECLASS"
15WANT_AUTOCONF="latest" 18WANT_AUTOCONF="latest"
16WANT_AUTOMAKE="latest" 19WANT_AUTOMAKE="latest"
20
17inherit eutils flag-o-matic gnuconfig autotools mysql_fx 21inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator toolchain-funcs
18 22
19# Shorten the path because the socket path length must be shorter than 107 chars 23# Shorten the path because the socket path length must be shorter than 107 chars
20# and we will run a mysql server during test phase 24# and we will run a mysql server during test phase
21S="${WORKDIR}/mysql" 25S="${WORKDIR}/mysql"
22 26
23# avoid running userspace code 8 times per ebuild :(
24if [[ "${_MYPVR}" != "${PVR}" ]] && [[ -n "${PVR}" ]]
25then
26 _MYPVR=${PVR}
27
28 [[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20070105" 27[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z"
29 28if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
30 if [[ ${PR#r} -lt 60 ]] ; then 29 EGIT_PROJECT=mysql-extras
31 IS_BITKEEPER=0 30 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
32 elif [[ ${PR#r} -lt 90 ]] ; then 31 inherit git
33 IS_BITKEEPER=60
34 else
35 IS_BITKEEPER=90
36 fi 32fi
37 33
34case "${EAPI:-0}" in
35 2)
36 EXPORT_FUNCTIONS pkg_setup \
37 src_unpack src_prepare \
38 src_configure src_compile \
39 src_install \
40 pkg_preinst pkg_postinst \
41 pkg_config pkg_postrm
42 IUSE_DEFAULT_ON='+'
43 ;;
44 0 | 1)
45 EXPORT_FUNCTIONS pkg_setup \
46 src_unpack \
47 src_compile \
48 src_install \
49 pkg_preinst pkg_postinst \
50 pkg_config pkg_postrm
51 ;;
52 *)
53 die "Unsupported EAPI: ${EAPI}" ;;
54esac
55
56
57# @ECLASS-VARIABLE: MYSQL_PV_MAJOR
58# @DESCRIPTION:
59# Upstream MySQL considers the first two parts of the version number to be the
60# major version. Upgrades that change major version should always run
61# mysql_upgrade.
62MYSQL_PV_MAJOR="$(get_version_component_range 1-2 ${PV})"
63
64# @ECLASS-VARIABLE: MYSQL_VERSION_ID
65# @DESCRIPTION:
38 # MYSQL_VERSION_ID will be: 66# MYSQL_VERSION_ID will be:
39 # major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 67# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
40 # This is an important part, because many of the choices the MySQL ebuild will do 68# This is an important part, because many of the choices the MySQL ebuild will do
41 # depend on this variable. 69# depend on this variable.
42 # In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803" 70# In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803"
71# We also strip off upstream's trailing letter that they use to respin tarballs
72
43 MYSQL_VERSION_ID="" 73MYSQL_VERSION_ID=""
74tpv="${PV%[a-z]}"
44 tpv=( ${PV//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}" 75tpv=( ${tpv//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}"
45 for vatom in 0 1 2 3 ; do 76for vatom in 0 1 2 3 ; do
46 # pad to length 2 77 # pad to length 2
47 tpv[${vatom}]="00${tpv[${vatom}]}" 78 tpv[${vatom}]="00${tpv[${vatom}]}"
48 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}" 79 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}"
49 done 80done
50 # strip leading "0" (otherwise it's considered an octal number by BASH) 81# strip leading "0" (otherwise it's considered an octal number by BASH)
51 MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"} 82MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"}
52 83
84# @ECLASS-VARIABLE: MYSQL_COMMUNITY_FEATURES
85# @DESCRIPTION:
86# Specifiy if community features are available. Possible values are 1 (yes)
87# and 0 (no).
88# Community features are available in mysql-community
89# AND in the re-merged mysql-5.0.82 and newer
90if [ "${PN}" == "mysql-community" -o "${PN}" == "mariadb" ]; then
91 MYSQL_COMMUNITY_FEATURES=1
92elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
93 MYSQL_COMMUNITY_FEATURES=1
94elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
95 MYSQL_COMMUNITY_FEATURES=1
96elif [ "${PV#5.4}" != "${PV}" ] ; then
97 MYSQL_COMMUNITY_FEATURES=1
98elif [ "${PV#5.5}" != "${PV}" ] ; then
99 MYSQL_COMMUNITY_FEATURES=1
100elif [ "${PV#6.0}" != "${PV}" ] ; then
101 MYSQL_COMMUNITY_FEATURES=1
102else
103 MYSQL_COMMUNITY_FEATURES=0
104fi
105
106# @ECLASS-VARIABLE: XTRADB_VER
107# @DESCRIPTION:
108# Version of the XTRADB storage engine
109XTRADB_VER="${XTRADB_VER}"
110
111# @ECLASS-VARIABLE: PERCONA_VER
112# @DESCRIPTION:
113# Designation by PERCONA for a MySQL version to apply an XTRADB release
114PERCONA_VER="${PERCONA_VER}"
115
53 # Be warned, *DEPEND are version-dependant 116# Be warned, *DEPEND are version-dependant
117# These are used for both runtime and compiletime
54 DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d ) 118DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )
55 userland_GNU? ( sys-process/procps ) 119 userland_GNU? ( sys-process/procps )
56 >=sys-apps/sed-4 120 >=sys-apps/sed-4
57 >=sys-apps/texinfo-4.7-r1 121 >=sys-apps/texinfo-4.7-r1
58 >=sys-libs/readline-4.1 122 >=sys-libs/readline-4.1
59 >=sys-libs/zlib-1.2.3 123 >=sys-libs/zlib-1.2.3"
60 "
61 124
125[[ "${PN}" == "mariadb" ]] \
126&& DEPEND="${DEPEND} libevent? ( >=dev-libs/libevent-1.4 )"
127
62 # having different flavours at the same time is not a good idea 128# Having different flavours at the same time is not a good idea
63 for i in "" "-community" "-slotted" ; do 129for i in "mysql" "mysql-community" "mariadb" ; do
64 [[ "${i}" == ${PN#mysql} ]] || 130 [[ "${i}" == ${PN} ]] ||
65 DEPEND="${DEPEND} !dev-db/mysql${i}" 131 DEPEND="${DEPEND} !dev-db/${i}"
66 done 132done
67 133
134RDEPEND="${DEPEND}
135 !minimal? ( dev-db/mysql-init-scripts )
136 selinux? ( sec-policy/selinux-mysql )"
137
138# compile-time-only
68 mysql_version_is_at_least "5.1" \ 139mysql_version_is_at_least "5.1" \
69 || DEPEND="${DEPEND} berkdb? ( sys-apps/ed )" 140|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
70 141
142# compile-time-only
143mysql_version_is_at_least "5.1.12" \
144&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
145
71 # dev-perl/DBD-mysql is needed by some scripts installed by MySQL 146# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
72 PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 147PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
73 148
74 if mysql_version_is_at_least "5.1.12" ; then 149# For other stuff to bring us in
75 DEPEND="${DEPEND} innodb? ( >=dev-util/cmake-2.4.3 )" 150PDEPEND="${PDEPEND} =virtual/mysql-${MYSQL_PV_MAJOR}"
151
152# Work out the default SERVER_URI correctly
153if [ -z "${SERVER_URI}" ]; then
154 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
155 if [ "${PN}" == "mariadb" ]; then
156 MARIA_FULL_PV="$(replace_version_separator 3 '-' ${PV})"
157 SERVER_URI="http://launchpad.net/maria/${MYSQL_PV_MAJOR}/ongoing/+download/mariadb-${MARIA_FULL_PV}.tar.gz"
158 # The community build is on the mirrors
159 elif [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
160 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${MY_PV}.tar.gz"
161 # The (old) enterprise source is on the primary site only
162 elif [ "${PN}" == "mysql" ]; then
163 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
164 fi
76 fi 165fi
77 166
78 # BitKeeper dependency, compile-time only
79 [[ ${IS_BITKEEPER} -eq 90 ]] && DEPEND="${DEPEND} dev-util/bk_client"
80
81 if [[ ${PN} == "mysql-slotted" ]] ; then
82 DEPEND="${DEPEND} app-admin/eselect-mysql"
83 fi
84
85 if [[ ${PN} == "mysql-slotted" ]] ; then
86 SLOT=""
87 tpv=( ${PV//[-._]/ } )
88 for vatom in 0 1 2 ; do
89 SLOT="${SLOT}${tpv[${vatom}]}_"
90 done
91 #finally SLOT=5_0_24
92 SLOT=${SLOT:0:${#SLOT}-1}
93 else
94 SLOT="0"
95 fi
96
97 # Define correct SRC_URIs 167# Define correct SRC_URIs
98 SRC_URI=" 168SRC_URI="${SERVER_URI}"
99 ${SERVER_URI} 169
170# Gentoo patches to MySQL
171[[ ${MY_EXTRAS_VER} != live ]] \
172&& SRC_URI="${SRC_URI}
173 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
100 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 174 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
101 " 175 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
102 mysql_version_is_at_least "5.1.12" \
103 && [[ -n "${PBXT_VERSION}" ]] \
104 && SRC_URI="${SRC_URI} pbxt? ( mirror://sourceforge/pbxt/pbxt-${PBXT_VERSION}.tar.gz )"
105 176
106 DESCRIPTION="A fast, multi-threaded, multi-user SQL database server." 177DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
107 HOMEPAGE="http://www.mysql.com/" 178HOMEPAGE="http://www.mysql.com/"
179if [[ "${PN}" == "mariadb" ]]; then
180 HOMEPAGE="http://askmonty.org/"
181 DESCRIPTION="MariaDB is a MySQL fork with 3rd-party patches and additional storage engines merged."
182fi
183if [[ "${PN}" == "mysql-community" ]]; then
184 DESCRIPTION="${DESCRIPTION} (obsolete, move to dev-db/mysql)"
185fi
108 LICENSE="GPL-2" 186LICENSE="GPL-2"
187SLOT="0"
109 IUSE="big-tables debug embedded minimal perl selinux ssl static" 188IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
110 RESTRICT="confcache"
111 189
112 mysql_version_is_at_least "4.1" \ 190mysql_version_is_at_least "4.1" \
113 && IUSE="${IUSE} latin1" 191&& IUSE="${IUSE} latin1"
114 192
115 mysql_version_is_at_least "4.1.3" \ 193mysql_version_is_at_least "4.1.3" \
116 && IUSE="${IUSE} cluster extraengine" 194&& IUSE="${IUSE} cluster extraengine"
117 195
118 mysql_version_is_at_least "5.0" \ 196mysql_version_is_at_least "5.0" \
119 || IUSE="${IUSE} raid" 197|| IUSE="${IUSE} raid"
120 198
121 mysql_version_is_at_least "5.0.18" \ 199mysql_version_is_at_least "5.0.18" \
122 && IUSE="${IUSE} max-idx-128" 200&& IUSE="${IUSE} max-idx-128"
123 201
124 mysql_version_is_at_least "5.1" \ 202mysql_version_is_at_least "5.1" \
125 && IUSE="${IUSE} innodb"
126
127 mysql_version_is_at_least "5.1" \
128 || IUSE="${IUSE} berkdb" 203|| IUSE="${IUSE} berkdb"
129 204
205[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
206&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
207
208[[ "${PN}" == "mariadb" ]] \
209&& IUSE="${IUSE} libevent"
210
211# MariaDB has integrated PBXT
212# PBXT_VERSION means that we have a PBXT patch for this PV
213# PBXT was only introduced after 5.1.12
214pbxt_patch_available() {
215 [[ "${PN}" != "mariadb" ]] \
130 mysql_version_is_at_least "5.1.12" \ 216 && mysql_version_is_at_least "5.1.12" \
217 && [[ -n "${PBXT_VERSION}" ]]
218 return $?
219}
220
221pbxt_available() {
222 pbxt_patch_available || [[ "${PN}" == "mariadb" ]]
223 return $?
224}
225
226# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
227# MariaDB has integrated XtraDB
228# XTRADB_VERS means that we have a XTRADB patch for this PV
229# XTRADB was only introduced after 5.1.26
230xtradb_patch_available() {
231 [[ "${PN}" != "mariadb" ]] \
232 && mysql_version_is_at_least "5.1.26" \
233 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]]
234 return $?
235}
236
237pbxt_patch_available \
238&& PBXT_P="pbxt-${PBXT_VERSION}" \
239&& PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
240&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
241
242pbxt_available \
131 && IUSE="${IUSE} pbxt" 243&& IUSE="${IUSE} pbxt"
132 244
133 RDEPEND="${DEPEND} 245xtradb_patch_available \
134 sys-apps/mysql 246&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
135 selinux? ( sec-policy/selinux-mysql ) 247&& XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
136 " 248&& XTRADB_SRC_URI1="http://www.percona.com/percona-builds/xtradb/${XTRADB_SRC_URI_COMMON}" \
137 249&& XTRADB_SRC_URI2="http://www.percona.com/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
138fi # if [[ "${_MYPVR}" != "${PVR}" ]] 250&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} )" \
139 251&& IUSE="${IUSE} xtradb"
140EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst \
141 pkg_postinst pkg_config pkg_postrm
142 252
143# 253#
144# HELPER FUNCTIONS: 254# HELPER FUNCTIONS:
145# 255#
146 256
147bitkeeper_fetch() { 257# @FUNCTION: mysql_disable_test
148 258# @DESCRIPTION:
149 local reposuf 259# Helper function to disable specific tests.
150 if [[ -z "${1}" ]] ; then
151 local tpv
152 tpv=( ${PV//[-._]/ } )
153 reposuf="mysql-${tpv[0]}.${tpv[1]}"
154 else
155 reposuf="${1}"
156 fi
157 einfo "using \"${reposuf}\" repository."
158 local repo_uri="bk://mysql.bkbits.net/${reposuf}"
159 ## -- ebk_store_dir: bitkeeper sources store directory
160 local ebk_store_dir="${PORTAGE_ACTUAL_DISTDIR-${DISTDIR}}/bk-src"
161 ## -- ebk_fetch_cmd: bitkeeper fetch command
162 # always fetch the latest revision, use -r<revision> if a specified revision is wanted
163 # hint: does not work
164 local ebk_fetch_cmd="sfioball"
165 ## -- ebk_update_cmd: bitkeeper update command
166 local ebk_update_cmd="update"
167
168 #addread "/etc/bitkeeper"
169 addwrite "${ebk_store_dir}"
170
171 if [[ ! -d "${ebk_store_dir}" ]]; then
172 debug-print "${FUNCNAME}: initial checkout. creating bitkeeper directory"
173 mkdir -p "${ebk_store_dir}" || die "${EBK}: can't mkdir ${ebk_store_dir}."
174 fi
175
176 pushd "${ebk_store_dir}" || die "${EBK}: can't chdir to ${ebk_store_dir}"
177
178 local wc_path=${reposuf}
179
180 if [[ ! -d "${wc_path}" ]]; then
181 local options="-r+"
182 # first check out
183 einfo "bitkeeper check out start -->"
184 einfo " repository: ${repo_uri}"
185 ${ebk_fetch_cmd} ${options} "${repo_uri}" ${wc_path} \
186 || die "${EBK}: can't fetch from ${repo_uri}."
187 else
188 if [[ ! -d "${wc_path}/BK" ]]; then
189 popd
190 die "Look like ${wc_path} is not a bitkeeper path."
191 fi
192
193 # update working copy
194 einfo "bitkeeper update start -->"
195 einfo " repository: ${repo_uri}"
196
197 ${ebk_update_cmd} "${repo_uri}" "${wc_path}" \
198 || die "BK: can't update from ${repo_uri} to ${wc_path}."
199 fi
200
201 einfo " working copy: ${wc_path}"
202 cd "${wc_path}"
203 rsync -rlpgo --exclude="BK/" . "${S}" || die "BK: can't export to ${S}."
204
205 echo
206 popd
207
208}
209
210mysql_disable_test() { 260mysql_disable_test() {
261 local rawtestname testname testsuite reason mysql_disable_file
211 local testname="${1}" ; shift 262 rawtestname="${1}" ; shift
212 local reason="${@}" 263 reason="${@}"
264 ewarn "test '${rawtestname}' disabled: '${reason}'"
265
266 testsuite="${rawtestname/.*}"
267 testname="${rawtestname/*.}"
213 local mysql_disable_file="${S}/mysql-test/t/disabled.def" 268 mysql_disable_file="${S}/mysql-test/t/disabled.def"
269 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
214 echo ${testname} : ${reason} >> "${mysql_disable_file}" 270 echo ${testname} : ${reason} >> "${mysql_disable_file}"
215 ewarn "test \"${testname}\" disabled because: \"${reason}\""
216}
217 271
272 # ${S}/mysql-tests/t/disabled.def
273 #
274 # ${S}/mysql-tests/suite/federated/disabled.def
275 #
276 # ${S}/mysql-tests/suite/jp/t/disabled.def
277 # ${S}/mysql-tests/suite/ndb/t/disabled.def
278 # ${S}/mysql-tests/suite/rpl/t/disabled.def
279 # ${S}/mysql-tests/suite/parts/t/disabled.def
280 # ${S}/mysql-tests/suite/rpl_ndb/t/disabled.def
281 # ${S}/mysql-tests/suite/ndb_team/t/disabled.def
282 # ${S}/mysql-tests/suite/binlog/t/disabled.def
283 # ${S}/mysql-tests/suite/innodb/t/disabled.def
284 if [ -n "${testsuite}" ]; then
285 for mysql_disable_file in \
286 ${S}/mysql-test/suite/${testsuite}/disabled.def \
287 ${S}/mysql-test/suite/${testsuite}/t/disabled.def \
288 FAILED ; do
289 [ -f "${mysql_disable_file}" ] && break
290 done
291 if [ "${mysql_disabled_file}" != "FAILED" ]; then
292 echo "${testname} : ${reason}" >> "${mysql_disable_file}"
293 else
294 ewarn "Could not find testsuite disabled.def location for ${rawtestname}"
295 fi
296 fi
297}
298
299# @FUNCTION: mysql_init_vars
300# @DESCRIPTION:
218# void mysql_init_vars() 301# void mysql_init_vars()
219#
220# Initialize global variables 302# Initialize global variables
221# 2005-11-19 <vivo@gentoo.org> 303# 2005-11-19 <vivo@gentoo.org>
222
223mysql_init_vars() { 304mysql_init_vars() {
224 if [[ ${SLOT} == "0" ]] ; then
225 MY_SUFFIX=""
226 else
227 MY_SUFFIX=${MY_SUFFIX:-"-${SLOT}"}
228 fi
229 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR:-"/usr/share/mysql${MY_SUFFIX}"} 305 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR="/usr/share/mysql"}
230 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql${MY_SUFFIX}"} 306 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql"}
231 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql${MY_SUFFIX}"} 307 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql"}
232 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql${MY_SUFFIX}"} 308 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql"}
233 MY_LOGDIR=${MY_LOGDIR="/var/log/mysql${MY_SUFFIX}"} 309 MY_LOGDIR=${MY_LOGDIR="/var/log/mysql"}
234 MY_INCLUDEDIR=${MY_INCLUDEDIR="/usr/include/mysql${MY_SUFFIX}"} 310 MY_INCLUDEDIR=${MY_INCLUDEDIR="/usr/include/mysql"}
235 311
236 if [[ -z "${DATADIR}" ]] ; then 312 if [[ -z "${MY_DATADIR}" ]] ; then
237 DATADIR="" 313 MY_DATADIR=""
238 if [[ -f "${MY_SYSCONFDIR}/my.cnf" ]] ; then 314 if [[ -f "${MY_SYSCONFDIR}/my.cnf" ]] ; then
239 DATADIR=`"my_print_defaults${MY_SUFFIX}" mysqld 2>/dev/null \ 315 MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
240 | sed -ne '/datadir/s|^--datadir=||p' \ 316 | sed -ne '/datadir/s|^--datadir=||p' \
241 | tail -n1` 317 | tail -n1`
242 if [[ -z "${DATADIR}" ]] ; then 318 if [[ -z "${MY_DATADIR}" ]] ; then
243 DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" \ 319 MY_DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" \
244 | sed -e 's/.*=\s*//'` 320 | sed -e 's/.*=\s*//' \
321 | tail -n1`
245 fi 322 fi
246 fi 323 fi
247 if [[ -z "${DATADIR}" ]] ; then 324 if [[ -z "${MY_DATADIR}" ]] ; then
248 DATADIR="${MY_LOCALSTATEDIR}" 325 MY_DATADIR="${MY_LOCALSTATEDIR}"
249 einfo "Using default DATADIR" 326 einfo "Using default MY_DATADIR"
250 fi 327 fi
251 elog "MySQL DATADIR is ${DATADIR}" 328 elog "MySQL MY_DATADIR is ${MY_DATADIR}"
252 329
253 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then 330 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then
254 if [[ -e "${DATADIR}" ]] ; then 331 if [[ -e "${MY_DATADIR}" ]] ; then
255 elog "Previous datadir found, it's YOUR job to change" 332 # If you get this and you're wondering about it, see bug #207636
256 elog "ownership and take care of it" 333 elog "MySQL datadir found in ${MY_DATADIR}"
334 elog "A new one will not be created."
257 PREVIOUS_DATADIR="yes" 335 PREVIOUS_DATADIR="yes"
258 else 336 else
259 PREVIOUS_DATADIR="no" 337 PREVIOUS_DATADIR="no"
260 fi 338 fi
261 export PREVIOUS_DATADIR 339 export PREVIOUS_DATADIR
262 fi 340 fi
341 else
342 if [[ ${EBUILD_PHASE} == "config" ]]; then
343 local new_MY_DATADIR
344 new_MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
345 | sed -ne '/datadir/s|^--datadir=||p' \
346 | tail -n1`
347
348 if [[ ( -n "${new_MY_DATADIR}" ) && ( "${new_MY_DATADIR}" != "${MY_DATADIR}" ) ]]; then
349 ewarn "MySQL MY_DATADIR has changed"
350 ewarn "from ${MY_DATADIR}"
351 ewarn "to ${new_MY_DATADIR}"
352 MY_DATADIR="${new_MY_DATADIR}"
353 fi
354 fi
263 fi 355 fi
264 356
265 MY_SOURCEDIR=${SERVER_URI##*/} 357 MY_SOURCEDIR=${SERVER_URI##*/}
266 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*} 358 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
267 359
268 export MY_SUFFIX MY_SHAREDSTATEDIR MY_SYSCONFDIR 360 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
269 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR 361 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
270 export MY_INCLUDEDIR DATADIR MY_SOURCEDIR 362 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
271} 363}
272 364
273configure_minimal() { 365configure_minimal() {
274 # These are things we exclude from a minimal build, please 366 # These are things we exclude from a minimal build, please
275 # note that the server actually does get built and installed, 367 # note that the server actually does get built and installed,
276 # but we then delete it before packaging. 368 # but we then delete it before packaging.
277 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication" 369 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication readline"
278 370
279 for i in ${minimal_exclude_list} ; do 371 for i in ${minimal_exclude_list} ; do
280 myconf="${myconf} --without-${i}" 372 myconf="${myconf} --without-${i}"
281 done 373 done
282 myconf="${myconf} --with-extra-charsets=none" 374 myconf="${myconf} --with-extra-charsets=none"
283 myconf="${myconf} --enable-local-infile" 375 myconf="${myconf} --enable-local-infile"
284 376
285 if useq "static" ; then 377 if use static ; then
286 myconf="${myconf} --with-client-ldflags=-all-static" 378 myconf="${myconf} --with-client-ldflags=-all-static"
287 myconf="${myconf} --disable-shared" 379 myconf="${myconf} --disable-shared --with-pic"
288 else 380 else
289 myconf="${myconf} --enable-shared --enable-static" 381 myconf="${myconf} --enable-shared --enable-static"
290 fi 382 fi
291 383
292 if mysql_version_is_at_least "4.01.00.00" && ! useq "latin1" ; then 384 if mysql_version_is_at_least "4.1" && ! use latin1 ; then
293 myconf="${myconf} --with-charset=utf8" 385 myconf="${myconf} --with-charset=utf8"
294 myconf="${myconf} --with-collation=utf8_general_ci" 386 myconf="${myconf} --with-collation=utf8_general_ci"
295 else 387 else
296 myconf="${myconf} --with-charset=latin1" 388 myconf="${myconf} --with-charset=latin1"
297 myconf="${myconf} --with-collation=latin1_swedish_ci" 389 myconf="${myconf} --with-collation=latin1_swedish_ci"
305 myconf="${myconf} --with-mysqld-user=mysql" 397 myconf="${myconf} --with-mysqld-user=mysql"
306 myconf="${myconf} --with-server" 398 myconf="${myconf} --with-server"
307 myconf="${myconf} --with-unix-socket-path=/var/run/mysqld/mysqld.sock" 399 myconf="${myconf} --with-unix-socket-path=/var/run/mysqld/mysqld.sock"
308 myconf="${myconf} --without-libwrap" 400 myconf="${myconf} --without-libwrap"
309 401
310 if useq "static" ; then 402 if use static ; then
311 myconf="${myconf} --with-mysqld-ldflags=-all-static" 403 myconf="${myconf} --with-mysqld-ldflags=-all-static"
312 myconf="${myconf} --with-client-ldflags=-all-static" 404 myconf="${myconf} --with-client-ldflags=-all-static"
313 myconf="${myconf} --disable-shared" 405 myconf="${myconf} --disable-shared --with-pic"
314 else 406 else
315 myconf="${myconf} --enable-shared --enable-static" 407 myconf="${myconf} --enable-shared --enable-static"
316 fi 408 fi
317 409
318 if useq "debug" ; then 410 if use debug ; then
319 myconf="${myconf} --with-debug=full" 411 myconf="${myconf} --with-debug=full"
320 else 412 else
321 myconf="${myconf} --without-debug" 413 myconf="${myconf} --without-debug"
322 mysql_version_is_at_least "4.1.3" \ 414 mysql_version_is_at_least "4.1.3" \
323 && useq "cluster" \ 415 && use cluster \
324 && myconf="${myconf} --without-ndb-debug" 416 && myconf="${myconf} --without-ndb-debug"
325 fi 417 fi
326 418
419 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
420 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
421 ewarn "and a collation of ${MYSQL_DEFAULT_COLLATION}."
422 ewarn "You MUST file bugs without these variables set."
423 myconf="${myconf} --with-charset=${MYSQL_DEFAULT_CHARSET}"
424 myconf="${myconf} --with-collation=${MYSQL_DEFAULT_COLLATION}"
327 if mysql_version_is_at_least "4.1" && ! useq "latin1" ; then 425 elif mysql_version_is_at_least "4.1" && ! use latin1 ; then
328 myconf="${myconf} --with-charset=utf8" 426 myconf="${myconf} --with-charset=utf8"
329 myconf="${myconf} --with-collation=utf8_general_ci" 427 myconf="${myconf} --with-collation=utf8_general_ci"
330 else 428 else
331 myconf="${myconf} --with-charset=latin1" 429 myconf="${myconf} --with-charset=latin1"
332 myconf="${myconf} --with-collation=latin1_swedish_ci" 430 myconf="${myconf} --with-collation=latin1_swedish_ci"
333 fi 431 fi
334 432
335 if useq "embedded" ; then 433 if use embedded ; then
336 myconf="${myconf} --with-embedded-privilege-control" 434 myconf="${myconf} --with-embedded-privilege-control"
337 myconf="${myconf} --with-embedded-server" 435 myconf="${myconf} --with-embedded-server"
338 else 436 else
339 myconf="${myconf} --without-embedded-privilege-control" 437 myconf="${myconf} --without-embedded-privilege-control"
340 myconf="${myconf} --without-embedded-server" 438 myconf="${myconf} --without-embedded-server"
346 myconf="${myconf} $(use_with perl bench)" 444 myconf="${myconf} $(use_with perl bench)"
347 myconf="${myconf} --enable-assembler" 445 myconf="${myconf} --enable-assembler"
348 myconf="${myconf} --with-extra-tools" 446 myconf="${myconf} --with-extra-tools"
349 myconf="${myconf} --with-innodb" 447 myconf="${myconf} --with-innodb"
350 myconf="${myconf} --without-readline" 448 myconf="${myconf} --without-readline"
449 myconf="${myconf} $(use_with ssl openssl)"
351 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)" 450 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
352 451
353 if useq "ssl" ; then
354 # --with-vio is not needed anymore, it's on by default and 452 # --with-vio is not needed anymore, it's on by default and
355 # has been removed from configure 453 # has been removed from configure
454 # Apply to 4.x and 5.0.[0-3]
455 if use ssl ; then
356 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio" 456 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
457 fi
458
357 if mysql_version_is_at_least "5.0.6" ; then 459 if mysql_version_is_at_least "5.0.60" ; then
358 # myconf="${myconf} --with-yassl" 460 if use berkdb ; then
461 elog "Berkeley DB support was disabled due to build failures"
462 elog "on multiple arches, go to a version earlier than 5.0.60"
463 elog "if you want it again. Gentoo bug #224067."
464 fi
359 myconf="${myconf} --with-ssl" 465 myconf="${myconf} --without-berkeley-db"
466 elif use berkdb ; then
467 # The following fix is due to a bug with bdb on SPARC's. See:
468 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
469 # It comes down to non-64-bit safety problems.
470 if use alpha || use amd64 || use hppa || use mips || use sparc ; then
471 elog "Berkeley DB support was disabled due to compatibility issues on this arch"
472 myconf="${myconf} --without-berkeley-db"
360 else 473 else
361 myconf="${myconf} --with-openssl" 474 myconf="${myconf} --with-berkeley-db=./bdb"
362 fi 475 fi
363 else 476 else
364 myconf="${myconf} --without-openssl"
365 fi
366
367 # The following fix is due to a bug with bdb on SPARC's. See:
368 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
369 # It comes down to non-64-bit safety problems.
370 if useq "sparc" || useq "alpha" || useq "hppa" || useq "mips" || useq "amd64" ; then
371 elog "Berkeley DB support was disabled due to incompatible arch"
372 myconf="${myconf} --without-berkeley-db" 477 myconf="${myconf} --without-berkeley-db"
373 else
374 if useq "berkdb" ; then
375 myconf="${myconf} --with-berkeley-db=./bdb"
376 else
377 myconf="${myconf} --without-berkeley-db"
378 fi
379 fi 478 fi
380 479
381 if mysql_version_is_at_least "4.1.3" ; then 480 if mysql_version_is_at_least "4.1.3" ; then
382 myconf="${myconf} --with-geometry" 481 myconf="${myconf} --with-geometry"
383 myconf="${myconf} $(use_with cluster ndbcluster)" 482 myconf="${myconf} $(use_with cluster ndbcluster)"
384 fi 483 fi
385 484
386 if mysql_version_is_at_least "4.1.3" && useq "extraengine" ; then 485 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
387 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html 486 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
388 myconf="${myconf} --with-archive-storage-engine" 487 myconf="${myconf} --with-archive-storage-engine"
389 488
390 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html 489 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
391 myconf="${myconf} --with-csv-storage-engine" 490 myconf="${myconf} --with-csv-storage-engine"
401 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html" 500 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html"
402 myconf="${myconf} --with-federated-storage-engine" 501 myconf="${myconf} --with-federated-storage-engine"
403 fi 502 fi
404 fi 503 fi
405 504
505 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
506 myconf="${myconf} `use_enable community community-features`"
507 if use community; then
508 myconf="${myconf} `use_enable profiling`"
509 else
510 myconf="${myconf} --disable-profiling"
511 fi
512 fi
513
406 mysql_version_is_at_least "5.0.18" \ 514 mysql_version_is_at_least "5.0.18" \
407 && useq "max-idx-128" \ 515 && use max-idx-128 \
408 && myconf="${myconf} --with-max-indexes=128" 516 && myconf="${myconf} --with-max-indexes=128"
409} 517}
410 518
411configure_51() { 519configure_51() {
412 # TODO: !!!! readd --without-readline 520 # TODO: !!!! readd --without-readline
413 # the failure depend upon config/ac-macros/readline.m4 checking into 521 # the failure depend upon config/ac-macros/readline.m4 checking into
414 # readline.h instead of history.h 522 # readline.h instead of history.h
415 myconf="${myconf} $(use_with ssl)" 523 myconf="${myconf} $(use_with ssl ssl /usr)"
416 myconf="${myconf} --enable-assembler" 524 myconf="${myconf} --enable-assembler"
417 myconf="${myconf} --with-geometry" 525 myconf="${myconf} --with-geometry"
418 myconf="${myconf} --with-readline" 526 myconf="${myconf} --with-readline"
419 myconf="${myconf} --with-row-based-replication"
420 myconf="${myconf} --with-zlib=/usr/$(get_libdir)" 527 myconf="${myconf} --with-zlib-dir=/usr/"
421 myconf="${myconf} --without-pstack" 528 myconf="${myconf} --without-pstack"
422 useq "max-idx-128" && myconf="${myconf} --with-max-indexes=128" 529 use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
530 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
531 myconf="${myconf} $(use_enable community community-features)"
532 if use community; then
533 myconf="${myconf} $(use_enable profiling)"
534 else
535 myconf="${myconf} --disable-profiling"
536 fi
537 fi
423 538
424 # 5.1 introduces a new way to manage storage engines (plugins) 539 # 5.1 introduces a new way to manage storage engines (plugins)
425 # like configuration=none 540 # like configuration=none
541 # This base set are required, and will always be statically built.
426 local plugins="csv,myisam,myisammrg,heap" 542 local plugins="csv,myisam,myisammrg,heap"
427 if useq "extraengine" ; then 543 if use extraengine ; then
428 # like configuration=max-no-ndb, archive and example removed in 5.1.11 544 # like configuration=max-no-ndb, archive and example removed in 5.1.11
545 # not added yet: ibmdb2i
546 # Not supporting as examples: example,daemon_example,ftexample
429 plugins="${plugins},archive,blackhole,example,federated,partition" 547 plugins="${plugins},archive,blackhole,federated,partition"
430 548
549 if [[ "${PN}" != "mariadb" ]] ; then
431 elog "Before using the Federated storage engine, please be sure to read" 550 elog "Before using the Federated storage engine, please be sure to read"
432 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 551 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
552 else
553 elog "MariaDB includes the FederatedX engine. Be sure to read"
554 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
433 fi 555 fi
434
435 if useq "innodb" ; then
436 plugins="${plugins},innobase"
437 fi 556 fi
557
558 # Upstream specifically requests that InnoDB always be built:
559 # - innobase, innodb_plugin
560 # Build falcon if available for 6.x series.
561 for i in innobase innodb_plugin falcon ; do
562 [ -e "${S}"/storage/${i} ] && plugins="${plugins},${i}"
563 done
438 564
439 # like configuration=max-no-ndb 565 # like configuration=max-no-ndb
440 if useq "cluster" ; then 566 if use cluster ; then
441 plugins="${plugins},ndbcluster" 567 plugins="${plugins},ndbcluster"
442 myconf="${myconf} --with-ndb-binlog" 568 myconf="${myconf} --with-ndb-binlog"
443 fi 569 fi
444 570
445 if mysql_version_is_at_least "5.2" ; then 571 if [[ "${PN}" == "mariadb" ]] ; then
572 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
573 # caught above.
574 plugins="${plugins},maria,innobase"
575 if use pbxt ; then
446 plugins="${plugins},falcon" 576 plugins="${plugins},pbxt"
577 else
578 myconf="${myconf} --without-plugin-pbxt"
579 fi
580 myconf="${myconf} $(use_with libevent)"
581 # This is not optional, without it several upstream testcases fail.
582 # Also strongly recommended by upstream.
583 myconf="${myconf} --with-maria-tmp-tables"
447 fi 584 fi
448 585
449 myconf="${myconf} --with-plugins=${plugins}" 586 myconf="${myconf} --with-plugins=${plugins}"
450} 587}
451 588
452pbxt_src_compile() { 589pbxt_src_configure() {
453 mysql_init_vars 590 mysql_init_vars
454 591
455 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 592 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
456 593
457 einfo "Reconfiguring dir '${PWD}'" 594 einfo "Reconfiguring dir '${PWD}'"
458 AT_GNUCONF_UPDATE="yes" eautoreconf 595 AT_GNUCONF_UPDATE="yes" eautoreconf
459 596
460 local myconf 597 local myconf=""
461 myconf="${myconf} --with-mysql=${S}" 598 myconf="${myconf} --with-mysql=${S} --libdir=/usr/$(get_libdir)"
462 mkdir -p ${T}/lib
463 myconf="${myconf} --libdir=${D}/${MY_LIBDIR}"
464 useq "debug" && myconf="${myconf} --with-debug=full" 599 use debug && myconf="${myconf} --with-debug=full"
465 # TODO is safe/needed to use econf here ?
466 ./configure ${myconf} || die "problem configuring pbxt storage engine" 600 econf ${myconf} || die "Problem configuring PBXT storage engine"
601}
602
603pbxt_src_compile() {
604 # Be backwards compatible for now
605 if [[ $EAPI != 2 ]]; then
606 pbxt_src_configure
607 fi
467 # TODO is safe/needed to use emake here ? 608 # TODO: is it safe/needed to use emake here ?
468 make || die "problem making pbxt storage engine (${myconf})" 609 make || die "Problem making PBXT storage engine (${myconf})"
469 610
470 popd 611 popd
471 # TODO: modify test suite 612 # TODO: modify test suite for PBXT
472} 613}
473 614
474pbxt_src_install() { 615pbxt_src_install() {
475 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 616 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
476 make install || die "failed pbxt install" 617 emake install DESTDIR="${D}" || die "Failed to install PBXT"
477 popd 618 popd
478} 619}
479 620
480# 621#
481# EBUILD FUNCTIONS 622# EBUILD FUNCTIONS
482# 623#
483 624# @FUNCTION: mysql_pkg_setup
625# @DESCRIPTION:
626# Perform some basic tests and tasks during pkg_setup phase:
627# die if FEATURES="test", USE="-minimal" and not using FEATURES="userpriv"
628# check for conflicting use flags
629# create new user and group for mysql
630# warn about deprecated features
484mysql_pkg_setup() { 631mysql_pkg_setup() {
485 enewgroup mysql 60 || die "problem adding 'mysql' group" 632 if hasq test ${FEATURES} ; then
486 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 633 if ! use minimal ; then
634 if [[ $UID -eq 0 ]]; then
635 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
636 fi
637 fi
638 fi
487 639
488 # Check for USE flag problems in pkg_setup 640 # Check for USE flag problems in pkg_setup
489 if useq "static" && useq "ssl" ; then 641 if use static && use ssl ; then
490 eerror "MySQL does not support being built statically with SSL support enabled!" 642 eerror "MySQL does not support being built statically with SSL support enabled!"
491 die "MySQL does not support being built statically with SSL support enabled!" 643 die "MySQL does not support being built statically with SSL support enabled!"
492 fi 644 fi
493 645
494 if ! mysql_version_is_at_least "5.0" \ 646 if ! mysql_version_is_at_least "5.0" \
495 && useq "raid" \ 647 && use raid \
496 && useq "static" ; then 648 && use static ; then
497 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically" 649 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically"
498 eerror "with RAID support enabled." 650 eerror "with RAID support enabled."
499 die "USE flags 'raid' and 'static' conflict!" 651 die "USE flags 'raid' and 'static' conflict!"
500 fi 652 fi
501 653
502 if mysql_version_is_at_least "4.1.3" \ 654 if mysql_version_is_at_least "4.1.3" \
503 && ( useq "cluster" || useq "extraengine" ) \ 655 && ( use cluster || use extraengine ) \
504 && useq "minimal" ; then 656 && use minimal ; then
505 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 657 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
506 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 658 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
507 fi 659 fi
508 660
661 # Bug #290570 fun. Upstream made us need a fairly new GCC4.
662 if mysql_version_is_at_least "5.0.83" ; then
663 GCC_VER=$(gcc-version)
664 case ${GCC_VER} in
665 2*|3*|4.0|4.1|4.2) die "Active GCC too old! Must have at least GCC4.3" ;;
666 esac
667 fi
668
669 # This should come after all of the die statements
670 enewgroup mysql 60 || die "problem adding 'mysql' group"
671 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
672
509 mysql_check_version_range "4.0 to 5.0.99.99" \ 673 mysql_check_version_range "4.0 to 5.0.99.99" \
510 && useq "berkdb" \ 674 && use berkdb \
511 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 675 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
512}
513 676
677 if [ "${PN}" != "mysql-cluster" ] && use cluster; then
678 ewarn "Upstream has noted that the NDB cluster support in the 5.0 and"
679 ewarn "5.1 series should NOT be put into production. In the near"
680 ewarn "future, it will be disabled from building."
681 ewarn ""
682 ewarn "If you need NDB support, you should instead move to the new"
683 ewarn "mysql-cluster package that represents that upstream NDB"
684 ewarn "development."
685 fi
686}
687
688# @FUNCTION: mysql_src_unpack
689# @DESCRIPTION:
690# Unpack the source code and call mysql_src_prepare for EAPI < 2.
514mysql_src_unpack() { 691mysql_src_unpack() {
515 # Initialize the proper variables first 692 # Initialize the proper variables first
516 mysql_init_vars 693 mysql_init_vars
517 694
518 unpack ${A} 695 unpack ${A}
519 if [[ ${IS_BITKEEPER} -eq 90 ]] ; then 696 # Grab the patches
520 if mysql_check_version_range "5.1 to 5.1.99" ; then 697 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack
521 bitkeeper_fetch "mysql-5.1-ndb" 698
522 elif mysql_check_version_range "5.2.0 to 5.2.99" ; then
523 bitkeeper_fetch "mysql-5.2-falcon"
524 else
525 bitkeeper_fetch
526 fi
527 cd "${S}"
528 einfo "running upstream autorun on bk sources"
529 BUILD/autorun.sh
530 else
531 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}" 699 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}"
700
701 # Be backwards compatible for now
702 case ${EAPI:-0} in
703 2) : ;;
704 0 | 1) mysql_src_prepare ;;
705 esac
706}
707
708# @FUNCTION: mysql_src_prepare
709# @DESCRIPTION:
710# Apply patches to the source code and remove unneeded bundled libs.
711mysql_src_prepare() {
532 cd "${S}" 712 cd "${S}"
533 fi
534 713
535 # Apply the patches for this MySQL version 714 # Apply the patches for this MySQL version
536 EPATCH_SUFFIX="patch" 715 EPATCH_SUFFIX="patch"
537 mkdir -p "${EPATCH_SOURCE}" || die "unable to create epatch directory" 716 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory"
717 # Clean out old items
718 rm -f "${EPATCH_SOURCE}"/*
719 # Now link in right patches
538 mysql_mv_patches 720 mysql_mv_patches
539 epatch || die "failed to apply all patches" 721 # And apply
722 epatch
723
724 # last -fPIC fixup, per bug #305873
725 i="${S}"/storage/innodb_plugin/plug.in
726 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
540 727
541 # Additional checks, remove bundled zlib 728 # Additional checks, remove bundled zlib
542 rm -f "${S}/zlib/"*.[ch] 729 rm -f "${S}/zlib/"*.[ch]
543 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 730 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
544 rm -f "scripts/mysqlbug" 731 rm -f "scripts/mysqlbug"
547 find . -name 'Makefile.am' \ 734 find . -name 'Makefile.am' \
548 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \; 735 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
549 736
550 if mysql_version_is_at_least "4.1" ; then 737 if mysql_version_is_at_least "4.1" ; then
551 # Remove what needs to be recreated, so we're sure it's actually done 738 # Remove what needs to be recreated, so we're sure it's actually done
739 einfo "Cleaning up old buildscript files"
552 find . -name Makefile \ 740 find . -name Makefile \
553 -o -name Makefile.in \ 741 -o -name Makefile.in \
554 -o -name configure \ 742 -o -name configure \
555 -exec rm -f {} \; 743 -exec rm -f {} \;
556 rm -f "ltmain.sh" 744 rm -f "ltmain.sh"
557 rm -f "scripts/mysqlbug" 745 rm -f "scripts/mysqlbug"
558 fi 746 fi
559 747
560 local rebuilddirlist d 748 local rebuilddirlist d
561 749
750 if xtradb_patch_available && use xtradb ; then
751 einfo "Replacing InnoDB with Percona XtraDB"
752 pushd "${S}"/storage
753 i="innobase"
754 o="${WORKDIR}/storage-${i}.mysql-upstream"
755 # Have we been here already?
756 [ -d "${o}" ] && rm -f "${i}"
757 # Or maybe we haven't
758 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
759 cp -ra "${WORKDIR}/${XTRADB_P}" "${i}"
760 popd
761 fi
762
562 if mysql_version_is_at_least "5.1.12" ; then 763 if mysql_version_is_at_least "5.1.12" ; then
563 rebuilddirlist="." 764 rebuilddirlist="."
765 # This does not seem to be needed presently. robbat2 2010/02/23
766 #einfo "Updating innobase cmake"
564 # TODO IMPO! Check this with a cmake expert 767 ## TODO: check this with a cmake expert
565 useq "innodb" \
566 && cmake \ 768 #cmake \
567 -DCMAKE_C_COMPILER=$(which $(tc-getCC)) \ 769 # -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
568 -DCMAKE_CXX_COMPILER=$(which $(tc-getCC)) \ 770 # -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
569 "storage/innobase" 771 # "storage/innobase"
570 else 772 else
571 rebuilddirlist=". innobase" 773 rebuilddirlist=". innobase"
572 fi 774 fi
573 775
574 for d in ${rebuilddirlist} ; do 776 for d in ${rebuilddirlist} ; do
577 AT_GNUCONF_UPDATE="yes" eautoreconf 779 AT_GNUCONF_UPDATE="yes" eautoreconf
578 popd &>/dev/null 780 popd &>/dev/null
579 done 781 done
580 782
581 if mysql_check_version_range "4.1 to 5.0.99.99" \ 783 if mysql_check_version_range "4.1 to 5.0.99.99" \
582 && useq "berkdb" ; then 784 && use berkdb ; then
785 einfo "Fixing up berkdb buildsystem"
583 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh" 786 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
787 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
788 || die "Could not copy libtool.m4 to bdb/dist/"
789 #These files exist only with libtool-2*, and need to be included.
790 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then
791 cat "/usr/share/aclocal/ltsugar.m4" >> "bdb/dist/aclocal/libtool.ac"
792 cat "/usr/share/aclocal/ltversion.m4" >> "bdb/dist/aclocal/libtool.ac"
793 cat "/usr/share/aclocal/lt~obsolete.m4" >> "bdb/dist/aclocal/libtool.ac"
794 cat "/usr/share/aclocal/ltoptions.m4" >> "bdb/dist/aclocal/libtool.ac"
795 fi
584 pushd "bdb/dist" \ 796 pushd "bdb/dist" &>/dev/null
585 && sh s_all \ 797 sh s_all \
586 || die "Failed bdb reconfigure" \ 798 || die "Failed bdb reconfigure"
587 &>/dev/null
588 popd &>/dev/null 799 popd &>/dev/null
589 fi 800 fi
590} 801}
591 802
803# @FUNCTION: mysql_src_configure
804# @DESCRIPTION:
805# Configure mysql to build the code for Gentoo respecting the use flags.
592mysql_src_compile() { 806mysql_src_configure() {
593 # Make sure the vars are correctly initialized 807 # Make sure the vars are correctly initialized
594 mysql_init_vars 808 mysql_init_vars
595 809
596 # $myconf is modified by the configure_* functions 810 # $myconf is modified by the configure_* functions
597 local myconf="" 811 local myconf=""
598 812
599 if useq "minimal" ; then 813 if use minimal ; then
600 configure_minimal 814 configure_minimal
601 else 815 else
602 configure_common 816 configure_common
603 if mysql_version_is_at_least "5.1.10" ; then 817 if mysql_version_is_at_least "5.1.10" ; then
604 configure_51 818 configure_51
611 filter-flags "-O" "-O[01]" 825 filter-flags "-O" "-O[01]"
612 826
613 # glib-2.3.2_pre fix, bug #16496 827 # glib-2.3.2_pre fix, bug #16496
614 append-flags "-DHAVE_ERRNO_AS_DEFINE=1" 828 append-flags "-DHAVE_ERRNO_AS_DEFINE=1"
615 829
830 # As discovered by bug #246652, doing a double-level of SSP causes NDB to
831 # fail badly during cluster startup.
832 if [[ $(gcc-major-version) -lt 4 ]]; then
833 filter-flags "-fstack-protector-all"
834 fi
835
616 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing" 836 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing"
617 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti" 837 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti"
618 mysql_version_is_at_least "5.0" \ 838 mysql_version_is_at_least "5.0" \
619 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 839 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
620 export CXXFLAGS 840 export CXXFLAGS
621 841
842 # bug #283926, with GCC4.4, this is required to get correct behavior.
843 append-flags -fno-strict-aliasing
844
622 econf \ 845 econf \
623 --program-suffix="${MY_SUFFIX}" \
624 --libexecdir="/usr/sbin" \ 846 --libexecdir="/usr/sbin" \
625 --sysconfdir="${MY_SYSCONFDIR}" \ 847 --sysconfdir="${MY_SYSCONFDIR}" \
626 --localstatedir="${MY_LOCALSTATEDIR}" \ 848 --localstatedir="${MY_LOCALSTATEDIR}" \
627 --sharedstatedir="${MY_SHAREDSTATEDIR}" \ 849 --sharedstatedir="${MY_SHAREDSTATEDIR}" \
628 --libdir="${MY_LIBDIR}" \ 850 --libdir="${MY_LIBDIR}" \
637 # TODO: Move this before autoreconf !!! 859 # TODO: Move this before autoreconf !!!
638 find . -type f -name Makefile -print0 \ 860 find . -type f -name Makefile -print0 \
639 | xargs -0 -n100 sed -i \ 861 | xargs -0 -n100 sed -i \
640 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 862 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
641 863
864 if [[ $EAPI == 2 ]]; then
865 pbxt_patch_available && use pbxt && pbxt_src_configure
866 fi
867}
868
869# @FUNCTION: mysql_src_compile
870# @DESCRIPTION:
871# Compile the mysql code.
872mysql_src_compile() {
873 # Be backwards compatible for now
874 case ${EAPI:-0} in
875 2) : ;;
876 0 | 1) mysql_src_configure ;;
877 esac
878
642 emake || die "emake failed" 879 emake || die "emake failed"
643 880
644 mysql_version_is_at_least "5.1.1" && useq "pbxt" && pbxt_src_compile 881 pbxt_patch_available && use pbxt && pbxt_src_compile
645} 882}
646 883
884# @FUNCTION: mysql_src_install
885# @DESCRIPTION:
886# Install mysql.
647mysql_src_install() { 887mysql_src_install() {
648 # Make sure the vars are correctly initialized 888 # Make sure the vars are correctly initialized
649 mysql_init_vars 889 mysql_init_vars
650 890
651 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die 891 emake install \
892 DESTDIR="${D}" \
893 benchdir_root="${MY_SHAREDSTATEDIR}" \
894 testroot="${MY_SHAREDSTATEDIR}" \
895 || die "emake install failed"
652 896
653 mysql_version_is_at_least "5.1.12" && useq "pbxt" && pbxt_src_install 897 pbxt_patch_available && use pbxt && pbxt_src_install
654
655 insinto "${MY_INCLUDEDIR}"
656 doins "${MY_INCLUDEDIR}"/my_{config,dir}.h
657 898
658 # Convenience links 899 # Convenience links
900 einfo "Making Convenience links for mysqlcheck multi-call binary"
659 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqlanalyze${MY_SUFFIX}" 901 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
660 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqlrepair${MY_SUFFIX}" 902 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
661 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqloptimize${MY_SUFFIX}" 903 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqloptimize"
662 904
663 # Various junk (my-*.cnf moved elsewhere) 905 # Various junk (my-*.cnf moved elsewhere)
906 einfo "Removing duplicate /usr/share/mysql files"
664 rm -Rf "${D}/usr/share/info" 907 rm -Rf "${D}/usr/share/info"
665 for removeme in "mysql-log-rotate" mysql.server* \ 908 for removeme in "mysql-log-rotate" mysql.server* \
666 binary-configure* my-*.cnf mi_test_all* 909 binary-configure* my-*.cnf mi_test_all*
667 do 910 do
668 rm -f "${D}"/usr/share/mysql/${removeme} 911 rm -f "${D}"/${MY_SHAREDSTATEDIR}/${removeme}
669 done 912 done
670 913
671 # TODO change at Makefile-am level
672 if [[ ${PN} == "mysql-slotted" ]] ; then
673 for moveme in "mysql_fix_privilege_tables.sql" \
674 "fill_help_tables.sql" "ndb-config-2-node.ini"
675 do
676 mv -f "${D}/usr/share/mysql/${moveme}" "${D}/usr/share/mysql${MY_SUFFIX}/" 2>/dev/null
677 done
678 fi
679
680 # clean up stuff for a minimal build 914 # Clean up stuff for a minimal build
681 if useq "minimal" ; then 915 if use minimal ; then
916 einfo "Remove all extra content for minimal build"
682 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench} 917 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench}
683 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 918 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
684 rm -f "${D}/usr/sbin/mysqld" 919 rm -f "${D}/usr/sbin/mysqld"
685 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 920 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
686 fi 921 fi
687 922
688 if [[ ${PN} == "mysql-slotted" ]] ; then 923 # Unless they explicitly specific USE=test, then do not install the
689 local notcatched=$(ls "${D}/usr/share/mysql"/*) 924 # testsuite. It DOES have a use to be installed, esp. when you want to do a
690 if [[ -n "${notcatched}" ]] ; then 925 # validation of your database configuration after tuning it.
691 ewarn "QA notice" 926 if use !test ; then
692 ewarn "${notcatched} files in /usr/share/mysql" 927 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
693 ewarn "bug mysql-herd to manage them"
694 fi
695 rm -Rf "${D}/usr/share/mysql"
696 fi 928 fi
697 929
698 # Configuration stuff 930 # Configuration stuff
931 if mysql_version_is_at_least "5.1" ; then
932 mysql_mycnf_version="5.1"
699 if mysql_version_is_at_least "4.1" ; then 933 elif mysql_version_is_at_least "4.1" ; then
700 mysql_mycnf_version="4.1" 934 mysql_mycnf_version="4.1"
701 else 935 else
702 mysql_mycnf_version="4.0" 936 mysql_mycnf_version="4.0"
703 fi 937 fi
938 einfo "Building default my.cnf"
704 insinto "${MY_SYSCONFDIR}" 939 insinto "${MY_SYSCONFDIR}"
705 doins scripts/mysqlaccess.conf 940 doins scripts/mysqlaccess.conf
706 sed -e "s!@MY_SUFFIX@!${MY_SUFFIX}!g" \
707 -e "s!@DATADIR@!${DATADIR}!g" \ 941 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
708 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \ 942 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \
709 > "${TMPDIR}/my.cnf.ok" 943 > "${TMPDIR}/my.cnf.ok"
710 if mysql_version_is_at_least "4.1" && useq "latin1" ; then 944 if mysql_version_is_at_least "4.1" && use latin1 ; then
711 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok" 945 sed -i \
946 -e "/character-set/s|utf8|latin1|g" \
947 "${TMPDIR}/my.cnf.ok"
712 fi 948 fi
713 newins "${TMPDIR}/my.cnf.ok" my.cnf 949 newins "${TMPDIR}/my.cnf.ok" my.cnf
714 950
715 # Minimal builds don't have the MySQL server 951 # Minimal builds don't have the MySQL server
716 if ! useq "minimal" ; then 952 if ! use minimal ; then
953 einfo "Creating initial directories"
717 # Empty directories ... 954 # Empty directories ...
718 diropts "-m0750" 955 diropts "-m0750"
719 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then 956 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
720 dodir "${DATADIR}" 957 dodir "${MY_DATADIR}"
721 keepdir "${DATADIR}" 958 keepdir "${MY_DATADIR}"
722 chown -R mysql:mysql "${D}/${DATADIR}" 959 chown -R mysql:mysql "${D}/${MY_DATADIR}"
723 fi 960 fi
724 961
725 diropts "-m0755" 962 diropts "-m0755"
726 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do 963 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do
727 dodir "${folder}" 964 dodir "${folder}"
729 chown -R mysql:mysql "${D}/${folder}" 966 chown -R mysql:mysql "${D}/${folder}"
730 done 967 done
731 fi 968 fi
732 969
733 # Docs 970 # Docs
971 einfo "Installing docs"
734 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 972 dodoc README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE
973 doinfo "${S}"/Docs/mysql.info
735 974
736 # Minimal builds don't have the MySQL server 975 # Minimal builds don't have the MySQL server
737 if ! useq "minimal" ; then 976 if ! use minimal ; then
977 einfo "Including support files and sample configurations"
978 docinto "support-files"
979 for script in \
980 "${S}"/support-files/my-*.cnf \
981 "${S}"/support-files/magic \
982 "${S}"/support-files/ndb-config-2-node.ini
983 do
984 [[ -f "$script" ]] && dodoc "${script}"
985 done
986
987 docinto "scripts"
988 for script in "${S}"/scripts/mysql* ; do
989 [[ -f "$script" ]] && [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
990 done
991
992 fi
993
994 mysql_lib_symlinks "${D}"
995}
996
997# @FUNCTION: mysql_pkg_preinst
998# @DESCRIPTION:
999# Create the user and groups for mysql - die if that fails.
1000mysql_pkg_preinst() {
1001 enewgroup mysql 60 || die "problem adding 'mysql' group"
1002 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
1003}
1004
1005# @FUNCTION: mysql_pkg_postinst
1006# @DESCRIPTION:
1007# Run post-installation tasks:
1008# create the dir for logfiles if non-existant
1009# touch the logfiles and secure them
1010# install scripts
1011# issue required steps for optional features
1012# issue deprecation warnings
1013mysql_pkg_postinst() {
1014 # Make sure the vars are correctly initialized
1015 mysql_init_vars
1016
1017 # Check FEATURES="collision-protect" before removing this
1018 [[ -d "${ROOT}/var/log/mysql" ]] || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
1019
1020 # Secure the logfiles
1021 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
1022 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
1023 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
1024
1025 # Minimal builds don't have the MySQL server
1026 if ! use minimal ; then
738 docinto "support-files" 1027 docinto "support-files"
739 for script in \ 1028 for script in \
740 support-files/my-*.cnf \ 1029 support-files/my-*.cnf \
741 support-files/magic \ 1030 support-files/magic \
742 support-files/ndb-config-2-node.ini 1031 support-files/ndb-config-2-node.ini
743 do 1032 do
1033 [[ -f "${script}" ]] \
744 dodoc "${script}" 1034 && dodoc "${script}"
745 done 1035 done
746 1036
747 docinto "scripts" 1037 docinto "scripts"
748 for script in scripts/mysql* ; do 1038 for script in scripts/mysql* ; do
1039 [[ -f "${script}" ]] \
749 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1040 && [[ "${script%.sh}" == "${script}" ]] \
1041 && dodoc "${script}"
750 done 1042 done
751 fi
752 1043
753 if [[ ${PN} == "mysql-slotted" ]] ; then 1044 einfo
754 # MOVED HERE DUE TO BUG #121445 1045 elog "You might want to run:"
755 # create a list of files, to be used 1046 elog "\"emerge --config =${CATEGORY}/${PF}\""
756 # by external utilities 1047 elog "if this is a new install."
757 mkdir -p "${D}/var/lib/eselect/mysql/" 1048 einfo
758 local filelist="${D}/var/lib/eselect/mysql/mysql${MY_SUFFIX}.filelist"
759 pushd "${D}/" &>/dev/null
760 find usr/bin/ usr/sbin/ \
761 -type f -name "*${MY_SUFFIX}*" \
762 -and -not -name "mysql_config${MY_SUFFIX}" \
763 > "${filelist}"
764 find usr/share/man \
765 -type f -name "*${MY_SUFFIX}*" \
766 | sed -e 's/$/.gz/' \
767 >> "${filelist}"
768 echo "${MY_SYSCONFDIR#"/"}" >> "${filelist}"
769 echo "${MY_LIBDIR#"/"}" >> "${filelist}"
770 echo "${MY_SHAREDSTATEDIR#"/"}" >> "${filelist}"
771 popd &>/dev/null
772 fi 1049 fi
773 1050
774 mysql_lib_symlinks "${D}" 1051 if pbxt_available && use pbxt ; then
775} 1052 # TODO: explain it better
1053 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
1054 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
1055 elog "if, after that, you cannot start the MySQL server,"
1056 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
1057 elog "use the MySQL upgrade script to restore the table"
1058 elog "or execute the following SQL command:"
1059 elog " CREATE TABLE IF NOT EXISTS plugin ("
1060 elog " name char(64) binary DEFAULT '' NOT NULL,"
1061 elog " dl char(128) DEFAULT '' NOT NULL,"
1062 elog " PRIMARY KEY (name)"
1063 elog " ) CHARACTER SET utf8 COLLATE utf8_bin;"
1064 fi
776 1065
777mysql_pkg_preinst() { 1066 mysql_check_version_range "4.0 to 5.0.99.99" \
778 enewgroup mysql 60 || die "problem adding 'mysql' group" 1067 && use berkdb \
779 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 1068 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
780} 1069}
781 1070
1071# @FUNCTION: mysql_pkg_config
1072# @DESCRIPTION:
1073# Configure mysql environment.
782mysql_pkg_postinst() { 1074mysql_pkg_config() {
1075 local old_MY_DATADIR="${MY_DATADIR}"
1076
783 # Make sure the vars are correctly initialized 1077 # Make sure the vars are correctly initialized
784 mysql_init_vars 1078 mysql_init_vars
785 1079
786 # Check FEATURES="collision-protect" before removing this
787 [[ -d "${ROOT}/var/log/mysql" ]] \
788 || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
789
790 # Secure the logfiles
791 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
792 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
793 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
794
795 # Minimal builds don't have the MySQL server
796 if ! useq "minimal" ; then
797 docinto "support-files"
798 for script in \
799 support-files/my-*.cnf \
800 support-files/magic \
801 support-files/ndb-config-2-node.ini
802 do
803 dodoc "${script}"
804 done
805
806 docinto "scripts"
807 for script in scripts/mysql* ; do
808 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
809 done
810 fi
811
812 einfo "you may want to read slotting upgrade documents in the overlay"
813 if useq "pbxt" && mysql_version_is_at_least "5.1" ; then
814 # TODO tell it better ;-)
815 einfo "mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
816 einfo "CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
817 einfo "if, after that you cannot start the mysql server"
818 einfo "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
819 einfo "use the mysql upgrade script to restore the table"
820 einfo " or "
821 einfo "CREATE TABLE IF NOT EXISTS plugin ("
822 einfo " name char(64) binary DEFAULT '' NOT NULL,"
823 einfo " dl char(128) DEFAULT '' NOT NULL,"
824 einfo " PRIMARY KEY (name)"
825 einfo ") CHARACTER SET utf8 COLLATE utf8_bin;"
826 fi
827 mysql_check_version_range "4.0 to 5.0.99.99" \
828 && useq "berkdb" \
829 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
830}
831
832mysql_pkg_config() {
833 # Make sure the vars are correctly initialized
834 mysql_init_vars
835
836 [[ -z "${DATADIR}" ]] && die "Sorry, unable to find DATADIR" 1080 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
837 1081
838 if built_with_use ${CATEGORY}/${PN} minimal ; then 1082 if built_with_use ${CATEGORY}/${PN} minimal ; then
839 die "Minimal builds do NOT include the MySQL server" 1083 die "Minimal builds do NOT include the MySQL server"
840 fi 1084 fi
841 1085
1086 if [[ ( -n "${MY_DATADIR}" ) && ( "${MY_DATADIR}" != "${old_MY_DATADIR}" ) ]]; then
1087 local MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${MY_DATADIR})"
1088 local old_MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${old_MY_DATADIR})"
1089
1090 if [[ -d "${old_MY_DATADIR_s}" ]]; then
1091 if [[ -d "${MY_DATADIR_s}" ]]; then
1092 ewarn "Both ${old_MY_DATADIR_s} and ${MY_DATADIR_s} exist"
1093 ewarn "Attempting to use ${MY_DATADIR_s} and preserving ${old_MY_DATADIR_s}"
1094 else
1095 elog "Moving MY_DATADIR from ${old_MY_DATADIR_s} to ${MY_DATADIR_s}"
1096 mv --strip-trailing-slashes -T "${old_MY_DATADIR_s}" "${MY_DATADIR_s}" \
1097 || die "Moving MY_DATADIR failed"
1098 fi
1099 else
1100 ewarn "Previous MY_DATADIR (${old_MY_DATADIR_s}) does not exist"
1101 if [[ -d "${MY_DATADIR_s}" ]]; then
1102 ewarn "Attempting to use ${MY_DATADIR_s}"
1103 else
1104 eerror "New MY_DATADIR (${MY_DATADIR_s}) does not exist"
1105 die "Configuration Failed! Please reinstall ${CATEGORY}/${PN}"
1106 fi
1107 fi
1108 fi
1109
842 local pwd1="a" 1110 local pwd1="a"
843 local pwd2="b" 1111 local pwd2="b"
1112 local MYSQL_ROOT_PASSWORD=''
844 local maxtry=5 1113 local maxtry=15
845 1114
1115 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${ROOT}/root/.my.cnf" ]; then
1116 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${ROOT}/root/.my.cnf")"
1117 fi
1118
846 if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then 1119 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
847 ewarn "You have already a MySQL database in place." 1120 ewarn "You have already a MySQL database in place."
848 ewarn "(${ROOT}/${DATADIR}/*)" 1121 ewarn "(${ROOT}/${MY_DATADIR}/*)"
849 ewarn "Please rename or delete it if you wish to replace it." 1122 ewarn "Please rename or delete it if you wish to replace it."
850 die "MySQL database already exists!" 1123 die "MySQL database already exists!"
851 fi 1124 fi
852 1125
853 einfo "Creating the mysql database and setting proper" 1126 # Bug #213475 - MySQL _will_ object strenously if your machine is named
854 einfo "permissions on it ..." 1127 # localhost. Also causes weird failures.
1128 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
855 1129
1130 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
1131
856 einfo "Insert a password for the mysql 'root' user" 1132 einfo "Please provide a password for the mysql 'root' user now,"
1133 einfo "or in the MYSQL_ROOT_PASSWORD env var."
857 ewarn "Avoid [\"'\\_%] characters in the password" 1134 ewarn "Avoid [\"'\\_%] characters in the password"
858 read -rsp " >" pwd1 ; echo 1135 read -rsp " >" pwd1 ; echo
859 1136
860 einfo "Retype the password" 1137 einfo "Retype the password"
861 read -rsp " >" pwd2 ; echo 1138 read -rsp " >" pwd2 ; echo
862 1139
863 if [[ "x$pwd1" != "x$pwd2" ]] ; then 1140 if [[ "x$pwd1" != "x$pwd2" ]] ; then
864 die "Passwords are not the same" 1141 die "Passwords are not the same"
1142 fi
1143 MYSQL_ROOT_PASSWORD="${pwd1}"
1144 unset pwd1 pwd2
865 fi 1145 fi
866 1146
867 local options="" 1147 local options=""
868 local sqltmp="$(emktemp)" 1148 local sqltmp="$(emktemp)"
869 1149
872 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \ 1152 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \
873 || touch "${TMPDIR}/fill_help_tables.sql" 1153 || touch "${TMPDIR}/fill_help_tables.sql"
874 help_tables="${TMPDIR}/fill_help_tables.sql" 1154 help_tables="${TMPDIR}/fill_help_tables.sql"
875 1155
876 pushd "${TMPDIR}" &>/dev/null 1156 pushd "${TMPDIR}" &>/dev/null
877 "${ROOT}/usr/bin/mysql_install_db" | grep -B5 -A999 -i "ERROR" 1157 "${ROOT}/usr/bin/mysql_install_db" >"${TMPDIR}"/mysql_install_db.log 2>&1
1158 if [ $? -ne 0 ]; then
1159 grep -B5 -A999 -i "ERROR" "${TMPDIR}"/mysql_install_db.log 1>&2
1160 die "Failed to run mysql_install_db. Please review /var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"
1161 fi
878 popd &>/dev/null 1162 popd &>/dev/null
879 [[ -f "${ROOT}/${DATADIR}/mysql/user.frm" ]] \ 1163 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
880 || die "MySQL databases not installed" 1164 || die "MySQL databases not installed"
881 chown -R mysql:mysql "${ROOT}/${DATADIR}" 2> /dev/null 1165 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
882 chmod 0750 "${ROOT}/${DATADIR}" 2> /dev/null 1166 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
1167
1168 # Figure out which options we need to disable to do the setup
1169 helpfile="${TMPDIR}/mysqld-help"
1170 ${ROOT}/usr/sbin/mysqld --verbose --help >"${helpfile}" 2>/dev/null
1171 for opt in grant-tables host-cache name-resolve networking slave-start bdb \
1172 federated innodb ssl log-bin relay-log slow-query-log external-locking \
1173 ; do
1174 optexp="--(skip-)?${opt}" optfull="--skip-${opt}"
1175 egrep -sq -- "${optexp}" "${helpfile}" && options="${options} ${optfull}"
1176 done
1177 # But some options changed names
1178 egrep -sq external-locking "${helpfile}" && \
1179 options="${options/skip-locking/skip-external-locking}"
883 1180
884 if mysql_version_is_at_least "4.1.3" ; then 1181 if mysql_version_is_at_least "4.1.3" ; then
885 options="--skip-ndbcluster"
886
887 # Filling timezones, see 1182 # Filling timezones, see
888 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html 1183 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
889 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null 1184 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
890 1185
891 if [[ -r "${help_tables}" ]] ; then 1186 if [[ -r "${help_tables}" ]] ; then
892 cat "${help_tables}" >> "${sqltmp}" 1187 cat "${help_tables}" >> "${sqltmp}"
893 fi 1188 fi
894 fi 1189 fi
1190
1191 einfo "Creating the mysql database and setting proper"
1192 einfo "permissions on it ..."
895 1193
896 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock" 1194 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock"
897 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid" 1195 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid"
898 local mysqld="${ROOT}/usr/sbin/mysqld \ 1196 local mysqld="${ROOT}/usr/sbin/mysqld \
899 ${options} \ 1197 ${options} \
900 --user=mysql \ 1198 --user=mysql \
901 --skip-grant-tables \
902 --basedir=${ROOT}/usr \ 1199 --basedir=${ROOT}/usr \
903 --datadir=${ROOT}/${DATADIR} \ 1200 --datadir=${ROOT}/${MY_DATADIR} \
904 --skip-innodb \
905 --skip-bdb \
906 --skip-networking \
907 --max_allowed_packet=8M \ 1201 --max_allowed_packet=8M \
908 --net_buffer_length=16K \ 1202 --net_buffer_length=16K \
909 --socket=${socket} \ 1203 --socket=${socket} \
910 --pid-file=${pidfile}" 1204 --pid-file=${pidfile}"
1205 #einfo "About to start mysqld: ${mysqld}"
1206 ebegin "Starting mysqld"
911 ${mysqld} & 1207 ${mysqld} &
1208 rc=$?
912 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do 1209 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
913 maxtry=$((${maxtry}-1)) 1210 maxtry=$((${maxtry}-1))
914 echo -n "." 1211 echo -n "."
915 sleep 1 1212 sleep 1
916 done 1213 done
1214 eend $rc
917 1215
1216 if ! [[ -S "${socket}" ]]; then
1217 die "Completely failed to start up mysqld with: ${mysqld}"
1218 fi
1219
1220 ebegin "Setting root password"
918 # Do this from memory, as we don't want clear text passwords in temp files 1221 # Do this from memory, as we don't want clear text passwords in temp files
919 local sql="UPDATE mysql.user SET Password = PASSWORD('${pwd1}') WHERE USER='root'" 1222 local sql="UPDATE mysql.user SET Password = PASSWORD('${MYSQL_ROOT_PASSWORD}') WHERE USER='root'"
920 "${ROOT}/usr/bin/mysql" \ 1223 "${ROOT}/usr/bin/mysql" \
921 --socket=${socket} \ 1224 --socket=${socket} \
922 -hlocalhost \ 1225 -hlocalhost \
923 -e "${sql}" 1226 -e "${sql}"
1227 eend $?
924 1228
925 einfo "Loading \"zoneinfo\", this step may require a few seconds ..." 1229 ebegin "Loading \"zoneinfo\", this step may require a few seconds ..."
926
927 "${ROOT}/usr/bin/mysql" \ 1230 "${ROOT}/usr/bin/mysql" \
928 --socket=${socket} \ 1231 --socket=${socket} \
929 -hlocalhost \ 1232 -hlocalhost \
930 -uroot \ 1233 -uroot \
931 -p"${pwd1}" \ 1234 -p"${MYSQL_ROOT_PASSWORD}" \
932 mysql < "${sqltmp}" 1235 mysql < "${sqltmp}"
1236 rc=$?
1237 eend $?
1238 [ $rc -ne 0 ] && ewarn "Failed to load zoneinfo!"
933 1239
934 # Stop the server and cleanup 1240 # Stop the server and cleanup
1241 einfo "Stopping the server ..."
935 kill $(< "${pidfile}" ) 1242 kill $(< "${pidfile}" )
936 rm -f "${sqltmp}" 1243 rm -f "${sqltmp}"
937 einfo "Stopping the server ..."
938 wait %1 1244 wait %1
939 einfo "Done" 1245 einfo "Done"
940} 1246}
941 1247
1248# @FUNCTION: mysql_pkg_postrm
1249# @DESCRIPTION:
1250# Remove mysql symlinks.
942mysql_pkg_postrm() { 1251mysql_pkg_postrm() {
943 if [[ ${PN} == "mysql-slotted" ]] ; then
944 mysql_lib_symlinks 1252 : # mysql_lib_symlinks "${D}"
945 mysql_clients_link_to_best_version
946 fi
947} 1253}

Legend:
Removed from v.1.59  
changed lines
  Added in v.1.142

  ViewVC Help
Powered by ViewVC 1.1.20