/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.132 Revision 1.159
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.132 2010/02/02 22:16:04 robbat2 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.159 2011/04/21 12:15:19 robbat2 Exp $
4 4
5# @ECLASS: mysql.eclass 5# @ECLASS: mysql.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 7# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
8# Maintainers: MySQL Team <mysql-bugs@gentoo.org> 8# Maintainers: MySQL Team <mysql-bugs@gentoo.org>
51 ;; 51 ;;
52 *) 52 *)
53 die "Unsupported EAPI: ${EAPI}" ;; 53 die "Unsupported EAPI: ${EAPI}" ;;
54esac 54esac
55 55
56
57# @ECLASS-VARIABLE: MYSQL_PV_MAJOR
58# @DESCRIPTION:
59# Upstream MySQL considers the first two parts of the version number to be the
60# major version. Upgrades that change major version should always run
61# mysql_upgrade.
62MYSQL_PV_MAJOR="$(get_version_component_range 1-2 ${PV})"
63
64# Cluster is a special case...
65if [[ "${PN}" == "mysql-cluster" ]]; then
66 case $PV in
67 6.1*|7.0*|7.1*) MYSQL_PV_MAJOR=5.1 ;;
68 esac
69fi
70
71
56# @ECLASS-VARIABLE: MYSQL_VERSION_ID 72# @ECLASS-VARIABLE: MYSQL_VERSION_ID
57# @DESCRIPTION: 73# @DESCRIPTION:
58# MYSQL_VERSION_ID will be: 74# MYSQL_VERSION_ID will be:
59# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 75# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
60# This is an important part, because many of the choices the MySQL ebuild will do 76# This is an important part, because many of the choices the MySQL ebuild will do
77# @DESCRIPTION: 93# @DESCRIPTION:
78# Specifiy if community features are available. Possible values are 1 (yes) 94# Specifiy if community features are available. Possible values are 1 (yes)
79# and 0 (no). 95# and 0 (no).
80# Community features are available in mysql-community 96# Community features are available in mysql-community
81# AND in the re-merged mysql-5.0.82 and newer 97# AND in the re-merged mysql-5.0.82 and newer
82if [ "${PN}" == "mysql-community" ]; then 98if [ "${PN}" == "mysql-community" -o "${PN}" == "mariadb" ]; then
83 MYSQL_COMMUNITY_FEATURES=1 99 MYSQL_COMMUNITY_FEATURES=1
84elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then 100elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
85 MYSQL_COMMUNITY_FEATURES=1 101 MYSQL_COMMUNITY_FEATURES=1
86elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then 102elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
87 MYSQL_COMMUNITY_FEATURES=1 103 MYSQL_COMMUNITY_FEATURES=1
88elif [ "${PV#5.4}" != "${PV}" ] ; then 104elif [ "${PV#5.4}" != "${PV}" ] ; then
89 MYSQL_COMMUNITY_FEATURES=1 105 MYSQL_COMMUNITY_FEATURES=1
90elif [ "${PV#5.5}" != "${PV}" ] ; then 106elif [ "${PV#5.5}" != "${PV}" ] ; then
91 MYSQL_COMMUNITY_FEATURES=1 107 MYSQL_COMMUNITY_FEATURES=1
92elif [ "${PV#6.0}" != "${PV}" ] ; then 108elif [ "${PV#6}" != "${PV}" ] ; then
109 MYSQL_COMMUNITY_FEATURES=1
110elif [ "${PV#7}" != "${PV}" ] ; then
93 MYSQL_COMMUNITY_FEATURES=1 111 MYSQL_COMMUNITY_FEATURES=1
94else 112else
95 MYSQL_COMMUNITY_FEATURES=0 113 MYSQL_COMMUNITY_FEATURES=0
96fi 114fi
97 115
112 >=sys-apps/sed-4 130 >=sys-apps/sed-4
113 >=sys-apps/texinfo-4.7-r1 131 >=sys-apps/texinfo-4.7-r1
114 >=sys-libs/readline-4.1 132 >=sys-libs/readline-4.1
115 >=sys-libs/zlib-1.2.3" 133 >=sys-libs/zlib-1.2.3"
116 134
135[[ "${PN}" == "mariadb" ]] \
136&& DEPEND="${DEPEND} libevent? ( >=dev-libs/libevent-1.4 )"
137
117# Having different flavours at the same time is not a good idea 138# Having different flavours at the same time is not a good idea
118for i in "" "-community" ; do 139for i in "mysql" "mysql-community" "mysql-cluster" "mariadb" ; do
119 [[ "${i}" == ${PN#mysql} ]] || 140 [[ "${i}" == ${PN} ]] ||
120 DEPEND="${DEPEND} !dev-db/mysql${i}" 141 DEPEND="${DEPEND} !dev-db/${i}"
121done 142done
122 143
123RDEPEND="${DEPEND} 144RDEPEND="${DEPEND}
124 !minimal? ( dev-db/mysql-init-scripts ) 145 !minimal? ( dev-db/mysql-init-scripts )
125 selinux? ( sec-policy/selinux-mysql )" 146 selinux? ( sec-policy/selinux-mysql )"
126 147
148if [ "${EAPI:-0}" = "2" ]; then
149 DEPEND="${DEPEND} static? ( || ( sys-libs/ncurses[static-libs] <=sys-libs/ncurses-5.7-r3 ) )"
150fi
151
127# compile-time-only 152# compile-time-only
128mysql_version_is_at_least "5.1" \ 153mysql_version_is_at_least "5.1" \
129|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )" 154|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
130 155
131# compile-time-only 156# compile-time-only
132mysql_version_is_at_least "5.1.12" \ 157mysql_version_is_at_least "5.1.12" \
133&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3" 158&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
134 159
160[[ "${PN}" == "mariadb" ]] \
161&& mysql_version_is_at_least "5.2" \
162&& DEPEND="${DEPEND} oqgraph? ( >=dev-libs/boost-1.40.0 )"
163#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
164# sphinx? ( app-misc/sphinx )"
165
135# dev-perl/DBD-mysql is needed by some scripts installed by MySQL 166# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
136PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 167PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
137 168
138# For other stuff to bring us in 169# For other stuff to bring us in
139PDEPEND="${PDEPEND} =virtual/mysql-$(get_version_component_range 1-2 ${PV})" 170PDEPEND="${PDEPEND} =virtual/mysql-${MYSQL_PV_MAJOR}"
140 171
141# Work out the default SERVER_URI correctly 172# Work out the default SERVER_URI correctly
142if [ -z "${SERVER_URI}" ]; then 173if [ -z "${SERVER_URI}" ]; then
143 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}" 174 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
175 if [ "${PN}" == "mariadb" ]; then
176 MARIA_FULL_PV="$(replace_version_separator 3 '-' ${PV})"
177 MARIA_FULL_P="${PN}-${MARIA_FULL_PV}"
178 SERVER_URI="
179 http://ftp.osuosl.org/pub/mariadb/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
180 http://ftp.rediris.es/mirror/MariaDB/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
181 http://maria.llarian.net/download/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
182 http://launchpad.net/maria/${MYSQL_PV_MAJOR}/ongoing/+download/${MARIA_FULL_P}.tar.gz
183 http://mirrors.fe.up.pt/pub/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
184 http://ftp-stud.hs-esslingen.de/pub/Mirrors/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
185 "
144 # The community build is on the mirrors 186 # The community and cluster builds are on the mirrors
145 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then 187 elif [[ "${MYSQL_COMMUNITY_FEATURES}" == "1" || ${PN} == "mysql-cluster" ]] ; then
146 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${MY_PV}.tar.gz" 188 if [[ "${PN}" == "mysql-cluster" ]] ; then
189 URI_DIR="MySQL-Cluster"
190 URI_FILE="mysql-cluster-gpl"
191 else
192 URI_DIR="MySQL"
193 URI_FILE="mysql"
194 fi
195 URI_A="${URI_FILE}-${MY_PV}.tar.gz"
196 MIRROR_PV=$(get_version_component_range 1-2 ${PV})
197 # Recently upstream switched to an archive site, and not on mirrors
198 SERVER_URI="http://downloads.mysql.com/archives/${URI_FILE}-${MIRROR_PV}/${URI_A}
199 mirror://mysql/Downloads/${URI_DIR}-${PV%.*}/${URI_A}"
147 # The (old) enterprise source is on the primary site only 200 # The (old) enterprise source is on the primary site only
148 elif [ "${PN}" == "mysql" ]; then 201 elif [ "${PN}" == "mysql" ]; then
149 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz" 202 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
150 fi 203 fi
151fi 204fi
158&& SRC_URI="${SRC_URI} 211&& SRC_URI="${SRC_URI}
159 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 212 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
160 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 213 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
161 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2" 214 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
162 215
163# PBXT engine
164mysql_version_is_at_least "5.1.12" \
165&& [[ -n "${PBXT_VERSION}" ]] \
166&& PBXT_P="pbxt-${PBXT_VERSION}" \
167&& PBXT_SRC_URI="mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
168&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )"
169
170# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
171mysql_version_is_at_least "5.1.26" \
172&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
173&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
174&& XTRADB_SRC_URI="http://www.percona.com/${PN}/xtradb/${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
175&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI} )"
176
177DESCRIPTION="A fast, multi-threaded, multi-user SQL database server." 216DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
178HOMEPAGE="http://www.mysql.com/" 217HOMEPAGE="http://www.mysql.com/"
218if [[ "${PN}" == "mariadb" ]]; then
219 HOMEPAGE="http://askmonty.org/"
220 DESCRIPTION="MariaDB is a MySQL fork with 3rd-party patches and additional storage engines merged."
221fi
222if [[ "${PN}" == "mysql-community" ]]; then
223 DESCRIPTION="${DESCRIPTION} (obsolete, move to dev-db/mysql)"
224fi
179LICENSE="GPL-2" 225LICENSE="GPL-2"
180SLOT="0" 226SLOT="0"
181IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static" 227IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
182 228
183mysql_version_is_at_least "4.1" \ 229mysql_version_is_at_least "4.1" \
184&& IUSE="${IUSE} latin1" 230&& IUSE="${IUSE} latin1"
185 231
186mysql_version_is_at_least "4.1.3" \ 232if mysql_version_is_at_least "4.1.3" ; then
187&& IUSE="${IUSE} cluster extraengine" 233 IUSE="${IUSE} extraengine"
234 if [[ "${PN}" != "mysql-cluster" ]] ; then
235 IUSE="${IUSE} cluster"
236 fi
237fi
188 238
189mysql_version_is_at_least "5.0" \ 239mysql_version_is_at_least "5.0" \
190|| IUSE="${IUSE} raid" 240|| IUSE="${IUSE} raid"
191 241
192mysql_version_is_at_least "5.0.18" \ 242mysql_version_is_at_least "5.0.18" \
193&& IUSE="${IUSE} max-idx-128" 243&& IUSE="${IUSE} max-idx-128"
194 244
195mysql_version_is_at_least "5.1" \ 245mysql_version_is_at_least "5.1" \
196|| IUSE="${IUSE} berkdb" 246|| IUSE="${IUSE} berkdb"
197 247
198mysql_version_is_at_least "5.1.12" \
199&& [[ -n "${PBXT_VERSION}" ]] \
200&& IUSE="${IUSE} pbxt"
201
202mysql_version_is_at_least "5.1.26" \
203&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
204&& IUSE="${IUSE} xtradb"
205
206[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \ 248[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
207&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling" 249&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
250
251[[ "${PN}" == "mariadb" ]] \
252&& IUSE="${IUSE} libevent"
253
254[[ "${PN}" == "mariadb" ]] \
255&& mysql_version_is_at_least "5.2" \
256&& IUSE="${IUSE} oqgraph"
257#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
258#&& IUSE="${IUSE} oqgraph sphinx"
259
260# MariaDB has integrated PBXT
261# PBXT_VERSION means that we have a PBXT patch for this PV
262# PBXT was only introduced after 5.1.12
263pbxt_patch_available() {
264 [[ "${PN}" != "mariadb" ]] \
265 && mysql_version_is_at_least "5.1.12" \
266 && [[ -n "${PBXT_VERSION}" ]]
267 return $?
268}
269
270pbxt_available() {
271 pbxt_patch_available || [[ "${PN}" == "mariadb" ]]
272 return $?
273}
274
275# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
276# MariaDB has integrated XtraDB
277# XTRADB_VERS means that we have a XTRADB patch for this PV
278# XTRADB was only introduced after 5.1.26
279xtradb_patch_available() {
280 [[ "${PN}" != "mariadb" ]] \
281 && mysql_version_is_at_least "5.1.26" \
282 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]]
283 return $?
284}
285
286
287pbxt_patch_available \
288&& PBXT_P="pbxt-${PBXT_VERSION}" \
289&& PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
290&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
291
292# PBXT_NEWSTYLE means pbxt is in storage/ and gets enabled as other plugins
293# vs. built outside the dir
294pbxt_available \
295&& IUSE="${IUSE} pbxt" \
296&& mysql_version_is_at_least "5.1.40" \
297&& PBXT_NEWSTYLE=1
298
299xtradb_patch_available \
300&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
301&& XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
302&& XTRADB_SRC_B1="http://www.percona.com/" \
303&& XTRADB_SRC_B2="${XTRADB_SRC_B1}/percona-builds/" \
304&& XTRADB_SRC_URI1="${XTRADB_SRC_B2}/Percona-Server/Percona-Server-${XTRADB_SRC_URI_COMMON}" \
305&& XTRADB_SRC_URI2="${XTRADB_SRC_B2}/xtradb/${XTRADB_SRC_URI_COMMON}" \
306&& XTRADB_SRC_URI3="${XTRADB_SRC_B1}/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
307&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} ${XTRADB_SRC_URI3} )" \
308&& IUSE="${IUSE} xtradb"
208 309
209# 310#
210# HELPER FUNCTIONS: 311# HELPER FUNCTIONS:
211# 312#
212 313
216mysql_disable_test() { 317mysql_disable_test() {
217 local rawtestname testname testsuite reason mysql_disable_file 318 local rawtestname testname testsuite reason mysql_disable_file
218 rawtestname="${1}" ; shift 319 rawtestname="${1}" ; shift
219 reason="${@}" 320 reason="${@}"
220 ewarn "test '${rawtestname}' disabled: '${reason}'" 321 ewarn "test '${rawtestname}' disabled: '${reason}'"
221 322
222 testsuite="${rawtestname/.*}" 323 testsuite="${rawtestname/.*}"
223 testname="${rawtestname/*.}" 324 testname="${rawtestname/*.}"
224 mysql_disable_file="${S}/mysql-test/t/disabled.def" 325 mysql_disable_file="${S}/mysql-test/t/disabled.def"
225 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}" 326 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
226 echo ${testname} : ${reason} >> "${mysql_disable_file}" 327 echo ${testname} : ${reason} >> "${mysql_disable_file}"
308 MY_DATADIR="${new_MY_DATADIR}" 409 MY_DATADIR="${new_MY_DATADIR}"
309 fi 410 fi
310 fi 411 fi
311 fi 412 fi
312 413
414 if [ "${MY_SOURCEDIR:-unset}" == "unset" ]; then
313 MY_SOURCEDIR=${SERVER_URI##*/} 415 MY_SOURCEDIR=${SERVER_URI##*/}
314 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*} 416 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
417 fi
315 418
316 export MY_SHAREDSTATEDIR MY_SYSCONFDIR 419 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
317 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR 420 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
318 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR 421 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
319} 422}
366 if use debug ; then 469 if use debug ; then
367 myconf="${myconf} --with-debug=full" 470 myconf="${myconf} --with-debug=full"
368 else 471 else
369 myconf="${myconf} --without-debug" 472 myconf="${myconf} --without-debug"
370 mysql_version_is_at_least "4.1.3" \ 473 mysql_version_is_at_least "4.1.3" \
371 && use cluster \ 474 && ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) \
372 && myconf="${myconf} --without-ndb-debug" 475 && myconf="${myconf} --without-ndb-debug"
373 fi 476 fi
374 477
375 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then 478 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
376 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}" 479 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
400 myconf="${myconf} $(use_with perl bench)" 503 myconf="${myconf} $(use_with perl bench)"
401 myconf="${myconf} --enable-assembler" 504 myconf="${myconf} --enable-assembler"
402 myconf="${myconf} --with-extra-tools" 505 myconf="${myconf} --with-extra-tools"
403 myconf="${myconf} --with-innodb" 506 myconf="${myconf} --with-innodb"
404 myconf="${myconf} --without-readline" 507 myconf="${myconf} --without-readline"
508 myconf="${myconf} $(use_with ssl openssl)"
405 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)" 509 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
406 510
407 # --with-vio is not needed anymore, it's on by default and 511 # --with-vio is not needed anymore, it's on by default and
408 # has been removed from configure 512 # has been removed from configure
513 # Apply to 4.x and 5.0.[0-3]
409 if use ssl ; then 514 if use ssl ; then
410 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio" 515 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
411 fi
412
413 if mysql_version_is_at_least "5.1.11" ; then
414 myconf="${myconf} $(use_with ssl)"
415 else
416 myconf="${myconf} $(use_with ssl openssl)"
417 fi 516 fi
418 517
419 if mysql_version_is_at_least "5.0.60" ; then 518 if mysql_version_is_at_least "5.0.60" ; then
420 if use berkdb ; then 519 if use berkdb ; then
421 elog "Berkeley DB support was disabled due to build failures" 520 elog "Berkeley DB support was disabled due to build failures"
437 myconf="${myconf} --without-berkeley-db" 536 myconf="${myconf} --without-berkeley-db"
438 fi 537 fi
439 538
440 if mysql_version_is_at_least "4.1.3" ; then 539 if mysql_version_is_at_least "4.1.3" ; then
441 myconf="${myconf} --with-geometry" 540 myconf="${myconf} --with-geometry"
541 if [[ "${PN}" != "mysql-cluster" ]] ; then
442 myconf="${myconf} $(use_with cluster ndbcluster)" 542 myconf="${myconf} $(use_with cluster ndbcluster)"
543 fi
443 fi 544 fi
444 545
445 if mysql_version_is_at_least "4.1.3" && use extraengine ; then 546 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
446 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html 547 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
447 myconf="${myconf} --with-archive-storage-engine" 548 myconf="${myconf} --with-archive-storage-engine"
478 579
479configure_51() { 580configure_51() {
480 # TODO: !!!! readd --without-readline 581 # TODO: !!!! readd --without-readline
481 # the failure depend upon config/ac-macros/readline.m4 checking into 582 # the failure depend upon config/ac-macros/readline.m4 checking into
482 # readline.h instead of history.h 583 # readline.h instead of history.h
483 myconf="${myconf} $(use_with ssl)" 584 myconf="${myconf} $(use_with ssl ssl /usr)"
484 myconf="${myconf} --enable-assembler" 585 myconf="${myconf} --enable-assembler"
485 myconf="${myconf} --with-geometry" 586 myconf="${myconf} --with-geometry"
486 myconf="${myconf} --with-readline" 587 myconf="${myconf} --with-readline"
487 myconf="${myconf} --with-row-based-replication"
488 myconf="${myconf} --with-zlib=/usr/$(get_libdir)" 588 myconf="${myconf} --with-zlib-dir=/usr/"
489 myconf="${myconf} --without-pstack" 589 myconf="${myconf} --without-pstack"
590 myconf="${myconf} --with-plugindir=/usr/$(get_libdir)/mysql/plugin"
591
592 # This is an explict die here, because if we just forcibly disable it, then the
593 # user's data is not accessible.
594 use max-idx-128 && die "Bug #336027: upstream has a corruption issue with max-idx-128 presently"
490 use max-idx-128 && myconf="${myconf} --with-max-indexes=128" 595 #use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
596 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
597 myconf="${myconf} $(use_enable community community-features)"
598 if use community; then
599 myconf="${myconf} $(use_enable profiling)"
600 else
601 myconf="${myconf} --disable-profiling"
602 fi
603 fi
604
605 # Scan for all available plugins
606 local plugins_avail="$(
607 LANG=C \
608 find "${S}" \
609 \( \
610 -name 'plug.in' \
611 -o -iname 'configure.in' \
612 -o -iname 'configure.ac' \
613 \) \
614 -print0 \
615 | xargs -0 sed -r -n \
616 -e '/^MYSQL_STORAGE_ENGINE/{
617 s~MYSQL_STORAGE_ENGINE\([[:space:]]*\[?([-_a-z0-9]+)\]?.*,~\1 ~g ;
618 s~^([^ ]+).*~\1~gp;
619 }' \
620 | tr -s '\n' ' '
621 )"
491 622
492 # 5.1 introduces a new way to manage storage engines (plugins) 623 # 5.1 introduces a new way to manage storage engines (plugins)
493 # like configuration=none 624 # like configuration=none
625 # This base set are required, and will always be statically built.
494 local plugins="csv,myisam,myisammrg,heap" 626 local plugins_sta="csv myisam myisammrg heap"
627 local plugins_dyn=""
628 local plugins_dis="example ibmdb2i"
629
630 # These aren't actually required by the base set, but are really useful:
631 plugins_sta="${plugins_sta} archive blackhole"
632
633 # default in 5.5.4
634 if mysql_version_is_at_least "5.5.4" ; then
635 plugins_sta="${plugins_sta} partition"
636 fi
637 # Now the extras
495 if use extraengine ; then 638 if use extraengine ; then
496 # like configuration=max-no-ndb, archive and example removed in 5.1.11 639 # like configuration=max-no-ndb, archive and example removed in 5.1.11
497 # not added yet: ibmdb2i 640 # not added yet: ibmdb2i
498 # Not supporting as examples: example,daemon_example,ftexample 641 # Not supporting as examples: example,daemon_example,ftexample
499 plugins="${plugins},archive,blackhole,federated,partition" 642 plugins_sta="${plugins_sta} partition"
500 643
644 if [[ "${PN}" != "mariadb" ]] ; then
501 elog "Before using the Federated storage engine, please be sure to read" 645 elog "Before using the Federated storage engine, please be sure to read"
502 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 646 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
647 plugins_dyn="${plugins_sta} federated"
648 else
649 elog "MariaDB includes the FederatedX engine. Be sure to read"
650 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
651 plugins_dyn="${plugins_sta} federatedx"
652 fi
653 else
654 plugins_dis="${plugins_dis} partition federated"
503 fi 655 fi
504 656
505 # Upstream specifically requests that InnoDB always be built: 657 # Upstream specifically requests that InnoDB always be built:
506 # - innobase, innodb_plugin 658 # - innobase, innodb_plugin
507 # Build falcon if available for 6.x series. 659 # Build falcon if available for 6.x series.
508 for i in innobase innodb_plugin falcon ; do 660 for i in innobase falcon ; do
509 [ -e "${S}"/storage/${i} ] && plugins="${plugins},${i}" 661 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
510 done 662 done
663 for i in innodb_plugin ; do
664 [ -e "${S}"/storage/${i} ] && plugins_dyn="${plugins_dyn} ${i}"
665 done
511 666
512 # like configuration=max-no-ndb 667 # like configuration=max-no-ndb
513 if use cluster ; then 668 if ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) ; then
514 plugins="${plugins},ndbcluster" 669 plugins_sta="${plugins_sta} ndbcluster partition"
670 plugins_dis="${plugins_dis//partition}"
515 myconf="${myconf} --with-ndb-binlog" 671 myconf="${myconf} --with-ndb-binlog"
672 else
673 plugins_dis="${plugins_dis} ndbcluster"
674 fi
675
676 if [[ "${PN}" == "mariadb" ]] ; then
677 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
678 # caught above.
679 # This is not optional, without it several upstream testcases fail.
680 # Also strongly recommended by upstream.
681 if [[ "${PV}" < "5.2.0" ]] ; then
682 myconf="${myconf} --with-maria-tmp-tables"
683 plugins_sta="${plugins_sta} maria"
684 else
685 myconf="${myconf} --with-aria-tmp-tables"
686 plugins_sta="${plugins_sta} aria"
516 fi 687 fi
517 688
689 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] ||
690 die "The ${P} package doesn't provide innobase nor xtradb"
691
692 for i in innobase xtradb ; do
693 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
694 done
695
696 myconf="${myconf} $(use_with libevent)"
697
698 if mysql_version_is_at_least "5.2" ; then
699 #This should include sphinx, but the 5.2.4 archive forgot the plug.in file
700 #for i in oqgraph sphinx ; do
701 for i in oqgraph ; do
702 use ${i} \
703 && plugins_dyn="${plugins_dyn} ${i}" \
704 || plugins_dis="${plugins_dis} ${i}"
705 done
706 fi
707 fi
708
709 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then
710 use pbxt \
711 && plugins_dyn="${plugins_dyn} pbxt" \
712 || plugins_dis="${plugins_dis} pbxt"
713 fi
714
715 use static && \
716 plugins_sta="${plugins_sta} ${plugins_dyn}" && \
717 plugins_dyn=""
718
719 einfo "Available plugins: ${plugins_avail}"
720 einfo "Dynamic plugins: ${plugins_dyn}"
721 einfo "Static plugins: ${plugins_sta}"
722 einfo "Disabled plugins: ${plugins_dis}"
723
724 # These are the static plugins
518 myconf="${myconf} --with-plugins=${plugins}" 725 myconf="${myconf} --with-plugins=${plugins_sta// /,}"
726 # And the disabled ones
727 for i in ${plugins_dis} ; do
728 myconf="${myconf} --without-plugin-${i}"
729 done
519} 730}
520 731
521pbxt_src_configure() { 732pbxt_src_configure() {
522 mysql_init_vars 733 mysql_init_vars
523 734
524 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 735 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
525 736
526 einfo "Reconfiguring dir '${PWD}'" 737 einfo "Reconfiguring dir '${PWD}'"
527 AT_GNUCONF_UPDATE="yes" eautoreconf 738 eautoreconf
528 739
529 local myconf="" 740 local myconf=""
530 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}" 741 myconf="${myconf} --with-mysql=${S} --libdir=/usr/$(get_libdir)"
531 use debug && myconf="${myconf} --with-debug=full" 742 use debug && myconf="${myconf} --with-debug=full"
532 # TODO: is it safe/needed to use econf here ?
533 ./configure ${myconf} || die "Problem configuring PBXT storage engine" 743 econf ${myconf} || die "Problem configuring PBXT storage engine"
534} 744}
535 745
536pbxt_src_compile() { 746pbxt_src_compile() {
747
537 # Be backwards compatible for now 748 # Be backwards compatible for now
538 if [[ $EAPI != 2 ]]; then 749 if [[ $EAPI != 2 ]]; then
539 pbxt_src_configure 750 pbxt_src_configure
540 fi 751 fi
541 # TODO: is it safe/needed to use emake here ? 752 # TODO: is it safe/needed to use emake here ?
545 # TODO: modify test suite for PBXT 756 # TODO: modify test suite for PBXT
546} 757}
547 758
548pbxt_src_install() { 759pbxt_src_install() {
549 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 760 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
550 make install || die "Failed to install PBXT" 761 emake install DESTDIR="${D}" || die "Failed to install PBXT"
551 popd 762 popd
552} 763}
553 764
554# 765#
555# EBUILD FUNCTIONS 766# EBUILD FUNCTIONS
568 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root." 779 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
569 fi 780 fi
570 fi 781 fi
571 fi 782 fi
572 783
784 # bug 350844
785 case "${EAPI:-0}" in
786 0 | 1)
787 if use static && !built_with_use sys-libs/ncurses static-libs; then
788 die "To build MySQL statically you need to enable static-libs for sys-libs/ncurses"
789 fi
790 ;;
791 esac
792
573 # Check for USE flag problems in pkg_setup 793 # Check for USE flag problems in pkg_setup
574 if use static && use ssl ; then 794 if use static && use ssl ; then
575 eerror "MySQL does not support being built statically with SSL support enabled!"
576 die "MySQL does not support being built statically with SSL support enabled!" 795 M="MySQL does not support being built statically with SSL support enabled!"
796 eerror "${M}"
797 die "${M}"
798 fi
799
800 if mysql_version_is_at_least "5.1.51" \
801 && ! mysql_version_is_at_least "5.2" \
802 && use debug ; then
803 # Also in package.use.mask
804 die "Bug #344885: Upstream has broken USE=debug for 5.1 series >=5.1.51"
577 fi 805 fi
578 806
579 if ! mysql_version_is_at_least "5.0" \ 807 if ! mysql_version_is_at_least "5.0" \
580 && use raid \ 808 && use raid \
581 && use static ; then 809 && use static ; then
583 eerror "with RAID support enabled." 811 eerror "with RAID support enabled."
584 die "USE flags 'raid' and 'static' conflict!" 812 die "USE flags 'raid' and 'static' conflict!"
585 fi 813 fi
586 814
587 if mysql_version_is_at_least "4.1.3" \ 815 if mysql_version_is_at_least "4.1.3" \
588 && ( use cluster || use extraengine ) \ 816 && ( use cluster || use extraengine || use embedded ) \
589 && use minimal ; then 817 && use minimal ; then
590 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
591 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 818 M="USE flags 'cluster', 'extraengine', 'embedded' conflict with 'minimal' USE flag!"
819 eerror "${M}"
820 die "${M}"
592 fi 821 fi
593 822
594 # Bug #290570 fun. Upstream made us need a fairly new GCC4.
595 if mysql_version_is_at_least "5.0.83" ; then 823 if mysql_version_is_at_least "5.1" \
824 && xtradb_patch_available \
825 && use xtradb \
826 && use embedded ; then
827 M="USE flags 'xtradb' and 'embedded' conflict and cause build failures"
828 eerror "${M}"
829 die "${M}"
830 fi
831
832 # Bug #290570, 284946, 307251
833 # Upstream changes made us need a fairly new GCC4.
834 # But only for 5.0.8[3-6]!
835 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then
596 GCC_VER=$(gcc-version) 836 GCC_VER=$(gcc-version)
597 case ${GCC_VER} in 837 case ${GCC_VER} in
598 2*|3*|4.0|4.1|4.2) die "Active GCC too old! Must have at least GCC4.3" ;; 838 2*|3*|4.0|4.1|4.2)
839 eerror "Some releases of MySQL required a very new GCC, and then"
840 eerror "later release relaxed that requirement again. Either pick a"
841 eerror "MySQL >=5.0.87, or use a newer GCC."
842 die "Active GCC too old!" ;;
599 esac 843 esac
600 fi 844 fi
601 845
602 # This should come after all of the die statements 846 # This should come after all of the die statements
603 enewgroup mysql 60 || die "problem adding 'mysql' group" 847 enewgroup mysql 60 || die "problem adding 'mysql' group"
604 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 848 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
605 849
606 mysql_check_version_range "4.0 to 5.0.99.99" \ 850 mysql_check_version_range "4.0 to 5.0.99.99" \
607 && use berkdb \ 851 && use berkdb \
608 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 852 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
853
854 if [ "${PN}" != "mysql-cluster" ] && use cluster; then
855 ewarn "Upstream has noted that the NDB cluster support in the 5.0 and"
856 ewarn "5.1 series should NOT be put into production. In the near"
857 ewarn "future, it will be disabled from building."
858 ewarn ""
859 ewarn "If you need NDB support, you should instead move to the new"
860 ewarn "mysql-cluster package that represents that upstream NDB"
861 ewarn "development."
862 fi
609} 863}
610 864
611# @FUNCTION: mysql_src_unpack 865# @FUNCTION: mysql_src_unpack
612# @DESCRIPTION: 866# @DESCRIPTION:
613# Unpack the source code and call mysql_src_prepare for EAPI < 2. 867# Unpack the source code and call mysql_src_prepare for EAPI < 2.
642 # Now link in right patches 896 # Now link in right patches
643 mysql_mv_patches 897 mysql_mv_patches
644 # And apply 898 # And apply
645 epatch 899 epatch
646 900
647 # Additional checks, remove bundled zlib 901 # last -fPIC fixup, per bug #305873
902 i="${S}"/storage/innodb_plugin/plug.in
903 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
904
905 # Additional checks, remove bundled zlib (Cluster needs this, for static
906 # memory management in zlib, leave available for Cluster)
907 if [[ "${PN}" != "mysql-cluster" ]] ; then
648 rm -f "${S}/zlib/"*.[ch] 908 rm -f "${S}/zlib/"*.[ch]
649 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 909 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
910 fi
650 rm -f "scripts/mysqlbug" 911 rm -f "scripts/mysqlbug"
651 912
652 # Make charsets install in the right place 913 # Make charsets install in the right place
653 find . -name 'Makefile.am' \ 914 find . -name 'Makefile.am' \
654 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \; 915 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
664 rm -f "scripts/mysqlbug" 925 rm -f "scripts/mysqlbug"
665 fi 926 fi
666 927
667 local rebuilddirlist d 928 local rebuilddirlist d
668 929
669 if mysql_version_is_at_least "5.1.26" && use xtradb ; then 930 if xtradb_patch_available && use xtradb ; then
670 einfo "Replacing InnoDB with Percona XtraDB" 931 einfo "Adding storage engine: Percona XtraDB (replacing InnoDB)"
671 pushd "${S}"/storage 932 pushd "${S}"/storage >/dev/null
672 i="innobase" 933 i="innobase"
673 o="${WORKDIR}/storage-${i}.mysql-upstream" 934 o="${WORKDIR}/storage-${i}.mysql-upstream"
674 # Have we been here already? 935 # Have we been here already?
675 [ -h "${i}" ] && rm -f "${i}" 936 [ -d "${o}" ] && rm -f "${i}"
676 # Or maybe we haven't 937 # Or maybe we haven't
677 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}" 938 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
678 ln -s "${WORKDIR}/${XTRADB_P}" "${i}" 939 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}"
679 popd 940 popd >/dev/null
941 fi
942
943 if pbxt_patch_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then
944 einfo "Adding storage engine: PBXT"
945 pushd "${S}"/storage >/dev/null
946 i='pbxt'
947 [ -d "${i}" ] && rm -rf "${i}"
948 cp -ral "${WORKDIR}/${PBXT_P}" "${i}"
949 popd >/dev/null
680 fi 950 fi
681 951
682 if mysql_version_is_at_least "5.1.12" ; then 952 if mysql_version_is_at_least "5.1.12" ; then
683 einfo "Updating innobase cmake"
684 rebuilddirlist="." 953 rebuilddirlist="."
954 # This does not seem to be needed presently. robbat2 2010/02/23
955 #einfo "Updating innobase cmake"
685 # TODO: check this with a cmake expert 956 ## TODO: check this with a cmake expert
686 cmake \ 957 #cmake \
687 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \ 958 # -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
688 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \ 959 # -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
689 "storage/innobase" 960 # "storage/innobase"
690 else 961 else
691 rebuilddirlist=". innobase" 962 rebuilddirlist=". innobase"
692 fi 963 fi
693 964
694 for d in ${rebuilddirlist} ; do 965 for d in ${rebuilddirlist} ; do
695 einfo "Reconfiguring dir '${d}'" 966 einfo "Reconfiguring dir '${d}'"
696 pushd "${d}" &>/dev/null 967 pushd "${d}" &>/dev/null
697 AT_GNUCONF_UPDATE="yes" eautoreconf 968 eautoreconf
698 popd &>/dev/null 969 popd &>/dev/null
699 done 970 done
700 971
701 if mysql_check_version_range "4.1 to 5.0.99.99" \ 972 if mysql_check_version_range "4.1 to 5.0.99.99" \
702 && use berkdb ; then 973 && use berkdb ; then
758 export CXXFLAGS 1029 export CXXFLAGS
759 1030
760 # bug #283926, with GCC4.4, this is required to get correct behavior. 1031 # bug #283926, with GCC4.4, this is required to get correct behavior.
761 append-flags -fno-strict-aliasing 1032 append-flags -fno-strict-aliasing
762 1033
1034 # bug #335185, #335995, with >= GCC4.3.3 on x86 only, omit-frame-pointer
1035 # causes a mis-compile.
1036 # Upstream bugs:
1037 # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38562
1038 # http://bugs.mysql.com/bug.php?id=45205
1039 use x86 && version_is_at_least "4.3.3" "$(gcc-fullversion)" && \
1040 append-flags -fno-omit-frame-pointer && \
1041 filter-flags -fomit-frame-pointer
1042
763 econf \ 1043 econf \
764 --libexecdir="/usr/sbin" \ 1044 --libexecdir="/usr/sbin" \
765 --sysconfdir="${MY_SYSCONFDIR}" \ 1045 --sysconfdir="${MY_SYSCONFDIR}" \
766 --localstatedir="${MY_LOCALSTATEDIR}" \ 1046 --localstatedir="${MY_LOCALSTATEDIR}" \
767 --sharedstatedir="${MY_SHAREDSTATEDIR}" \ 1047 --sharedstatedir="${MY_SHAREDSTATEDIR}" \
770 --with-low-memory \ 1050 --with-low-memory \
771 --with-client-ldflags=-lstdc++ \ 1051 --with-client-ldflags=-lstdc++ \
772 --enable-thread-safe-client \ 1052 --enable-thread-safe-client \
773 --with-comment="Gentoo Linux ${PF}" \ 1053 --with-comment="Gentoo Linux ${PF}" \
774 --without-docs \ 1054 --without-docs \
1055 --with-LIBDIR="$(get_libdir)" \
775 ${myconf} || die "econf failed" 1056 ${myconf} || die "econf failed"
776 1057
777 # TODO: Move this before autoreconf !!! 1058 # TODO: Move this before autoreconf !!!
778 find . -type f -name Makefile -print0 \ 1059 find . -type f -name Makefile -print0 \
779 | xargs -0 -n100 sed -i \ 1060 | xargs -0 -n100 sed -i \
780 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 1061 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
781 1062
782 if [[ $EAPI == 2 ]]; then 1063 if [[ $EAPI == 2 ]] && [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
783 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_configure 1064 pbxt_patch_available && use pbxt && pbxt_src_configure
784 fi 1065 fi
785} 1066}
786 1067
787# @FUNCTION: mysql_src_compile 1068# @FUNCTION: mysql_src_compile
788# @DESCRIPTION: 1069# @DESCRIPTION:
789# Compile the mysql code. 1070# Compile the mysql code.
790mysql_src_compile() { 1071mysql_src_compile() {
791 # Be backwards compatible for now 1072 # Be backwards compatible for now
792 case ${EAPI:-0} in 1073 case ${EAPI:-0} in
793 2) : ;; 1074 2) : ;;
794 0 | 1) mysql_src_configure ;; 1075 0 | 1) mysql_src_configure ;;
795 esac 1076 esac
796 1077
797 emake || die "emake failed" 1078 emake || die "emake failed"
798 1079
799 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile 1080 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1081 pbxt_patch_available && use pbxt && pbxt_src_compile
1082 fi
800} 1083}
801 1084
802# @FUNCTION: mysql_src_install 1085# @FUNCTION: mysql_src_install
803# @DESCRIPTION: 1086# @DESCRIPTION:
804# Install mysql. 1087# Install mysql.
805mysql_src_install() { 1088mysql_src_install() {
806 # Make sure the vars are correctly initialized 1089 # Make sure the vars are correctly initialized
807 mysql_init_vars 1090 mysql_init_vars
808 1091
809 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed" 1092 emake install \
1093 DESTDIR="${D}" \
1094 benchdir_root="${MY_SHAREDSTATEDIR}" \
1095 testroot="${MY_SHAREDSTATEDIR}" \
1096 || die "emake install failed"
810 1097
811 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_install 1098 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1099 pbxt_patch_available && use pbxt && pbxt_src_install
1100 fi
812 1101
813 # Convenience links 1102 # Convenience links
814 einfo "Making Convenience links for mysqlcheck multi-call binary" 1103 einfo "Making Convenience links for mysqlcheck multi-call binary"
815 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze" 1104 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
816 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair" 1105 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
820 einfo "Removing duplicate /usr/share/mysql files" 1109 einfo "Removing duplicate /usr/share/mysql files"
821 rm -Rf "${D}/usr/share/info" 1110 rm -Rf "${D}/usr/share/info"
822 for removeme in "mysql-log-rotate" mysql.server* \ 1111 for removeme in "mysql-log-rotate" mysql.server* \
823 binary-configure* my-*.cnf mi_test_all* 1112 binary-configure* my-*.cnf mi_test_all*
824 do 1113 do
825 rm -f "${D}"/usr/share/mysql/${removeme} 1114 rm -f "${D}"/${MY_SHAREDSTATEDIR}/${removeme}
826 done 1115 done
827 1116
828 # Clean up stuff for a minimal build 1117 # Clean up stuff for a minimal build
829 if use minimal ; then 1118 if use minimal ; then
830 einfo "Remove all extra content for minimal build" 1119 einfo "Remove all extra content for minimal build"
832 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 1121 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
833 rm -f "${D}/usr/sbin/mysqld" 1122 rm -f "${D}/usr/sbin/mysqld"
834 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 1123 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
835 fi 1124 fi
836 1125
1126 # Unless they explicitly specific USE=test, then do not install the
1127 # testsuite. It DOES have a use to be installed, esp. when you want to do a
1128 # validation of your database configuration after tuning it.
1129 if use !test ; then
1130 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
1131 fi
1132
837 # Configuration stuff 1133 # Configuration stuff
838 if mysql_version_is_at_least "4.1" ; then 1134 case ${MYSQL_PV_MAJOR} in
839 mysql_mycnf_version="4.1"
840 else
841 mysql_mycnf_version="4.0" 1135 3*|4.0) mysql_mycnf_version="4.0" ;;
842 fi 1136 4.[1-9]|5.0) mysql_mycnf_version="4.1" ;;
843 einfo "Building default my.cnf" 1137 5.[1-9]|6*|7*) mysql_mycnf_version="5.1" ;;
1138 esac
1139 einfo "Building default my.cnf (${mysql_mycnf_version})"
844 insinto "${MY_SYSCONFDIR}" 1140 insinto "${MY_SYSCONFDIR}"
845 doins scripts/mysqlaccess.conf 1141 doins scripts/mysqlaccess.conf
1142 mycnf_src="my.cnf-${mysql_mycnf_version}"
846 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \ 1143 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
847 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \ 1144 "${FILESDIR}/${mycnf_src}" \
848 > "${TMPDIR}/my.cnf.ok" 1145 > "${TMPDIR}/my.cnf.ok"
849 if mysql_version_is_at_least "4.1" && use latin1 ; then 1146 if use latin1 ; then
850 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok" 1147 sed -i \
1148 -e "/character-set/s|utf8|latin1|g" \
1149 "${TMPDIR}/my.cnf.ok"
851 fi 1150 fi
852 newins "${TMPDIR}/my.cnf.ok" my.cnf 1151 newins "${TMPDIR}/my.cnf.ok" my.cnf
853 1152
854 # Minimal builds don't have the MySQL server 1153 # Minimal builds don't have the MySQL server
855 if ! use minimal ; then 1154 if ! use minimal ; then
870 done 1169 done
871 fi 1170 fi
872 1171
873 # Docs 1172 # Docs
874 einfo "Installing docs" 1173 einfo "Installing docs"
875 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 1174 dodoc README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE
876 doinfo "${S}"/Docs/mysql.info 1175 doinfo "${S}"/Docs/mysql.info
877 1176
878 # Minimal builds don't have the MySQL server 1177 # Minimal builds don't have the MySQL server
879 if ! use minimal ; then 1178 if ! use minimal ; then
880 einfo "Including support files and sample configurations" 1179 einfo "Including support files and sample configurations"
882 for script in \ 1181 for script in \
883 "${S}"/support-files/my-*.cnf \ 1182 "${S}"/support-files/my-*.cnf \
884 "${S}"/support-files/magic \ 1183 "${S}"/support-files/magic \
885 "${S}"/support-files/ndb-config-2-node.ini 1184 "${S}"/support-files/ndb-config-2-node.ini
886 do 1185 do
887 dodoc "${script}" 1186 [[ -f "$script" ]] && dodoc "${script}"
888 done 1187 done
889 1188
890 docinto "scripts" 1189 docinto "scripts"
891 for script in "${S}"/scripts/mysql* ; do 1190 for script in "${S}"/scripts/mysql* ; do
892 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1191 [[ -f "$script" ]] && [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
893 done 1192 done
894 1193
895 fi 1194 fi
896 1195
897 mysql_lib_symlinks "${D}" 1196 mysql_lib_symlinks "${D}"
931 for script in \ 1230 for script in \
932 support-files/my-*.cnf \ 1231 support-files/my-*.cnf \
933 support-files/magic \ 1232 support-files/magic \
934 support-files/ndb-config-2-node.ini 1233 support-files/ndb-config-2-node.ini
935 do 1234 do
1235 [[ -f "${script}" ]] \
936 dodoc "${script}" 1236 && dodoc "${script}"
937 done 1237 done
938 1238
939 docinto "scripts" 1239 docinto "scripts"
940 for script in scripts/mysql* ; do 1240 for script in scripts/mysql* ; do
1241 [[ -f "${script}" ]] \
941 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1242 && [[ "${script%.sh}" == "${script}" ]] \
1243 && dodoc "${script}"
942 done 1244 done
943 1245
944 einfo 1246 einfo
945 elog "You might want to run:" 1247 elog "You might want to run:"
946 elog "\"emerge --config =${CATEGORY}/${PF}\"" 1248 elog "\"emerge --config =${CATEGORY}/${PF}\""
947 elog "if this is a new install." 1249 elog "if this is a new install."
948 einfo 1250 einfo
949 fi
950 1251
951 if mysql_version_is_at_least "5.1.12" && use pbxt ; then 1252 einfo
1253 elog "If you are upgrading major versions, you should run the"
1254 elog "mysql_upgrade tool."
1255 einfo
1256 fi
1257
1258 if pbxt_available && use pbxt ; then
952 # TODO: explain it better 1259 # TODO: explain it better
953 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';" 1260 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
954 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;" 1261 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
955 elog "if, after that, you cannot start the MySQL server," 1262 elog "if, after that, you cannot start the MySQL server,"
956 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then" 1263 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
1007 fi 1314 fi
1008 fi 1315 fi
1009 1316
1010 local pwd1="a" 1317 local pwd1="a"
1011 local pwd2="b" 1318 local pwd2="b"
1012 local maxtry=5 1319 local maxtry=15
1320
1321 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${ROOT}/root/.my.cnf" ]; then
1322 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${ROOT}/root/.my.cnf")"
1323 fi
1013 1324
1014 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then 1325 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
1015 ewarn "You have already a MySQL database in place." 1326 ewarn "You have already a MySQL database in place."
1016 ewarn "(${ROOT}/${MY_DATADIR}/*)" 1327 ewarn "(${ROOT}/${MY_DATADIR}/*)"
1017 ewarn "Please rename or delete it if you wish to replace it." 1328 ewarn "Please rename or delete it if you wish to replace it."
1020 1331
1021 # Bug #213475 - MySQL _will_ object strenously if your machine is named 1332 # Bug #213475 - MySQL _will_ object strenously if your machine is named
1022 # localhost. Also causes weird failures. 1333 # localhost. Also causes weird failures.
1023 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost" 1334 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
1024 1335
1025 einfo "Creating the mysql database and setting proper" 1336 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
1026 einfo "permissions on it ..."
1027 1337
1028 einfo "Insert a password for the mysql 'root' user" 1338 einfo "Please provide a password for the mysql 'root' user now, in the"
1339 einfo "MYSQL_ROOT_PASSWORD env var or through the /root/.my.cnf file."
1029 ewarn "Avoid [\"'\\_%] characters in the password" 1340 ewarn "Avoid [\"'\\_%] characters in the password"
1030 read -rsp " >" pwd1 ; echo 1341 read -rsp " >" pwd1 ; echo
1031 1342
1032 einfo "Retype the password" 1343 einfo "Retype the password"
1033 read -rsp " >" pwd2 ; echo 1344 read -rsp " >" pwd2 ; echo
1034 1345
1035 if [[ "x$pwd1" != "x$pwd2" ]] ; then 1346 if [[ "x$pwd1" != "x$pwd2" ]] ; then
1036 die "Passwords are not the same" 1347 die "Passwords are not the same"
1348 fi
1349 MYSQL_ROOT_PASSWORD="${pwd1}"
1350 unset pwd1 pwd2
1037 fi 1351 fi
1038 1352
1039 local options="" 1353 local options=""
1040 local sqltmp="$(emktemp)" 1354 local sqltmp="$(emktemp)"
1041 1355
1055 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \ 1369 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
1056 || die "MySQL databases not installed" 1370 || die "MySQL databases not installed"
1057 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null 1371 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
1058 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null 1372 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
1059 1373
1374 # Figure out which options we need to disable to do the setup
1375 helpfile="${TMPDIR}/mysqld-help"
1376 ${ROOT}/usr/sbin/mysqld --verbose --help >"${helpfile}" 2>/dev/null
1377 for opt in grant-tables host-cache name-resolve networking slave-start bdb \
1378 federated innodb ssl log-bin relay-log slow-query-log external-locking \
1379 ndbcluster \
1380 ; do
1381 optexp="--(skip-)?${opt}" optfull="--skip-${opt}"
1382 egrep -sq -- "${optexp}" "${helpfile}" && options="${options} ${optfull}"
1383 done
1384 # But some options changed names
1385 egrep -sq external-locking "${helpfile}" && \
1386 options="${options/skip-locking/skip-external-locking}"
1387
1060 if mysql_version_is_at_least "4.1.3" ; then 1388 if mysql_version_is_at_least "4.1.3" ; then
1061 options="--skip-ndbcluster"
1062
1063 # Filling timezones, see 1389 # Filling timezones, see
1064 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html 1390 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
1065 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null 1391 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
1066 1392
1067 if [[ -r "${help_tables}" ]] ; then 1393 if [[ -r "${help_tables}" ]] ; then
1068 cat "${help_tables}" >> "${sqltmp}" 1394 cat "${help_tables}" >> "${sqltmp}"
1069 fi 1395 fi
1070 fi 1396 fi
1397
1398 einfo "Creating the mysql database and setting proper"
1399 einfo "permissions on it ..."
1071 1400
1072 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock" 1401 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock"
1073 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid" 1402 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid"
1074 local mysqld="${ROOT}/usr/sbin/mysqld \ 1403 local mysqld="${ROOT}/usr/sbin/mysqld \
1075 ${options} \ 1404 ${options} \
1076 --user=mysql \ 1405 --user=mysql \
1077 --skip-grant-tables \
1078 --basedir=${ROOT}/usr \ 1406 --basedir=${ROOT}/usr \
1079 --datadir=${ROOT}/${MY_DATADIR} \ 1407 --datadir=${ROOT}/${MY_DATADIR} \
1080 --skip-innodb \
1081 --skip-bdb \
1082 --skip-networking \
1083 --max_allowed_packet=8M \ 1408 --max_allowed_packet=8M \
1084 --net_buffer_length=16K \ 1409 --net_buffer_length=16K \
1410 --default-storage-engine=MyISAM \
1085 --socket=${socket} \ 1411 --socket=${socket} \
1086 --pid-file=${pidfile}" 1412 --pid-file=${pidfile}"
1413 #einfo "About to start mysqld: ${mysqld}"
1414 ebegin "Starting mysqld"
1087 ${mysqld} & 1415 ${mysqld} &
1416 rc=$?
1088 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do 1417 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
1089 maxtry=$((${maxtry}-1)) 1418 maxtry=$((${maxtry}-1))
1090 echo -n "." 1419 echo -n "."
1091 sleep 1 1420 sleep 1
1092 done 1421 done
1422 eend $rc
1093 1423
1424 if ! [[ -S "${socket}" ]]; then
1425 die "Completely failed to start up mysqld with: ${mysqld}"
1426 fi
1427
1428 ebegin "Setting root password"
1094 # Do this from memory, as we don't want clear text passwords in temp files 1429 # Do this from memory, as we don't want clear text passwords in temp files
1095 local sql="UPDATE mysql.user SET Password = PASSWORD('${pwd1}') WHERE USER='root'" 1430 local sql="UPDATE mysql.user SET Password = PASSWORD('${MYSQL_ROOT_PASSWORD}') WHERE USER='root'"
1096 "${ROOT}/usr/bin/mysql" \ 1431 "${ROOT}/usr/bin/mysql" \
1097 --socket=${socket} \ 1432 --socket=${socket} \
1098 -hlocalhost \ 1433 -hlocalhost \
1099 -e "${sql}" 1434 -e "${sql}"
1435 eend $?
1100 1436
1101 einfo "Loading \"zoneinfo\", this step may require a few seconds ..." 1437 ebegin "Loading \"zoneinfo\", this step may require a few seconds ..."
1102
1103 "${ROOT}/usr/bin/mysql" \ 1438 "${ROOT}/usr/bin/mysql" \
1104 --socket=${socket} \ 1439 --socket=${socket} \
1105 -hlocalhost \ 1440 -hlocalhost \
1106 -uroot \ 1441 -uroot \
1107 -p"${pwd1}" \ 1442 -p"${MYSQL_ROOT_PASSWORD}" \
1108 mysql < "${sqltmp}" 1443 mysql < "${sqltmp}"
1444 rc=$?
1445 eend $?
1446 [ $rc -ne 0 ] && ewarn "Failed to load zoneinfo!"
1109 1447
1110 # Stop the server and cleanup 1448 # Stop the server and cleanup
1449 einfo "Stopping the server ..."
1111 kill $(< "${pidfile}" ) 1450 kill $(< "${pidfile}" )
1112 rm -f "${sqltmp}" 1451 rm -f "${sqltmp}"
1113 einfo "Stopping the server ..."
1114 wait %1 1452 wait %1
1115 einfo "Done" 1453 einfo "Done"
1116} 1454}
1117 1455
1118# @FUNCTION: mysql_pkg_postrm 1456# @FUNCTION: mysql_pkg_postrm

Legend:
Removed from v.1.132  
changed lines
  Added in v.1.159

  ViewVC Help
Powered by ViewVC 1.1.20