/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.133 Revision 1.159
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.133 2010/02/21 00:18:16 robbat2 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.159 2011/04/21 12:15:19 robbat2 Exp $
4 4
5# @ECLASS: mysql.eclass 5# @ECLASS: mysql.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 7# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
8# Maintainers: MySQL Team <mysql-bugs@gentoo.org> 8# Maintainers: MySQL Team <mysql-bugs@gentoo.org>
51 ;; 51 ;;
52 *) 52 *)
53 die "Unsupported EAPI: ${EAPI}" ;; 53 die "Unsupported EAPI: ${EAPI}" ;;
54esac 54esac
55 55
56
57# @ECLASS-VARIABLE: MYSQL_PV_MAJOR
58# @DESCRIPTION:
59# Upstream MySQL considers the first two parts of the version number to be the
60# major version. Upgrades that change major version should always run
61# mysql_upgrade.
62MYSQL_PV_MAJOR="$(get_version_component_range 1-2 ${PV})"
63
64# Cluster is a special case...
65if [[ "${PN}" == "mysql-cluster" ]]; then
66 case $PV in
67 6.1*|7.0*|7.1*) MYSQL_PV_MAJOR=5.1 ;;
68 esac
69fi
70
71
56# @ECLASS-VARIABLE: MYSQL_VERSION_ID 72# @ECLASS-VARIABLE: MYSQL_VERSION_ID
57# @DESCRIPTION: 73# @DESCRIPTION:
58# MYSQL_VERSION_ID will be: 74# MYSQL_VERSION_ID will be:
59# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 75# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
60# This is an important part, because many of the choices the MySQL ebuild will do 76# This is an important part, because many of the choices the MySQL ebuild will do
77# @DESCRIPTION: 93# @DESCRIPTION:
78# Specifiy if community features are available. Possible values are 1 (yes) 94# Specifiy if community features are available. Possible values are 1 (yes)
79# and 0 (no). 95# and 0 (no).
80# Community features are available in mysql-community 96# Community features are available in mysql-community
81# AND in the re-merged mysql-5.0.82 and newer 97# AND in the re-merged mysql-5.0.82 and newer
82if [ "${PN}" == "mysql-community" ]; then 98if [ "${PN}" == "mysql-community" -o "${PN}" == "mariadb" ]; then
83 MYSQL_COMMUNITY_FEATURES=1 99 MYSQL_COMMUNITY_FEATURES=1
84elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then 100elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
85 MYSQL_COMMUNITY_FEATURES=1 101 MYSQL_COMMUNITY_FEATURES=1
86elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then 102elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
87 MYSQL_COMMUNITY_FEATURES=1 103 MYSQL_COMMUNITY_FEATURES=1
88elif [ "${PV#5.4}" != "${PV}" ] ; then 104elif [ "${PV#5.4}" != "${PV}" ] ; then
89 MYSQL_COMMUNITY_FEATURES=1 105 MYSQL_COMMUNITY_FEATURES=1
90elif [ "${PV#5.5}" != "${PV}" ] ; then 106elif [ "${PV#5.5}" != "${PV}" ] ; then
91 MYSQL_COMMUNITY_FEATURES=1 107 MYSQL_COMMUNITY_FEATURES=1
92elif [ "${PV#6.0}" != "${PV}" ] ; then 108elif [ "${PV#6}" != "${PV}" ] ; then
109 MYSQL_COMMUNITY_FEATURES=1
110elif [ "${PV#7}" != "${PV}" ] ; then
93 MYSQL_COMMUNITY_FEATURES=1 111 MYSQL_COMMUNITY_FEATURES=1
94else 112else
95 MYSQL_COMMUNITY_FEATURES=0 113 MYSQL_COMMUNITY_FEATURES=0
96fi 114fi
97 115
112 >=sys-apps/sed-4 130 >=sys-apps/sed-4
113 >=sys-apps/texinfo-4.7-r1 131 >=sys-apps/texinfo-4.7-r1
114 >=sys-libs/readline-4.1 132 >=sys-libs/readline-4.1
115 >=sys-libs/zlib-1.2.3" 133 >=sys-libs/zlib-1.2.3"
116 134
135[[ "${PN}" == "mariadb" ]] \
136&& DEPEND="${DEPEND} libevent? ( >=dev-libs/libevent-1.4 )"
137
117# Having different flavours at the same time is not a good idea 138# Having different flavours at the same time is not a good idea
118for i in "" "-community" ; do 139for i in "mysql" "mysql-community" "mysql-cluster" "mariadb" ; do
119 [[ "${i}" == ${PN#mysql} ]] || 140 [[ "${i}" == ${PN} ]] ||
120 DEPEND="${DEPEND} !dev-db/mysql${i}" 141 DEPEND="${DEPEND} !dev-db/${i}"
121done 142done
122 143
123RDEPEND="${DEPEND} 144RDEPEND="${DEPEND}
124 !minimal? ( dev-db/mysql-init-scripts ) 145 !minimal? ( dev-db/mysql-init-scripts )
125 selinux? ( sec-policy/selinux-mysql )" 146 selinux? ( sec-policy/selinux-mysql )"
126 147
148if [ "${EAPI:-0}" = "2" ]; then
149 DEPEND="${DEPEND} static? ( || ( sys-libs/ncurses[static-libs] <=sys-libs/ncurses-5.7-r3 ) )"
150fi
151
127# compile-time-only 152# compile-time-only
128mysql_version_is_at_least "5.1" \ 153mysql_version_is_at_least "5.1" \
129|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )" 154|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
130 155
131# compile-time-only 156# compile-time-only
132mysql_version_is_at_least "5.1.12" \ 157mysql_version_is_at_least "5.1.12" \
133&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3" 158&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
134 159
160[[ "${PN}" == "mariadb" ]] \
161&& mysql_version_is_at_least "5.2" \
162&& DEPEND="${DEPEND} oqgraph? ( >=dev-libs/boost-1.40.0 )"
163#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
164# sphinx? ( app-misc/sphinx )"
165
135# dev-perl/DBD-mysql is needed by some scripts installed by MySQL 166# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
136PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 167PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
137 168
138# For other stuff to bring us in 169# For other stuff to bring us in
139PDEPEND="${PDEPEND} =virtual/mysql-$(get_version_component_range 1-2 ${PV})" 170PDEPEND="${PDEPEND} =virtual/mysql-${MYSQL_PV_MAJOR}"
140 171
141# Work out the default SERVER_URI correctly 172# Work out the default SERVER_URI correctly
142if [ -z "${SERVER_URI}" ]; then 173if [ -z "${SERVER_URI}" ]; then
143 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}" 174 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
175 if [ "${PN}" == "mariadb" ]; then
176 MARIA_FULL_PV="$(replace_version_separator 3 '-' ${PV})"
177 MARIA_FULL_P="${PN}-${MARIA_FULL_PV}"
178 SERVER_URI="
179 http://ftp.osuosl.org/pub/mariadb/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
180 http://ftp.rediris.es/mirror/MariaDB/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
181 http://maria.llarian.net/download/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
182 http://launchpad.net/maria/${MYSQL_PV_MAJOR}/ongoing/+download/${MARIA_FULL_P}.tar.gz
183 http://mirrors.fe.up.pt/pub/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
184 http://ftp-stud.hs-esslingen.de/pub/Mirrors/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
185 "
144 # The community build is on the mirrors 186 # The community and cluster builds are on the mirrors
145 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then 187 elif [[ "${MYSQL_COMMUNITY_FEATURES}" == "1" || ${PN} == "mysql-cluster" ]] ; then
146 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${MY_PV}.tar.gz" 188 if [[ "${PN}" == "mysql-cluster" ]] ; then
189 URI_DIR="MySQL-Cluster"
190 URI_FILE="mysql-cluster-gpl"
191 else
192 URI_DIR="MySQL"
193 URI_FILE="mysql"
194 fi
195 URI_A="${URI_FILE}-${MY_PV}.tar.gz"
196 MIRROR_PV=$(get_version_component_range 1-2 ${PV})
197 # Recently upstream switched to an archive site, and not on mirrors
198 SERVER_URI="http://downloads.mysql.com/archives/${URI_FILE}-${MIRROR_PV}/${URI_A}
199 mirror://mysql/Downloads/${URI_DIR}-${PV%.*}/${URI_A}"
147 # The (old) enterprise source is on the primary site only 200 # The (old) enterprise source is on the primary site only
148 elif [ "${PN}" == "mysql" ]; then 201 elif [ "${PN}" == "mysql" ]; then
149 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz" 202 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
150 fi 203 fi
151fi 204fi
160 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 213 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
161 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2" 214 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
162 215
163DESCRIPTION="A fast, multi-threaded, multi-user SQL database server." 216DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
164HOMEPAGE="http://www.mysql.com/" 217HOMEPAGE="http://www.mysql.com/"
218if [[ "${PN}" == "mariadb" ]]; then
219 HOMEPAGE="http://askmonty.org/"
220 DESCRIPTION="MariaDB is a MySQL fork with 3rd-party patches and additional storage engines merged."
221fi
222if [[ "${PN}" == "mysql-community" ]]; then
223 DESCRIPTION="${DESCRIPTION} (obsolete, move to dev-db/mysql)"
224fi
165LICENSE="GPL-2" 225LICENSE="GPL-2"
166SLOT="0" 226SLOT="0"
167IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test" 227IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
168 228
169mysql_version_is_at_least "4.1" \ 229mysql_version_is_at_least "4.1" \
170&& IUSE="${IUSE} latin1" 230&& IUSE="${IUSE} latin1"
171 231
172mysql_version_is_at_least "4.1.3" \ 232if mysql_version_is_at_least "4.1.3" ; then
173&& IUSE="${IUSE} cluster extraengine" 233 IUSE="${IUSE} extraengine"
234 if [[ "${PN}" != "mysql-cluster" ]] ; then
235 IUSE="${IUSE} cluster"
236 fi
237fi
174 238
175mysql_version_is_at_least "5.0" \ 239mysql_version_is_at_least "5.0" \
176|| IUSE="${IUSE} raid" 240|| IUSE="${IUSE} raid"
177 241
178mysql_version_is_at_least "5.0.18" \ 242mysql_version_is_at_least "5.0.18" \
182|| IUSE="${IUSE} berkdb" 246|| IUSE="${IUSE} berkdb"
183 247
184[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \ 248[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
185&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling" 249&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
186 250
187# PBXT engine 251[[ "${PN}" == "mariadb" ]] \
252&& IUSE="${IUSE} libevent"
253
254[[ "${PN}" == "mariadb" ]] \
255&& mysql_version_is_at_least "5.2" \
256&& IUSE="${IUSE} oqgraph"
257#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
258#&& IUSE="${IUSE} oqgraph sphinx"
259
260# MariaDB has integrated PBXT
261# PBXT_VERSION means that we have a PBXT patch for this PV
262# PBXT was only introduced after 5.1.12
263pbxt_patch_available() {
264 [[ "${PN}" != "mariadb" ]] \
188mysql_version_is_at_least "5.1.12" \ 265 && mysql_version_is_at_least "5.1.12" \
189&& [[ -n "${PBXT_VERSION}" ]] \ 266 && [[ -n "${PBXT_VERSION}" ]]
267 return $?
268}
269
270pbxt_available() {
271 pbxt_patch_available || [[ "${PN}" == "mariadb" ]]
272 return $?
273}
274
275# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
276# MariaDB has integrated XtraDB
277# XTRADB_VERS means that we have a XTRADB patch for this PV
278# XTRADB was only introduced after 5.1.26
279xtradb_patch_available() {
280 [[ "${PN}" != "mariadb" ]] \
281 && mysql_version_is_at_least "5.1.26" \
282 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]]
283 return $?
284}
285
286
287pbxt_patch_available \
190&& PBXT_P="pbxt-${PBXT_VERSION}" \ 288&& PBXT_P="pbxt-${PBXT_VERSION}" \
191&& PBXT_SRC_URI="mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \ 289&& PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
192&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \ 290&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
291
292# PBXT_NEWSTYLE means pbxt is in storage/ and gets enabled as other plugins
293# vs. built outside the dir
294pbxt_available \
193&& IUSE="${IUSE} pbxt" 295&& IUSE="${IUSE} pbxt" \
194
195# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
196mysql_version_is_at_least "5.1.26" \ 296&& mysql_version_is_at_least "5.1.40" \
197&& [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \ 297&& PBXT_NEWSTYLE=1
298
299xtradb_patch_available \
198&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \ 300&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
199&& XTRADB_SRC_URI="http://www.percona.com/${PN}/xtradb/${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \ 301&& XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
200&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI} )" \ 302&& XTRADB_SRC_B1="http://www.percona.com/" \
303&& XTRADB_SRC_B2="${XTRADB_SRC_B1}/percona-builds/" \
304&& XTRADB_SRC_URI1="${XTRADB_SRC_B2}/Percona-Server/Percona-Server-${XTRADB_SRC_URI_COMMON}" \
305&& XTRADB_SRC_URI2="${XTRADB_SRC_B2}/xtradb/${XTRADB_SRC_URI_COMMON}" \
306&& XTRADB_SRC_URI3="${XTRADB_SRC_B1}/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
307&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} ${XTRADB_SRC_URI3} )" \
201&& IUSE="${IUSE} xtradb" 308&& IUSE="${IUSE} xtradb"
202 309
203# 310#
204# HELPER FUNCTIONS: 311# HELPER FUNCTIONS:
205# 312#
210mysql_disable_test() { 317mysql_disable_test() {
211 local rawtestname testname testsuite reason mysql_disable_file 318 local rawtestname testname testsuite reason mysql_disable_file
212 rawtestname="${1}" ; shift 319 rawtestname="${1}" ; shift
213 reason="${@}" 320 reason="${@}"
214 ewarn "test '${rawtestname}' disabled: '${reason}'" 321 ewarn "test '${rawtestname}' disabled: '${reason}'"
215 322
216 testsuite="${rawtestname/.*}" 323 testsuite="${rawtestname/.*}"
217 testname="${rawtestname/*.}" 324 testname="${rawtestname/*.}"
218 mysql_disable_file="${S}/mysql-test/t/disabled.def" 325 mysql_disable_file="${S}/mysql-test/t/disabled.def"
219 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}" 326 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
220 echo ${testname} : ${reason} >> "${mysql_disable_file}" 327 echo ${testname} : ${reason} >> "${mysql_disable_file}"
302 MY_DATADIR="${new_MY_DATADIR}" 409 MY_DATADIR="${new_MY_DATADIR}"
303 fi 410 fi
304 fi 411 fi
305 fi 412 fi
306 413
414 if [ "${MY_SOURCEDIR:-unset}" == "unset" ]; then
307 MY_SOURCEDIR=${SERVER_URI##*/} 415 MY_SOURCEDIR=${SERVER_URI##*/}
308 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*} 416 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
417 fi
309 418
310 export MY_SHAREDSTATEDIR MY_SYSCONFDIR 419 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
311 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR 420 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
312 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR 421 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
313} 422}
360 if use debug ; then 469 if use debug ; then
361 myconf="${myconf} --with-debug=full" 470 myconf="${myconf} --with-debug=full"
362 else 471 else
363 myconf="${myconf} --without-debug" 472 myconf="${myconf} --without-debug"
364 mysql_version_is_at_least "4.1.3" \ 473 mysql_version_is_at_least "4.1.3" \
365 && use cluster \ 474 && ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) \
366 && myconf="${myconf} --without-ndb-debug" 475 && myconf="${myconf} --without-ndb-debug"
367 fi 476 fi
368 477
369 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then 478 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
370 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}" 479 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
394 myconf="${myconf} $(use_with perl bench)" 503 myconf="${myconf} $(use_with perl bench)"
395 myconf="${myconf} --enable-assembler" 504 myconf="${myconf} --enable-assembler"
396 myconf="${myconf} --with-extra-tools" 505 myconf="${myconf} --with-extra-tools"
397 myconf="${myconf} --with-innodb" 506 myconf="${myconf} --with-innodb"
398 myconf="${myconf} --without-readline" 507 myconf="${myconf} --without-readline"
508 myconf="${myconf} $(use_with ssl openssl)"
399 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)" 509 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
400 510
401 # --with-vio is not needed anymore, it's on by default and 511 # --with-vio is not needed anymore, it's on by default and
402 # has been removed from configure 512 # has been removed from configure
513 # Apply to 4.x and 5.0.[0-3]
403 if use ssl ; then 514 if use ssl ; then
404 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio" 515 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
405 fi
406
407 if mysql_version_is_at_least "5.1.11" ; then
408 myconf="${myconf} $(use_with ssl)"
409 else
410 myconf="${myconf} $(use_with ssl openssl)"
411 fi 516 fi
412 517
413 if mysql_version_is_at_least "5.0.60" ; then 518 if mysql_version_is_at_least "5.0.60" ; then
414 if use berkdb ; then 519 if use berkdb ; then
415 elog "Berkeley DB support was disabled due to build failures" 520 elog "Berkeley DB support was disabled due to build failures"
431 myconf="${myconf} --without-berkeley-db" 536 myconf="${myconf} --without-berkeley-db"
432 fi 537 fi
433 538
434 if mysql_version_is_at_least "4.1.3" ; then 539 if mysql_version_is_at_least "4.1.3" ; then
435 myconf="${myconf} --with-geometry" 540 myconf="${myconf} --with-geometry"
541 if [[ "${PN}" != "mysql-cluster" ]] ; then
436 myconf="${myconf} $(use_with cluster ndbcluster)" 542 myconf="${myconf} $(use_with cluster ndbcluster)"
543 fi
437 fi 544 fi
438 545
439 if mysql_version_is_at_least "4.1.3" && use extraengine ; then 546 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
440 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html 547 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
441 myconf="${myconf} --with-archive-storage-engine" 548 myconf="${myconf} --with-archive-storage-engine"
472 579
473configure_51() { 580configure_51() {
474 # TODO: !!!! readd --without-readline 581 # TODO: !!!! readd --without-readline
475 # the failure depend upon config/ac-macros/readline.m4 checking into 582 # the failure depend upon config/ac-macros/readline.m4 checking into
476 # readline.h instead of history.h 583 # readline.h instead of history.h
477 myconf="${myconf} $(use_with ssl)" 584 myconf="${myconf} $(use_with ssl ssl /usr)"
478 myconf="${myconf} --enable-assembler" 585 myconf="${myconf} --enable-assembler"
479 myconf="${myconf} --with-geometry" 586 myconf="${myconf} --with-geometry"
480 myconf="${myconf} --with-readline" 587 myconf="${myconf} --with-readline"
481 myconf="${myconf} --with-zlib-dir=/usr/" 588 myconf="${myconf} --with-zlib-dir=/usr/"
482 myconf="${myconf} --without-pstack" 589 myconf="${myconf} --without-pstack"
590 myconf="${myconf} --with-plugindir=/usr/$(get_libdir)/mysql/plugin"
591
592 # This is an explict die here, because if we just forcibly disable it, then the
593 # user's data is not accessible.
594 use max-idx-128 && die "Bug #336027: upstream has a corruption issue with max-idx-128 presently"
483 use max-idx-128 && myconf="${myconf} --with-max-indexes=128" 595 #use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
596 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
597 myconf="${myconf} $(use_enable community community-features)"
598 if use community; then
599 myconf="${myconf} $(use_enable profiling)"
600 else
601 myconf="${myconf} --disable-profiling"
602 fi
603 fi
604
605 # Scan for all available plugins
606 local plugins_avail="$(
607 LANG=C \
608 find "${S}" \
609 \( \
610 -name 'plug.in' \
611 -o -iname 'configure.in' \
612 -o -iname 'configure.ac' \
613 \) \
614 -print0 \
615 | xargs -0 sed -r -n \
616 -e '/^MYSQL_STORAGE_ENGINE/{
617 s~MYSQL_STORAGE_ENGINE\([[:space:]]*\[?([-_a-z0-9]+)\]?.*,~\1 ~g ;
618 s~^([^ ]+).*~\1~gp;
619 }' \
620 | tr -s '\n' ' '
621 )"
484 622
485 # 5.1 introduces a new way to manage storage engines (plugins) 623 # 5.1 introduces a new way to manage storage engines (plugins)
486 # like configuration=none 624 # like configuration=none
625 # This base set are required, and will always be statically built.
487 local plugins="csv,myisam,myisammrg,heap" 626 local plugins_sta="csv myisam myisammrg heap"
627 local plugins_dyn=""
628 local plugins_dis="example ibmdb2i"
629
630 # These aren't actually required by the base set, but are really useful:
631 plugins_sta="${plugins_sta} archive blackhole"
632
633 # default in 5.5.4
634 if mysql_version_is_at_least "5.5.4" ; then
635 plugins_sta="${plugins_sta} partition"
636 fi
637 # Now the extras
488 if use extraengine ; then 638 if use extraengine ; then
489 # like configuration=max-no-ndb, archive and example removed in 5.1.11 639 # like configuration=max-no-ndb, archive and example removed in 5.1.11
490 # not added yet: ibmdb2i 640 # not added yet: ibmdb2i
491 # Not supporting as examples: example,daemon_example,ftexample 641 # Not supporting as examples: example,daemon_example,ftexample
492 plugins="${plugins},archive,blackhole,federated,partition" 642 plugins_sta="${plugins_sta} partition"
493 643
644 if [[ "${PN}" != "mariadb" ]] ; then
494 elog "Before using the Federated storage engine, please be sure to read" 645 elog "Before using the Federated storage engine, please be sure to read"
495 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 646 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
647 plugins_dyn="${plugins_sta} federated"
648 else
649 elog "MariaDB includes the FederatedX engine. Be sure to read"
650 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
651 plugins_dyn="${plugins_sta} federatedx"
652 fi
653 else
654 plugins_dis="${plugins_dis} partition federated"
496 fi 655 fi
497 656
498 # Upstream specifically requests that InnoDB always be built: 657 # Upstream specifically requests that InnoDB always be built:
499 # - innobase, innodb_plugin 658 # - innobase, innodb_plugin
500 # Build falcon if available for 6.x series. 659 # Build falcon if available for 6.x series.
501 for i in innobase innodb_plugin falcon ; do 660 for i in innobase falcon ; do
502 [ -e "${S}"/storage/${i} ] && plugins="${plugins},${i}" 661 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
503 done 662 done
663 for i in innodb_plugin ; do
664 [ -e "${S}"/storage/${i} ] && plugins_dyn="${plugins_dyn} ${i}"
665 done
504 666
505 # like configuration=max-no-ndb 667 # like configuration=max-no-ndb
506 if use cluster ; then 668 if ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) ; then
507 plugins="${plugins},ndbcluster" 669 plugins_sta="${plugins_sta} ndbcluster partition"
670 plugins_dis="${plugins_dis//partition}"
508 myconf="${myconf} --with-ndb-binlog" 671 myconf="${myconf} --with-ndb-binlog"
672 else
673 plugins_dis="${plugins_dis} ndbcluster"
674 fi
675
676 if [[ "${PN}" == "mariadb" ]] ; then
677 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
678 # caught above.
679 # This is not optional, without it several upstream testcases fail.
680 # Also strongly recommended by upstream.
681 if [[ "${PV}" < "5.2.0" ]] ; then
682 myconf="${myconf} --with-maria-tmp-tables"
683 plugins_sta="${plugins_sta} maria"
684 else
685 myconf="${myconf} --with-aria-tmp-tables"
686 plugins_sta="${plugins_sta} aria"
509 fi 687 fi
510 688
689 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] ||
690 die "The ${P} package doesn't provide innobase nor xtradb"
691
692 for i in innobase xtradb ; do
693 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
694 done
695
696 myconf="${myconf} $(use_with libevent)"
697
698 if mysql_version_is_at_least "5.2" ; then
699 #This should include sphinx, but the 5.2.4 archive forgot the plug.in file
700 #for i in oqgraph sphinx ; do
701 for i in oqgraph ; do
702 use ${i} \
703 && plugins_dyn="${plugins_dyn} ${i}" \
704 || plugins_dis="${plugins_dis} ${i}"
705 done
706 fi
707 fi
708
709 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then
710 use pbxt \
711 && plugins_dyn="${plugins_dyn} pbxt" \
712 || plugins_dis="${plugins_dis} pbxt"
713 fi
714
715 use static && \
716 plugins_sta="${plugins_sta} ${plugins_dyn}" && \
717 plugins_dyn=""
718
719 einfo "Available plugins: ${plugins_avail}"
720 einfo "Dynamic plugins: ${plugins_dyn}"
721 einfo "Static plugins: ${plugins_sta}"
722 einfo "Disabled plugins: ${plugins_dis}"
723
724 # These are the static plugins
511 myconf="${myconf} --with-plugins=${plugins}" 725 myconf="${myconf} --with-plugins=${plugins_sta// /,}"
512} 726 # And the disabled ones
513 727 for i in ${plugins_dis} ; do
514xtradb_applicable() { 728 myconf="${myconf} --without-plugin-${i}"
515 mysql_version_is_at_least "5.1.26" \ 729 done
516 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]] \
517 && use xtradb
518 return $?
519}
520
521pbxt_applicable() {
522 mysql_version_is_at_least "5.1.12" \
523 && [[ -n "${PBXT_VERSION}" ]] \
524 && use pbxt
525 return $?
526} 730}
527 731
528pbxt_src_configure() { 732pbxt_src_configure() {
529 mysql_init_vars 733 mysql_init_vars
530 734
531 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 735 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
532 736
533 einfo "Reconfiguring dir '${PWD}'" 737 einfo "Reconfiguring dir '${PWD}'"
534 AT_GNUCONF_UPDATE="yes" eautoreconf 738 eautoreconf
535 739
536 local myconf="" 740 local myconf=""
537 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}" 741 myconf="${myconf} --with-mysql=${S} --libdir=/usr/$(get_libdir)"
538 use debug && myconf="${myconf} --with-debug=full" 742 use debug && myconf="${myconf} --with-debug=full"
539 # TODO: is it safe/needed to use econf here ?
540 ./configure ${myconf} || die "Problem configuring PBXT storage engine" 743 econf ${myconf} || die "Problem configuring PBXT storage engine"
541} 744}
542 745
543pbxt_src_compile() { 746pbxt_src_compile() {
747
544 # Be backwards compatible for now 748 # Be backwards compatible for now
545 if [[ $EAPI != 2 ]]; then 749 if [[ $EAPI != 2 ]]; then
546 pbxt_src_configure 750 pbxt_src_configure
547 fi 751 fi
548 # TODO: is it safe/needed to use emake here ? 752 # TODO: is it safe/needed to use emake here ?
552 # TODO: modify test suite for PBXT 756 # TODO: modify test suite for PBXT
553} 757}
554 758
555pbxt_src_install() { 759pbxt_src_install() {
556 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 760 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
557 make install || die "Failed to install PBXT" 761 emake install DESTDIR="${D}" || die "Failed to install PBXT"
558 popd 762 popd
559} 763}
560 764
561# 765#
562# EBUILD FUNCTIONS 766# EBUILD FUNCTIONS
575 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root." 779 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
576 fi 780 fi
577 fi 781 fi
578 fi 782 fi
579 783
784 # bug 350844
785 case "${EAPI:-0}" in
786 0 | 1)
787 if use static && !built_with_use sys-libs/ncurses static-libs; then
788 die "To build MySQL statically you need to enable static-libs for sys-libs/ncurses"
789 fi
790 ;;
791 esac
792
580 # Check for USE flag problems in pkg_setup 793 # Check for USE flag problems in pkg_setup
581 if use static && use ssl ; then 794 if use static && use ssl ; then
582 eerror "MySQL does not support being built statically with SSL support enabled!"
583 die "MySQL does not support being built statically with SSL support enabled!" 795 M="MySQL does not support being built statically with SSL support enabled!"
796 eerror "${M}"
797 die "${M}"
798 fi
799
800 if mysql_version_is_at_least "5.1.51" \
801 && ! mysql_version_is_at_least "5.2" \
802 && use debug ; then
803 # Also in package.use.mask
804 die "Bug #344885: Upstream has broken USE=debug for 5.1 series >=5.1.51"
584 fi 805 fi
585 806
586 if ! mysql_version_is_at_least "5.0" \ 807 if ! mysql_version_is_at_least "5.0" \
587 && use raid \ 808 && use raid \
588 && use static ; then 809 && use static ; then
590 eerror "with RAID support enabled." 811 eerror "with RAID support enabled."
591 die "USE flags 'raid' and 'static' conflict!" 812 die "USE flags 'raid' and 'static' conflict!"
592 fi 813 fi
593 814
594 if mysql_version_is_at_least "4.1.3" \ 815 if mysql_version_is_at_least "4.1.3" \
595 && ( use cluster || use extraengine ) \ 816 && ( use cluster || use extraengine || use embedded ) \
596 && use minimal ; then 817 && use minimal ; then
597 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
598 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 818 M="USE flags 'cluster', 'extraengine', 'embedded' conflict with 'minimal' USE flag!"
819 eerror "${M}"
820 die "${M}"
599 fi 821 fi
600 822
601 # Bug #290570 fun. Upstream made us need a fairly new GCC4.
602 if mysql_version_is_at_least "5.0.83" ; then 823 if mysql_version_is_at_least "5.1" \
824 && xtradb_patch_available \
825 && use xtradb \
826 && use embedded ; then
827 M="USE flags 'xtradb' and 'embedded' conflict and cause build failures"
828 eerror "${M}"
829 die "${M}"
830 fi
831
832 # Bug #290570, 284946, 307251
833 # Upstream changes made us need a fairly new GCC4.
834 # But only for 5.0.8[3-6]!
835 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then
603 GCC_VER=$(gcc-version) 836 GCC_VER=$(gcc-version)
604 case ${GCC_VER} in 837 case ${GCC_VER} in
605 2*|3*|4.0|4.1|4.2) die "Active GCC too old! Must have at least GCC4.3" ;; 838 2*|3*|4.0|4.1|4.2)
839 eerror "Some releases of MySQL required a very new GCC, and then"
840 eerror "later release relaxed that requirement again. Either pick a"
841 eerror "MySQL >=5.0.87, or use a newer GCC."
842 die "Active GCC too old!" ;;
606 esac 843 esac
607 fi 844 fi
608 845
609 # This should come after all of the die statements 846 # This should come after all of the die statements
610 enewgroup mysql 60 || die "problem adding 'mysql' group" 847 enewgroup mysql 60 || die "problem adding 'mysql' group"
660 mysql_mv_patches 897 mysql_mv_patches
661 # And apply 898 # And apply
662 epatch 899 epatch
663 900
664 # last -fPIC fixup, per bug #305873 901 # last -fPIC fixup, per bug #305873
665 i="${S}"/storage/innodb_plugin/plug.in 902 i="${S}"/storage/innodb_plugin/plug.in
666 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}" 903 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
667 904
668 # Additional checks, remove bundled zlib 905 # Additional checks, remove bundled zlib (Cluster needs this, for static
906 # memory management in zlib, leave available for Cluster)
907 if [[ "${PN}" != "mysql-cluster" ]] ; then
669 rm -f "${S}/zlib/"*.[ch] 908 rm -f "${S}/zlib/"*.[ch]
670 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 909 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
910 fi
671 rm -f "scripts/mysqlbug" 911 rm -f "scripts/mysqlbug"
672 912
673 # Make charsets install in the right place 913 # Make charsets install in the right place
674 find . -name 'Makefile.am' \ 914 find . -name 'Makefile.am' \
675 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \; 915 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
685 rm -f "scripts/mysqlbug" 925 rm -f "scripts/mysqlbug"
686 fi 926 fi
687 927
688 local rebuilddirlist d 928 local rebuilddirlist d
689 929
690 if xtradb_applicable ; then 930 if xtradb_patch_available && use xtradb ; then
691 einfo "Replacing InnoDB with Percona XtraDB" 931 einfo "Adding storage engine: Percona XtraDB (replacing InnoDB)"
692 pushd "${S}"/storage 932 pushd "${S}"/storage >/dev/null
693 i="innobase" 933 i="innobase"
694 o="${WORKDIR}/storage-${i}.mysql-upstream" 934 o="${WORKDIR}/storage-${i}.mysql-upstream"
695 # Have we been here already? 935 # Have we been here already?
696 [ -h "${i}" ] && rm -f "${i}" 936 [ -d "${o}" ] && rm -f "${i}"
697 # Or maybe we haven't 937 # Or maybe we haven't
698 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}" 938 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
699 ln -s "${WORKDIR}/${XTRADB_P}" "${i}" 939 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}"
700 popd 940 popd >/dev/null
941 fi
942
943 if pbxt_patch_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then
944 einfo "Adding storage engine: PBXT"
945 pushd "${S}"/storage >/dev/null
946 i='pbxt'
947 [ -d "${i}" ] && rm -rf "${i}"
948 cp -ral "${WORKDIR}/${PBXT_P}" "${i}"
949 popd >/dev/null
701 fi 950 fi
702 951
703 if mysql_version_is_at_least "5.1.12" ; then 952 if mysql_version_is_at_least "5.1.12" ; then
704 einfo "Updating innobase cmake"
705 rebuilddirlist="." 953 rebuilddirlist="."
954 # This does not seem to be needed presently. robbat2 2010/02/23
955 #einfo "Updating innobase cmake"
706 # TODO: check this with a cmake expert 956 ## TODO: check this with a cmake expert
707 cmake \ 957 #cmake \
708 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \ 958 # -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
709 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \ 959 # -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
710 "storage/innobase" 960 # "storage/innobase"
711 else 961 else
712 rebuilddirlist=". innobase" 962 rebuilddirlist=". innobase"
713 fi 963 fi
714 964
715 for d in ${rebuilddirlist} ; do 965 for d in ${rebuilddirlist} ; do
716 einfo "Reconfiguring dir '${d}'" 966 einfo "Reconfiguring dir '${d}'"
717 pushd "${d}" &>/dev/null 967 pushd "${d}" &>/dev/null
718 AT_GNUCONF_UPDATE="yes" eautoreconf 968 eautoreconf
719 popd &>/dev/null 969 popd &>/dev/null
720 done 970 done
721 971
722 if mysql_check_version_range "4.1 to 5.0.99.99" \ 972 if mysql_check_version_range "4.1 to 5.0.99.99" \
723 && use berkdb ; then 973 && use berkdb ; then
779 export CXXFLAGS 1029 export CXXFLAGS
780 1030
781 # bug #283926, with GCC4.4, this is required to get correct behavior. 1031 # bug #283926, with GCC4.4, this is required to get correct behavior.
782 append-flags -fno-strict-aliasing 1032 append-flags -fno-strict-aliasing
783 1033
1034 # bug #335185, #335995, with >= GCC4.3.3 on x86 only, omit-frame-pointer
1035 # causes a mis-compile.
1036 # Upstream bugs:
1037 # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38562
1038 # http://bugs.mysql.com/bug.php?id=45205
1039 use x86 && version_is_at_least "4.3.3" "$(gcc-fullversion)" && \
1040 append-flags -fno-omit-frame-pointer && \
1041 filter-flags -fomit-frame-pointer
1042
784 econf \ 1043 econf \
785 --libexecdir="/usr/sbin" \ 1044 --libexecdir="/usr/sbin" \
786 --sysconfdir="${MY_SYSCONFDIR}" \ 1045 --sysconfdir="${MY_SYSCONFDIR}" \
787 --localstatedir="${MY_LOCALSTATEDIR}" \ 1046 --localstatedir="${MY_LOCALSTATEDIR}" \
788 --sharedstatedir="${MY_SHAREDSTATEDIR}" \ 1047 --sharedstatedir="${MY_SHAREDSTATEDIR}" \
791 --with-low-memory \ 1050 --with-low-memory \
792 --with-client-ldflags=-lstdc++ \ 1051 --with-client-ldflags=-lstdc++ \
793 --enable-thread-safe-client \ 1052 --enable-thread-safe-client \
794 --with-comment="Gentoo Linux ${PF}" \ 1053 --with-comment="Gentoo Linux ${PF}" \
795 --without-docs \ 1054 --without-docs \
1055 --with-LIBDIR="$(get_libdir)" \
796 ${myconf} || die "econf failed" 1056 ${myconf} || die "econf failed"
797 1057
798 # TODO: Move this before autoreconf !!! 1058 # TODO: Move this before autoreconf !!!
799 find . -type f -name Makefile -print0 \ 1059 find . -type f -name Makefile -print0 \
800 | xargs -0 -n100 sed -i \ 1060 | xargs -0 -n100 sed -i \
801 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 1061 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
802 1062
803 if [[ $EAPI == 2 ]]; then 1063 if [[ $EAPI == 2 ]] && [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
804 pbxt_applicable && pbxt_src_configure 1064 pbxt_patch_available && use pbxt && pbxt_src_configure
805 fi 1065 fi
806} 1066}
807 1067
808# @FUNCTION: mysql_src_compile 1068# @FUNCTION: mysql_src_compile
809# @DESCRIPTION: 1069# @DESCRIPTION:
810# Compile the mysql code. 1070# Compile the mysql code.
811mysql_src_compile() { 1071mysql_src_compile() {
812 # Be backwards compatible for now 1072 # Be backwards compatible for now
813 case ${EAPI:-0} in 1073 case ${EAPI:-0} in
814 2) : ;; 1074 2) : ;;
815 0 | 1) mysql_src_configure ;; 1075 0 | 1) mysql_src_configure ;;
816 esac 1076 esac
817 1077
818 emake || die "emake failed" 1078 emake || die "emake failed"
819 1079
820 pbxt_applicable && pbxt_src_compile 1080 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1081 pbxt_patch_available && use pbxt && pbxt_src_compile
1082 fi
821} 1083}
822 1084
823# @FUNCTION: mysql_src_install 1085# @FUNCTION: mysql_src_install
824# @DESCRIPTION: 1086# @DESCRIPTION:
825# Install mysql. 1087# Install mysql.
831 DESTDIR="${D}" \ 1093 DESTDIR="${D}" \
832 benchdir_root="${MY_SHAREDSTATEDIR}" \ 1094 benchdir_root="${MY_SHAREDSTATEDIR}" \
833 testroot="${MY_SHAREDSTATEDIR}" \ 1095 testroot="${MY_SHAREDSTATEDIR}" \
834 || die "emake install failed" 1096 || die "emake install failed"
835 1097
836 pbxt_applicable && pbxt_src_install 1098 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1099 pbxt_patch_available && use pbxt && pbxt_src_install
1100 fi
837 1101
838 # Convenience links 1102 # Convenience links
839 einfo "Making Convenience links for mysqlcheck multi-call binary" 1103 einfo "Making Convenience links for mysqlcheck multi-call binary"
840 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze" 1104 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
841 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair" 1105 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
865 if use !test ; then 1129 if use !test ; then
866 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test 1130 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
867 fi 1131 fi
868 1132
869 # Configuration stuff 1133 # Configuration stuff
870 if mysql_version_is_at_least "4.1" ; then 1134 case ${MYSQL_PV_MAJOR} in
871 mysql_mycnf_version="4.1"
872 else
873 mysql_mycnf_version="4.0" 1135 3*|4.0) mysql_mycnf_version="4.0" ;;
874 fi 1136 4.[1-9]|5.0) mysql_mycnf_version="4.1" ;;
875 einfo "Building default my.cnf" 1137 5.[1-9]|6*|7*) mysql_mycnf_version="5.1" ;;
1138 esac
1139 einfo "Building default my.cnf (${mysql_mycnf_version})"
876 insinto "${MY_SYSCONFDIR}" 1140 insinto "${MY_SYSCONFDIR}"
877 doins scripts/mysqlaccess.conf 1141 doins scripts/mysqlaccess.conf
1142 mycnf_src="my.cnf-${mysql_mycnf_version}"
878 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \ 1143 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
879 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \ 1144 "${FILESDIR}/${mycnf_src}" \
880 > "${TMPDIR}/my.cnf.ok" 1145 > "${TMPDIR}/my.cnf.ok"
881 if mysql_version_is_at_least "4.1" && use latin1 ; then 1146 if use latin1 ; then
882 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok" 1147 sed -i \
1148 -e "/character-set/s|utf8|latin1|g" \
1149 "${TMPDIR}/my.cnf.ok"
883 fi 1150 fi
884 newins "${TMPDIR}/my.cnf.ok" my.cnf 1151 newins "${TMPDIR}/my.cnf.ok" my.cnf
885 1152
886 # Minimal builds don't have the MySQL server 1153 # Minimal builds don't have the MySQL server
887 if ! use minimal ; then 1154 if ! use minimal ; then
914 for script in \ 1181 for script in \
915 "${S}"/support-files/my-*.cnf \ 1182 "${S}"/support-files/my-*.cnf \
916 "${S}"/support-files/magic \ 1183 "${S}"/support-files/magic \
917 "${S}"/support-files/ndb-config-2-node.ini 1184 "${S}"/support-files/ndb-config-2-node.ini
918 do 1185 do
919 dodoc "${script}" 1186 [[ -f "$script" ]] && dodoc "${script}"
920 done 1187 done
921 1188
922 docinto "scripts" 1189 docinto "scripts"
923 for script in "${S}"/scripts/mysql* ; do 1190 for script in "${S}"/scripts/mysql* ; do
924 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1191 [[ -f "$script" ]] && [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
925 done 1192 done
926 1193
927 fi 1194 fi
928 1195
929 mysql_lib_symlinks "${D}" 1196 mysql_lib_symlinks "${D}"
963 for script in \ 1230 for script in \
964 support-files/my-*.cnf \ 1231 support-files/my-*.cnf \
965 support-files/magic \ 1232 support-files/magic \
966 support-files/ndb-config-2-node.ini 1233 support-files/ndb-config-2-node.ini
967 do 1234 do
1235 [[ -f "${script}" ]] \
968 dodoc "${script}" 1236 && dodoc "${script}"
969 done 1237 done
970 1238
971 docinto "scripts" 1239 docinto "scripts"
972 for script in scripts/mysql* ; do 1240 for script in scripts/mysql* ; do
1241 [[ -f "${script}" ]] \
973 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1242 && [[ "${script%.sh}" == "${script}" ]] \
1243 && dodoc "${script}"
974 done 1244 done
975 1245
976 einfo 1246 einfo
977 elog "You might want to run:" 1247 elog "You might want to run:"
978 elog "\"emerge --config =${CATEGORY}/${PF}\"" 1248 elog "\"emerge --config =${CATEGORY}/${PF}\""
979 elog "if this is a new install." 1249 elog "if this is a new install."
980 einfo 1250 einfo
981 fi
982 1251
983 if pbxt_applicable ; then 1252 einfo
1253 elog "If you are upgrading major versions, you should run the"
1254 elog "mysql_upgrade tool."
1255 einfo
1256 fi
1257
1258 if pbxt_available && use pbxt ; then
984 # TODO: explain it better 1259 # TODO: explain it better
985 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';" 1260 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
986 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;" 1261 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
987 elog "if, after that, you cannot start the MySQL server," 1262 elog "if, after that, you cannot start the MySQL server,"
988 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then" 1263 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
1039 fi 1314 fi
1040 fi 1315 fi
1041 1316
1042 local pwd1="a" 1317 local pwd1="a"
1043 local pwd2="b" 1318 local pwd2="b"
1044 local maxtry=5 1319 local maxtry=15
1320
1321 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${ROOT}/root/.my.cnf" ]; then
1322 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${ROOT}/root/.my.cnf")"
1323 fi
1045 1324
1046 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then 1325 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
1047 ewarn "You have already a MySQL database in place." 1326 ewarn "You have already a MySQL database in place."
1048 ewarn "(${ROOT}/${MY_DATADIR}/*)" 1327 ewarn "(${ROOT}/${MY_DATADIR}/*)"
1049 ewarn "Please rename or delete it if you wish to replace it." 1328 ewarn "Please rename or delete it if you wish to replace it."
1052 1331
1053 # Bug #213475 - MySQL _will_ object strenously if your machine is named 1332 # Bug #213475 - MySQL _will_ object strenously if your machine is named
1054 # localhost. Also causes weird failures. 1333 # localhost. Also causes weird failures.
1055 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost" 1334 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
1056 1335
1057 einfo "Creating the mysql database and setting proper" 1336 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
1058 einfo "permissions on it ..."
1059 1337
1060 einfo "Insert a password for the mysql 'root' user" 1338 einfo "Please provide a password for the mysql 'root' user now, in the"
1339 einfo "MYSQL_ROOT_PASSWORD env var or through the /root/.my.cnf file."
1061 ewarn "Avoid [\"'\\_%] characters in the password" 1340 ewarn "Avoid [\"'\\_%] characters in the password"
1062 read -rsp " >" pwd1 ; echo 1341 read -rsp " >" pwd1 ; echo
1063 1342
1064 einfo "Retype the password" 1343 einfo "Retype the password"
1065 read -rsp " >" pwd2 ; echo 1344 read -rsp " >" pwd2 ; echo
1066 1345
1067 if [[ "x$pwd1" != "x$pwd2" ]] ; then 1346 if [[ "x$pwd1" != "x$pwd2" ]] ; then
1068 die "Passwords are not the same" 1347 die "Passwords are not the same"
1348 fi
1349 MYSQL_ROOT_PASSWORD="${pwd1}"
1350 unset pwd1 pwd2
1069 fi 1351 fi
1070 1352
1071 local options="" 1353 local options=""
1072 local sqltmp="$(emktemp)" 1354 local sqltmp="$(emktemp)"
1073 1355
1087 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \ 1369 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
1088 || die "MySQL databases not installed" 1370 || die "MySQL databases not installed"
1089 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null 1371 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
1090 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null 1372 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
1091 1373
1374 # Figure out which options we need to disable to do the setup
1375 helpfile="${TMPDIR}/mysqld-help"
1376 ${ROOT}/usr/sbin/mysqld --verbose --help >"${helpfile}" 2>/dev/null
1377 for opt in grant-tables host-cache name-resolve networking slave-start bdb \
1378 federated innodb ssl log-bin relay-log slow-query-log external-locking \
1379 ndbcluster \
1380 ; do
1381 optexp="--(skip-)?${opt}" optfull="--skip-${opt}"
1382 egrep -sq -- "${optexp}" "${helpfile}" && options="${options} ${optfull}"
1383 done
1384 # But some options changed names
1385 egrep -sq external-locking "${helpfile}" && \
1386 options="${options/skip-locking/skip-external-locking}"
1387
1092 if mysql_version_is_at_least "4.1.3" ; then 1388 if mysql_version_is_at_least "4.1.3" ; then
1093 options="--skip-ndbcluster"
1094
1095 # Filling timezones, see 1389 # Filling timezones, see
1096 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html 1390 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
1097 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null 1391 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
1098 1392
1099 if [[ -r "${help_tables}" ]] ; then 1393 if [[ -r "${help_tables}" ]] ; then
1100 cat "${help_tables}" >> "${sqltmp}" 1394 cat "${help_tables}" >> "${sqltmp}"
1101 fi 1395 fi
1102 fi 1396 fi
1397
1398 einfo "Creating the mysql database and setting proper"
1399 einfo "permissions on it ..."
1103 1400
1104 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock" 1401 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock"
1105 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid" 1402 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid"
1106 local mysqld="${ROOT}/usr/sbin/mysqld \ 1403 local mysqld="${ROOT}/usr/sbin/mysqld \
1107 ${options} \ 1404 ${options} \
1108 --user=mysql \ 1405 --user=mysql \
1109 --skip-grant-tables \
1110 --basedir=${ROOT}/usr \ 1406 --basedir=${ROOT}/usr \
1111 --datadir=${ROOT}/${MY_DATADIR} \ 1407 --datadir=${ROOT}/${MY_DATADIR} \
1112 --skip-innodb \
1113 --skip-bdb \
1114 --skip-networking \
1115 --max_allowed_packet=8M \ 1408 --max_allowed_packet=8M \
1116 --net_buffer_length=16K \ 1409 --net_buffer_length=16K \
1410 --default-storage-engine=MyISAM \
1117 --socket=${socket} \ 1411 --socket=${socket} \
1118 --pid-file=${pidfile}" 1412 --pid-file=${pidfile}"
1413 #einfo "About to start mysqld: ${mysqld}"
1414 ebegin "Starting mysqld"
1119 ${mysqld} & 1415 ${mysqld} &
1416 rc=$?
1120 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do 1417 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
1121 maxtry=$((${maxtry}-1)) 1418 maxtry=$((${maxtry}-1))
1122 echo -n "." 1419 echo -n "."
1123 sleep 1 1420 sleep 1
1124 done 1421 done
1422 eend $rc
1125 1423
1424 if ! [[ -S "${socket}" ]]; then
1425 die "Completely failed to start up mysqld with: ${mysqld}"
1426 fi
1427
1428 ebegin "Setting root password"
1126 # Do this from memory, as we don't want clear text passwords in temp files 1429 # Do this from memory, as we don't want clear text passwords in temp files
1127 local sql="UPDATE mysql.user SET Password = PASSWORD('${pwd1}') WHERE USER='root'" 1430 local sql="UPDATE mysql.user SET Password = PASSWORD('${MYSQL_ROOT_PASSWORD}') WHERE USER='root'"
1128 "${ROOT}/usr/bin/mysql" \ 1431 "${ROOT}/usr/bin/mysql" \
1129 --socket=${socket} \ 1432 --socket=${socket} \
1130 -hlocalhost \ 1433 -hlocalhost \
1131 -e "${sql}" 1434 -e "${sql}"
1435 eend $?
1132 1436
1133 einfo "Loading \"zoneinfo\", this step may require a few seconds ..." 1437 ebegin "Loading \"zoneinfo\", this step may require a few seconds ..."
1134
1135 "${ROOT}/usr/bin/mysql" \ 1438 "${ROOT}/usr/bin/mysql" \
1136 --socket=${socket} \ 1439 --socket=${socket} \
1137 -hlocalhost \ 1440 -hlocalhost \
1138 -uroot \ 1441 -uroot \
1139 -p"${pwd1}" \ 1442 -p"${MYSQL_ROOT_PASSWORD}" \
1140 mysql < "${sqltmp}" 1443 mysql < "${sqltmp}"
1444 rc=$?
1445 eend $?
1446 [ $rc -ne 0 ] && ewarn "Failed to load zoneinfo!"
1141 1447
1142 # Stop the server and cleanup 1448 # Stop the server and cleanup
1449 einfo "Stopping the server ..."
1143 kill $(< "${pidfile}" ) 1450 kill $(< "${pidfile}" )
1144 rm -f "${sqltmp}" 1451 rm -f "${sqltmp}"
1145 einfo "Stopping the server ..."
1146 wait %1 1452 wait %1
1147 einfo "Done" 1453 einfo "Done"
1148} 1454}
1149 1455
1150# @FUNCTION: mysql_pkg_postrm 1456# @FUNCTION: mysql_pkg_postrm

Legend:
Removed from v.1.133  
changed lines
  Added in v.1.159

  ViewVC Help
Powered by ViewVC 1.1.20