/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.153 Revision 1.163
1# Copyright 1999-2009 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.153 2010/10/27 07:19:24 robbat2 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.163 2011/08/21 16:14:56 jmbsvicetto Exp $
4 4
5# @ECLASS: mysql.eclass 5# @ECLASS: mysql.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 7# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
8# Maintainers: MySQL Team <mysql-bugs@gentoo.org> 8# Maintainers: MySQL Team <mysql-bugs@gentoo.org>
143 143
144RDEPEND="${DEPEND} 144RDEPEND="${DEPEND}
145 !minimal? ( dev-db/mysql-init-scripts ) 145 !minimal? ( dev-db/mysql-init-scripts )
146 selinux? ( sec-policy/selinux-mysql )" 146 selinux? ( sec-policy/selinux-mysql )"
147 147
148DEPEND="${DEPEND}
149 virtual/yacc"
150
151if [ "${EAPI:-0}" = "2" ]; then
152 DEPEND="${DEPEND} static? ( || ( sys-libs/ncurses[static-libs] <=sys-libs/ncurses-5.7-r3 ) )"
153fi
154
148# compile-time-only 155# compile-time-only
149mysql_version_is_at_least "5.1" \ 156mysql_version_is_at_least "5.1" \
150|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )" 157|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
151 158
152# compile-time-only 159# compile-time-only
153mysql_version_is_at_least "5.1.12" \ 160mysql_version_is_at_least "5.1.12" \
154&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3" 161&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
162
163[[ "${PN}" == "mariadb" ]] \
164&& mysql_version_is_at_least "5.2" \
165&& DEPEND="${DEPEND} oqgraph? ( >=dev-libs/boost-1.40.0 )"
166#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
167# sphinx? ( app-misc/sphinx )"
155 168
156# dev-perl/DBD-mysql is needed by some scripts installed by MySQL 169# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
157PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 170PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
158 171
159# For other stuff to bring us in 172# For other stuff to bring us in
238[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \ 251[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
239&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling" 252&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
240 253
241[[ "${PN}" == "mariadb" ]] \ 254[[ "${PN}" == "mariadb" ]] \
242&& IUSE="${IUSE} libevent" 255&& IUSE="${IUSE} libevent"
256
257[[ "${PN}" == "mariadb" ]] \
258&& mysql_version_is_at_least "5.2" \
259&& IUSE="${IUSE} oqgraph"
260#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
261#&& IUSE="${IUSE} oqgraph sphinx"
243 262
244# MariaDB has integrated PBXT 263# MariaDB has integrated PBXT
245# PBXT_VERSION means that we have a PBXT patch for this PV 264# PBXT_VERSION means that we have a PBXT patch for this PV
246# PBXT was only introduced after 5.1.12 265# PBXT was only introduced after 5.1.12
247pbxt_patch_available() { 266pbxt_patch_available() {
571 myconf="${myconf} --with-readline" 590 myconf="${myconf} --with-readline"
572 myconf="${myconf} --with-zlib-dir=/usr/" 591 myconf="${myconf} --with-zlib-dir=/usr/"
573 myconf="${myconf} --without-pstack" 592 myconf="${myconf} --without-pstack"
574 myconf="${myconf} --with-plugindir=/usr/$(get_libdir)/mysql/plugin" 593 myconf="${myconf} --with-plugindir=/usr/$(get_libdir)/mysql/plugin"
575 594
595 # This is an explict die here, because if we just forcibly disable it, then the
596 # user's data is not accessible.
597 use max-idx-128 && die "Bug #336027: upstream has a corruption issue with max-idx-128 presently"
576 use max-idx-128 && myconf="${myconf} --with-max-indexes=128" 598 #use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
577 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then 599 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
578 myconf="${myconf} $(use_enable community community-features)" 600 myconf="${myconf} $(use_enable community community-features)"
579 if use community; then 601 if use community; then
580 myconf="${myconf} $(use_enable profiling)" 602 myconf="${myconf} $(use_enable profiling)"
581 else 603 else
617 fi 639 fi
618 # Now the extras 640 # Now the extras
619 if use extraengine ; then 641 if use extraengine ; then
620 # like configuration=max-no-ndb, archive and example removed in 5.1.11 642 # like configuration=max-no-ndb, archive and example removed in 5.1.11
621 # not added yet: ibmdb2i 643 # not added yet: ibmdb2i
622 # Not supporting as examples: example,daemon_example,ftexample 644 # Not supporting as examples: example,daemon_example,ftexample
623 plugins_sta="${plugins_sta} partition" 645 plugins_sta="${plugins_sta} partition"
624 plugins_dyn="${plugins_sta} federated"
625 646
626 if [[ "${PN}" != "mariadb" ]] ; then 647 if [[ "${PN}" != "mariadb" ]] ; then
627 elog "Before using the Federated storage engine, please be sure to read" 648 elog "Before using the Federated storage engine, please be sure to read"
628 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 649 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
650 plugins_dyn="${plugins_sta} federated"
629 else 651 else
630 elog "MariaDB includes the FederatedX engine. Be sure to read" 652 elog "MariaDB includes the FederatedX engine. Be sure to read"
631 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine" 653 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
654 plugins_dyn="${plugins_sta} federatedx"
632 fi 655 fi
633 else 656 else
634 plugins_dis="${plugins_dis} partition federated" 657 plugins_dis="${plugins_dis} partition federated"
635 fi 658 fi
636 659
654 fi 677 fi
655 678
656 if [[ "${PN}" == "mariadb" ]] ; then 679 if [[ "${PN}" == "mariadb" ]] ; then
657 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not 680 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
658 # caught above. 681 # caught above.
682 # This is not optional, without it several upstream testcases fail.
683 # Also strongly recommended by upstream.
684 if [[ "${PV}" < "5.2.0" ]] ; then
685 myconf="${myconf} --with-maria-tmp-tables"
659 plugins_sta="${plugins_sta} maria" 686 plugins_sta="${plugins_sta} maria"
687 else
688 myconf="${myconf} --with-aria-tmp-tables"
689 plugins_sta="${plugins_sta} aria"
690 fi
660 691
661 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] || 692 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] ||
662 die "The ${P} package doesn't provide innobase nor xtradb" 693 die "The ${P} package doesn't provide innobase nor xtradb"
663 694
664 for i in innobase xtradb ; do 695 for i in innobase xtradb ; do
665 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}" 696 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
666 done 697 done
667 698
668 myconf="${myconf} $(use_with libevent)" 699 myconf="${myconf} $(use_with libevent)"
669 # This is not optional, without it several upstream testcases fail. 700
670 # Also strongly recommended by upstream. 701 if mysql_version_is_at_least "5.2" ; then
671 myconf="${myconf} --with-maria-tmp-tables" 702 #This should include sphinx, but the 5.2.4 archive forgot the plug.in file
703 #for i in oqgraph sphinx ; do
704 for i in oqgraph ; do
705 use ${i} \
706 && plugins_dyn="${plugins_dyn} ${i}" \
707 || plugins_dis="${plugins_dis} ${i}"
708 done
709 fi
672 fi 710 fi
673 711
674 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then 712 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then
675 use pbxt \ 713 use pbxt \
676 && plugins_dyn="${plugins_dyn} pbxt" \ 714 && plugins_dyn="${plugins_dyn} pbxt" \
736# die if FEATURES="test", USE="-minimal" and not using FEATURES="userpriv" 774# die if FEATURES="test", USE="-minimal" and not using FEATURES="userpriv"
737# check for conflicting use flags 775# check for conflicting use flags
738# create new user and group for mysql 776# create new user and group for mysql
739# warn about deprecated features 777# warn about deprecated features
740mysql_pkg_setup() { 778mysql_pkg_setup() {
741 if hasq test ${FEATURES} ; then 779 if has test ${FEATURES} ; then
742 if ! use minimal ; then 780 if ! use minimal ; then
743 if [[ $UID -eq 0 ]]; then 781 if [[ $UID -eq 0 ]]; then
744 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root." 782 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
745 fi 783 fi
746 fi 784 fi
747 fi 785 fi
786
787 # bug 350844
788 case "${EAPI:-0}" in
789 0 | 1)
790 if use static && !built_with_use sys-libs/ncurses static-libs; then
791 die "To build MySQL statically you need to enable static-libs for sys-libs/ncurses"
792 fi
793 ;;
794 esac
748 795
749 # Check for USE flag problems in pkg_setup 796 # Check for USE flag problems in pkg_setup
750 if use static && use ssl ; then 797 if use static && use ssl ; then
751 M="MySQL does not support being built statically with SSL support enabled!" 798 M="MySQL does not support being built statically with SSL support enabled!"
752 eerror "${M}" 799 eerror "${M}"
753 die "${M}" 800 die "${M}"
801 fi
802
803 if mysql_version_is_at_least "5.1.51" \
804 && ! mysql_version_is_at_least "5.2" \
805 && use debug ; then
806 # Also in package.use.mask
807 die "Bug #344885: Upstream has broken USE=debug for 5.1 series >=5.1.51"
754 fi 808 fi
755 809
756 if ! mysql_version_is_at_least "5.0" \ 810 if ! mysql_version_is_at_least "5.0" \
757 && use raid \ 811 && use raid \
758 && use static ; then 812 && use static ; then
782 # Upstream changes made us need a fairly new GCC4. 836 # Upstream changes made us need a fairly new GCC4.
783 # But only for 5.0.8[3-6]! 837 # But only for 5.0.8[3-6]!
784 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then 838 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then
785 GCC_VER=$(gcc-version) 839 GCC_VER=$(gcc-version)
786 case ${GCC_VER} in 840 case ${GCC_VER} in
787 2*|3*|4.0|4.1|4.2) 841 2*|3*|4.0|4.1|4.2)
788 eerror "Some releases of MySQL required a very new GCC, and then" 842 eerror "Some releases of MySQL required a very new GCC, and then"
789 eerror "later release relaxed that requirement again. Either pick a" 843 eerror "later release relaxed that requirement again. Either pick a"
790 eerror "MySQL >=5.0.87, or use a newer GCC." 844 eerror "MySQL >=5.0.87, or use a newer GCC."
791 die "Active GCC too old!" ;; 845 die "Active GCC too old!" ;;
792 esac 846 esac
887 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}" 941 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
888 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}" 942 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}"
889 popd >/dev/null 943 popd >/dev/null
890 fi 944 fi
891 945
892 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then 946 if pbxt_patch_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then
893 einfo "Adding storage engine: PBXT" 947 einfo "Adding storage engine: PBXT"
894 pushd "${S}"/storage >/dev/null 948 pushd "${S}"/storage >/dev/null
895 i='pbxt' 949 i='pbxt'
896 [ -d "${i}" ] && rm -rf "${i}" 950 [ -d "${i}" ] && rm -rf "${i}"
897 cp -ral "${WORKDIR}/${PBXT_P}" "${i}" 951 cp -ral "${WORKDIR}/${PBXT_P}" "${i}"
977 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 1031 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
978 export CXXFLAGS 1032 export CXXFLAGS
979 1033
980 # bug #283926, with GCC4.4, this is required to get correct behavior. 1034 # bug #283926, with GCC4.4, this is required to get correct behavior.
981 append-flags -fno-strict-aliasing 1035 append-flags -fno-strict-aliasing
982 1036
983 # bug #335185, with GCC4.5 on x86 only, omit-frame-pointer causes a 1037 # bug #335185, #335995, with >= GCC4.3.3 on x86 only, omit-frame-pointer
984 # mis-compile 1038 # causes a mis-compile.
985 use x86 && [[ "$(gcc-version)" == "4.5" ]] && \ 1039 # Upstream bugs:
1040 # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38562
1041 # http://bugs.mysql.com/bug.php?id=45205
1042 use x86 && version_is_at_least "4.3.3" "$(gcc-fullversion)" && \
986 append-flags -fno-omit-frame-pointer && \ 1043 append-flags -fno-omit-frame-pointer && \
987 filter-flags -fomit-frame-pointer 1044 filter-flags -fomit-frame-pointer
988 1045
989 econf \ 1046 econf \
990 --libexecdir="/usr/sbin" \ 1047 --libexecdir="/usr/sbin" \
996 --with-low-memory \ 1053 --with-low-memory \
997 --with-client-ldflags=-lstdc++ \ 1054 --with-client-ldflags=-lstdc++ \
998 --enable-thread-safe-client \ 1055 --enable-thread-safe-client \
999 --with-comment="Gentoo Linux ${PF}" \ 1056 --with-comment="Gentoo Linux ${PF}" \
1000 --without-docs \ 1057 --without-docs \
1058 --with-LIBDIR="$(get_libdir)" \
1001 ${myconf} || die "econf failed" 1059 ${myconf} || die "econf failed"
1002 1060
1003 # TODO: Move this before autoreconf !!! 1061 # TODO: Move this before autoreconf !!!
1004 find . -type f -name Makefile -print0 \ 1062 find . -type f -name Makefile -print0 \
1005 | xargs -0 -n100 sed -i \ 1063 | xargs -0 -n100 sed -i \
1114 done 1172 done
1115 fi 1173 fi
1116 1174
1117 # Docs 1175 # Docs
1118 einfo "Installing docs" 1176 einfo "Installing docs"
1119 dodoc README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 1177 for i in README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE ; do
1178 [[ -f "$i" ]] && dodoc "$i"
1179 done
1120 doinfo "${S}"/Docs/mysql.info 1180 doinfo "${S}"/Docs/mysql.info
1121 1181
1122 # Minimal builds don't have the MySQL server 1182 # Minimal builds don't have the MySQL server
1123 if ! use minimal ; then 1183 if ! use minimal ; then
1124 einfo "Including support files and sample configurations" 1184 einfo "Including support files and sample configurations"
1259 fi 1319 fi
1260 fi 1320 fi
1261 1321
1262 local pwd1="a" 1322 local pwd1="a"
1263 local pwd2="b" 1323 local pwd2="b"
1264 local MYSQL_ROOT_PASSWORD=''
1265 local maxtry=15 1324 local maxtry=15
1266 1325
1267 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${ROOT}/root/.my.cnf" ]; then 1326 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${ROOT}/root/.my.cnf" ]; then
1268 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${ROOT}/root/.my.cnf")" 1327 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${ROOT}/root/.my.cnf")"
1269 fi 1328 fi
1279 # localhost. Also causes weird failures. 1338 # localhost. Also causes weird failures.
1280 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost" 1339 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
1281 1340
1282 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then 1341 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
1283 1342
1284 einfo "Please provide a password for the mysql 'root' user now," 1343 einfo "Please provide a password for the mysql 'root' user now, in the"
1285 einfo "or in the MYSQL_ROOT_PASSWORD env var." 1344 einfo "MYSQL_ROOT_PASSWORD env var or through the /root/.my.cnf file."
1286 ewarn "Avoid [\"'\\_%] characters in the password" 1345 ewarn "Avoid [\"'\\_%] characters in the password"
1287 read -rsp " >" pwd1 ; echo 1346 read -rsp " >" pwd1 ; echo
1288 1347
1289 einfo "Retype the password" 1348 einfo "Retype the password"
1290 read -rsp " >" pwd2 ; echo 1349 read -rsp " >" pwd2 ; echo

Legend:
Removed from v.1.153  
changed lines
  Added in v.1.163

  ViewVC Help
Powered by ViewVC 1.1.20