/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.25 Revision 1.166
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.25 2006/03/16 20:39:00 vivo Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.166 2011/09/25 12:43:28 grobian Exp $
4 4
5# Author: Francesco Riosa <vivo at gentoo.org> 5# @ECLASS: mysql.eclass
6# Maintainer: Francesco Riosa <vivo at gentoo.org> 6# @MAINTAINER:
7# MySQL Team <mysql-bugs@gentoo.org>
8# Luca Longinotti <chtekk@gentoo.org>
9# Robin H. Johnson <robbat2@gentoo.org>
10# @AUTHOR:
11# Francesco Riosa (Retired) <vivo@gentoo.org>
12# @BLURB: This eclass provides most of the functions for mysql ebuilds
13# @DESCRIPTION:
14# The mysql.eclass provides almost all the code to build the mysql ebuilds
15# including the src_unpack, src_prepare, src_configure, src_compile,
16# scr_install, pkg_preinst, pkg_postinst, pkg_config and pkg_postrm
17# phase hooks.
7 18
19WANT_AUTOCONF="latest"
20WANT_AUTOMAKE="latest"
21
8inherit eutils flag-o-matic gnuconfig autotools mysql_fx 22inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator toolchain-funcs
9 23
10#major, minor only in the slot
11SLOT=$(( ${MYSQL_VERSION_ID} / 10000 ))
12
13# shorten the path because the socket path length must be shorter than 107 chars 24# Shorten the path because the socket path length must be shorter than 107 chars
14# and we will run a mysql server during test phase 25# and we will run a mysql server during test phase
15S="${WORKDIR}/${PN}" 26S="${WORKDIR}/mysql"
16 27
28[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z"
29if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
30 EGIT_PROJECT=mysql-extras
31 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
32 inherit git
33fi
34
35case "${EAPI:-0}" in
36 2)
37 EXPORT_FUNCTIONS pkg_setup \
38 src_unpack src_prepare \
39 src_configure src_compile \
40 src_install \
41 pkg_preinst pkg_postinst \
42 pkg_config pkg_postrm
43 IUSE_DEFAULT_ON='+'
44 ;;
45 0 | 1)
46 EXPORT_FUNCTIONS pkg_setup \
47 src_unpack \
48 src_compile \
49 src_install \
50 pkg_preinst pkg_postinst \
51 pkg_config pkg_postrm
52 ;;
53 *)
54 die "Unsupported EAPI: ${EAPI}" ;;
55esac
56
57
58# @ECLASS-VARIABLE: MYSQL_PV_MAJOR
59# @DESCRIPTION:
60# Upstream MySQL considers the first two parts of the version number to be the
61# major version. Upgrades that change major version should always run
62# mysql_upgrade.
63MYSQL_PV_MAJOR="$(get_version_component_range 1-2 ${PV})"
64
65# Cluster is a special case...
66if [[ "${PN}" == "mysql-cluster" ]]; then
67 case $PV in
68 6.1*|7.0*|7.1*) MYSQL_PV_MAJOR=5.1 ;;
69 esac
70fi
71
72
73# @ECLASS-VARIABLE: MYSQL_VERSION_ID
74# @DESCRIPTION:
75# MYSQL_VERSION_ID will be:
76# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
77# This is an important part, because many of the choices the MySQL ebuild will do
78# depend on this variable.
79# In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803"
80# We also strip off upstream's trailing letter that they use to respin tarballs
81
82MYSQL_VERSION_ID=""
83tpv="${PV%[a-z]}"
84tpv=( ${tpv//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}"
85for vatom in 0 1 2 3 ; do
86 # pad to length 2
87 tpv[${vatom}]="00${tpv[${vatom}]}"
88 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}"
89done
90# strip leading "0" (otherwise it's considered an octal number by BASH)
91MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"}
92
93# @ECLASS-VARIABLE: MYSQL_COMMUNITY_FEATURES
94# @DESCRIPTION:
95# Specifiy if community features are available. Possible values are 1 (yes)
96# and 0 (no).
97# Community features are available in mysql-community
98# AND in the re-merged mysql-5.0.82 and newer
99if [ "${PN}" == "mysql-community" -o "${PN}" == "mariadb" ]; then
100 MYSQL_COMMUNITY_FEATURES=1
101elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
102 MYSQL_COMMUNITY_FEATURES=1
103elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
104 MYSQL_COMMUNITY_FEATURES=1
105elif [ "${PV#5.4}" != "${PV}" ] ; then
106 MYSQL_COMMUNITY_FEATURES=1
107elif [ "${PV#5.5}" != "${PV}" ] ; then
108 MYSQL_COMMUNITY_FEATURES=1
109elif [ "${PV#6}" != "${PV}" ] ; then
110 MYSQL_COMMUNITY_FEATURES=1
111elif [ "${PV#7}" != "${PV}" ] ; then
112 MYSQL_COMMUNITY_FEATURES=1
113else
114 MYSQL_COMMUNITY_FEATURES=0
115fi
116
117# @ECLASS-VARIABLE: XTRADB_VER
118# @DESCRIPTION:
119# Version of the XTRADB storage engine
120XTRADB_VER="${XTRADB_VER}"
121
122# @ECLASS-VARIABLE: PERCONA_VER
123# @DESCRIPTION:
124# Designation by PERCONA for a MySQL version to apply an XTRADB release
125PERCONA_VER="${PERCONA_VER}"
126
127# Be warned, *DEPEND are version-dependant
128# These are used for both runtime and compiletime
129DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )
130 userland_GNU? ( sys-process/procps )
131 >=sys-apps/sed-4
132 >=sys-apps/texinfo-4.7-r1
133 >=sys-libs/readline-4.1
134 >=sys-libs/zlib-1.2.3"
135
136[[ "${PN}" == "mariadb" ]] \
137&& DEPEND="${DEPEND} libevent? ( >=dev-libs/libevent-1.4 )"
138
139# Having different flavours at the same time is not a good idea
140for i in "mysql" "mysql-community" "mysql-cluster" "mariadb" ; do
141 [[ "${i}" == ${PN} ]] ||
142 DEPEND="${DEPEND} !dev-db/${i}"
143done
144
145# prefix: first need to implement something for #196294
146RDEPEND="${DEPEND}
147 !minimal? ( !prefix? ( dev-db/mysql-init-scripts ) )
148 selinux? ( sec-policy/selinux-mysql )"
149
150DEPEND="${DEPEND}
151 virtual/yacc"
152
153if [ "${EAPI:-0}" = "2" ]; then
154 DEPEND="${DEPEND} static? ( || ( sys-libs/ncurses[static-libs] <=sys-libs/ncurses-5.7-r3 ) )"
155fi
156
157# compile-time-only
158mysql_version_is_at_least "5.1" \
159|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
160
161# compile-time-only
162mysql_version_is_at_least "5.1.12" \
163&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
164
165[[ "${PN}" == "mariadb" ]] \
166&& mysql_version_is_at_least "5.2" \
167&& DEPEND="${DEPEND} oqgraph? ( >=dev-libs/boost-1.40.0 )"
168#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
169# sphinx? ( app-misc/sphinx )"
170
171# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
172PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
173
174# For other stuff to bring us in
175PDEPEND="${PDEPEND} =virtual/mysql-${MYSQL_PV_MAJOR}"
176
177# Work out the default SERVER_URI correctly
178if [ -z "${SERVER_URI}" ]; then
179 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
180 if [ "${PN}" == "mariadb" ]; then
181 MARIA_FULL_PV="$(replace_version_separator 3 '-' ${PV})"
182 MARIA_FULL_P="${PN}-${MARIA_FULL_PV}"
183 SERVER_URI="
184 http://ftp.osuosl.org/pub/mariadb/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
185 http://ftp.rediris.es/mirror/MariaDB/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
186 http://maria.llarian.net/download/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
187 http://launchpad.net/maria/${MYSQL_PV_MAJOR}/ongoing/+download/${MARIA_FULL_P}.tar.gz
188 http://mirrors.fe.up.pt/pub/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
189 http://ftp-stud.hs-esslingen.de/pub/Mirrors/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
190 "
191 # The community and cluster builds are on the mirrors
192 elif [[ "${MYSQL_COMMUNITY_FEATURES}" == "1" || ${PN} == "mysql-cluster" ]] ; then
193 if [[ "${PN}" == "mysql-cluster" ]] ; then
194 URI_DIR="MySQL-Cluster"
195 URI_FILE="mysql-cluster-gpl"
196 else
197 URI_DIR="MySQL"
198 URI_FILE="mysql"
199 fi
200 URI_A="${URI_FILE}-${MY_PV}.tar.gz"
201 MIRROR_PV=$(get_version_component_range 1-2 ${PV})
202 # Recently upstream switched to an archive site, and not on mirrors
203 SERVER_URI="http://downloads.mysql.com/archives/${URI_FILE}-${MIRROR_PV}/${URI_A}
204 mirror://mysql/Downloads/${URI_DIR}-${PV%.*}/${URI_A}"
205 # The (old) enterprise source is on the primary site only
206 elif [ "${PN}" == "mysql" ]; then
207 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
208 fi
209fi
210
211# Define correct SRC_URIs
212SRC_URI="${SERVER_URI}"
213
214# Gentoo patches to MySQL
215[[ ${MY_EXTRAS_VER} != live ]] \
216&& SRC_URI="${SRC_URI}
217 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
218 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
219 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
220
17DESCRIPTION="A fast, multi-threaded, multi-user SQL database server" 221DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
18HOMEPAGE="http://www.mysql.com/" 222HOMEPAGE="http://www.mysql.com/"
19NEWP="${P/_/-}" 223if [[ "${PN}" == "mariadb" ]]; then
20SRC_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/${NEWP}.tar.gz 224 HOMEPAGE="http://askmonty.org/"
21 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2" 225 DESCRIPTION="MariaDB is a MySQL fork with 3rd-party patches and additional storage engines merged."
226fi
227if [[ "${PN}" == "mysql-community" ]]; then
228 DESCRIPTION="${DESCRIPTION} (obsolete, move to dev-db/mysql)"
229fi
22LICENSE="GPL-2" 230LICENSE="GPL-2"
231SLOT="0"
23IUSE="big-tables berkdb debug embedded minimal perl selinux srvdir ssl static" 232IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
24RESTRICT="primaryuri confcache"
25 233
26mysql_version_is_at_least "4.01.03.00" \ 234mysql_version_is_at_least "4.1" \
235&& IUSE="${IUSE} latin1"
236
237if mysql_version_is_at_least "4.1.3" ; then
27&& IUSE="${IUSE} cluster extraengine" 238 IUSE="${IUSE} extraengine"
239 if [[ "${PN}" != "mysql-cluster" ]] ; then
240 IUSE="${IUSE} cluster"
241 fi
242fi
28 243
29mysql_version_is_at_least "5.00.00.00" \ 244mysql_version_is_at_least "5.0" \
30|| IUSE="${IUSE} raid" 245|| IUSE="${IUSE} raid"
31 246
32mysql_version_is_at_least "5.00.18.00" \ 247mysql_version_is_at_least "5.0.18" \
33&& IUSE="${IUSE} max-idx-128" 248&& IUSE="${IUSE} max-idx-128"
34 249
35mysql_version_is_at_least "5.01.00.00" \ 250mysql_version_is_at_least "5.1" \
251|| IUSE="${IUSE} berkdb"
252
253[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
254&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
255
256[[ "${PN}" == "mariadb" ]] \
257&& IUSE="${IUSE} libevent"
258
259[[ "${PN}" == "mariadb" ]] \
260&& mysql_version_is_at_least "5.2" \
261&& IUSE="${IUSE} oqgraph"
262#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
263#&& IUSE="${IUSE} oqgraph sphinx"
264
265# MariaDB has integrated PBXT
266# PBXT_VERSION means that we have a PBXT patch for this PV
267# PBXT was only introduced after 5.1.12
268pbxt_patch_available() {
269 [[ "${PN}" != "mariadb" ]] \
270 && mysql_version_is_at_least "5.1.12" \
271 && [[ -n "${PBXT_VERSION}" ]]
272 return $?
273}
274
275pbxt_available() {
276 pbxt_patch_available || [[ "${PN}" == "mariadb" ]]
277 return $?
278}
279
280# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
281# MariaDB has integrated XtraDB
282# XTRADB_VERS means that we have a XTRADB patch for this PV
283# XTRADB was only introduced after 5.1.26
284xtradb_patch_available() {
285 [[ "${PN}" != "mariadb" ]] \
286 && mysql_version_is_at_least "5.1.26" \
287 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]]
288 return $?
289}
290
291
292pbxt_patch_available \
293&& PBXT_P="pbxt-${PBXT_VERSION}" \
294&& PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
295&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
296
297# PBXT_NEWSTYLE means pbxt is in storage/ and gets enabled as other plugins
298# vs. built outside the dir
299pbxt_available \
300&& IUSE="${IUSE} pbxt" \
301&& mysql_version_is_at_least "5.1.40" \
302&& PBXT_NEWSTYLE=1
303
304xtradb_patch_available \
305&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
306&& XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
307&& XTRADB_SRC_B1="http://www.percona.com/" \
308&& XTRADB_SRC_B2="${XTRADB_SRC_B1}/percona-builds/" \
309&& XTRADB_SRC_URI1="${XTRADB_SRC_B2}/Percona-Server/Percona-Server-${XTRADB_SRC_URI_COMMON}" \
310&& XTRADB_SRC_URI2="${XTRADB_SRC_B2}/xtradb/${XTRADB_SRC_URI_COMMON}" \
311&& XTRADB_SRC_URI3="${XTRADB_SRC_B1}/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
312&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} ${XTRADB_SRC_URI3} )" \
36&& IUSE="${IUSE} innodb" 313&& IUSE="${IUSE} xtradb"
37 314
38EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst pkg_postinst pkg_config pkg_prerm pkg_postrm 315#
316# HELPER FUNCTIONS:
317#
39 318
319# @FUNCTION: mysql_disable_test
320# @DESCRIPTION:
321# Helper function to disable specific tests.
322mysql_disable_test() {
323 local rawtestname testname testsuite reason mysql_disable_file
324 rawtestname="${1}" ; shift
325 reason="${@}"
326 ewarn "test '${rawtestname}' disabled: '${reason}'"
327
328 testsuite="${rawtestname/.*}"
329 testname="${rawtestname/*.}"
330 mysql_disable_file="${S}/mysql-test/t/disabled.def"
331 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
332 echo ${testname} : ${reason} >> "${mysql_disable_file}"
333
334 # ${S}/mysql-tests/t/disabled.def
335 #
336 # ${S}/mysql-tests/suite/federated/disabled.def
337 #
338 # ${S}/mysql-tests/suite/jp/t/disabled.def
339 # ${S}/mysql-tests/suite/ndb/t/disabled.def
340 # ${S}/mysql-tests/suite/rpl/t/disabled.def
341 # ${S}/mysql-tests/suite/parts/t/disabled.def
342 # ${S}/mysql-tests/suite/rpl_ndb/t/disabled.def
343 # ${S}/mysql-tests/suite/ndb_team/t/disabled.def
344 # ${S}/mysql-tests/suite/binlog/t/disabled.def
345 # ${S}/mysql-tests/suite/innodb/t/disabled.def
346 if [ -n "${testsuite}" ]; then
347 for mysql_disable_file in \
348 ${S}/mysql-test/suite/${testsuite}/disabled.def \
349 ${S}/mysql-test/suite/${testsuite}/t/disabled.def \
350 FAILED ; do
351 [ -f "${mysql_disable_file}" ] && break
352 done
353 if [ "${mysql_disabled_file}" != "FAILED" ]; then
354 echo "${testname} : ${reason}" >> "${mysql_disable_file}"
355 else
356 ewarn "Could not find testsuite disabled.def location for ${rawtestname}"
357 fi
358 fi
359}
360
361# @FUNCTION: mysql_init_vars
362# @DESCRIPTION:
40# void mysql_init_vars() 363# void mysql_init_vars()
41#
42# initialize global variables 364# Initialize global variables
43# 2005-11-19 <vivo at gentoo.org> 365# 2005-11-19 <vivo@gentoo.org>
44mysql_init_vars() { 366mysql_init_vars() {
45
46 if [[ ${SLOT} -eq 0 ]] ; then
47 MY_SUFFIX=""
48 else
49 MY_SUFFIX=${MY_SUFFIX:-"-${SLOT}"}
50 fi
51 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR:-"/usr/share/mysql${MY_SUFFIX}"} 367 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR="/usr/share/mysql"}
52 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql${MY_SUFFIX}"} 368 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql"}
53 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql${MY_SUFFIX}"} 369 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql"}
54 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql${MY_SUFFIX}"} 370 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql"}
55 MY_LOGDIR=${MY_LOGDIR="/var/log/mysql${MY_SUFFIX}"} 371 MY_LOGDIR=${MY_LOGDIR="/var/log/mysql"}
56 MY_INCLUDEDIR=${MY_INCLUDEDIR="/usr/include/mysql${MY_SUFFIX}"} 372 MY_INCLUDEDIR=${MY_INCLUDEDIR="/usr/include/mysql"}
57 373
58 if [ -z "${DATADIR}" ]; then 374 if [[ -z "${MY_DATADIR}" ]] ; then
59 DATADIR="" 375 MY_DATADIR=""
60 if [ -f "${MY_SYSCONFDIR}/my.cnf" ] ; then 376 if [[ -f "${MY_SYSCONFDIR}/my.cnf" ]] ; then
61 DATADIR=`"my_print_defaults${MY_SUFFIX}" mysqld 2>/dev/null | sed -ne '/datadir/s|^--datadir=||p' | tail -n1` 377 MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
378 | sed -ne '/datadir/s|^--datadir=||p' \
379 | tail -n1`
62 if [ -z "${DATADIR}" ]; then 380 if [[ -z "${MY_DATADIR}" ]] ; then
63 if useq "srvdir" ; then
64 DATADIR="${ROOT}/srv/localhost/mysql${MY_SUFFIX}/datadir"
65 else
66 DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" | sed -e 's/.*=\s*//'` 381 MY_DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" \
67 fi 382 | sed -e 's/.*=\s*//' \
383 | tail -n1`
68 fi 384 fi
69 fi 385 fi
70 if [ -z "${DATADIR}" ]; then 386 if [[ -z "${MY_DATADIR}" ]] ; then
71 if useq "srvdir" ; then
72 DATADIR="${ROOT}/srv/localhost/mysql${MY_SUFFIX}/datadir"
73 else
74 DATADIR="${MY_LOCALSTATEDIR}" 387 MY_DATADIR="${MY_LOCALSTATEDIR}"
75 fi
76 einfo "Using default DATADIR" 388 einfo "Using default MY_DATADIR"
77 fi 389 fi
78 einfo "MySQL DATADIR is ${DATADIR}" 390 elog "MySQL MY_DATADIR is ${MY_DATADIR}"
79 391
80 if [ -z "${PREVIOUS_DATADIR}" ] ; then 392 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then
81 if [ -a "${DATADIR}" ] ; then 393 if [[ -e "${MY_DATADIR}" ]] ; then
82 ewarn "Previous datadir found, it's YOUR job to change" 394 # If you get this and you're wondering about it, see bug #207636
83 ewarn "ownership and have care of it" 395 elog "MySQL datadir found in ${MY_DATADIR}"
396 elog "A new one will not be created."
84 PREVIOUS_DATADIR="yes" 397 PREVIOUS_DATADIR="yes"
85 export PREVIOUS_DATADIR
86 else 398 else
87 PREVIOUS_DATADIR="no" 399 PREVIOUS_DATADIR="no"
88 export PREVIOUS_DATADIR
89 fi 400 fi
401 export PREVIOUS_DATADIR
402 fi
403 else
404 if [[ ${EBUILD_PHASE} == "config" ]]; then
405 local new_MY_DATADIR
406 new_MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
407 | sed -ne '/datadir/s|^--datadir=||p' \
408 | tail -n1`
409
410 if [[ ( -n "${new_MY_DATADIR}" ) && ( "${new_MY_DATADIR}" != "${MY_DATADIR}" ) ]]; then
411 ewarn "MySQL MY_DATADIR has changed"
412 ewarn "from ${MY_DATADIR}"
413 ewarn "to ${new_MY_DATADIR}"
414 MY_DATADIR="${new_MY_DATADIR}"
90 fi 415 fi
91 fi 416 fi
417 fi
92 418
419 if [ "${MY_SOURCEDIR:-unset}" == "unset" ]; then
420 MY_SOURCEDIR=${SERVER_URI##*/}
421 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
422 fi
423
93 export MY_SUFFIX MY_SHAREDSTATEDIR MY_SYSCONFDIR 424 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
94 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR 425 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
95 export MY_INCLUDEDIR 426 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
96 export DATADIR
97} 427}
98 428
429configure_minimal() {
430 # These are things we exclude from a minimal build, please
431 # note that the server actually does get built and installed,
432 # but we then delete it before packaging.
433 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication readline"
434
435 for i in ${minimal_exclude_list} ; do
436 myconf="${myconf} --without-${i}"
437 done
438 myconf="${myconf} --with-extra-charsets=none"
439 myconf="${myconf} --enable-local-infile"
440
441 if use static ; then
442 myconf="${myconf} --with-client-ldflags=-all-static"
443 myconf="${myconf} --disable-shared --with-pic"
444 else
445 myconf="${myconf} --enable-shared --enable-static"
446 fi
447
448 if mysql_version_is_at_least "4.1" && ! use latin1 ; then
449 myconf="${myconf} --with-charset=utf8"
450 myconf="${myconf} --with-collation=utf8_general_ci"
451 else
452 myconf="${myconf} --with-charset=latin1"
453 myconf="${myconf} --with-collation=latin1_swedish_ci"
454 fi
455}
456
457configure_common() {
458 myconf="${myconf} $(use_with big-tables)"
459 myconf="${myconf} --enable-local-infile"
460 myconf="${myconf} --with-extra-charsets=all"
461 myconf="${myconf} --with-mysqld-user=mysql"
462 myconf="${myconf} --with-server"
463 myconf="${myconf} --with-unix-socket-path=/var/run/mysqld/mysqld.sock"
464 myconf="${myconf} --without-libwrap"
465
466 if use static ; then
467 myconf="${myconf} --with-mysqld-ldflags=-all-static"
468 myconf="${myconf} --with-client-ldflags=-all-static"
469 myconf="${myconf} --disable-shared --with-pic"
470 else
471 myconf="${myconf} --enable-shared --enable-static"
472 fi
473
474 if use debug ; then
475 myconf="${myconf} --with-debug=full"
476 else
477 myconf="${myconf} --without-debug"
478 mysql_version_is_at_least "4.1.3" \
479 && ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) \
480 && myconf="${myconf} --without-ndb-debug"
481 fi
482
483 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
484 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
485 ewarn "and a collation of ${MYSQL_DEFAULT_COLLATION}."
486 ewarn "You MUST file bugs without these variables set."
487 myconf="${myconf} --with-charset=${MYSQL_DEFAULT_CHARSET}"
488 myconf="${myconf} --with-collation=${MYSQL_DEFAULT_COLLATION}"
489 elif mysql_version_is_at_least "4.1" && ! use latin1 ; then
490 myconf="${myconf} --with-charset=utf8"
491 myconf="${myconf} --with-collation=utf8_general_ci"
492 else
493 myconf="${myconf} --with-charset=latin1"
494 myconf="${myconf} --with-collation=latin1_swedish_ci"
495 fi
496
497 if use embedded ; then
498 myconf="${myconf} --with-embedded-privilege-control"
499 myconf="${myconf} --with-embedded-server"
500 else
501 myconf="${myconf} --without-embedded-privilege-control"
502 myconf="${myconf} --without-embedded-server"
503 fi
504
505}
506
507configure_40_41_50() {
508 myconf="${myconf} $(use_with perl bench)"
509 myconf="${myconf} --enable-assembler"
510 myconf="${myconf} --with-extra-tools"
511 myconf="${myconf} --with-innodb"
512 myconf="${myconf} --without-readline"
513 myconf="${myconf} $(use_with ssl openssl)"
514 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
515
516 # --with-vio is not needed anymore, it's on by default and
517 # has been removed from configure
518 # Apply to 4.x and 5.0.[0-3]
519 if use ssl ; then
520 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
521 fi
522
523 if mysql_version_is_at_least "5.0.60" ; then
524 if use berkdb ; then
525 elog "Berkeley DB support was disabled due to build failures"
526 elog "on multiple arches, go to a version earlier than 5.0.60"
527 elog "if you want it again. Gentoo bug #224067."
528 fi
529 myconf="${myconf} --without-berkeley-db"
530 elif use berkdb ; then
531 # The following fix is due to a bug with bdb on SPARC's. See:
532 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
533 # It comes down to non-64-bit safety problems.
534 if use alpha || use amd64 || use hppa || use mips || use sparc ; then
535 elog "Berkeley DB support was disabled due to compatibility issues on this arch"
536 myconf="${myconf} --without-berkeley-db"
537 else
538 myconf="${myconf} --with-berkeley-db=./bdb"
539 fi
540 else
541 myconf="${myconf} --without-berkeley-db"
542 fi
543
544 if mysql_version_is_at_least "4.1.3" ; then
545 myconf="${myconf} --with-geometry"
546 if [[ "${PN}" != "mysql-cluster" ]] ; then
547 myconf="${myconf} $(use_with cluster ndbcluster)"
548 fi
549 fi
550
551 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
552 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
553 myconf="${myconf} --with-archive-storage-engine"
554
555 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
556 myconf="${myconf} --with-csv-storage-engine"
557
558 # http://dev.mysql.com/doc/mysql/en/blackhole-storage-engine.html
559 myconf="${myconf} --with-blackhole-storage-engine"
560
561 # http://dev.mysql.com/doc/mysql/en/federated-storage-engine.html
562 # http://dev.mysql.com/doc/mysql/en/federated-description.html
563 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html
564 if mysql_version_is_at_least "5.0.3" ; then
565 elog "Before using the Federated storage engine, please be sure to read"
566 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html"
567 myconf="${myconf} --with-federated-storage-engine"
568 fi
569 fi
570
571 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
572 myconf="${myconf} `use_enable community community-features`"
573 if use community; then
574 myconf="${myconf} `use_enable profiling`"
575 else
576 myconf="${myconf} --disable-profiling"
577 fi
578 fi
579
580 mysql_version_is_at_least "5.0.18" \
581 && use max-idx-128 \
582 && myconf="${myconf} --with-max-indexes=128"
583}
584
585configure_51() {
586 # TODO: !!!! readd --without-readline
587 # the failure depend upon config/ac-macros/readline.m4 checking into
588 # readline.h instead of history.h
589 myconf="${myconf} $(use_with ssl ssl /usr)"
590 myconf="${myconf} --enable-assembler"
591 myconf="${myconf} --with-geometry"
592 myconf="${myconf} --with-readline"
593 myconf="${myconf} --with-zlib-dir=/usr/"
594 myconf="${myconf} --without-pstack"
595 myconf="${myconf} --with-plugindir=/usr/$(get_libdir)/mysql/plugin"
596
597 # This is an explict die here, because if we just forcibly disable it, then the
598 # user's data is not accessible.
599 use max-idx-128 && die "Bug #336027: upstream has a corruption issue with max-idx-128 presently"
600 #use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
601 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
602 myconf="${myconf} $(use_enable community community-features)"
603 if use community; then
604 myconf="${myconf} $(use_enable profiling)"
605 else
606 myconf="${myconf} --disable-profiling"
607 fi
608 fi
609
610 # Scan for all available plugins
611 local plugins_avail="$(
612 LANG=C \
613 find "${S}" \
614 \( \
615 -name 'plug.in' \
616 -o -iname 'configure.in' \
617 -o -iname 'configure.ac' \
618 \) \
619 -print0 \
620 | xargs -0 sed -r -n \
621 -e '/^MYSQL_STORAGE_ENGINE/{
622 s~MYSQL_STORAGE_ENGINE\([[:space:]]*\[?([-_a-z0-9]+)\]?.*,~\1 ~g ;
623 s~^([^ ]+).*~\1~gp;
624 }' \
625 | tr -s '\n' ' '
626 )"
627
628 # 5.1 introduces a new way to manage storage engines (plugins)
629 # like configuration=none
630 # This base set are required, and will always be statically built.
631 local plugins_sta="csv myisam myisammrg heap"
632 local plugins_dyn=""
633 local plugins_dis="example ibmdb2i"
634
635 # These aren't actually required by the base set, but are really useful:
636 plugins_sta="${plugins_sta} archive blackhole"
637
638 # default in 5.5.4
639 if mysql_version_is_at_least "5.5.4" ; then
640 plugins_sta="${plugins_sta} partition"
641 fi
642 # Now the extras
643 if use extraengine ; then
644 # like configuration=max-no-ndb, archive and example removed in 5.1.11
645 # not added yet: ibmdb2i
646 # Not supporting as examples: example,daemon_example,ftexample
647 plugins_sta="${plugins_sta} partition"
648
649 if [[ "${PN}" != "mariadb" ]] ; then
650 elog "Before using the Federated storage engine, please be sure to read"
651 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
652 plugins_dyn="${plugins_sta} federated"
653 else
654 elog "MariaDB includes the FederatedX engine. Be sure to read"
655 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
656 plugins_dyn="${plugins_sta} federatedx"
657 fi
658 else
659 plugins_dis="${plugins_dis} partition federated"
660 fi
661
662 # Upstream specifically requests that InnoDB always be built:
663 # - innobase, innodb_plugin
664 # Build falcon if available for 6.x series.
665 for i in innobase falcon ; do
666 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
667 done
668 for i in innodb_plugin ; do
669 [ -e "${S}"/storage/${i} ] && plugins_dyn="${plugins_dyn} ${i}"
670 done
671
672 # like configuration=max-no-ndb
673 if ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) ; then
674 plugins_sta="${plugins_sta} ndbcluster partition"
675 plugins_dis="${plugins_dis//partition}"
676 myconf="${myconf} --with-ndb-binlog"
677 else
678 plugins_dis="${plugins_dis} ndbcluster"
679 fi
680
681 if [[ "${PN}" == "mariadb" ]] ; then
682 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
683 # caught above.
684 # This is not optional, without it several upstream testcases fail.
685 # Also strongly recommended by upstream.
686 if [[ "${PV}" < "5.2.0" ]] ; then
687 myconf="${myconf} --with-maria-tmp-tables"
688 plugins_sta="${plugins_sta} maria"
689 else
690 myconf="${myconf} --with-aria-tmp-tables"
691 plugins_sta="${plugins_sta} aria"
692 fi
693
694 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] ||
695 die "The ${P} package doesn't provide innobase nor xtradb"
696
697 for i in innobase xtradb ; do
698 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
699 done
700
701 myconf="${myconf} $(use_with libevent)"
702
703 if mysql_version_is_at_least "5.2" ; then
704 #This should include sphinx, but the 5.2.4 archive forgot the plug.in file
705 #for i in oqgraph sphinx ; do
706 for i in oqgraph ; do
707 use ${i} \
708 && plugins_dyn="${plugins_dyn} ${i}" \
709 || plugins_dis="${plugins_dis} ${i}"
710 done
711 fi
712 fi
713
714 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then
715 use pbxt \
716 && plugins_dyn="${plugins_dyn} pbxt" \
717 || plugins_dis="${plugins_dis} pbxt"
718 fi
719
720 use static && \
721 plugins_sta="${plugins_sta} ${plugins_dyn}" && \
722 plugins_dyn=""
723
724 einfo "Available plugins: ${plugins_avail}"
725 einfo "Dynamic plugins: ${plugins_dyn}"
726 einfo "Static plugins: ${plugins_sta}"
727 einfo "Disabled plugins: ${plugins_dis}"
728
729 # These are the static plugins
730 myconf="${myconf} --with-plugins=${plugins_sta// /,}"
731 # And the disabled ones
732 for i in ${plugins_dis} ; do
733 myconf="${myconf} --without-plugin-${i}"
734 done
735}
736
737pbxt_src_configure() {
738 mysql_init_vars
739
740 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
741
742 einfo "Reconfiguring dir '${PWD}'"
743 eautoreconf
744
745 local myconf=""
746 myconf="${myconf} --with-mysql=${S} --libdir=/usr/$(get_libdir)"
747 use debug && myconf="${myconf} --with-debug=full"
748 econf ${myconf} || die "Problem configuring PBXT storage engine"
749}
750
751pbxt_src_compile() {
752
753 # Be backwards compatible for now
754 if [[ $EAPI != 2 ]]; then
755 pbxt_src_configure
756 fi
757 # TODO: is it safe/needed to use emake here ?
758 make || die "Problem making PBXT storage engine (${myconf})"
759
760 popd
761 # TODO: modify test suite for PBXT
762}
763
764pbxt_src_install() {
765 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
766 emake install DESTDIR="${D}" || die "Failed to install PBXT"
767 popd
768}
769
770#
771# EBUILD FUNCTIONS
772#
773# @FUNCTION: mysql_pkg_setup
774# @DESCRIPTION:
775# Perform some basic tests and tasks during pkg_setup phase:
776# die if FEATURES="test", USE="-minimal" and not using FEATURES="userpriv"
777# check for conflicting use flags
778# create new user and group for mysql
779# warn about deprecated features
99mysql_pkg_setup() { 780mysql_pkg_setup() {
781 if has test ${FEATURES} ; then
782 if ! use minimal ; then
783 if [[ $UID -eq 0 ]]; then
784 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
785 fi
786 fi
787 fi
100 788
789 # bug 350844
790 case "${EAPI:-0}" in
791 0 | 1)
792 if use static && !built_with_use sys-libs/ncurses static-libs; then
793 die "To build MySQL statically you need to enable static-libs for sys-libs/ncurses"
794 fi
795 ;;
796 esac
797
798 # Check for USE flag problems in pkg_setup
799 if use static && use ssl ; then
800 M="MySQL does not support being built statically with SSL support enabled!"
801 eerror "${M}"
802 die "${M}"
803 fi
804
805 if mysql_version_is_at_least "5.1.51" \
806 && ! mysql_version_is_at_least "5.2" \
807 && use debug ; then
808 # Also in package.use.mask
809 die "Bug #344885: Upstream has broken USE=debug for 5.1 series >=5.1.51"
810 fi
811
812 if ! mysql_version_is_at_least "5.0" \
813 && use raid \
814 && use static ; then
815 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically"
816 eerror "with RAID support enabled."
817 die "USE flags 'raid' and 'static' conflict!"
818 fi
819
820 if mysql_version_is_at_least "4.1.3" \
821 && ( use cluster || use extraengine || use embedded ) \
822 && use minimal ; then
823 M="USE flags 'cluster', 'extraengine', 'embedded' conflict with 'minimal' USE flag!"
824 eerror "${M}"
825 die "${M}"
826 fi
827
828 if mysql_version_is_at_least "5.1" \
829 && xtradb_patch_available \
830 && use xtradb \
831 && use embedded ; then
832 M="USE flags 'xtradb' and 'embedded' conflict and cause build failures"
833 eerror "${M}"
834 die "${M}"
835 fi
836
837 # Bug #290570, 284946, 307251
838 # Upstream changes made us need a fairly new GCC4.
839 # But only for 5.0.8[3-6]!
840 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then
841 GCC_VER=$(gcc-version)
842 case ${GCC_VER} in
843 2*|3*|4.0|4.1|4.2)
844 eerror "Some releases of MySQL required a very new GCC, and then"
845 eerror "later release relaxed that requirement again. Either pick a"
846 eerror "MySQL >=5.0.87, or use a newer GCC."
847 die "Active GCC too old!" ;;
848 esac
849 fi
850
851 # This should come after all of the die statements
101 enewgroup mysql 60 || die "problem adding group mysql" 852 enewgroup mysql 60 || die "problem adding 'mysql' group"
102 enewuser mysql 60 -1 /dev/null mysql \ 853 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
103 || die "problem adding user mysql"
104}
105 854
855 mysql_check_version_range "4.0 to 5.0.99.99" \
856 && use berkdb \
857 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
858
859 if [ "${PN}" != "mysql-cluster" ] && use cluster; then
860 ewarn "Upstream has noted that the NDB cluster support in the 5.0 and"
861 ewarn "5.1 series should NOT be put into production. In the near"
862 ewarn "future, it will be disabled from building."
863 ewarn ""
864 ewarn "If you need NDB support, you should instead move to the new"
865 ewarn "mysql-cluster package that represents that upstream NDB"
866 ewarn "development."
867 fi
868}
869
870# @FUNCTION: mysql_src_unpack
871# @DESCRIPTION:
872# Unpack the source code and call mysql_src_prepare for EAPI < 2.
106mysql_src_unpack() { 873mysql_src_unpack() {
107 874 # Initialize the proper variables first
108 mysql_init_vars 875 mysql_init_vars
109 876
110 if useq static && useq ssl; then
111 local msg="MySQL does not support building statically with SSL support"
112 eerror "${msg}"
113 die "${msg}"
114 fi
115
116 if mysql_version_is_at_least "4.01.03.00" \
117 && useq cluster \
118 || useq extraengine \
119 && useq minimal ; then
120 die "USEs cluster, extraengine conflicts with \"minimal\""
121 fi
122
123 unpack ${A} || die 877 unpack ${A}
878 # Grab the patches
879 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack
124 880
125 mv -f "${WORKDIR}/${NEWP}" "${S}" 881 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}"
882
883 # Be backwards compatible for now
884 case ${EAPI:-0} in
885 2) : ;;
886 0 | 1) mysql_src_prepare ;;
887 esac
888}
889
890# @FUNCTION: mysql_src_prepare
891# @DESCRIPTION:
892# Apply patches to the source code and remove unneeded bundled libs.
893mysql_src_prepare() {
126 cd "${S}" 894 cd "${S}"
127 895
896 # Apply the patches for this MySQL version
128 EPATCH_SUFFIX="patch" 897 EPATCH_SUFFIX="patch"
129 mkdir -p "${EPATCH_SOURCE}" || die "unable to create epatch directory" 898 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory"
899 # Clean out old items
900 rm -f "${EPATCH_SOURCE}"/*
901 # Now link in right patches
130 mysql_mv_patches 902 mysql_mv_patches
131 epatch || die "failed to apply all patches" 903 # And apply
904 epatch
132 905
133 # additional check, remove bundled zlib 906 # last -fPIC fixup, per bug #305873
907 i="${S}"/storage/innodb_plugin/plug.in
908 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
909
910 # Additional checks, remove bundled zlib (Cluster needs this, for static
911 # memory management in zlib, leave available for Cluster)
912 if [[ "${PN}" != "mysql-cluster" ]] ; then
134 rm -f "${S}/zlib/"*.[ch] 913 rm -f "${S}/zlib/"*.[ch]
135 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 914 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
915 fi
136 rm -f scripts/mysqlbug 916 rm -f "scripts/mysqlbug"
137 917
138 # Make charsets install in the right place 918 # Make charsets install in the right place
139 find . -name 'Makefile.am' \ 919 find . -name 'Makefile.am' \
140 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \; 920 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
141 921
142 # Manage mysqlmanager
143 mysql_version_is_at_least "5.00.15.00" \ 922 if mysql_version_is_at_least "4.1" ; then
144 && sed -i -e "s!@GENTOO_EXT@!${MY_SUFFIX}!g" \
145 -e "s!@GENTOO_SOCK_PATH@!var/run/mysqld!g" \
146 "${S}/server-tools/instance-manager/Makefile.am"
147
148 # remove what need to be recreated, so we are sure it's actually done 923 # Remove what needs to be recreated, so we're sure it's actually done
149 find . -name Makefile -o -name Makefile.in -o -name configure -exec rm -f {} \; 924 einfo "Cleaning up old buildscript files"
925 find . -name Makefile \
926 -o -name Makefile.in \
927 -o -name configure \
928 -exec rm -f {} \;
150 rm ltmain.sh 929 rm -f "ltmain.sh"
930 rm -f "scripts/mysqlbug"
931 fi
151 932
152 local rebuilddirlist d buildstep bdbdir 933 local rebuilddirlist d
153 934
935 if xtradb_patch_available && use xtradb ; then
936 einfo "Adding storage engine: Percona XtraDB (replacing InnoDB)"
937 pushd "${S}"/storage >/dev/null
938 i="innobase"
939 o="${WORKDIR}/storage-${i}.mysql-upstream"
940 # Have we been here already?
941 [ -d "${o}" ] && rm -f "${i}"
942 # Or maybe we haven't
943 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
944 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}"
945 popd >/dev/null
946 fi
947
948 if pbxt_patch_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then
949 einfo "Adding storage engine: PBXT"
950 pushd "${S}"/storage >/dev/null
951 i='pbxt'
952 [ -d "${i}" ] && rm -rf "${i}"
953 cp -ral "${WORKDIR}/${PBXT_P}" "${i}"
954 popd >/dev/null
955 fi
956
154 if mysql_version_is_at_least "5.01.00.00" ; then 957 if mysql_version_is_at_least "5.1.12" ; then
155 rebuilddirlist=". storage/innobase" 958 rebuilddirlist="."
156 bdbdir='storage/bdb/dist' 959 # This does not seem to be needed presently. robbat2 2010/02/23
960 #einfo "Updating innobase cmake"
961 ## TODO: check this with a cmake expert
962 #cmake \
963 # -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
964 # -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
965 # "storage/innobase"
157 else 966 else
158 rebuilddirlist=". innobase" 967 rebuilddirlist=". innobase"
159 bdbdir='bdb/dist'
160 fi 968 fi
161 969
162 for d in ${rebuilddirlist}; do 970 for d in ${rebuilddirlist} ; do
163 einfo "reconfiguring dir \"${d}\"" 971 einfo "Reconfiguring dir '${d}'"
164 pushd "${d}" &>/dev/null 972 pushd "${d}" &>/dev/null
165 AT_GNUCONF_UPDATE="yes" eautoreconf 973 eautoreconf
166 popd &>/dev/null 974 popd &>/dev/null
167 done 975 done
168 976
169 #TODO berkdb in 5.1 need to be worked on 977 if mysql_check_version_range "4.1 to 5.0.99.99" \
170 if useq berkdb && ! mysql_check_version_range "5.01.00.00 to 5.01.08.99" 978 && use berkdb ; then
171 then 979 einfo "Fixing up berkdb buildsystem"
172 [[ -w "${bdbdir}/ltmain.sh" ]] && cp -f ltmain.sh "${bdbdir}/ltmain.sh" 980 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
173 pushd "${bdbdir}" && sh s_all || die "failed bdb reconfigure" &>/dev/null 981 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
982 || die "Could not copy libtool.m4 to bdb/dist/"
983 #These files exist only with libtool-2*, and need to be included.
984 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then
985 cat "/usr/share/aclocal/ltsugar.m4" >> "bdb/dist/aclocal/libtool.ac"
986 cat "/usr/share/aclocal/ltversion.m4" >> "bdb/dist/aclocal/libtool.ac"
987 cat "/usr/share/aclocal/lt~obsolete.m4" >> "bdb/dist/aclocal/libtool.ac"
988 cat "/usr/share/aclocal/ltoptions.m4" >> "bdb/dist/aclocal/libtool.ac"
989 fi
990 pushd "bdb/dist" &>/dev/null
991 sh s_all \
992 || die "Failed bdb reconfigure"
174 popd &>/dev/null 993 popd &>/dev/null
175 fi 994 fi
176
177} 995}
178 996
997# @FUNCTION: mysql_src_configure
998# @DESCRIPTION:
999# Configure mysql to build the code for Gentoo respecting the use flags.
179mysql_src_compile() { 1000mysql_src_configure() {
180 1001 # Make sure the vars are correctly initialized
181 mysql_init_vars 1002 mysql_init_vars
1003
1004 # $myconf is modified by the configure_* functions
182 local myconf 1005 local myconf=""
183 1006
184 if useq static ; then 1007 if use minimal ; then
185 myconf="${myconf} --with-mysqld-ldflags=-all-static" 1008 configure_minimal
186 myconf="${myconf} --with-client-ldflags=-all-static"
187 myconf="${myconf} --disable-shared"
188 else 1009 else
189 myconf="${myconf} --enable-shared --enable-static" 1010 configure_common
190 fi
191
192 #myconf="${myconf} `use_with tcpd libwrap`"
193 myconf="${myconf} --without-libwrap"
194
195 if useq ssl ; then
196 # --with-vio is not needed anymore, it's on by default and
197 # has been removed from configure
198 mysql_version_is_at_least "5.00.04.00" || myconf="${myconf} --with-vio"
199 if mysql_version_is_at_least "5.00.06.00" ; then 1011 if mysql_version_is_at_least "5.1.10" ; then
200 # yassl-0.96 is young break with gcc-4.0 || amd64 1012 configure_51
201 #myconf="${myconf} --with-yassl"
202 myconf="${myconf} --with-openssl"
203 else 1013 else
204 myconf="${myconf} --with-openssl" 1014 configure_40_41_50
205 fi
206 else
207 myconf="${myconf} --without-openssl"
208 fi
209
210 if useq debug; then
211 myconf="${myconf} --with-debug=full"
212 else
213 myconf="${myconf} --without-debug"
214 mysql_version_is_at_least "4.01.03.00" && useq cluster && myconf="${myconf} --without-ndb-debug"
215 fi
216
217 # benchmarking stuff needs perl
218 # and shouldn't be bothered with on minimal builds
219 if useq perl && ! useq minimal; then
220 myconf="${myconf} --with-bench"
221 else
222 myconf="${myconf} --without-bench"
223 fi
224
225 # these are things we exclude from a minimal build
226 # note that the server actually does get built and installed
227 # but we then delete it before packaging.
228 local minimal_exclude_list="server embedded-server extra-tools innodb"
229 if ! useq minimal; then
230 for i in ${minimal_exclude_list}; do
231 myconf="${myconf} --with-${i}"
232 done
233
234 if useq static ; then
235 myconf="${myconf} --without-raid"
236 ewarn "disabling raid support, has problem with static"
237 else
238 if mysql_version_is_at_least "5.00.00.00" ; then
239 myconf="${myconf} --without-raid"
240 else
241 myconf="${myconf} `use_with raid`"
242 fi 1015 fi
243 fi 1016 fi
244 1017
245 if ! mysql_version_is_at_least "5.00.00.00" ; then
246 if mysql_version_is_at_least "4.01.00.00" ; then
247 myconf="${myconf} --with-charset=utf8"
248 myconf="${myconf} --with-collation=utf8_general_ci"
249 else
250 myconf="${myconf} --with-charset=latin1"
251 myconf="${myconf} --with-collation=latin1_swedish_ci"
252 fi
253 fi
254
255 # optional again from 2005-12-05
256 if mysql_version_is_at_least "5.01.00.00" ; then
257 myconf="${myconf} $(use_with innodb)"
258 else
259 myconf="${myconf} --with-innodb"
260 fi
261
262 # lots of chars
263 myconf="${myconf} --with-extra-charsets=all"
264
265 #The following fix is due to a bug with bdb on sparc's. See:
266 #http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
267 # it comes down to non-64-bit safety problems
268 if useq sparc || useq alpha || useq hppa || useq mips || useq amd64 \
269 || mysql_check_version_range "5.01.00.00 to 5.01.06.99"
270 then
271 ewarn "bdb berkeley-db disabled due to arch or version"
272 myconf="${myconf} --without-berkeley-db"
273 else
274 #TODO berkdb in 5.1 need to be worked on
275 useq berkdb && \
276 ! mysql_check_version_range "5.01.00.00 to 5.01.08.99" \
277 && myconf="${myconf} --with-berkeley-db=./bdb" \
278 || myconf="${myconf} --without-berkeley-db"
279 fi
280
281 if mysql_version_is_at_least "4.01.03.00" ; then
282 #myconf="${myconf} $(use_with geometry)"
283 myconf="${myconf} --with-geometry"
284 myconf="${myconf} $(use_with cluster ndbcluster)"
285 fi
286
287 mysql_version_is_at_least "4.01.11.00" && myconf="${myconf} `use_with big-tables`"
288
289 mysql_version_is_at_least "5.01.06.00" && myconf="${myconf} --with-ndb-binlog"
290
291 if useq embedded ; then
292 #REMIND, need the privilege control enabled ?
293 myconf="${myconf} --without-embedded-privilege-control"
294 myconf="${myconf} --with-embedded-server"
295 else
296 myconf="${myconf} --without-embedded-privilege-control"
297 myconf="${myconf} --without-embedded-server"
298 fi
299 else
300 for i in ${minimal_exclude_list}; do
301 myconf="${myconf} --without-${i}"
302 done
303 myconf="${myconf} --without-berkeley-db"
304 myconf="${myconf} --with-extra-charsets=none"
305 fi
306
307 if mysql_version_is_at_least "4.01.03.00" && useq extraengine; then
308 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
309 myconf="${myconf} --with-archive-storage-engine"
310 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
311
312 mysql_version_is_at_least "4.01.04.00" \
313 && myconf="${myconf} --with-csv-storage-engine"
314
315 mysql_version_is_at_least "4.01.11.00" \
316 && myconf="${myconf} --with-blackhole-storage-engine"
317
318 # http://dev.mysql.com/doc/mysql/en/federated-description.html
319 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html
320 if mysql_version_is_at_least "5.00.03.00" ; then
321 einfo "before to use federated engine be sure to read"
322 einfo "http://dev.mysql.com/doc/refman/5.0/en/federated-limitations.html"
323 myconf="${myconf} --with-federated-storage-engine"
324
325 # http://dev.mysql.com/doc/refman/5.1/en/partitioning-overview.html
326 if mysql_version_is_at_least "5.01.00.00" ; then
327 myconf="${myconf} --with-partition"
328 fi
329 fi
330
331 fi
332
333 mysql_version_is_at_least "5.00.18.00" \
334 && useq "max-idx-128" \
335 && myconf="${myconf} --with-max-indexes=128"
336
337 if mysql_version_is_at_least "5.01.05.00" ; then
338 myconf="${myconf} --with-row-based-replication"
339 fi
340
341 #TODO rechek again later, had problem with assembler enabled
342 # and some combination of use-flags with 5.1
343 if mysql_check_version_range "5.01.00.00 to 5.01.08.99" ; then
344 myconf="${myconf} --disable-assembler"
345 else
346 myconf="${myconf} --enable-assembler"
347 fi
348
349 #Bug #114895,Bug #110149 1018 # Bug #114895, bug #110149
350 filter-flags "-O" "-O[01]" 1019 filter-flags "-O" "-O[01]"
1020
351 #glibc-2.3.2_pre fix; bug #16496 1021 # glib-2.3.2_pre fix, bug #16496
352 append-flags "-DHAVE_ERRNO_AS_DEFINE=1" 1022 append-flags "-DHAVE_ERRNO_AS_DEFINE=1"
353 1023
354 #the compiler flags are as per their "official" spec ;) 1024 # As discovered by bug #246652, doing a double-level of SSP causes NDB to
355 #CFLAGS="${CFLAGS/-O?/} -O3" \ 1025 # fail badly during cluster startup.
1026 if [[ $(gcc-major-version) -lt 4 ]]; then
1027 filter-flags "-fstack-protector-all"
1028 fi
1029
1030 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing"
356 export CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-exceptions -fno-rtti" 1031 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti"
357 mysql_version_is_at_least "5.00.00.00" \ 1032 mysql_version_is_at_least "5.0" \
358 && export CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 1033 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
1034 export CXXFLAGS
1035
1036 # bug #283926, with GCC4.4, this is required to get correct behavior.
1037 append-flags -fno-strict-aliasing
1038
1039 # bug #335185, #335995, with >= GCC4.3.3 on x86 only, omit-frame-pointer
1040 # causes a mis-compile.
1041 # Upstream bugs:
1042 # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38562
1043 # http://bugs.mysql.com/bug.php?id=45205
1044 use x86 && version_is_at_least "4.3.3" "$(gcc-fullversion)" && \
1045 append-flags -fno-omit-frame-pointer && \
1046 filter-flags -fomit-frame-pointer
359 1047
360 econf \ 1048 econf \
361 --program-suffix="${MY_SUFFIX}" \
362 --libexecdir="/usr/sbin" \ 1049 --libexecdir="/usr/sbin" \
363 --sysconfdir="${MY_SYSCONFDIR}" \ 1050 --sysconfdir="${MY_SYSCONFDIR}" \
364 --localstatedir="${MY_LOCALSTATEDIR}" \ 1051 --localstatedir="${MY_LOCALSTATEDIR}" \
365 --sharedstatedir="${MY_SHAREDSTATEDIR}" \ 1052 --sharedstatedir="${MY_SHAREDSTATEDIR}" \
366 --libdir="${MY_LIBDIR}" \ 1053 --libdir="${MY_LIBDIR}" \
367 --includedir="${MY_INCLUDEDIR}" \ 1054 --includedir="${MY_INCLUDEDIR}" \
368 --with-low-memory \ 1055 --with-low-memory \
369 --enable-local-infile \
370 --with-mysqld-user=mysql \
371 --with-client-ldflags=-lstdc++ \ 1056 --with-client-ldflags=-lstdc++ \
372 --enable-thread-safe-client \ 1057 --enable-thread-safe-client \
373 --with-comment="Gentoo Linux ${PF}" \ 1058 --with-comment="Gentoo Linux ${PF}" \
374 --with-unix-socket-path="/var/run/mysqld/mysqld.sock" \
375 --with-lib-ccflags="-fPIC" \
376 --without-readline \
377 --without-docs \ 1059 --without-docs \
1060 --with-LIBDIR="$(get_libdir)" \
378 ${myconf} || die "bad ./configure" 1061 ${myconf} || die "econf failed"
379 1062
380 # TODO Move this before autoreconf !!! 1063 # TODO: Move this before autoreconf !!!
381 find . -type f -name Makefile -print0 \ 1064 find . -type f -name Makefile -print0 \
382 | xargs -0 -n100 sed -i \ 1065 | xargs -0 -n100 sed -i \
383 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 1066 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
384 1067
385 emake || die "compile problem" 1068 if [[ $EAPI == 2 ]] && [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1069 pbxt_patch_available && use pbxt && pbxt_src_configure
1070 fi
386} 1071}
387 1072
1073# @FUNCTION: mysql_src_compile
1074# @DESCRIPTION:
1075# Compile the mysql code.
1076mysql_src_compile() {
1077 # Be backwards compatible for now
1078 case ${EAPI:-0} in
1079 2) : ;;
1080 0 | 1) mysql_src_configure ;;
1081 esac
1082
1083 emake || die "emake failed"
1084
1085 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1086 pbxt_patch_available && use pbxt && pbxt_src_compile
1087 fi
1088}
1089
1090# @FUNCTION: mysql_src_install
1091# @DESCRIPTION:
1092# Install mysql.
388mysql_src_install() { 1093mysql_src_install() {
389 1094 # Make sure the vars are correctly initialized
390 mysql_init_vars 1095 mysql_init_vars
391 make install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die
392 1096
393 insinto "${MY_INCLUDEDIR}" 1097 emake install \
394 doins "${MY_INCLUDEDIR}"/my_{config,dir}.h 1098 DESTDIR="${D}" \
1099 benchdir_root="${MY_SHAREDSTATEDIR}" \
1100 testroot="${MY_SHAREDSTATEDIR}" \
1101 || die "emake install failed"
395 1102
1103 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1104 pbxt_patch_available && use pbxt && pbxt_src_install
1105 fi
1106
396 # convenience links 1107 # Convenience links
1108 einfo "Making Convenience links for mysqlcheck multi-call binary"
397 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqlanalyze${MY_SUFFIX}" 1109 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
398 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqlrepair${MY_SUFFIX}" 1110 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
399 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqloptimize${MY_SUFFIX}" 1111 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqloptimize"
400 1112
401 # various junk (my-*.cnf moved elsewhere) 1113 # Various junk (my-*.cnf moved elsewhere)
1114 einfo "Removing duplicate /usr/share/mysql files"
402 rm -rf "${D}/usr/share/info" 1115 rm -Rf "${D}/usr/share/info"
403 for removeme in "mysql-log-rotate" mysql.server* \ 1116 for removeme in "mysql-log-rotate" mysql.server* \
404 binary-configure* my-*.cnf mi_test_all* 1117 binary-configure* my-*.cnf mi_test_all*
405 do 1118 do
406 rm -f ${D}/usr/share/mysql/${removeme} 1119 rm -f "${D}"/${MY_SHAREDSTATEDIR}/${removeme}
407 done 1120 done
408 1121
409 # TODO change at Makefile-am level
410 for moveme in "mysql_fix_privilege_tables.sql" \
411 "fill_help_tables.sql" "ndb-config-2-node.ini"
412 do
413 mv -f "${D}/usr/share/mysql/${moveme}" "${D}/usr/share/mysql${MY_SUFFIX}/" 2>/dev/null
414 done
415
416 if [[ -n "${MY_SUFFIX}" ]] ; then
417 local notcatched=$(ls "${D}/usr/share/mysql"/*)
418 if [[ -n "${notcatched}" ]] ; then
419 ewarn "QA notice"
420 ewarn "${notcatched} files in /usr/share/mysql"
421 ewarn "bug mysql-herd to manage them"
422 fi
423 rm -rf "${D}/usr/share/mysql"
424 fi
425
426 # clean up stuff for a minimal build 1122 # Clean up stuff for a minimal build
427 # this is anything server-specific
428 if useq minimal; then 1123 if use minimal ; then
1124 einfo "Remove all extra content for minimal build"
429 rm -rf ${D}${MY_SHAREDSTATEDIR}/{mysql-test,sql-bench} 1125 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench}
430 rm -f ${D}/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 1126 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
431 rm -f "${D}/usr/sbin/mysqld${MY_SUFFIX}" 1127 rm -f "${D}/usr/sbin/mysqld"
432 rm -f ${D}${MY_LIBDIR}/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 1128 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
433 fi 1129 fi
434 1130
1131 # Unless they explicitly specific USE=test, then do not install the
1132 # testsuite. It DOES have a use to be installed, esp. when you want to do a
1133 # validation of your database configuration after tuning it.
1134 if use !test ; then
1135 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
1136 fi
1137
435 # config stuff 1138 # Configuration stuff
1139 case ${MYSQL_PV_MAJOR} in
1140 3*|4.0) mysql_mycnf_version="4.0" ;;
1141 4.[1-9]|5.0) mysql_mycnf_version="4.1" ;;
1142 5.[1-9]|6*|7*) mysql_mycnf_version="5.1" ;;
1143 esac
1144 einfo "Building default my.cnf (${mysql_mycnf_version})"
436 insinto "${MY_SYSCONFDIR}" 1145 insinto "${MY_SYSCONFDIR}"
437 doins scripts/mysqlaccess.conf 1146 doins scripts/mysqlaccess.conf
438 sed -e "s!@MY_SUFFIX@!${MY_SUFFIX}!g" \ 1147 mycnf_src="my.cnf-${mysql_mycnf_version}"
439 -e "s!@DATADIR@!${DATADIR}!g" \ 1148 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
440 "${FILESDIR}/my.cnf-4.1-r1" \ 1149 "${FILESDIR}/${mycnf_src}" \
441 > "${TMPDIR}/my.cnf.ok" 1150 > "${TMPDIR}/my.cnf.ok"
1151 if use latin1 ; then
1152 sed -i \
1153 -e "/character-set/s|utf8|latin1|g" \
1154 "${TMPDIR}/my.cnf.ok"
1155 fi
442 newins "${TMPDIR}/my.cnf.ok" my.cnf 1156 newins "${TMPDIR}/my.cnf.ok" my.cnf
443 1157
444 insinto "/etc/conf.d"
445 newins "${FILESDIR}/mysql.conf.d-r1" "mysql"
446 mysql_version_is_at_least "5.00.11.00" \
447 && newins "${FILESDIR}/mysqlmanager.conf.d" "mysqlmanager"
448
449 # minimal builds don't have the server 1158 # Minimal builds don't have the MySQL server
450 if ! useq minimal; then 1159 if ! use minimal ; then
451 exeinto /etc/init.d 1160 einfo "Creating initial directories"
452 newexe "${FILESDIR}/mysql.rc6-r3" "mysql" 1161 # Empty directories ...
453
454 mysql_version_is_at_least "5.00.11.00" \
455 && newexe "${FILESDIR}/mysqlmanager.rc6" "mysqlmanager"
456 insinto /etc/logrotate.d
457 sed -e "s!___MY_SUFFIX___!${MY_SUFFIX}!g" \
458 "${FILESDIR}/logrotate-slot.mysql" \
459 > "${TMPDIR}/logrotate.mysql"
460 newins "${TMPDIR}/logrotate.mysql" "mysql${MY_SUFFIX}"
461
462 #empty dirs...
463 diropts "-m0750" 1162 diropts "-m0750"
464 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then 1163 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
465 dodir "${DATADIR}" 1164 dodir "${MY_DATADIR}"
466 keepdir "${DATADIR}" 1165 keepdir "${MY_DATADIR}"
467 chown -R mysql:mysql "${D}/${DATADIR}" 1166 chown -R mysql:mysql "${D}/${MY_DATADIR}"
468 fi 1167 fi
469 1168
470 diropts "-m0755" 1169 diropts "-m0755"
471 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do 1170 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do
472 dodir "${folder}" 1171 dodir "${folder}"
473 keepdir "${folder}" 1172 keepdir "${folder}"
474 chown -R mysql:mysql "${D}/${folder}" 1173 chown -R mysql:mysql "${D}/${folder}"
475 done 1174 done
476 fi 1175 fi
477 1176
478 # docs 1177 # Docs
1178 einfo "Installing docs"
479 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 1179 for i in README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE ; do
1180 [[ -f "$i" ]] && dodoc "$i"
1181 done
1182 doinfo "${S}"/Docs/mysql.info
1183
480 # minimal builds don't have the server 1184 # Minimal builds don't have the MySQL server
481 if ! useq minimal; then 1185 if ! use minimal ; then
1186 einfo "Including support files and sample configurations"
1187 docinto "support-files"
1188 for script in \
1189 "${S}"/support-files/my-*.cnf \
1190 "${S}"/support-files/magic \
1191 "${S}"/support-files/ndb-config-2-node.ini
1192 do
1193 [[ -f "$script" ]] && dodoc "${script}"
1194 done
1195
1196 docinto "scripts"
1197 for script in "${S}"/scripts/mysql* ; do
1198 [[ -f "$script" ]] && [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
1199 done
1200
1201 fi
1202
1203 mysql_lib_symlinks "${D}"
1204}
1205
1206# @FUNCTION: mysql_pkg_preinst
1207# @DESCRIPTION:
1208# Create the user and groups for mysql - die if that fails.
1209mysql_pkg_preinst() {
1210 enewgroup mysql 60 || die "problem adding 'mysql' group"
1211 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
1212}
1213
1214# @FUNCTION: mysql_pkg_postinst
1215# @DESCRIPTION:
1216# Run post-installation tasks:
1217# create the dir for logfiles if non-existant
1218# touch the logfiles and secure them
1219# install scripts
1220# issue required steps for optional features
1221# issue deprecation warnings
1222mysql_pkg_postinst() {
1223 # Make sure the vars are correctly initialized
1224 mysql_init_vars
1225
1226 # Check FEATURES="collision-protect" before removing this
1227 [[ -d "${ROOT}/var/log/mysql" ]] || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
1228
1229 # Secure the logfiles
1230 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
1231 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
1232 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
1233
1234 # Minimal builds don't have the MySQL server
1235 if ! use minimal ; then
482 docinto "support-files" 1236 docinto "support-files"
483 for script in \ 1237 for script in \
484 support-files/my-*.cnf \ 1238 support-files/my-*.cnf \
485 support-files/magic \ 1239 support-files/magic \
486 support-files/ndb-config-2-node.ini 1240 support-files/ndb-config-2-node.ini
487 do 1241 do
1242 [[ -f "${script}" ]] \
488 dodoc "${script}" 1243 && dodoc "${script}"
489 done 1244 done
490 1245
491 docinto "scripts" 1246 docinto "scripts"
492 for script in scripts/mysql* ; do 1247 for script in scripts/mysql* ; do
1248 [[ -f "${script}" ]] \
493 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1249 && [[ "${script%.sh}" == "${script}" ]] \
1250 && dodoc "${script}"
494 done 1251 done
495 fi
496 1252
497 # oops, temporary fix 1253 einfo
498 mysql_check_version_range "5.00.16.00 to 5.00.18.99" \ 1254 elog "You might want to run:"
499 && cp -f \ 1255 elog "\"emerge --config =${CATEGORY}/${PF}\""
500 "${WORKDIR}/mysql-extras/fill_help_tables.sql-5.0" \ 1256 elog "if this is a new install."
501 "${D}/usr/share/mysql${MY_SUFFIX}/fill_help_tables.sql" 1257 einfo
502 1258
503 if [[ ${SLOT} -gt 0 ]] ; then 1259 einfo
504 # MOVED HERE DUE TO BUG #121445 1260 elog "If you are upgrading major versions, you should run the"
505 # create a list of files, to be used 1261 elog "mysql_upgrade tool."
506 # by external utilities 1262 einfo
507 mkdir -p "${D}/var/lib/eselect/mysql/"
508 local filelist="${D}/var/lib/eselect/mysql/mysql${MY_SUFFIX}.filelist"
509 pushd "${D}/" &>/dev/null
510 find usr/bin/ usr/sbin/ \
511 -type f -name "*${MY_SUFFIX}*" \
512 -and -not -name "mysql_config${MY_SUFFIX}" \
513 > "${filelist}"
514 find usr/share/man \
515 -type f -name "*${MY_SUFFIX}*" \
516 | sed -e 's/$/.gz/' \
517 >> "${filelist}"
518 echo "${MY_SYSCONFDIR#"/"}" >> "${filelist}"
519 echo "${MY_LIBDIR#"/"}" >> "${filelist}"
520 echo "${MY_SHAREDSTATEDIR#"/"}" >> "${filelist}"
521 popd &>/dev/null
522 fi 1263 fi
523
524 # It's safer portage wis doing this in instal, but we can't
525 # if it's a slotted install
526 [[ ${SLOT} -eq 0 ]] && ROOT="${D}" mysql_lib_symlinks
527}
528 1264
529mysql_pkg_preinst() { 1265 if pbxt_available && use pbxt ; then
1266 # TODO: explain it better
1267 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
1268 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
1269 elog "if, after that, you cannot start the MySQL server,"
1270 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
1271 elog "use the MySQL upgrade script to restore the table"
1272 elog "or execute the following SQL command:"
1273 elog " CREATE TABLE IF NOT EXISTS plugin ("
1274 elog " name char(64) binary DEFAULT '' NOT NULL,"
1275 elog " dl char(128) DEFAULT '' NOT NULL,"
1276 elog " PRIMARY KEY (name)"
1277 elog " ) CHARACTER SET utf8 COLLATE utf8_bin;"
1278 fi
530 1279
531 enewgroup mysql 60 || die "problem adding group mysql" 1280 mysql_check_version_range "4.0 to 5.0.99.99" \
532 enewuser mysql 60 -1 /dev/null mysql \ 1281 && use berkdb \
533 || die "problem adding user mysql" 1282 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
534} 1283}
535 1284
1285# @FUNCTION: mysql_pkg_config
1286# @DESCRIPTION:
1287# Configure mysql environment.
536mysql_pkg_postinst() { 1288mysql_pkg_config() {
1289 local old_MY_DATADIR="${MY_DATADIR}"
537 1290
1291 # Make sure the vars are correctly initialized
538 mysql_init_vars 1292 mysql_init_vars
539 # slotted, manage lib symlinks on the real file-system
540 # to cope with other version installed
541 [[ ${SLOT} -ne 0 ]] && mysql_lib_symlinks
542 1293
543 # mind at FEATURES=collision-protect before to remove this
544 [ -d "${ROOT}/var/log/mysql" ] \
545 || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
546
547 #secure the logfiles... does this bother anybody?
548 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
549 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
550 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
551
552 if ! useq minimal; then
553 if [[ ${SLOT} -gt 0 ]] ; then
554 einfo "you may want to read:"
555 einfo "http://www.gentoo.org/doc/en/mysql-upgrade-slotted.xml"
556 einfo "you may want to run \"eselect mysql list\" followed by a "
557 einfo "\"eselect mysql set 1\" to choose the default mysql server"
558 fi
559
560 # your friendly public service announcement...
561 einfo
562 einfo "You might want to run:"
563 einfo "\"emerge --config =${CATEGORY}/${PF}\""
564 einfo "if this is a new install."
565 einfo
566 mysql_version_is_at_least "5.01.00.00" \
567 || einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
568 fi
569}
570
571mysql_pkg_config() {
572 mysql_init_vars
573 [[ -z "${DATADIR}" ]] && die "sorry, unable to find DATADIR" 1294 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
574 1295
575 if built_with_use dev-db/mysql minimal; then 1296 if built_with_use ${CATEGORY}/${PN} minimal ; then
576 die "Minimal builds do NOT include the MySQL server" 1297 die "Minimal builds do NOT include the MySQL server"
1298 fi
1299
1300 if [[ ( -n "${MY_DATADIR}" ) && ( "${MY_DATADIR}" != "${old_MY_DATADIR}" ) ]]; then
1301 local MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${MY_DATADIR})"
1302 local old_MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${old_MY_DATADIR})"
1303
1304 if [[ -d "${old_MY_DATADIR_s}" ]]; then
1305 if [[ -d "${MY_DATADIR_s}" ]]; then
1306 ewarn "Both ${old_MY_DATADIR_s} and ${MY_DATADIR_s} exist"
1307 ewarn "Attempting to use ${MY_DATADIR_s} and preserving ${old_MY_DATADIR_s}"
1308 else
1309 elog "Moving MY_DATADIR from ${old_MY_DATADIR_s} to ${MY_DATADIR_s}"
1310 mv --strip-trailing-slashes -T "${old_MY_DATADIR_s}" "${MY_DATADIR_s}" \
1311 || die "Moving MY_DATADIR failed"
1312 fi
1313 else
1314 ewarn "Previous MY_DATADIR (${old_MY_DATADIR_s}) does not exist"
1315 if [[ -d "${MY_DATADIR_s}" ]]; then
1316 ewarn "Attempting to use ${MY_DATADIR_s}"
1317 else
1318 eerror "New MY_DATADIR (${MY_DATADIR_s}) does not exist"
1319 die "Configuration Failed! Please reinstall ${CATEGORY}/${PN}"
1320 fi
1321 fi
577 fi 1322 fi
578 1323
579 local pwd1="a" 1324 local pwd1="a"
580 local pwd2="b" 1325 local pwd2="b"
581 local maxtry=5 1326 local maxtry=15
582 1327
1328 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${ROOT}/root/.my.cnf" ]; then
1329 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${ROOT}/root/.my.cnf")"
1330 fi
1331
583 if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then 1332 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
584 ewarn "You have already a MySQL database in place." 1333 ewarn "You have already a MySQL database in place."
585 ewarn "(${ROOT}/${DATADIR}/*)" 1334 ewarn "(${ROOT}/${MY_DATADIR}/*)"
586 ewarn "Please rename or delete it if you wish to replace it." 1335 ewarn "Please rename or delete it if you wish to replace it."
587 die "MySQL database already exists!" 1336 die "MySQL database already exists!"
588 fi 1337 fi
589 1338
590 einfo "Creating the mysql database and setting proper" 1339 # Bug #213475 - MySQL _will_ object strenously if your machine is named
591 einfo "permissions on it..." 1340 # localhost. Also causes weird failures.
1341 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
592 1342
1343 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
1344
593 einfo "Insert a password for the mysql 'root' user" 1345 einfo "Please provide a password for the mysql 'root' user now, in the"
1346 einfo "MYSQL_ROOT_PASSWORD env var or through the /root/.my.cnf file."
594 ewarn "Avoid [\"'\\_%] characters in the password" 1347 ewarn "Avoid [\"'\\_%] characters in the password"
595
596 read -rsp " >" pwd1 ; echo 1348 read -rsp " >" pwd1 ; echo
1349
597 einfo "Check the password" 1350 einfo "Retype the password"
598 read -rsp " >" pwd2 ; echo 1351 read -rsp " >" pwd2 ; echo
599 1352
600 if [[ "x$pwd1" != "x$pwd2" ]] ; then 1353 if [[ "x$pwd1" != "x$pwd2" ]] ; then
601 die "Passwords are not the same" 1354 die "Passwords are not the same"
1355 fi
1356 MYSQL_ROOT_PASSWORD="${pwd1}"
1357 unset pwd1 pwd2
602 fi 1358 fi
603 1359
604 local options="" 1360 local options=""
605 local sqltmp="$(emktemp)" 1361 local sqltmp="$(emktemp)"
606 1362
607 local help_tables="${MY_SHAREDSTATEDIR}/fill_help_tables.sql" 1363 local help_tables="${ROOT}${MY_SHAREDSTATEDIR}/fill_help_tables.sql"
608 [[ -r "${help_tables}" ]] \ 1364 [[ -r "${help_tables}" ]] \
609 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \ 1365 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \
610 || touch "${TMPDIR}/fill_help_tables.sql" 1366 || touch "${TMPDIR}/fill_help_tables.sql"
611 help_tables="${TMPDIR}/fill_help_tables.sql" 1367 help_tables="${TMPDIR}/fill_help_tables.sql"
612 1368
613 pushd "${TMPDIR}" &>/dev/null 1369 pushd "${TMPDIR}" &>/dev/null
614 ${ROOT}/usr/bin/mysql_install_db${MY_SUFFIX} | grep -B5 -A999 -i "ERROR" 1370 "${ROOT}/usr/bin/mysql_install_db" >"${TMPDIR}"/mysql_install_db.log 2>&1
1371 if [ $? -ne 0 ]; then
1372 grep -B5 -A999 -i "ERROR" "${TMPDIR}"/mysql_install_db.log 1>&2
1373 die "Failed to run mysql_install_db. Please review /var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"
1374 fi
615 popd &>/dev/null 1375 popd &>/dev/null
616 [[ -f ${ROOT}/${DATADIR}/mysql/user.frm ]] || die "MySQL databases not installed" 1376 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
1377 || die "MySQL databases not installed"
617 chown -R mysql:mysql ${ROOT}/${DATADIR} 2> /dev/null 1378 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
618 chmod 0750 ${ROOT}/${DATADIR} 2> /dev/null 1379 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
619 1380
1381 # Figure out which options we need to disable to do the setup
1382 helpfile="${TMPDIR}/mysqld-help"
1383 ${ROOT}/usr/sbin/mysqld --verbose --help >"${helpfile}" 2>/dev/null
1384 for opt in grant-tables host-cache name-resolve networking slave-start bdb \
1385 federated innodb ssl log-bin relay-log slow-query-log external-locking \
1386 ndbcluster \
1387 ; do
1388 optexp="--(skip-)?${opt}" optfull="--skip-${opt}"
1389 egrep -sq -- "${optexp}" "${helpfile}" && options="${options} ${optfull}"
1390 done
1391 # But some options changed names
1392 egrep -sq external-locking "${helpfile}" && \
1393 options="${options/skip-locking/skip-external-locking}"
1394
620 if mysql_version_is_at_least "4.01.03.00" ; then 1395 if mysql_version_is_at_least "4.1.3" ; then
621 options="--skip-ndbcluster"
622
623 # Filling timezones, see 1396 # Filling timezones, see
624 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html 1397 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
625 ${ROOT}/usr/bin/mysql_tzinfo_to_sql${MY_SUFFIX} ${ROOT}/usr/share/zoneinfo \ 1398 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
626 > "${sqltmp}" 2>/dev/null
627 1399
628 if [[ -r "${help_tables}" ]] ; then 1400 if [[ -r "${help_tables}" ]] ; then
629 cat "${help_tables}" >> "${sqltmp}" 1401 cat "${help_tables}" >> "${sqltmp}"
630 fi 1402 fi
631 fi 1403 fi
632 1404
1405 einfo "Creating the mysql database and setting proper"
1406 einfo "permissions on it ..."
1407
633 local socket=${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock 1408 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock"
634 local pidfile=${ROOT}/var/run/mysqld/mysqld${MY_SUFFIX}${RANDOM}.pid 1409 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid"
635 local mysqld="${ROOT}/usr/sbin/mysqld${MY_SUFFIX} \ 1410 local mysqld="${ROOT}/usr/sbin/mysqld \
636 ${options} \ 1411 ${options} \
637 --user=mysql \ 1412 --user=mysql \
638 --skip-grant-tables \
639 --basedir=${ROOT}/usr \ 1413 --basedir=${ROOT}/usr \
640 --datadir=${ROOT}/${DATADIR} \ 1414 --datadir=${ROOT}/${MY_DATADIR} \
641 --skip-innodb \
642 --skip-bdb \
643 --skip-networking \
644 --max_allowed_packet=8M \ 1415 --max_allowed_packet=8M \
645 --net_buffer_length=16K \ 1416 --net_buffer_length=16K \
1417 --default-storage-engine=MyISAM \
646 --socket=${socket} \ 1418 --socket=${socket} \
647 --pid-file=${pidfile}" 1419 --pid-file=${pidfile}"
1420 #einfo "About to start mysqld: ${mysqld}"
1421 ebegin "Starting mysqld"
648 $mysqld & 1422 ${mysqld} &
1423 rc=$?
649 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do 1424 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
650 maxtry=$(($maxtry-1)) 1425 maxtry=$((${maxtry}-1))
651 echo -n "." 1426 echo -n "."
652 sleep 1 1427 sleep 1
653 done 1428 done
1429 eend $rc
654 1430
1431 if ! [[ -S "${socket}" ]]; then
1432 die "Completely failed to start up mysqld with: ${mysqld}"
1433 fi
1434
1435 ebegin "Setting root password"
655 # do this from memory we don't want clear text password in temp files 1436 # Do this from memory, as we don't want clear text passwords in temp files
656 local sql="UPDATE mysql.user SET Password = PASSWORD('${pwd1}') WHERE USER='root'" 1437 local sql="UPDATE mysql.user SET Password = PASSWORD('${MYSQL_ROOT_PASSWORD}') WHERE USER='root'"
657 ${ROOT}/usr/bin/mysql${MY_SUFFIX} \ 1438 "${ROOT}/usr/bin/mysql" \
658 --socket=${socket} \ 1439 --socket=${socket} \
659 -hlocalhost \ 1440 -hlocalhost \
660 -e "${sql}" 1441 -e "${sql}"
1442 eend $?
661 1443
662 einfo "Loading \"zoneinfo\" this step may require few seconds" 1444 ebegin "Loading \"zoneinfo\", this step may require a few seconds ..."
663
664 ${ROOT}/usr/bin/mysql${MY_SUFFIX} \ 1445 "${ROOT}/usr/bin/mysql" \
665 --socket=${socket} \ 1446 --socket=${socket} \
666 -hlocalhost \ 1447 -hlocalhost \
667 -uroot \ 1448 -uroot \
668 -p"${pwd1}" \ 1449 -p"${MYSQL_ROOT_PASSWORD}" \
669 mysql < "${sqltmp}" 1450 mysql < "${sqltmp}"
1451 rc=$?
1452 eend $?
1453 [ $rc -ne 0 ] && ewarn "Failed to load zoneinfo!"
670 1454
671 # server stop and cleanup 1455 # Stop the server and cleanup
1456 einfo "Stopping the server ..."
672 kill $(< "${pidfile}" ) 1457 kill $(< "${pidfile}" )
673 rm "${sqltmp}" 1458 rm -f "${sqltmp}"
674 einfo "stopping the server,"
675 wait %1 1459 wait %1
676 einfo "done" 1460 einfo "Done"
677} 1461}
678 1462
679mysql_pkg_prerm() { 1463# @FUNCTION: mysql_pkg_postrm
680 if [[ ${SLOT} -gt 0 ]] ; then 1464# @DESCRIPTION:
681 # external program 1465# Remove mysql symlinks.
682 eselect mysql slot_remove "${SLOT}"
683 fi
684}
685
686mysql_pkg_postrm() { 1466mysql_pkg_postrm() {
687 mysql_lib_symlinks 1467 : # mysql_lib_symlinks "${D}"
688 if [[ ${SLOT} -gt 0 ]] ; then
689 einfo "you may want to run \"eselect mysql list\" followed by a "
690 einfo "\"eselect mysql list\" to choose the default mysql server"
691 fi
692} 1468}

Legend:
Removed from v.1.25  
changed lines
  Added in v.1.166

  ViewVC Help
Powered by ViewVC 1.1.20