/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.37 Revision 1.38
1# Copyright 1999-2006 Gentoo Foundation 1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.37 2006/10/20 12:56:30 vivo Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.38 2006/10/20 13:14:21 chtekk Exp $
4 4
5# Author: Francesco Riosa <vivo@gentoo.org> 5# Author: Francesco Riosa <vivo@gentoo.org>
6# Maintainer: Luca Longinotti <chtekk@gentoo.org> 6# Maintainer: Luca Longinotti <chtekk@gentoo.org>
7 7
8# Both MYSQL_VERSION_ID and MYSQL_PATCHSET_REV must be set in the ebuild too 8# Both MYSQL_VERSION_ID and MYSQL_PATCHSET_REV must be set in the ebuild too
201 myconf="${myconf} $(use_with perl bench)" 201 myconf="${myconf} $(use_with perl bench)"
202 myconf="${myconf} --enable-assembler" 202 myconf="${myconf} --enable-assembler"
203 myconf="${myconf} --with-extra-tools" 203 myconf="${myconf} --with-extra-tools"
204 myconf="${myconf} --with-innodb" 204 myconf="${myconf} --with-innodb"
205 myconf="${myconf} --without-readline" 205 myconf="${myconf} --without-readline"
206 mysql_version_is_at_least "5.00.00.00" && myconf="${myconf} $(use_with raid)" 206 mysql_version_is_at_least "5.00.00.00" || myconf="${myconf} $(use_with raid)"
207 207
208 if useq "ssl" ; then 208 if useq "ssl" ; then
209 # --with-vio is not needed anymore, it's on by default and 209 # --with-vio is not needed anymore, it's on by default and
210 # has been removed from configure 210 # has been removed from configure
211 mysql_version_is_at_least "5.00.04.00" || myconf="${myconf} --with-vio" 211 mysql_version_is_at_least "5.00.04.00" || myconf="${myconf} --with-vio"

Legend:
Removed from v.1.37  
changed lines
  Added in v.1.38

  ViewVC Help
Powered by ViewVC 1.1.20