/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.58 Revision 1.109
1# Copyright 1999-2006 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.58 2007/01/04 20:38:16 vivo Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.109 2009/02/28 10:51:57 robbat2 Exp $
4# kate: encoding utf-8; eol unix;
5# kate: indent-width 4; mixedindent off; remove-trailing-space on; space-indent off;
6# kate: word-wrap-column 80; word-wrap off;
7 4
8# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 5# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
6# Maintainer: MySQL Team <mysql-bugs@gentoo.org>
9# Maintainer: Luca Longinotti <chtekk@gentoo.org> 7# - Luca Longinotti <chtekk@gentoo.org>
8# - Robin H. Johnson <robbat2@gentoo.org>
10 9
11# Note that MYSQL_VERSION_ID must be empty !!! 10WANT_AUTOCONF="latest"
11WANT_AUTOMAKE="latest"
12 12
13ECLASS="mysql"
14INHERITED="$INHERITED $ECLASS"
15inherit eutils flag-o-matic gnuconfig autotools mysql_fx 13inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator
16 14
17# avoid running userspace code 8 times per ebuild :( 15# Shorten the path because the socket path length must be shorter than 107 chars
18if [[ "${_MYPVR}" != "${PVR}" ]] && [[ -n "${PVR}" ]] 16# and we will run a mysql server during test phase
19then 17S="${WORKDIR}/mysql"
20 _MYPVR=${PVR}
21 18
22 [[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20070104" 19[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z"
23 20if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
24 if [[ ${PR#r} -lt 60 ]] ; then 21 EGIT_PROJECT=mysql-extras
25 IS_BITKEEPER=0 22 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
26 elif [[ ${PR#r} -lt 90 ]] ; then 23 inherit git
27 IS_BITKEEPER=60
28 else
29 IS_BITKEEPER=90
30 fi 24fi
31 25
32 # MYSQL_VERSION_ID will be: 26# MYSQL_VERSION_ID will be:
33 # major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 27# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
34 # This is an important part, because many of the choices the MySQL ebuild will do 28# This is an important part, because many of the choices the MySQL ebuild will do
35 # depend on this variable. 29# depend on this variable.
36 # In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803" 30# In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803"
31# We also strip off upstream's trailing letter that they use to respin tarballs
32
37 MYSQL_VERSION_ID="" 33MYSQL_VERSION_ID=""
34tpv="${PV%[a-z]}"
38 tpv=( ${PV//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}" 35tpv=( ${tpv//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}"
39 for vatom in 0 1 2 3 ; do 36for vatom in 0 1 2 3 ; do
40 # pad to length 2 37 # pad to length 2
41 tpv[${vatom}]="00${tpv[${vatom}]}" 38 tpv[${vatom}]="00${tpv[${vatom}]}"
42 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}" 39 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}"
43 done 40done
44 # strip leading "0" (otherwise it's considered an octal number by BASH) 41# strip leading "0" (otherwise it's considered an octal number by BASH)
45 MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"} 42MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"}
46 43
47 # Be warned, *DEPEND are version-dependant 44# Be warned, *DEPEND are version-dependant
45# These are used for both runtime and compiletime
48 DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d ) 46DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )
49 userland_GNU? ( sys-process/procps ) 47 userland_GNU? ( sys-process/procps )
50 >=sys-apps/sed-4 48 >=sys-apps/sed-4
51 >=sys-apps/texinfo-4.7-r1 49 >=sys-apps/texinfo-4.7-r1
52 >=sys-libs/readline-4.1 50 >=sys-libs/readline-4.1
53 >=sys-libs/zlib-1.2.3 51 >=sys-libs/zlib-1.2.3"
54 "
55 52
56 # having different flavours at the same time is not a good idea 53# Having different flavours at the same time is not a good idea
57 for i in "" "-community" "-slotted" ; do 54for i in "" "-community" ; do
58 [[ "${i}" == ${PN#mysql} ]] || 55 [[ "${i}" == ${PN#mysql} ]] ||
59 DEPEND="${DEPEND} !dev-db/mysql${i}" 56 DEPEND="${DEPEND} !dev-db/mysql${i}"
60 done 57done
61 58
59RDEPEND="${DEPEND}
60 !minimal? ( dev-db/mysql-init-scripts )
61 selinux? ( sec-policy/selinux-mysql )"
62
63# compile-time-only
62 mysql_version_is_at_least "5.1" \ 64mysql_version_is_at_least "5.1" \
63 || DEPEND="${DEPEND} berkdb? ( sys-apps/ed )" 65|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
64 66
67# compile-time-only
68mysql_version_is_at_least "5.1.12" \
69&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
70
65 # dev-perl/DBD-mysql is needed by some scripts installed by MySQL 71# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
66 PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 72PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
67 73
68 if mysql_version_is_at_least "5.1.12" ; then 74# For other stuff to bring us in
69 DEPEND="${DEPEND} innodb? ( >=dev-util/cmake-2.4.3 )" 75PDEPEND="${PDEPEND} =virtual/mysql-$(get_version_component_range 1-2 ${PV})"
76
77# Work out the default SERVER_URI correctly
78if [ -z "${SERVER_URI}" ]; then
79 # The community build is on the mirrors
80 if [ "${PN}" == "mysql-community" ]; then
81 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz"
82 # The enterprise source is on the primary site only
83 elif [ "${PN}" == "mysql" ]; then
84 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
85 fi
70 fi 86fi
71 87
72 # Shorten the path because the socket path length must be shorter than 107 chars
73 # and we will run a mysql server during test phase
74 S="${WORKDIR}/mysql"
75
76 # BitKeeper dependency, compile-time only
77 [[ ${IS_BITKEEPER} -eq 90 ]] && DEPEND="${DEPEND} dev-util/bk_client"
78
79 if [[ ${PN} == "mysql-slotted" ]] ; then
80 DEPEND="${DEPEND} app-admin/eselect-mysql"
81 fi
82
83 if [[ ${PN} == "mysql-slotted" ]] ; then
84 SLOT=""
85 tpv=( ${PV//[-._]/ } )
86 for vatom in 0 1 2 ; do
87 SLOT="${SLOT}${tpv[${vatom}]}_"
88 done
89 #finally SLOT=5_0_24
90 SLOT=${SLOT:0:${#SLOT}-1}
91 else
92 SLOT="0"
93 fi
94
95 # Define correct SRC_URIs 88# Define correct SRC_URIs
96 SRC_URI=" 89SRC_URI="${SERVER_URI}"
97 ${SERVER_URI} 90
91[[ ${MY_EXTRAS_VER} != live ]] && SRC_URI="${SRC_URI}
92 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
98 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 93 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
99 "
100 mysql_version_is_at_least "5.1.12" \ 94mysql_version_is_at_least "5.1.12" \
101 && [[ -n "${PBXT_VERSION}" ]] \ 95&& [[ -n "${PBXT_VERSION}" ]] \
102 && SRC_URI="${SRC_URI} pbxt? ( mirror://sourceforge/pbxt/pbxt-${PBXT_VERSION}.tar.gz )" 96&& SRC_URI="${SRC_URI} pbxt? ( mirror://sourceforge/pbxt/pbxt-${PBXT_VERSION}.tar.gz )"
103 97
104 DESCRIPTION="A fast, multi-threaded, multi-user SQL database server." 98DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
105 HOMEPAGE="http://www.mysql.com/" 99HOMEPAGE="http://www.mysql.com/"
106 LICENSE="GPL-2" 100LICENSE="GPL-2"
101SLOT="0"
107 IUSE="big-tables debug embedded minimal perl selinux ssl static" 102IUSE="big-tables debug embedded minimal perl selinux ssl static"
108 RESTRICT="confcache"
109 103
110 mysql_version_is_at_least "4.1" \ 104mysql_version_is_at_least "4.1" \
111 && IUSE="${IUSE} latin1" 105&& IUSE="${IUSE} latin1"
112 106
113 mysql_version_is_at_least "4.1.3" \ 107mysql_version_is_at_least "4.1.3" \
114 && IUSE="${IUSE} cluster extraengine" 108&& IUSE="${IUSE} cluster extraengine"
115 109
116 mysql_version_is_at_least "5.0" \ 110mysql_version_is_at_least "5.0" \
117 || IUSE="${IUSE} raid" 111|| IUSE="${IUSE} raid"
118 112
119 mysql_version_is_at_least "5.0.18" \ 113mysql_version_is_at_least "5.0.18" \
120 && IUSE="${IUSE} max-idx-128" 114&& IUSE="${IUSE} max-idx-128"
121 115
122 mysql_version_is_at_least "5.1" \ 116mysql_version_is_at_least "5.1" \
123 && IUSE="${IUSE} innodb"
124
125 mysql_version_is_at_least "5.1" \
126 || IUSE="${IUSE} berkdb" 117|| IUSE="${IUSE} berkdb"
127 118
128 mysql_version_is_at_least "5.1.12" \ 119mysql_version_is_at_least "5.1.12" \
129 && IUSE="${IUSE} pbxt" 120&& IUSE="${IUSE} pbxt"
130
131 RDEPEND="${DEPEND}
132 sys-apps/mysql
133 selinux? ( sec-policy/selinux-mysql )
134 "
135
136fi # if [[ "${_MYPVR}" != "${PVR}" ]]
137 121
138EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst \ 122EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst \
139 pkg_postinst pkg_config pkg_postrm 123 pkg_postinst pkg_config pkg_postrm
140 124
141# 125#
142# HELPER FUNCTIONS: 126# HELPER FUNCTIONS:
143# 127#
144
145bitkeeper_fetch() {
146
147 local reposuf
148 if [[ -z "${1}" ]] ; then
149 local tpv
150 tpv=( ${PV//[-._]/ } )
151 reposuf="mysql-${tpv[0]}.${tpv[1]}"
152 else
153 reposuf="${1}"
154 fi
155 einfo "using \"${reposuf}\" repository."
156 local repo_uri="bk://mysql.bkbits.net/${reposuf}"
157 ## -- ebk_store_dir: bitkeeper sources store directory
158 local ebk_store_dir="${PORTAGE_ACTUAL_DISTDIR-${DISTDIR}}/bk-src"
159 ## -- ebk_fetch_cmd: bitkeeper fetch command
160 # always fetch the latest revision, use -r<revision> if a specified revision is wanted
161 # hint: does not work
162 local ebk_fetch_cmd="sfioball"
163 ## -- ebk_update_cmd: bitkeeper update command
164 local ebk_update_cmd="update"
165
166 #addread "/etc/bitkeeper"
167 addwrite "${ebk_store_dir}"
168
169 if [[ ! -d "${ebk_store_dir}" ]]; then
170 debug-print "${FUNCNAME}: initial checkout. creating bitkeeper directory"
171 mkdir -p "${ebk_store_dir}" || die "${EBK}: can't mkdir ${ebk_store_dir}."
172 fi
173
174 pushd "${ebk_store_dir}" || die "${EBK}: can't chdir to ${ebk_store_dir}"
175
176 local wc_path=${reposuf}
177
178 if [[ ! -d "${wc_path}" ]]; then
179 local options="-r+"
180 # first check out
181 einfo "bitkeeper check out start -->"
182 einfo " repository: ${repo_uri}"
183 ${ebk_fetch_cmd} ${options} "${repo_uri}" ${wc_path} \
184 || die "${EBK}: can't fetch from ${repo_uri}."
185 else
186 if [[ ! -d "${wc_path}/BK" ]]; then
187 popd
188 die "Look like ${wc_path} is not a bitkeeper path."
189 fi
190
191 # update working copy
192 einfo "bitkeeper update start -->"
193 einfo " repository: ${repo_uri}"
194
195 ${ebk_update_cmd} "${repo_uri}" "${wc_path}" \
196 || die "BK: can't update from ${repo_uri} to ${wc_path}."
197 fi
198
199 einfo " working copy: ${wc_path}"
200 cd "${wc_path}"
201 rsync -rlpgo --exclude="BK/" . "${S}" || die "BK: can't export to ${S}."
202
203 echo
204 popd
205
206}
207 128
208mysql_disable_test() { 129mysql_disable_test() {
209 local testname="${1}" ; shift 130 local testname="${1}" ; shift
210 local reason="${@}" 131 local reason="${@}"
211 local mysql_disable_file="${S}/mysql-test/t/disabled.def" 132 local mysql_disable_file="${S}/mysql-test/t/disabled.def"
212 echo ${testname} : ${reason} >> "${mysql_disable_file}" 133 echo ${testname} : ${reason} >> "${mysql_disable_file}"
213 ewarn "test \"${testname}\" disabled because: \"${reason}\"" 134 ewarn "test '${testname}' disabled: '${reason}'"
214} 135}
215 136
216# void mysql_init_vars() 137# void mysql_init_vars()
217# 138#
218# Initialize global variables 139# Initialize global variables
219# 2005-11-19 <vivo@gentoo.org> 140# 2005-11-19 <vivo@gentoo.org>
220 141
221mysql_init_vars() { 142mysql_init_vars() {
222 if [[ ${SLOT} == "0" ]] ; then
223 MY_SUFFIX=""
224 else
225 MY_SUFFIX=${MY_SUFFIX:-"-${SLOT}"}
226 fi
227 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR:-"/usr/share/mysql${MY_SUFFIX}"} 143 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR="/usr/share/mysql"}
228 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql${MY_SUFFIX}"} 144 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql"}
229 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql${MY_SUFFIX}"} 145 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql"}
230 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql${MY_SUFFIX}"} 146 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql"}
231 MY_LOGDIR=${MY_LOGDIR="/var/log/mysql${MY_SUFFIX}"} 147 MY_LOGDIR=${MY_LOGDIR="/var/log/mysql"}
232 MY_INCLUDEDIR=${MY_INCLUDEDIR="/usr/include/mysql${MY_SUFFIX}"} 148 MY_INCLUDEDIR=${MY_INCLUDEDIR="/usr/include/mysql"}
233 149
234 if [[ -z "${DATADIR}" ]] ; then 150 if [[ -z "${MY_DATADIR}" ]] ; then
235 DATADIR="" 151 MY_DATADIR=""
236 if [[ -f "${MY_SYSCONFDIR}/my.cnf" ]] ; then 152 if [[ -f "${MY_SYSCONFDIR}/my.cnf" ]] ; then
237 DATADIR=`"my_print_defaults${MY_SUFFIX}" mysqld 2>/dev/null \ 153 MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
238 | sed -ne '/datadir/s|^--datadir=||p' \ 154 | sed -ne '/datadir/s|^--datadir=||p' \
239 | tail -n1` 155 | tail -n1`
240 if [[ -z "${DATADIR}" ]] ; then 156 if [[ -z "${MY_DATADIR}" ]] ; then
241 DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" \ 157 MY_DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" \
242 | sed -e 's/.*=\s*//'` 158 | sed -e 's/.*=\s*//' \
159 | tail -n1`
243 fi 160 fi
244 fi 161 fi
245 if [[ -z "${DATADIR}" ]] ; then 162 if [[ -z "${MY_DATADIR}" ]] ; then
246 DATADIR="${MY_LOCALSTATEDIR}" 163 MY_DATADIR="${MY_LOCALSTATEDIR}"
247 einfo "Using default DATADIR" 164 einfo "Using default MY_DATADIR"
248 fi 165 fi
249 elog "MySQL DATADIR is ${DATADIR}" 166 elog "MySQL MY_DATADIR is ${MY_DATADIR}"
250 167
251 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then 168 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then
252 if [[ -e "${DATADIR}" ]] ; then 169 if [[ -e "${MY_DATADIR}" ]] ; then
253 elog "Previous datadir found, it's YOUR job to change" 170 # If you get this and you're wondering about it, see bug #207636
254 elog "ownership and take care of it" 171 elog "MySQL datadir found in ${MY_DATADIR}"
172 elog "A new one will not be created."
255 PREVIOUS_DATADIR="yes" 173 PREVIOUS_DATADIR="yes"
256 else 174 else
257 PREVIOUS_DATADIR="no" 175 PREVIOUS_DATADIR="no"
258 fi 176 fi
259 export PREVIOUS_DATADIR 177 export PREVIOUS_DATADIR
261 fi 179 fi
262 180
263 MY_SOURCEDIR=${SERVER_URI##*/} 181 MY_SOURCEDIR=${SERVER_URI##*/}
264 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*} 182 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
265 183
266 export MY_SUFFIX MY_SHAREDSTATEDIR MY_SYSCONFDIR 184 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
267 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR 185 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
268 export MY_INCLUDEDIR DATADIR MY_SOURCEDIR 186 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
269} 187}
270 188
271configure_minimal() { 189configure_minimal() {
272 # These are things we exclude from a minimal build, please 190 # These are things we exclude from a minimal build, please
273 # note that the server actually does get built and installed, 191 # note that the server actually does get built and installed,
274 # but we then delete it before packaging. 192 # but we then delete it before packaging.
275 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication" 193 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication readline"
276 194
277 for i in ${minimal_exclude_list} ; do 195 for i in ${minimal_exclude_list} ; do
278 myconf="${myconf} --without-${i}" 196 myconf="${myconf} --without-${i}"
279 done 197 done
280 myconf="${myconf} --with-extra-charsets=none" 198 myconf="${myconf} --with-extra-charsets=none"
281 myconf="${myconf} --enable-local-infile" 199 myconf="${myconf} --enable-local-infile"
282 200
283 if useq "static" ; then 201 if use static ; then
284 myconf="${myconf} --with-client-ldflags=-all-static" 202 myconf="${myconf} --with-client-ldflags=-all-static"
285 myconf="${myconf} --disable-shared" 203 myconf="${myconf} --disable-shared --with-pic"
286 else 204 else
287 myconf="${myconf} --enable-shared --enable-static" 205 myconf="${myconf} --enable-shared --enable-static"
288 fi 206 fi
289 207
290 if mysql_version_is_at_least "4.01.00.00" && ! useq "latin1" ; then 208 if mysql_version_is_at_least "4.1" && ! use latin1 ; then
291 myconf="${myconf} --with-charset=utf8" 209 myconf="${myconf} --with-charset=utf8"
292 myconf="${myconf} --with-collation=utf8_general_ci" 210 myconf="${myconf} --with-collation=utf8_general_ci"
293 else 211 else
294 myconf="${myconf} --with-charset=latin1" 212 myconf="${myconf} --with-charset=latin1"
295 myconf="${myconf} --with-collation=latin1_swedish_ci" 213 myconf="${myconf} --with-collation=latin1_swedish_ci"
303 myconf="${myconf} --with-mysqld-user=mysql" 221 myconf="${myconf} --with-mysqld-user=mysql"
304 myconf="${myconf} --with-server" 222 myconf="${myconf} --with-server"
305 myconf="${myconf} --with-unix-socket-path=/var/run/mysqld/mysqld.sock" 223 myconf="${myconf} --with-unix-socket-path=/var/run/mysqld/mysqld.sock"
306 myconf="${myconf} --without-libwrap" 224 myconf="${myconf} --without-libwrap"
307 225
308 if useq "static" ; then 226 if use static ; then
309 myconf="${myconf} --with-mysqld-ldflags=-all-static" 227 myconf="${myconf} --with-mysqld-ldflags=-all-static"
310 myconf="${myconf} --with-client-ldflags=-all-static" 228 myconf="${myconf} --with-client-ldflags=-all-static"
311 myconf="${myconf} --disable-shared" 229 myconf="${myconf} --disable-shared --with-pic"
312 else 230 else
313 myconf="${myconf} --enable-shared --enable-static" 231 myconf="${myconf} --enable-shared --enable-static"
314 fi 232 fi
315 233
316 if useq "debug" ; then 234 if use debug ; then
317 myconf="${myconf} --with-debug=full" 235 myconf="${myconf} --with-debug=full"
318 else 236 else
319 myconf="${myconf} --without-debug" 237 myconf="${myconf} --without-debug"
320 mysql_version_is_at_least "4.1.3" \ 238 mysql_version_is_at_least "4.1.3" \
321 && useq "cluster" \ 239 && use cluster \
322 && myconf="${myconf} --without-ndb-debug" 240 && myconf="${myconf} --without-ndb-debug"
323 fi 241 fi
324 242
243 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
244 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
245 ewarn "and a collation of ${MYSQL_DEFAULT_COLLATION}."
246 ewarn "You MUST file bugs without these variables set."
247 myconf="${myconf} --with-charset=${MYSQL_DEFAULT_CHARSET}"
248 myconf="${myconf} --with-collation=${MYSQL_DEFAULT_COLLATION}"
325 if mysql_version_is_at_least "4.1" && ! useq "latin1" ; then 249 elif mysql_version_is_at_least "4.1" && ! use latin1 ; then
326 myconf="${myconf} --with-charset=utf8" 250 myconf="${myconf} --with-charset=utf8"
327 myconf="${myconf} --with-collation=utf8_general_ci" 251 myconf="${myconf} --with-collation=utf8_general_ci"
328 else 252 else
329 myconf="${myconf} --with-charset=latin1" 253 myconf="${myconf} --with-charset=latin1"
330 myconf="${myconf} --with-collation=latin1_swedish_ci" 254 myconf="${myconf} --with-collation=latin1_swedish_ci"
331 fi 255 fi
332 256
333 if useq "embedded" ; then 257 if use embedded ; then
334 myconf="${myconf} --with-embedded-privilege-control" 258 myconf="${myconf} --with-embedded-privilege-control"
335 myconf="${myconf} --with-embedded-server" 259 myconf="${myconf} --with-embedded-server"
336 else 260 else
337 myconf="${myconf} --without-embedded-privilege-control" 261 myconf="${myconf} --without-embedded-privilege-control"
338 myconf="${myconf} --without-embedded-server" 262 myconf="${myconf} --without-embedded-server"
346 myconf="${myconf} --with-extra-tools" 270 myconf="${myconf} --with-extra-tools"
347 myconf="${myconf} --with-innodb" 271 myconf="${myconf} --with-innodb"
348 myconf="${myconf} --without-readline" 272 myconf="${myconf} --without-readline"
349 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)" 273 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
350 274
351 if useq "ssl" ; then
352 # --with-vio is not needed anymore, it's on by default and 275 # --with-vio is not needed anymore, it's on by default and
353 # has been removed from configure 276 # has been removed from configure
277 if use ssl ; then
354 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio" 278 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
279 fi
280
281 if mysql_version_is_at_least "5.1.11" ; then
282 myconf="${myconf} $(use_with ssl)"
283 else
284 myconf="${myconf} $(use_with ssl openssl)"
285 fi
286
355 if mysql_version_is_at_least "5.0.6" ; then 287 if mysql_version_is_at_least "5.0.60" ; then
356 # myconf="${myconf} --with-yassl" 288 if use berkdb ; then
289 elog "Berkeley DB support was disabled due to build failures"
290 elog "on multiple arches, go to a version earlier than 5.0.60"
291 elog "if you want it again. Gentoo bug #224067."
292 fi
357 myconf="${myconf} --with-ssl" 293 myconf="${myconf} --without-berkeley-db"
294 elif use berkdb ; then
295 # The following fix is due to a bug with bdb on SPARC's. See:
296 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
297 # It comes down to non-64-bit safety problems.
298 if use alpha || use amd64 || use hppa || use mips || use sparc ; then
299 elog "Berkeley DB support was disabled due to compatibility issues on this arch"
300 myconf="${myconf} --without-berkeley-db"
358 else 301 else
359 myconf="${myconf} --with-openssl" 302 myconf="${myconf} --with-berkeley-db=./bdb"
360 fi
361 else
362 myconf="${myconf} --without-openssl"
363 fi 303 fi
364 304 else
365 # The following fix is due to a bug with bdb on SPARC's. See:
366 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
367 # It comes down to non-64-bit safety problems.
368 if useq "sparc" || useq "alpha" || useq "hppa" || useq "mips" || useq "amd64" ; then
369 elog "Berkeley DB support was disabled due to incompatible arch"
370 myconf="${myconf} --without-berkeley-db" 305 myconf="${myconf} --without-berkeley-db"
371 else
372 if useq "berkdb" ; then
373 myconf="${myconf} --with-berkeley-db=./bdb"
374 else
375 myconf="${myconf} --without-berkeley-db"
376 fi
377 fi 306 fi
378 307
379 if mysql_version_is_at_least "4.1.3" ; then 308 if mysql_version_is_at_least "4.1.3" ; then
380 myconf="${myconf} --with-geometry" 309 myconf="${myconf} --with-geometry"
381 myconf="${myconf} $(use_with cluster ndbcluster)" 310 myconf="${myconf} $(use_with cluster ndbcluster)"
382 fi 311 fi
383 312
384 if mysql_version_is_at_least "4.1.3" && useq "extraengine" ; then 313 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
385 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html 314 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
386 myconf="${myconf} --with-archive-storage-engine" 315 myconf="${myconf} --with-archive-storage-engine"
387 316
388 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html 317 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
389 myconf="${myconf} --with-csv-storage-engine" 318 myconf="${myconf} --with-csv-storage-engine"
399 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html" 328 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html"
400 myconf="${myconf} --with-federated-storage-engine" 329 myconf="${myconf} --with-federated-storage-engine"
401 fi 330 fi
402 fi 331 fi
403 332
333 if [ "${PN}" == "mysql-community" ]; then
334 myconf="${myconf} --enable-community-features"
335 fi
336
404 mysql_version_is_at_least "5.0.18" \ 337 mysql_version_is_at_least "5.0.18" \
405 && useq "max-idx-128" \ 338 && use max-idx-128 \
406 && myconf="${myconf} --with-max-indexes=128" 339 && myconf="${myconf} --with-max-indexes=128"
407} 340}
408 341
409configure_51() { 342configure_51() {
410 # TODO: !!!! readd --without-readline 343 # TODO: !!!! readd --without-readline
415 myconf="${myconf} --with-geometry" 348 myconf="${myconf} --with-geometry"
416 myconf="${myconf} --with-readline" 349 myconf="${myconf} --with-readline"
417 myconf="${myconf} --with-row-based-replication" 350 myconf="${myconf} --with-row-based-replication"
418 myconf="${myconf} --with-zlib=/usr/$(get_libdir)" 351 myconf="${myconf} --with-zlib=/usr/$(get_libdir)"
419 myconf="${myconf} --without-pstack" 352 myconf="${myconf} --without-pstack"
420 useq "max-idx-128" && myconf="${myconf} --with-max-indexes=128" 353 use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
421 354
422 # 5.1 introduces a new way to manage storage engines (plugins) 355 # 5.1 introduces a new way to manage storage engines (plugins)
423 # like configuration=none 356 # like configuration=none
424 local plugins="csv,myisam,myisammrg,heap" 357 local plugins="csv,myisam,myisammrg,heap"
425 if useq "extraengine" ; then 358 if use extraengine ; then
426 # like configuration=max-no-ndb, archive and example removed in 5.1.11 359 # like configuration=max-no-ndb, archive and example removed in 5.1.11
427 plugins="${plugins},archive,blackhole,example,federated,partition" 360 plugins="${plugins},archive,blackhole,example,federated,partition"
428 361
429 elog "Before using the Federated storage engine, please be sure to read" 362 elog "Before using the Federated storage engine, please be sure to read"
430 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 363 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
431 fi 364 fi
432 365
433 if useq "innodb" ; then 366 # Upstream specifically requests that InnoDB always be built.
434 plugins="${plugins},innobase" 367 plugins="${plugins},innobase"
435 fi
436 368
437 # like configuration=max-no-ndb 369 # like configuration=max-no-ndb
438 if useq "cluster" ; then 370 if use cluster ; then
439 plugins="${plugins},ndbcluster" 371 plugins="${plugins},ndbcluster"
440 myconf="${myconf} --with-ndb-binlog" 372 myconf="${myconf} --with-ndb-binlog"
441 fi 373 fi
442 374
443 if mysql_version_is_at_least "5.2" ; then 375 if mysql_version_is_at_least "5.2" ; then
453 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 385 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
454 386
455 einfo "Reconfiguring dir '${PWD}'" 387 einfo "Reconfiguring dir '${PWD}'"
456 AT_GNUCONF_UPDATE="yes" eautoreconf 388 AT_GNUCONF_UPDATE="yes" eautoreconf
457 389
458 local myconf 390 local myconf=""
459 myconf="${myconf} --with-mysql=${S}"
460 mkdir -p ${T}/lib
461 myconf="${myconf} --libdir=${D}/${MY_LIBDIR}" 391 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}"
462 useq "debug" && myconf="${myconf} --with-debug=full" 392 use debug && myconf="${myconf} --with-debug=full"
463 # TODO is safe/needed to use econf here ? 393 # TODO: is it safe/needed to use econf here ?
464 ./configure ${myconf} || die "problem configuring pbxt storage engine" 394 ./configure ${myconf} || die "Problem configuring PBXT storage engine"
465 # TODO is safe/needed to use emake here ? 395 # TODO: is it safe/needed to use emake here ?
466 make || die "problem making pbxt storage engine (${myconf})" 396 make || die "Problem making PBXT storage engine (${myconf})"
467 397
468 popd 398 popd
469 # TODO: modify test suite 399 # TODO: modify test suite for PBXT
470} 400}
471 401
472pbxt_src_install() { 402pbxt_src_install() {
473 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 403 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
474 make install || die "failed pbxt install" 404 make install || die "Failed to install PBXT"
475 popd 405 popd
476} 406}
477 407
478# 408#
479# EBUILD FUNCTIONS 409# EBUILD FUNCTIONS
480# 410#
481
482mysql_pkg_setup() { 411mysql_pkg_setup() {
483 enewgroup mysql 60 || die "problem adding 'mysql' group" 412 if hasq test ${FEATURES} ; then
484 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 413 if ! use minimal ; then
414 if [[ $UID -eq 0 ]]; then
415 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
416 fi
417 fi
418 fi
485 419
486 # Check for USE flag problems in pkg_setup 420 # Check for USE flag problems in pkg_setup
487 if useq "static" && useq "ssl" ; then 421 if use static && use ssl ; then
488 eerror "MySQL does not support being built statically with SSL support enabled!" 422 eerror "MySQL does not support being built statically with SSL support enabled!"
489 die "MySQL does not support being built statically with SSL support enabled!" 423 die "MySQL does not support being built statically with SSL support enabled!"
490 fi 424 fi
491 425
492 if ! mysql_version_is_at_least "5.0" \ 426 if ! mysql_version_is_at_least "5.0" \
493 && useq "raid" \ 427 && use raid \
494 && useq "static" ; then 428 && use static ; then
495 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically" 429 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically"
496 eerror "with RAID support enabled." 430 eerror "with RAID support enabled."
497 die "USE flags 'raid' and 'static' conflict!" 431 die "USE flags 'raid' and 'static' conflict!"
498 fi 432 fi
499 433
500 if mysql_version_is_at_least "4.1.3" \ 434 if mysql_version_is_at_least "4.1.3" \
501 && ( useq "cluster" || useq "extraengine" ) \ 435 && ( use cluster || use extraengine ) \
502 && useq "minimal" ; then 436 && use minimal ; then
503 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 437 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
504 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 438 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
505 fi 439 fi
506 440
441 # This should come after all of the die statements
442 enewgroup mysql 60 || die "problem adding 'mysql' group"
443 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
444
507 mysql_check_version_range "4.0 to 5.0.99.99" \ 445 mysql_check_version_range "4.0 to 5.0.99.99" \
508 && useq "berkdb" \ 446 && use berkdb \
509 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 447 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
510} 448}
511 449
512mysql_src_unpack() { 450mysql_src_unpack() {
513 # Initialize the proper variables first 451 # Initialize the proper variables first
514 mysql_init_vars 452 mysql_init_vars
515 453
516 unpack ${A} 454 unpack ${A}
517 if [[ ${IS_BITKEEPER} -eq 90 ]] ; then 455 # Grab the patches
518 if mysql_check_version_range "5.1 to 5.1.99" ; then 456 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack
519 bitkeeper_fetch "mysql-5.1-ndb" 457
520 elif mysql_check_version_range "5.2.0 to 5.2.99" ; then
521 bitkeeper_fetch "mysql-5.2-falcon"
522 else
523 bitkeeper_fetch
524 fi
525 cd "${S}"
526 einfo "running upstream autorun on bk sources"
527 BUILD/autorun.sh
528 else
529 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}" 458 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}"
530 cd "${S}" 459 cd "${S}"
531 fi
532 460
533 # Apply the patches for this MySQL version 461 # Apply the patches for this MySQL version
534 EPATCH_SUFFIX="patch" 462 EPATCH_SUFFIX="patch"
535 mkdir -p "${EPATCH_SOURCE}" || die "unable to create epatch directory" 463 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory"
464 # Clean out old items
465 rm -f "${EPATCH_SOURCE}"/*
466 # Now link in right patches
536 mysql_mv_patches 467 mysql_mv_patches
537 epatch || die "failed to apply all patches" 468 # And apply
469 epatch
538 470
539 # Additional checks, remove bundled zlib 471 # Additional checks, remove bundled zlib
540 rm -f "${S}/zlib/"*.[ch] 472 rm -f "${S}/zlib/"*.[ch]
541 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 473 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
542 rm -f "scripts/mysqlbug" 474 rm -f "scripts/mysqlbug"
557 489
558 local rebuilddirlist d 490 local rebuilddirlist d
559 491
560 if mysql_version_is_at_least "5.1.12" ; then 492 if mysql_version_is_at_least "5.1.12" ; then
561 rebuilddirlist="." 493 rebuilddirlist="."
562 # TODO IMPO! Check this with a cmake expert 494 # TODO: check this with a cmake expert
563 useq "innodb" \
564 && cmake \ 495 cmake \
565 -DCMAKE_C_COMPILER=$(which $(tc-getCC)) \ 496 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
566 -DCMAKE_CXX_COMPILER=$(which $(tc-getCC)) \ 497 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
567 "storage/innobase" 498 "storage/innobase"
568 else 499 else
569 rebuilddirlist=". innobase" 500 rebuilddirlist=". innobase"
570 fi 501 fi
571 502
575 AT_GNUCONF_UPDATE="yes" eautoreconf 506 AT_GNUCONF_UPDATE="yes" eautoreconf
576 popd &>/dev/null 507 popd &>/dev/null
577 done 508 done
578 509
579 if mysql_check_version_range "4.1 to 5.0.99.99" \ 510 if mysql_check_version_range "4.1 to 5.0.99.99" \
580 && useq "berkdb" ; then 511 && use berkdb ; then
581 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh" 512 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
513 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
514 || die "Could not copy libtool.m4 to bdb/dist/"
515 #These files exist only with libtool-2*, and need to be included.
516 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then
517 cat "/usr/share/aclocal/ltsugar.m4" >> "bdb/dist/aclocal/libtool.ac"
518 cat "/usr/share/aclocal/ltversion.m4" >> "bdb/dist/aclocal/libtool.ac"
519 cat "/usr/share/aclocal/lt~obsolete.m4" >> "bdb/dist/aclocal/libtool.ac"
520 cat "/usr/share/aclocal/ltoptions.m4" >> "bdb/dist/aclocal/libtool.ac"
521 fi
582 pushd "bdb/dist" \ 522 pushd "bdb/dist" &>/dev/null
583 && sh s_all \ 523 sh s_all \
584 || die "Failed bdb reconfigure" \ 524 || die "Failed bdb reconfigure"
585 &>/dev/null
586 popd &>/dev/null 525 popd &>/dev/null
587 fi 526 fi
588} 527}
589 528
590mysql_src_compile() { 529mysql_src_compile() {
592 mysql_init_vars 531 mysql_init_vars
593 532
594 # $myconf is modified by the configure_* functions 533 # $myconf is modified by the configure_* functions
595 local myconf="" 534 local myconf=""
596 535
597 if useq "minimal" ; then 536 if use minimal ; then
598 configure_minimal 537 configure_minimal
599 else 538 else
600 configure_common 539 configure_common
601 if mysql_version_is_at_least "5.1.10" ; then 540 if mysql_version_is_at_least "5.1.10" ; then
602 configure_51 541 configure_51
609 filter-flags "-O" "-O[01]" 548 filter-flags "-O" "-O[01]"
610 549
611 # glib-2.3.2_pre fix, bug #16496 550 # glib-2.3.2_pre fix, bug #16496
612 append-flags "-DHAVE_ERRNO_AS_DEFINE=1" 551 append-flags "-DHAVE_ERRNO_AS_DEFINE=1"
613 552
553 # As discovered by bug #246652, doing a double-level of SSP causes NDB to
554 # fail badly during cluster startup.
555 if [[ $(gcc-major-version) -lt 4 ]]; then
556 filter-flags "-fstack-protector-all"
557 fi
558
614 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing" 559 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing"
615 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti" 560 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti"
616 mysql_version_is_at_least "5.0" \ 561 mysql_version_is_at_least "5.0" \
617 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 562 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
618 export CXXFLAGS 563 export CXXFLAGS
619 564
620 econf \ 565 econf \
621 --program-suffix="${MY_SUFFIX}" \
622 --libexecdir="/usr/sbin" \ 566 --libexecdir="/usr/sbin" \
623 --sysconfdir="${MY_SYSCONFDIR}" \ 567 --sysconfdir="${MY_SYSCONFDIR}" \
624 --localstatedir="${MY_LOCALSTATEDIR}" \ 568 --localstatedir="${MY_LOCALSTATEDIR}" \
625 --sharedstatedir="${MY_SHAREDSTATEDIR}" \ 569 --sharedstatedir="${MY_SHAREDSTATEDIR}" \
626 --libdir="${MY_LIBDIR}" \ 570 --libdir="${MY_LIBDIR}" \
637 | xargs -0 -n100 sed -i \ 581 | xargs -0 -n100 sed -i \
638 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 582 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
639 583
640 emake || die "emake failed" 584 emake || die "emake failed"
641 585
642 mysql_version_is_at_least "5.1.1" && useq "pbxt" && pbxt_src_compile 586 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile
643} 587}
644 588
645mysql_src_install() { 589mysql_src_install() {
646 # Make sure the vars are correctly initialized 590 # Make sure the vars are correctly initialized
647 mysql_init_vars 591 mysql_init_vars
648 592
649 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die 593 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed"
650 594
651 mysql_version_is_at_least "5.1.12" && useq "pbxt" && pbxt_src_install 595 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_install
652
653 insinto "${MY_INCLUDEDIR}"
654 doins "${MY_INCLUDEDIR}"/my_{config,dir}.h
655 596
656 # Convenience links 597 # Convenience links
598 einfo "Making Convenience links for mysqlcheck multi-call binary"
657 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqlanalyze${MY_SUFFIX}" 599 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
658 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqlrepair${MY_SUFFIX}" 600 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
659 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqloptimize${MY_SUFFIX}" 601 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqloptimize"
660 602
661 # Various junk (my-*.cnf moved elsewhere) 603 # Various junk (my-*.cnf moved elsewhere)
604 einfo "Removing duplicate /usr/share/mysql files"
662 rm -Rf "${D}/usr/share/info" 605 rm -Rf "${D}/usr/share/info"
663 for removeme in "mysql-log-rotate" mysql.server* \ 606 for removeme in "mysql-log-rotate" mysql.server* \
664 binary-configure* my-*.cnf mi_test_all* 607 binary-configure* my-*.cnf mi_test_all*
665 do 608 do
666 rm -f "${D}"/usr/share/mysql/${removeme} 609 rm -f "${D}"/usr/share/mysql/${removeme}
667 done 610 done
668 611
669 # TODO change at Makefile-am level
670 if [[ ${PN} == "mysql-slotted" ]] ; then
671 for moveme in "mysql_fix_privilege_tables.sql" \
672 "fill_help_tables.sql" "ndb-config-2-node.ini"
673 do
674 mv -f "${D}/usr/share/mysql/${moveme}" "${D}/usr/share/mysql${MY_SUFFIX}/" 2>/dev/null
675 done
676 fi
677
678 # clean up stuff for a minimal build 612 # Clean up stuff for a minimal build
679 if useq "minimal" ; then 613 if use minimal ; then
614 einfo "Remove all extra content for minimal build"
680 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench} 615 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench}
681 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 616 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
682 rm -f "${D}/usr/sbin/mysqld" 617 rm -f "${D}/usr/sbin/mysqld"
683 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 618 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
684 fi 619 fi
685 620
686 if [[ ${PN} == "mysql-slotted" ]] ; then
687 local notcatched=$(ls "${D}/usr/share/mysql"/*)
688 if [[ -n "${notcatched}" ]] ; then
689 ewarn "QA notice"
690 ewarn "${notcatched} files in /usr/share/mysql"
691 ewarn "bug mysql-herd to manage them"
692 fi
693 rm -Rf "${D}/usr/share/mysql"
694 fi
695
696 # Configuration stuff 621 # Configuration stuff
697 if mysql_version_is_at_least "4.1" ; then 622 if mysql_version_is_at_least "4.1" ; then
698 mysql_mycnf_version="4.1" 623 mysql_mycnf_version="4.1"
699 else 624 else
700 mysql_mycnf_version="4.0" 625 mysql_mycnf_version="4.0"
701 fi 626 fi
627 einfo "Building default my.cnf"
702 insinto "${MY_SYSCONFDIR}" 628 insinto "${MY_SYSCONFDIR}"
703 doins scripts/mysqlaccess.conf 629 doins scripts/mysqlaccess.conf
704 sed -e "s!@MY_SUFFIX@!${MY_SUFFIX}!g" \
705 -e "s!@DATADIR@!${DATADIR}!g" \ 630 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
706 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \ 631 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \
707 > "${TMPDIR}/my.cnf.ok" 632 > "${TMPDIR}/my.cnf.ok"
708 if mysql_version_is_at_least "4.1" && useq "latin1" ; then 633 if mysql_version_is_at_least "4.1" && use latin1 ; then
709 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok" 634 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok"
710 fi 635 fi
711 newins "${TMPDIR}/my.cnf.ok" my.cnf 636 newins "${TMPDIR}/my.cnf.ok" my.cnf
712 637
713 # Minimal builds don't have the MySQL server 638 # Minimal builds don't have the MySQL server
714 if ! useq "minimal" ; then 639 if ! use minimal ; then
640 einfo "Creating initial directories"
715 # Empty directories ... 641 # Empty directories ...
716 diropts "-m0750" 642 diropts "-m0750"
717 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then 643 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
718 dodir "${DATADIR}" 644 dodir "${MY_DATADIR}"
719 keepdir "${DATADIR}" 645 keepdir "${MY_DATADIR}"
720 chown -R mysql:mysql "${D}/${DATADIR}" 646 chown -R mysql:mysql "${D}/${MY_DATADIR}"
721 fi 647 fi
722 648
723 diropts "-m0755" 649 diropts "-m0755"
724 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do 650 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do
725 dodir "${folder}" 651 dodir "${folder}"
727 chown -R mysql:mysql "${D}/${folder}" 653 chown -R mysql:mysql "${D}/${folder}"
728 done 654 done
729 fi 655 fi
730 656
731 # Docs 657 # Docs
658 einfo "Installing docs"
732 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 659 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE
660 doinfo "${S}"/Docs/mysql.info
733 661
734 # Minimal builds don't have the MySQL server 662 # Minimal builds don't have the MySQL server
735 if ! useq "minimal" ; then 663 if ! use minimal ; then
664 einfo "Including support files and sample configurations"
665 docinto "support-files"
666 for script in \
667 "${S}"/support-files/my-*.cnf \
668 "${S}"/support-files/magic \
669 "${S}"/support-files/ndb-config-2-node.ini
670 do
671 dodoc "${script}"
672 done
673
674 docinto "scripts"
675 for script in "${S}"/scripts/mysql* ; do
676 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
677 done
678
679 fi
680
681 mysql_lib_symlinks "${D}"
682}
683
684mysql_pkg_preinst() {
685 enewgroup mysql 60 || die "problem adding 'mysql' group"
686 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
687}
688
689mysql_pkg_postinst() {
690 # Make sure the vars are correctly initialized
691 mysql_init_vars
692
693 # Check FEATURES="collision-protect" before removing this
694 [[ -d "${ROOT}/var/log/mysql" ]] || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
695
696 # Secure the logfiles
697 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
698 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
699 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
700
701 # Minimal builds don't have the MySQL server
702 if ! use minimal ; then
736 docinto "support-files" 703 docinto "support-files"
737 for script in \ 704 for script in \
738 support-files/my-*.cnf \ 705 support-files/my-*.cnf \
739 support-files/magic \ 706 support-files/magic \
740 support-files/ndb-config-2-node.ini 707 support-files/ndb-config-2-node.ini
744 711
745 docinto "scripts" 712 docinto "scripts"
746 for script in scripts/mysql* ; do 713 for script in scripts/mysql* ; do
747 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 714 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
748 done 715 done
749 fi
750 716
751 if [[ ${PN} == "mysql-slotted" ]] ; then 717 einfo
752 # MOVED HERE DUE TO BUG #121445 718 elog "You might want to run:"
753 # create a list of files, to be used 719 elog "\"emerge --config =${CATEGORY}/${PF}\""
754 # by external utilities 720 elog "if this is a new install."
755 mkdir -p "${D}/var/lib/eselect/mysql/" 721 einfo
756 local filelist="${D}/var/lib/eselect/mysql/mysql${MY_SUFFIX}.filelist"
757 pushd "${D}/" &>/dev/null
758 find usr/bin/ usr/sbin/ \
759 -type f -name "*${MY_SUFFIX}*" \
760 -and -not -name "mysql_config${MY_SUFFIX}" \
761 > "${filelist}"
762 find usr/share/man \
763 -type f -name "*${MY_SUFFIX}*" \
764 | sed -e 's/$/.gz/' \
765 >> "${filelist}"
766 echo "${MY_SYSCONFDIR#"/"}" >> "${filelist}"
767 echo "${MY_LIBDIR#"/"}" >> "${filelist}"
768 echo "${MY_SHAREDSTATEDIR#"/"}" >> "${filelist}"
769 popd &>/dev/null
770 fi 722 fi
771 723
772 mysql_lib_symlinks "${D}" 724 if mysql_version_is_at_least "5.1.12" && use pbxt ; then
773} 725 # TODO: explain it better
774
775mysql_pkg_preinst() {
776 enewgroup mysql 60 || die "problem adding 'mysql' group"
777 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
778}
779
780mysql_pkg_postinst() {
781 # Make sure the vars are correctly initialized
782 mysql_init_vars
783
784 # Check FEATURES="collision-protect" before removing this
785 [[ -d "${ROOT}/var/log/mysql" ]] \
786 || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
787
788 # Secure the logfiles
789 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
790 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
791 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
792
793 # Minimal builds don't have the MySQL server
794 if ! useq "minimal" ; then
795 docinto "support-files"
796 for script in \
797 support-files/my-*.cnf \
798 support-files/magic \
799 support-files/ndb-config-2-node.ini
800 do
801 dodoc "${script}"
802 done
803
804 docinto "scripts"
805 for script in scripts/mysql* ; do
806 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
807 done
808 fi
809
810 einfo "you may want to read slotting upgrade documents in the overlay"
811 if useq "pbxt" && mysql_version_is_at_least "5.1" ; then
812 # TODO tell it better ;-)
813 einfo "mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';" 726 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
814 einfo "CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;" 727 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
815 einfo "if, after that you cannot start the mysql server" 728 elog "if, after that, you cannot start the MySQL server,"
816 einfo "remove the ${MY_DATADIR}/mysql/plugin.* files, then" 729 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
817 einfo "use the mysql upgrade script to restore the table" 730 elog "use the MySQL upgrade script to restore the table"
818 einfo " or " 731 elog "or execute the following SQL command:"
819 einfo "CREATE TABLE IF NOT EXISTS plugin (" 732 elog " CREATE TABLE IF NOT EXISTS plugin ("
820 einfo " name char(64) binary DEFAULT '' NOT NULL," 733 elog " name char(64) binary DEFAULT '' NOT NULL,"
821 einfo " dl char(128) DEFAULT '' NOT NULL," 734 elog " dl char(128) DEFAULT '' NOT NULL,"
822 einfo " PRIMARY KEY (name)" 735 elog " PRIMARY KEY (name)"
823 einfo ") CHARACTER SET utf8 COLLATE utf8_bin;" 736 elog " ) CHARACTER SET utf8 COLLATE utf8_bin;"
824 fi 737 fi
738
825 mysql_check_version_range "4.0 to 5.0.99.99" \ 739 mysql_check_version_range "4.0 to 5.0.99.99" \
826 && useq "berkdb" \ 740 && use berkdb \
827 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 741 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
828} 742}
829 743
830mysql_pkg_config() { 744mysql_pkg_config() {
831 # Make sure the vars are correctly initialized 745 # Make sure the vars are correctly initialized
832 mysql_init_vars 746 mysql_init_vars
833 747
834 [[ -z "${DATADIR}" ]] && die "Sorry, unable to find DATADIR" 748 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
835 749
836 if built_with_use ${CATEGORY}/${PN} minimal ; then 750 if built_with_use ${CATEGORY}/${PN} minimal ; then
837 die "Minimal builds do NOT include the MySQL server" 751 die "Minimal builds do NOT include the MySQL server"
838 fi 752 fi
839 753
840 local pwd1="a" 754 local pwd1="a"
841 local pwd2="b" 755 local pwd2="b"
842 local maxtry=5 756 local maxtry=5
843 757
844 if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then 758 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
845 ewarn "You have already a MySQL database in place." 759 ewarn "You have already a MySQL database in place."
846 ewarn "(${ROOT}/${DATADIR}/*)" 760 ewarn "(${ROOT}/${MY_DATADIR}/*)"
847 ewarn "Please rename or delete it if you wish to replace it." 761 ewarn "Please rename or delete it if you wish to replace it."
848 die "MySQL database already exists!" 762 die "MySQL database already exists!"
849 fi 763 fi
764
765 # Bug #213475 - MySQL _will_ object strenously if your machine is named
766 # localhost. Also causes weird failures.
767 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
850 768
851 einfo "Creating the mysql database and setting proper" 769 einfo "Creating the mysql database and setting proper"
852 einfo "permissions on it ..." 770 einfo "permissions on it ..."
853 771
854 einfo "Insert a password for the mysql 'root' user" 772 einfo "Insert a password for the mysql 'root' user"
870 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \ 788 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \
871 || touch "${TMPDIR}/fill_help_tables.sql" 789 || touch "${TMPDIR}/fill_help_tables.sql"
872 help_tables="${TMPDIR}/fill_help_tables.sql" 790 help_tables="${TMPDIR}/fill_help_tables.sql"
873 791
874 pushd "${TMPDIR}" &>/dev/null 792 pushd "${TMPDIR}" &>/dev/null
875 "${ROOT}/usr/bin/mysql_install_db" | grep -B5 -A999 -i "ERROR" 793 "${ROOT}/usr/bin/mysql_install_db" >"${TMPDIR}"/mysql_install_db.log 2>&1
794 if [ $? -ne 0 ]; then
795 grep -B5 -A999 -i "ERROR" "${TMPDIR}"/mysql_install_db.log 1>&2
796 die "Failed to run mysql_install_db. Please review /var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"
797 fi
876 popd &>/dev/null 798 popd &>/dev/null
877 [[ -f "${ROOT}/${DATADIR}/mysql/user.frm" ]] \ 799 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
878 || die "MySQL databases not installed" 800 || die "MySQL databases not installed"
879 chown -R mysql:mysql "${ROOT}/${DATADIR}" 2> /dev/null 801 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
880 chmod 0750 "${ROOT}/${DATADIR}" 2> /dev/null 802 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
881 803
882 if mysql_version_is_at_least "4.1.3" ; then 804 if mysql_version_is_at_least "4.1.3" ; then
883 options="--skip-ndbcluster" 805 options="--skip-ndbcluster"
884 806
885 # Filling timezones, see 807 # Filling timezones, see
896 local mysqld="${ROOT}/usr/sbin/mysqld \ 818 local mysqld="${ROOT}/usr/sbin/mysqld \
897 ${options} \ 819 ${options} \
898 --user=mysql \ 820 --user=mysql \
899 --skip-grant-tables \ 821 --skip-grant-tables \
900 --basedir=${ROOT}/usr \ 822 --basedir=${ROOT}/usr \
901 --datadir=${ROOT}/${DATADIR} \ 823 --datadir=${ROOT}/${MY_DATADIR} \
902 --skip-innodb \ 824 --skip-innodb \
903 --skip-bdb \ 825 --skip-bdb \
904 --skip-networking \ 826 --skip-networking \
905 --max_allowed_packet=8M \ 827 --max_allowed_packet=8M \
906 --net_buffer_length=16K \ 828 --net_buffer_length=16K \
936 wait %1 858 wait %1
937 einfo "Done" 859 einfo "Done"
938} 860}
939 861
940mysql_pkg_postrm() { 862mysql_pkg_postrm() {
941 if [[ ${PN} == "mysql-slotted" ]] ; then
942 mysql_lib_symlinks 863 : # mysql_lib_symlinks "${D}"
943 mysql_clients_link_to_best_version
944 fi
945} 864}

Legend:
Removed from v.1.58  
changed lines
  Added in v.1.109

  ViewVC Help
Powered by ViewVC 1.1.20