/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.6 Revision 1.165
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.6 2006/01/14 19:00:32 vivo Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.165 2011/08/29 01:28:10 vapier Exp $
4 4
5# Author: Francesco Riosa <vivo at gentoo.org> 5# @ECLASS: mysql.eclass
6# Maintainer: Francesco Riosa <vivo at gentoo.org> 6# @MAINTAINER:
7# MySQL Team <mysql-bugs@gentoo.org>
8# Luca Longinotti <chtekk@gentoo.org>
9# Robin H. Johnson <robbat2@gentoo.org>
10# @AUTHOR:
11# Francesco Riosa (Retired) <vivo@gentoo.org>
12# @BLURB: This eclass provides most of the functions for mysql ebuilds
13# @DESCRIPTION:
14# The mysql.eclass provides almost all the code to build the mysql ebuilds
15# including the src_unpack, src_prepare, src_configure, src_compile,
16# scr_install, pkg_preinst, pkg_postinst, pkg_config and pkg_postrm
17# phase hooks.
7 18
8inherit eutils flag-o-matic gnuconfig mysql_fx 19WANT_AUTOCONF="latest"
20WANT_AUTOMAKE="latest"
9 21
10#major, minor only in the slot 22inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator toolchain-funcs
11SLOT=$(( ${MYSQL_VERSION_ID} / 10000 ))
12 23
13# shorten the path because the socket path length must be shorter than 107 chars 24# Shorten the path because the socket path length must be shorter than 107 chars
14# and we will run a mysql server during test phase 25# and we will run a mysql server during test phase
15S="${WORKDIR}/${PN}" 26S="${WORKDIR}/mysql"
16 27
28[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z"
29if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
30 EGIT_PROJECT=mysql-extras
31 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
32 inherit git
33fi
34
35case "${EAPI:-0}" in
36 2)
37 EXPORT_FUNCTIONS pkg_setup \
38 src_unpack src_prepare \
39 src_configure src_compile \
40 src_install \
41 pkg_preinst pkg_postinst \
42 pkg_config pkg_postrm
43 IUSE_DEFAULT_ON='+'
44 ;;
45 0 | 1)
46 EXPORT_FUNCTIONS pkg_setup \
47 src_unpack \
48 src_compile \
49 src_install \
50 pkg_preinst pkg_postinst \
51 pkg_config pkg_postrm
52 ;;
53 *)
54 die "Unsupported EAPI: ${EAPI}" ;;
55esac
56
57
58# @ECLASS-VARIABLE: MYSQL_PV_MAJOR
59# @DESCRIPTION:
60# Upstream MySQL considers the first two parts of the version number to be the
61# major version. Upgrades that change major version should always run
62# mysql_upgrade.
63MYSQL_PV_MAJOR="$(get_version_component_range 1-2 ${PV})"
64
65# Cluster is a special case...
66if [[ "${PN}" == "mysql-cluster" ]]; then
67 case $PV in
68 6.1*|7.0*|7.1*) MYSQL_PV_MAJOR=5.1 ;;
69 esac
70fi
71
72
73# @ECLASS-VARIABLE: MYSQL_VERSION_ID
74# @DESCRIPTION:
75# MYSQL_VERSION_ID will be:
76# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
77# This is an important part, because many of the choices the MySQL ebuild will do
78# depend on this variable.
79# In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803"
80# We also strip off upstream's trailing letter that they use to respin tarballs
81
82MYSQL_VERSION_ID=""
83tpv="${PV%[a-z]}"
84tpv=( ${tpv//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}"
85for vatom in 0 1 2 3 ; do
86 # pad to length 2
87 tpv[${vatom}]="00${tpv[${vatom}]}"
88 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}"
89done
90# strip leading "0" (otherwise it's considered an octal number by BASH)
91MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"}
92
93# @ECLASS-VARIABLE: MYSQL_COMMUNITY_FEATURES
94# @DESCRIPTION:
95# Specifiy if community features are available. Possible values are 1 (yes)
96# and 0 (no).
97# Community features are available in mysql-community
98# AND in the re-merged mysql-5.0.82 and newer
99if [ "${PN}" == "mysql-community" -o "${PN}" == "mariadb" ]; then
100 MYSQL_COMMUNITY_FEATURES=1
101elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
102 MYSQL_COMMUNITY_FEATURES=1
103elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
104 MYSQL_COMMUNITY_FEATURES=1
105elif [ "${PV#5.4}" != "${PV}" ] ; then
106 MYSQL_COMMUNITY_FEATURES=1
107elif [ "${PV#5.5}" != "${PV}" ] ; then
108 MYSQL_COMMUNITY_FEATURES=1
109elif [ "${PV#6}" != "${PV}" ] ; then
110 MYSQL_COMMUNITY_FEATURES=1
111elif [ "${PV#7}" != "${PV}" ] ; then
112 MYSQL_COMMUNITY_FEATURES=1
113else
114 MYSQL_COMMUNITY_FEATURES=0
115fi
116
117# @ECLASS-VARIABLE: XTRADB_VER
118# @DESCRIPTION:
119# Version of the XTRADB storage engine
120XTRADB_VER="${XTRADB_VER}"
121
122# @ECLASS-VARIABLE: PERCONA_VER
123# @DESCRIPTION:
124# Designation by PERCONA for a MySQL version to apply an XTRADB release
125PERCONA_VER="${PERCONA_VER}"
126
127# Be warned, *DEPEND are version-dependant
128# These are used for both runtime and compiletime
129DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )
130 userland_GNU? ( sys-process/procps )
131 >=sys-apps/sed-4
132 >=sys-apps/texinfo-4.7-r1
133 >=sys-libs/readline-4.1
134 >=sys-libs/zlib-1.2.3"
135
136[[ "${PN}" == "mariadb" ]] \
137&& DEPEND="${DEPEND} libevent? ( >=dev-libs/libevent-1.4 )"
138
139# Having different flavours at the same time is not a good idea
140for i in "mysql" "mysql-community" "mysql-cluster" "mariadb" ; do
141 [[ "${i}" == ${PN} ]] ||
142 DEPEND="${DEPEND} !dev-db/${i}"
143done
144
145RDEPEND="${DEPEND}
146 !minimal? ( dev-db/mysql-init-scripts )
147 selinux? ( sec-policy/selinux-mysql )"
148
149DEPEND="${DEPEND}
150 virtual/yacc"
151
152if [ "${EAPI:-0}" = "2" ]; then
153 DEPEND="${DEPEND} static? ( || ( sys-libs/ncurses[static-libs] <=sys-libs/ncurses-5.7-r3 ) )"
154fi
155
156# compile-time-only
157mysql_version_is_at_least "5.1" \
158|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
159
160# compile-time-only
161mysql_version_is_at_least "5.1.12" \
162&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
163
164[[ "${PN}" == "mariadb" ]] \
165&& mysql_version_is_at_least "5.2" \
166&& DEPEND="${DEPEND} oqgraph? ( >=dev-libs/boost-1.40.0 )"
167#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
168# sphinx? ( app-misc/sphinx )"
169
170# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
171PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
172
173# For other stuff to bring us in
174PDEPEND="${PDEPEND} =virtual/mysql-${MYSQL_PV_MAJOR}"
175
176# Work out the default SERVER_URI correctly
177if [ -z "${SERVER_URI}" ]; then
178 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
179 if [ "${PN}" == "mariadb" ]; then
180 MARIA_FULL_PV="$(replace_version_separator 3 '-' ${PV})"
181 MARIA_FULL_P="${PN}-${MARIA_FULL_PV}"
182 SERVER_URI="
183 http://ftp.osuosl.org/pub/mariadb/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
184 http://ftp.rediris.es/mirror/MariaDB/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
185 http://maria.llarian.net/download/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
186 http://launchpad.net/maria/${MYSQL_PV_MAJOR}/ongoing/+download/${MARIA_FULL_P}.tar.gz
187 http://mirrors.fe.up.pt/pub/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
188 http://ftp-stud.hs-esslingen.de/pub/Mirrors/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
189 "
190 # The community and cluster builds are on the mirrors
191 elif [[ "${MYSQL_COMMUNITY_FEATURES}" == "1" || ${PN} == "mysql-cluster" ]] ; then
192 if [[ "${PN}" == "mysql-cluster" ]] ; then
193 URI_DIR="MySQL-Cluster"
194 URI_FILE="mysql-cluster-gpl"
195 else
196 URI_DIR="MySQL"
197 URI_FILE="mysql"
198 fi
199 URI_A="${URI_FILE}-${MY_PV}.tar.gz"
200 MIRROR_PV=$(get_version_component_range 1-2 ${PV})
201 # Recently upstream switched to an archive site, and not on mirrors
202 SERVER_URI="http://downloads.mysql.com/archives/${URI_FILE}-${MIRROR_PV}/${URI_A}
203 mirror://mysql/Downloads/${URI_DIR}-${PV%.*}/${URI_A}"
204 # The (old) enterprise source is on the primary site only
205 elif [ "${PN}" == "mysql" ]; then
206 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
207 fi
208fi
209
210# Define correct SRC_URIs
211SRC_URI="${SERVER_URI}"
212
213# Gentoo patches to MySQL
214[[ ${MY_EXTRAS_VER} != live ]] \
215&& SRC_URI="${SRC_URI}
216 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
217 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
218 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
219
17DESCRIPTION="A fast, multi-threaded, multi-user SQL database server" 220DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
18HOMEPAGE="http://www.mysql.com/" 221HOMEPAGE="http://www.mysql.com/"
19NEWP="${PN}-${PV/_/-}" 222if [[ "${PN}" == "mariadb" ]]; then
20SRC_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/${NEWP}.tar.gz 223 HOMEPAGE="http://askmonty.org/"
21 mirror://gentoo/mysql-extras-20060114.tar.bz2" 224 DESCRIPTION="MariaDB is a MySQL fork with 3rd-party patches and additional storage engines merged."
225fi
226if [[ "${PN}" == "mysql-community" ]]; then
227 DESCRIPTION="${DESCRIPTION} (obsolete, move to dev-db/mysql)"
228fi
22LICENSE="GPL-2" 229LICENSE="GPL-2"
23IUSE="big-tables berkdb debug minimal perl selinux ssl static" 230SLOT="0"
24RESTRICT="primaryuri" 231IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
25DEPEND="app-admin/eselect-mysql"
26 232
27mysql_version_is_at_least "4.01.03.00" \ 233mysql_version_is_at_least "4.1" \
234&& IUSE="${IUSE} latin1"
235
236if mysql_version_is_at_least "4.1.3" ; then
28&& IUSE="${IUSE} cluster utf8 extraengine" 237 IUSE="${IUSE} extraengine"
238 if [[ "${PN}" != "mysql-cluster" ]] ; then
239 IUSE="${IUSE} cluster"
240 fi
241fi
29 242
243mysql_version_is_at_least "5.0" \
244|| IUSE="${IUSE} raid"
245
30mysql_version_is_at_least "5.00.18.00" \ 246mysql_version_is_at_least "5.0.18" \
31&& IUSE="${IUSE} max-idx-128" 247&& IUSE="${IUSE} max-idx-128"
32 248
33mysql_version_is_at_least "5.01.00.00" \ 249mysql_version_is_at_least "5.1" \
250|| IUSE="${IUSE} berkdb"
251
252[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
253&& IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
254
255[[ "${PN}" == "mariadb" ]] \
256&& IUSE="${IUSE} libevent"
257
258[[ "${PN}" == "mariadb" ]] \
259&& mysql_version_is_at_least "5.2" \
260&& IUSE="${IUSE} oqgraph"
261#SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
262#&& IUSE="${IUSE} oqgraph sphinx"
263
264# MariaDB has integrated PBXT
265# PBXT_VERSION means that we have a PBXT patch for this PV
266# PBXT was only introduced after 5.1.12
267pbxt_patch_available() {
268 [[ "${PN}" != "mariadb" ]] \
269 && mysql_version_is_at_least "5.1.12" \
270 && [[ -n "${PBXT_VERSION}" ]]
271 return $?
272}
273
274pbxt_available() {
275 pbxt_patch_available || [[ "${PN}" == "mariadb" ]]
276 return $?
277}
278
279# Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
280# MariaDB has integrated XtraDB
281# XTRADB_VERS means that we have a XTRADB patch for this PV
282# XTRADB was only introduced after 5.1.26
283xtradb_patch_available() {
284 [[ "${PN}" != "mariadb" ]] \
285 && mysql_version_is_at_least "5.1.26" \
286 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]]
287 return $?
288}
289
290
291pbxt_patch_available \
292&& PBXT_P="pbxt-${PBXT_VERSION}" \
293&& PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
294&& SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
295
296# PBXT_NEWSTYLE means pbxt is in storage/ and gets enabled as other plugins
297# vs. built outside the dir
298pbxt_available \
299&& IUSE="${IUSE} pbxt" \
300&& mysql_version_is_at_least "5.1.40" \
301&& PBXT_NEWSTYLE=1
302
303xtradb_patch_available \
304&& XTRADB_P="percona-xtradb-${XTRADB_VER}" \
305&& XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
306&& XTRADB_SRC_B1="http://www.percona.com/" \
307&& XTRADB_SRC_B2="${XTRADB_SRC_B1}/percona-builds/" \
308&& XTRADB_SRC_URI1="${XTRADB_SRC_B2}/Percona-Server/Percona-Server-${XTRADB_SRC_URI_COMMON}" \
309&& XTRADB_SRC_URI2="${XTRADB_SRC_B2}/xtradb/${XTRADB_SRC_URI_COMMON}" \
310&& XTRADB_SRC_URI3="${XTRADB_SRC_B1}/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
311&& SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} ${XTRADB_SRC_URI3} )" \
34&& IUSE="${IUSE} innodb" 312&& IUSE="${IUSE} xtradb"
35 313
36EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst pkg_postinst pkg_config pkg_postrm 314#
315# HELPER FUNCTIONS:
316#
37 317
318# @FUNCTION: mysql_disable_test
319# @DESCRIPTION:
320# Helper function to disable specific tests.
321mysql_disable_test() {
322 local rawtestname testname testsuite reason mysql_disable_file
323 rawtestname="${1}" ; shift
324 reason="${@}"
325 ewarn "test '${rawtestname}' disabled: '${reason}'"
326
327 testsuite="${rawtestname/.*}"
328 testname="${rawtestname/*.}"
329 mysql_disable_file="${S}/mysql-test/t/disabled.def"
330 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
331 echo ${testname} : ${reason} >> "${mysql_disable_file}"
332
333 # ${S}/mysql-tests/t/disabled.def
334 #
335 # ${S}/mysql-tests/suite/federated/disabled.def
336 #
337 # ${S}/mysql-tests/suite/jp/t/disabled.def
338 # ${S}/mysql-tests/suite/ndb/t/disabled.def
339 # ${S}/mysql-tests/suite/rpl/t/disabled.def
340 # ${S}/mysql-tests/suite/parts/t/disabled.def
341 # ${S}/mysql-tests/suite/rpl_ndb/t/disabled.def
342 # ${S}/mysql-tests/suite/ndb_team/t/disabled.def
343 # ${S}/mysql-tests/suite/binlog/t/disabled.def
344 # ${S}/mysql-tests/suite/innodb/t/disabled.def
345 if [ -n "${testsuite}" ]; then
346 for mysql_disable_file in \
347 ${S}/mysql-test/suite/${testsuite}/disabled.def \
348 ${S}/mysql-test/suite/${testsuite}/t/disabled.def \
349 FAILED ; do
350 [ -f "${mysql_disable_file}" ] && break
351 done
352 if [ "${mysql_disabled_file}" != "FAILED" ]; then
353 echo "${testname} : ${reason}" >> "${mysql_disable_file}"
354 else
355 ewarn "Could not find testsuite disabled.def location for ${rawtestname}"
356 fi
357 fi
358}
359
360# @FUNCTION: mysql_init_vars
361# @DESCRIPTION:
362# void mysql_init_vars()
363# Initialize global variables
364# 2005-11-19 <vivo@gentoo.org>
365mysql_init_vars() {
366 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR="/usr/share/mysql"}
367 MY_SYSCONFDIR=${MY_SYSCONFDIR="/etc/mysql"}
368 MY_LIBDIR=${MY_LIBDIR="/usr/$(get_libdir)/mysql"}
369 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="/var/lib/mysql"}
370 MY_LOGDIR=${MY_LOGDIR="/var/log/mysql"}
371 MY_INCLUDEDIR=${MY_INCLUDEDIR="/usr/include/mysql"}
372
373 if [[ -z "${MY_DATADIR}" ]] ; then
374 MY_DATADIR=""
375 if [[ -f "${MY_SYSCONFDIR}/my.cnf" ]] ; then
376 MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
377 | sed -ne '/datadir/s|^--datadir=||p' \
378 | tail -n1`
379 if [[ -z "${MY_DATADIR}" ]] ; then
380 MY_DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" \
381 | sed -e 's/.*=\s*//' \
382 | tail -n1`
383 fi
384 fi
385 if [[ -z "${MY_DATADIR}" ]] ; then
386 MY_DATADIR="${MY_LOCALSTATEDIR}"
387 einfo "Using default MY_DATADIR"
388 fi
389 elog "MySQL MY_DATADIR is ${MY_DATADIR}"
390
391 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then
392 if [[ -e "${MY_DATADIR}" ]] ; then
393 # If you get this and you're wondering about it, see bug #207636
394 elog "MySQL datadir found in ${MY_DATADIR}"
395 elog "A new one will not be created."
396 PREVIOUS_DATADIR="yes"
397 else
398 PREVIOUS_DATADIR="no"
399 fi
400 export PREVIOUS_DATADIR
401 fi
402 else
403 if [[ ${EBUILD_PHASE} == "config" ]]; then
404 local new_MY_DATADIR
405 new_MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
406 | sed -ne '/datadir/s|^--datadir=||p' \
407 | tail -n1`
408
409 if [[ ( -n "${new_MY_DATADIR}" ) && ( "${new_MY_DATADIR}" != "${MY_DATADIR}" ) ]]; then
410 ewarn "MySQL MY_DATADIR has changed"
411 ewarn "from ${MY_DATADIR}"
412 ewarn "to ${new_MY_DATADIR}"
413 MY_DATADIR="${new_MY_DATADIR}"
414 fi
415 fi
416 fi
417
418 if [ "${MY_SOURCEDIR:-unset}" == "unset" ]; then
419 MY_SOURCEDIR=${SERVER_URI##*/}
420 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
421 fi
422
423 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
424 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
425 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
426}
427
428configure_minimal() {
429 # These are things we exclude from a minimal build, please
430 # note that the server actually does get built and installed,
431 # but we then delete it before packaging.
432 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication readline"
433
434 for i in ${minimal_exclude_list} ; do
435 myconf="${myconf} --without-${i}"
436 done
437 myconf="${myconf} --with-extra-charsets=none"
438 myconf="${myconf} --enable-local-infile"
439
440 if use static ; then
441 myconf="${myconf} --with-client-ldflags=-all-static"
442 myconf="${myconf} --disable-shared --with-pic"
443 else
444 myconf="${myconf} --enable-shared --enable-static"
445 fi
446
447 if mysql_version_is_at_least "4.1" && ! use latin1 ; then
448 myconf="${myconf} --with-charset=utf8"
449 myconf="${myconf} --with-collation=utf8_general_ci"
450 else
451 myconf="${myconf} --with-charset=latin1"
452 myconf="${myconf} --with-collation=latin1_swedish_ci"
453 fi
454}
455
456configure_common() {
457 myconf="${myconf} $(use_with big-tables)"
458 myconf="${myconf} --enable-local-infile"
459 myconf="${myconf} --with-extra-charsets=all"
460 myconf="${myconf} --with-mysqld-user=mysql"
461 myconf="${myconf} --with-server"
462 myconf="${myconf} --with-unix-socket-path=/var/run/mysqld/mysqld.sock"
463 myconf="${myconf} --without-libwrap"
464
465 if use static ; then
466 myconf="${myconf} --with-mysqld-ldflags=-all-static"
467 myconf="${myconf} --with-client-ldflags=-all-static"
468 myconf="${myconf} --disable-shared --with-pic"
469 else
470 myconf="${myconf} --enable-shared --enable-static"
471 fi
472
473 if use debug ; then
474 myconf="${myconf} --with-debug=full"
475 else
476 myconf="${myconf} --without-debug"
477 mysql_version_is_at_least "4.1.3" \
478 && ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) \
479 && myconf="${myconf} --without-ndb-debug"
480 fi
481
482 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
483 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
484 ewarn "and a collation of ${MYSQL_DEFAULT_COLLATION}."
485 ewarn "You MUST file bugs without these variables set."
486 myconf="${myconf} --with-charset=${MYSQL_DEFAULT_CHARSET}"
487 myconf="${myconf} --with-collation=${MYSQL_DEFAULT_COLLATION}"
488 elif mysql_version_is_at_least "4.1" && ! use latin1 ; then
489 myconf="${myconf} --with-charset=utf8"
490 myconf="${myconf} --with-collation=utf8_general_ci"
491 else
492 myconf="${myconf} --with-charset=latin1"
493 myconf="${myconf} --with-collation=latin1_swedish_ci"
494 fi
495
496 if use embedded ; then
497 myconf="${myconf} --with-embedded-privilege-control"
498 myconf="${myconf} --with-embedded-server"
499 else
500 myconf="${myconf} --without-embedded-privilege-control"
501 myconf="${myconf} --without-embedded-server"
502 fi
503
504}
505
506configure_40_41_50() {
507 myconf="${myconf} $(use_with perl bench)"
508 myconf="${myconf} --enable-assembler"
509 myconf="${myconf} --with-extra-tools"
510 myconf="${myconf} --with-innodb"
511 myconf="${myconf} --without-readline"
512 myconf="${myconf} $(use_with ssl openssl)"
513 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
514
515 # --with-vio is not needed anymore, it's on by default and
516 # has been removed from configure
517 # Apply to 4.x and 5.0.[0-3]
518 if use ssl ; then
519 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
520 fi
521
522 if mysql_version_is_at_least "5.0.60" ; then
523 if use berkdb ; then
524 elog "Berkeley DB support was disabled due to build failures"
525 elog "on multiple arches, go to a version earlier than 5.0.60"
526 elog "if you want it again. Gentoo bug #224067."
527 fi
528 myconf="${myconf} --without-berkeley-db"
529 elif use berkdb ; then
530 # The following fix is due to a bug with bdb on SPARC's. See:
531 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
532 # It comes down to non-64-bit safety problems.
533 if use alpha || use amd64 || use hppa || use mips || use sparc ; then
534 elog "Berkeley DB support was disabled due to compatibility issues on this arch"
535 myconf="${myconf} --without-berkeley-db"
536 else
537 myconf="${myconf} --with-berkeley-db=./bdb"
538 fi
539 else
540 myconf="${myconf} --without-berkeley-db"
541 fi
542
543 if mysql_version_is_at_least "4.1.3" ; then
544 myconf="${myconf} --with-geometry"
545 if [[ "${PN}" != "mysql-cluster" ]] ; then
546 myconf="${myconf} $(use_with cluster ndbcluster)"
547 fi
548 fi
549
550 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
551 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
552 myconf="${myconf} --with-archive-storage-engine"
553
554 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
555 myconf="${myconf} --with-csv-storage-engine"
556
557 # http://dev.mysql.com/doc/mysql/en/blackhole-storage-engine.html
558 myconf="${myconf} --with-blackhole-storage-engine"
559
560 # http://dev.mysql.com/doc/mysql/en/federated-storage-engine.html
561 # http://dev.mysql.com/doc/mysql/en/federated-description.html
562 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html
563 if mysql_version_is_at_least "5.0.3" ; then
564 elog "Before using the Federated storage engine, please be sure to read"
565 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html"
566 myconf="${myconf} --with-federated-storage-engine"
567 fi
568 fi
569
570 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
571 myconf="${myconf} `use_enable community community-features`"
572 if use community; then
573 myconf="${myconf} `use_enable profiling`"
574 else
575 myconf="${myconf} --disable-profiling"
576 fi
577 fi
578
579 mysql_version_is_at_least "5.0.18" \
580 && use max-idx-128 \
581 && myconf="${myconf} --with-max-indexes=128"
582}
583
584configure_51() {
585 # TODO: !!!! readd --without-readline
586 # the failure depend upon config/ac-macros/readline.m4 checking into
587 # readline.h instead of history.h
588 myconf="${myconf} $(use_with ssl ssl /usr)"
589 myconf="${myconf} --enable-assembler"
590 myconf="${myconf} --with-geometry"
591 myconf="${myconf} --with-readline"
592 myconf="${myconf} --with-zlib-dir=/usr/"
593 myconf="${myconf} --without-pstack"
594 myconf="${myconf} --with-plugindir=/usr/$(get_libdir)/mysql/plugin"
595
596 # This is an explict die here, because if we just forcibly disable it, then the
597 # user's data is not accessible.
598 use max-idx-128 && die "Bug #336027: upstream has a corruption issue with max-idx-128 presently"
599 #use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
600 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
601 myconf="${myconf} $(use_enable community community-features)"
602 if use community; then
603 myconf="${myconf} $(use_enable profiling)"
604 else
605 myconf="${myconf} --disable-profiling"
606 fi
607 fi
608
609 # Scan for all available plugins
610 local plugins_avail="$(
611 LANG=C \
612 find "${S}" \
613 \( \
614 -name 'plug.in' \
615 -o -iname 'configure.in' \
616 -o -iname 'configure.ac' \
617 \) \
618 -print0 \
619 | xargs -0 sed -r -n \
620 -e '/^MYSQL_STORAGE_ENGINE/{
621 s~MYSQL_STORAGE_ENGINE\([[:space:]]*\[?([-_a-z0-9]+)\]?.*,~\1 ~g ;
622 s~^([^ ]+).*~\1~gp;
623 }' \
624 | tr -s '\n' ' '
625 )"
626
627 # 5.1 introduces a new way to manage storage engines (plugins)
628 # like configuration=none
629 # This base set are required, and will always be statically built.
630 local plugins_sta="csv myisam myisammrg heap"
631 local plugins_dyn=""
632 local plugins_dis="example ibmdb2i"
633
634 # These aren't actually required by the base set, but are really useful:
635 plugins_sta="${plugins_sta} archive blackhole"
636
637 # default in 5.5.4
638 if mysql_version_is_at_least "5.5.4" ; then
639 plugins_sta="${plugins_sta} partition"
640 fi
641 # Now the extras
642 if use extraengine ; then
643 # like configuration=max-no-ndb, archive and example removed in 5.1.11
644 # not added yet: ibmdb2i
645 # Not supporting as examples: example,daemon_example,ftexample
646 plugins_sta="${plugins_sta} partition"
647
648 if [[ "${PN}" != "mariadb" ]] ; then
649 elog "Before using the Federated storage engine, please be sure to read"
650 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
651 plugins_dyn="${plugins_sta} federated"
652 else
653 elog "MariaDB includes the FederatedX engine. Be sure to read"
654 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
655 plugins_dyn="${plugins_sta} federatedx"
656 fi
657 else
658 plugins_dis="${plugins_dis} partition federated"
659 fi
660
661 # Upstream specifically requests that InnoDB always be built:
662 # - innobase, innodb_plugin
663 # Build falcon if available for 6.x series.
664 for i in innobase falcon ; do
665 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
666 done
667 for i in innodb_plugin ; do
668 [ -e "${S}"/storage/${i} ] && plugins_dyn="${plugins_dyn} ${i}"
669 done
670
671 # like configuration=max-no-ndb
672 if ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) ; then
673 plugins_sta="${plugins_sta} ndbcluster partition"
674 plugins_dis="${plugins_dis//partition}"
675 myconf="${myconf} --with-ndb-binlog"
676 else
677 plugins_dis="${plugins_dis} ndbcluster"
678 fi
679
680 if [[ "${PN}" == "mariadb" ]] ; then
681 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
682 # caught above.
683 # This is not optional, without it several upstream testcases fail.
684 # Also strongly recommended by upstream.
685 if [[ "${PV}" < "5.2.0" ]] ; then
686 myconf="${myconf} --with-maria-tmp-tables"
687 plugins_sta="${plugins_sta} maria"
688 else
689 myconf="${myconf} --with-aria-tmp-tables"
690 plugins_sta="${plugins_sta} aria"
691 fi
692
693 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] ||
694 die "The ${P} package doesn't provide innobase nor xtradb"
695
696 for i in innobase xtradb ; do
697 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
698 done
699
700 myconf="${myconf} $(use_with libevent)"
701
702 if mysql_version_is_at_least "5.2" ; then
703 #This should include sphinx, but the 5.2.4 archive forgot the plug.in file
704 #for i in oqgraph sphinx ; do
705 for i in oqgraph ; do
706 use ${i} \
707 && plugins_dyn="${plugins_dyn} ${i}" \
708 || plugins_dis="${plugins_dis} ${i}"
709 done
710 fi
711 fi
712
713 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then
714 use pbxt \
715 && plugins_dyn="${plugins_dyn} pbxt" \
716 || plugins_dis="${plugins_dis} pbxt"
717 fi
718
719 use static && \
720 plugins_sta="${plugins_sta} ${plugins_dyn}" && \
721 plugins_dyn=""
722
723 einfo "Available plugins: ${plugins_avail}"
724 einfo "Dynamic plugins: ${plugins_dyn}"
725 einfo "Static plugins: ${plugins_sta}"
726 einfo "Disabled plugins: ${plugins_dis}"
727
728 # These are the static plugins
729 myconf="${myconf} --with-plugins=${plugins_sta// /,}"
730 # And the disabled ones
731 for i in ${plugins_dis} ; do
732 myconf="${myconf} --without-plugin-${i}"
733 done
734}
735
736pbxt_src_configure() {
737 mysql_init_vars
738
739 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
740
741 einfo "Reconfiguring dir '${PWD}'"
742 eautoreconf
743
744 local myconf=""
745 myconf="${myconf} --with-mysql=${S} --libdir=/usr/$(get_libdir)"
746 use debug && myconf="${myconf} --with-debug=full"
747 econf ${myconf} || die "Problem configuring PBXT storage engine"
748}
749
750pbxt_src_compile() {
751
752 # Be backwards compatible for now
753 if [[ $EAPI != 2 ]]; then
754 pbxt_src_configure
755 fi
756 # TODO: is it safe/needed to use emake here ?
757 make || die "Problem making PBXT storage engine (${myconf})"
758
759 popd
760 # TODO: modify test suite for PBXT
761}
762
763pbxt_src_install() {
764 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
765 emake install DESTDIR="${D}" || die "Failed to install PBXT"
766 popd
767}
768
769#
770# EBUILD FUNCTIONS
771#
772# @FUNCTION: mysql_pkg_setup
773# @DESCRIPTION:
774# Perform some basic tests and tasks during pkg_setup phase:
775# die if FEATURES="test", USE="-minimal" and not using FEATURES="userpriv"
776# check for conflicting use flags
777# create new user and group for mysql
778# warn about deprecated features
38mysql_pkg_setup() { 779mysql_pkg_setup() {
780 if has test ${FEATURES} ; then
781 if ! use minimal ; then
782 if [[ $UID -eq 0 ]]; then
783 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
784 fi
785 fi
786 fi
39 787
788 # bug 350844
789 case "${EAPI:-0}" in
790 0 | 1)
791 if use static && !built_with_use sys-libs/ncurses static-libs; then
792 die "To build MySQL statically you need to enable static-libs for sys-libs/ncurses"
793 fi
794 ;;
795 esac
796
797 # Check for USE flag problems in pkg_setup
798 if use static && use ssl ; then
799 M="MySQL does not support being built statically with SSL support enabled!"
800 eerror "${M}"
801 die "${M}"
802 fi
803
804 if mysql_version_is_at_least "5.1.51" \
805 && ! mysql_version_is_at_least "5.2" \
806 && use debug ; then
807 # Also in package.use.mask
808 die "Bug #344885: Upstream has broken USE=debug for 5.1 series >=5.1.51"
809 fi
810
811 if ! mysql_version_is_at_least "5.0" \
812 && use raid \
813 && use static ; then
814 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically"
815 eerror "with RAID support enabled."
816 die "USE flags 'raid' and 'static' conflict!"
817 fi
818
819 if mysql_version_is_at_least "4.1.3" \
820 && ( use cluster || use extraengine || use embedded ) \
821 && use minimal ; then
822 M="USE flags 'cluster', 'extraengine', 'embedded' conflict with 'minimal' USE flag!"
823 eerror "${M}"
824 die "${M}"
825 fi
826
827 if mysql_version_is_at_least "5.1" \
828 && xtradb_patch_available \
829 && use xtradb \
830 && use embedded ; then
831 M="USE flags 'xtradb' and 'embedded' conflict and cause build failures"
832 eerror "${M}"
833 die "${M}"
834 fi
835
836 # Bug #290570, 284946, 307251
837 # Upstream changes made us need a fairly new GCC4.
838 # But only for 5.0.8[3-6]!
839 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then
840 GCC_VER=$(gcc-version)
841 case ${GCC_VER} in
842 2*|3*|4.0|4.1|4.2)
843 eerror "Some releases of MySQL required a very new GCC, and then"
844 eerror "later release relaxed that requirement again. Either pick a"
845 eerror "MySQL >=5.0.87, or use a newer GCC."
846 die "Active GCC too old!" ;;
847 esac
848 fi
849
850 # This should come after all of the die statements
40 enewgroup mysql 60 || die "problem adding group mysql" 851 enewgroup mysql 60 || die "problem adding 'mysql' group"
41 enewuser mysql 60 -1 /dev/null mysql \ 852 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
42 || die "problem adding user mysql"
43}
44 853
854 mysql_check_version_range "4.0 to 5.0.99.99" \
855 && use berkdb \
856 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
857
858 if [ "${PN}" != "mysql-cluster" ] && use cluster; then
859 ewarn "Upstream has noted that the NDB cluster support in the 5.0 and"
860 ewarn "5.1 series should NOT be put into production. In the near"
861 ewarn "future, it will be disabled from building."
862 ewarn ""
863 ewarn "If you need NDB support, you should instead move to the new"
864 ewarn "mysql-cluster package that represents that upstream NDB"
865 ewarn "development."
866 fi
867}
868
869# @FUNCTION: mysql_src_unpack
870# @DESCRIPTION:
871# Unpack the source code and call mysql_src_prepare for EAPI < 2.
45mysql_src_unpack() { 872mysql_src_unpack() {
46 873 # Initialize the proper variables first
47 mysql_init_vars 874 mysql_init_vars
48 875
49 if useq static && useq ssl; then
50 local msg="MySQL does not support building statically with SSL support"
51 eerror "${msg}"
52 die "${msg}"
53 fi
54
55 if mysql_version_is_at_least "4.01.03.00" \
56 && useq cluster \
57 || useq extraengine \
58 && useq minimal ; then
59 die "USEs cluster, extraengine conflicts with \"minimal\""
60 fi
61
62 unpack ${A} || die 876 unpack ${A}
877 # Grab the patches
878 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack
63 879
64 mv -f "${WORKDIR}/${NEWP}" "${S}" 880 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}"
881
882 # Be backwards compatible for now
883 case ${EAPI:-0} in
884 2) : ;;
885 0 | 1) mysql_src_prepare ;;
886 esac
887}
888
889# @FUNCTION: mysql_src_prepare
890# @DESCRIPTION:
891# Apply patches to the source code and remove unneeded bundled libs.
892mysql_src_prepare() {
65 cd "${S}" 893 cd "${S}"
66 894
895 # Apply the patches for this MySQL version
67 EPATCH_SUFFIX="patch" 896 EPATCH_SUFFIX="patch"
68 mkdir -p "${EPATCH_SOURCE}" || die "unable to create epatch directory" 897 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory"
898 # Clean out old items
899 rm -f "${EPATCH_SOURCE}"/*
900 # Now link in right patches
69 mysql_mv_patches 901 mysql_mv_patches
70 epatch || die "failed to apply all patches" 902 # And apply
903 epatch
71 904
72 # additional check, remove bundled zlib 905 # last -fPIC fixup, per bug #305873
906 i="${S}"/storage/innodb_plugin/plug.in
907 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
908
909 # Additional checks, remove bundled zlib (Cluster needs this, for static
910 # memory management in zlib, leave available for Cluster)
911 if [[ "${PN}" != "mysql-cluster" ]] ; then
73 rm -f "${S}/zlib/"*.[ch] 912 rm -f "${S}/zlib/"*.[ch]
74 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 913 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
914 fi
75 rm -f scripts/mysqlbug 915 rm -f "scripts/mysqlbug"
76
77 # Multilib issue with zlib detection
78 mysql_version_is_at_least "5.00.15.00" \
79 && sed -i -e "s:zlib_dir/lib:zlib_dir/$(get_libdir):g" \
80 "${S}/config/ac-macros/zlib.m4"
81 916
82 # Make charsets install in the right place 917 # Make charsets install in the right place
83 find . -name 'Makefile.am' \ 918 find . -name 'Makefile.am' \
84 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \; 919 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
85 920
86 # Manage mysqlmanager
87 mysql_version_is_at_least "5.00.15.00" \ 921 if mysql_version_is_at_least "4.1" ; then
88 && sed -i -e "s!@GENTOO_EXT@!${MY_SUFFIX}!g" \
89 -e "s!@GENTOO_SOCK_PATH@!var/run/mysqld!g" \
90 "${S}/server-tools/instance-manager/Makefile.am"
91
92 # remove what need to be recreated, so we are sure it's actually done 922 # Remove what needs to be recreated, so we're sure it's actually done
93 find . -name Makefile -o -name Makefile.in -o -name configure -exec rm -f {} \; 923 einfo "Cleaning up old buildscript files"
924 find . -name Makefile \
925 -o -name Makefile.in \
926 -o -name configure \
927 -exec rm -f {} \;
94 rm ltmain.sh 928 rm -f "ltmain.sh"
929 rm -f "scripts/mysqlbug"
930 fi
95 931
96 local rebuilddirlist d buildstep bdbdir 932 local rebuilddirlist d
97 933
934 if xtradb_patch_available && use xtradb ; then
935 einfo "Adding storage engine: Percona XtraDB (replacing InnoDB)"
936 pushd "${S}"/storage >/dev/null
937 i="innobase"
938 o="${WORKDIR}/storage-${i}.mysql-upstream"
939 # Have we been here already?
940 [ -d "${o}" ] && rm -f "${i}"
941 # Or maybe we haven't
942 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
943 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}"
944 popd >/dev/null
945 fi
946
947 if pbxt_patch_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then
948 einfo "Adding storage engine: PBXT"
949 pushd "${S}"/storage >/dev/null
950 i='pbxt'
951 [ -d "${i}" ] && rm -rf "${i}"
952 cp -ral "${WORKDIR}/${PBXT_P}" "${i}"
953 popd >/dev/null
954 fi
955
98 if mysql_version_is_at_least "5.01.00.00" ; then 956 if mysql_version_is_at_least "5.1.12" ; then
99 rebuilddirlist=". storage/innobase" 957 rebuilddirlist="."
100 bdbdir='storage/bdb/dist' 958 # This does not seem to be needed presently. robbat2 2010/02/23
959 #einfo "Updating innobase cmake"
960 ## TODO: check this with a cmake expert
961 #cmake \
962 # -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
963 # -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
964 # "storage/innobase"
101 else 965 else
102 rebuilddirlist=". innobase" 966 rebuilddirlist=". innobase"
103 bdbdir='bdb/dist'
104 fi 967 fi
105 968
106 for d in ${rebuilddirlist}; do 969 for d in ${rebuilddirlist} ; do
107 einfo "reconfiguring dir \"${d}\"" 970 einfo "Reconfiguring dir '${d}'"
108 pushd "${d}" &>/dev/null 971 pushd "${d}" &>/dev/null
109 for buildstep in \ 972 eautoreconf
110 'libtoolize --copy --force' \
111 'aclocal --force' \
112 'autoheader --force -Wnone' \
113 'autoconf --force -Wnone' \
114 'automake --force --force-missing -Wnone' \
115 'gnuconfig_update'
116 do
117 einfo "performing ${buildstep}"
118 ${buildstep} || die "failed ${buildstep/ */} dir \"${d}\""
119 done
120 popd &>/dev/null 973 popd &>/dev/null
121 done 974 done
122 975
123 if ! useq bdbdir && ! mysql_check_version_range "5.01.00.00 to 5.01.06.99" 976 if mysql_check_version_range "4.1 to 5.0.99.99" \
124 then 977 && use berkdb ; then
978 einfo "Fixing up berkdb buildsystem"
125 [[ -w "${bdbdir}/ltmain.sh" ]] && cp -f ltmain.sh "${bdbdir}/ltmain.sh" 979 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
126 pushd "${bdbdir}" && sh s_all || die "failed bdb reconfigure" &>/dev/null 980 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
981 || die "Could not copy libtool.m4 to bdb/dist/"
982 #These files exist only with libtool-2*, and need to be included.
983 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then
984 cat "/usr/share/aclocal/ltsugar.m4" >> "bdb/dist/aclocal/libtool.ac"
985 cat "/usr/share/aclocal/ltversion.m4" >> "bdb/dist/aclocal/libtool.ac"
986 cat "/usr/share/aclocal/lt~obsolete.m4" >> "bdb/dist/aclocal/libtool.ac"
987 cat "/usr/share/aclocal/ltoptions.m4" >> "bdb/dist/aclocal/libtool.ac"
988 fi
989 pushd "bdb/dist" &>/dev/null
990 sh s_all \
991 || die "Failed bdb reconfigure"
127 popd &>/dev/null 992 popd &>/dev/null
128 fi 993 fi
129
130} 994}
131 995
996# @FUNCTION: mysql_src_configure
997# @DESCRIPTION:
998# Configure mysql to build the code for Gentoo respecting the use flags.
132mysql_src_compile() { 999mysql_src_configure() {
133 1000 # Make sure the vars are correctly initialized
134 mysql_init_vars 1001 mysql_init_vars
1002
1003 # $myconf is modified by the configure_* functions
135 local myconf 1004 local myconf=""
136 1005
137 if useq static ; then 1006 if use minimal ; then
138 myconf="${myconf} --with-mysqld-ldflags=-all-static" 1007 configure_minimal
139 myconf="${myconf} --with-client-ldflags=-all-static"
140 myconf="${myconf} --disable-shared"
141 else 1008 else
142 myconf="${myconf} --enable-shared --enable-static" 1009 configure_common
143 fi
144
145 #myconf="${myconf} `use_with tcpd libwrap`"
146 myconf="${myconf} --without-libwrap"
147
148 if useq ssl ; then
149 # --with-vio is not needed anymore, it's on by default and
150 # has been removed from configure
151 mysql_version_is_at_least "5.00.04.00" || myconf="${myconf} --with-vio"
152 if mysql_version_is_at_least "5.00.06.00" ; then 1010 if mysql_version_is_at_least "5.1.10" ; then
153 # yassl-0.96 is young break with gcc-4.0 || amd64 1011 configure_51
154 #myconf="${myconf} --with-yassl"
155 myconf="${myconf} --with-openssl"
156 else 1012 else
157 myconf="${myconf} --with-openssl" 1013 configure_40_41_50
158 fi
159 else
160 myconf="${myconf} --without-openssl"
161 fi
162
163 if useq debug; then
164 myconf="${myconf} --with-debug=full"
165 else
166 myconf="${myconf} --without-debug"
167 mysql_version_is_at_least "4.01.03.00" && useq cluster && myconf="${myconf} --without-ndb-debug"
168 fi
169
170 # benchmarking stuff needs perl
171 # and shouldn't be bothered with on minimal builds
172 if useq perl && ! useq minimal; then
173 myconf="${myconf} --with-bench"
174 else
175 myconf="${myconf} --without-bench"
176 fi
177
178 # these are things we exclude from a minimal build
179 # note that the server actually does get built and installed
180 # but we then delete it before packaging.
181 local minimal_exclude_list="server embedded-server extra-tools innodb"
182 if ! useq minimal; then
183 for i in ${minimal_exclude_list}; do
184 myconf="${myconf} --with-${i}"
185 done
186
187 if useq static ; then
188 myconf="${myconf} --without-raid"
189 ewarn "disabling raid support, has problem with static"
190 else
191 myconf="${myconf} --with-raid"
192 fi
193
194 if ! mysql_version_is_at_least "5.00.00.00" ; then
195 if mysql_version_is_at_least "4.01.00.00" && useq utf8; then
196 myconf="${myconf} --with-charset=utf8"
197 myconf="${myconf} --with-collation=utf8_general_ci"
198 else
199 myconf="${myconf} --with-charset=latin1"
200 myconf="${myconf} --with-collation=latin1_swedish_ci"
201 fi 1014 fi
202 fi 1015 fi
203 1016
204 # optional again from 2005-12-05
205 if mysql_version_is_at_least "5.01.00.00" ; then
206 myconf="${myconf} $(use_with innodb)"
207 else
208 myconf="${myconf} --with-innodb"
209 fi
210
211 # lots of chars
212 myconf="${myconf} --with-extra-charsets=all"
213
214 #The following fix is due to a bug with bdb on sparc's. See:
215 #http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
216 # it comes down to non-64-bit safety problems
217 if useq sparc || useq alpha || useq hppa || useq mips || useq amd64 \
218 || mysql_check_version_range "5.01.00.00 to 5.01.06.99"
219 then
220 ewarn "bdb berkeley-db disabled due to arch or version"
221 myconf="${myconf} --without-berkeley-db"
222 else
223 useq berkdb \
224 && myconf="${myconf} --with-berkeley-db=./bdb" \
225 || myconf="${myconf} --without-berkeley-db"
226 fi
227
228 if mysql_version_is_at_least "4.01.03.00" ; then
229 #myconf="${myconf} $(use_with geometry)"
230 myconf="${myconf} --with-geometry"
231 myconf="${myconf} $(use_with cluster ndbcluster)"
232 fi
233
234 mysql_version_is_at_least "4.01.11.00" && myconf="${myconf} `use_with big-tables`"
235 else
236 for i in ${minimal_exclude_list}; do
237 myconf="${myconf} --without-${i}"
238 done
239 myconf="${myconf} --without-berkeley-db"
240 myconf="${myconf} --with-extra-charsets=none"
241 fi
242
243 if mysql_version_is_at_least "4.01.03.00" && useq extraengine; then
244 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
245 myconf="${myconf} --with-archive-storage-engine"
246 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
247
248 mysql_version_is_at_least "4.01.04.00" \
249 && myconf="${myconf} --with-csv-storage-engine"
250
251 mysql_version_is_at_least "4.01.11.00" \
252 && myconf="${myconf} --with-blackhole-storage-engine"
253
254 # http://dev.mysql.com/doc/mysql/en/federated-description.html
255 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html
256 if mysql_version_is_at_least "5.00.03.00" ; then
257 einfo "before to use federated engine be sure to read"
258 einfo "http://dev.mysql.com/doc/refman/5.0/en/federated-limitations.html"
259 myconf="${myconf} --with-federated-storage-engine"
260
261 # http://dev.mysql.com/doc/refman/5.1/en/partitioning-overview.html
262 if mysql_version_is_at_least "5.01.00.00" ; then
263 myconf="${myconf} --with-partition"
264 fi
265 fi
266
267 mysql_version_is_at_least "5.00.18.00" \
268 && useq "max-idx-128" \
269 && myconf="${myconf} --with-max-indexes=128"
270 fi
271
272 #Bug #114895,Bug #110149 1017 # Bug #114895, bug #110149
273 filter-flags "-O" "-O[01]" 1018 filter-flags "-O" "-O[01]"
1019
274 #glibc-2.3.2_pre fix; bug #16496 1020 # glib-2.3.2_pre fix, bug #16496
275 append-flags "-DHAVE_ERRNO_AS_DEFINE=1" 1021 append-flags "-DHAVE_ERRNO_AS_DEFINE=1"
276 1022
277 #the compiler flags are as per their "official" spec ;) 1023 # As discovered by bug #246652, doing a double-level of SSP causes NDB to
278 #CFLAGS="${CFLAGS/-O?/} -O3" \ 1024 # fail badly during cluster startup.
1025 if [[ $(gcc-major-version) -lt 4 ]]; then
1026 filter-flags "-fstack-protector-all"
1027 fi
1028
1029 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing"
279 export CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-exceptions -fno-rtti" 1030 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti"
280 mysql_version_is_at_least "5.00.00.00" \ 1031 mysql_version_is_at_least "5.0" \
281 && export CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 1032 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
1033 export CXXFLAGS
1034
1035 # bug #283926, with GCC4.4, this is required to get correct behavior.
1036 append-flags -fno-strict-aliasing
1037
1038 # bug #335185, #335995, with >= GCC4.3.3 on x86 only, omit-frame-pointer
1039 # causes a mis-compile.
1040 # Upstream bugs:
1041 # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38562
1042 # http://bugs.mysql.com/bug.php?id=45205
1043 use x86 && version_is_at_least "4.3.3" "$(gcc-fullversion)" && \
1044 append-flags -fno-omit-frame-pointer && \
1045 filter-flags -fomit-frame-pointer
282 1046
283 econf \ 1047 econf \
284 --program-suffix="${MY_SUFFIX}" \
285 --libexecdir="/usr/sbin" \ 1048 --libexecdir="/usr/sbin" \
286 --sysconfdir="${MY_SYSCONFDIR}" \ 1049 --sysconfdir="${MY_SYSCONFDIR}" \
287 --localstatedir="${MY_LOCALSTATEDIR}" \ 1050 --localstatedir="${MY_LOCALSTATEDIR}" \
288 --sharedstatedir="${MY_SHAREDSTATEDIR}" \ 1051 --sharedstatedir="${MY_SHAREDSTATEDIR}" \
289 --libdir="${MY_LIBDIR}" \ 1052 --libdir="${MY_LIBDIR}" \
290 --includedir="${MY_INCLUDEDIR}" \ 1053 --includedir="${MY_INCLUDEDIR}" \
291 --with-low-memory \ 1054 --with-low-memory \
292 --enable-assembler \
293 --enable-local-infile \
294 --with-mysqld-user=mysql \
295 --with-client-ldflags=-lstdc++ \ 1055 --with-client-ldflags=-lstdc++ \
296 --enable-thread-safe-client \ 1056 --enable-thread-safe-client \
297 --with-comment="Gentoo Linux ${PF}" \ 1057 --with-comment="Gentoo Linux ${PF}" \
298 --with-unix-socket-path="/var/run/mysqld/mysqld${MY_SUFFIX}.sock" \
299 --with-zlib-dir=/usr \
300 --with-lib-ccflags="-fPIC" \
301 --without-readline \
302 --without-docs \ 1058 --without-docs \
1059 --with-LIBDIR="$(get_libdir)" \
303 ${myconf} || die "bad ./configure" 1060 ${myconf} || die "econf failed"
304 1061
305 # TODO Move this before autoreconf !!! 1062 # TODO: Move this before autoreconf !!!
306 find . -name 'Makefile' \ 1063 find . -type f -name Makefile -print0 \
307 -exec sed --in-place \ 1064 | xargs -0 -n100 sed -i \
308 -e 's|^pkglibdir\s*=\s*$(libdir)/mysql|pkglibdir = $(libdir)|' \ 1065 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
309 -e 's|^pkgincludedir\s*=\s*$(includedir)/mysql|pkgincludedir = $(includedir)|' \
310 {} \;
311 1066
312 emake || die "compile problem" 1067 if [[ $EAPI == 2 ]] && [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1068 pbxt_patch_available && use pbxt && pbxt_src_configure
1069 fi
313} 1070}
314 1071
1072# @FUNCTION: mysql_src_compile
1073# @DESCRIPTION:
1074# Compile the mysql code.
1075mysql_src_compile() {
1076 # Be backwards compatible for now
1077 case ${EAPI:-0} in
1078 2) : ;;
1079 0 | 1) mysql_src_configure ;;
1080 esac
1081
1082 emake || die "emake failed"
1083
1084 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1085 pbxt_patch_available && use pbxt && pbxt_src_compile
1086 fi
1087}
1088
1089# @FUNCTION: mysql_src_install
1090# @DESCRIPTION:
1091# Install mysql.
315mysql_src_install() { 1092mysql_src_install() {
316 1093 # Make sure the vars are correctly initialized
317 mysql_init_vars 1094 mysql_init_vars
318 make install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die
319 1095
320 insinto "${MY_INCLUDEDIR}" 1096 emake install \
321 doins "${MY_INCLUDEDIR}"/my_{config,dir}.h 1097 DESTDIR="${D}" \
1098 benchdir_root="${MY_SHAREDSTATEDIR}" \
1099 testroot="${MY_SHAREDSTATEDIR}" \
1100 || die "emake install failed"
322 1101
1102 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1103 pbxt_patch_available && use pbxt && pbxt_src_install
1104 fi
1105
323 # convenience links 1106 # Convenience links
1107 einfo "Making Convenience links for mysqlcheck multi-call binary"
324 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqlanalyze${MY_SUFFIX}" 1108 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
325 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqlrepair${MY_SUFFIX}" 1109 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
326 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqloptimize${MY_SUFFIX}" 1110 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqloptimize"
327 1111
328 # various junk (my-*.cnf moved elsewhere) 1112 # Various junk (my-*.cnf moved elsewhere)
1113 einfo "Removing duplicate /usr/share/mysql files"
329 rm -rf "${D}/usr/share/info" 1114 rm -Rf "${D}/usr/share/info"
330 for removeme in "mysql-log-rotate" mysql.server* \ 1115 for removeme in "mysql-log-rotate" mysql.server* \
331 binary-configure* my-*.cnf mi_test_all* 1116 binary-configure* my-*.cnf mi_test_all*
332 do 1117 do
333 rm -f ${D}/usr/share/mysql/${removeme} 1118 rm -f "${D}"/${MY_SHAREDSTATEDIR}/${removeme}
334 done 1119 done
335 1120
336 # TODO change at Makefile-am level
337 for moveme in "mysql_fix_privilege_tables.sql" \
338 "fill_help_tables.sql" "ndb-config-2-node.ini"
339 do
340 mv -f "${D}/usr/share/mysql/${moveme}" "${D}/usr/share/mysql${MY_SUFFIX}/" 2>/dev/null
341 done
342
343 if [[ -n "${MY_SUFFIX}" ]] ; then
344 local notcatched=$(ls "${D}/usr/share/mysql"/*)
345 if [[ -n "${notcatched}" ]] ; then
346 ewarn "QA notice"
347 ewarn "${notcatched} files in /usr/share/mysql"
348 ewarn "bug mysql-herd to manage them"
349 fi
350 rm -rf "${D}/usr/share/mysql"
351 fi
352
353 # clean up stuff for a minimal build 1121 # Clean up stuff for a minimal build
354 # this is anything server-specific
355 if useq minimal; then 1122 if use minimal ; then
1123 einfo "Remove all extra content for minimal build"
356 rm -rf ${D}${MY_SHAREDSTATEDIR}/{mysql-test,sql-bench} 1124 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench}
357 rm -f ${D}/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 1125 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
358 rm -f "${D}/usr/sbin/mysqld${MY_SUFFIX}" 1126 rm -f "${D}/usr/sbin/mysqld"
359 rm -f ${D}${MY_LIBDIR}/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 1127 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
360 fi 1128 fi
361 1129
1130 # Unless they explicitly specific USE=test, then do not install the
1131 # testsuite. It DOES have a use to be installed, esp. when you want to do a
1132 # validation of your database configuration after tuning it.
1133 if use !test ; then
1134 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
1135 fi
1136
362 # config stuff 1137 # Configuration stuff
1138 case ${MYSQL_PV_MAJOR} in
1139 3*|4.0) mysql_mycnf_version="4.0" ;;
1140 4.[1-9]|5.0) mysql_mycnf_version="4.1" ;;
1141 5.[1-9]|6*|7*) mysql_mycnf_version="5.1" ;;
1142 esac
1143 einfo "Building default my.cnf (${mysql_mycnf_version})"
363 insinto "${MY_SYSCONFDIR}" 1144 insinto "${MY_SYSCONFDIR}"
364 doins scripts/mysqlaccess.conf 1145 doins scripts/mysqlaccess.conf
1146 mycnf_src="my.cnf-${mysql_mycnf_version}"
1147 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
1148 "${FILESDIR}/${mycnf_src}" \
1149 > "${TMPDIR}/my.cnf.ok"
1150 if use latin1 ; then
1151 sed -i \
1152 -e "/character-set/s|utf8|latin1|g" \
1153 "${TMPDIR}/my.cnf.ok"
1154 fi
365 newins "${FILESDIR}/my.cnf-4.1" my.cnf 1155 newins "${TMPDIR}/my.cnf.ok" my.cnf
366 insinto "/etc/conf.d"
367 newins "${FILESDIR}/mysql-slot.conf.d-r2" "mysql"
368 mysql_version_is_at_least "5.00.11.00" \
369 && newins "${FILESDIR}/mysqlmanager-slot.conf.d" "mysqlmanager"
370 1156
371 local charset='utf8'
372 ! useq utf8 && local charset='latin1'
373 sed --in-place \
374 -e "s/@MY_SUFFIX@/${MY_SUFFIX}/" \
375 -e "s/@CHARSET@/${charset}/" \
376 "${D}/etc/mysql${MY_SUFFIX}/my.cnf"
377
378 # minimal builds don't have the server 1157 # Minimal builds don't have the MySQL server
379 if ! useq minimal; then 1158 if ! use minimal ; then
380 exeinto /etc/init.d 1159 einfo "Creating initial directories"
381 newexe "${FILESDIR}/mysql-slot.rc6-r2" "mysql" 1160 # Empty directories ...
382 [[ ${SLOT} -gt 0 ]] && dosym "/etc/init.d/mysql" "/etc/init.d/mysql${MY_SUFFIX}"
383
384 mysql_version_is_at_least "5.00.11.00" \
385 && newexe "${FILESDIR}/mysqlmanager-slot.rc6" "mysqlmanager"
386 insinto /etc/logrotate.d
387 # TODO
388 newins "${FILESDIR}/logrotate.mysql" "mysql${MY_SUFFIX}"
389
390 #empty dirs...
391 diropts "-m0750" 1161 diropts "-m0750"
392 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then 1162 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
393 dodir "${DATADIR}" 1163 dodir "${MY_DATADIR}"
394 keepdir "${DATADIR}" 1164 keepdir "${MY_DATADIR}"
395 chown -R mysql:mysql "${D}/${DATADIR}" 1165 chown -R mysql:mysql "${D}/${MY_DATADIR}"
396 fi 1166 fi
397 1167
398 diropts "-m0755" 1168 diropts "-m0755"
399 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do 1169 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do
400 dodir "${folder}" 1170 dodir "${folder}"
401 keepdir "${folder}" 1171 keepdir "${folder}"
402 chown -R mysql:mysql "${D}/${folder}" 1172 chown -R mysql:mysql "${D}/${folder}"
403 done 1173 done
404 fi 1174 fi
405 1175
406 # docs 1176 # Docs
1177 einfo "Installing docs"
407 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 1178 for i in README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE ; do
1179 [[ -f "$i" ]] && dodoc "$i"
1180 done
1181 doinfo "${S}"/Docs/mysql.info
1182
408 # minimal builds don't have the server 1183 # Minimal builds don't have the MySQL server
409 if ! useq minimal; then 1184 if ! use minimal ; then
1185 einfo "Including support files and sample configurations"
1186 docinto "support-files"
1187 for script in \
1188 "${S}"/support-files/my-*.cnf \
1189 "${S}"/support-files/magic \
1190 "${S}"/support-files/ndb-config-2-node.ini
1191 do
1192 [[ -f "$script" ]] && dodoc "${script}"
1193 done
1194
1195 docinto "scripts"
1196 for script in "${S}"/scripts/mysql* ; do
1197 [[ -f "$script" ]] && [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
1198 done
1199
1200 fi
1201
1202 mysql_lib_symlinks "${D}"
1203}
1204
1205# @FUNCTION: mysql_pkg_preinst
1206# @DESCRIPTION:
1207# Create the user and groups for mysql - die if that fails.
1208mysql_pkg_preinst() {
1209 enewgroup mysql 60 || die "problem adding 'mysql' group"
1210 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
1211}
1212
1213# @FUNCTION: mysql_pkg_postinst
1214# @DESCRIPTION:
1215# Run post-installation tasks:
1216# create the dir for logfiles if non-existant
1217# touch the logfiles and secure them
1218# install scripts
1219# issue required steps for optional features
1220# issue deprecation warnings
1221mysql_pkg_postinst() {
1222 # Make sure the vars are correctly initialized
1223 mysql_init_vars
1224
1225 # Check FEATURES="collision-protect" before removing this
1226 [[ -d "${ROOT}/var/log/mysql" ]] || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
1227
1228 # Secure the logfiles
1229 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
1230 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
1231 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
1232
1233 # Minimal builds don't have the MySQL server
1234 if ! use minimal ; then
410 docinto "support-files" 1235 docinto "support-files"
411 for script in \ 1236 for script in \
412 support-files/my-*.cnf \ 1237 support-files/my-*.cnf \
413 support-files/magic \ 1238 support-files/magic \
414 support-files/ndb-config-2-node.ini 1239 support-files/ndb-config-2-node.ini
415 do 1240 do
1241 [[ -f "${script}" ]] \
416 dodoc "${script}" 1242 && dodoc "${script}"
417 done 1243 done
418 1244
419 docinto "scripts" 1245 docinto "scripts"
420 for script in scripts/mysql* ; do 1246 for script in scripts/mysql* ; do
1247 [[ -f "${script}" ]] \
421 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 1248 && [[ "${script%.sh}" == "${script}" ]] \
1249 && dodoc "${script}"
422 done 1250 done
423 fi
424 1251
425 # oops, temporary fix 1252 einfo
426 mysql_check_version_range "5.00.16.00 to 5.00.18.99" \ 1253 elog "You might want to run:"
427 && cp -f \ 1254 elog "\"emerge --config =${CATEGORY}/${PF}\""
428 "${WORKDIR}/mysql-extras/fill_help_tables.sql-5.0" \ 1255 elog "if this is a new install."
429 "${D}/usr/share/mysql${MY_SUFFIX}/fill_help_tables.sql" 1256 einfo
430}
431 1257
432mysql_pkg_preinst() { 1258 einfo
1259 elog "If you are upgrading major versions, you should run the"
1260 elog "mysql_upgrade tool."
1261 einfo
1262 fi
433 1263
434 enewgroup mysql 60 || die "problem adding group mysql" 1264 if pbxt_available && use pbxt ; then
435 enewuser mysql 60 -1 /dev/null mysql \ 1265 # TODO: explain it better
436 || die "problem adding user mysql" 1266 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
437} 1267 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
1268 elog "if, after that, you cannot start the MySQL server,"
1269 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
1270 elog "use the MySQL upgrade script to restore the table"
1271 elog "or execute the following SQL command:"
1272 elog " CREATE TABLE IF NOT EXISTS plugin ("
1273 elog " name char(64) binary DEFAULT '' NOT NULL,"
1274 elog " dl char(128) DEFAULT '' NOT NULL,"
1275 elog " PRIMARY KEY (name)"
1276 elog " ) CHARACTER SET utf8 COLLATE utf8_bin;"
1277 fi
438 1278
1279 mysql_check_version_range "4.0 to 5.0.99.99" \
1280 && use berkdb \
1281 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
1282}
1283
1284# @FUNCTION: mysql_pkg_config
1285# @DESCRIPTION:
1286# Configure mysql environment.
439mysql_pkg_postinst() { 1287mysql_pkg_config() {
1288 local old_MY_DATADIR="${MY_DATADIR}"
440 1289
1290 # Make sure the vars are correctly initialized
441 mysql_init_vars 1291 mysql_init_vars
442 mysql_lib_symlinks
443 1292
444 # mind at FEATURES=collision-protect before to remove this 1293 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
445 [ -d "${ROOT}/var/log/mysql" ] \
446 || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
447 1294
448 #secure the logfiles... does this bother anybody? 1295 if built_with_use ${CATEGORY}/${PN} minimal ; then
449 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err} 1296 die "Minimal builds do NOT include the MySQL server"
450 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql* 1297 fi
451 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
452 1298
453 # create a list of files, to be used 1299 if [[ ( -n "${MY_DATADIR}" ) && ( "${MY_DATADIR}" != "${old_MY_DATADIR}" ) ]]; then
454 # by external utilities 1300 local MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${MY_DATADIR})"
455 # uncompressed because of the small size 1301 local old_MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${old_MY_DATADIR})"
456 local filelist="${ROOT}/var/lib/eselect/mysql/mysql${MY_SUFFIX}"
457 pushd "${D}/" &>/dev/null
458 mkdir -p "${ROOT}/var/lib/eselect/mysql/"
459 env -i find usr/bin/ usr/sbin/ usr/share/man \
460 -type f -name "*${MY_SUFFIX}*" \
461 -and -not -name "mysql_config${MY_SUFFIX}" \
462 > "${filelist}.filelist"
463 echo "${MY_SYSCONFDIR#"/"}" >> "${filelist}.filelist"
464 echo "${MY_LIBDIR#"/"}" >> "${filelist}.filelist"
465 echo "${MY_SHAREDSTATEDIR#"/"}" >> "${filelist}.filelist"
466 popd &>/dev/null
467 1302
468 if ! useq minimal; then 1303 if [[ -d "${old_MY_DATADIR_s}" ]]; then
469 if [[ ${SLOT} -gt 0 ]] ; then 1304 if [[ -d "${MY_DATADIR_s}" ]]; then
470 if [[ -f "${ROOT}/usr/sbin/mysqld" ]] ; then 1305 ewarn "Both ${old_MY_DATADIR_s} and ${MY_DATADIR_s} exist"
471 einfo "you may want to run unmerge any unslotted MySQL versions with " 1306 ewarn "Attempting to use ${MY_DATADIR_s} and preserving ${old_MY_DATADIR_s}"
472 einfo "emerge -C --pretend dev-db/mysql"
473 einfo "emerge -C =dev-db/mysql-X.Y.Z"
474 einfo "After the unmerge run \"eselect myqsl list\" followed by a "
475 einfo "\"eselect myqsl set 1\" to chose the default mysql server"
476 else 1307 else
477 local tmpres="$( eselect mysql show )" 1308 elog "Moving MY_DATADIR from ${old_MY_DATADIR_s} to ${MY_DATADIR_s}"
478 # "like grep -q unset" 1309 mv --strip-trailing-slashes -T "${old_MY_DATADIR_s}" "${MY_DATADIR_s}" \
479 if [[ "{$tmpres}" == "{$tmpres/unset/}" ]] ; then 1310 || die "Moving MY_DATADIR failed"
480 eselect mysql set 1
481 else
482 einfo "The version of mysql emerged now stils is _NOT_ the default"
483 einfo "you may want to run \"eselect myqsl list\" followed by a "
484 einfo "\"eselect myqsl set 1\" to chose the default mysql server"
485 fi
486 fi 1311 fi
1312 else
1313 ewarn "Previous MY_DATADIR (${old_MY_DATADIR_s}) does not exist"
1314 if [[ -d "${MY_DATADIR_s}" ]]; then
1315 ewarn "Attempting to use ${MY_DATADIR_s}"
1316 else
1317 eerror "New MY_DATADIR (${MY_DATADIR_s}) does not exist"
1318 die "Configuration Failed! Please reinstall ${CATEGORY}/${PN}"
487 fi 1319 fi
488
489 # your friendly public service announcement...
490 einfo
491 einfo "You might want to run:"
492 einfo "\"emerge --config =${CATEGORY}/${PF}\""
493 einfo "if this is a new install."
494 einfo
495 einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
496 fi 1320 fi
497}
498
499mysql_pkg_config() {
500 mysql_init_vars
501 [[ -z "${DATADIR}" ]] && die "sorry, unable to find DATADIR"
502
503 if built_with_use dev-db/mysql minimal; then
504 die "Minimal builds do NOT include the MySQL server"
505 fi 1321 fi
506 1322
507 local pwd1="a" 1323 local pwd1="a"
508 local pwd2="b" 1324 local pwd2="b"
509 local maxtry=5 1325 local maxtry=15
510 1326
1327 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${ROOT}/root/.my.cnf" ]; then
1328 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${ROOT}/root/.my.cnf")"
1329 fi
1330
511 if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then 1331 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
512 ewarn "You have already a MySQL database in place." 1332 ewarn "You have already a MySQL database in place."
513 ewarn "(${ROOT}/${DATADIR}/*)" 1333 ewarn "(${ROOT}/${MY_DATADIR}/*)"
514 ewarn "Please rename or delete it if you wish to replace it." 1334 ewarn "Please rename or delete it if you wish to replace it."
515 die "MySQL database already exists!" 1335 die "MySQL database already exists!"
516 fi 1336 fi
517 1337
518 einfo "Creating the mysql database and setting proper" 1338 # Bug #213475 - MySQL _will_ object strenously if your machine is named
519 einfo "permissions on it..." 1339 # localhost. Also causes weird failures.
1340 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
520 1341
1342 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
1343
521 einfo "Insert a password for the mysql 'root' user" 1344 einfo "Please provide a password for the mysql 'root' user now, in the"
1345 einfo "MYSQL_ROOT_PASSWORD env var or through the /root/.my.cnf file."
522 ewarn "Avoid [\"'\\_%] characters in the password" 1346 ewarn "Avoid [\"'\\_%] characters in the password"
523
524 read -rsp " >" pwd1 ; echo 1347 read -rsp " >" pwd1 ; echo
1348
525 einfo "Check the password" 1349 einfo "Retype the password"
526 read -rsp " >" pwd2 ; echo 1350 read -rsp " >" pwd2 ; echo
527 1351
528 if [[ "x$pwd1" != "x$pwd2" ]] ; then 1352 if [[ "x$pwd1" != "x$pwd2" ]] ; then
529 die "Passwords are not the same" 1353 die "Passwords are not the same"
1354 fi
1355 MYSQL_ROOT_PASSWORD="${pwd1}"
1356 unset pwd1 pwd2
530 fi 1357 fi
531 1358
532 local options="" 1359 local options=""
533 local sqltmp="$(emktemp)" 1360 local sqltmp="$(emktemp)"
534 1361
535 local help_tables="${ROOT}/usr/share/doc/mysql-${PVR}/scripts/fill_help_tables.sql.gz" 1362 local help_tables="${ROOT}${MY_SHAREDSTATEDIR}/fill_help_tables.sql"
536 [[ -r "${help_tables}" ]] \ 1363 [[ -r "${help_tables}" ]] \
537 && zcat "${help_tables}" > "${TMPDIR}/fill_help_tables.sql" \ 1364 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \
538 || touch "${TMPDIR}/fill_help_tables.sql" 1365 || touch "${TMPDIR}/fill_help_tables.sql"
539 help_tables="${TMPDIR}/fill_help_tables.sql" 1366 help_tables="${TMPDIR}/fill_help_tables.sql"
540 1367
541 pushd "${TMPDIR}" &>/dev/null 1368 pushd "${TMPDIR}" &>/dev/null
542 ${ROOT}/usr/bin/mysql_install_db${MY_SUFFIX} | grep -B5 -A999 -i "ERROR" 1369 "${ROOT}/usr/bin/mysql_install_db" >"${TMPDIR}"/mysql_install_db.log 2>&1
1370 if [ $? -ne 0 ]; then
1371 grep -B5 -A999 -i "ERROR" "${TMPDIR}"/mysql_install_db.log 1>&2
1372 die "Failed to run mysql_install_db. Please review /var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"
1373 fi
543 popd &>/dev/null 1374 popd &>/dev/null
544 [[ -f ${ROOT}/${DATADIR}/mysql/user.frm ]] || die "MySQL databases not installed" 1375 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
1376 || die "MySQL databases not installed"
545 chown -R mysql:mysql ${ROOT}/${DATADIR} 2> /dev/null 1377 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
546 chmod 0750 ${ROOT}/${DATADIR} 2> /dev/null 1378 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
547 1379
1380 # Figure out which options we need to disable to do the setup
1381 helpfile="${TMPDIR}/mysqld-help"
1382 ${ROOT}/usr/sbin/mysqld --verbose --help >"${helpfile}" 2>/dev/null
1383 for opt in grant-tables host-cache name-resolve networking slave-start bdb \
1384 federated innodb ssl log-bin relay-log slow-query-log external-locking \
1385 ndbcluster \
1386 ; do
1387 optexp="--(skip-)?${opt}" optfull="--skip-${opt}"
1388 egrep -sq -- "${optexp}" "${helpfile}" && options="${options} ${optfull}"
1389 done
1390 # But some options changed names
1391 egrep -sq external-locking "${helpfile}" && \
1392 options="${options/skip-locking/skip-external-locking}"
1393
548 if mysql_version_is_at_least "4.01.03.00" ; then 1394 if mysql_version_is_at_least "4.1.3" ; then
549 options="--skip-ndbcluster"
550
551 # Filling timezones, see 1395 # Filling timezones, see
552 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html 1396 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
553 ${ROOT}/usr/bin/mysql_tzinfo_to_sql${MY_SUFFIX} ${ROOT}/usr/share/zoneinfo \ 1397 "${ROOT}/usr/bin/mysql_tzinfo_to_sql" "${ROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
554 > "${sqltmp}" 2>/dev/null
555 1398
556 if [[ -r "${help_tables}" ]] ; then 1399 if [[ -r "${help_tables}" ]] ; then
557 cat "${help_tables}" >> "${sqltmp}" 1400 cat "${help_tables}" >> "${sqltmp}"
558 fi 1401 fi
559 fi 1402 fi
560 1403
1404 einfo "Creating the mysql database and setting proper"
1405 einfo "permissions on it ..."
1406
561 local socket=${ROOT}/var/run/mysqld/mysqld${MY_SUFFIX}${RANDOM}.sock 1407 local socket="${ROOT}/var/run/mysqld/mysqld${RANDOM}.sock"
562 local pidfile=${ROOT}/var/run/mysqld/mysqld${MY_SUFFIX}${RANDOM}.sock 1408 local pidfile="${ROOT}/var/run/mysqld/mysqld${RANDOM}.pid"
563 local mysqld="${ROOT}/usr/sbin/mysqld${MY_SUFFIX} \ 1409 local mysqld="${ROOT}/usr/sbin/mysqld \
564 ${options} \ 1410 ${options} \
565 --user=mysql \ 1411 --user=mysql \
566 --skip-grant-tables \
567 --basedir=${ROOT}/usr \ 1412 --basedir=${ROOT}/usr \
568 --datadir=${ROOT}/${DATADIR} \ 1413 --datadir=${ROOT}/${MY_DATADIR} \
569 --skip-innodb \
570 --skip-bdb \
571 --skip-networking \
572 --max_allowed_packet=8M \ 1414 --max_allowed_packet=8M \
573 --net_buffer_length=16K \ 1415 --net_buffer_length=16K \
1416 --default-storage-engine=MyISAM \
574 --socket=${socket} \ 1417 --socket=${socket} \
575 --pid-file=${pidfile}" 1418 --pid-file=${pidfile}"
1419 #einfo "About to start mysqld: ${mysqld}"
1420 ebegin "Starting mysqld"
576 $mysqld & 1421 ${mysqld} &
1422 rc=$?
577 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do 1423 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
578 maxtry=$(($maxtry-1)) 1424 maxtry=$((${maxtry}-1))
579 echo -n "." 1425 echo -n "."
580 sleep 1 1426 sleep 1
581 done 1427 done
1428 eend $rc
582 1429
1430 if ! [[ -S "${socket}" ]]; then
1431 die "Completely failed to start up mysqld with: ${mysqld}"
1432 fi
1433
1434 ebegin "Setting root password"
583 # do this from memory we don't want clear text password in temp files 1435 # Do this from memory, as we don't want clear text passwords in temp files
584 local sql="UPDATE mysql.user SET Password = PASSWORD('${pwd1}') WHERE USER='root'" 1436 local sql="UPDATE mysql.user SET Password = PASSWORD('${MYSQL_ROOT_PASSWORD}') WHERE USER='root'"
585 ${ROOT}/usr/bin/mysql${MY_SUFFIX} \ 1437 "${ROOT}/usr/bin/mysql" \
586 --socket=${socket} \ 1438 --socket=${socket} \
587 -hlocalhost \ 1439 -hlocalhost \
588 -e "${sql}" 1440 -e "${sql}"
1441 eend $?
589 1442
590 einfo "Loading \"zoneinfo\" this step may require few seconds" 1443 ebegin "Loading \"zoneinfo\", this step may require a few seconds ..."
591
592 ${ROOT}/usr/bin/mysql${MY_SUFFIX} \ 1444 "${ROOT}/usr/bin/mysql" \
593 --socket=${socket} \ 1445 --socket=${socket} \
594 -hlocalhost \ 1446 -hlocalhost \
595 -uroot \ 1447 -uroot \
596 -p"${pwd1}" \ 1448 -p"${MYSQL_ROOT_PASSWORD}" \
597 mysql < "${sqltmp}" 1449 mysql < "${sqltmp}"
1450 rc=$?
1451 eend $?
1452 [ $rc -ne 0 ] && ewarn "Failed to load zoneinfo!"
598 1453
599 # server stop and cleanup 1454 # Stop the server and cleanup
1455 einfo "Stopping the server ..."
600 kill $(< "${pidfile}" ) 1456 kill $(< "${pidfile}" )
601 rm "${sqltmp}" 1457 rm -f "${sqltmp}"
602 einfo "stopping the server,"
603 wait %1 1458 wait %1
604 einfo "done" 1459 einfo "Done"
605} 1460}
606 1461
1462# @FUNCTION: mysql_pkg_postrm
1463# @DESCRIPTION:
1464# Remove mysql symlinks.
607mysql_pkg_postrm() { 1465mysql_pkg_postrm() {
608 mysql_lib_symlinks 1466 : # mysql_lib_symlinks "${D}"
609 if [[ ${SLOT} -gt 0 ]] ; then
610 einfo "you may want to run \"eselect myqsl list\" followed by a "
611 einfo "\"eselect myqsl list\" to chose the default mysql server"
612 fi
613} 1467}

Legend:
Removed from v.1.6  
changed lines
  Added in v.1.165

  ViewVC Help
Powered by ViewVC 1.1.20