/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.61 Revision 1.67
1# Copyright 1999-2006 Gentoo Foundation 1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.61 2007/01/05 22:41:49 vivo Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.67 2007/01/09 15:48:34 cardoe Exp $
4# kate: encoding utf-8; eol unix; 4# kate: encoding utf-8; eol unix;
5# kate: indent-width 4; mixedindent off; remove-trailing-space on; space-indent off; 5# kate: indent-width 4; mixedindent off; remove-trailing-space on; space-indent off;
6# kate: word-wrap-column 80; word-wrap off; 6# kate: word-wrap-column 80; word-wrap off;
7 7
8# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 8# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
18 18
19# Shorten the path because the socket path length must be shorter than 107 chars 19# Shorten the path because the socket path length must be shorter than 107 chars
20# and we will run a mysql server during test phase 20# and we will run a mysql server during test phase
21S="${WORKDIR}/mysql" 21S="${WORKDIR}/mysql"
22 22
23[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20070105" 23[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20070108"
24 24
25if [[ ${PR#r} -lt 60 ]] ; then 25if [[ ${PR#r} -lt 60 ]] ; then
26 IS_BITKEEPER=0 26 IS_BITKEEPER=0
27elif [[ ${PR#r} -lt 90 ]] ; then 27elif [[ ${PR#r} -lt 90 ]] ; then
28 IS_BITKEEPER=60 28 IS_BITKEEPER=60
124 124
125mysql_version_is_at_least "5.1.12" \ 125mysql_version_is_at_least "5.1.12" \
126&& IUSE="${IUSE} pbxt" 126&& IUSE="${IUSE} pbxt"
127 127
128RDEPEND="${DEPEND} 128RDEPEND="${DEPEND}
129sys-apps/mysql 129!minimal? ( sys-apps/mysql )
130selinux? ( sec-policy/selinux-mysql ) 130selinux? ( sec-policy/selinux-mysql )
131" 131"
132 132
133EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst \ 133EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst \
134 pkg_postinst pkg_config pkg_postrm 134 pkg_postinst pkg_config pkg_postrm
172 172
173 if [[ ! -d "${wc_path}" ]]; then 173 if [[ ! -d "${wc_path}" ]]; then
174 local options="-r+" 174 local options="-r+"
175 # first check out 175 # first check out
176 einfo "bitkeeper check out start -->" 176 einfo "bitkeeper check out start -->"
177 einfo " repository: ${repo_uri}" 177 elog " repository: ${repo_uri}"
178 ${ebk_fetch_cmd} ${options} "${repo_uri}" ${wc_path} \ 178 ${ebk_fetch_cmd} ${options} "${repo_uri}" ${wc_path} \
179 || die "${EBK}: can't fetch from ${repo_uri}." 179 || die "${EBK}: can't fetch from ${repo_uri}."
180 else 180 else
181 if [[ ! -d "${wc_path}/BK" ]]; then 181 if [[ ! -d "${wc_path}/BK" ]]; then
182 popd 182 popd
183 die "Look like ${wc_path} is not a bitkeeper path." 183 die "Look like ${wc_path} is not a bitkeeper path."
184 fi 184 fi
185 185
186 # update working copy 186 # update working copy
187 einfo "bitkeeper update start -->" 187 einfo "bitkeeper update start -->"
188 einfo " repository: ${repo_uri}" 188 elog " repository: ${repo_uri}"
189 189
190 ${ebk_update_cmd} "${repo_uri}" "${wc_path}" \ 190 ${ebk_update_cmd} "${repo_uri}" "${wc_path}" \
191 || die "BK: can't update from ${repo_uri} to ${wc_path}." 191 || die "BK: can't update from ${repo_uri} to ${wc_path}."
192 fi 192 fi
193 193
273 myconf="${myconf} --without-${i}" 273 myconf="${myconf} --without-${i}"
274 done 274 done
275 myconf="${myconf} --with-extra-charsets=none" 275 myconf="${myconf} --with-extra-charsets=none"
276 myconf="${myconf} --enable-local-infile" 276 myconf="${myconf} --enable-local-infile"
277 277
278 if useq "static" ; then 278 if use static ; then
279 myconf="${myconf} --with-client-ldflags=-all-static" 279 myconf="${myconf} --with-client-ldflags=-all-static"
280 myconf="${myconf} --disable-shared" 280 myconf="${myconf} --disable-shared"
281 else 281 else
282 myconf="${myconf} --enable-shared --enable-static" 282 myconf="${myconf} --enable-shared --enable-static"
283 fi 283 fi
284 284
285 if mysql_version_is_at_least "4.01.00.00" && ! useq "latin1" ; then 285 if mysql_version_is_at_least "4.01.00.00" && ! use latin1 ; then
286 myconf="${myconf} --with-charset=utf8" 286 myconf="${myconf} --with-charset=utf8"
287 myconf="${myconf} --with-collation=utf8_general_ci" 287 myconf="${myconf} --with-collation=utf8_general_ci"
288 else 288 else
289 myconf="${myconf} --with-charset=latin1" 289 myconf="${myconf} --with-charset=latin1"
290 myconf="${myconf} --with-collation=latin1_swedish_ci" 290 myconf="${myconf} --with-collation=latin1_swedish_ci"
298 myconf="${myconf} --with-mysqld-user=mysql" 298 myconf="${myconf} --with-mysqld-user=mysql"
299 myconf="${myconf} --with-server" 299 myconf="${myconf} --with-server"
300 myconf="${myconf} --with-unix-socket-path=/var/run/mysqld/mysqld.sock" 300 myconf="${myconf} --with-unix-socket-path=/var/run/mysqld/mysqld.sock"
301 myconf="${myconf} --without-libwrap" 301 myconf="${myconf} --without-libwrap"
302 302
303 if useq "static" ; then 303 if use static ; then
304 myconf="${myconf} --with-mysqld-ldflags=-all-static" 304 myconf="${myconf} --with-mysqld-ldflags=-all-static"
305 myconf="${myconf} --with-client-ldflags=-all-static" 305 myconf="${myconf} --with-client-ldflags=-all-static"
306 myconf="${myconf} --disable-shared" 306 myconf="${myconf} --disable-shared"
307 else 307 else
308 myconf="${myconf} --enable-shared --enable-static" 308 myconf="${myconf} --enable-shared --enable-static"
309 fi 309 fi
310 310
311 if useq "debug" ; then 311 if use debug ; then
312 myconf="${myconf} --with-debug=full" 312 myconf="${myconf} --with-debug=full"
313 else 313 else
314 myconf="${myconf} --without-debug" 314 myconf="${myconf} --without-debug"
315 mysql_version_is_at_least "4.1.3" \ 315 mysql_version_is_at_least "4.1.3" \
316 && useq "cluster" \ 316 && use cluster \
317 && myconf="${myconf} --without-ndb-debug" 317 && myconf="${myconf} --without-ndb-debug"
318 fi 318 fi
319 319
320 if mysql_version_is_at_least "4.1" && ! useq "latin1" ; then 320 if mysql_version_is_at_least "4.1" && ! use latin1 ; then
321 myconf="${myconf} --with-charset=utf8" 321 myconf="${myconf} --with-charset=utf8"
322 myconf="${myconf} --with-collation=utf8_general_ci" 322 myconf="${myconf} --with-collation=utf8_general_ci"
323 else 323 else
324 myconf="${myconf} --with-charset=latin1" 324 myconf="${myconf} --with-charset=latin1"
325 myconf="${myconf} --with-collation=latin1_swedish_ci" 325 myconf="${myconf} --with-collation=latin1_swedish_ci"
326 fi 326 fi
327 327
328 if useq "embedded" ; then 328 if use embedded ; then
329 myconf="${myconf} --with-embedded-privilege-control" 329 myconf="${myconf} --with-embedded-privilege-control"
330 myconf="${myconf} --with-embedded-server" 330 myconf="${myconf} --with-embedded-server"
331 else 331 else
332 myconf="${myconf} --without-embedded-privilege-control" 332 myconf="${myconf} --without-embedded-privilege-control"
333 myconf="${myconf} --without-embedded-server" 333 myconf="${myconf} --without-embedded-server"
341 myconf="${myconf} --with-extra-tools" 341 myconf="${myconf} --with-extra-tools"
342 myconf="${myconf} --with-innodb" 342 myconf="${myconf} --with-innodb"
343 myconf="${myconf} --without-readline" 343 myconf="${myconf} --without-readline"
344 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)" 344 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
345 345
346 if useq "ssl" ; then 346 if use ssl ; then
347 # --with-vio is not needed anymore, it's on by default and 347 # --with-vio is not needed anymore, it's on by default and
348 # has been removed from configure 348 # has been removed from configure
349 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio" 349 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
350 fi
351
350 if mysql_version_is_at_least "5.2.0" ; then 352 if mysql_version_is_at_least "5.1.11" ; then
351 myconf="${myconf} --with-ssl" 353 myconf="${myconf} $(use_with ssl)"
352 else 354 else
353 myconf="${myconf} --with-openssl" 355 myconf="${myconf} $(use_with ssl openssl)"
354 fi
355 else
356 myconf="${myconf} --without-openssl"
357 fi 356 fi
358 357
359 # The following fix is due to a bug with bdb on SPARC's. See: 358 # The following fix is due to a bug with bdb on SPARC's. See:
360 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8 359 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
361 # It comes down to non-64-bit safety problems. 360 # It comes down to non-64-bit safety problems.
362 if useq "sparc" || useq "alpha" || useq "hppa" || useq "mips" || useq "amd64" ; then 361 if use sparc || use alpha || use hppa || use mips || use amd64 ; then
363 elog "Berkeley DB support was disabled due to incompatible arch" 362 elog "Berkeley DB support was disabled due to incompatible arch"
364 myconf="${myconf} --without-berkeley-db" 363 myconf="${myconf} --without-berkeley-db"
365 else 364 else
366 if useq "berkdb" ; then 365 if use berkdb ; then
367 myconf="${myconf} --with-berkeley-db=./bdb" 366 myconf="${myconf} --with-berkeley-db=./bdb"
368 else 367 else
369 myconf="${myconf} --without-berkeley-db" 368 myconf="${myconf} --without-berkeley-db"
370 fi 369 fi
371 fi 370 fi
373 if mysql_version_is_at_least "4.1.3" ; then 372 if mysql_version_is_at_least "4.1.3" ; then
374 myconf="${myconf} --with-geometry" 373 myconf="${myconf} --with-geometry"
375 myconf="${myconf} $(use_with cluster ndbcluster)" 374 myconf="${myconf} $(use_with cluster ndbcluster)"
376 fi 375 fi
377 376
378 if mysql_version_is_at_least "4.1.3" && useq "extraengine" ; then 377 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
379 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html 378 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
380 myconf="${myconf} --with-archive-storage-engine" 379 myconf="${myconf} --with-archive-storage-engine"
381 380
382 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html 381 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
383 myconf="${myconf} --with-csv-storage-engine" 382 myconf="${myconf} --with-csv-storage-engine"
394 myconf="${myconf} --with-federated-storage-engine" 393 myconf="${myconf} --with-federated-storage-engine"
395 fi 394 fi
396 fi 395 fi
397 396
398 mysql_version_is_at_least "5.0.18" \ 397 mysql_version_is_at_least "5.0.18" \
399 && useq "max-idx-128" \ 398 && use max-idx-128 \
400 && myconf="${myconf} --with-max-indexes=128" 399 && myconf="${myconf} --with-max-indexes=128"
401} 400}
402 401
403configure_51() { 402configure_51() {
404 # TODO: !!!! readd --without-readline 403 # TODO: !!!! readd --without-readline
409 myconf="${myconf} --with-geometry" 408 myconf="${myconf} --with-geometry"
410 myconf="${myconf} --with-readline" 409 myconf="${myconf} --with-readline"
411 myconf="${myconf} --with-row-based-replication" 410 myconf="${myconf} --with-row-based-replication"
412 myconf="${myconf} --with-zlib=/usr/$(get_libdir)" 411 myconf="${myconf} --with-zlib=/usr/$(get_libdir)"
413 myconf="${myconf} --without-pstack" 412 myconf="${myconf} --without-pstack"
414 useq "max-idx-128" && myconf="${myconf} --with-max-indexes=128" 413 use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
415 414
416 # 5.1 introduces a new way to manage storage engines (plugins) 415 # 5.1 introduces a new way to manage storage engines (plugins)
417 # like configuration=none 416 # like configuration=none
418 local plugins="csv,myisam,myisammrg,heap" 417 local plugins="csv,myisam,myisammrg,heap"
419 if useq "extraengine" ; then 418 if use extraengine ; then
420 # like configuration=max-no-ndb, archive and example removed in 5.1.11 419 # like configuration=max-no-ndb, archive and example removed in 5.1.11
421 plugins="${plugins},archive,blackhole,example,federated,partition" 420 plugins="${plugins},archive,blackhole,example,federated,partition"
422 421
423 elog "Before using the Federated storage engine, please be sure to read" 422 elog "Before using the Federated storage engine, please be sure to read"
424 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 423 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
425 fi 424 fi
426 425
427 if useq "innodb" ; then 426 if use innodb ; then
428 plugins="${plugins},innobase" 427 plugins="${plugins},innobase"
429 fi 428 fi
430 429
431 # like configuration=max-no-ndb 430 # like configuration=max-no-ndb
432 if useq "cluster" ; then 431 if use cluster ; then
433 plugins="${plugins},ndbcluster" 432 plugins="${plugins},ndbcluster"
434 myconf="${myconf} --with-ndb-binlog" 433 myconf="${myconf} --with-ndb-binlog"
435 fi 434 fi
436 435
437 if mysql_version_is_at_least "5.2" ; then 436 if mysql_version_is_at_least "5.2" ; then
451 450
452 local myconf 451 local myconf
453 myconf="${myconf} --with-mysql=${S}" 452 myconf="${myconf} --with-mysql=${S}"
454 mkdir -p ${T}/lib 453 mkdir -p ${T}/lib
455 myconf="${myconf} --libdir=${D}/${MY_LIBDIR}" 454 myconf="${myconf} --libdir=${D}/${MY_LIBDIR}"
456 useq "debug" && myconf="${myconf} --with-debug=full" 455 use debug && myconf="${myconf} --with-debug=full"
457 # TODO is safe/needed to use econf here ? 456 # TODO is safe/needed to use econf here ?
458 ./configure ${myconf} || die "problem configuring pbxt storage engine" 457 ./configure ${myconf} || die "problem configuring pbxt storage engine"
459 # TODO is safe/needed to use emake here ? 458 # TODO is safe/needed to use emake here ?
460 make || die "problem making pbxt storage engine (${myconf})" 459 make || die "problem making pbxt storage engine (${myconf})"
461 460
476mysql_pkg_setup() { 475mysql_pkg_setup() {
477 enewgroup mysql 60 || die "problem adding 'mysql' group" 476 enewgroup mysql 60 || die "problem adding 'mysql' group"
478 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 477 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
479 478
480 # Check for USE flag problems in pkg_setup 479 # Check for USE flag problems in pkg_setup
481 if useq "static" && useq "ssl" ; then 480 if use static && use ssl ; then
482 eerror "MySQL does not support being built statically with SSL support enabled!" 481 eerror "MySQL does not support being built statically with SSL support enabled!"
483 die "MySQL does not support being built statically with SSL support enabled!" 482 die "MySQL does not support being built statically with SSL support enabled!"
484 fi 483 fi
485 484
486 if ! mysql_version_is_at_least "5.0" \ 485 if ! mysql_version_is_at_least "5.0" \
487 && useq "raid" \ 486 && use raid \
488 && useq "static" ; then 487 && use static ; then
489 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically" 488 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically"
490 eerror "with RAID support enabled." 489 eerror "with RAID support enabled."
491 die "USE flags 'raid' and 'static' conflict!" 490 die "USE flags 'raid' and 'static' conflict!"
492 fi 491 fi
493 492
494 if mysql_version_is_at_least "4.1.3" \ 493 if mysql_version_is_at_least "4.1.3" \
495 && ( useq "cluster" || useq "extraengine" ) \ 494 && ( use cluster || use extraengine ) \
496 && useq "minimal" ; then 495 && use minimal ; then
497 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 496 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
498 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 497 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
499 fi 498 fi
500 499
501 mysql_check_version_range "4.0 to 5.0.99.99" \ 500 mysql_check_version_range "4.0 to 5.0.99.99" \
502 && useq "berkdb" \ 501 && use berkdb \
503 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 502 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
504} 503}
505 504
506mysql_src_unpack() { 505mysql_src_unpack() {
507 # Initialize the proper variables first 506 # Initialize the proper variables first
552 local rebuilddirlist d 551 local rebuilddirlist d
553 552
554 if mysql_version_is_at_least "5.1.12" ; then 553 if mysql_version_is_at_least "5.1.12" ; then
555 rebuilddirlist="." 554 rebuilddirlist="."
556 # TODO IMPO! Check this with a cmake expert 555 # TODO IMPO! Check this with a cmake expert
557 useq "innodb" \ 556 use innodb \
558 && cmake \ 557 && cmake \
559 -DCMAKE_C_COMPILER=$(which $(tc-getCC)) \ 558 -DCMAKE_C_COMPILER=$(which $(tc-getCC)) \
560 -DCMAKE_CXX_COMPILER=$(which $(tc-getCC)) \ 559 -DCMAKE_CXX_COMPILER=$(which $(tc-getCC)) \
561 "storage/innobase" 560 "storage/innobase"
562 else 561 else
569 AT_GNUCONF_UPDATE="yes" eautoreconf 568 AT_GNUCONF_UPDATE="yes" eautoreconf
570 popd &>/dev/null 569 popd &>/dev/null
571 done 570 done
572 571
573 if mysql_check_version_range "4.1 to 5.0.99.99" \ 572 if mysql_check_version_range "4.1 to 5.0.99.99" \
574 && useq "berkdb" ; then 573 && use berkdb ; then
575 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh" 574 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
576 pushd "bdb/dist" \ 575 pushd "bdb/dist" \
577 && sh s_all \ 576 && sh s_all \
578 || die "Failed bdb reconfigure" \ 577 || die "Failed bdb reconfigure" \
579 &>/dev/null 578 &>/dev/null
586 mysql_init_vars 585 mysql_init_vars
587 586
588 # $myconf is modified by the configure_* functions 587 # $myconf is modified by the configure_* functions
589 local myconf="" 588 local myconf=""
590 589
591 if useq "minimal" ; then 590 if use minimal ; then
592 configure_minimal 591 configure_minimal
593 else 592 else
594 configure_common 593 configure_common
595 if mysql_version_is_at_least "5.1.10" ; then 594 if mysql_version_is_at_least "5.1.10" ; then
596 configure_51 595 configure_51
631 | xargs -0 -n100 sed -i \ 630 | xargs -0 -n100 sed -i \
632 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 631 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
633 632
634 emake || die "emake failed" 633 emake || die "emake failed"
635 634
636 mysql_version_is_at_least "5.1.1" && useq "pbxt" && pbxt_src_compile 635 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile
637} 636}
638 637
639mysql_src_install() { 638mysql_src_install() {
640 # Make sure the vars are correctly initialized 639 # Make sure the vars are correctly initialized
641 mysql_init_vars 640 mysql_init_vars
642 641
643 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die 642 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die
644 643
645 mysql_version_is_at_least "5.1.12" && useq "pbxt" && pbxt_src_install 644 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_install
646 645
647 insinto "${MY_INCLUDEDIR}" 646 insinto "${MY_INCLUDEDIR}"
648 doins "${MY_INCLUDEDIR}"/my_{config,dir}.h 647 doins "${MY_INCLUDEDIR}"/my_{config,dir}.h
649 648
650 # Convenience links 649 # Convenience links
668 mv -f "${D}/usr/share/mysql/${moveme}" "${D}/usr/share/mysql${MY_SUFFIX}/" 2>/dev/null 667 mv -f "${D}/usr/share/mysql/${moveme}" "${D}/usr/share/mysql${MY_SUFFIX}/" 2>/dev/null
669 done 668 done
670 fi 669 fi
671 670
672 # clean up stuff for a minimal build 671 # clean up stuff for a minimal build
673 if useq "minimal" ; then 672 if use minimal ; then
674 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench} 673 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench}
675 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 674 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
676 rm -f "${D}/usr/sbin/mysqld" 675 rm -f "${D}/usr/sbin/mysqld"
677 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 676 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
678 fi 677 fi
697 doins scripts/mysqlaccess.conf 696 doins scripts/mysqlaccess.conf
698 sed -e "s!@MY_SUFFIX@!${MY_SUFFIX}!g" \ 697 sed -e "s!@MY_SUFFIX@!${MY_SUFFIX}!g" \
699 -e "s!@DATADIR@!${DATADIR}!g" \ 698 -e "s!@DATADIR@!${DATADIR}!g" \
700 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \ 699 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \
701 > "${TMPDIR}/my.cnf.ok" 700 > "${TMPDIR}/my.cnf.ok"
702 if mysql_version_is_at_least "4.1" && useq "latin1" ; then 701 if mysql_version_is_at_least "4.1" && use latin1 ; then
703 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok" 702 sed -e "s|utf8|latin1|g" -i "${TMPDIR}/my.cnf.ok"
704 fi 703 fi
705 newins "${TMPDIR}/my.cnf.ok" my.cnf 704 newins "${TMPDIR}/my.cnf.ok" my.cnf
706 705
707 # Minimal builds don't have the MySQL server 706 # Minimal builds don't have the MySQL server
708 if ! useq "minimal" ; then 707 if ! use minimal ; then
709 # Empty directories ... 708 # Empty directories ...
710 diropts "-m0750" 709 diropts "-m0750"
711 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then 710 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
712 dodir "${DATADIR}" 711 dodir "${DATADIR}"
713 keepdir "${DATADIR}" 712 keepdir "${DATADIR}"
724 723
725 # Docs 724 # Docs
726 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 725 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE
727 726
728 # Minimal builds don't have the MySQL server 727 # Minimal builds don't have the MySQL server
729 if ! useq "minimal" ; then 728 if ! use minimal ; then
730 docinto "support-files" 729 docinto "support-files"
731 for script in \ 730 for script in \
732 support-files/my-*.cnf \ 731 support-files/my-*.cnf \
733 support-files/magic \ 732 support-files/magic \
734 support-files/ndb-config-2-node.ini 733 support-files/ndb-config-2-node.ini
783 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err} 782 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
784 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql* 783 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
785 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql* 784 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
786 785
787 # Minimal builds don't have the MySQL server 786 # Minimal builds don't have the MySQL server
788 if ! useq "minimal" ; then 787 if ! use minimal ; then
789 docinto "support-files" 788 docinto "support-files"
790 for script in \ 789 for script in \
791 support-files/my-*.cnf \ 790 support-files/my-*.cnf \
792 support-files/magic \ 791 support-files/magic \
793 support-files/ndb-config-2-node.ini 792 support-files/ndb-config-2-node.ini
799 for script in scripts/mysql* ; do 798 for script in scripts/mysql* ; do
800 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 799 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
801 done 800 done
802 fi 801 fi
803 802
804 einfo "you may want to read slotting upgrade documents in the overlay" 803 #einfo "you may want to read slotting upgrade documents in the overlay"
805 if useq "pbxt" && mysql_version_is_at_least "5.1" ; then 804 if mysql_version_is_at_least "5.1.12" && use pbxt ; then
806 # TODO tell it better ;-) 805 # TODO tell it better ;-)
807 einfo "mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';" 806 elog "mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
808 einfo "CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;" 807 elog "CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
809 einfo "if, after that you cannot start the mysql server" 808 elog "if, after that you cannot start the mysql server"
810 einfo "remove the ${MY_DATADIR}/mysql/plugin.* files, then" 809 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
811 einfo "use the mysql upgrade script to restore the table" 810 elog "use the mysql upgrade script to restore the table"
812 einfo " or " 811 elog " or "
813 einfo "CREATE TABLE IF NOT EXISTS plugin (" 812 elog "CREATE TABLE IF NOT EXISTS plugin ("
814 einfo " name char(64) binary DEFAULT '' NOT NULL," 813 elog " name char(64) binary DEFAULT '' NOT NULL,"
815 einfo " dl char(128) DEFAULT '' NOT NULL," 814 elog " dl char(128) DEFAULT '' NOT NULL,"
816 einfo " PRIMARY KEY (name)" 815 elog " PRIMARY KEY (name)"
817 einfo ") CHARACTER SET utf8 COLLATE utf8_bin;" 816 elog ") CHARACTER SET utf8 COLLATE utf8_bin;"
818 fi 817 fi
819 mysql_check_version_range "4.0 to 5.0.99.99" \ 818 mysql_check_version_range "4.0 to 5.0.99.99" \
820 && useq "berkdb" \ 819 && use berkdb \
821 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 820 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
822} 821}
823 822
824mysql_pkg_config() { 823mysql_pkg_config() {
825 # Make sure the vars are correctly initialized 824 # Make sure the vars are correctly initialized

Legend:
Removed from v.1.61  
changed lines
  Added in v.1.67

  ViewVC Help
Powered by ViewVC 1.1.20