/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.90 Revision 1.112
1# Copyright 1999-2007 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.90 2008/05/22 18:13:33 robbat2 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.112 2009/07/06 18:58:41 robbat2 Exp $
4 4
5# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 5# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
6# Maintainer: MySQL Team <mysql-bugs@gentoo.org> 6# Maintainer: MySQL Team <mysql-bugs@gentoo.org>
7# - Luca Longinotti <chtekk@gentoo.org> 7# - Luca Longinotti <chtekk@gentoo.org>
8# - Robin H. Johnson <robbat2@gentoo.org> 8# - Robin H. Johnson <robbat2@gentoo.org>
9 9
10WANT_AUTOCONF="latest" 10WANT_AUTOCONF="latest"
11WANT_AUTOMAKE="latest" 11WANT_AUTOMAKE="latest"
12 12
13inherit eutils flag-o-matic gnuconfig autotools mysql_fx 13inherit eutils flag-o-matic gnuconfig autotools mysql_fx versionator
14 14
15# Shorten the path because the socket path length must be shorter than 107 chars 15# Shorten the path because the socket path length must be shorter than 107 chars
16# and we will run a mysql server during test phase 16# and we will run a mysql server during test phase
17S="${WORKDIR}/mysql" 17S="${WORKDIR}/mysql"
18 18
19[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20070108" 19[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z"
20if [[ "${MY_EXTRAS_VER}" == "live" ]]; then 20if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
21 EGIT_PROJECT=mysql-extras 21 EGIT_PROJECT=mysql-extras
22 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git" 22 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
23 inherit git 23 inherit git
24fi
25
26if [[ ${PR#r} -lt 60 ]] ; then
27 IS_BITKEEPER=0
28elif [[ ${PR#r} -lt 90 ]] ; then
29 IS_BITKEEPER=60
30else
31 IS_BITKEEPER=90
32fi 24fi
33 25
34# MYSQL_VERSION_ID will be: 26# MYSQL_VERSION_ID will be:
35# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 27# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
36# This is an important part, because many of the choices the MySQL ebuild will do 28# This is an important part, because many of the choices the MySQL ebuild will do
47 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}" 39 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}"
48done 40done
49# strip leading "0" (otherwise it's considered an octal number by BASH) 41# strip leading "0" (otherwise it's considered an octal number by BASH)
50MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"} 42MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"}
51 43
44# Community features are available in mysql-community
45# AND in the re-merged mysql-5.0.82 and newer
46if [ "${PN}" == "mysql-community" ]; then
47 MYSQL_COMMUNITY_FEATURES=1
48elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
49 MYSQL_COMMUNITY_FEATURES=1
50else
51 MYSQL_COMMUNITY_FEATURES=0
52fi
53
52# Be warned, *DEPEND are version-dependant 54# Be warned, *DEPEND are version-dependant
53# These are used for both runtime and compiletime 55# These are used for both runtime and compiletime
54DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d ) 56DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )
55 userland_GNU? ( sys-process/procps ) 57 userland_GNU? ( sys-process/procps )
56 >=sys-apps/sed-4 58 >=sys-apps/sed-4
72mysql_version_is_at_least "5.1" \ 74mysql_version_is_at_least "5.1" \
73|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )" 75|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
74 76
75# compile-time-only 77# compile-time-only
76mysql_version_is_at_least "5.1.12" \ 78mysql_version_is_at_least "5.1.12" \
77&& DEPEND="${DEPEND} innodb? ( >=dev-util/cmake-2.4.3 )" 79&& DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
78
79# BitKeeper dependency, compile-time only
80[[ ${IS_BITKEEPER} -eq 90 ]] && DEPEND="${DEPEND} dev-util/bk_client"
81
82 80
83# dev-perl/DBD-mysql is needed by some scripts installed by MySQL 81# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
84PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 82PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
83
84# For other stuff to bring us in
85PDEPEND="${PDEPEND} =virtual/mysql-$(get_version_component_range 1-2 ${PV})"
85 86
86# Work out the default SERVER_URI correctly 87# Work out the default SERVER_URI correctly
87if [ -z "${SERVER_URI}" ]; then 88if [ -z "${SERVER_URI}" ]; then
88 # The community build is on the mirrors 89 # The community build is on the mirrors
89 if [ "${PN}" == "mysql-community" ]; then 90 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
90 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz" 91 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz"
91 # The enterprise source is on the primary site only 92 # The (old) enterprise source is on the primary site only
92 elif [ "${PN}" == "mysql" ]; then 93 elif [ "${PN}" == "mysql" ]; then
93 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz" 94 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
94 fi 95 fi
95fi 96fi
96 97
121 122
122mysql_version_is_at_least "5.0.18" \ 123mysql_version_is_at_least "5.0.18" \
123&& IUSE="${IUSE} max-idx-128" 124&& IUSE="${IUSE} max-idx-128"
124 125
125mysql_version_is_at_least "5.1" \ 126mysql_version_is_at_least "5.1" \
126&& IUSE="${IUSE} innodb"
127
128mysql_version_is_at_least "5.1" \
129|| IUSE="${IUSE} berkdb" 127|| IUSE="${IUSE} berkdb"
130 128
131mysql_version_is_at_least "5.1.12" \ 129mysql_version_is_at_least "5.1.12" \
132&& IUSE="${IUSE} pbxt" 130&& IUSE="${IUSE} pbxt"
133 131
134EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst \ 132[ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
133&& IUSE="${IUSE} community profiling"
134
135case "${EAPI:-0}" in
136 2)
137 EXPORT_FUNCTIONS pkg_setup \
138 src_unpack src_prepare \
139 src_configure src_compile \
140 src_install \
141 pkg_preinst pkg_postinst \
135 pkg_postinst pkg_config pkg_postrm 142 pkg_config pkg_postrm
143 ;;
144 *)
145 EXPORT_FUNCTIONS pkg_setup \
146 src_unpack \
147 src_compile \
148 src_install \
149 pkg_preinst pkg_postinst \
150 pkg_config pkg_postrm
151 ;;
152esac
136 153
137# 154#
138# HELPER FUNCTIONS: 155# HELPER FUNCTIONS:
139# 156#
140
141bitkeeper_fetch() {
142 local reposuf
143 if [[ -z "${1}" ]] ; then
144 local tpv
145 tpv=( ${PV//[-._]/ } )
146 reposuf="mysql-${tpv[0]}.${tpv[1]}"
147 else
148 reposuf="${1}"
149 fi
150 einfo "Using '${reposuf}' repository."
151 local repo_uri="bk://mysql.bkbits.net/${reposuf}"
152 ## -- ebk_store_dir: bitkeeper sources store directory
153 local ebk_store_dir="${PORTAGE_ACTUAL_DISTDIR-${DISTDIR}}/bk-src"
154 ## -- ebk_fetch_cmd: bitkeeper fetch command
155 # always fetch the latest revision, use -r<revision> if a specified revision is wanted
156 # hint: does not work
157 local ebk_fetch_cmd="sfioball"
158 ## -- ebk_update_cmd: bitkeeper update command
159 local ebk_update_cmd="update"
160
161 # addread "/etc/bitkeeper"
162 addwrite "${ebk_store_dir}"
163
164 if [[ ! -d "${ebk_store_dir}" ]] ; then
165 debug-print "${FUNCNAME}: initial checkout, creating bitkeeper directory ..."
166 mkdir -p "${ebk_store_dir}" || die "BK: couldn't mkdir ${ebk_store_dir}"
167 fi
168
169 pushd "${ebk_store_dir}" || die "BK: couldn't chdir to ${ebk_store_dir}"
170
171 local wc_path=${reposuf}
172
173 if [[ ! -d "${wc_path}" ]] ; then
174 local options="-r+"
175
176 # first checkout
177 einfo "bitkeeper checkout start -->"
178 einfo " repository: ${repo_uri}"
179
180 ${ebk_fetch_cmd} ${options} "${repo_uri}" "${wc_path}" \
181 || die "BK: couldn't fetch from ${repo_uri}"
182 else
183 if [[ ! -d "${wc_path}/BK" ]] ; then
184 popd
185 die "Looks like ${wc_path} is not a bitkeeper path"
186 fi
187
188 # update working copy
189 einfo "bitkeeper update start -->"
190 einfo " repository: ${repo_uri}"
191
192 ${ebk_update_cmd} "${repo_uri}" "${wc_path}" \
193 || die "BK: couldn't update from ${repo_uri} to ${wc_path}"
194 fi
195
196 einfo " working copy: ${wc_path}"
197 cd "${wc_path}"
198 rsync -rlpgo --exclude="BK/" . "${S}" || die "BK: couldn't export to ${S}"
199
200 echo
201 popd
202}
203 157
204mysql_disable_test() { 158mysql_disable_test() {
205 local testname="${1}" ; shift 159 local testname="${1}" ; shift
206 local reason="${@}" 160 local reason="${@}"
207 local mysql_disable_file="${S}/mysql-test/t/disabled.def" 161 local mysql_disable_file="${S}/mysql-test/t/disabled.def"
240 fi 194 fi
241 elog "MySQL MY_DATADIR is ${MY_DATADIR}" 195 elog "MySQL MY_DATADIR is ${MY_DATADIR}"
242 196
243 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then 197 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then
244 if [[ -e "${MY_DATADIR}" ]] ; then 198 if [[ -e "${MY_DATADIR}" ]] ; then
245 elog "Previous datadir found, it's YOUR job to change" 199 # If you get this and you're wondering about it, see bug #207636
246 elog "ownership and take care of it" 200 elog "MySQL datadir found in ${MY_DATADIR}"
201 elog "A new one will not be created."
247 PREVIOUS_DATADIR="yes" 202 PREVIOUS_DATADIR="yes"
248 else 203 else
249 PREVIOUS_DATADIR="no" 204 PREVIOUS_DATADIR="no"
250 fi 205 fi
251 export PREVIOUS_DATADIR 206 export PREVIOUS_DATADIR
207 fi
208 else
209 if [[ ${EBUILD_PHASE} == "config" ]]; then
210 local new_MY_DATADIR
211 new_MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
212 | sed -ne '/datadir/s|^--datadir=||p' \
213 | tail -n1`
214
215 if [[ ( -n "${new_MY_DATADIR}" ) && ( "${new_MY_DATADIR}" != "${MY_DATADIR}" ) ]]; then
216 ewarn "MySQL MY_DATADIR has changed"
217 ewarn "from ${MY_DATADIR}"
218 ewarn "to ${new_MY_DATADIR}"
219 MY_DATADIR="${new_MY_DATADIR}"
220 fi
252 fi 221 fi
253 fi 222 fi
254 223
255 MY_SOURCEDIR=${SERVER_URI##*/} 224 MY_SOURCEDIR=${SERVER_URI##*/}
256 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*} 225 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
312 mysql_version_is_at_least "4.1.3" \ 281 mysql_version_is_at_least "4.1.3" \
313 && use cluster \ 282 && use cluster \
314 && myconf="${myconf} --without-ndb-debug" 283 && myconf="${myconf} --without-ndb-debug"
315 fi 284 fi
316 285
286 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
287 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
288 ewarn "and a collation of ${MYSQL_DEFAULT_COLLATION}."
289 ewarn "You MUST file bugs without these variables set."
290 myconf="${myconf} --with-charset=${MYSQL_DEFAULT_CHARSET}"
291 myconf="${myconf} --with-collation=${MYSQL_DEFAULT_COLLATION}"
317 if mysql_version_is_at_least "4.1" && ! use latin1 ; then 292 elif mysql_version_is_at_least "4.1" && ! use latin1 ; then
318 myconf="${myconf} --with-charset=utf8" 293 myconf="${myconf} --with-charset=utf8"
319 myconf="${myconf} --with-collation=utf8_general_ci" 294 myconf="${myconf} --with-collation=utf8_general_ci"
320 else 295 else
321 myconf="${myconf} --with-charset=latin1" 296 myconf="${myconf} --with-charset=latin1"
322 myconf="${myconf} --with-collation=latin1_swedish_ci" 297 myconf="${myconf} --with-collation=latin1_swedish_ci"
323 fi 298 fi
324 299
325 if use embedded ; then 300 if use embedded ; then
326 myconf="${myconf} --with-embedded-privilege-control" 301 myconf="${myconf} --with-embedded-privilege-control"
327 myconf="${myconf} --with-embedded-server" 302 myconf="${myconf} --with-embedded-server"
350 myconf="${myconf} $(use_with ssl)" 325 myconf="${myconf} $(use_with ssl)"
351 else 326 else
352 myconf="${myconf} $(use_with ssl openssl)" 327 myconf="${myconf} $(use_with ssl openssl)"
353 fi 328 fi
354 329
330 if mysql_version_is_at_least "5.0.60" ; then
355 if use berkdb ; then 331 if use berkdb ; then
332 elog "Berkeley DB support was disabled due to build failures"
333 elog "on multiple arches, go to a version earlier than 5.0.60"
334 elog "if you want it again. Gentoo bug #224067."
335 fi
336 myconf="${myconf} --without-berkeley-db"
337 elif use berkdb ; then
356 # The following fix is due to a bug with bdb on SPARC's. See: 338 # The following fix is due to a bug with bdb on SPARC's. See:
357 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8 339 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
358 # It comes down to non-64-bit safety problems. 340 # It comes down to non-64-bit safety problems.
359 if use alpha || use amd64 || use hppa || use mips || use sparc ; then 341 if use alpha || use amd64 || use hppa || use mips || use sparc ; then
360 elog "Berkeley DB support was disabled due to compatibility issues on this arch" 342 elog "Berkeley DB support was disabled due to compatibility issues on this arch"
386 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html 368 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html
387 if mysql_version_is_at_least "5.0.3" ; then 369 if mysql_version_is_at_least "5.0.3" ; then
388 elog "Before using the Federated storage engine, please be sure to read" 370 elog "Before using the Federated storage engine, please be sure to read"
389 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html" 371 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html"
390 myconf="${myconf} --with-federated-storage-engine" 372 myconf="${myconf} --with-federated-storage-engine"
373 fi
374 fi
375
376 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
377 myconf="${myconf} `use_enable community community-features`"
378 if use community; then
379 myconf="${myconf} `use_enable profiling`"
380 else
381 myconf="${myconf} --disable-profiling"
391 fi 382 fi
392 fi 383 fi
393 384
394 mysql_version_is_at_least "5.0.18" \ 385 mysql_version_is_at_least "5.0.18" \
395 && use max-idx-128 \ 386 && use max-idx-128 \
418 409
419 elog "Before using the Federated storage engine, please be sure to read" 410 elog "Before using the Federated storage engine, please be sure to read"
420 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html" 411 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
421 fi 412 fi
422 413
423 if use innodb ; then 414 # Upstream specifically requests that InnoDB always be built.
424 plugins="${plugins},innobase" 415 plugins="${plugins},innobase"
425 fi
426 416
427 # like configuration=max-no-ndb 417 # like configuration=max-no-ndb
428 if use cluster ; then 418 if use cluster ; then
429 plugins="${plugins},ndbcluster" 419 plugins="${plugins},ndbcluster"
430 myconf="${myconf} --with-ndb-binlog" 420 myconf="${myconf} --with-ndb-binlog"
435 fi 425 fi
436 426
437 myconf="${myconf} --with-plugins=${plugins}" 427 myconf="${myconf} --with-plugins=${plugins}"
438} 428}
439 429
440pbxt_src_compile() { 430pbxt_src_configure() {
441 mysql_init_vars 431 mysql_init_vars
442 432
443 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null 433 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
444 434
445 einfo "Reconfiguring dir '${PWD}'" 435 einfo "Reconfiguring dir '${PWD}'"
448 local myconf="" 438 local myconf=""
449 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}" 439 myconf="${myconf} --with-mysql=${S} --libdir=${D}/${MY_LIBDIR}"
450 use debug && myconf="${myconf} --with-debug=full" 440 use debug && myconf="${myconf} --with-debug=full"
451 # TODO: is it safe/needed to use econf here ? 441 # TODO: is it safe/needed to use econf here ?
452 ./configure ${myconf} || die "Problem configuring PBXT storage engine" 442 ./configure ${myconf} || die "Problem configuring PBXT storage engine"
443}
444
445pbxt_src_compile() {
446 # Be backwards compatible for now
447 if [[ $EAPI != 2 ]]; then
448 pbxt_src_configure
449 fi
453 # TODO: is it safe/needed to use emake here ? 450 # TODO: is it safe/needed to use emake here ?
454 make || die "Problem making PBXT storage engine (${myconf})" 451 make || die "Problem making PBXT storage engine (${myconf})"
455 452
456 popd 453 popd
457 # TODO: modify test suite for PBXT 454 # TODO: modify test suite for PBXT
467# EBUILD FUNCTIONS 464# EBUILD FUNCTIONS
468# 465#
469mysql_pkg_setup() { 466mysql_pkg_setup() {
470 if hasq test ${FEATURES} ; then 467 if hasq test ${FEATURES} ; then
471 if ! use minimal ; then 468 if ! use minimal ; then
472 if ! hasq userpriv ${FEATURES} ; then 469 if [[ $UID -eq 0 ]]; then
473 die "Testing with FEATURES=-userpriv is no longer supported by upstream" 470 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
474 fi 471 fi
475 fi 472 fi
476 fi 473 fi
477 474
478 # Check for USE flag problems in pkg_setup 475 # Check for USE flag problems in pkg_setup
493 && ( use cluster || use extraengine ) \ 490 && ( use cluster || use extraengine ) \
494 && use minimal ; then 491 && use minimal ; then
495 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 492 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
496 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 493 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
497 fi 494 fi
498 495
499 # This should come after all of the die statements 496 # This should come after all of the die statements
500 enewgroup mysql 60 || die "problem adding 'mysql' group" 497 enewgroup mysql 60 || die "problem adding 'mysql' group"
501 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 498 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
502 499
503 mysql_check_version_range "4.0 to 5.0.99.99" \ 500 mysql_check_version_range "4.0 to 5.0.99.99" \
510 mysql_init_vars 507 mysql_init_vars
511 508
512 unpack ${A} 509 unpack ${A}
513 # Grab the patches 510 # Grab the patches
514 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack 511 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack
515 # Bitkeeper checkout support 512
516 if [[ ${IS_BITKEEPER} -eq 90 ]] ; then
517 if mysql_check_version_range "5.1 to 5.1.99" ; then
518 bitkeeper_fetch "mysql-5.1-ndb"
519 elif mysql_check_version_range "5.2 to 5.2.99" ; then
520 bitkeeper_fetch "mysql-5.2-falcon"
521 else
522 bitkeeper_fetch
523 fi
524 cd "${S}"
525 einfo "Running upstream autorun over BK sources ..."
526 BUILD/autorun.sh
527 else
528 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}" 513 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}"
514
515 # Be backwards compatible for now
516 if [[ $EAPI != 2 ]]; then
517 mysql_src_prepare
518 fi
519}
520
521mysql_src_prepare() {
529 cd "${S}" 522 cd "${S}"
530 fi
531 523
532 # Apply the patches for this MySQL version 524 # Apply the patches for this MySQL version
533 EPATCH_SUFFIX="patch" 525 EPATCH_SUFFIX="patch"
534 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory" 526 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory"
535 # Clean out old items 527 # Clean out old items
561 local rebuilddirlist d 553 local rebuilddirlist d
562 554
563 if mysql_version_is_at_least "5.1.12" ; then 555 if mysql_version_is_at_least "5.1.12" ; then
564 rebuilddirlist="." 556 rebuilddirlist="."
565 # TODO: check this with a cmake expert 557 # TODO: check this with a cmake expert
566 use innodb \
567 && cmake \ 558 cmake \
568 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \ 559 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
569 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \ 560 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
570 "storage/innobase" 561 "storage/innobase"
571 else 562 else
572 rebuilddirlist=". innobase" 563 rebuilddirlist=". innobase"
582 if mysql_check_version_range "4.1 to 5.0.99.99" \ 573 if mysql_check_version_range "4.1 to 5.0.99.99" \
583 && use berkdb ; then 574 && use berkdb ; then
584 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh" 575 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
585 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \ 576 cp -f "/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
586 || die "Could not copy libtool.m4 to bdb/dist/" 577 || die "Could not copy libtool.m4 to bdb/dist/"
578 #These files exist only with libtool-2*, and need to be included.
579 if [ -f '/usr/share/aclocal/ltsugar.m4' ]; then
580 cat "/usr/share/aclocal/ltsugar.m4" >> "bdb/dist/aclocal/libtool.ac"
581 cat "/usr/share/aclocal/ltversion.m4" >> "bdb/dist/aclocal/libtool.ac"
582 cat "/usr/share/aclocal/lt~obsolete.m4" >> "bdb/dist/aclocal/libtool.ac"
583 cat "/usr/share/aclocal/ltoptions.m4" >> "bdb/dist/aclocal/libtool.ac"
584 fi
587 pushd "bdb/dist" &>/dev/null 585 pushd "bdb/dist" &>/dev/null
588 sh s_all \ 586 sh s_all \
589 || die "Failed bdb reconfigure" 587 || die "Failed bdb reconfigure"
590 popd &>/dev/null 588 popd &>/dev/null
591 fi 589 fi
592} 590}
593 591
594mysql_src_compile() { 592mysql_src_configure() {
595 # Make sure the vars are correctly initialized 593 # Make sure the vars are correctly initialized
596 mysql_init_vars 594 mysql_init_vars
597 595
598 # $myconf is modified by the configure_* functions 596 # $myconf is modified by the configure_* functions
599 local myconf="" 597 local myconf=""
612 # Bug #114895, bug #110149 610 # Bug #114895, bug #110149
613 filter-flags "-O" "-O[01]" 611 filter-flags "-O" "-O[01]"
614 612
615 # glib-2.3.2_pre fix, bug #16496 613 # glib-2.3.2_pre fix, bug #16496
616 append-flags "-DHAVE_ERRNO_AS_DEFINE=1" 614 append-flags "-DHAVE_ERRNO_AS_DEFINE=1"
615
616 # As discovered by bug #246652, doing a double-level of SSP causes NDB to
617 # fail badly during cluster startup.
618 if [[ $(gcc-major-version) -lt 4 ]]; then
619 filter-flags "-fstack-protector-all"
620 fi
617 621
618 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing" 622 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing"
619 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti" 623 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti"
620 mysql_version_is_at_least "5.0" \ 624 mysql_version_is_at_least "5.0" \
621 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates" 625 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
638 # TODO: Move this before autoreconf !!! 642 # TODO: Move this before autoreconf !!!
639 find . -type f -name Makefile -print0 \ 643 find . -type f -name Makefile -print0 \
640 | xargs -0 -n100 sed -i \ 644 | xargs -0 -n100 sed -i \
641 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|' 645 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
642 646
647 if [[ $EAPI == 2 ]]; then
648 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_configure
649 fi
650}
651
652mysql_src_compile() {
653 # Be backwards compatible for now
654 if [[ $EAPI != 2 ]]; then
655 mysql_src_configure
656 fi
657
643 emake || die "emake failed" 658 emake || die "emake failed"
644 659
645 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile 660 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_compile
646} 661}
647 662
651 666
652 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed" 667 emake install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die "emake install failed"
653 668
654 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_install 669 mysql_version_is_at_least "5.1.12" && use pbxt && pbxt_src_install
655 670
656 insinto "${MY_INCLUDEDIR}"
657 doins "${MY_INCLUDEDIR}"/my_{config,dir}.h
658
659 # Convenience links 671 # Convenience links
672 einfo "Making Convenience links for mysqlcheck multi-call binary"
660 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze" 673 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
661 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair" 674 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
662 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqloptimize" 675 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqloptimize"
663 676
664 # Various junk (my-*.cnf moved elsewhere) 677 # Various junk (my-*.cnf moved elsewhere)
678 einfo "Removing duplicate /usr/share/mysql files"
665 rm -Rf "${D}/usr/share/info" 679 rm -Rf "${D}/usr/share/info"
666 for removeme in "mysql-log-rotate" mysql.server* \ 680 for removeme in "mysql-log-rotate" mysql.server* \
667 binary-configure* my-*.cnf mi_test_all* 681 binary-configure* my-*.cnf mi_test_all*
668 do 682 do
669 rm -f "${D}"/usr/share/mysql/${removeme} 683 rm -f "${D}"/usr/share/mysql/${removeme}
670 done 684 done
671 685
672 # Clean up stuff for a minimal build 686 # Clean up stuff for a minimal build
673 if use minimal ; then 687 if use minimal ; then
688 einfo "Remove all extra content for minimal build"
674 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench} 689 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench}
675 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam} 690 rm -f "${D}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
676 rm -f "${D}/usr/sbin/mysqld" 691 rm -f "${D}/usr/sbin/mysqld"
677 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a 692 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
678 fi 693 fi
681 if mysql_version_is_at_least "4.1" ; then 696 if mysql_version_is_at_least "4.1" ; then
682 mysql_mycnf_version="4.1" 697 mysql_mycnf_version="4.1"
683 else 698 else
684 mysql_mycnf_version="4.0" 699 mysql_mycnf_version="4.0"
685 fi 700 fi
701 einfo "Building default my.cnf"
686 insinto "${MY_SYSCONFDIR}" 702 insinto "${MY_SYSCONFDIR}"
687 doins scripts/mysqlaccess.conf 703 doins scripts/mysqlaccess.conf
688 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \ 704 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
689 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \ 705 "${FILESDIR}/my.cnf-${mysql_mycnf_version}" \
690 > "${TMPDIR}/my.cnf.ok" 706 > "${TMPDIR}/my.cnf.ok"
693 fi 709 fi
694 newins "${TMPDIR}/my.cnf.ok" my.cnf 710 newins "${TMPDIR}/my.cnf.ok" my.cnf
695 711
696 # Minimal builds don't have the MySQL server 712 # Minimal builds don't have the MySQL server
697 if ! use minimal ; then 713 if ! use minimal ; then
714 einfo "Creating initial directories"
698 # Empty directories ... 715 # Empty directories ...
699 diropts "-m0750" 716 diropts "-m0750"
700 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then 717 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
701 dodir "${MY_DATADIR}" 718 dodir "${MY_DATADIR}"
702 keepdir "${MY_DATADIR}" 719 keepdir "${MY_DATADIR}"
710 chown -R mysql:mysql "${D}/${folder}" 727 chown -R mysql:mysql "${D}/${folder}"
711 done 728 done
712 fi 729 fi
713 730
714 # Docs 731 # Docs
732 einfo "Installing docs"
715 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE 733 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE
716 doinfo ${S}/Docs/mysql.info 734 doinfo "${S}"/Docs/mysql.info
717 735
718 # Minimal builds don't have the MySQL server 736 # Minimal builds don't have the MySQL server
719 if ! use minimal ; then 737 if ! use minimal ; then
738 einfo "Including support files and sample configurations"
720 docinto "support-files" 739 docinto "support-files"
721 for script in \ 740 for script in \
722 support-files/my-*.cnf \ 741 "${S}"/support-files/my-*.cnf \
723 support-files/magic \ 742 "${S}"/support-files/magic \
724 support-files/ndb-config-2-node.ini 743 "${S}"/support-files/ndb-config-2-node.ini
725 do 744 do
726 dodoc "${script}" 745 dodoc "${script}"
727 done 746 done
728 747
729 docinto "scripts" 748 docinto "scripts"
730 for script in scripts/mysql* ; do 749 for script in "${S}"/scripts/mysql* ; do
731 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}" 750 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
732 done 751 done
733 752
734 fi 753 fi
735 754
795 && use berkdb \ 814 && use berkdb \
796 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 815 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
797} 816}
798 817
799mysql_pkg_config() { 818mysql_pkg_config() {
819 local old_MY_DATADIR="${MY_DATADIR}"
820
800 # Make sure the vars are correctly initialized 821 # Make sure the vars are correctly initialized
801 mysql_init_vars 822 mysql_init_vars
802 823
803 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR" 824 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
804 825
805 if built_with_use ${CATEGORY}/${PN} minimal ; then 826 if built_with_use ${CATEGORY}/${PN} minimal ; then
806 die "Minimal builds do NOT include the MySQL server" 827 die "Minimal builds do NOT include the MySQL server"
828 fi
829
830 if [[ ( -n "${MY_DATADIR}" ) && ( "${MY_DATADIR}" != "${old_MY_DATADIR}" ) ]]; then
831 local MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${MY_DATADIR})"
832 local old_MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${old_MY_DATADIR})"
833
834 if [[ -d "${old_MY_DATADIR_s}" ]]; then
835 if [[ -d "${MY_DATADIR_s}" ]]; then
836 ewarn "Both ${old_MY_DATADIR_s} and ${MY_DATADIR_s} exist"
837 ewarn "Attempting to use ${MY_DATADIR_s} and preserving ${old_MY_DATADIR_s}"
838 else
839 elog "Moving MY_DATADIR from ${old_MY_DATADIR_s} to ${MY_DATADIR_s}"
840 mv --strip-trailing-slashes -T "${old_MY_DATADIR_s}" "${MY_DATADIR_s}" \
841 || die "Moving MY_DATADIR failed"
842 fi
843 else
844 ewarn "Previous MY_DATADIR (${old_MY_DATADIR_s}) does not exist"
845 if [[ -d "${MY_DATADIR_s}" ]]; then
846 ewarn "Attempting to use ${MY_DATADIR_s}"
847 else
848 eerror "New MY_DATADIR (${MY_DATADIR_s}) does not exist"
849 die "Configuration Failed! Please reinstall ${CATEGORY}/${PN}"
850 fi
851 fi
807 fi 852 fi
808 853
809 local pwd1="a" 854 local pwd1="a"
810 local pwd2="b" 855 local pwd2="b"
811 local maxtry=5 856 local maxtry=5
815 ewarn "(${ROOT}/${MY_DATADIR}/*)" 860 ewarn "(${ROOT}/${MY_DATADIR}/*)"
816 ewarn "Please rename or delete it if you wish to replace it." 861 ewarn "Please rename or delete it if you wish to replace it."
817 die "MySQL database already exists!" 862 die "MySQL database already exists!"
818 fi 863 fi
819 864
865 # Bug #213475 - MySQL _will_ object strenously if your machine is named
866 # localhost. Also causes weird failures.
867 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
868
820 einfo "Creating the mysql database and setting proper" 869 einfo "Creating the mysql database and setting proper"
821 einfo "permissions on it ..." 870 einfo "permissions on it ..."
822 871
823 einfo "Insert a password for the mysql 'root' user" 872 einfo "Insert a password for the mysql 'root' user"
824 ewarn "Avoid [\"'\\_%] characters in the password" 873 ewarn "Avoid [\"'\\_%] characters in the password"
847 die "Failed to run mysql_install_db. Please review /var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log" 896 die "Failed to run mysql_install_db. Please review /var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"
848 fi 897 fi
849 popd &>/dev/null 898 popd &>/dev/null
850 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \ 899 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
851 || die "MySQL databases not installed" 900 || die "MySQL databases not installed"
852 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2> /dev/null 901 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
853 chmod 0750 "${ROOT}/${MY_DATADIR}" 2> /dev/null 902 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
854 903
855 if mysql_version_is_at_least "4.1.3" ; then 904 if mysql_version_is_at_least "4.1.3" ; then
856 options="--skip-ndbcluster" 905 options="--skip-ndbcluster"
857 906
858 # Filling timezones, see 907 # Filling timezones, see

Legend:
Removed from v.1.90  
changed lines
  Added in v.1.112

  ViewVC Help
Powered by ViewVC 1.1.20