/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Diff of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.80 Revision 1.90
1# Copyright 1999-2007 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.80 2007/07/11 08:18:03 robbat2 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.90 2008/05/22 18:13:33 robbat2 Exp $
4 4
5# Author: Francesco Riosa (Retired) <vivo@gentoo.org> 5# Author: Francesco Riosa (Retired) <vivo@gentoo.org>
6# Maintainer: MySQL Team <mysql-bugs@gentoo.org>
6# Maintainer: Luca Longinotti <chtekk@gentoo.org> 7# - Luca Longinotti <chtekk@gentoo.org>
7 8# - Robin H. Johnson <robbat2@gentoo.org>
8# Both MYSQL_VERSION_ID and MYSQL_PATCHSET_REV must be set in the ebuild too!
9# Note that MYSQL_VERSION_ID must be empty!
10 9
11WANT_AUTOCONF="latest" 10WANT_AUTOCONF="latest"
12WANT_AUTOMAKE="latest" 11WANT_AUTOMAKE="latest"
13 12
14inherit eutils flag-o-matic gnuconfig autotools mysql_fx 13inherit eutils flag-o-matic gnuconfig autotools mysql_fx
16# Shorten the path because the socket path length must be shorter than 107 chars 15# Shorten the path because the socket path length must be shorter than 107 chars
17# and we will run a mysql server during test phase 16# and we will run a mysql server during test phase
18S="${WORKDIR}/mysql" 17S="${WORKDIR}/mysql"
19 18
20[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20070108" 19[[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20070108"
20if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
21 EGIT_PROJECT=mysql-extras
22 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
23 inherit git
24fi
21 25
22if [[ ${PR#r} -lt 60 ]] ; then 26if [[ ${PR#r} -lt 60 ]] ; then
23 IS_BITKEEPER=0 27 IS_BITKEEPER=0
24elif [[ ${PR#r} -lt 90 ]] ; then 28elif [[ ${PR#r} -lt 90 ]] ; then
25 IS_BITKEEPER=60 29 IS_BITKEEPER=60
30# MYSQL_VERSION_ID will be: 34# MYSQL_VERSION_ID will be:
31# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99] 35# major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
32# This is an important part, because many of the choices the MySQL ebuild will do 36# This is an important part, because many of the choices the MySQL ebuild will do
33# depend on this variable. 37# depend on this variable.
34# In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803" 38# In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803"
39# We also strip off upstream's trailing letter that they use to respin tarballs
35 40
36MYSQL_VERSION_ID="" 41MYSQL_VERSION_ID=""
42tpv="${PV%[a-z]}"
37tpv=( ${PV//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}" 43tpv=( ${tpv//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}"
38for vatom in 0 1 2 3 ; do 44for vatom in 0 1 2 3 ; do
39 # pad to length 2 45 # pad to length 2
40 tpv[${vatom}]="00${tpv[${vatom}]}" 46 tpv[${vatom}]="00${tpv[${vatom}]}"
41 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}" 47 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}"
42done 48done
43# strip leading "0" (otherwise it's considered an octal number by BASH) 49# strip leading "0" (otherwise it's considered an octal number by BASH)
44MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"} 50MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"}
45 51
46# Be warned, *DEPEND are version-dependant 52# Be warned, *DEPEND are version-dependant
53# These are used for both runtime and compiletime
47DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d ) 54DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )
48 userland_GNU? ( sys-process/procps ) 55 userland_GNU? ( sys-process/procps )
49 >=sys-apps/sed-4 56 >=sys-apps/sed-4
50 >=sys-apps/texinfo-4.7-r1 57 >=sys-apps/texinfo-4.7-r1
51 >=sys-libs/readline-4.1 58 >=sys-libs/readline-4.1
55for i in "" "-community" ; do 62for i in "" "-community" ; do
56 [[ "${i}" == ${PN#mysql} ]] || 63 [[ "${i}" == ${PN#mysql} ]] ||
57 DEPEND="${DEPEND} !dev-db/mysql${i}" 64 DEPEND="${DEPEND} !dev-db/mysql${i}"
58done 65done
59 66
67RDEPEND="${DEPEND}
68 !minimal? ( dev-db/mysql-init-scripts )
69 selinux? ( sec-policy/selinux-mysql )"
70
71# compile-time-only
60mysql_version_is_at_least "5.1" \ 72mysql_version_is_at_least "5.1" \
61|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )" 73|| DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
62 74
75# compile-time-only
63mysql_version_is_at_least "5.1.12" \ 76mysql_version_is_at_least "5.1.12" \
64&& DEPEND="${DEPEND} innodb? ( >=dev-util/cmake-2.4.3 )" 77&& DEPEND="${DEPEND} innodb? ( >=dev-util/cmake-2.4.3 )"
65 78
79# BitKeeper dependency, compile-time only
80[[ ${IS_BITKEEPER} -eq 90 ]] && DEPEND="${DEPEND} dev-util/bk_client"
81
82
66# dev-perl/DBD-mysql is needed by some scripts installed by MySQL 83# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
67PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )" 84PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
68 85
69# BitKeeper dependency, compile-time only 86# Work out the default SERVER_URI correctly
70[[ ${IS_BITKEEPER} -eq 90 ]] && DEPEND="${DEPEND} dev-util/bk_client" 87if [ -z "${SERVER_URI}" ]; then
88 # The community build is on the mirrors
89 if [ "${PN}" == "mysql-community" ]; then
90 SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz"
91 # The enterprise source is on the primary site only
92 elif [ "${PN}" == "mysql" ]; then
93 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${PV//_/-}.tar.gz"
94 fi
95fi
71 96
72# Define correct SRC_URIs 97# Define correct SRC_URIs
73SRC_URI="${SERVER_URI} 98SRC_URI="${SERVER_URI}"
99
100[[ ${MY_EXTRAS_VER} != live ]] && SRC_URI="${SRC_URI}
74 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2 101 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
75 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2" 102 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
76mysql_version_is_at_least "5.1.12" \ 103mysql_version_is_at_least "5.1.12" \
77&& [[ -n "${PBXT_VERSION}" ]] \ 104&& [[ -n "${PBXT_VERSION}" ]] \
78&& SRC_URI="${SRC_URI} pbxt? ( mirror://sourceforge/pbxt/pbxt-${PBXT_VERSION}.tar.gz )" 105&& SRC_URI="${SRC_URI} pbxt? ( mirror://sourceforge/pbxt/pbxt-${PBXT_VERSION}.tar.gz )"
101mysql_version_is_at_least "5.1" \ 128mysql_version_is_at_least "5.1" \
102|| IUSE="${IUSE} berkdb" 129|| IUSE="${IUSE} berkdb"
103 130
104mysql_version_is_at_least "5.1.12" \ 131mysql_version_is_at_least "5.1.12" \
105&& IUSE="${IUSE} pbxt" 132&& IUSE="${IUSE} pbxt"
106
107RDEPEND="${DEPEND}
108 !minimal? ( dev-db/mysql-init-scripts )
109 selinux? ( sec-policy/selinux-mysql )"
110 133
111EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst \ 134EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst \
112 pkg_postinst pkg_config pkg_postrm 135 pkg_postinst pkg_config pkg_postrm
113 136
114# 137#
205 MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \ 228 MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
206 | sed -ne '/datadir/s|^--datadir=||p' \ 229 | sed -ne '/datadir/s|^--datadir=||p' \
207 | tail -n1` 230 | tail -n1`
208 if [[ -z "${MY_DATADIR}" ]] ; then 231 if [[ -z "${MY_DATADIR}" ]] ; then
209 MY_DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" \ 232 MY_DATADIR=`grep ^datadir "${MY_SYSCONFDIR}/my.cnf" \
210 | sed -e 's/.*=\s*//'` 233 | sed -e 's/.*=\s*//' \
234 | tail -n1`
211 fi 235 fi
212 fi 236 fi
213 if [[ -z "${MY_DATADIR}" ]] ; then 237 if [[ -z "${MY_DATADIR}" ]] ; then
214 MY_DATADIR="${MY_LOCALSTATEDIR}" 238 MY_DATADIR="${MY_LOCALSTATEDIR}"
215 einfo "Using default MY_DATADIR" 239 einfo "Using default MY_DATADIR"
238 262
239configure_minimal() { 263configure_minimal() {
240 # These are things we exclude from a minimal build, please 264 # These are things we exclude from a minimal build, please
241 # note that the server actually does get built and installed, 265 # note that the server actually does get built and installed,
242 # but we then delete it before packaging. 266 # but we then delete it before packaging.
243 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication" 267 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication readline"
244 268
245 for i in ${minimal_exclude_list} ; do 269 for i in ${minimal_exclude_list} ; do
246 myconf="${myconf} --without-${i}" 270 myconf="${myconf} --without-${i}"
247 done 271 done
248 myconf="${myconf} --with-extra-charsets=none" 272 myconf="${myconf} --with-extra-charsets=none"
440} 464}
441 465
442# 466#
443# EBUILD FUNCTIONS 467# EBUILD FUNCTIONS
444# 468#
445
446mysql_pkg_setup() { 469mysql_pkg_setup() {
447 enewgroup mysql 60 || die "problem adding 'mysql' group" 470 if hasq test ${FEATURES} ; then
448 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user" 471 if ! use minimal ; then
472 if ! hasq userpriv ${FEATURES} ; then
473 die "Testing with FEATURES=-userpriv is no longer supported by upstream"
474 fi
475 fi
476 fi
449 477
450 # Check for USE flag problems in pkg_setup 478 # Check for USE flag problems in pkg_setup
451 if use static && use ssl ; then 479 if use static && use ssl ; then
452 eerror "MySQL does not support being built statically with SSL support enabled!" 480 eerror "MySQL does not support being built statically with SSL support enabled!"
453 die "MySQL does not support being built statically with SSL support enabled!" 481 die "MySQL does not support being built statically with SSL support enabled!"
465 && ( use cluster || use extraengine ) \ 493 && ( use cluster || use extraengine ) \
466 && use minimal ; then 494 && use minimal ; then
467 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 495 eerror "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
468 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!" 496 die "USE flags 'cluster' and 'extraengine' conflict with 'minimal' USE flag!"
469 fi 497 fi
498
499 # This should come after all of the die statements
500 enewgroup mysql 60 || die "problem adding 'mysql' group"
501 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
470 502
471 mysql_check_version_range "4.0 to 5.0.99.99" \ 503 mysql_check_version_range "4.0 to 5.0.99.99" \
472 && use berkdb \ 504 && use berkdb \
473 && elog "Berkeley DB support is deprecated and will be removed in future versions!" 505 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
474} 506}
476mysql_src_unpack() { 508mysql_src_unpack() {
477 # Initialize the proper variables first 509 # Initialize the proper variables first
478 mysql_init_vars 510 mysql_init_vars
479 511
480 unpack ${A} 512 unpack ${A}
513 # Grab the patches
514 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack
515 # Bitkeeper checkout support
481 if [[ ${IS_BITKEEPER} -eq 90 ]] ; then 516 if [[ ${IS_BITKEEPER} -eq 90 ]] ; then
482 if mysql_check_version_range "5.1 to 5.1.99" ; then 517 if mysql_check_version_range "5.1 to 5.1.99" ; then
483 bitkeeper_fetch "mysql-5.1-ndb" 518 bitkeeper_fetch "mysql-5.1-ndb"
484 elif mysql_check_version_range "5.2 to 5.2.99" ; then 519 elif mysql_check_version_range "5.2 to 5.2.99" ; then
485 bitkeeper_fetch "mysql-5.2-falcon" 520 bitkeeper_fetch "mysql-5.2-falcon"
495 fi 530 fi
496 531
497 # Apply the patches for this MySQL version 532 # Apply the patches for this MySQL version
498 EPATCH_SUFFIX="patch" 533 EPATCH_SUFFIX="patch"
499 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory" 534 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory"
535 # Clean out old items
536 rm -f "${EPATCH_SOURCE}"/*
537 # Now link in right patches
500 mysql_mv_patches 538 mysql_mv_patches
539 # And apply
501 epatch 540 epatch
502 541
503 # Additional checks, remove bundled zlib 542 # Additional checks, remove bundled zlib
504 rm -f "${S}/zlib/"*.[ch] 543 rm -f "${S}/zlib/"*.[ch]
505 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in" 544 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
525 rebuilddirlist="." 564 rebuilddirlist="."
526 # TODO: check this with a cmake expert 565 # TODO: check this with a cmake expert
527 use innodb \ 566 use innodb \
528 && cmake \ 567 && cmake \
529 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \ 568 -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
530 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCC)) \ 569 -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
531 "storage/innobase" 570 "storage/innobase"
532 else 571 else
533 rebuilddirlist=". innobase" 572 rebuilddirlist=". innobase"
534 fi 573 fi
535 574
800 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \ 839 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \
801 || touch "${TMPDIR}/fill_help_tables.sql" 840 || touch "${TMPDIR}/fill_help_tables.sql"
802 help_tables="${TMPDIR}/fill_help_tables.sql" 841 help_tables="${TMPDIR}/fill_help_tables.sql"
803 842
804 pushd "${TMPDIR}" &>/dev/null 843 pushd "${TMPDIR}" &>/dev/null
805 "${ROOT}/usr/bin/mysql_install_db" | grep -B5 -A999 -i "ERROR" 844 "${ROOT}/usr/bin/mysql_install_db" >"${TMPDIR}"/mysql_install_db.log 2>&1
845 if [ $? -ne 0 ]; then
846 grep -B5 -A999 -i "ERROR" "${TMPDIR}"/mysql_install_db.log 1>&2
847 die "Failed to run mysql_install_db. Please review /var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"
848 fi
806 popd &>/dev/null 849 popd &>/dev/null
807 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \ 850 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
808 || die "MySQL databases not installed" 851 || die "MySQL databases not installed"
809 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2> /dev/null 852 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2> /dev/null
810 chmod 0750 "${ROOT}/${MY_DATADIR}" 2> /dev/null 853 chmod 0750 "${ROOT}/${MY_DATADIR}" 2> /dev/null

Legend:
Removed from v.1.80  
changed lines
  Added in v.1.90

  ViewVC Help
Powered by ViewVC 1.1.20