/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Contents of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.172 - (show annotations) (download)
Mon Jul 23 10:57:15 2012 UTC (2 years ago) by jmbsvicetto
Branch: MAIN
Changes since 1.171: +2 -2 lines
Sync mysql and mysql-v2 eclasses from the mysql overlay.
Simplify ncurses dependency and update inherit to use git-2 eclass.

1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.170 2012/01/09 10:42:19 grobian Exp $
4
5 # @ECLASS: mysql.eclass
6 # @MAINTAINER:
7 # MySQL Team <mysql-bugs@gentoo.org>
8 # Luca Longinotti <chtekk@gentoo.org>
9 # Robin H. Johnson <robbat2@gentoo.org>
10 # @AUTHOR:
11 # Francesco Riosa (Retired) <vivo@gentoo.org>
12 # @BLURB: This eclass provides most of the functions for mysql ebuilds
13 # @DESCRIPTION:
14 # The mysql.eclass provides almost all the code to build the mysql ebuilds
15 # including the src_unpack, src_prepare, src_configure, src_compile,
16 # scr_install, pkg_preinst, pkg_postinst, pkg_config and pkg_postrm
17 # phase hooks.
18
19 WANT_AUTOCONF="latest"
20 WANT_AUTOMAKE="latest"
21
22 inherit eutils flag-o-matic gnuconfig autotools multilib mysql_fx versionator toolchain-funcs
23
24 # Shorten the path because the socket path length must be shorter than 107 chars
25 # and we will run a mysql server during test phase
26 S="${WORKDIR}/mysql"
27
28 [[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z"
29 if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
30 EGIT_PROJECT=mysql-extras
31 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
32 inherit git-2
33 fi
34
35 case "${EAPI:-0}" in
36 2 | 3 | 4)
37 EXPORT_FUNCTIONS pkg_setup \
38 src_unpack src_prepare \
39 src_configure src_compile \
40 src_install \
41 pkg_preinst pkg_postinst \
42 pkg_config pkg_postrm
43 IUSE_DEFAULT_ON='+'
44 ;;
45 0 | 1)
46 EXPORT_FUNCTIONS pkg_setup \
47 src_unpack \
48 src_compile \
49 src_install \
50 pkg_preinst pkg_postinst \
51 pkg_config pkg_postrm
52 ;;
53 *)
54 die "Unsupported EAPI: ${EAPI}" ;;
55 esac
56
57
58 # @ECLASS-VARIABLE: MYSQL_PV_MAJOR
59 # @DESCRIPTION:
60 # Upstream MySQL considers the first two parts of the version number to be the
61 # major version. Upgrades that change major version should always run
62 # mysql_upgrade.
63 MYSQL_PV_MAJOR="$(get_version_component_range 1-2 ${PV})"
64
65 # Cluster is a special case...
66 if [[ "${PN}" == "mysql-cluster" ]]; then
67 case $PV in
68 6.1*|7.0*|7.1*) MYSQL_PV_MAJOR=5.1 ;;
69 esac
70 fi
71
72
73 # @ECLASS-VARIABLE: MYSQL_VERSION_ID
74 # @DESCRIPTION:
75 # MYSQL_VERSION_ID will be:
76 # major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
77 # This is an important part, because many of the choices the MySQL ebuild will do
78 # depend on this variable.
79 # In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803"
80 # We also strip off upstream's trailing letter that they use to respin tarballs
81
82 MYSQL_VERSION_ID=""
83 tpv="${PV%[a-z]}"
84 tpv=( ${tpv//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}"
85 for vatom in 0 1 2 3 ; do
86 # pad to length 2
87 tpv[${vatom}]="00${tpv[${vatom}]}"
88 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}"
89 done
90 # strip leading "0" (otherwise it's considered an octal number by BASH)
91 MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"}
92
93 # @ECLASS-VARIABLE: MYSQL_COMMUNITY_FEATURES
94 # @DESCRIPTION:
95 # Specifiy if community features are available. Possible values are 1 (yes)
96 # and 0 (no).
97 # Community features are available in mysql-community
98 # AND in the re-merged mysql-5.0.82 and newer
99 if [ "${PN}" == "mysql-community" -o "${PN}" == "mariadb" ]; then
100 MYSQL_COMMUNITY_FEATURES=1
101 elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
102 MYSQL_COMMUNITY_FEATURES=1
103 elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
104 MYSQL_COMMUNITY_FEATURES=1
105 elif [ "${PV#5.4}" != "${PV}" ] ; then
106 MYSQL_COMMUNITY_FEATURES=1
107 elif [ "${PV#5.5}" != "${PV}" ] ; then
108 MYSQL_COMMUNITY_FEATURES=1
109 elif [ "${PV#6}" != "${PV}" ] ; then
110 MYSQL_COMMUNITY_FEATURES=1
111 elif [ "${PV#7}" != "${PV}" ] ; then
112 MYSQL_COMMUNITY_FEATURES=1
113 else
114 MYSQL_COMMUNITY_FEATURES=0
115 fi
116
117 # @ECLASS-VARIABLE: XTRADB_VER
118 # @DESCRIPTION:
119 # Version of the XTRADB storage engine
120 XTRADB_VER="${XTRADB_VER}"
121
122 # @ECLASS-VARIABLE: PERCONA_VER
123 # @DESCRIPTION:
124 # Designation by PERCONA for a MySQL version to apply an XTRADB release
125 PERCONA_VER="${PERCONA_VER}"
126
127 # Be warned, *DEPEND are version-dependant
128 # These are used for both runtime and compiletime
129 DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )
130 kernel_linux? ( sys-process/procps )
131 >=sys-apps/sed-4
132 >=sys-apps/texinfo-4.7-r1
133 >=sys-libs/readline-4.1
134 >=sys-libs/zlib-1.2.3"
135
136 [[ "${PN}" == "mariadb" ]] \
137 && DEPEND="${DEPEND} libevent? ( >=dev-libs/libevent-1.4 )"
138
139 # Having different flavours at the same time is not a good idea
140 for i in "mysql" "mysql-community" "mysql-cluster" "mariadb" ; do
141 [[ "${i}" == ${PN} ]] ||
142 DEPEND="${DEPEND} !dev-db/${i}"
143 done
144
145 # prefix: first need to implement something for #196294
146 RDEPEND="${DEPEND}
147 !minimal? ( !prefix? ( dev-db/mysql-init-scripts ) )
148 selinux? ( sec-policy/selinux-mysql )"
149
150 DEPEND="${DEPEND}
151 virtual/yacc"
152
153 if [ "${EAPI:-0}" = "2" ]; then
154 DEPEND="${DEPEND} static? ( sys-libs/ncurses[static-libs] )"
155 fi
156
157 # compile-time-only
158 mysql_version_is_at_least "5.1" \
159 || DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
160
161 # compile-time-only
162 mysql_version_is_at_least "5.1.12" \
163 && DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
164
165 [[ "${PN}" == "mariadb" ]] \
166 && mysql_version_is_at_least "5.2" \
167 && DEPEND="${DEPEND} oqgraph? ( >=dev-libs/boost-1.40.0 )"
168 #SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
169 # sphinx? ( app-misc/sphinx )"
170
171 # dev-perl/DBD-mysql is needed by some scripts installed by MySQL
172 PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
173
174 # For other stuff to bring us in
175 PDEPEND="${PDEPEND} =virtual/mysql-${MYSQL_PV_MAJOR}"
176
177 # Work out the default SERVER_URI correctly
178 if [ -z "${SERVER_URI}" ]; then
179 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
180 if [ "${PN}" == "mariadb" ]; then
181 MARIA_FULL_PV="$(replace_version_separator 3 '-' ${PV})"
182 MARIA_FULL_P="${PN}-${MARIA_FULL_PV}"
183 SERVER_URI="
184 http://ftp.osuosl.org/pub/mariadb/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
185 http://ftp.rediris.es/mirror/MariaDB/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
186 http://maria.llarian.net/download/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
187 http://launchpad.net/maria/${MYSQL_PV_MAJOR}/ongoing/+download/${MARIA_FULL_P}.tar.gz
188 http://mirrors.fe.up.pt/pub/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
189 http://ftp-stud.hs-esslingen.de/pub/Mirrors/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
190 "
191 # The community and cluster builds are on the mirrors
192 elif [[ "${MYSQL_COMMUNITY_FEATURES}" == "1" || ${PN} == "mysql-cluster" ]] ; then
193 if [[ "${PN}" == "mysql-cluster" ]] ; then
194 URI_DIR="MySQL-Cluster"
195 URI_FILE="mysql-cluster-gpl"
196 else
197 URI_DIR="MySQL"
198 URI_FILE="mysql"
199 fi
200 URI_A="${URI_FILE}-${MY_PV}.tar.gz"
201 MIRROR_PV=$(get_version_component_range 1-2 ${PV})
202 # Recently upstream switched to an archive site, and not on mirrors
203 SERVER_URI="http://downloads.mysql.com/archives/${URI_FILE}-${MIRROR_PV}/${URI_A}
204 mirror://mysql/Downloads/${URI_DIR}-${PV%.*}/${URI_A}"
205 # The (old) enterprise source is on the primary site only
206 elif [ "${PN}" == "mysql" ]; then
207 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
208 fi
209 fi
210
211 # Define correct SRC_URIs
212 SRC_URI="${SERVER_URI}"
213
214 # Gentoo patches to MySQL
215 [[ ${MY_EXTRAS_VER} != live ]] \
216 && SRC_URI="${SRC_URI}
217 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
218 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
219 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
220
221 DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
222 HOMEPAGE="http://www.mysql.com/"
223 if [[ "${PN}" == "mariadb" ]]; then
224 HOMEPAGE="http://askmonty.org/"
225 DESCRIPTION="MariaDB is a MySQL fork with 3rd-party patches and additional storage engines merged."
226 fi
227 if [[ "${PN}" == "mysql-community" ]]; then
228 DESCRIPTION="${DESCRIPTION} (obsolete, move to dev-db/mysql)"
229 fi
230 LICENSE="GPL-2"
231 SLOT="0"
232 IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
233
234 mysql_version_is_at_least "4.1" \
235 && IUSE="${IUSE} latin1"
236
237 if mysql_version_is_at_least "4.1.3" ; then
238 IUSE="${IUSE} extraengine"
239 if [[ "${PN}" != "mysql-cluster" ]] ; then
240 IUSE="${IUSE} cluster"
241 fi
242 fi
243
244 mysql_version_is_at_least "5.0" \
245 || IUSE="${IUSE} raid"
246
247 mysql_version_is_at_least "5.0.18" \
248 && IUSE="${IUSE} max-idx-128"
249
250 mysql_version_is_at_least "5.1" \
251 || IUSE="${IUSE} berkdb"
252
253 [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
254 && IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
255
256 [[ "${PN}" == "mariadb" ]] \
257 && IUSE="${IUSE} libevent"
258
259 [[ "${PN}" == "mariadb" ]] \
260 && mysql_version_is_at_least "5.2" \
261 && IUSE="${IUSE} oqgraph"
262 #SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
263 #&& IUSE="${IUSE} oqgraph sphinx"
264
265 # MariaDB has integrated PBXT
266 # PBXT_VERSION means that we have a PBXT patch for this PV
267 # PBXT was only introduced after 5.1.12
268 pbxt_patch_available() {
269 [[ "${PN}" != "mariadb" ]] \
270 && mysql_version_is_at_least "5.1.12" \
271 && [[ -n "${PBXT_VERSION}" ]]
272 return $?
273 }
274
275 pbxt_available() {
276 pbxt_patch_available || [[ "${PN}" == "mariadb" ]]
277 return $?
278 }
279
280 # Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
281 # MariaDB has integrated XtraDB
282 # XTRADB_VERS means that we have a XTRADB patch for this PV
283 # XTRADB was only introduced after 5.1.26
284 xtradb_patch_available() {
285 [[ "${PN}" != "mariadb" ]] \
286 && mysql_version_is_at_least "5.1.26" \
287 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]]
288 return $?
289 }
290
291
292 pbxt_patch_available \
293 && PBXT_P="pbxt-${PBXT_VERSION}" \
294 && PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
295 && SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
296
297 # PBXT_NEWSTYLE means pbxt is in storage/ and gets enabled as other plugins
298 # vs. built outside the dir
299 pbxt_available \
300 && IUSE="${IUSE} pbxt" \
301 && mysql_version_is_at_least "5.1.40" \
302 && PBXT_NEWSTYLE=1
303
304 xtradb_patch_available \
305 && XTRADB_P="percona-xtradb-${XTRADB_VER}" \
306 && XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
307 && XTRADB_SRC_B1="http://www.percona.com/" \
308 && XTRADB_SRC_B2="${XTRADB_SRC_B1}/percona-builds/" \
309 && XTRADB_SRC_URI1="${XTRADB_SRC_B2}/Percona-Server/Percona-Server-${XTRADB_SRC_URI_COMMON}" \
310 && XTRADB_SRC_URI2="${XTRADB_SRC_B2}/xtradb/${XTRADB_SRC_URI_COMMON}" \
311 && XTRADB_SRC_URI3="${XTRADB_SRC_B1}/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
312 && SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} ${XTRADB_SRC_URI3} )" \
313 && IUSE="${IUSE} xtradb"
314
315 #
316 # HELPER FUNCTIONS:
317 #
318
319 # @FUNCTION: mysql_disable_test
320 # @DESCRIPTION:
321 # Helper function to disable specific tests.
322 mysql_disable_test() {
323 local rawtestname testname testsuite reason mysql_disable_file
324 rawtestname="${1}" ; shift
325 reason="${@}"
326 ewarn "test '${rawtestname}' disabled: '${reason}'"
327
328 testsuite="${rawtestname/.*}"
329 testname="${rawtestname/*.}"
330 mysql_disable_file="${S}/mysql-test/t/disabled.def"
331 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
332 echo ${testname} : ${reason} >> "${mysql_disable_file}"
333
334 # ${S}/mysql-tests/t/disabled.def
335 #
336 # ${S}/mysql-tests/suite/federated/disabled.def
337 #
338 # ${S}/mysql-tests/suite/jp/t/disabled.def
339 # ${S}/mysql-tests/suite/ndb/t/disabled.def
340 # ${S}/mysql-tests/suite/rpl/t/disabled.def
341 # ${S}/mysql-tests/suite/parts/t/disabled.def
342 # ${S}/mysql-tests/suite/rpl_ndb/t/disabled.def
343 # ${S}/mysql-tests/suite/ndb_team/t/disabled.def
344 # ${S}/mysql-tests/suite/binlog/t/disabled.def
345 # ${S}/mysql-tests/suite/innodb/t/disabled.def
346 if [ -n "${testsuite}" ]; then
347 for mysql_disable_file in \
348 ${S}/mysql-test/suite/${testsuite}/disabled.def \
349 ${S}/mysql-test/suite/${testsuite}/t/disabled.def \
350 FAILED ; do
351 [ -f "${mysql_disable_file}" ] && break
352 done
353 if [ "${mysql_disabled_file}" != "FAILED" ]; then
354 echo "${testname} : ${reason}" >> "${mysql_disable_file}"
355 else
356 ewarn "Could not find testsuite disabled.def location for ${rawtestname}"
357 fi
358 fi
359 }
360
361 # @FUNCTION: mysql_init_vars
362 # @DESCRIPTION:
363 # void mysql_init_vars()
364 # Initialize global variables
365 # 2005-11-19 <vivo@gentoo.org>
366 mysql_init_vars() {
367 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR="${EPREFIX}/usr/share/mysql"}
368 MY_SYSCONFDIR=${MY_SYSCONFDIR="${EPREFIX}/etc/mysql"}
369 MY_LIBDIR=${MY_LIBDIR="${EPREFIX}/usr/$(get_libdir)/mysql"}
370 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="${EPREFIX}/var/lib/mysql"}
371 MY_LOGDIR=${MY_LOGDIR="${EPREFIX}/var/log/mysql"}
372 MY_INCLUDEDIR=${MY_INCLUDEDIR="${EPREFIX}/usr/include/mysql"}
373
374 if [[ -z "${MY_DATADIR}" ]] ; then
375 MY_DATADIR=""
376 if [[ -f ${MY_SYSCONFDIR}/my.cnf ]] ; then
377 MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
378 | sed -ne '/datadir/s|^--datadir=||p' \
379 | tail -n1`
380 if [[ -z "${MY_DATADIR}" ]] ; then
381 MY_DATADIR=`grep ^datadir ${MY_SYSCONFDIR}/my.cnf \
382 | sed -e 's/.*=\s*//' \
383 | tail -n1`
384 fi
385 fi
386 if [[ -z "${MY_DATADIR}" ]] ; then
387 MY_DATADIR="${MY_LOCALSTATEDIR}"
388 einfo "Using default MY_DATADIR"
389 fi
390 elog "MySQL MY_DATADIR is ${MY_DATADIR}"
391
392 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then
393 if [[ -e "${MY_DATADIR}" ]] ; then
394 # If you get this and you're wondering about it, see bug #207636
395 elog "MySQL datadir found in ${MY_DATADIR}"
396 elog "A new one will not be created."
397 PREVIOUS_DATADIR="yes"
398 else
399 PREVIOUS_DATADIR="no"
400 fi
401 export PREVIOUS_DATADIR
402 fi
403 else
404 if [[ ${EBUILD_PHASE} == "config" ]]; then
405 local new_MY_DATADIR
406 new_MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
407 | sed -ne '/datadir/s|^--datadir=||p' \
408 | tail -n1`
409
410 if [[ ( -n "${new_MY_DATADIR}" ) && ( "${new_MY_DATADIR}" != "${MY_DATADIR}" ) ]]; then
411 ewarn "MySQL MY_DATADIR has changed"
412 ewarn "from ${MY_DATADIR}"
413 ewarn "to ${new_MY_DATADIR}"
414 MY_DATADIR="${new_MY_DATADIR}"
415 fi
416 fi
417 fi
418
419 if [ "${MY_SOURCEDIR:-unset}" == "unset" ]; then
420 MY_SOURCEDIR=${SERVER_URI##*/}
421 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
422 fi
423
424 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
425 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
426 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
427 }
428
429 configure_minimal() {
430 # These are things we exclude from a minimal build, please
431 # note that the server actually does get built and installed,
432 # but we then delete it before packaging.
433 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication readline"
434
435 for i in ${minimal_exclude_list} ; do
436 myconf="${myconf} --without-${i}"
437 done
438 myconf="${myconf} --with-extra-charsets=none"
439 myconf="${myconf} --enable-local-infile"
440
441 if use static ; then
442 myconf="${myconf} --with-client-ldflags=-all-static"
443 myconf="${myconf} --disable-shared --with-pic"
444 else
445 myconf="${myconf} --enable-shared --enable-static"
446 fi
447
448 if mysql_version_is_at_least "4.1" && ! use latin1 ; then
449 myconf="${myconf} --with-charset=utf8"
450 myconf="${myconf} --with-collation=utf8_general_ci"
451 else
452 myconf="${myconf} --with-charset=latin1"
453 myconf="${myconf} --with-collation=latin1_swedish_ci"
454 fi
455 }
456
457 configure_common() {
458 myconf="${myconf} $(use_with big-tables)"
459 myconf="${myconf} --enable-local-infile"
460 myconf="${myconf} --with-extra-charsets=all"
461 myconf="${myconf} --with-mysqld-user=mysql"
462 myconf="${myconf} --with-server"
463 myconf="${myconf} --with-unix-socket-path=${EPREFIX}/var/run/mysqld/mysqld.sock"
464 myconf="${myconf} --without-libwrap"
465
466 if use static ; then
467 myconf="${myconf} --with-mysqld-ldflags=-all-static"
468 myconf="${myconf} --with-client-ldflags=-all-static"
469 myconf="${myconf} --disable-shared --with-pic"
470 else
471 myconf="${myconf} --enable-shared --enable-static"
472 fi
473
474 if use debug ; then
475 myconf="${myconf} --with-debug=full"
476 else
477 myconf="${myconf} --without-debug"
478 mysql_version_is_at_least "4.1.3" \
479 && ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) \
480 && myconf="${myconf} --without-ndb-debug"
481 fi
482
483 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
484 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
485 ewarn "and a collation of ${MYSQL_DEFAULT_COLLATION}."
486 ewarn "You MUST file bugs without these variables set."
487 myconf="${myconf} --with-charset=${MYSQL_DEFAULT_CHARSET}"
488 myconf="${myconf} --with-collation=${MYSQL_DEFAULT_COLLATION}"
489 elif mysql_version_is_at_least "4.1" && ! use latin1 ; then
490 myconf="${myconf} --with-charset=utf8"
491 myconf="${myconf} --with-collation=utf8_general_ci"
492 else
493 myconf="${myconf} --with-charset=latin1"
494 myconf="${myconf} --with-collation=latin1_swedish_ci"
495 fi
496
497 if use embedded ; then
498 myconf="${myconf} --with-embedded-privilege-control"
499 myconf="${myconf} --with-embedded-server"
500 else
501 myconf="${myconf} --without-embedded-privilege-control"
502 myconf="${myconf} --without-embedded-server"
503 fi
504
505 }
506
507 configure_40_41_50() {
508 myconf="${myconf} --with-zlib-dir=${EPREFIX}/usr"
509 myconf="${myconf} $(use_with perl bench)"
510 myconf="${myconf} --enable-assembler"
511 myconf="${myconf} --with-extra-tools"
512 myconf="${myconf} --with-innodb"
513 myconf="${myconf} --without-readline"
514 myconf="${myconf} $(use_with ssl openssl "${EPREFIX}/usr")"
515 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
516
517 # --with-vio is not needed anymore, it's on by default and
518 # has been removed from configure
519 # Apply to 4.x and 5.0.[0-3]
520 if use ssl ; then
521 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
522 fi
523
524 if mysql_version_is_at_least "5.0.60" ; then
525 if use berkdb ; then
526 elog "Berkeley DB support was disabled due to build failures"
527 elog "on multiple arches, go to a version earlier than 5.0.60"
528 elog "if you want it again. Gentoo bug #224067."
529 fi
530 myconf="${myconf} --without-berkeley-db"
531 elif use berkdb ; then
532 # The following fix is due to a bug with bdb on SPARC's. See:
533 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
534 # It comes down to non-64-bit safety problems.
535 if use alpha || use amd64 || use hppa || use mips || use sparc ; then
536 elog "Berkeley DB support was disabled due to compatibility issues on this arch"
537 myconf="${myconf} --without-berkeley-db"
538 else
539 myconf="${myconf} --with-berkeley-db=./bdb"
540 fi
541 else
542 myconf="${myconf} --without-berkeley-db"
543 fi
544
545 if mysql_version_is_at_least "4.1.3" ; then
546 myconf="${myconf} --with-geometry"
547 if [[ "${PN}" != "mysql-cluster" ]] ; then
548 myconf="${myconf} $(use_with cluster ndbcluster)"
549 fi
550 fi
551
552 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
553 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
554 myconf="${myconf} --with-archive-storage-engine"
555
556 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
557 myconf="${myconf} --with-csv-storage-engine"
558
559 # http://dev.mysql.com/doc/mysql/en/blackhole-storage-engine.html
560 myconf="${myconf} --with-blackhole-storage-engine"
561
562 # http://dev.mysql.com/doc/mysql/en/federated-storage-engine.html
563 # http://dev.mysql.com/doc/mysql/en/federated-description.html
564 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html
565 if mysql_version_is_at_least "5.0.3" ; then
566 elog "Before using the Federated storage engine, please be sure to read"
567 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html"
568 myconf="${myconf} --with-federated-storage-engine"
569 fi
570 fi
571
572 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
573 myconf="${myconf} `use_enable community community-features`"
574 if use community; then
575 myconf="${myconf} `use_enable profiling`"
576 else
577 myconf="${myconf} --disable-profiling"
578 fi
579 fi
580
581 mysql_version_is_at_least "5.0.18" \
582 && use max-idx-128 \
583 && myconf="${myconf} --with-max-indexes=128"
584 }
585
586 configure_51() {
587 # TODO: !!!! readd --without-readline
588 # the failure depend upon config/ac-macros/readline.m4 checking into
589 # readline.h instead of history.h
590 myconf="${myconf} $(use_with ssl ssl "${EPREFIX}"/usr)"
591 myconf="${myconf} --enable-assembler"
592 myconf="${myconf} --with-geometry"
593 myconf="${myconf} --with-readline"
594 myconf="${myconf} --with-zlib-dir=${EPREFIX}/usr/"
595 myconf="${myconf} --without-pstack"
596 myconf="${myconf} --with-plugindir=${EPREFIX}/usr/$(get_libdir)/mysql/plugin"
597
598 # This is an explict die here, because if we just forcibly disable it, then the
599 # user's data is not accessible.
600 use max-idx-128 && die "Bug #336027: upstream has a corruption issue with max-idx-128 presently"
601 #use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
602 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
603 myconf="${myconf} $(use_enable community community-features)"
604 if use community; then
605 myconf="${myconf} $(use_enable profiling)"
606 else
607 myconf="${myconf} --disable-profiling"
608 fi
609 fi
610
611 # Scan for all available plugins
612 local plugins_avail="$(
613 LANG=C \
614 find "${S}" \
615 \( \
616 -name 'plug.in' \
617 -o -iname 'configure.in' \
618 -o -iname 'configure.ac' \
619 \) \
620 -print0 \
621 | xargs -0 sed -r -n \
622 -e '/^MYSQL_STORAGE_ENGINE/{
623 s~MYSQL_STORAGE_ENGINE\([[:space:]]*\[?([-_a-z0-9]+)\]?.*,~\1 ~g ;
624 s~^([^ ]+).*~\1~gp;
625 }' \
626 | tr -s '\n' ' '
627 )"
628
629 # 5.1 introduces a new way to manage storage engines (plugins)
630 # like configuration=none
631 # This base set are required, and will always be statically built.
632 local plugins_sta="csv myisam myisammrg heap"
633 local plugins_dyn=""
634 local plugins_dis="example ibmdb2i"
635
636 # These aren't actually required by the base set, but are really useful:
637 plugins_sta="${plugins_sta} archive blackhole"
638
639 # default in 5.5.4
640 if mysql_version_is_at_least "5.5.4" ; then
641 plugins_sta="${plugins_sta} partition"
642 fi
643 # Now the extras
644 if use extraengine ; then
645 # like configuration=max-no-ndb, archive and example removed in 5.1.11
646 # not added yet: ibmdb2i
647 # Not supporting as examples: example,daemon_example,ftexample
648 plugins_sta="${plugins_sta} partition"
649
650 if [[ "${PN}" != "mariadb" ]] ; then
651 elog "Before using the Federated storage engine, please be sure to read"
652 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
653 plugins_dyn="${plugins_sta} federated"
654 else
655 elog "MariaDB includes the FederatedX engine. Be sure to read"
656 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
657 plugins_dyn="${plugins_sta} federatedx"
658 fi
659 else
660 plugins_dis="${plugins_dis} partition federated"
661 fi
662
663 # Upstream specifically requests that InnoDB always be built:
664 # - innobase, innodb_plugin
665 # Build falcon if available for 6.x series.
666 for i in innobase falcon ; do
667 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
668 done
669 for i in innodb_plugin ; do
670 [ -e "${S}"/storage/${i} ] && plugins_dyn="${plugins_dyn} ${i}"
671 done
672
673 # like configuration=max-no-ndb
674 if ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) ; then
675 plugins_sta="${plugins_sta} ndbcluster partition"
676 plugins_dis="${plugins_dis//partition}"
677 myconf="${myconf} --with-ndb-binlog"
678 else
679 plugins_dis="${plugins_dis} ndbcluster"
680 fi
681
682 if [[ "${PN}" == "mariadb" ]] ; then
683 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
684 # caught above.
685 # This is not optional, without it several upstream testcases fail.
686 # Also strongly recommended by upstream.
687 if [[ "${PV}" < "5.2.0" ]] ; then
688 myconf="${myconf} --with-maria-tmp-tables"
689 plugins_sta="${plugins_sta} maria"
690 else
691 myconf="${myconf} --with-aria-tmp-tables"
692 plugins_sta="${plugins_sta} aria"
693 fi
694
695 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] ||
696 die "The ${P} package doesn't provide innobase nor xtradb"
697
698 for i in innobase xtradb ; do
699 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
700 done
701
702 myconf="${myconf} $(use_with libevent)"
703
704 if mysql_version_is_at_least "5.2" ; then
705 #This should include sphinx, but the 5.2.4 archive forgot the plug.in file
706 #for i in oqgraph sphinx ; do
707 for i in oqgraph ; do
708 use ${i} \
709 && plugins_dyn="${plugins_dyn} ${i}" \
710 || plugins_dis="${plugins_dis} ${i}"
711 done
712 fi
713 fi
714
715 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then
716 use pbxt \
717 && plugins_dyn="${plugins_dyn} pbxt" \
718 || plugins_dis="${plugins_dis} pbxt"
719 fi
720
721 use static && \
722 plugins_sta="${plugins_sta} ${plugins_dyn}" && \
723 plugins_dyn=""
724
725 einfo "Available plugins: ${plugins_avail}"
726 einfo "Dynamic plugins: ${plugins_dyn}"
727 einfo "Static plugins: ${plugins_sta}"
728 einfo "Disabled plugins: ${plugins_dis}"
729
730 # These are the static plugins
731 myconf="${myconf} --with-plugins=${plugins_sta// /,}"
732 # And the disabled ones
733 for i in ${plugins_dis} ; do
734 myconf="${myconf} --without-plugin-${i}"
735 done
736 }
737
738 pbxt_src_configure() {
739 mysql_init_vars
740
741 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
742
743 einfo "Reconfiguring dir '${PWD}'"
744 eautoreconf
745
746 local myconf=""
747 myconf="${myconf} --with-mysql=${S} --libdir=${EPREFIX}/usr/$(get_libdir)"
748 use debug && myconf="${myconf} --with-debug=full"
749 econf ${myconf} || die "Problem configuring PBXT storage engine"
750 }
751
752 pbxt_src_compile() {
753
754 # Be backwards compatible for now
755 if [[ $EAPI != 2 ]]; then
756 pbxt_src_configure
757 fi
758 # TODO: is it safe/needed to use emake here ?
759 make || die "Problem making PBXT storage engine (${myconf})"
760
761 popd
762 # TODO: modify test suite for PBXT
763 }
764
765 pbxt_src_install() {
766 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
767 emake install DESTDIR="${D}" || die "Failed to install PBXT"
768 popd
769 }
770
771 #
772 # EBUILD FUNCTIONS
773 #
774 # @FUNCTION: mysql_pkg_setup
775 # @DESCRIPTION:
776 # Perform some basic tests and tasks during pkg_setup phase:
777 # die if FEATURES="test", USE="-minimal" and not using FEATURES="userpriv"
778 # check for conflicting use flags
779 # create new user and group for mysql
780 # warn about deprecated features
781 mysql_pkg_setup() {
782 if has test ${FEATURES} ; then
783 if ! use minimal ; then
784 if [[ $UID -eq 0 ]]; then
785 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
786 fi
787 fi
788 fi
789
790 # bug 350844
791 case "${EAPI:-0}" in
792 0 | 1)
793 if use static && !built_with_use sys-libs/ncurses static-libs; then
794 die "To build MySQL statically you need to enable static-libs for sys-libs/ncurses"
795 fi
796 ;;
797 esac
798
799 # Check for USE flag problems in pkg_setup
800 if use static && use ssl ; then
801 M="MySQL does not support being built statically with SSL support enabled!"
802 eerror "${M}"
803 die "${M}"
804 fi
805
806 if mysql_version_is_at_least "5.1.51" \
807 && ! mysql_version_is_at_least "5.2" \
808 && use debug ; then
809 # Also in package.use.mask
810 die "Bug #344885: Upstream has broken USE=debug for 5.1 series >=5.1.51"
811 fi
812
813 if ! mysql_version_is_at_least "5.0" \
814 && use raid \
815 && use static ; then
816 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically"
817 eerror "with RAID support enabled."
818 die "USE flags 'raid' and 'static' conflict!"
819 fi
820
821 if mysql_version_is_at_least "4.1.3" \
822 && ( use cluster || use extraengine || use embedded ) \
823 && use minimal ; then
824 M="USE flags 'cluster', 'extraengine', 'embedded' conflict with 'minimal' USE flag!"
825 eerror "${M}"
826 die "${M}"
827 fi
828
829 if mysql_version_is_at_least "5.1" \
830 && xtradb_patch_available \
831 && use xtradb \
832 && use embedded ; then
833 M="USE flags 'xtradb' and 'embedded' conflict and cause build failures"
834 eerror "${M}"
835 die "${M}"
836 fi
837
838 # Bug #290570, 284946, 307251
839 # Upstream changes made us need a fairly new GCC4.
840 # But only for 5.0.8[3-6]!
841 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then
842 GCC_VER=$(gcc-version)
843 case ${CHOST}:${GCC_VER} in
844 *-darwin*:4.*) : ;; # bug #310615
845 *:2*|*:3*|*:4.0|*:4.1|*:4.2)
846 eerror "Some releases of MySQL required a very new GCC, and then"
847 eerror "later release relaxed that requirement again. Either pick a"
848 eerror "MySQL >=5.0.87, or use a newer GCC."
849 die "Active GCC too old!" ;;
850 esac
851 fi
852
853 # This should come after all of the die statements
854 enewgroup mysql 60 || die "problem adding 'mysql' group"
855 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
856
857 mysql_check_version_range "4.0 to 5.0.99.99" \
858 && use berkdb \
859 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
860
861 if [ "${PN}" != "mysql-cluster" ] && use cluster; then
862 ewarn "Upstream has noted that the NDB cluster support in the 5.0 and"
863 ewarn "5.1 series should NOT be put into production. In the near"
864 ewarn "future, it will be disabled from building."
865 ewarn ""
866 ewarn "If you need NDB support, you should instead move to the new"
867 ewarn "mysql-cluster package that represents that upstream NDB"
868 ewarn "development."
869 fi
870 }
871
872 # @FUNCTION: mysql_src_unpack
873 # @DESCRIPTION:
874 # Unpack the source code and call mysql_src_prepare for EAPI < 2.
875 mysql_src_unpack() {
876 # Initialize the proper variables first
877 mysql_init_vars
878
879 unpack ${A}
880 # Grab the patches
881 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git_src_unpack
882
883 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}"
884
885 # Be backwards compatible for now
886 case ${EAPI:-0} in
887 2) : ;;
888 0 | 1) mysql_src_prepare ;;
889 esac
890 }
891
892 # @FUNCTION: mysql_src_prepare
893 # @DESCRIPTION:
894 # Apply patches to the source code and remove unneeded bundled libs.
895 mysql_src_prepare() {
896 cd "${S}"
897
898 # Apply the patches for this MySQL version
899 EPATCH_SUFFIX="patch"
900 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory"
901 # Clean out old items
902 rm -f "${EPATCH_SOURCE}"/*
903 # Now link in right patches
904 mysql_mv_patches
905 # And apply
906 epatch
907
908 # last -fPIC fixup, per bug #305873
909 i="${S}"/storage/innodb_plugin/plug.in
910 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
911
912 # Additional checks, remove bundled zlib (Cluster needs this, for static
913 # memory management in zlib, leave available for Cluster)
914 if [[ "${PN}" != "mysql-cluster" ]] ; then
915 rm -f "${S}/zlib/"*.[ch]
916 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
917 fi
918 rm -f "scripts/mysqlbug"
919
920 # Make charsets install in the right place
921 find . -name 'Makefile.am' \
922 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
923
924 if mysql_version_is_at_least "4.1" ; then
925 # Remove what needs to be recreated, so we're sure it's actually done
926 einfo "Cleaning up old buildscript files"
927 find . -name Makefile \
928 -o -name Makefile.in \
929 -o -name configure \
930 -exec rm -f {} \;
931 rm -f "ltmain.sh"
932 rm -f "scripts/mysqlbug"
933 fi
934
935 local rebuilddirlist d
936
937 if xtradb_patch_available && use xtradb ; then
938 einfo "Adding storage engine: Percona XtraDB (replacing InnoDB)"
939 pushd "${S}"/storage >/dev/null
940 i="innobase"
941 o="${WORKDIR}/storage-${i}.mysql-upstream"
942 # Have we been here already?
943 [ -d "${o}" ] && rm -f "${i}"
944 # Or maybe we haven't
945 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
946 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}"
947 popd >/dev/null
948 fi
949
950 if pbxt_patch_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then
951 einfo "Adding storage engine: PBXT"
952 pushd "${S}"/storage >/dev/null
953 i='pbxt'
954 [ -d "${i}" ] && rm -rf "${i}"
955 cp -ral "${WORKDIR}/${PBXT_P}" "${i}"
956 popd >/dev/null
957 fi
958
959 if mysql_version_is_at_least "5.1.12" ; then
960 rebuilddirlist="."
961 # This does not seem to be needed presently. robbat2 2010/02/23
962 #einfo "Updating innobase cmake"
963 ## TODO: check this with a cmake expert
964 #cmake \
965 # -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
966 # -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
967 # "storage/innobase"
968 else
969 rebuilddirlist=". innobase"
970 fi
971
972 for d in ${rebuilddirlist} ; do
973 einfo "Reconfiguring dir '${d}'"
974 pushd "${d}" &>/dev/null
975 eautoreconf
976 popd &>/dev/null
977 done
978
979 if mysql_check_version_range "4.1 to 5.0.99.99" \
980 && use berkdb ; then
981 einfo "Fixing up berkdb buildsystem"
982 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
983 cp -f "${EPREFIX}/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
984 || die "Could not copy libtool.m4 to bdb/dist/"
985 #These files exist only with libtool-2*, and need to be included.
986 if [ -f ${EPREFIX}'/usr/share/aclocal/ltsugar.m4' ]; then
987 cat "${EPREFIX}/usr/share/aclocal/ltsugar.m4" >> "bdb/dist/aclocal/libtool.ac"
988 cat "${EPREFIX}/usr/share/aclocal/ltversion.m4" >> "bdb/dist/aclocal/libtool.ac"
989 cat "${EPREFIX}/usr/share/aclocal/lt~obsolete.m4" >> "bdb/dist/aclocal/libtool.ac"
990 cat "${EPREFIX}/usr/share/aclocal/ltoptions.m4" >> "bdb/dist/aclocal/libtool.ac"
991 fi
992 pushd "bdb/dist" &>/dev/null
993 sh s_all \
994 || die "Failed bdb reconfigure"
995 popd &>/dev/null
996 fi
997 }
998
999 # @FUNCTION: mysql_src_configure
1000 # @DESCRIPTION:
1001 # Configure mysql to build the code for Gentoo respecting the use flags.
1002 mysql_src_configure() {
1003 # Make sure the vars are correctly initialized
1004 mysql_init_vars
1005
1006 # $myconf is modified by the configure_* functions
1007 local myconf=""
1008
1009 if use minimal ; then
1010 configure_minimal
1011 else
1012 configure_common
1013 if mysql_version_is_at_least "5.1.10" ; then
1014 configure_51
1015 else
1016 configure_40_41_50
1017 fi
1018 fi
1019
1020 # Bug #114895, bug #110149
1021 filter-flags "-O" "-O[01]"
1022
1023 # glib-2.3.2_pre fix, bug #16496
1024 append-flags "-DHAVE_ERRNO_AS_DEFINE=1"
1025
1026 # As discovered by bug #246652, doing a double-level of SSP causes NDB to
1027 # fail badly during cluster startup.
1028 if [[ $(gcc-major-version) -lt 4 ]]; then
1029 filter-flags "-fstack-protector-all"
1030 fi
1031
1032 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing"
1033 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti"
1034 mysql_version_is_at_least "5.0" \
1035 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
1036 export CXXFLAGS
1037
1038 # bug #283926, with GCC4.4, this is required to get correct behavior.
1039 append-flags -fno-strict-aliasing
1040
1041 # bug #335185, #335995, with >= GCC4.3.3 on x86 only, omit-frame-pointer
1042 # causes a mis-compile.
1043 # Upstream bugs:
1044 # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38562
1045 # http://bugs.mysql.com/bug.php?id=45205
1046 use x86 && version_is_at_least "4.3.3" "$(gcc-fullversion)" && \
1047 append-flags -fno-omit-frame-pointer && \
1048 filter-flags -fomit-frame-pointer
1049
1050 econf \
1051 --libexecdir="${EPREFIX}"/usr/sbin \
1052 --sysconfdir=${MY_SYSCONFDIR} \
1053 --localstatedir=${MY_LOCALSTATEDIR} \
1054 --sharedstatedir=${MY_SHAREDSTATEDIR} \
1055 --libdir=${MY_LIBDIR} \
1056 --includedir=${MY_INCLUDEDIR} \
1057 --with-low-memory \
1058 --with-client-ldflags=-lstdc++ \
1059 --enable-thread-safe-client \
1060 --with-comment="Gentoo Linux ${PF}" \
1061 --without-docs \
1062 --with-LIBDIR="$(get_libdir)" \
1063 ${myconf} || die "econf failed"
1064
1065 # TODO: Move this before autoreconf !!!
1066 find . -type f -name Makefile -print0 \
1067 | xargs -0 -n100 sed -i \
1068 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
1069
1070 if [[ $EAPI == 2 ]] && [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1071 pbxt_patch_available && use pbxt && pbxt_src_configure
1072 fi
1073 }
1074
1075 # @FUNCTION: mysql_src_compile
1076 # @DESCRIPTION:
1077 # Compile the mysql code.
1078 mysql_src_compile() {
1079 # Be backwards compatible for now
1080 case ${EAPI:-0} in
1081 2) : ;;
1082 0 | 1) mysql_src_configure ;;
1083 esac
1084
1085 emake || die "emake failed"
1086
1087 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1088 pbxt_patch_available && use pbxt && pbxt_src_compile
1089 fi
1090 }
1091
1092 # @FUNCTION: mysql_src_install
1093 # @DESCRIPTION:
1094 # Install mysql.
1095 mysql_src_install() {
1096 # Make sure the vars are correctly initialized
1097 mysql_init_vars
1098
1099 emake install \
1100 DESTDIR="${D}" \
1101 benchdir_root=${MY_SHAREDSTATEDIR} \
1102 testroot="${MY_SHAREDSTATEDIR}" \
1103 || die "emake install failed"
1104
1105 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1106 pbxt_patch_available && use pbxt && pbxt_src_install
1107 fi
1108
1109 # Convenience links
1110 einfo "Making Convenience links for mysqlcheck multi-call binary"
1111 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
1112 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
1113 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqloptimize"
1114
1115 # Various junk (my-*.cnf moved elsewhere)
1116 einfo "Removing duplicate /usr/share/mysql files"
1117 rm -Rf "${ED}/usr/share/info"
1118 for removeme in "mysql-log-rotate" mysql.server* \
1119 binary-configure* my-*.cnf mi_test_all*
1120 do
1121 rm -f "${D}"/${MY_SHAREDSTATEDIR}/${removeme}
1122 done
1123
1124 # Clean up stuff for a minimal build
1125 if use minimal ; then
1126 einfo "Remove all extra content for minimal build"
1127 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench}
1128 rm -f "${ED}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
1129 rm -f "${ED}/usr/sbin/mysqld"
1130 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
1131 fi
1132
1133 # Unless they explicitly specific USE=test, then do not install the
1134 # testsuite. It DOES have a use to be installed, esp. when you want to do a
1135 # validation of your database configuration after tuning it.
1136 if use !test ; then
1137 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
1138 fi
1139
1140 # Configuration stuff
1141 case ${MYSQL_PV_MAJOR} in
1142 3*|4.0) mysql_mycnf_version="4.0" ;;
1143 4.[1-9]|5.0) mysql_mycnf_version="4.1" ;;
1144 5.[1-9]|6*|7*) mysql_mycnf_version="5.1" ;;
1145 esac
1146 einfo "Building default my.cnf (${mysql_mycnf_version})"
1147 insinto "${MY_SYSCONFDIR#${EPREFIX}}"
1148 doins scripts/mysqlaccess.conf
1149 mycnf_src="my.cnf-${mysql_mycnf_version}"
1150 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
1151 -e "s!/tmp!${EPREFIX}/tmp!" \
1152 -e "s!/usr!${EPREFIX}/usr!" \
1153 -e "s!= /var!= ${EPREFIX}/var!" \
1154 "${FILESDIR}/${mycnf_src}" \
1155 > "${TMPDIR}/my.cnf.ok"
1156 use prefix && sed -i -e '/^user[ ]*= mysql$/d' "${TMPDIR}/my.cnf.ok"
1157 if use latin1 ; then
1158 sed -i \
1159 -e "/character-set/s|utf8|latin1|g" \
1160 "${TMPDIR}/my.cnf.ok"
1161 fi
1162 newins "${TMPDIR}/my.cnf.ok" my.cnf
1163
1164 # Minimal builds don't have the MySQL server
1165 if ! use minimal ; then
1166 einfo "Creating initial directories"
1167 # Empty directories ...
1168 diropts "-m0750"
1169 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
1170 dodir "${MY_DATADIR#${EPREFIX}}"
1171 keepdir "${MY_DATADIR#${EPREFIX}}"
1172 chown -R mysql:mysql "${D}/${MY_DATADIR}"
1173 fi
1174
1175 diropts "-m0755"
1176 for folder in "${MY_LOGDIR#${EPREFIX}}" "/var/run/mysqld" ; do
1177 dodir "${folder}"
1178 keepdir "${folder}"
1179 chown -R mysql:mysql "${ED}/${folder}"
1180 done
1181 fi
1182
1183 # Docs
1184 einfo "Installing docs"
1185 for i in README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE ; do
1186 [[ -f "$i" ]] && dodoc "$i"
1187 done
1188 doinfo "${S}"/Docs/mysql.info
1189
1190 # Minimal builds don't have the MySQL server
1191 if ! use minimal ; then
1192 einfo "Including support files and sample configurations"
1193 docinto "support-files"
1194 for script in \
1195 "${S}"/support-files/my-*.cnf \
1196 "${S}"/support-files/magic \
1197 "${S}"/support-files/ndb-config-2-node.ini
1198 do
1199 [[ -f "$script" ]] && dodoc "${script}"
1200 done
1201
1202 docinto "scripts"
1203 for script in "${S}"/scripts/mysql* ; do
1204 [[ -f "$script" ]] && [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
1205 done
1206
1207 fi
1208
1209 mysql_lib_symlinks "${ED}"
1210 }
1211
1212 # @FUNCTION: mysql_pkg_preinst
1213 # @DESCRIPTION:
1214 # Create the user and groups for mysql - die if that fails.
1215 mysql_pkg_preinst() {
1216 enewgroup mysql 60 || die "problem adding 'mysql' group"
1217 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
1218 }
1219
1220 # @FUNCTION: mysql_pkg_postinst
1221 # @DESCRIPTION:
1222 # Run post-installation tasks:
1223 # create the dir for logfiles if non-existant
1224 # touch the logfiles and secure them
1225 # install scripts
1226 # issue required steps for optional features
1227 # issue deprecation warnings
1228 mysql_pkg_postinst() {
1229 # Make sure the vars are correctly initialized
1230 mysql_init_vars
1231
1232 # Check FEATURES="collision-protect" before removing this
1233 [[ -d "${EROOT}/var/log/mysql" ]] || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
1234
1235 # Secure the logfiles
1236 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
1237 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
1238 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
1239
1240 # Minimal builds don't have the MySQL server
1241 if ! use minimal ; then
1242 docinto "support-files"
1243 for script in \
1244 support-files/my-*.cnf \
1245 support-files/magic \
1246 support-files/ndb-config-2-node.ini
1247 do
1248 [[ -f "${script}" ]] \
1249 && dodoc "${script}"
1250 done
1251
1252 docinto "scripts"
1253 for script in scripts/mysql* ; do
1254 [[ -f "${script}" ]] \
1255 && [[ "${script%.sh}" == "${script}" ]] \
1256 && dodoc "${script}"
1257 done
1258
1259 einfo
1260 elog "You might want to run:"
1261 elog "\"emerge --config =${CATEGORY}/${PF}\""
1262 elog "if this is a new install."
1263 einfo
1264
1265 einfo
1266 elog "If you are upgrading major versions, you should run the"
1267 elog "mysql_upgrade tool."
1268 einfo
1269 fi
1270
1271 if pbxt_available && use pbxt ; then
1272 # TODO: explain it better
1273 elog " mysql> INSTALL PLUGIN pbxt SONAME 'libpbxt.so';"
1274 elog " mysql> CREATE TABLE t1 (c1 int, c2 text) ENGINE=pbxt;"
1275 elog "if, after that, you cannot start the MySQL server,"
1276 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
1277 elog "use the MySQL upgrade script to restore the table"
1278 elog "or execute the following SQL command:"
1279 elog " CREATE TABLE IF NOT EXISTS plugin ("
1280 elog " name char(64) binary DEFAULT '' NOT NULL,"
1281 elog " dl char(128) DEFAULT '' NOT NULL,"
1282 elog " PRIMARY KEY (name)"
1283 elog " ) CHARACTER SET utf8 COLLATE utf8_bin;"
1284 fi
1285
1286 mysql_check_version_range "4.0 to 5.0.99.99" \
1287 && use berkdb \
1288 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
1289 }
1290
1291 # @FUNCTION: mysql_pkg_config
1292 # @DESCRIPTION:
1293 # Configure mysql environment.
1294 mysql_pkg_config() {
1295 local old_MY_DATADIR="${MY_DATADIR}"
1296
1297 # Make sure the vars are correctly initialized
1298 mysql_init_vars
1299
1300 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
1301
1302 if built_with_use ${CATEGORY}/${PN} minimal ; then
1303 die "Minimal builds do NOT include the MySQL server"
1304 fi
1305
1306 if [[ ( -n "${MY_DATADIR}" ) && ( "${MY_DATADIR}" != "${old_MY_DATADIR}" ) ]]; then
1307 local MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${MY_DATADIR})"
1308 local old_MY_DATADIR_s="$(strip_duplicate_slashes ${ROOT}/${old_MY_DATADIR})"
1309
1310 if [[ -d "${old_MY_DATADIR_s}" ]]; then
1311 if [[ -d "${MY_DATADIR_s}" ]]; then
1312 ewarn "Both ${old_MY_DATADIR_s} and ${MY_DATADIR_s} exist"
1313 ewarn "Attempting to use ${MY_DATADIR_s} and preserving ${old_MY_DATADIR_s}"
1314 else
1315 elog "Moving MY_DATADIR from ${old_MY_DATADIR_s} to ${MY_DATADIR_s}"
1316 mv --strip-trailing-slashes -T "${old_MY_DATADIR_s}" "${MY_DATADIR_s}" \
1317 || die "Moving MY_DATADIR failed"
1318 fi
1319 else
1320 ewarn "Previous MY_DATADIR (${old_MY_DATADIR_s}) does not exist"
1321 if [[ -d "${MY_DATADIR_s}" ]]; then
1322 ewarn "Attempting to use ${MY_DATADIR_s}"
1323 else
1324 eerror "New MY_DATADIR (${MY_DATADIR_s}) does not exist"
1325 die "Configuration Failed! Please reinstall ${CATEGORY}/${PN}"
1326 fi
1327 fi
1328 fi
1329
1330 local pwd1="a"
1331 local pwd2="b"
1332 local maxtry=15
1333
1334 if [ -z "${MYSQL_ROOT_PASSWORD}" -a -f "${EROOT}/root/.my.cnf" ]; then
1335 MYSQL_ROOT_PASSWORD="$(sed -n -e '/^password=/s,^password=,,gp' "${EROOT}/root/.my.cnf")"
1336 fi
1337
1338 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
1339 ewarn "You have already a MySQL database in place."
1340 ewarn "(${ROOT}/${MY_DATADIR}/*)"
1341 ewarn "Please rename or delete it if you wish to replace it."
1342 die "MySQL database already exists!"
1343 fi
1344
1345 # Bug #213475 - MySQL _will_ object strenously if your machine is named
1346 # localhost. Also causes weird failures.
1347 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
1348
1349 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
1350
1351 einfo "Please provide a password for the mysql 'root' user now, in the"
1352 einfo "MYSQL_ROOT_PASSWORD env var or through the /root/.my.cnf file."
1353 ewarn "Avoid [\"'\\_%] characters in the password"
1354 read -rsp " >" pwd1 ; echo
1355
1356 einfo "Retype the password"
1357 read -rsp " >" pwd2 ; echo
1358
1359 if [[ "x$pwd1" != "x$pwd2" ]] ; then
1360 die "Passwords are not the same"
1361 fi
1362 MYSQL_ROOT_PASSWORD="${pwd1}"
1363 unset pwd1 pwd2
1364 fi
1365
1366 local options=""
1367 local sqltmp="$(emktemp)"
1368
1369 local help_tables="${ROOT}${MY_SHAREDSTATEDIR}/fill_help_tables.sql"
1370 [[ -r "${help_tables}" ]] \
1371 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \
1372 || touch "${TMPDIR}/fill_help_tables.sql"
1373 help_tables="${TMPDIR}/fill_help_tables.sql"
1374
1375 pushd "${TMPDIR}" &>/dev/null
1376 "${EROOT}/usr/bin/mysql_install_db" >"${TMPDIR}"/mysql_install_db.log 2>&1
1377 if [ $? -ne 0 ]; then
1378 grep -B5 -A999 -i "ERROR" "${TMPDIR}"/mysql_install_db.log 1>&2
1379 die "Failed to run mysql_install_db. Please review /var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"
1380 fi
1381 popd &>/dev/null
1382 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
1383 || die "MySQL databases not installed"
1384 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
1385 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
1386
1387 # Figure out which options we need to disable to do the setup
1388 helpfile="${TMPDIR}/mysqld-help"
1389 ${EROOT}/usr/sbin/mysqld --verbose --help >"${helpfile}" 2>/dev/null
1390 for opt in grant-tables host-cache name-resolve networking slave-start bdb \
1391 federated innodb ssl log-bin relay-log slow-query-log external-locking \
1392 ndbcluster \
1393 ; do
1394 optexp="--(skip-)?${opt}" optfull="--skip-${opt}"
1395 egrep -sq -- "${optexp}" "${helpfile}" && options="${options} ${optfull}"
1396 done
1397 # But some options changed names
1398 egrep -sq external-locking "${helpfile}" && \
1399 options="${options/skip-locking/skip-external-locking}"
1400
1401 if mysql_version_is_at_least "4.1.3" ; then
1402 # Filling timezones, see
1403 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
1404 "${EROOT}/usr/bin/mysql_tzinfo_to_sql" "${EROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
1405
1406 if [[ -r "${help_tables}" ]] ; then
1407 cat "${help_tables}" >> "${sqltmp}"
1408 fi
1409 fi
1410
1411 einfo "Creating the mysql database and setting proper"
1412 einfo "permissions on it ..."
1413
1414 use prefix || options="${options} --user=mysql"
1415
1416 local socket="${EROOT}/var/run/mysqld/mysqld${RANDOM}.sock"
1417 local pidfile="${EROOT}/var/run/mysqld/mysqld${RANDOM}.pid"
1418 local mysqld="${EROOT}/usr/sbin/mysqld \
1419 ${options} \
1420 --user=mysql \
1421 --basedir=${EROOT}/usr \
1422 --datadir=${ROOT}/${MY_DATADIR} \
1423 --max_allowed_packet=8M \
1424 --net_buffer_length=16K \
1425 --default-storage-engine=MyISAM \
1426 --socket=${socket} \
1427 --pid-file=${pidfile}"
1428 #einfo "About to start mysqld: ${mysqld}"
1429 ebegin "Starting mysqld"
1430 ${mysqld} &
1431 rc=$?
1432 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
1433 maxtry=$((${maxtry}-1))
1434 echo -n "."
1435 sleep 1
1436 done
1437 eend $rc
1438
1439 if ! [[ -S "${socket}" ]]; then
1440 die "Completely failed to start up mysqld with: ${mysqld}"
1441 fi
1442
1443 ebegin "Setting root password"
1444 # Do this from memory, as we don't want clear text passwords in temp files
1445 local sql="UPDATE mysql.user SET Password = PASSWORD('${MYSQL_ROOT_PASSWORD}') WHERE USER='root'"
1446 "${EROOT}/usr/bin/mysql" \
1447 --socket=${socket} \
1448 -hlocalhost \
1449 -e "${sql}"
1450 eend $?
1451
1452 ebegin "Loading \"zoneinfo\", this step may require a few seconds ..."
1453 "${EROOT}/usr/bin/mysql" \
1454 --socket=${socket} \
1455 -hlocalhost \
1456 -uroot \
1457 -p"${MYSQL_ROOT_PASSWORD}" \
1458 mysql < "${sqltmp}"
1459 rc=$?
1460 eend $?
1461 [ $rc -ne 0 ] && ewarn "Failed to load zoneinfo!"
1462
1463 # Stop the server and cleanup
1464 einfo "Stopping the server ..."
1465 kill $(< "${pidfile}" )
1466 rm -f "${sqltmp}"
1467 wait %1
1468 einfo "Done"
1469 }
1470
1471 # @FUNCTION: mysql_pkg_postrm
1472 # @DESCRIPTION:
1473 # Remove mysql symlinks.
1474 mysql_pkg_postrm() {
1475 : # mysql_lib_symlinks "${ED}"
1476 }

  ViewVC Help
Powered by ViewVC 1.1.20