/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Contents of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.6 - (show annotations) (download)
Sat Jan 14 19:00:32 2006 UTC (8 years, 8 months ago) by vivo
Branch: MAIN
Changes since 1.5: +7 -6 lines
upgraded patch tarball, better management for client packages that will need to compile against mysql

1 # Copyright 1999-2005 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.5 2006/01/08 23:29:20 vivo Exp $
4
5 # Author: Francesco Riosa <vivo at gentoo.org>
6 # Maintainer: Francesco Riosa <vivo at gentoo.org>
7
8 inherit eutils flag-o-matic gnuconfig mysql_fx
9
10 #major, minor only in the slot
11 SLOT=$(( ${MYSQL_VERSION_ID} / 10000 ))
12
13 # shorten the path because the socket path length must be shorter than 107 chars
14 # and we will run a mysql server during test phase
15 S="${WORKDIR}/${PN}"
16
17 DESCRIPTION="A fast, multi-threaded, multi-user SQL database server"
18 HOMEPAGE="http://www.mysql.com/"
19 NEWP="${PN}-${PV/_/-}"
20 SRC_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/${NEWP}.tar.gz
21 mirror://gentoo/mysql-extras-20060114.tar.bz2"
22 LICENSE="GPL-2"
23 IUSE="big-tables berkdb debug minimal perl selinux ssl static"
24 RESTRICT="primaryuri"
25 DEPEND="app-admin/eselect-mysql"
26
27 mysql_version_is_at_least "4.01.03.00" \
28 && IUSE="${IUSE} cluster utf8 extraengine"
29
30 mysql_version_is_at_least "5.00.18.00" \
31 && IUSE="${IUSE} max-idx-128"
32
33 mysql_version_is_at_least "5.01.00.00" \
34 && IUSE="${IUSE} innodb"
35
36 EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_preinst pkg_postinst pkg_config pkg_postrm
37
38 mysql_pkg_setup() {
39
40 enewgroup mysql 60 || die "problem adding group mysql"
41 enewuser mysql 60 -1 /dev/null mysql \
42 || die "problem adding user mysql"
43 }
44
45 mysql_src_unpack() {
46
47 mysql_init_vars
48
49 if useq static && useq ssl; then
50 local msg="MySQL does not support building statically with SSL support"
51 eerror "${msg}"
52 die "${msg}"
53 fi
54
55 if mysql_version_is_at_least "4.01.03.00" \
56 && useq cluster \
57 || useq extraengine \
58 && useq minimal ; then
59 die "USEs cluster, extraengine conflicts with \"minimal\""
60 fi
61
62 unpack ${A} || die
63
64 mv -f "${WORKDIR}/${NEWP}" "${S}"
65 cd "${S}"
66
67 EPATCH_SUFFIX="patch"
68 mkdir -p "${EPATCH_SOURCE}" || die "unable to create epatch directory"
69 mysql_mv_patches
70 epatch || die "failed to apply all patches"
71
72 # additional check, remove bundled zlib
73 rm -f "${S}/zlib/"*.[ch]
74 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
75 rm -f scripts/mysqlbug
76
77 # Multilib issue with zlib detection
78 mysql_version_is_at_least "5.00.15.00" \
79 && sed -i -e "s:zlib_dir/lib:zlib_dir/$(get_libdir):g" \
80 "${S}/config/ac-macros/zlib.m4"
81
82 # Make charsets install in the right place
83 find . -name 'Makefile.am' \
84 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
85
86 # Manage mysqlmanager
87 mysql_version_is_at_least "5.00.15.00" \
88 && sed -i -e "s!@GENTOO_EXT@!${MY_SUFFIX}!g" \
89 -e "s!@GENTOO_SOCK_PATH@!var/run/mysqld!g" \
90 "${S}/server-tools/instance-manager/Makefile.am"
91
92 # remove what need to be recreated, so we are sure it's actually done
93 find . -name Makefile -o -name Makefile.in -o -name configure -exec rm -f {} \;
94 rm ltmain.sh
95
96 local rebuilddirlist d buildstep bdbdir
97
98 if mysql_version_is_at_least "5.01.00.00" ; then
99 rebuilddirlist=". storage/innobase"
100 bdbdir='storage/bdb/dist'
101 else
102 rebuilddirlist=". innobase"
103 bdbdir='bdb/dist'
104 fi
105
106 for d in ${rebuilddirlist}; do
107 einfo "reconfiguring dir \"${d}\""
108 pushd "${d}" &>/dev/null
109 for buildstep in \
110 'libtoolize --copy --force' \
111 'aclocal --force' \
112 'autoheader --force -Wnone' \
113 'autoconf --force -Wnone' \
114 'automake --force --force-missing -Wnone' \
115 'gnuconfig_update'
116 do
117 einfo "performing ${buildstep}"
118 ${buildstep} || die "failed ${buildstep/ */} dir \"${d}\""
119 done
120 popd &>/dev/null
121 done
122
123 if ! useq bdbdir && ! mysql_check_version_range "5.01.00.00 to 5.01.06.99"
124 then
125 [[ -w "${bdbdir}/ltmain.sh" ]] && cp -f ltmain.sh "${bdbdir}/ltmain.sh"
126 pushd "${bdbdir}" && sh s_all || die "failed bdb reconfigure" &>/dev/null
127 popd &>/dev/null
128 fi
129
130 }
131
132 mysql_src_compile() {
133
134 mysql_init_vars
135 local myconf
136
137 if useq static ; then
138 myconf="${myconf} --with-mysqld-ldflags=-all-static"
139 myconf="${myconf} --with-client-ldflags=-all-static"
140 myconf="${myconf} --disable-shared"
141 else
142 myconf="${myconf} --enable-shared --enable-static"
143 fi
144
145 #myconf="${myconf} `use_with tcpd libwrap`"
146 myconf="${myconf} --without-libwrap"
147
148 if useq ssl ; then
149 # --with-vio is not needed anymore, it's on by default and
150 # has been removed from configure
151 mysql_version_is_at_least "5.00.04.00" || myconf="${myconf} --with-vio"
152 if mysql_version_is_at_least "5.00.06.00" ; then
153 # yassl-0.96 is young break with gcc-4.0 || amd64
154 #myconf="${myconf} --with-yassl"
155 myconf="${myconf} --with-openssl"
156 else
157 myconf="${myconf} --with-openssl"
158 fi
159 else
160 myconf="${myconf} --without-openssl"
161 fi
162
163 if useq debug; then
164 myconf="${myconf} --with-debug=full"
165 else
166 myconf="${myconf} --without-debug"
167 mysql_version_is_at_least "4.01.03.00" && useq cluster && myconf="${myconf} --without-ndb-debug"
168 fi
169
170 # benchmarking stuff needs perl
171 # and shouldn't be bothered with on minimal builds
172 if useq perl && ! useq minimal; then
173 myconf="${myconf} --with-bench"
174 else
175 myconf="${myconf} --without-bench"
176 fi
177
178 # these are things we exclude from a minimal build
179 # note that the server actually does get built and installed
180 # but we then delete it before packaging.
181 local minimal_exclude_list="server embedded-server extra-tools innodb"
182 if ! useq minimal; then
183 for i in ${minimal_exclude_list}; do
184 myconf="${myconf} --with-${i}"
185 done
186
187 if useq static ; then
188 myconf="${myconf} --without-raid"
189 ewarn "disabling raid support, has problem with static"
190 else
191 myconf="${myconf} --with-raid"
192 fi
193
194 if ! mysql_version_is_at_least "5.00.00.00" ; then
195 if mysql_version_is_at_least "4.01.00.00" && useq utf8; then
196 myconf="${myconf} --with-charset=utf8"
197 myconf="${myconf} --with-collation=utf8_general_ci"
198 else
199 myconf="${myconf} --with-charset=latin1"
200 myconf="${myconf} --with-collation=latin1_swedish_ci"
201 fi
202 fi
203
204 # optional again from 2005-12-05
205 if mysql_version_is_at_least "5.01.00.00" ; then
206 myconf="${myconf} $(use_with innodb)"
207 else
208 myconf="${myconf} --with-innodb"
209 fi
210
211 # lots of chars
212 myconf="${myconf} --with-extra-charsets=all"
213
214 #The following fix is due to a bug with bdb on sparc's. See:
215 #http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
216 # it comes down to non-64-bit safety problems
217 if useq sparc || useq alpha || useq hppa || useq mips || useq amd64 \
218 || mysql_check_version_range "5.01.00.00 to 5.01.06.99"
219 then
220 ewarn "bdb berkeley-db disabled due to arch or version"
221 myconf="${myconf} --without-berkeley-db"
222 else
223 useq berkdb \
224 && myconf="${myconf} --with-berkeley-db=./bdb" \
225 || myconf="${myconf} --without-berkeley-db"
226 fi
227
228 if mysql_version_is_at_least "4.01.03.00" ; then
229 #myconf="${myconf} $(use_with geometry)"
230 myconf="${myconf} --with-geometry"
231 myconf="${myconf} $(use_with cluster ndbcluster)"
232 fi
233
234 mysql_version_is_at_least "4.01.11.00" && myconf="${myconf} `use_with big-tables`"
235 else
236 for i in ${minimal_exclude_list}; do
237 myconf="${myconf} --without-${i}"
238 done
239 myconf="${myconf} --without-berkeley-db"
240 myconf="${myconf} --with-extra-charsets=none"
241 fi
242
243 if mysql_version_is_at_least "4.01.03.00" && useq extraengine; then
244 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
245 myconf="${myconf} --with-archive-storage-engine"
246 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
247
248 mysql_version_is_at_least "4.01.04.00" \
249 && myconf="${myconf} --with-csv-storage-engine"
250
251 mysql_version_is_at_least "4.01.11.00" \
252 && myconf="${myconf} --with-blackhole-storage-engine"
253
254 # http://dev.mysql.com/doc/mysql/en/federated-description.html
255 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html
256 if mysql_version_is_at_least "5.00.03.00" ; then
257 einfo "before to use federated engine be sure to read"
258 einfo "http://dev.mysql.com/doc/refman/5.0/en/federated-limitations.html"
259 myconf="${myconf} --with-federated-storage-engine"
260
261 # http://dev.mysql.com/doc/refman/5.1/en/partitioning-overview.html
262 if mysql_version_is_at_least "5.01.00.00" ; then
263 myconf="${myconf} --with-partition"
264 fi
265 fi
266
267 mysql_version_is_at_least "5.00.18.00" \
268 && useq "max-idx-128" \
269 && myconf="${myconf} --with-max-indexes=128"
270 fi
271
272 #Bug #114895,Bug #110149
273 filter-flags "-O" "-O[01]"
274 #glibc-2.3.2_pre fix; bug #16496
275 append-flags "-DHAVE_ERRNO_AS_DEFINE=1"
276
277 #the compiler flags are as per their "official" spec ;)
278 #CFLAGS="${CFLAGS/-O?/} -O3" \
279 export CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-exceptions -fno-rtti"
280 mysql_version_is_at_least "5.00.00.00" \
281 && export CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
282
283 econf \
284 --program-suffix="${MY_SUFFIX}" \
285 --libexecdir="/usr/sbin" \
286 --sysconfdir="${MY_SYSCONFDIR}" \
287 --localstatedir="${MY_LOCALSTATEDIR}" \
288 --sharedstatedir="${MY_SHAREDSTATEDIR}" \
289 --libdir="${MY_LIBDIR}" \
290 --includedir="${MY_INCLUDEDIR}" \
291 --with-low-memory \
292 --enable-assembler \
293 --enable-local-infile \
294 --with-mysqld-user=mysql \
295 --with-client-ldflags=-lstdc++ \
296 --enable-thread-safe-client \
297 --with-comment="Gentoo Linux ${PF}" \
298 --with-unix-socket-path="/var/run/mysqld/mysqld${MY_SUFFIX}.sock" \
299 --with-zlib-dir=/usr \
300 --with-lib-ccflags="-fPIC" \
301 --without-readline \
302 --without-docs \
303 ${myconf} || die "bad ./configure"
304
305 # TODO Move this before autoreconf !!!
306 find . -name 'Makefile' \
307 -exec sed --in-place \
308 -e 's|^pkglibdir\s*=\s*$(libdir)/mysql|pkglibdir = $(libdir)|' \
309 -e 's|^pkgincludedir\s*=\s*$(includedir)/mysql|pkgincludedir = $(includedir)|' \
310 {} \;
311
312 emake || die "compile problem"
313 }
314
315 mysql_src_install() {
316
317 mysql_init_vars
318 make install DESTDIR="${D}" benchdir_root="${MY_SHAREDSTATEDIR}" || die
319
320 insinto "${MY_INCLUDEDIR}"
321 doins "${MY_INCLUDEDIR}"/my_{config,dir}.h
322
323 # convenience links
324 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqlanalyze${MY_SUFFIX}"
325 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqlrepair${MY_SUFFIX}"
326 dosym "/usr/bin/mysqlcheck${MY_SUFFIX}" "/usr/bin/mysqloptimize${MY_SUFFIX}"
327
328 # various junk (my-*.cnf moved elsewhere)
329 rm -rf "${D}/usr/share/info"
330 for removeme in "mysql-log-rotate" mysql.server* \
331 binary-configure* my-*.cnf mi_test_all*
332 do
333 rm -f ${D}/usr/share/mysql/${removeme}
334 done
335
336 # TODO change at Makefile-am level
337 for moveme in "mysql_fix_privilege_tables.sql" \
338 "fill_help_tables.sql" "ndb-config-2-node.ini"
339 do
340 mv -f "${D}/usr/share/mysql/${moveme}" "${D}/usr/share/mysql${MY_SUFFIX}/" 2>/dev/null
341 done
342
343 if [[ -n "${MY_SUFFIX}" ]] ; then
344 local notcatched=$(ls "${D}/usr/share/mysql"/*)
345 if [[ -n "${notcatched}" ]] ; then
346 ewarn "QA notice"
347 ewarn "${notcatched} files in /usr/share/mysql"
348 ewarn "bug mysql-herd to manage them"
349 fi
350 rm -rf "${D}/usr/share/mysql"
351 fi
352
353 # clean up stuff for a minimal build
354 # this is anything server-specific
355 if useq minimal; then
356 rm -rf ${D}${MY_SHAREDSTATEDIR}/{mysql-test,sql-bench}
357 rm -f ${D}/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
358 rm -f "${D}/usr/sbin/mysqld${MY_SUFFIX}"
359 rm -f ${D}${MY_LIBDIR}/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
360 fi
361
362 # config stuff
363 insinto "${MY_SYSCONFDIR}"
364 doins scripts/mysqlaccess.conf
365 newins "${FILESDIR}/my.cnf-4.1" my.cnf
366 insinto "/etc/conf.d"
367 newins "${FILESDIR}/mysql-slot.conf.d-r2" "mysql"
368 mysql_version_is_at_least "5.00.11.00" \
369 && newins "${FILESDIR}/mysqlmanager-slot.conf.d" "mysqlmanager"
370
371 local charset='utf8'
372 ! useq utf8 && local charset='latin1'
373 sed --in-place \
374 -e "s/@MY_SUFFIX@/${MY_SUFFIX}/" \
375 -e "s/@CHARSET@/${charset}/" \
376 "${D}/etc/mysql${MY_SUFFIX}/my.cnf"
377
378 # minimal builds don't have the server
379 if ! useq minimal; then
380 exeinto /etc/init.d
381 newexe "${FILESDIR}/mysql-slot.rc6-r2" "mysql"
382 [[ ${SLOT} -gt 0 ]] && dosym "/etc/init.d/mysql" "/etc/init.d/mysql${MY_SUFFIX}"
383
384 mysql_version_is_at_least "5.00.11.00" \
385 && newexe "${FILESDIR}/mysqlmanager-slot.rc6" "mysqlmanager"
386 insinto /etc/logrotate.d
387 # TODO
388 newins "${FILESDIR}/logrotate.mysql" "mysql${MY_SUFFIX}"
389
390 #empty dirs...
391 diropts "-m0750"
392 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
393 dodir "${DATADIR}"
394 keepdir "${DATADIR}"
395 chown -R mysql:mysql "${D}/${DATADIR}"
396 fi
397
398 diropts "-m0755"
399 for folder in "${MY_LOGDIR}" "/var/run/mysqld" ; do
400 dodir "${folder}"
401 keepdir "${folder}"
402 chown -R mysql:mysql "${D}/${folder}"
403 done
404 fi
405
406 # docs
407 dodoc README COPYING ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE
408 # minimal builds don't have the server
409 if ! useq minimal; then
410 docinto "support-files"
411 for script in \
412 support-files/my-*.cnf \
413 support-files/magic \
414 support-files/ndb-config-2-node.ini
415 do
416 dodoc "${script}"
417 done
418
419 docinto "scripts"
420 for script in scripts/mysql* ; do
421 [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
422 done
423 fi
424
425 # oops, temporary fix
426 mysql_check_version_range "5.00.16.00 to 5.00.18.99" \
427 && cp -f \
428 "${WORKDIR}/mysql-extras/fill_help_tables.sql-5.0" \
429 "${D}/usr/share/mysql${MY_SUFFIX}/fill_help_tables.sql"
430 }
431
432 mysql_pkg_preinst() {
433
434 enewgroup mysql 60 || die "problem adding group mysql"
435 enewuser mysql 60 -1 /dev/null mysql \
436 || die "problem adding user mysql"
437 }
438
439 mysql_pkg_postinst() {
440
441 mysql_init_vars
442 mysql_lib_symlinks
443
444 # mind at FEATURES=collision-protect before to remove this
445 [ -d "${ROOT}/var/log/mysql" ] \
446 || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
447
448 #secure the logfiles... does this bother anybody?
449 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
450 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
451 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
452
453 # create a list of files, to be used
454 # by external utilities
455 # uncompressed because of the small size
456 local filelist="${ROOT}/var/lib/eselect/mysql/mysql${MY_SUFFIX}"
457 pushd "${D}/" &>/dev/null
458 mkdir -p "${ROOT}/var/lib/eselect/mysql/"
459 env -i find usr/bin/ usr/sbin/ usr/share/man \
460 -type f -name "*${MY_SUFFIX}*" \
461 -and -not -name "mysql_config${MY_SUFFIX}" \
462 > "${filelist}.filelist"
463 echo "${MY_SYSCONFDIR#"/"}" >> "${filelist}.filelist"
464 echo "${MY_LIBDIR#"/"}" >> "${filelist}.filelist"
465 echo "${MY_SHAREDSTATEDIR#"/"}" >> "${filelist}.filelist"
466 popd &>/dev/null
467
468 if ! useq minimal; then
469 if [[ ${SLOT} -gt 0 ]] ; then
470 if [[ -f "${ROOT}/usr/sbin/mysqld" ]] ; then
471 einfo "you may want to run unmerge any unslotted MySQL versions with "
472 einfo "emerge -C --pretend dev-db/mysql"
473 einfo "emerge -C =dev-db/mysql-X.Y.Z"
474 einfo "After the unmerge run \"eselect myqsl list\" followed by a "
475 einfo "\"eselect myqsl set 1\" to chose the default mysql server"
476 else
477 local tmpres="$( eselect mysql show )"
478 # "like grep -q unset"
479 if [[ "{$tmpres}" == "{$tmpres/unset/}" ]] ; then
480 eselect mysql set 1
481 else
482 einfo "The version of mysql emerged now stils is _NOT_ the default"
483 einfo "you may want to run \"eselect myqsl list\" followed by a "
484 einfo "\"eselect myqsl set 1\" to chose the default mysql server"
485 fi
486 fi
487 fi
488
489 # your friendly public service announcement...
490 einfo
491 einfo "You might want to run:"
492 einfo "\"emerge --config =${CATEGORY}/${PF}\""
493 einfo "if this is a new install."
494 einfo
495 einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
496 fi
497 }
498
499 mysql_pkg_config() {
500 mysql_init_vars
501 [[ -z "${DATADIR}" ]] && die "sorry, unable to find DATADIR"
502
503 if built_with_use dev-db/mysql minimal; then
504 die "Minimal builds do NOT include the MySQL server"
505 fi
506
507 local pwd1="a"
508 local pwd2="b"
509 local maxtry=5
510
511 if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then
512 ewarn "You have already a MySQL database in place."
513 ewarn "(${ROOT}/${DATADIR}/*)"
514 ewarn "Please rename or delete it if you wish to replace it."
515 die "MySQL database already exists!"
516 fi
517
518 einfo "Creating the mysql database and setting proper"
519 einfo "permissions on it..."
520
521 einfo "Insert a password for the mysql 'root' user"
522 ewarn "Avoid [\"'\\_%] characters in the password"
523
524 read -rsp " >" pwd1 ; echo
525 einfo "Check the password"
526 read -rsp " >" pwd2 ; echo
527
528 if [[ "x$pwd1" != "x$pwd2" ]] ; then
529 die "Passwords are not the same"
530 fi
531
532 local options=""
533 local sqltmp="$(emktemp)"
534
535 local help_tables="${ROOT}/usr/share/doc/mysql-${PVR}/scripts/fill_help_tables.sql.gz"
536 [[ -r "${help_tables}" ]] \
537 && zcat "${help_tables}" > "${TMPDIR}/fill_help_tables.sql" \
538 || touch "${TMPDIR}/fill_help_tables.sql"
539 help_tables="${TMPDIR}/fill_help_tables.sql"
540
541 pushd "${TMPDIR}" &>/dev/null
542 ${ROOT}/usr/bin/mysql_install_db${MY_SUFFIX} | grep -B5 -A999 -i "ERROR"
543 popd &>/dev/null
544 [[ -f ${ROOT}/${DATADIR}/mysql/user.frm ]] || die "MySQL databases not installed"
545 chown -R mysql:mysql ${ROOT}/${DATADIR} 2> /dev/null
546 chmod 0750 ${ROOT}/${DATADIR} 2> /dev/null
547
548 if mysql_version_is_at_least "4.01.03.00" ; then
549 options="--skip-ndbcluster"
550
551 # Filling timezones, see
552 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
553 ${ROOT}/usr/bin/mysql_tzinfo_to_sql${MY_SUFFIX} ${ROOT}/usr/share/zoneinfo \
554 > "${sqltmp}" 2>/dev/null
555
556 if [[ -r "${help_tables}" ]] ; then
557 cat "${help_tables}" >> "${sqltmp}"
558 fi
559 fi
560
561 local socket=${ROOT}/var/run/mysqld/mysqld${MY_SUFFIX}${RANDOM}.sock
562 local pidfile=${ROOT}/var/run/mysqld/mysqld${MY_SUFFIX}${RANDOM}.sock
563 local mysqld="${ROOT}/usr/sbin/mysqld${MY_SUFFIX} \
564 ${options} \
565 --user=mysql \
566 --skip-grant-tables \
567 --basedir=${ROOT}/usr \
568 --datadir=${ROOT}/${DATADIR} \
569 --skip-innodb \
570 --skip-bdb \
571 --skip-networking \
572 --max_allowed_packet=8M \
573 --net_buffer_length=16K \
574 --socket=${socket} \
575 --pid-file=${pidfile}"
576 $mysqld &
577 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
578 maxtry=$(($maxtry-1))
579 echo -n "."
580 sleep 1
581 done
582
583 # do this from memory we don't want clear text password in temp files
584 local sql="UPDATE mysql.user SET Password = PASSWORD('${pwd1}') WHERE USER='root'"
585 ${ROOT}/usr/bin/mysql${MY_SUFFIX} \
586 --socket=${socket} \
587 -hlocalhost \
588 -e "${sql}"
589
590 einfo "Loading \"zoneinfo\" this step may require few seconds"
591
592 ${ROOT}/usr/bin/mysql${MY_SUFFIX} \
593 --socket=${socket} \
594 -hlocalhost \
595 -uroot \
596 -p"${pwd1}" \
597 mysql < "${sqltmp}"
598
599 # server stop and cleanup
600 kill $(< "${pidfile}" )
601 rm "${sqltmp}"
602 einfo "stopping the server,"
603 wait %1
604 einfo "done"
605 }
606
607 mysql_pkg_postrm() {
608 mysql_lib_symlinks
609 if [[ ${SLOT} -gt 0 ]] ; then
610 einfo "you may want to run \"eselect myqsl list\" followed by a "
611 einfo "\"eselect myqsl list\" to chose the default mysql server"
612 fi
613 }

  ViewVC Help
Powered by ViewVC 1.1.20