/[gentoo-x86]/eclass/mysql.eclass
Gentoo

Contents of /eclass/mysql.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.181 - (show annotations) (download)
Tue Jul 29 20:24:00 2014 UTC (7 weeks, 2 days ago) by robbat2
Branch: MAIN
CVS Tags: HEAD
Changes since 1.180: +5 -4 lines
Convert mysql eclasses to git-r3 eclass, so we can remove RESTRICT=userpriv for live copies of the patches.

1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/mysql.eclass,v 1.180 2014/07/29 17:59:21 robbat2 Exp $
4
5 # @ECLASS: mysql.eclass
6 # @MAINTAINER:
7 # MySQL Team <mysql-bugs@gentoo.org>
8 # Luca Longinotti <chtekk@gentoo.org>
9 # Robin H. Johnson <robbat2@gentoo.org>
10 # @AUTHOR:
11 # Francesco Riosa (Retired) <vivo@gentoo.org>
12 # @BLURB: This eclass provides most of the functions for mysql ebuilds
13 # @DESCRIPTION:
14 # The mysql.eclass provides almost all the code to build the mysql ebuilds
15 # including the src_unpack, src_prepare, src_configure, src_compile,
16 # scr_install, pkg_preinst, pkg_postinst, pkg_config and pkg_postrm
17 # phase hooks.
18
19 WANT_AUTOCONF="latest"
20 WANT_AUTOMAKE="latest"
21
22 inherit eutils flag-o-matic gnuconfig autotools multilib mysql_fx versionator toolchain-funcs
23
24 # Shorten the path because the socket path length must be shorter than 107 chars
25 # and we will run a mysql server during test phase
26 S="${WORKDIR}/mysql"
27
28 [[ "${MY_EXTRAS_VER}" == "latest" ]] && MY_EXTRAS_VER="20090228-0714Z"
29 if [[ "${MY_EXTRAS_VER}" == "live" ]]; then
30 EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
31 EGIT_CHECKOUT_DIR=${WORKDIR}/mysql-extras
32 EGIT_CLONE_TYPE=shallow
33 inherit git-r3
34 fi
35
36 case "${EAPI:-0}" in
37 2|3|4|5)
38 EXPORT_FUNCTIONS pkg_setup \
39 src_unpack src_prepare \
40 src_configure src_compile \
41 src_install \
42 pkg_preinst pkg_postinst \
43 pkg_config pkg_postrm
44 IUSE_DEFAULT_ON='+'
45 ;;
46 0 | 1)
47 EXPORT_FUNCTIONS pkg_setup \
48 src_unpack \
49 src_compile \
50 src_install \
51 pkg_preinst pkg_postinst \
52 pkg_config pkg_postrm
53 ;;
54 *)
55 die "Unsupported EAPI: ${EAPI}" ;;
56 esac
57
58
59 # @ECLASS-VARIABLE: MYSQL_PV_MAJOR
60 # @DESCRIPTION:
61 # Upstream MySQL considers the first two parts of the version number to be the
62 # major version. Upgrades that change major version should always run
63 # mysql_upgrade.
64 MYSQL_PV_MAJOR="$(get_version_component_range 1-2 ${PV})"
65
66 # Cluster is a special case...
67 if [[ "${PN}" == "mysql-cluster" ]]; then
68 case $PV in
69 6.1*|7.0*|7.1*) MYSQL_PV_MAJOR=5.1 ;;
70 esac
71 fi
72
73
74 # @ECLASS-VARIABLE: MYSQL_VERSION_ID
75 # @DESCRIPTION:
76 # MYSQL_VERSION_ID will be:
77 # major * 10e6 + minor * 10e4 + micro * 10e2 + gentoo revision number, all [0..99]
78 # This is an important part, because many of the choices the MySQL ebuild will do
79 # depend on this variable.
80 # In particular, the code below transforms a $PVR like "5.0.18-r3" in "5001803"
81 # We also strip off upstream's trailing letter that they use to respin tarballs
82
83 MYSQL_VERSION_ID=""
84 tpv="${PV%[a-z]}"
85 tpv=( ${tpv//[-._]/ } ) ; tpv[3]="${PVR:${#PV}}" ; tpv[3]="${tpv[3]##*-r}"
86 for vatom in 0 1 2 3 ; do
87 # pad to length 2
88 tpv[${vatom}]="00${tpv[${vatom}]}"
89 MYSQL_VERSION_ID="${MYSQL_VERSION_ID}${tpv[${vatom}]:0-2}"
90 done
91 # strip leading "0" (otherwise it's considered an octal number by BASH)
92 MYSQL_VERSION_ID=${MYSQL_VERSION_ID##"0"}
93
94 # @ECLASS-VARIABLE: MYSQL_COMMUNITY_FEATURES
95 # @DESCRIPTION:
96 # Specifiy if community features are available. Possible values are 1 (yes)
97 # and 0 (no).
98 # Community features are available in mysql-community
99 # AND in the re-merged mysql-5.0.82 and newer
100 if [ "${PN}" == "mysql-community" -o "${PN}" == "mariadb" ]; then
101 MYSQL_COMMUNITY_FEATURES=1
102 elif [ "${PV#5.0}" != "${PV}" ] && mysql_version_is_at_least "5.0.82"; then
103 MYSQL_COMMUNITY_FEATURES=1
104 elif [ "${PV#5.1}" != "${PV}" ] && mysql_version_is_at_least "5.1.28"; then
105 MYSQL_COMMUNITY_FEATURES=1
106 elif [ "${PV#5.4}" != "${PV}" ] ; then
107 MYSQL_COMMUNITY_FEATURES=1
108 elif [ "${PV#5.5}" != "${PV}" ] ; then
109 MYSQL_COMMUNITY_FEATURES=1
110 elif [ "${PV#6}" != "${PV}" ] ; then
111 MYSQL_COMMUNITY_FEATURES=1
112 elif [ "${PV#7}" != "${PV}" ] ; then
113 MYSQL_COMMUNITY_FEATURES=1
114 else
115 MYSQL_COMMUNITY_FEATURES=0
116 fi
117
118 # @ECLASS-VARIABLE: XTRADB_VER
119 # @DESCRIPTION:
120 # Version of the XTRADB storage engine
121 XTRADB_VER="${XTRADB_VER}"
122
123 # @ECLASS-VARIABLE: PERCONA_VER
124 # @DESCRIPTION:
125 # Designation by PERCONA for a MySQL version to apply an XTRADB release
126 PERCONA_VER="${PERCONA_VER}"
127
128 # Be warned, *DEPEND are version-dependant
129 # These are used for both runtime and compiletime
130 DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )
131 kernel_linux? ( sys-process/procps )
132 >=sys-apps/sed-4
133 >=sys-apps/texinfo-4.7-r1
134 >=sys-libs/readline-4.1
135 >=sys-libs/zlib-1.2.3"
136
137 [[ "${PN}" == "mariadb" ]] \
138 && DEPEND="${DEPEND} libevent? ( >=dev-libs/libevent-1.4 )"
139
140 # Having different flavours at the same time is not a good idea
141 for i in "mysql" "mysql-community" "mysql-cluster" "mariadb" ; do
142 [[ "${i}" == ${PN} ]] ||
143 DEPEND="${DEPEND} !dev-db/${i}"
144 done
145
146 # prefix: first need to implement something for #196294
147 RDEPEND="${DEPEND}
148 !minimal? ( !prefix? ( dev-db/mysql-init-scripts ) )
149 selinux? ( sec-policy/selinux-mysql )"
150
151 DEPEND="${DEPEND}
152 virtual/yacc"
153
154 if [ "${EAPI:-0}" = "2" ]; then
155 DEPEND="${DEPEND} static? ( sys-libs/ncurses[static-libs] )"
156 fi
157
158 # compile-time-only
159 mysql_version_is_at_least "5.1" \
160 || DEPEND="${DEPEND} berkdb? ( sys-apps/ed )"
161
162 # compile-time-only
163 mysql_version_is_at_least "5.1.12" \
164 && DEPEND="${DEPEND} >=dev-util/cmake-2.4.3"
165
166 [[ "${PN}" == "mariadb" ]] \
167 && mysql_version_is_at_least "5.2" \
168 && DEPEND="${DEPEND} oqgraph? ( >=dev-libs/boost-1.40.0 )"
169 #SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
170 # sphinx? ( app-misc/sphinx )"
171
172 # dev-perl/DBD-mysql is needed by some scripts installed by MySQL
173 PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
174
175 # For other stuff to bring us in
176 PDEPEND="${PDEPEND} =virtual/mysql-${MYSQL_PV_MAJOR}"
177
178 # Work out the default SERVER_URI correctly
179 if [ -z "${SERVER_URI}" ]; then
180 [ -z "${MY_PV}" ] && MY_PV="${PV//_/-}"
181 if [ "${PN}" == "mariadb" ]; then
182 MARIA_FULL_PV="$(replace_version_separator 3 '-' ${PV})"
183 MARIA_FULL_P="${PN}-${MARIA_FULL_PV}"
184 SERVER_URI="
185 http://ftp.osuosl.org/pub/mariadb/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
186 http://ftp.rediris.es/mirror/MariaDB/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
187 http://maria.llarian.net/download/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
188 http://launchpad.net/maria/${MYSQL_PV_MAJOR}/ongoing/+download/${MARIA_FULL_P}.tar.gz
189 http://mirrors.fe.up.pt/pub/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
190 http://ftp-stud.hs-esslingen.de/pub/Mirrors/${PN}/${MARIA_FULL_P}/kvm-tarbake-jaunty-x86/${MARIA_FULL_P}.tar.gz
191 "
192 # The community and cluster builds are on the mirrors
193 elif [[ "${MYSQL_COMMUNITY_FEATURES}" == "1" || ${PN} == "mysql-cluster" ]] ; then
194 if [[ "${PN}" == "mysql-cluster" ]] ; then
195 URI_DIR="MySQL-Cluster"
196 URI_FILE="mysql-cluster-gpl"
197 else
198 URI_DIR="MySQL"
199 URI_FILE="mysql"
200 fi
201 URI_A="${URI_FILE}-${MY_PV}.tar.gz"
202 MIRROR_PV=$(get_version_component_range 1-2 ${PV})
203 # Recently upstream switched to an archive site, and not on mirrors
204 SERVER_URI="http://downloads.mysql.com/archives/${URI_FILE}-${MIRROR_PV}/${URI_A}
205 mirror://mysql/Downloads/${URI_DIR}-${PV%.*}/${URI_A}"
206 # The (old) enterprise source is on the primary site only
207 elif [ "${PN}" == "mysql" ]; then
208 SERVER_URI="ftp://ftp.mysql.com/pub/mysql/src/mysql-${MY_PV}.tar.gz"
209 fi
210 fi
211
212 # Define correct SRC_URIs
213 SRC_URI="${SERVER_URI}"
214
215 # Gentoo patches to MySQL
216 [[ ${MY_EXTRAS_VER} != live ]] \
217 && SRC_URI="${SRC_URI}
218 mirror://gentoo/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
219 http://g3nt8.org/patches/mysql-extras-${MY_EXTRAS_VER}.tar.bz2
220 http://dev.gentoo.org/~robbat2/distfiles/mysql-extras-${MY_EXTRAS_VER}.tar.bz2"
221
222 DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
223 HOMEPAGE="http://www.mysql.com/"
224 if [[ "${PN}" == "mariadb" ]]; then
225 HOMEPAGE="http://askmonty.org/"
226 DESCRIPTION="MariaDB is a MySQL fork with 3rd-party patches and additional storage engines merged."
227 fi
228 if [[ "${PN}" == "mysql-community" ]]; then
229 DESCRIPTION="${DESCRIPTION} (obsolete, move to dev-db/mysql)"
230 fi
231 LICENSE="GPL-2"
232 SLOT="0"
233 IUSE="big-tables debug embedded minimal ${IUSE_DEFAULT_ON}perl selinux ssl static test"
234
235 mysql_version_is_at_least "4.1" \
236 && IUSE="${IUSE} latin1"
237
238 if mysql_version_is_at_least "4.1.3" ; then
239 IUSE="${IUSE} extraengine"
240 if [[ "${PN}" != "mysql-cluster" ]] ; then
241 IUSE="${IUSE} cluster"
242 fi
243 fi
244
245 mysql_version_is_at_least "5.0" \
246 || IUSE="${IUSE} raid"
247
248 mysql_version_is_at_least "5.0.18" \
249 && IUSE="${IUSE} max-idx-128"
250
251 mysql_version_is_at_least "5.1" \
252 || IUSE="${IUSE} berkdb"
253
254 [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ] \
255 && IUSE="${IUSE} ${IUSE_DEFAULT_ON}community profiling"
256
257 [[ "${PN}" == "mariadb" ]] \
258 && IUSE="${IUSE} libevent"
259
260 [[ "${PN}" == "mariadb" ]] \
261 && mysql_version_is_at_least "5.2" \
262 && IUSE="${IUSE} oqgraph"
263 #SphinxSE is included but is not available in 5.2.4 due to a missing plug.in file
264 #&& IUSE="${IUSE} oqgraph sphinx"
265
266 # MariaDB has integrated PBXT
267 # PBXT_VERSION means that we have a PBXT patch for this PV
268 # PBXT was only introduced after 5.1.12
269 pbxt_patch_available() {
270 [[ "${PN}" != "mariadb" ]] \
271 && mysql_version_is_at_least "5.1.12" \
272 && [[ -n "${PBXT_VERSION}" ]]
273 return $?
274 }
275
276 pbxt_available() {
277 pbxt_patch_available || [[ "${PN}" == "mariadb" ]]
278 return $?
279 }
280
281 # Get the percona tarball if XTRADB_VER and PERCONA_VER are both set
282 # MariaDB has integrated XtraDB
283 # XTRADB_VERS means that we have a XTRADB patch for this PV
284 # XTRADB was only introduced after 5.1.26
285 xtradb_patch_available() {
286 [[ "${PN}" != "mariadb" ]] \
287 && mysql_version_is_at_least "5.1.26" \
288 && [[ -n "${XTRADB_VER}" && -n "${PERCONA_VER}" ]]
289 return $?
290 }
291
292
293 pbxt_patch_available \
294 && PBXT_P="pbxt-${PBXT_VERSION}" \
295 && PBXT_SRC_URI="http://www.primebase.org/download/${PBXT_P}.tar.gz mirror://sourceforge/pbxt/${PBXT_P}.tar.gz" \
296 && SRC_URI="${SRC_URI} pbxt? ( ${PBXT_SRC_URI} )" \
297
298 # PBXT_NEWSTYLE means pbxt is in storage/ and gets enabled as other plugins
299 # vs. built outside the dir
300 pbxt_available \
301 && IUSE="${IUSE} pbxt" \
302 && mysql_version_is_at_least "5.1.40" \
303 && PBXT_NEWSTYLE=1
304
305 xtradb_patch_available \
306 && XTRADB_P="percona-xtradb-${XTRADB_VER}" \
307 && XTRADB_SRC_URI_COMMON="${PERCONA_VER}/source/${XTRADB_P}.tar.gz" \
308 && XTRADB_SRC_B1="http://www.percona.com/" \
309 && XTRADB_SRC_B2="${XTRADB_SRC_B1}/percona-builds/" \
310 && XTRADB_SRC_URI1="${XTRADB_SRC_B2}/Percona-Server/Percona-Server-${XTRADB_SRC_URI_COMMON}" \
311 && XTRADB_SRC_URI2="${XTRADB_SRC_B2}/xtradb/${XTRADB_SRC_URI_COMMON}" \
312 && XTRADB_SRC_URI3="${XTRADB_SRC_B1}/${PN}/xtradb/${XTRADB_SRC_URI_COMMON}" \
313 && SRC_URI="${SRC_URI} xtradb? ( ${XTRADB_SRC_URI1} ${XTRADB_SRC_URI2} ${XTRADB_SRC_URI3} )" \
314 && IUSE="${IUSE} xtradb"
315
316 #
317 # HELPER FUNCTIONS:
318 #
319
320 # @FUNCTION: mysql_disable_test
321 # @DESCRIPTION:
322 # Helper function to disable specific tests.
323 mysql_disable_test() {
324 local rawtestname testname testsuite reason mysql_disable_file
325 rawtestname="${1}" ; shift
326 reason="${@}"
327 ewarn "test '${rawtestname}' disabled: '${reason}'"
328
329 testsuite="${rawtestname/.*}"
330 testname="${rawtestname/*.}"
331 mysql_disable_file="${S}/mysql-test/t/disabled.def"
332 #einfo "rawtestname=${rawtestname} testname=${testname} testsuite=${testsuite}"
333 echo ${testname} : ${reason} >> "${mysql_disable_file}"
334
335 # ${S}/mysql-tests/t/disabled.def
336 #
337 # ${S}/mysql-tests/suite/federated/disabled.def
338 #
339 # ${S}/mysql-tests/suite/jp/t/disabled.def
340 # ${S}/mysql-tests/suite/ndb/t/disabled.def
341 # ${S}/mysql-tests/suite/rpl/t/disabled.def
342 # ${S}/mysql-tests/suite/parts/t/disabled.def
343 # ${S}/mysql-tests/suite/rpl_ndb/t/disabled.def
344 # ${S}/mysql-tests/suite/ndb_team/t/disabled.def
345 # ${S}/mysql-tests/suite/binlog/t/disabled.def
346 # ${S}/mysql-tests/suite/innodb/t/disabled.def
347 if [ -n "${testsuite}" ]; then
348 for mysql_disable_file in \
349 ${S}/mysql-test/suite/${testsuite}/disabled.def \
350 ${S}/mysql-test/suite/${testsuite}/t/disabled.def \
351 FAILED ; do
352 [ -f "${mysql_disable_file}" ] && break
353 done
354 if [ "${mysql_disabled_file}" != "FAILED" ]; then
355 echo "${testname} : ${reason}" >> "${mysql_disable_file}"
356 else
357 ewarn "Could not find testsuite disabled.def location for ${rawtestname}"
358 fi
359 fi
360 }
361
362 # @FUNCTION: mysql_init_vars
363 # @DESCRIPTION:
364 # void mysql_init_vars()
365 # Initialize global variables
366 # 2005-11-19 <vivo@gentoo.org>
367 mysql_init_vars() {
368 MY_SHAREDSTATEDIR=${MY_SHAREDSTATEDIR="${EPREFIX}/usr/share/mysql"}
369 MY_SYSCONFDIR=${MY_SYSCONFDIR="${EPREFIX}/etc/mysql"}
370 MY_LIBDIR=${MY_LIBDIR="${EPREFIX}/usr/$(get_libdir)/mysql"}
371 MY_LOCALSTATEDIR=${MY_LOCALSTATEDIR="${EPREFIX}/var/lib/mysql"}
372 MY_LOGDIR=${MY_LOGDIR="${EPREFIX}/var/log/mysql"}
373 MY_INCLUDEDIR=${MY_INCLUDEDIR="${EPREFIX}/usr/include/mysql"}
374
375 if [[ -z "${MY_DATADIR}" ]] ; then
376 MY_DATADIR=""
377 if [[ -f ${MY_SYSCONFDIR}/my.cnf ]] ; then
378 MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
379 | sed -ne '/datadir/s|^--datadir=||p' \
380 | tail -n1`
381 if [[ -z "${MY_DATADIR}" ]] ; then
382 MY_DATADIR=`grep ^datadir ${MY_SYSCONFDIR}/my.cnf \
383 | sed -e 's/.*=\s*//' \
384 | tail -n1`
385 fi
386 fi
387 if [[ -z "${MY_DATADIR}" ]] ; then
388 MY_DATADIR="${MY_LOCALSTATEDIR}"
389 einfo "Using default MY_DATADIR"
390 fi
391 elog "MySQL MY_DATADIR is ${MY_DATADIR}"
392
393 if [[ -z "${PREVIOUS_DATADIR}" ]] ; then
394 if [[ -e "${MY_DATADIR}" ]] ; then
395 # If you get this and you're wondering about it, see bug #207636
396 elog "MySQL datadir found in ${MY_DATADIR}"
397 elog "A new one will not be created."
398 PREVIOUS_DATADIR="yes"
399 else
400 PREVIOUS_DATADIR="no"
401 fi
402 export PREVIOUS_DATADIR
403 fi
404 else
405 if [[ ${EBUILD_PHASE} == "config" ]]; then
406 local new_MY_DATADIR
407 new_MY_DATADIR=`"my_print_defaults" mysqld 2>/dev/null \
408 | sed -ne '/datadir/s|^--datadir=||p' \
409 | tail -n1`
410
411 if [[ ( -n "${new_MY_DATADIR}" ) && ( "${new_MY_DATADIR}" != "${MY_DATADIR}" ) ]]; then
412 ewarn "MySQL MY_DATADIR has changed"
413 ewarn "from ${MY_DATADIR}"
414 ewarn "to ${new_MY_DATADIR}"
415 MY_DATADIR="${new_MY_DATADIR}"
416 fi
417 fi
418 fi
419
420 if [ "${MY_SOURCEDIR:-unset}" == "unset" ]; then
421 MY_SOURCEDIR=${SERVER_URI##*/}
422 MY_SOURCEDIR=${MY_SOURCEDIR%.tar*}
423 fi
424
425 export MY_SHAREDSTATEDIR MY_SYSCONFDIR
426 export MY_LIBDIR MY_LOCALSTATEDIR MY_LOGDIR
427 export MY_INCLUDEDIR MY_DATADIR MY_SOURCEDIR
428 }
429
430 configure_minimal() {
431 # These are things we exclude from a minimal build, please
432 # note that the server actually does get built and installed,
433 # but we then delete it before packaging.
434 local minimal_exclude_list="server embedded-server extra-tools innodb bench berkeley-db row-based-replication readline"
435
436 for i in ${minimal_exclude_list} ; do
437 myconf="${myconf} --without-${i}"
438 done
439 myconf="${myconf} --with-extra-charsets=none"
440 myconf="${myconf} --enable-local-infile"
441
442 if use static ; then
443 myconf="${myconf} --with-client-ldflags=-all-static"
444 myconf="${myconf} --disable-shared --with-pic"
445 else
446 myconf="${myconf} --enable-shared --enable-static"
447 fi
448
449 if mysql_version_is_at_least "4.1" && ! use latin1 ; then
450 myconf="${myconf} --with-charset=utf8"
451 myconf="${myconf} --with-collation=utf8_general_ci"
452 else
453 myconf="${myconf} --with-charset=latin1"
454 myconf="${myconf} --with-collation=latin1_swedish_ci"
455 fi
456 }
457
458 configure_common() {
459 myconf="${myconf} $(use_with big-tables)"
460 myconf="${myconf} --enable-local-infile"
461 myconf="${myconf} --with-extra-charsets=all"
462 use prefix || myconf="${myconf} --with-mysqld-user=mysql"
463 myconf="${myconf} --with-server"
464 myconf="${myconf} --with-unix-socket-path=${EPREFIX}/var/run/mysqld/mysqld.sock"
465 myconf="${myconf} --without-libwrap"
466
467 if use static ; then
468 myconf="${myconf} --with-mysqld-ldflags=-all-static"
469 myconf="${myconf} --with-client-ldflags=-all-static"
470 myconf="${myconf} --disable-shared --with-pic"
471 else
472 myconf="${myconf} --enable-shared --enable-static"
473 fi
474
475 if use debug ; then
476 myconf="${myconf} --with-debug=full"
477 else
478 myconf="${myconf} --without-debug"
479 mysql_version_is_at_least "4.1.3" \
480 && ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) \
481 && myconf="${myconf} --without-ndb-debug"
482 fi
483
484 if [ -n "${MYSQL_DEFAULT_CHARSET}" -a -n "${MYSQL_DEFAULT_COLLATION}" ]; then
485 ewarn "You are using a custom charset of ${MYSQL_DEFAULT_CHARSET}"
486 ewarn "and a collation of ${MYSQL_DEFAULT_COLLATION}."
487 ewarn "You MUST file bugs without these variables set."
488 myconf="${myconf} --with-charset=${MYSQL_DEFAULT_CHARSET}"
489 myconf="${myconf} --with-collation=${MYSQL_DEFAULT_COLLATION}"
490 elif mysql_version_is_at_least "4.1" && ! use latin1 ; then
491 myconf="${myconf} --with-charset=utf8"
492 myconf="${myconf} --with-collation=utf8_general_ci"
493 else
494 myconf="${myconf} --with-charset=latin1"
495 myconf="${myconf} --with-collation=latin1_swedish_ci"
496 fi
497
498 if use embedded ; then
499 myconf="${myconf} --with-embedded-privilege-control"
500 myconf="${myconf} --with-embedded-server"
501 else
502 myconf="${myconf} --without-embedded-privilege-control"
503 myconf="${myconf} --without-embedded-server"
504 fi
505
506 }
507
508 configure_40_41_50() {
509 myconf="${myconf} --with-zlib-dir=${EPREFIX}/usr"
510 myconf="${myconf} $(use_with perl bench)"
511 myconf="${myconf} --enable-assembler"
512 myconf="${myconf} --with-extra-tools"
513 myconf="${myconf} --with-innodb"
514 myconf="${myconf} --without-readline"
515 myconf="${myconf} $(use_with ssl openssl "${EPREFIX}/usr")"
516 mysql_version_is_at_least "5.0" || myconf="${myconf} $(use_with raid)"
517
518 # --with-vio is not needed anymore, it's on by default and
519 # has been removed from configure
520 # Apply to 4.x and 5.0.[0-3]
521 if use ssl ; then
522 mysql_version_is_at_least "5.0.4" || myconf="${myconf} --with-vio"
523 fi
524
525 if mysql_version_is_at_least "5.0.60" ; then
526 if use berkdb ; then
527 elog "Berkeley DB support was disabled due to build failures"
528 elog "on multiple arches, go to a version earlier than 5.0.60"
529 elog "if you want it again. Gentoo bug #224067."
530 fi
531 myconf="${myconf} --without-berkeley-db"
532 elif use berkdb ; then
533 # The following fix is due to a bug with bdb on SPARC's. See:
534 # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
535 # It comes down to non-64-bit safety problems.
536 if use alpha || use amd64 || use hppa || use mips || use sparc ; then
537 elog "Berkeley DB support was disabled due to compatibility issues on this arch"
538 myconf="${myconf} --without-berkeley-db"
539 else
540 myconf="${myconf} --with-berkeley-db=./bdb"
541 fi
542 else
543 myconf="${myconf} --without-berkeley-db"
544 fi
545
546 if mysql_version_is_at_least "4.1.3" ; then
547 myconf="${myconf} --with-geometry"
548 if [[ "${PN}" != "mysql-cluster" ]] ; then
549 myconf="${myconf} $(use_with cluster ndbcluster)"
550 fi
551 fi
552
553 if mysql_version_is_at_least "4.1.3" && use extraengine ; then
554 # http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
555 myconf="${myconf} --with-archive-storage-engine"
556
557 # http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
558 myconf="${myconf} --with-csv-storage-engine"
559
560 # http://dev.mysql.com/doc/mysql/en/blackhole-storage-engine.html
561 myconf="${myconf} --with-blackhole-storage-engine"
562
563 # http://dev.mysql.com/doc/mysql/en/federated-storage-engine.html
564 # http://dev.mysql.com/doc/mysql/en/federated-description.html
565 # http://dev.mysql.com/doc/mysql/en/federated-limitations.html
566 if mysql_version_is_at_least "5.0.3" ; then
567 elog "Before using the Federated storage engine, please be sure to read"
568 elog "http://dev.mysql.com/doc/mysql/en/federated-limitations.html"
569 myconf="${myconf} --with-federated-storage-engine"
570 fi
571 fi
572
573 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
574 myconf="${myconf} `use_enable community community-features`"
575 if use community; then
576 myconf="${myconf} `use_enable profiling`"
577 else
578 myconf="${myconf} --disable-profiling"
579 fi
580 fi
581
582 mysql_version_is_at_least "5.0.18" \
583 && use max-idx-128 \
584 && myconf="${myconf} --with-max-indexes=128"
585 }
586
587 configure_51() {
588 # TODO: !!!! readd --without-readline
589 # the failure depend upon config/ac-macros/readline.m4 checking into
590 # readline.h instead of history.h
591 myconf="${myconf} $(use_with ssl ssl "${EPREFIX}"/usr)"
592 myconf="${myconf} --enable-assembler"
593 myconf="${myconf} --with-geometry"
594 myconf="${myconf} --with-readline"
595 myconf="${myconf} --with-zlib-dir=${EPREFIX}/usr/"
596 myconf="${myconf} --without-pstack"
597 myconf="${myconf} --with-plugindir=${EPREFIX}/usr/$(get_libdir)/mysql/plugin"
598
599 # This is an explict die here, because if we just forcibly disable it, then the
600 # user's data is not accessible.
601 use max-idx-128 && die "Bug #336027: upstream has a corruption issue with max-idx-128 presently"
602 #use max-idx-128 && myconf="${myconf} --with-max-indexes=128"
603 if [ "${MYSQL_COMMUNITY_FEATURES}" == "1" ]; then
604 myconf="${myconf} $(use_enable community community-features)"
605 if use community; then
606 myconf="${myconf} $(use_enable profiling)"
607 else
608 myconf="${myconf} --disable-profiling"
609 fi
610 fi
611
612 # Scan for all available plugins
613 local plugins_avail="$(
614 LANG=C \
615 find "${S}" \
616 \( \
617 -name 'plug.in' \
618 -o -iname 'configure.in' \
619 -o -iname 'configure.ac' \
620 \) \
621 -print0 \
622 | xargs -0 sed -r -n \
623 -e '/^MYSQL_STORAGE_ENGINE/{
624 s~MYSQL_STORAGE_ENGINE\([[:space:]]*\[?([-_a-z0-9]+)\]?.*,~\1 ~g ;
625 s~^([^ ]+).*~\1~gp;
626 }' \
627 | tr -s '\n' ' '
628 )"
629
630 # 5.1 introduces a new way to manage storage engines (plugins)
631 # like configuration=none
632 # This base set are required, and will always be statically built.
633 local plugins_sta="csv myisam myisammrg heap"
634 local plugins_dyn=""
635 local plugins_dis="example ibmdb2i"
636
637 # These aren't actually required by the base set, but are really useful:
638 plugins_sta="${plugins_sta} archive blackhole"
639
640 # default in 5.5.4
641 if mysql_version_is_at_least "5.5.4" ; then
642 plugins_sta="${plugins_sta} partition"
643 fi
644 # Now the extras
645 if use extraengine ; then
646 # like configuration=max-no-ndb, archive and example removed in 5.1.11
647 # not added yet: ibmdb2i
648 # Not supporting as examples: example,daemon_example,ftexample
649 plugins_sta="${plugins_sta} partition"
650
651 if [[ "${PN}" != "mariadb" ]] ; then
652 elog "Before using the Federated storage engine, please be sure to read"
653 elog "http://dev.mysql.com/doc/refman/5.1/en/federated-limitations.html"
654 plugins_dyn="${plugins_sta} federated"
655 else
656 elog "MariaDB includes the FederatedX engine. Be sure to read"
657 elog "http://askmonty.org/wiki/index.php/Manual:FederatedX_storage_engine"
658 plugins_dyn="${plugins_sta} federatedx"
659 fi
660 else
661 plugins_dis="${plugins_dis} partition federated"
662 fi
663
664 # Upstream specifically requests that InnoDB always be built:
665 # - innobase, innodb_plugin
666 # Build falcon if available for 6.x series.
667 for i in innobase falcon ; do
668 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
669 done
670 for i in innodb_plugin ; do
671 [ -e "${S}"/storage/${i} ] && plugins_dyn="${plugins_dyn} ${i}"
672 done
673
674 # like configuration=max-no-ndb
675 if ( use cluster || [[ "${PN}" == "mysql-cluster" ]] ) ; then
676 plugins_sta="${plugins_sta} ndbcluster partition"
677 plugins_dis="${plugins_dis//partition}"
678 myconf="${myconf} --with-ndb-binlog"
679 else
680 plugins_dis="${plugins_dis} ndbcluster"
681 fi
682
683 if [[ "${PN}" == "mariadb" ]] ; then
684 # In MariaDB, InnoDB is packaged in the xtradb directory, so it's not
685 # caught above.
686 # This is not optional, without it several upstream testcases fail.
687 # Also strongly recommended by upstream.
688 if [[ "${PV}" < "5.2.0" ]] ; then
689 myconf="${myconf} --with-maria-tmp-tables"
690 plugins_sta="${plugins_sta} maria"
691 else
692 myconf="${myconf} --with-aria-tmp-tables"
693 plugins_sta="${plugins_sta} aria"
694 fi
695
696 [ -e "${S}"/storage/innobase ] || [ -e "${S}"/storage/xtradb ] ||
697 die "The ${P} package doesn't provide innobase nor xtradb"
698
699 for i in innobase xtradb ; do
700 [ -e "${S}"/storage/${i} ] && plugins_sta="${plugins_sta} ${i}"
701 done
702
703 myconf="${myconf} $(use_with libevent)"
704
705 if mysql_version_is_at_least "5.2" ; then
706 #This should include sphinx, but the 5.2.4 archive forgot the plug.in file
707 #for i in oqgraph sphinx ; do
708 for i in oqgraph ; do
709 use ${i} \
710 && plugins_dyn="${plugins_dyn} ${i}" \
711 || plugins_dis="${plugins_dis} ${i}"
712 done
713 fi
714 fi
715
716 if pbxt_available && [[ "${PBXT_NEWSTYLE}" == "1" ]]; then
717 use pbxt \
718 && plugins_sta="${plugins_sta} pbxt" \
719 || plugins_dis="${plugins_dis} pbxt"
720 fi
721
722 use static && \
723 plugins_sta="${plugins_sta} ${plugins_dyn}" && \
724 plugins_dyn=""
725
726 einfo "Available plugins: ${plugins_avail}"
727 einfo "Dynamic plugins: ${plugins_dyn}"
728 einfo "Static plugins: ${plugins_sta}"
729 einfo "Disabled plugins: ${plugins_dis}"
730
731 # These are the static plugins
732 myconf="${myconf} --with-plugins=${plugins_sta// /,}"
733 # And the disabled ones
734 for i in ${plugins_dis} ; do
735 myconf="${myconf} --without-plugin-${i}"
736 done
737 }
738
739 pbxt_src_configure() {
740 mysql_init_vars
741
742 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
743
744 einfo "Reconfiguring dir '${PWD}'"
745 eautoreconf
746
747 local myconf=""
748 myconf="${myconf} --with-mysql=${S} --libdir=${EPREFIX}/usr/$(get_libdir)"
749 use debug && myconf="${myconf} --with-debug=full"
750 econf ${myconf} || die "Problem configuring PBXT storage engine"
751 }
752
753 pbxt_src_compile() {
754
755 # Be backwards compatible for now
756 if [[ $EAPI != 2 ]]; then
757 pbxt_src_configure
758 fi
759 # TODO: is it safe/needed to use emake here ?
760 make || die "Problem making PBXT storage engine (${myconf})"
761
762 popd
763 # TODO: modify test suite for PBXT
764 }
765
766 pbxt_src_install() {
767 pushd "${WORKDIR}/pbxt-${PBXT_VERSION}" &>/dev/null
768 emake install DESTDIR="${D}" || die "Failed to install PBXT"
769 popd
770 }
771
772 #
773 # EBUILD FUNCTIONS
774 #
775 # @FUNCTION: mysql_pkg_setup
776 # @DESCRIPTION:
777 # Perform some basic tests and tasks during pkg_setup phase:
778 # die if FEATURES="test", USE="-minimal" and not using FEATURES="userpriv"
779 # check for conflicting use flags
780 # create new user and group for mysql
781 # warn about deprecated features
782 mysql_pkg_setup() {
783 if has test ${FEATURES} ; then
784 if ! use minimal ; then
785 if [[ $UID -eq 0 ]]; then
786 eerror "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
787 fi
788 fi
789 fi
790
791 # bug 350844
792 case "${EAPI:-0}" in
793 0 | 1)
794 if use static && ! built_with_use sys-libs/ncurses static-libs; then
795 die "To build MySQL statically you need to enable static-libs for sys-libs/ncurses"
796 fi
797 ;;
798 esac
799
800 # Check for USE flag problems in pkg_setup
801 if use static && use ssl ; then
802 M="MySQL does not support being built statically with SSL support enabled!"
803 eerror "${M}"
804 die "${M}"
805 fi
806
807 if mysql_version_is_at_least "5.1.51" \
808 && ! mysql_version_is_at_least "5.2" \
809 && use debug ; then
810 # Also in package.use.mask
811 die "Bug #344885: Upstream has broken USE=debug for 5.1 series >=5.1.51"
812 fi
813
814 if ! mysql_version_is_at_least "5.0" \
815 && use raid \
816 && use static ; then
817 eerror "USE flags 'raid' and 'static' conflict, you cannot build MySQL statically"
818 eerror "with RAID support enabled."
819 die "USE flags 'raid' and 'static' conflict!"
820 fi
821
822 if mysql_version_is_at_least "4.1.3" \
823 && ( use cluster || use extraengine || use embedded ) \
824 && use minimal ; then
825 M="USE flags 'cluster', 'extraengine', 'embedded' conflict with 'minimal' USE flag!"
826 eerror "${M}"
827 die "${M}"
828 fi
829
830 if mysql_version_is_at_least "5.1" \
831 && xtradb_patch_available \
832 && use xtradb \
833 && use embedded ; then
834 M="USE flags 'xtradb' and 'embedded' conflict and cause build failures"
835 eerror "${M}"
836 die "${M}"
837 fi
838
839 # Bug #290570, 284946, 307251
840 # Upstream changes made us need a fairly new GCC4.
841 # But only for 5.0.8[3-6]!
842 if mysql_version_is_at_least "5.0.83" && ! mysql_version_is_at_least 5.0.87 ; then
843 GCC_VER=$(gcc-version)
844 case ${CHOST}:${GCC_VER} in
845 *-darwin*:4.*) : ;; # bug #310615
846 *:2*|*:3*|*:4.0|*:4.1|*:4.2)
847 eerror "Some releases of MySQL required a very new GCC, and then"
848 eerror "later release relaxed that requirement again. Either pick a"
849 eerror "MySQL >=5.0.87, or use a newer GCC."
850 die "Active GCC too old!" ;;
851 esac
852 fi
853
854 # This should come after all of the die statements
855 enewgroup mysql 60 || die "problem adding 'mysql' group"
856 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
857
858 mysql_check_version_range "4.0 to 5.0.99.99" \
859 && use berkdb \
860 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
861
862 if [ "${PN}" != "mysql-cluster" ] && use cluster; then
863 ewarn "Upstream has noted that the NDB cluster support in the 5.0 and"
864 ewarn "5.1 series should NOT be put into production. In the near"
865 ewarn "future, it will be disabled from building."
866 ewarn ""
867 ewarn "If you need NDB support, you should instead move to the new"
868 ewarn "mysql-cluster package that represents that upstream NDB"
869 ewarn "development."
870 fi
871 }
872
873 # @FUNCTION: mysql_src_unpack
874 # @DESCRIPTION:
875 # Unpack the source code and call mysql_src_prepare for EAPI < 2.
876 mysql_src_unpack() {
877 # Initialize the proper variables first
878 mysql_init_vars
879
880 unpack ${A}
881 # Grab the patches
882 [[ "${MY_EXTRAS_VER}" == "live" ]] && S="${WORKDIR}/mysql-extras" git-r3_src_unpack
883
884 mv -f "${WORKDIR}/${MY_SOURCEDIR}" "${S}"
885
886 # Be backwards compatible for now
887 case ${EAPI:-0} in
888 2) : ;;
889 0 | 1) mysql_src_prepare ;;
890 esac
891 }
892
893 # @FUNCTION: mysql_src_prepare
894 # @DESCRIPTION:
895 # Apply patches to the source code and remove unneeded bundled libs.
896 mysql_src_prepare() {
897 cd "${S}"
898
899 # Apply the patches for this MySQL version
900 EPATCH_SUFFIX="patch"
901 mkdir -p "${EPATCH_SOURCE}" || die "Unable to create epatch directory"
902 # Clean out old items
903 rm -f "${EPATCH_SOURCE}"/*
904 # Now link in right patches
905 mysql_mv_patches
906 # And apply
907 epatch
908
909 # last -fPIC fixup, per bug #305873
910 i="${S}"/storage/innodb_plugin/plug.in
911 [ -f "${i}" ] && sed -i -e '/CFLAGS/s,-prefer-non-pic,,g' "${i}"
912
913 # Additional checks, remove bundled zlib (Cluster needs this, for static
914 # memory management in zlib, leave available for Cluster)
915 if [[ "${PN}" != "mysql-cluster" ]] ; then
916 rm -f "${S}/zlib/"*.[ch]
917 sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
918 fi
919 rm -f "scripts/mysqlbug"
920
921 # Make charsets install in the right place
922 find . -name 'Makefile.am' \
923 -exec sed --in-place -e 's!$(pkgdatadir)!'${MY_SHAREDSTATEDIR}'!g' {} \;
924
925 if mysql_version_is_at_least "4.1" ; then
926 # Remove what needs to be recreated, so we're sure it's actually done
927 einfo "Cleaning up old buildscript files"
928 find . -name Makefile \
929 -o -name Makefile.in \
930 -o -name configure \
931 -exec rm -f {} \;
932 rm -f "ltmain.sh"
933 rm -f "scripts/mysqlbug"
934 fi
935
936 local rebuilddirlist d
937
938 if xtradb_patch_available && use xtradb ; then
939 einfo "Adding storage engine: Percona XtraDB (replacing InnoDB)"
940 pushd "${S}"/storage >/dev/null
941 i="innobase"
942 o="${WORKDIR}/storage-${i}.mysql-upstream"
943 # Have we been here already?
944 [ -d "${o}" ] && rm -f "${i}"
945 # Or maybe we haven't
946 [ -d "${i}" -a ! -d "${o}" ] && mv "${i}" "${o}"
947 cp -ral "${WORKDIR}/${XTRADB_P}" "${i}"
948 popd >/dev/null
949 fi
950
951 if pbxt_patch_available && [[ "${PBXT_NEWSTYLE}" == "1" ]] && use pbxt ; then
952 einfo "Adding storage engine: PBXT"
953 pushd "${S}"/storage >/dev/null
954 i='pbxt'
955 [ -d "${i}" ] && rm -rf "${i}"
956 cp -ral "${WORKDIR}/${PBXT_P}" "${i}"
957 popd >/dev/null
958 fi
959
960 if mysql_version_is_at_least "5.1.12" ; then
961 rebuilddirlist="."
962 # This does not seem to be needed presently. robbat2 2010/02/23
963 #einfo "Updating innobase cmake"
964 ## TODO: check this with a cmake expert
965 #cmake \
966 # -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
967 # -DCMAKE_CXX_COMPILER=$(type -P $(tc-getCXX)) \
968 # "storage/innobase"
969 else
970 rebuilddirlist=". innobase"
971 fi
972
973 for d in ${rebuilddirlist} ; do
974 einfo "Reconfiguring dir '${d}'"
975 pushd "${d}" &>/dev/null
976 eautoreconf
977 popd &>/dev/null
978 done
979
980 if mysql_check_version_range "4.1 to 5.0.99.99" \
981 && use berkdb ; then
982 einfo "Fixing up berkdb buildsystem"
983 [[ -w "bdb/dist/ltmain.sh" ]] && cp -f "ltmain.sh" "bdb/dist/ltmain.sh"
984 cp -f "${EPREFIX}/usr/share/aclocal/libtool.m4" "bdb/dist/aclocal/libtool.ac" \
985 || die "Could not copy libtool.m4 to bdb/dist/"
986 #These files exist only with libtool-2*, and need to be included.
987 if [ -f ${EPREFIX}'/usr/share/aclocal/ltsugar.m4' ]; then
988 cat "${EPREFIX}/usr/share/aclocal/ltsugar.m4" >> "bdb/dist/aclocal/libtool.ac"
989 cat "${EPREFIX}/usr/share/aclocal/ltversion.m4" >> "bdb/dist/aclocal/libtool.ac"
990 cat "${EPREFIX}/usr/share/aclocal/lt~obsolete.m4" >> "bdb/dist/aclocal/libtool.ac"
991 cat "${EPREFIX}/usr/share/aclocal/ltoptions.m4" >> "bdb/dist/aclocal/libtool.ac"
992 fi
993 pushd "bdb/dist" &>/dev/null
994 sh s_all \
995 || die "Failed bdb reconfigure"
996 popd &>/dev/null
997 fi
998 }
999
1000 # @FUNCTION: mysql_src_configure
1001 # @DESCRIPTION:
1002 # Configure mysql to build the code for Gentoo respecting the use flags.
1003 mysql_src_configure() {
1004 # Make sure the vars are correctly initialized
1005 mysql_init_vars
1006
1007 # $myconf is modified by the configure_* functions
1008 local myconf=""
1009
1010 if use minimal ; then
1011 configure_minimal
1012 else
1013 configure_common
1014 if mysql_version_is_at_least "5.1.10" ; then
1015 configure_51
1016 else
1017 configure_40_41_50
1018 fi
1019 fi
1020
1021 # Bug #114895, bug #110149
1022 filter-flags "-O" "-O[01]"
1023
1024 # glib-2.3.2_pre fix, bug #16496
1025 append-cppflags "-DHAVE_ERRNO_AS_DEFINE=1"
1026
1027 # As discovered by bug #246652, doing a double-level of SSP causes NDB to
1028 # fail badly during cluster startup.
1029 if [[ $(gcc-major-version) -lt 4 ]]; then
1030 filter-flags "-fstack-protector-all"
1031 fi
1032
1033 CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-strict-aliasing"
1034 CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-rtti"
1035 mysql_version_is_at_least "5.0" \
1036 && CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
1037 export CXXFLAGS
1038
1039 # bug #283926, with GCC4.4, this is required to get correct behavior.
1040 append-flags -fno-strict-aliasing
1041
1042 # bug #335185, #335995, with >= GCC4.3.3 on x86 only, omit-frame-pointer
1043 # causes a mis-compile.
1044 # Upstream bugs:
1045 # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=38562
1046 # http://bugs.mysql.com/bug.php?id=45205
1047 use x86 && version_is_at_least "4.3.3" "$(gcc-fullversion)" && \
1048 append-flags -fno-omit-frame-pointer && \
1049 filter-flags -fomit-frame-pointer
1050
1051 econf \
1052 --libexecdir="${EPREFIX}"/usr/sbin \
1053 --sysconfdir=${MY_SYSCONFDIR} \
1054 --localstatedir=${MY_LOCALSTATEDIR} \
1055 --sharedstatedir=${MY_SHAREDSTATEDIR} \
1056 --libdir=${MY_LIBDIR} \
1057 --includedir=${MY_INCLUDEDIR} \
1058 --with-low-memory \
1059 --with-client-ldflags=-lstdc++ \
1060 --enable-thread-safe-client \
1061 --with-comment="Gentoo Linux ${PF}" \
1062 --without-docs \
1063 --with-LIBDIR="$(get_libdir)" \
1064 ${myconf} || die "econf failed"
1065
1066 # TODO: Move this before autoreconf !!!
1067 find . -type f -name Makefile -print0 \
1068 | xargs -0 -n100 sed -i \
1069 -e 's|^pkglibdir *= *$(libdir)/mysql|pkglibdir = $(libdir)|;s|^pkgincludedir *= *$(includedir)/mysql|pkgincludedir = $(includedir)|'
1070
1071 if [[ $EAPI == 2 ]] && [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1072 pbxt_patch_available && use pbxt && pbxt_src_configure
1073 fi
1074 }
1075
1076 # @FUNCTION: mysql_src_compile
1077 # @DESCRIPTION:
1078 # Compile the mysql code.
1079 mysql_src_compile() {
1080 # Be backwards compatible for now
1081 case ${EAPI:-0} in
1082 2) : ;;
1083 0 | 1) mysql_src_configure ;;
1084 esac
1085
1086 emake || die "emake failed"
1087
1088 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1089 pbxt_patch_available && use pbxt && pbxt_src_compile
1090 fi
1091 }
1092
1093 # @FUNCTION: mysql_src_install
1094 # @DESCRIPTION:
1095 # Install mysql.
1096 mysql_src_install() {
1097 # Make sure the vars are correctly initialized
1098 mysql_init_vars
1099
1100 emake install \
1101 DESTDIR="${D}" \
1102 benchdir_root=${MY_SHAREDSTATEDIR} \
1103 testroot="${MY_SHAREDSTATEDIR}" \
1104 || die "emake install failed"
1105
1106 if [[ "${PBXT_NEWSTYLE}" != "1" ]]; then
1107 pbxt_patch_available && use pbxt && pbxt_src_install
1108 fi
1109
1110 # Convenience links
1111 einfo "Making Convenience links for mysqlcheck multi-call binary"
1112 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlanalyze"
1113 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqlrepair"
1114 dosym "/usr/bin/mysqlcheck" "/usr/bin/mysqloptimize"
1115
1116 # Various junk (my-*.cnf moved elsewhere)
1117 einfo "Removing duplicate /usr/share/mysql files"
1118 rm -Rf "${ED}/usr/share/info"
1119 for removeme in "mysql-log-rotate" mysql.server* \
1120 binary-configure* my-*.cnf mi_test_all*
1121 do
1122 rm -f "${D}"/${MY_SHAREDSTATEDIR}/${removeme}
1123 done
1124
1125 # Clean up stuff for a minimal build
1126 if use minimal ; then
1127 einfo "Remove all extra content for minimal build"
1128 rm -Rf "${D}${MY_SHAREDSTATEDIR}"/{mysql-test,sql-bench}
1129 rm -f "${ED}"/usr/bin/{mysql{_install_db,manager*,_secure_installation,_fix_privilege_tables,hotcopy,_convert_table_format,d_multi,_fix_extensions,_zap,_explain_log,_tableinfo,d_safe,_install,_waitpid,binlog,test},myisam*,isam*,pack_isam}
1130 rm -f "${ED}/usr/sbin/mysqld"
1131 rm -f "${D}${MY_LIBDIR}"/lib{heap,merge,nisam,my{sys,strings,sqld,isammrg,isam},vio,dbug}.a
1132 fi
1133
1134 # Unless they explicitly specific USE=test, then do not install the
1135 # testsuite. It DOES have a use to be installed, esp. when you want to do a
1136 # validation of your database configuration after tuning it.
1137 if use !test ; then
1138 rm -rf "${D}"/${MY_SHAREDSTATEDIR}/mysql-test
1139 fi
1140
1141 # Configuration stuff
1142 case ${MYSQL_PV_MAJOR} in
1143 3*|4.0) mysql_mycnf_version="4.0" ;;
1144 4.[1-9]|5.0) mysql_mycnf_version="4.1" ;;
1145 5.[1-9]|6*|7*) mysql_mycnf_version="5.1" ;;
1146 esac
1147 einfo "Building default my.cnf (${mysql_mycnf_version})"
1148 insinto "${MY_SYSCONFDIR#${EPREFIX}}"
1149 doins scripts/mysqlaccess.conf
1150 mycnf_src="my.cnf-${mysql_mycnf_version}"
1151 sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
1152 -e "s!/tmp!${EPREFIX}/tmp!" \
1153 -e "s!/usr!${EPREFIX}/usr!" \
1154 -e "s!= /var!= ${EPREFIX}/var!" \
1155 "${FILESDIR}/${mycnf_src}" \
1156 > "${TMPDIR}/my.cnf.ok"
1157 use prefix && sed -i -r -e '/^user[[:space:]]*=[[:space:]]*mysql$/d' "${TMPDIR}/my.cnf.ok"
1158 if use latin1 ; then
1159 sed -i \
1160 -e "/character-set/s|utf8|latin1|g" \
1161 "${TMPDIR}/my.cnf.ok"
1162 fi
1163 newins "${TMPDIR}/my.cnf.ok" my.cnf
1164
1165 # Minimal builds don't have the MySQL server
1166 if ! use minimal ; then
1167 einfo "Creating initial directories"
1168 # Empty directories ...
1169 diropts "-m0750"
1170 if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
1171 dodir "${MY_DATADIR#${EPREFIX}}"
1172 keepdir "${MY_DATADIR#${EPREFIX}}"
1173 chown -R mysql:mysql "${D}/${MY_DATADIR}"
1174 fi
1175
1176 diropts "-m0755"
1177 for folder in "${MY_LOGDIR#${EPREFIX}}" "/var/run/mysqld" ; do
1178 dodir "${folder}"
1179 keepdir "${folder}"
1180 chown -R mysql:mysql "${ED}/${folder}"
1181 done
1182 fi
1183
1184 # Docs
1185 einfo "Installing docs"
1186 for i in README ChangeLog EXCEPTIONS-CLIENT INSTALL-SOURCE ; do
1187 [[ -f "$i" ]] && dodoc "$i"
1188 done
1189 doinfo "${S}"/Docs/mysql.info
1190
1191 # Minimal builds don't have the MySQL server
1192 if ! use minimal ; then
1193 einfo "Including support files and sample configurations"
1194 docinto "support-files"
1195 for script in \
1196 "${S}"/support-files/my-*.cnf \
1197 "${S}"/support-files/magic \
1198 "${S}"/support-files/ndb-config-2-node.ini
1199 do
1200 [[ -f "$script" ]] && dodoc "${script}"
1201 done
1202
1203 docinto "scripts"
1204 for script in "${S}"/scripts/mysql* ; do
1205 [[ -f "$script" ]] && [[ "${script%.sh}" == "${script}" ]] && dodoc "${script}"
1206 done
1207
1208 fi
1209
1210 mysql_lib_symlinks "${ED}"
1211 }
1212
1213 # @FUNCTION: mysql_pkg_preinst
1214 # @DESCRIPTION:
1215 # Create the user and groups for mysql - die if that fails.
1216 mysql_pkg_preinst() {
1217 enewgroup mysql 60 || die "problem adding 'mysql' group"
1218 enewuser mysql 60 -1 /dev/null mysql || die "problem adding 'mysql' user"
1219 }
1220
1221 # @FUNCTION: mysql_pkg_postinst
1222 # @DESCRIPTION:
1223 # Run post-installation tasks:
1224 # create the dir for logfiles if non-existant
1225 # touch the logfiles and secure them
1226 # install scripts
1227 # issue required steps for optional features
1228 # issue deprecation warnings
1229 mysql_pkg_postinst() {
1230 # Make sure the vars are correctly initialized
1231 mysql_init_vars
1232
1233 # Check FEATURES="collision-protect" before removing this
1234 [[ -d "${EROOT}/var/log/mysql" ]] || install -d -m0750 -o mysql -g mysql "${ROOT}${MY_LOGDIR}"
1235
1236 # Secure the logfiles
1237 touch "${ROOT}${MY_LOGDIR}"/mysql.{log,err}
1238 chown mysql:mysql "${ROOT}${MY_LOGDIR}"/mysql*
1239 chmod 0660 "${ROOT}${MY_LOGDIR}"/mysql*
1240
1241 # Minimal builds don't have the MySQL server
1242 if ! use minimal ; then
1243 docinto "support-files"
1244 for script in \
1245 support-files/my-*.cnf \
1246 support-files/magic \
1247 support-files/ndb-config-2-node.ini
1248 do
1249 [[ -f "${script}" ]] \
1250 && dodoc "${script}"
1251 done
1252
1253 docinto "scripts"
1254 for script in scripts/mysql* ; do
1255 [[ -f "${script}" ]] \
1256 && [[ "${script%.sh}" == "${script}" ]] \
1257 && dodoc "${script}"
1258 done
1259
1260 einfo
1261 elog "You might want to run:"
1262 elog "\"emerge --config =${CATEGORY}/${PF}\""
1263 elog "if this is a new install."
1264 einfo
1265
1266 einfo
1267 elog "If you are upgrading major versions, you should run the"
1268 elog "mysql_upgrade tool."
1269 einfo
1270 fi
1271
1272 if pbxt_available && use pbxt ; then
1273 elog "Note: PBXT is now statically built when enabled."
1274 elog ""
1275 elog "If, you previously installed as a plugin and "
1276 elog "you cannot start the MySQL server,"
1277 elog "remove the ${MY_DATADIR}/mysql/plugin.* files, then"
1278 elog "use the MySQL upgrade script to restore the table"
1279 elog "or execute the following SQL command:"
1280 elog " CREATE TABLE IF NOT EXISTS plugin ("
1281 elog " name char(64) binary DEFAULT '' NOT NULL,"
1282 elog " dl char(128) DEFAULT '' NOT NULL,"
1283 elog " PRIMARY KEY (name)"
1284 elog " ) CHARACTER SET utf8 COLLATE utf8_bin;"
1285 fi
1286
1287 mysql_check_version_range "4.0 to 5.0.99.99" \
1288 && use berkdb \
1289 && elog "Berkeley DB support is deprecated and will be removed in future versions!"
1290 }
1291
1292 # @FUNCTION: mysql_getopt
1293 # @DESCRIPTION:
1294 # Use my_print_defaults to extract specific config options
1295 mysql_getopt() {
1296 local mypd="${EROOT}"/usr/bin/my_print_defaults
1297 section="$1"
1298 flag="--${2}="
1299 "${mypd}" $section | sed -n "/^${flag}/p"
1300 }
1301
1302 # @FUNCTION: mysql_getoptval
1303 # @DESCRIPTION:
1304 # Use my_print_defaults to extract specific config options
1305 mysql_getoptval() {
1306 local mypd="${EROOT}"/usr/bin/my_print_defaults
1307 section="$1"
1308 flag="--${2}="
1309 "${mypd}" $section | sed -n "/^${flag}/s,${flag},,gp"
1310 }
1311
1312 # @FUNCTION: mysql_pkg_config
1313 # @DESCRIPTION:
1314 # Configure mysql environment.
1315 mysql_pkg_config() {
1316 local old_MY_DATADIR="${MY_DATADIR}"
1317 local old_HOME="${HOME}"
1318 # my_print_defaults needs to read stuff in $HOME/.my.cnf
1319 export HOME=/root
1320
1321 # Make sure the vars are correctly initialized
1322 mysql_init_vars
1323
1324 [[ -z "${MY_DATADIR}" ]] && die "Sorry, unable to find MY_DATADIR"
1325
1326 if built_with_use ${CATEGORY}/${PN} minimal ; then
1327 die "Minimal builds do NOT include the MySQL server"
1328 fi
1329
1330 if [[ ( -n "${MY_DATADIR}" ) && ( "${MY_DATADIR}" != "${old_MY_DATADIR}" ) ]]; then
1331 local MY_DATADIR_s="${ROOT}/${MY_DATADIR}"
1332 MY_DATADIR_s="${MY_DATADIR_s%%/}"
1333 local old_MY_DATADIR_s="${ROOT}/${old_MY_DATADIR}"
1334 old_MY_DATADIR_s="${old_MY_DATADIR_s%%/}"
1335
1336 if [[ -d "${old_MY_DATADIR_s}" ]] && [[ "${old_MY_DATADIR_s}" != / ]]; then
1337 if [[ -d "${MY_DATADIR_s}" ]]; then
1338 ewarn "Both ${old_MY_DATADIR_s} and ${MY_DATADIR_s} exist"
1339 ewarn "Attempting to use ${MY_DATADIR_s} and preserving ${old_MY_DATADIR_s}"
1340 else
1341 elog "Moving MY_DATADIR from ${old_MY_DATADIR_s} to ${MY_DATADIR_s}"
1342 mv --strip-trailing-slashes -T "${old_MY_DATADIR_s}" "${MY_DATADIR_s}" \
1343 || die "Moving MY_DATADIR failed"
1344 fi
1345 else
1346 ewarn "Previous MY_DATADIR (${old_MY_DATADIR_s}) does not exist"
1347 if [[ -d "${MY_DATADIR_s}" ]]; then
1348 ewarn "Attempting to use ${MY_DATADIR_s}"
1349 else
1350 eerror "New MY_DATADIR (${MY_DATADIR_s}) does not exist"
1351 die "Configuration Failed! Please reinstall ${CATEGORY}/${PN}"
1352 fi
1353 fi
1354 fi
1355
1356 local pwd1="a"
1357 local pwd2="b"
1358 local maxtry=15
1359
1360 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
1361 MYSQL_ROOT_PASSWORD="$(mysql_getoptval 'client mysql' password)"
1362 fi
1363 MYSQL_TMPDIR="$(mysql_getoptval mysqld tmpdir)"
1364 # These are dir+prefix
1365 MYSQL_RELAY_LOG="$(mysql_getoptval mysqld relay-log)"
1366 MYSQL_RELAY_LOG=${MYSQL_RELAY_LOG%/*}
1367 MYSQL_LOG_BIN="$(mysql_getoptval mysqld log-bin)"
1368 MYSQL_LOG_BIN=${MYSQL_LOG_BIN%/*}
1369
1370 if [[ ! -d "${ROOT}"/$MYSQL_TMPDIR ]]; then
1371 einfo "Creating MySQL tmpdir $MYSQL_TMPDIR"
1372 install -d -m 770 -o mysql -g mysql "${ROOT}"/$MYSQL_TMPDIR
1373 fi
1374 if [[ ! -d "${ROOT}"/$MYSQL_LOG_BIN ]]; then
1375 einfo "Creating MySQL log-bin directory $MYSQL_LOG_BIN"
1376 install -d -m 770 -o mysql -g mysql "${ROOT}"/$MYSQL_LOG_BIN
1377 fi
1378 if [[ ! -d "${ROOT}"/$MYSQL_RELAY_LOG ]]; then
1379 einfo "Creating MySQL relay-log directory $MYSQL_RELAY_LOG"
1380 install -d -m 770 -o mysql -g mysql "${ROOT}"/$MYSQL_RELAY_LOG
1381 fi
1382
1383 if [[ -d "${ROOT}/${MY_DATADIR}/mysql" ]] ; then
1384 ewarn "You have already a MySQL database in place."
1385 ewarn "(${ROOT}/${MY_DATADIR}/*)"
1386 ewarn "Please rename or delete it if you wish to replace it."
1387 die "MySQL database already exists!"
1388 fi
1389
1390 # Bug #213475 - MySQL _will_ object strenously if your machine is named
1391 # localhost. Also causes weird failures.
1392 [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
1393
1394 if [ -z "${MYSQL_ROOT_PASSWORD}" ]; then
1395
1396 einfo "Please provide a password for the mysql 'root' user now, in the"
1397 einfo "MYSQL_ROOT_PASSWORD env var or through the /root/.my.cnf file."
1398 ewarn "Avoid [\"'\\_%] characters in the password"
1399 read -rsp " >" pwd1 ; echo
1400
1401 einfo "Retype the password"
1402 read -rsp " >" pwd2 ; echo
1403
1404 if [[ "x$pwd1" != "x$pwd2" ]] ; then
1405 die "Passwords are not the same"
1406 fi
1407 MYSQL_ROOT_PASSWORD="${pwd1}"
1408 unset pwd1 pwd2
1409 fi
1410
1411 local options="--log-warnings=0"
1412 local sqltmp="$(emktemp)"
1413
1414 local help_tables="${ROOT}${MY_SHAREDSTATEDIR}/fill_help_tables.sql"
1415 [[ -r "${help_tables}" ]] \
1416 && cp "${help_tables}" "${TMPDIR}/fill_help_tables.sql" \
1417 || touch "${TMPDIR}/fill_help_tables.sql"
1418 help_tables="${TMPDIR}/fill_help_tables.sql"
1419
1420 # Figure out which options we need to disable to do the setup
1421 helpfile="${TMPDIR}/mysqld-help"
1422 ${EROOT}/usr/sbin/mysqld --verbose --help >"${helpfile}" 2>/dev/null
1423 for opt in grant-tables host-cache name-resolve networking slave-start bdb \
1424 federated innodb ssl log-bin relay-log slow-query-log external-locking \
1425 ndbcluster log-slave-updates \
1426 ; do
1427 optexp="--(skip-)?${opt}" optfull="--loose-skip-${opt}"
1428 egrep -sq -- "${optexp}" "${helpfile}" && options="${options} ${optfull}"
1429 done
1430 # But some options changed names
1431 egrep -sq external-locking "${helpfile}" && \
1432 options="${options/skip-locking/skip-external-locking}"
1433
1434 use prefix || options="${options} --user=mysql"
1435
1436 pushd "${TMPDIR}" &>/dev/null
1437 #cmd="'${EROOT}/usr/share/mysql/scripts/mysql_install_db' '--basedir=${EPREFIX}/usr' ${options}"
1438 cmd=${EROOT}usr/share/mysql/scripts/mysql_install_db
1439 [ -f ${cmd} ] || cmd=${EROOT}usr/bin/mysql_install_db
1440 cmd="'$cmd' '--basedir=${EPREFIX}/usr' ${options}"
1441 einfo "Command: $cmd"
1442 eval $cmd \
1443 >"${TMPDIR}"/mysql_install_db.log 2>&1
1444 if [ $? -ne 0 ]; then
1445 grep -B5 -A999 -i "ERROR" "${TMPDIR}"/mysql_install_db.log 1>&2
1446 die "Failed to run mysql_install_db. Please review ${EPREFIX}/var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"
1447 fi
1448 popd &>/dev/null
1449 [[ -f "${ROOT}/${MY_DATADIR}/mysql/user.frm" ]] \
1450 || die "MySQL databases not installed"
1451 chown -R mysql:mysql "${ROOT}/${MY_DATADIR}" 2>/dev/null
1452 chmod 0750 "${ROOT}/${MY_DATADIR}" 2>/dev/null
1453
1454 if mysql_version_is_at_least "4.1.3" ; then
1455 # Filling timezones, see
1456 # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
1457 "${EROOT}/usr/bin/mysql_tzinfo_to_sql" "${EROOT}/usr/share/zoneinfo" > "${sqltmp}" 2>/dev/null
1458
1459 if [[ -r "${help_tables}" ]] ; then
1460 cat "${help_tables}" >> "${sqltmp}"
1461 fi
1462 fi
1463
1464 einfo "Creating the mysql database and setting proper"
1465 einfo "permissions on it ..."
1466
1467 local socket="${EROOT}/var/run/mysqld/mysqld${RANDOM}.sock"
1468 local pidfile="${EROOT}/var/run/mysqld/mysqld${RANDOM}.pid"
1469 local mysqld="${EROOT}/usr/sbin/mysqld \
1470 ${options} \
1471 $(use prefix || echo --user=mysql) \
1472 --log-warnings=0 \
1473 --basedir=${EROOT}/usr \
1474 --datadir=${ROOT}/${MY_DATADIR} \
1475 --max_allowed_packet=8M \
1476 --net_buffer_length=16K \
1477 --default-storage-engine=MyISAM \
1478 --socket=${socket} \
1479 --pid-file=${pidfile}"
1480 #einfo "About to start mysqld: ${mysqld}"
1481 ebegin "Starting mysqld"
1482 einfo "Command ${mysqld}"
1483 ${mysqld} &
1484 rc=$?
1485 while ! [[ -S "${socket}" || "${maxtry}" -lt 1 ]] ; do
1486 maxtry=$((${maxtry}-1))
1487 echo -n "."
1488 sleep 1
1489 done
1490 eend $rc
1491
1492 if ! [[ -S "${socket}" ]]; then
1493 die "Completely failed to start up mysqld with: ${mysqld}"
1494 fi
1495
1496 ebegin "Setting root password"
1497 # Do this from memory, as we don't want clear text passwords in temp files
1498 local sql="UPDATE mysql.user SET Password = PASSWORD('${MYSQL_ROOT_PASSWORD}') WHERE USER='root'"
1499 "${EROOT}/usr/bin/mysql" \
1500 --socket=${socket} \
1501 -hlocalhost \
1502 -e "${sql}"
1503 eend $?
1504
1505 ebegin "Loading \"zoneinfo\", this step may require a few seconds ..."
1506 "${EROOT}/usr/bin/mysql" \
1507 --socket=${socket} \
1508 -hlocalhost \
1509 -uroot \
1510 --password="${MYSQL_ROOT_PASSWORD}" \
1511 mysql < "${sqltmp}"
1512 rc=$?
1513 eend $?
1514 [ $rc -ne 0 ] && ewarn "Failed to load zoneinfo!"
1515
1516 # Stop the server and cleanup
1517 einfo "Stopping the server ..."
1518 kill $(< "${pidfile}" )
1519 rm -f "${sqltmp}"
1520 wait %1
1521 einfo "Done"
1522 }
1523
1524 # @FUNCTION: mysql_pkg_postrm
1525 # @DESCRIPTION:
1526 # Remove mysql symlinks.
1527 mysql_pkg_postrm() {
1528 : # mysql_lib_symlinks "${ED}"
1529 }

  ViewVC Help
Powered by ViewVC 1.1.20