/[gentoo-x86]/eclass/perl-module.eclass
Gentoo

Diff of /eclass/perl-module.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.137 Revision 1.138
1# Copyright 1999-2013 Gentoo Foundation 1# Copyright 1999-2013 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/perl-module.eclass,v 1.137 2013/07/31 05:15:43 mattst88 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/perl-module.eclass,v 1.138 2013/12/29 21:37:09 dilfridge Exp $
4 4
5# @ECLASS: perl-module.eclass 5# @ECLASS: perl-module.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# perl@gentoo.org 7# perl@gentoo.org
8# @AUTHOR: 8# @AUTHOR:
25 PERL_EXPF+=" src_prepare src_configure" 25 PERL_EXPF+=" src_prepare src_configure"
26 [[ ${CATEGORY} == "perl-core" ]] && \ 26 [[ ${CATEGORY} == "perl-core" ]] && \
27 PERL_EXPF+=" pkg_postinst pkg_postrm" 27 PERL_EXPF+=" pkg_postinst pkg_postrm"
28 28
29 case "${GENTOO_DEPEND_ON_PERL:-yes}" in 29 case "${GENTOO_DEPEND_ON_PERL:-yes}" in
30 yes)
31 case "${EAPI:-0}" in
32 5)
33 case "${GENTOO_DEPEND_ON_PERL_SUBSLOT:-yes}" in
30 yes) 34 yes)
35 DEPEND="dev-lang/perl:=[-build(-)]"
36 ;;
37 *)
38 DEPEND="dev-lang/perl[-build(-)]"
39 ;;
40 esac
41 ;;
42 *)
31 DEPEND="|| ( >=dev-lang/perl-5.16 <dev-lang/perl-5.16[-build] )" 43 DEPEND="|| ( >=dev-lang/perl-5.16 <dev-lang/perl-5.16[-build] )"
32 RDEPEND="${DEPEND}"
33 ;; 44 ;;
45 esac
46 RDEPEND="${DEPEND}"
47 ;;
34 esac 48 esac
35 ;; 49 ;;
36 *) 50 *)
37 die "EAPI=${EAPI} is not supported by perl-module.eclass" 51 die "EAPI=${EAPI} is not supported by perl-module.eclass"
38 ;; 52 ;;

Legend:
Removed from v.1.137  
changed lines
  Added in v.1.138

  ViewVC Help
Powered by ViewVC 1.1.20