/[gentoo-x86]/eclass/perl-module.eclass
Gentoo

Diff of /eclass/perl-module.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.81 Revision 1.82
1# Copyright 1999-2004 Gentoo Foundation 1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/perl-module.eclass,v 1.81 2006/01/01 01:14:59 swegener Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/perl-module.eclass,v 1.82 2006/02/11 19:09:27 mcummings Exp $
4# 4#
5# Author: Seemant Kulleen <seemant@gentoo.org> 5# Author: Seemant Kulleen <seemant@gentoo.org>
6# Maintained by the Perl herd <perl@gentoo.org> 6# Maintained by the Perl herd <perl@gentoo.org>
7# 7#
8# The perl-module eclass is designed to allow easier installation of perl 8# The perl-module eclass is designed to allow easier installation of perl
63# Providing an override var for the use of Module::Build. While it is being 63# Providing an override var for the use of Module::Build. While it is being
64# incorporated in more and more modules, not module authors have working 64# incorporated in more and more modules, not module authors have working
65# Build.PL's in place. The override is to allow for a fallback to the "classic" 65# Build.PL's in place. The override is to allow for a fallback to the "classic"
66# Makfile.PL - example is Class::MethodMaker, which provides a Build.PL that is 66# Makfile.PL - example is Class::MethodMaker, which provides a Build.PL that is
67# severely broken. 67# severely broken.
68#
69# 2006.02.11 mcummings
70# Per a conversation with solar, adding a change to the dep/rdep lines for
71# minimal. Should fix bug 68367 and bug 83622, as well as other embedded builds
72# that use perl components without providing perl
68 73
69 74
70 75IUSE="minimal"
71DEPEND=">=dev-lang/perl-5.8.2 !<perl-core/ExtUtils-MakeMaker-6.17" 76DEPEND=">=dev-lang/perl-5.8.2 !<perl-core/ExtUtils-MakeMaker-6.17"
72RDEPEND="${DEPEND}" 77RDEPEND="!minimal? ( ${DEPEND} )"
73SRC_PREP="no" 78SRC_PREP="no"
74SRC_TEST="skip" 79SRC_TEST="skip"
75USE_BUILDER="yes" 80USE_BUILDER="yes"
76 81
77PERL_VERSION="" 82PERL_VERSION=""

Legend:
Removed from v.1.81  
changed lines
  Added in v.1.82

  ViewVC Help
Powered by ViewVC 1.1.20