/[gentoo-x86]/eclass/php-ext-source-r2.eclass
Gentoo

Contents of /eclass/php-ext-source-r2.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.34 - (hide annotations) (download)
Thu Mar 26 16:15:33 2015 UTC (8 hours, 20 minutes ago) by grknight
Branch: MAIN
CVS Tags: HEAD
Changes since 1.33: +5 -4 lines
Add deprecation warning when USE_PHP is empty

1 grknight 1.34 # Copyright 1999-2015 Gentoo Foundation
2 olemarkus 1.1 # Distributed under the terms of the GNU General Public License v2
3 grknight 1.34 # $Header: /var/cvsroot/gentoo-x86/eclass/php-ext-source-r2.eclass,v 1.33 2013/06/01 18:51:57 robbat2 Exp $
4 vapier 1.15
5     # @ECLASS: php-ext-source-r2.eclass
6     # @MAINTAINER:
7     # Gentoo PHP team <php-bugs@gentoo.org>
8     # @AUTHOR:
9 olemarkus 1.1 # Author: Tal Peer <coredumb@gentoo.org>
10     # Author: Stuart Herbert <stuart@gentoo.org>
11     # Author: Luca Longinotti <chtekk@gentoo.org>
12     # Author: Jakub Moc <jakub@gentoo.org> (documentation)
13     # Author: Ole Markus With <olemarkus@gentoo.org>
14     # @BLURB: A unified interface for compiling and installing standalone PHP extensions.
15     # @DESCRIPTION:
16     # This eclass provides a unified interface for compiling and installing standalone
17     # PHP extensions (modules).
18    
19 grknight 1.34 inherit flag-o-matic autotools multilib eutils
20 olemarkus 1.1
21 olemarkus 1.4 EXPORT_FUNCTIONS src_unpack src_prepare src_configure src_compile src_install
22 olemarkus 1.1
23     DEPEND=">=sys-devel/m4-1.4.3
24     >=sys-devel/libtool-1.5.18"
25     RDEPEND=""
26    
27     # Because of USE deps, we require at least EAPI 2
28     case ${EAPI} in
29 olemarkus 1.32 4|5) ;;
30 olemarkus 1.1 *)
31     die "php-ext-source-r2 is not compatible with EAPI=${EAPI}"
32     esac
33    
34     # @ECLASS-VARIABLE: PHP_EXT_NAME
35     # @DESCRIPTION:
36     # The extension name. This must be set, otherwise the eclass dies.
37     # Only automagically set by php-ext-pecl-r2.eclass, so unless your ebuild
38     # inherits that eclass, you must set this manually before inherit.
39     [[ -z "${PHP_EXT_NAME}" ]] && die "No module name specified for the php-ext-source-r2 eclass"
40    
41     # @ECLASS-VARIABLE: PHP_EXT_INI
42     # @DESCRIPTION:
43     # Controls whether or not to add a line to php.ini for the extension.
44     # Defaults to "yes" and should not be changed in most cases.
45     [[ -z "${PHP_EXT_INI}" ]] && PHP_EXT_INI="yes"
46    
47     # @ECLASS-VARIABLE: PHP_EXT_ZENDEXT
48     # @DESCRIPTION:
49     # Controls whether the extension is a ZendEngine extension or not.
50     # Defaults to "no" and if you don't know what is it, you don't need it.
51     [[ -z "${PHP_EXT_ZENDEXT}" ]] && PHP_EXT_ZENDEXT="no"
52    
53     # @ECLASS-VARIABLE: USE_PHP
54     # @DESCRIPTION:
55     # Lists the PHP slots compatibile the extension is compatibile with
56 grknight 1.34 [[ -z "${USE_PHP}" ]] && USE_PHP="php5-3" \
57     && eqawarn "An empty USE_PHP is deprecated and support will be removed on 2015-05-01"
58 olemarkus 1.1
59 robbat2 1.7 # @ECLASS-VARIABLE: PHP_EXT_OPTIONAL_USE
60     # @DESCRIPTION:
61     # If set, this is the USE flag that the PHP dependencies are behind
62     # Most commonly set as PHP_EXT_OPTIONAL_USE=php to get the dependencies behind
63     # USE=php.
64    
65 olemarkus 1.8 # @ECLASS-VARIABLE: PHP_EXT_S
66     # @DESCRIPTION:
67     # The relative location of the temporary build directory for the PHP extension within
68     # the source package. This is useful for packages that bundle the PHP extension.
69     # Defaults to ${S}
70     [[ -z "${PHP_EXT_S}" ]] && PHP_EXT_S="${S}"
71    
72 olemarkus 1.32 #Make sure at least one target is installed.
73 robbat2 1.33 REQUIRED_USE="${PHP_EXT_OPTIONAL_USE}${PHP_EXT_OPTIONAL_USE:+? ( }|| ( "
74 olemarkus 1.3 for target in ${USE_PHP}; do
75     IUSE="${IUSE} php_targets_${target}"
76 olemarkus 1.1 target=${target/+}
77 olemarkus 1.32 REQUIRED_USE+="php_targets_${target} "
78 olemarkus 1.1 slot=${target/php}
79     slot=${slot/-/.}
80 darkside 1.6 PHPDEPEND="${PHPDEPEND}
81 olemarkus 1.3 php_targets_${target}? ( dev-lang/php:${slot} )"
82 olemarkus 1.1 done
83 robbat2 1.33 REQUIRED_USE+=") ${PHP_EXT_OPTIONAL_USE:+ )}"
84 darkside 1.6
85     RDEPEND="${RDEPEND}
86 robbat2 1.7 ${PHP_EXT_OPTIONAL_USE}${PHP_EXT_OPTIONAL_USE:+? ( }
87     ${PHPDEPEND}
88     ${PHP_EXT_OPTIONAL_USE:+ )}"
89 olemarkus 1.1
90 mabi 1.22 DEPEND="${DEPEND}
91     ${PHP_EXT_OPTIONAL_USE}${PHP_EXT_OPTIONAL_USE:+? ( }
92     ${PHPDEPEND}
93     ${PHP_EXT_OPTIONAL_USE:+ )}
94     "
95 olemarkus 1.1
96     # @FUNCTION: php-ext-source-r2_src_unpack
97     # @DESCRIPTION:
98     # runs standard src_unpack + _phpize
99 vapier 1.15
100 olemarkus 1.1 # @VARIABLE: PHP_EXT_SKIP_PHPIZE
101     # @DESCRIPTION:
102     # phpize will be run by default for all ebuilds that use
103 darkside 1.6 # php-ext-source-r2_src_unpack
104 olemarkus 1.1 # Set PHP_EXT_SKIP_PHPIZE="yes" in your ebuild if you do not want to run phpize.
105     php-ext-source-r2_src_unpack() {
106     unpack ${A}
107 olemarkus 1.8 local slot orig_s="${PHP_EXT_S}"
108 olemarkus 1.1 for slot in $(php_get_slots); do
109 olemarkus 1.25 cp -r "${orig_s}" "${WORKDIR}/${slot}" || die "Failed to copy source ${orig_s} to PHP target directory"
110 olemarkus 1.4 done
111     }
112    
113     php-ext-source-r2_src_prepare() {
114 olemarkus 1.8 local slot orig_s="${PHP_EXT_S}"
115 olemarkus 1.4 for slot in $(php_get_slots); do
116 olemarkus 1.3 php_init_slot_env ${slot}
117 olemarkus 1.4 php-ext-source-r2_phpize
118 olemarkus 1.1 done
119     }
120    
121 vapier 1.15 # @FUNCTION: php-ext-source-r2_phpize
122 olemarkus 1.1 # @DESCRIPTION:
123     # Runs phpize and autotools in addition to the standard src_unpack
124     php-ext-source-r2_phpize() {
125 olemarkus 1.4 if [[ "${PHP_EXT_SKIP_PHPIZE}" != 'yes' ]] ; then
126     # Create configure out of config.m4
127     # I wish I could run this to solve #329071, but I cannot
128 vapier 1.16 #autotools_run_tool ${PHPIZE}
129 olemarkus 1.4 ${PHPIZE}
130     # force run of libtoolize and regeneration of related autotools
131     # files (bug 220519)
132     rm aclocal.m4
133     eautoreconf
134 darkside 1.6 fi
135 olemarkus 1.1 }
136    
137     # @FUNCTION: php-ext-source-r2_src_configure
138     # @DESCRIPTION:
139     # Takes care of standard configure for PHP extensions (modules).
140 vapier 1.15
141 olemarkus 1.1 # @VARIABLE: my_conf
142     # @DESCRIPTION:
143     # Set this in the ebuild to pass configure options to econf.
144     php-ext-source-r2_src_configure() {
145 mabi 1.24 # net-snmp creates this file #385403
146     addpredict /usr/share/snmp/mibs/.index
147 olemarkus 1.29 addpredict /var/lib/net-snmp/mib_indexes
148 mabi 1.24
149 olemarkus 1.1 local slot
150     for slot in $(php_get_slots); do
151 olemarkus 1.3 php_init_slot_env ${slot}
152 olemarkus 1.1 # Set the correct config options
153 olemarkus 1.14 econf --with-php-config=${PHPCONFIG} ${my_conf} || die "Unable to configure code to compile"
154 olemarkus 1.1 done
155     }
156    
157     # @FUNCTION: php-ext-source-r2_src_compile
158     # @DESCRIPTION:
159     # Takes care of standard compile for PHP extensions (modules).
160     php-ext-source-r2_src_compile() {
161     # net-snmp creates this file #324739
162     addpredict /usr/share/snmp/mibs/.index
163 olemarkus 1.29 addpredict /var/lib/net-snmp/mib_indexes
164    
165 olemarkus 1.1 # shm extension createss a semaphore file #173574
166     addpredict /session_mm_cli0.sem
167 darkside 1.6 local slot
168 olemarkus 1.1 for slot in $(php_get_slots); do
169 olemarkus 1.3 php_init_slot_env ${slot}
170 olemarkus 1.1 emake || die "Unable to make code"
171    
172     done
173     }
174    
175 olemarkus 1.28 # @FUNCTION: php-ext-source-r2_src_install
176 olemarkus 1.1 # @DESCRIPTION:
177     # Takes care of standard install for PHP extensions (modules).
178    
179     # @VARIABLE: DOCS
180     # @DESCRIPTION:
181     # Set in ebuild if you wish to install additional, package-specific documentation.
182     php-ext-source-r2_src_install() {
183     local slot
184     for slot in $(php_get_slots); do
185 olemarkus 1.3 php_init_slot_env ${slot}
186 olemarkus 1.1
187     # Let's put the default module away
188     insinto "${EXT_DIR}"
189     newins "modules/${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so" || die "Unable to install extension"
190    
191 olemarkus 1.3 local doc
192 olemarkus 1.1 for doc in ${DOCS} ; do
193     [[ -s ${doc} ]] && dodoc ${doc}
194     done
195    
196 olemarkus 1.14 INSTALL_ROOT="${D}" emake install-headers
197 olemarkus 1.1 done
198     php-ext-source-r2_createinifiles
199     }
200    
201    
202     php_get_slots() {
203 olemarkus 1.3 local s slot
204     for slot in ${USE_PHP}; do
205     use php_targets_${slot} && s+=" ${slot/-/.}"
206 olemarkus 1.1 done
207     echo $s
208     }
209    
210     php_init_slot_env() {
211     libdir=$(get_libdir)
212    
213 olemarkus 1.3 PHPIZE="/usr/${libdir}/${1}/bin/phpize"
214     PHPCONFIG="/usr/${libdir}/${1}/bin/php-config"
215     PHPCLI="/usr/${libdir}/${1}/bin/php"
216     PHPCGI="/usr/${libdir}/${1}/bin/php-cgi"
217 olemarkus 1.1 PHP_PKG="$(best_version =dev-lang/php-${1:3}*)"
218 olemarkus 1.3 PHPPREFIX="/usr/${libdir}/${slot}"
219 olemarkus 1.1 EXT_DIR="$(${PHPCONFIG} --extension-dir 2>/dev/null)"
220 olemarkus 1.5 PHP_CURRENTSLOT=${1:3}
221 olemarkus 1.1
222 olemarkus 1.8 PHP_EXT_S="${WORKDIR}/${1}"
223     cd "${PHP_EXT_S}"
224 olemarkus 1.1 }
225    
226     php-ext-source-r2_buildinilist() {
227     # Work out the list of <ext>.ini files to edit/add to
228     if [[ -z "${PHPSAPILIST}" ]] ; then
229 olemarkus 1.27 PHPSAPILIST="apache2 cli cgi fpm embed"
230 olemarkus 1.1 fi
231    
232 olemarkus 1.12 PHPINIFILELIST=""
233 olemarkus 1.3 local x
234 olemarkus 1.1 for x in ${PHPSAPILIST} ; do
235     if [[ -f "/etc/php/${x}-${1}/php.ini" ]] ; then
236     PHPINIFILELIST="${PHPINIFILELIST} etc/php/${x}-${1}/ext/${PHP_EXT_NAME}.ini"
237     fi
238     done
239 olemarkus 1.12 PHPFULLINIFILELIST="${PHPFULLINIFILELIST} ${PHPINIFILELIST}"
240 olemarkus 1.1 }
241    
242     # @FUNCTION: php-ext-source-r2_createinifiles
243     # @DESCRIPTION:
244     # Builds ini files for every enabled slot and SAPI
245     php-ext-source-r2_createinifiles() {
246     local slot
247 darkside 1.6 for slot in $(php_get_slots); do
248 olemarkus 1.3 php_init_slot_env ${slot}
249 olemarkus 1.1 # Pull in the PHP settings
250    
251     # Build the list of <ext>.ini files to edit/add to
252 olemarkus 1.3 php-ext-source-r2_buildinilist ${slot}
253 olemarkus 1.1
254 olemarkus 1.13
255 olemarkus 1.1 # Add the needed lines to the <ext>.ini files
256 olemarkus 1.13 local file
257 olemarkus 1.1 if [[ "${PHP_EXT_INI}" = "yes" ]] ; then
258 vapier 1.16 for file in ${PHPINIFILELIST}; do
259 olemarkus 1.13 php-ext-source-r2_addextension "${PHP_EXT_NAME}.so" "${file}"
260     done
261 olemarkus 1.1 fi
262    
263     # Symlink the <ext>.ini files from ext/ to ext-active/
264 olemarkus 1.13 local inifile
265 olemarkus 1.1 for inifile in ${PHPINIFILELIST} ; do
266 olemarkus 1.12 if [[ -n "${PHP_EXT_INIFILE}" ]]; then
267 olemarkus 1.31 cat "${FILESDIR}/${PHP_EXT_INIFILE}" >> "${ED}/${inifile}"
268 olemarkus 1.12 einfo "Added content of ${FILESDIR}/${PHP_EXT_INIFILE} to ${inifile}"
269     fi
270 olemarkus 1.1 inidir="${inifile/${PHP_EXT_NAME}.ini/}"
271     inidir="${inidir/ext/ext-active}"
272     dodir "/${inidir}"
273     dosym "/${inifile}" "/${inifile/ext/ext-active}"
274     done
275    
276     # Add support for installing PHP files into a version dependant directory
277     PHP_EXT_SHARED_DIR="/usr/share/php/${PHP_EXT_NAME}"
278     done
279     }
280    
281     php-ext-source-r2_addextension() {
282     if [[ "${PHP_EXT_ZENDEXT}" = "yes" ]] ; then
283     # We need the full path for ZendEngine extensions
284     # and we need to check for debugging enabled!
285 olemarkus 1.5 if has_version "dev-lang/php:${PHP_CURRENTSLOT}[threads]" ; then
286     if has_version "dev-lang/php:${PHP_CURRENTSLOT}[debug]" ; then
287 olemarkus 1.1 ext_type="zend_extension_debug_ts"
288     else
289     ext_type="zend_extension_ts"
290     fi
291 olemarkus 1.3 ext_file="${EXT_DIR}/${1}"
292 olemarkus 1.1 else
293 olemarkus 1.5 if has_version "dev-lang/php:${PHP_CURRENTSLOT}[debug]"; then
294 olemarkus 1.1 ext_type="zend_extension_debug"
295     else
296     ext_type="zend_extension"
297     fi
298 olemarkus 1.3 ext_file="${EXT_DIR}/${1}"
299 olemarkus 1.1 fi
300    
301     # php-5.3 unifies zend_extension loading and just requires the
302     # zend_extension keyword with no suffix
303     # TODO: drop previous code and this check once <php-5.3 support is
304     # discontinued
305     if has_version '>=dev-lang/php-5.3' ; then
306     ext_type="zend_extension"
307     fi
308     else
309     # We don't need the full path for normal extensions!
310     ext_type="extension"
311 olemarkus 1.3 ext_file="${1}"
312 olemarkus 1.1 fi
313    
314 olemarkus 1.13 php-ext-source-r2_addtoinifile "${ext_type}" "${ext_file}" "${2}" "Extension added"
315 olemarkus 1.1 }
316    
317     # $1 - Setting name
318     # $2 - Setting value
319     # $3 - File to add to
320     # $4 - Sanitized text to output
321     php-ext-source-r2_addtoinifile() {
322 olemarkus 1.13 local inifile="${WORKDIR}/${3}"
323     if [[ ! -d $(dirname ${inifile}) ]] ; then
324     mkdir -p $(dirname ${inifile})
325 olemarkus 1.1 fi
326    
327     # Are we adding the name of a section?
328     if [[ ${1:0:1} == "[" ]] ; then
329 olemarkus 1.13 echo "${1}" >> "${inifile}"
330 olemarkus 1.3 my_added="${1}"
331 olemarkus 1.1 else
332 olemarkus 1.13 echo "${1}=${2}" >> "${inifile}"
333 olemarkus 1.3 my_added="${1}=${2}"
334 olemarkus 1.1 fi
335    
336 olemarkus 1.3 if [[ -z "${4}" ]] ; then
337     einfo "Added '${my_added}' to /${3}"
338 olemarkus 1.1 else
339 olemarkus 1.3 einfo "${4} to /${3}"
340 olemarkus 1.1 fi
341    
342 olemarkus 1.3 insinto /$(dirname ${3})
343 olemarkus 1.13 doins "${inifile}"
344 olemarkus 1.1 }
345    
346     # @FUNCTION: php-ext-source-r2_addtoinifiles
347     # @USAGE: <setting name> <setting value> [message to output]; or just [section name]
348     # @DESCRIPTION:
349     # Add value settings to php.ini file installed by the extension (module).
350     # You can also add a [section], see examples below.
351     #
352     # @CODE
353     # Add some settings for the extension:
354     #
355     # php-ext-source-r2_addtoinifiles "zend_optimizer.optimization_level" "15"
356     # php-ext-source-r2_addtoinifiles "zend_optimizer.enable_loader" "0"
357     # php-ext-source-r2_addtoinifiles "zend_optimizer.disable_licensing" "0"
358     #
359     # Adding values to a section in php.ini file installed by the extension:
360     #
361     # php-ext-source-r2_addtoinifiles "[Debugger]"
362     # php-ext-source-r2_addtoinifiles "debugger.enabled" "on"
363     # php-ext-source-r2_addtoinifiles "debugger.profiler_enabled" "on"
364     # @CODE
365     php-ext-source-r2_addtoinifiles() {
366 olemarkus 1.3 local x
367 olemarkus 1.12 for x in ${PHPFULLINIFILELIST} ; do
368 olemarkus 1.3 php-ext-source-r2_addtoinifile "${1}" "${2}" "${x}" "${3}"
369 olemarkus 1.1 done
370     }

  ViewVC Help
Powered by ViewVC 1.1.20