/[gentoo-x86]/eclass/php-pear-lib-r1.eclass
Gentoo

Diff of /eclass/php-pear-lib-r1.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.1 Revision 1.3
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/php-pear-lib-r1.eclass,v 1.1 2005/10/31 14:08:42 chtekk Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/php-pear-lib-r1.eclass,v 1.3 2006/01/05 09:11:39 sebastian Exp $
4# 4#
5# Author: Luca Longinotti <chtekk@gentoo.org> 5# Author: Luca Longinotti <chtekk@gentoo.org>
6# Maintained by the PHP Herd <php-bugs@gentoo.org>
6# 7#
7# Based on Tal Peer's <coredumb@gentoo.org> work on php-pear.eclass. 8# Based on Tal Peer's <coredumb@gentoo.org> work on php-pear.eclass.
8# 9#
9# The php-pear-lib eclass provides means for easy installation of PEAR 10# The php-pear-lib-r1 eclass provides means for an easy installation of PEAR
10# based libraries, such as Creole, Jargon, Phing etc., while retaining 11# based libraries, such as Creole, Jargon, Phing etc., while retaining
11# the functionality to put the libraries into version-dependant dirs. 12# the functionality to put the libraries into version-dependant dirs.
12 13
13inherit depend.php 14inherit depend.php
14 15
15EXPORT_FUNCTIONS src_install 16EXPORT_FUNCTIONS src_install
16
17# Set this is the the package name on PEAR is different than the one in
18# portage (generally shouldn't be the case).
19 17
20# We must depend on the base package as we need it to let 18# We must depend on the base package as we need it to let
21# PEAR work, as well as PEAR itself. 19# PEAR work, as well as PEAR itself.
22DEPEND="${DEPEND} dev-lang/php >=dev-php/PEAR-PEAR-1.3.6" 20DEPEND="${DEPEND} dev-lang/php >=dev-php/PEAR-PEAR-1.3.6"
23RDEPEND="${RDEPEND} ${DEPEND}" 21RDEPEND="${RDEPEND} ${DEPEND}"
27 25
28 # SNMP support 26 # SNMP support
29 addpredict /usr/share/snmp/mibs/.index 27 addpredict /usr/share/snmp/mibs/.index
30 addpredict /var/lib/net-snmp/ 28 addpredict /var/lib/net-snmp/
31 29
30 case "${CATEGORY}" in
31 dev-php)
32 if has_version '=dev-lang/php-5*' ; then
33 PHP_BIN="/usr/lib/php5/bin/php"
34 else
35 PHP_BIN="/usr/lib/php4/bin/php"
36 fi ;;
37 dev-php4) PHP_BIN="/usr/lib/php4/bin/php" ;;
38 dev-php5) PHP_BIN="/usr/lib/php5/bin/php" ;;
39 *) die "I don't know which version of PHP packages in ${CATEGORY} require"
40 esac
41
32 cd "${S}" 42 cd "${S}"
33 mv "${WORKDIR}/package.xml" "${S}" 43 mv "${WORKDIR}/package.xml" "${S}"
34 pear install --nodeps --installroot="${D}" "${S}/package.xml" || die "Unable to install PEAR package" 44 pear -d php_bin="${PHP_BIN}" install --nodeps --installroot="${D}" "${S}/package.xml" || die "Unable to install PEAR package"
35 45
36 rm -rf "${D}/usr/share/php/.filemap" \ 46 rm -rf "${D}/usr/share/php/.filemap" \
37 "${D}/usr/share/php/.lock" \ 47 "${D}/usr/share/php/.lock" \
38 "${D}/usr/share/php/.registry" 48 "${D}/usr/share/php/.registry"
39 49

Legend:
Removed from v.1.1  
changed lines
  Added in v.1.3

  ViewVC Help
Powered by ViewVC 1.1.20