/[gentoo-x86]/eclass/php-sapi.eclass
Gentoo

Contents of /eclass/php-sapi.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.95 - (show annotations) (download)
Mon Nov 30 04:19:36 2009 UTC (4 years, 9 months ago) by abcd
Branch: MAIN
CVS Tags: HEAD
Changes since 1.94: +1 -1 lines
FILE REMOVED
Remove eclasses that have been marked as deprecated for >=2 years; schedule other deprecated eclasses for removal

1 # Copyright 1999-2005 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/php-sapi.eclass,v 1.94 2008/01/06 19:30:24 swegener Exp $
4 # Author: Robin H. Johnson <robbat2@gentoo.org>
5
6 # DEPRECATED!!!
7 # STOP USING THIS ECLASS, use one of the php?_?-sapi eclasses instead!
8
9 deprecation_warning() {
10 eerror "Please upgrade ${PF} to use one of the php?_?-sapi eclasses instead!"
11 }
12
13 php-sapi_check_java_config() {
14 deprecation_warning
15 }
16
17 php-sapi_src_unpack() {
18 deprecation_warning
19 }
20
21 php-sapi_src_compile() {
22 deprecation_warning
23 }
24
25 php-sapi_src_install() {
26 deprecation_warning
27 }
28
29 php-sapi_pkg_preinst() {
30 deprecation_warning
31 }
32
33 php-sapi_pkg_postinst() {
34 deprecation_warning
35 }
36
37 php-sapi_securityupgrade() {
38 deprecation_warning
39 }
40
41 php-sapi_warning_mssql_freetds() {
42 deprecation_warning
43 }

  ViewVC Help
Powered by ViewVC 1.1.20