/[gentoo-x86]/eclass/php5-sapi.eclass
Gentoo

Contents of /eclass/php5-sapi.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.61 - (show annotations) (download)
Mon Nov 30 04:19:36 2009 UTC (4 years, 11 months ago) by abcd
Branch: MAIN
CVS Tags: HEAD
Changes since 1.60: +1 -1 lines
FILE REMOVED
Remove eclasses that have been marked as deprecated for >=2 years; schedule other deprecated eclasses for removal

1 # Copyright 1999-2004 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/php5-sapi.eclass,v 1.60 2008/01/06 19:30:24 swegener Exp $
4 #
5 # eclass/php5-sapi.eclass
6 # Eclass for building different php5 SAPI instances
7 #
8 # Based on robbat2's work on the php4 sapi eclass
9 #
10 # Author(s) Stuart Herbert
11 # <stuart@gentoo.org>
12 #
13 # ========================================================================
14
15 # DEPRECATED!!!
16 # STOP USING THIS ECLASS, use php5_2-sapi eclass instead!
17
18 inherit php5_2-sapi
19
20 deprecation_warning() {
21 eerror "Please upgrade ${PF} to use php5_2-sapi eclass instead!"
22 }
23
24 php5-sapi_check_awkward_uses() {
25 deprecation_warning
26 php5_2-sapi_check_use_flags
27 }
28
29 php5-sapi_pkg_setup() {
30 deprecation_warning
31 php5_2-sapi_pkg_setup
32 }
33
34 php5-sapi_src_unpack() {
35 deprecation_warning
36 php5_2-sapi_src_unpack
37 }
38
39 php5-sapi_src_compile() {
40 deprecation_warning
41 php5_2-sapi_src_compile
42 }
43
44 php5-sapi_src_install() {
45 deprecation_warning
46 php5_2-sapi_src_install
47 }
48
49 php5-sapi_pkg_postinst() {
50 deprecation_warning
51 php5_2-sapi_pkg_postinst
52 }

  ViewVC Help
Powered by ViewVC 1.1.20