/[gentoo-x86]/eclass/python.eclass
Gentoo

Diff of /eclass/python.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.150 Revision 1.151
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.150 2012/02/13 23:50:12 zmedico Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.151 2012/02/27 03:57:35 floppym Exp $
4 4
5# @ECLASS: python.eclass 5# @ECLASS: python.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Gentoo Python Project <python@gentoo.org> 7# Gentoo Python Project <python@gentoo.org>
8# @BLURB: Eclass for Python packages 8# @BLURB: Eclass for Python packages
842 die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}" 842 die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}"
843 fi 843 fi
844 else 844 else
845 python3_version="" 845 python3_version=""
846 fi 846 fi
847 fi
848
849 if [[ -z "${python2_version}" && -z "${python3_version}" ]]; then
850 eerror "${CATEGORY}/${PF} requires at least one of the following packages:"
851 for PYTHON_ABI in "${_CPYTHON2_GLOBALLY_SUPPORTED_ABIS[@]}" "${_CPYTHON3_GLOBALLY_SUPPORTED_ABIS[@]}"; do
852 if ! _python_check_python_abi_matching --patterns-list "${PYTHON_ABI}" "${RESTRICT_PYTHON_ABIS}"; then
853 eerror " dev-lang/python:${PYTHON_ABI}"
854 fi
855 done
856 die "No supported version of CPython installed"
847 fi 857 fi
848 858
849 if [[ -n "${python2_version}" && "${python_version}" == "2."* && "${python_version}" != "${python2_version}" ]]; then 859 if [[ -n "${python2_version}" && "${python_version}" == "2."* && "${python_version}" != "${python2_version}" ]]; then
850 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python2' symlink" 860 eerror "Python wrapper is configured incorrectly or '${EPREFIX}/usr/bin/python2' symlink"
851 eerror "is set incorrectly. Use \`eselect python\` to fix configuration." 861 eerror "is set incorrectly. Use \`eselect python\` to fix configuration."

Legend:
Removed from v.1.150  
changed lines
  Added in v.1.151

  ViewVC Help
Powered by ViewVC 1.1.20